Настройка командной строки

Для настройки командной строки, выполните следующие действия.

  1. Откройте окно Командная строка.
  2. Щелкните левый верхний угол окна и выберите команду Свойства.
  3. Выберите вкладку Общие.
  4. В области Запоминание команд выберите или введите значение 999 в поле Размер буфера, а затем выберите или введите значение 5 в поле Количество буферов.
  5. В области Правка установите флажки Выделение мышью и Быстрая вставка.
  6. Выберите вкладку Расположение.
  7. В области Размер буфера экрана введите или выберите значение 2500 в поле Высота.
  8. Выполните одно из следующих действий по выбору.
    • В области Размер буфера экрана увеличьте значение параметра Ширина.
    • В области Размер окна увеличьте значение параметра Высота.
    • В области Размер окна увеличьте значение параметра Ширина.
    • Снимите флажок Автоматический выбор, а затем в области Положение окна измените значения полей Левый край и Верхний край.
  9. В диалоговом окне Изменение свойств выберите вариант Сохранить свойства для других окон с тем же именем.

Примечания

  • Чтобы открыть окно Свойства: Командная строка с помощью клавиатуры, нажмите клавиши ALT + ПРОБЕЛ + Й.
  • Флажок Выделение мышью позволяет копировать и вставлять данные в окне командной строки. Чтобы скопировать, выделите левой кнопкой мыши текст в окне командной строки и нажмите правую кнопку мыши. Чтобы выполнить вставку в командную строку или текстовый файл, щелкните правой кнопкой мыши.
  • Увеличение размера буфера экрана до 999 позволяет выполнять прокрутку в окне командной строки.
  • Увеличение количества буферов до пяти увеличивает число строк в окне командной строки до 5000.
  • Чтобы включить или выключить завершение имен файлов и папок в компьютере или сеансе пользователя, запустите программу Regedit.exe и задайте следующее значение REG_DWORD:

    HKLM\Software\Microsoft\Command Processor\CompletionChar\REG_DWORD

    Чтобы задать значение REG_DWORD, введите шестнадцатеричное число управляющего символа для определенной функции (например 0×9 — это TAB, а 0×08 — это BACKSPACE). Пользовательские настройки имеют приоритет над настройками компьютера, а параметры командной строки имеют приоритет над параметрами реестра.

    Внимание!

    • Ошибка при изменении реестра может серьезно повредить систему. Перед изменением реестра создайте резервную копию всех важных данных.


Средства командной строки

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z А—Я

Справочник параметров командной строки

Чтобы найти информацию о команде, в алфавитном меню на верху страницы выберите начальную букву команды, а затем выберите имя команды.

В добавление к средствам, устанавливаемым с Windows XP, на компакт-диске Windows XP существует более 40 средств поддержки. Эти средства могут быть использованы для диагностики и устранения неполадок на компьютере.

К некоторым средствам командной строки могут обращаться только пользователи с привилегиями администратора на исходном и или конечном компьютере.

Средства командной строки должны запускаться из командной строки интерпретатора Cmd.exe. Чтобы открыть командную строку, нажмите кнопку Пуск, выберите команду Выполнить и введите cmd затем нажмите кнопку OK.

A

Append

Arp

Assoc

At

Atmadm

Attrib

B

Bootcfg

Batch

C

Cacls

Call

Change

Chcp

Chdir

Chkdsk

Chkntfs

Cipher

Cls

Cmd

Cmstp

Color

Comp

Compact

Convert

Copy

Cprofile

CScript (общие сведения)

D

Date

Defrag

Del

Dir

Diskcomp

Diskcopy

DiskPart

Doskey

Dos

Dos_cmds

Dos_diffs

Dosonly

Driverquery

Devicehigh

Device

E

Echo

Echoconfig

Edit

Endlocal

Eventcreate

Eventquery

Eventtriggers

Evntcmd

Exe2bin

Exit

Expand

F

Fc

Fcbs

Files

Filters

Find

Findstr

Finger

Flattemp

For

Format

Fsutil

Behavior

Dirty

File

Fsinfo

Hardlink

Objectid

Guota

Reparsepoint

Ftp

Ftp (подкоманды)

Ftype

G

Getmac

Goto

Gpresult

Gpupdate

Graftabl

H

Help

Helpctr

Hostname

I

If

Install

Ipconfig

Ipseccmd

Ipxroute

Irftp

L

Label

Loadfix

Loadhigh

Lodctr

Logman

Lpq

Lpr

M

Macfile

Mkdir (md)

Mmc

Mode

More

Mountvol

Move

MS-DOS (команды настройки подсистемы )

Msiexec

Msinfo32

N

Nbtstat

Net (команды сетевых служб)

Net (общие сведения о сетевых службах)

Netsh (команды диагностики)

Netsh (команды для интерфейса IP)

Netsh (команды для маршрутизации)

Netsh (команды для протокола AAAA)

Netsh (команды для протокола DHCP)

Netsh (команды для службы RAS)

Netsh (команды для службы WINS)

Netsh (общие сведения о командах)

Netstat

Nslookup

Nslookup (подкоманды)

Ntbackup

Ntcmdprompt

Ntsd

O

Openfiles

P

Pagefileconfig

Path

Pathping

Pause

Pbadmin

Pentnt

Perfmon

Ping

Popd

Print

Prncnfg

Prndrvr

Prnjobs

Prnmngr

Prnport

Prnqctl

Prompt

Pushd

Q

Query process

Query session

Query termservr

Query user

R

Rasdial

Rcp

Recover

Reg

Regsvr32

Relog

Rem

Rename

Replace

Reset session

Rexec

Rmdir

Route

Rsh

Rsm

Runas

Rundll32

S

SC

Schtasks

Secedit

Set

Setlocal

Setver

Share

Shell

Sfc (программа проверки системных файлов)

Shift

Shutdown

Sort

Stacks

Start

Subst

Switches

Systeminfo

T

Taskkill

Tasklist

Tcmsetup

TCP/IP (службы и программы )

Telnet (команды)

Tftp

Time

Title

Tracerpt

Tracert

Tree

Type

Typeperf

U

Unlodctr

V

Ver

Vol

Vssadmin

W

W32tm

Winnt

Winnt32

WMIC (общие сведения)

X

Xcopy

А—Я

Командная оболочка (общие сведения)

Команды служб терминалов

Команды-фильтры

Операторы перенаправления

Пакетные файлы


Автоматизация задач командной строки

Автоматизация задач, выполняемых с командной строки

Сведения о средствах для автоматизации задач, выполняемых с командной строки.

    Использование пакетных файлов
    Использование сервера сценариев для командной строки (CScript.exe)
    Использование команды Netsh
    Использование средств WMIC


Новые средства командной строки

В следующей таблице перечислены новые средства командной строки Windows XP Professional.

Команда | Свойства
bootcfg | Настраивает, запрашивает или изменяет параметры файла Boot.ini.
defrag | Производит поиск и объединение фрагментированных файлов загрузки, файлов данных и папок на локальных томах.
diskpart | Управляет дисками, разделами и томами.
driverquery | Запрашивает список драйверов и их свойств.
eventcreate | Позволяет администратору создать особое событие в указанном журнале событий.
eventquery | Выводит список событий и их свойств из одного или нескольких журналов событий.
eventtriggers | Отображает и настраивает события триггеров на локальных и удаленных компьютерах.
fsutil | Управляет точками повторной обработки разреженных файлов, отключения или расширения тома.
getmac | Получает MAC-адрес и список сетевых протоколов.
helpctr | Запускает центр справки и поддержки.
ipseccmd | Производит настройку политик IPSec (Internet Protocol Security) в службе каталогов либо в локальном или удаленном реестре. Ipseccmd — это запускаемая с командной строки версия оснастки «Политика безопасности IP» консоли управления Microsoft (MMC).
logman | Управляет и задает расписания для счетчиков производительности и журнала трассировки событий на локальном или удаленных компьютерах.
openfiles | Запрашивает, отображает и/или отключает открытые файлы.
pagefileconfig | Производит отображение и настройку параметров использования виртуальной памяти файлом подкачки.
perfmon | Открывает консоль «Производительность» с настройками системного монитора из файлов настройки версии для Windows NT 4.0.
prncnfg | Производит настройку или отображение сведений о конфигурации принтера.
prndrvr | Добавляет, удаляет и перечисляет драйверы принтера с локального или удаленных серверов печати.
prnjobs | Приостанавливает, возобновляет, отменяет и перечисляет задания печати.
prnmngr | Добавляет, удаляет и перечисляет принтеры или подключения принтеров, а также настраивает и отображает принтер, используемый по умолчанию.
prnport | Создает, удаляет и перечисляет стандартные порты TCP/IP для принтеров, а также отображает и изменяет конфигурацию порта.
prnqctl | Печатает пробную страницу, приостанавливает или возобновляет работу принтера и очищает очередь принтера.
relog | Сохраняет данные счетчиков производительности из файлов журналов в файлы других форматов, такие как текстовый-TSV (разделитель — запятая), текстовый-CSV (разделитель — табуляция), двоичный-BIN или SQL.
sc | Извлекает и настраивает информацию о службах. Проверяет и отлаживает служебные программы.
schtasks | Настраивает выполнение команд и программ через заданные интервалы или в указанное время. Добавляет и удаляет задания из расписания, запускает и останавливает задания по требованию, отображает и изменяет задания в расписании.
shutdown | Выключает и перезагружает локальный или удаленный компьютер.
systeminfo | Запрашивает основные сведения о конфигурации системы.
taskkill | Завершает одно или несколько заданий или процессов.
tasklist | Отображает список приложений, служб и код процесс (PID) для всех заданий, выполняющихся в данный момент на локальном или удаленном компьютере.
tracerpt | Обрабатывает журналы трассировки событий и данные, поступающие в реальном масштабе времени от поставщиков трассировочных данных и позволяет создавать отчеты с анализом данных трассировки и файлы CSV (с разделителем запятой) для создающихся событий.
typeperf | Производит запись данных счетчика производительности в командное окно или в файл журнала поддерживаемого формата.
WMIC | Облегчает использование инструментария WMI и систем, управляемых с его помощью.


Справочник параметров командной строки

Справочник по параметрам командной строки

Можно использовать для ознакомления с средствами командной строки, настройки командной строки, получения сведений о командной оболочке и для автоматизации заданий с помощью пакетных файлов или средств создания сценариев, таких как CScript и WMIC.

    Новые способы выполнения типичных задач.
    Новые средства командной строки.
    Средства командной строки.
    Настройка командной строки.

Вся ответственность за нарушение работоспособности компьютера лежит на Вас
 Перепечатка материалов с обязательной ссылкой на сайт http://reestr.hotmail.ru
Размещать Справочник на сайтах без разрешения запрещается


Командная оболочка

Командная оболочка — это отдельный программный продукт, который обеспечивает прямую связь между пользователем и операционной системой. Текстовый пользовательский интерфейс командной строки предоставляет среду, в которой выполняются приложения и служебные программы с текстовым интерфейсом. В командной оболочке программы выполняются и результат выполнения отображается на экране в виде, сходном с интерпретатором Command.com MS-DOS. Командная оболочка Windows XP использует интерпретатор команд Cmd.exe, который загружает приложения и направляет поток данных между приложениями, для перевода введенной команды в понятный системе вид.

Имеется возможность использовать командную оболочку для создания и редактирования пакетных файлов (также называемых сценариями), что позволит автоматизировать выполнение обычных задач. Например, можно использовать сценарии для автоматизации управления учетными записями пользователей и ежедневной архивацией в нерабочие часы. Также можно использовать сервер сценариев Windows, CScript.exe, для выполнения в командной оболочке сложных сценариев. Выполнение операций с помощью пакетных файлов является более эффективным, чем с помощью интерфейса пользователя. Пакетные файлы принимают все команды, доступные из командной строки. Дополнительные сведения о пакетных файлах и создании сценариев см. в разделе Использование пакетных файлов.

Имеется возможность настроить окно командной строки для облегчения просмотра и для увеличения контроля за выполнением программ. Дополнительные сведения о настройке окна командной строки см. в разделе Настройка командной строки.

Использование синтаксиса команд

Синтаксическая структура выводится в том порядке, в котором следует вводить команду и следующие за ней параметры, если они есть. Следующий пример команды xcopy иллюстрирует разнообразие синтаксических форматов текста.

xcopy источник [результат] [/w] [/p] [/c] [/v] [/q] [/f] [/l] [/g] [/d[:мм-дд-гггг]] [/u] [/i] [/s [/e]] [/t] [/k] [/r] [/h] [{/a|/m}] [/n] [/o] [/x] [/exclude:файл1[+[файл2]][+[файл3]] [{/y|/-y}] [/z]

В следующей таблице показано, как следует интерпретировать различные текстовые форматы.

Использование нескольких команд и символов условной обработки

Можно выполнять несколько команд из одной командной строки или сценария с помощью символов условной обработки. При использовании нескольких команд, содержащих символы условной обработки, выполнение команд, стоящих справа от символа условной обработки, будет проводиться в зависимости от результатов выполнения команды, стоящей слева от символа. Например, требуется, чтобы команда выполнялась, только если предыдущая команда не была выполнена успешно. Или требуется, чтобы команда выполнялась, только если предыдущая команда была выполнена успешно.

Для передачи нескольких команд можно использовать специальные символы, перечисленные в следующей таблице.

Символ | Синтаксис | Определение
& [...] | команда1 & команда2 | Используется для разделения нескольких команд в одной командной строке. В Cmd.exe выполняется первая команда, затем вторая команда.
&& [...] | команда1 && команда2 | Запускает команду, стоящую за символом &&, только если команда, стоящая перед этим символом была выполнена успешно. В Cmd.exe выполняется первая команда. Вторая команда выполняется, только если первая была выполнена успешно.
|| [...] | команда1 || команда2 | Запускает команду, стоящую за символом ||, только если команда, стоящая перед символом || не была выполнена. В Cmd.exe выполняется первая команда. Вторая команда выполняется, только если первая не была выполнена (полученный код ошибки превышает ноль).
( ) [...] | (команда1 & команда2) | Используется для группировки или вложения команд.
; или , | команда1 параметр1;параметр2 | Используется для разделения параметров команды.

Примечания

  • Амперсанд (&), вертикальная черта (|) и скобки ( ) являются специальными символами, которым должен предшествовать управляющий символ (^) или кавычки, если эти символы передаются в качестве аргументов.
  • Если команда завершает операцию успешно, возвращается нулевой (0) код ошибки или не возвращается никакого кода.

Вложенные командные оболочки

Имеется возможность вкладывать командные оболочки в Cmd.exe, открывая новый экземпляр Cmd.exe из командной строки. По умолчанию каждый экземпляр Cmd.exe наследует среду своего родительского приложения Cmd.exe. Вложение экземпляров Cmd.exe позволяет вносить в локальную среду изменения, которые не повлияют на родительское приложение Cmd.exe. Это позволяет сохранять исходную среду Cmd.exe и возвращаться к ней после удаления вложенной командной оболочки. Изменения вложенной командной оболочки не сохраняются.

Чтобы создать вложенную командную оболочку, в командной строке введите:

cmd

Появится сообщение следующего вида:

Microsoft (R) Windows XP (TM)
(C) Copyright 1985-2001 Microsoft Corp.

Чтобы закрыть все вложенные командные оболочки, введите команду exit.

Можно еще уже локализовать изменения в экземпляре Cmd.exe (или в сценарии) с помощью команд setlocal и endlocal. Команда setlocal создает локальную область, а endlocal ее удаляет. Любые изменения, сделанные внутри области, созданной командами setlocal и endlocal, не учитываются; таким образом исходная среда остается без изменений. С помощью этих команд можно создать до 32 вложенных областей. Дополнительные сведения о командах setlocal и endlocal см. в разделах Setlocal и Endlocal.

Использование переменных среды в Cmd.exe

Среда командной оболочки Cmd.exe определяется переменными, задающими поведение командной оболочки и операционной системы. Имеется возможность определить поведение среды командной оболочки или среды всей операционной системы с помощью двух типов переменных среды: системных и локальных. Системные переменные среды определяют поведение глобальной среды операционной системы. Локальные переменные среды определяют поведение среды в данном экземпляре Cmd.exe.

Системные переменные среды заданы заранее в операционной системе и доступны для всех процессов Windows XP. Только пользователи с привилегиями администратора могут изменять эти переменные. Эти переменные наиболее часто используются в сценариях входа в систему.

Локальные переменные среды доступны, только когда пользователь, для которого они были созданы, вошел в систему. Локальные переменные из куста HKEY_CURRENT_USER подходят только для текущего пользователя, но определяют поведение глобальной среды операционной системы.

В следующем списке представлены различные типы переменных в порядке убывания приоритета.

  1. Встроенные системные переменные
  2. Системные переменные куста HKEY_LOCAL_MACHINE
  3. Локальные переменные куста HKEY_CURRENT_USER
  4. Все переменные среды и пути указаны в файле Autoexec.bat.
  5. Все переменные среды и пути указаны в сценарии входа в систему (если он имеется).
  6. Переменные, используемые интерактивно в сценарии или пакетном файле

В командной оболочке каждый экземпляр Cmd.exe наследует среду своего родительского приложения. Поэтому можно изменять переменные в новой среде Cmd.exe, что не повлияет на среду родительского приложения.

В следующей таблице приведен список системных и локальных переменных среды для Windows XP.

Переменная | Тип | Описание
%ALLUSERSPROFILE% | Локальная | Возвращает размещение профиля «All Users».
%APPDATA% | Локальная | Возвращает используемое по умолчанию размещение данных приложений.
%CD% | Локальная | Возвращает путь к текущей папке.
%CMDCMDLINE% | Локальная | Возвращает строку команд, с помощью которой был запущен данный экземпляр Cmd.exe.
%CMDEXTVERSION% | Системная | Возвращает номер версии текущих расширений обработчика команд.
%COMPUTERNAME% | Системная | Возвращает имя компьютера.
%COMSPEC% | Системная | Возвращает путь к исполняемой командной оболочке.
%DATE% | Системная | Возвращает текущие данные. Использует тот же формат, что и команда date /t. Создается командой Cmd.exe. Дополнительные сведения о команде date см. в разделе Date.
%ERRORLEVEL% | Системная | Возвращает код ошибки последней использовавшейся команды. Значение, не равное нуля, обычно указывает на наличие ошибки.
%HOMEDRIVE% | Системная | Возвращает имя диска локальной рабочей станции, связанного с основным каталогом пользователя. Задается на основании расположения основного каталога. Основной каталог пользователя указывается в оснастке «Локальные пользователи и группы».
%HOMEPATH% | Системная | Возвращает полный путь к основному каталогу пользователя. Задается на основании расположения основного каталога. Основной каталог пользователя указывается в оснастке «Локальные пользователи и группы».
%HOMESHARE% | Системная | Возвращает сетевой путь к общему основному каталогу пользователя. Задается на основании расположения основного каталога. Основной каталог пользователя указывается в оснастке «Локальные пользователи и группы».
%LOGONSEVER% | Локальная | Возвращает имя контроллера домена, который проверял подлинность текущей сессии.
%NUMBER_OF_PROCESSORS% | Системная | Задает количество процессоров, установленных на компьютере.
%OS% | Системная | Возвращает имя операционной системы. При использовании Windows 2000 имя операционной системы отображается как Windows_NT.
%PATH% | Системная | Указывает путь поиска для исполняемых файлов.
%PATHEXT% | Системная | Возвращает список расширений файлов, которые рассматриваются операционной системой как исполняемые.
%PROCESSOR_ARCHITECTURE% | Системная | Возвращает архитектуру процессора. Значения: x86, IA64.
%PROCESSOR_IDENTFIER% | Системная | Возвращает описание процессора.
%PROCESSOR_LEVEL% | Системная | Возвращает номер модели процессора, установленного на компьютере.
%PROCESSOR_REVISION% | Системная | Возвращает номер модификации процессора.
%PROMPT% | Локальная | Возвращает параметры командной строки для текущего интерпретатора. Создается командой Cmd.exe.
%RANDOM% | Системная | Возвращает произвольное десятичное число от 0 до 32767. Создается командой Cmd.exe.
%SYSTEMDRIVE% | Системная | Возвращает имя диска, содержащего корневой каталог Windows XP (т. е. системный каталог).
%SYSTEMROOT% | Системная | Возвращает размещение системного каталога Windows XP.
%TEMP% и %TMP% | Системная и пользовательская | Возвращает временные папки, по умолчанию используемые приложениями, которые доступны пользователям, выполнившим вход в систему. Некоторые приложения требуют переменную TEMP, другие — переменную TMP.
%TIME% | Системная | Возвращает текущее время. Использует тот же формат, что и команда time /t. Создается командой Cmd.exe. Дополнительные сведения о команде time см. в разделе Time.
%USERDOMAIN% | Локальная | Возвращает имя домена, содержащего список учетных записей пользователей.
%USERNAME% | Локальная | Возвращает имя пользователя, выполнившего вход в систему.
%USERPROFILE% | Локальная | Возвращает размещение профиля для текущего пользователя.
%WINDIR% | Системная | Возвращает размещение каталога операционной системы.

Установка переменных среды

Используйте команду set для создания, удаления или отображения переменных среды. Команда set изменяет переменные только в среде текущей оболочки.

Чтобы отобразить переменную, в командной строке введите:

set имя_переменной

Чтобы добавить переменную, в командной строке введите:

set variablename=значение

Чтобы удалить переменную, в командной строке введите:

set имя_переменной=

Имеется возможность использовать большинство символов в качестве значений переменных, в том числе пробел. При использовании специальных символов, таких как <, >, &, или ^, перед ними следует помещать управляющий символ (^) или кавычки. При использовании кавычек они включаются в значение переменной, так как все символы, следующие после знака равенства принимаются за значение переменной. Учтите следующие примеры.

  • Чтобы создать значение переменной new&name ,введите:

    set varname=new^&name

  • Чтобы создать значение переменной "new&name" ,введите:

    set varname="new&name"

  • При вводе в командной строке set varname=new&name появляется следующее сообщение об ошибке:
    • "'name' is not recognized as an internal or external command, operable program or batch file."

В именах переменных регистр символов не учитывается. Однако, команда set отображает значение переменной так, как оно было введено. Можно комбинировать символы нижнего и верхнего регистра в именах переменных, чтобы облегчить восприятие кода (например, Имя Пользователя).

Примечания

  • Максимальный размер отдельной переменной среды составляет 8192 байта.
  • Максимальный общий размер всех переменных среды, включая имена переменных и знак равенства, составляет 65 536 Кбайт.

Подстановка значений в переменные среды

Чтобы иметь возможность подставлять значения в переменную среды из командной строки или из сценариев, следует заключить имя соответствующей переменной в символы процентов (%имя_переменной%). Символы процентов указывают на то, что Cmd.exe должен обратиться к значениям переменных, а не делать посимвольное сравнение. После определения значения для имени переменной, заключите имя переменной в символы процентов. Cmd.exe проводит поиск всех вхождений имени переменной и заменяет его на определенное значение переменной. Например, требуется создать сценарий, содержащий различные значения (например, имена пользователей), и требуется определить соответствующее значение переменной среды USERNAME для каждого пользователя. Для этого следует написать сценарий с использованием переменной USERNAME, заключенной в кавычки. При выполнении сценария Cmd.exe заменит вхождения %USERNAME% соответствующими значениями, что избавит от необходимости делать это вручную для каждого пользователя. Подстановка значений не является рекурсивной. Cmd.exe проверяет переменные один раз. Дополнительные сведения о подстановке значений в переменные см. в разделах For и Call.


Ftp

Позволяет передавать файлы с компьютера и на компьютер с помощью программ, поддерживающих протокол FTP (File Transfer Protocol), таких как службы Internet Information Services. Данная команда может использоваться как в интерактивном, так и в пакетном режимах. В последнем случае она позволяет обрабатывать текстовые файлы в формате ASCII.

Синтаксис

ftp [-v] [-d] [-i] [-n] [-g] [-s:имя_файла] [-a] [-w:размер] [-A] [Ведомый компьютер]

Параметры

-v
Запрещает вывод на экран ответа FTP-сервера.
-d
Включает отладочный режим. На экран при этом выводятся все команды, которыми обмениваются клиент и сервер.
-i
Отключает подтверждение при передаче нескольких файлов.
-n
Запрещает автоматический вход в систему в ходе начального подключения.
-g
Отключает глобализацию имени файла. Команда Glob допускает использование звездочки (*) и вопросительного знака (?) в качестве подстановочных знаков при вводе имен локальных файлов и путей. Дополнительные сведения см. в разделе Ftp: Glob.
-s:имя_файла
Указывает текстовый файл с ftp-командами. Эти команды выполняются автоматически после запуска команды ftp. Значение данного параметра не должно содержать пробелов. Данный параметр следует использовать вместо перенаправления (<).
-a
Указывает возможность использования любого локального интерфейса при привязке FTP-соединения.
-w:размер
Задает размер буфера переноса. По умолчанию он равен 4096 байтам.
-A
Обеспечивает анонимный вход на FTP-сервер.
узел
Задает имя компьютера, а также IP-адрес или адрес IPv6 сервера, к которому следует подключиться. Если этот параметр указывается, то он должен быть последним параметром в строке.
/?
Отображает справку в командной строке.

Примечания

  • В качестве префикса для параметров команды ftp следует использовать не косую черту (/), а знак переноса (-).
  • При вводе параметров команды Ftp учитывается регистр.
  • Эта команда доступна, только если в свойствах сетевого адаптера в объекте Сетевые подключения в качестве компонента установлен протокол Интернета (TCP/IP).
  • Команда Ftp может работать в интерактивном режиме. Сразу после ее запуска создается временная среда, поддерживающая ftp-команды. Возврат в командную строку производится с помощью команды quit. Признаком запущенной среды ftp служит командная строка в виде ftp >.
  • FTP поддерживает использование IPv6 (протокола IP версии 6), если он установлен.

Примеры

Чтобы подключиться к FTP-серверу с именем ftp.example.microsoft.com, введите:

ftp ftp.example.microsoft.com

Чтобы подключиться к FTP-серверу с именем ftp.example.microsoft.com как аноним, введите:

ftp -A ftp.example.microsoft.com

Чтобы подключиться к FTP-серверу с именем ftp.example.microsoft.com и выполнить ftp-команды, содержащиеся в файле Resynch.txt, введите:

ftp -s:resynch.txt ftp.example.microsoft.com


Ftp: append

Добавляет файла локального компьютера к файлу на удаленном компьютере с использованием текущих настроек типа файлов.

Синтаксис

append локальный_файл [удаленный_файл]

Параметры

локальный_файл
Задает имя локального файла.
удаленный_файл
Задает имя файла на удаленной системе, к которому добавляется локальный_файл.
? append
Отображение справки для команды append.

Примечания

  • Отсутствие параметра удаленный_файл приводит к тому, что вместо имени удаленного файла используется значение параметра локальный_файл.


Ftp: ascii

Задает тип передаваемых файлов (по умолчанию - файлы в формате ASCII).

Синтаксис

ascii

Параметры

? ascii
Отображение справки для команды ascii.

Примечания

  • По умолчанию тип передаваемых файлов — ASCII.
  • В режиме ASCII выполняются преобразования некоторых символов, в соответствии с особенностями сетевых стандартов. Например, символ конца строки будет преобразован в соответствии с типом операционной системы, в которую передается файл.
  • Протокол Ftp поддерживает два типа файлов: текстовые (ASCII) и двоичные. При передаче текстовых файлов следует использовать режим ASCII.


Ftp: !

Временный выход из подсистемы ftp в окно командной строки для выполнения команд Windows XP. Возврат в подсистему ftp из командной строки производится с помощью команды exit.

Синтаксис

!

Параметры

? !
Отображает справку для команды !.

Примечания

  • Команда ! позволяет выполнять команды Windows XP без завершения работы с подсистемой ftp.


Ftp: bell

Переключает режим выдачи звукового сигнала после передачи каждого файла.

Синтаксис

bell

Параметры

? bell
Отображение справки для команды bell.

Примечания

  • По умолчанию сигнал отключен.


Ftp: binary

Установка режима передачи двоичных файлов.

Синтаксис

binary

Параметры

? binary
Отображение справки для команды binary.

Примечания

  • Протокол Ftp поддерживает два типа файлов: текстовые (ASCII) и двоичные. Исполняемые файлы следует передавать как двоичные. В данном режиме файлы передаются по байту. Чтобы получить дополнительные сведения о передаче файлов в формате ASCII, выберите Ftp: Ascii,


Ftp: bye

Завершает сеанс FTP-подключения к удаленному компьютеру с выходом из программы ftp.

Синтаксис

bye

Параметры

? bye
Отображение справки для команды bye.


Ftp: cd

Сменяет текущий каталог на удаленном компьютере.

Синтаксис

cd удаленный_каталог

Параметры

удаленный_каталог
Задает имя каталога, который будет сделан текущим на удаленном компьютере.
? cd
Отображение справки для команды cd.


Ftp: close

Завершает сеанс FTP-соединения с удаленным сервером с возвратом к командной строке вида ftp>.

Синтаксис

close

Параметры

? close
Отображение справки для команды close.


Ftp: debug

Включает отладочный режим.

Синтаксис

debug

Параметры

? debug
Отображение справки для команды debug.

Примечания

  • По умолчанию отладочный режим отключен.
  • Когда отладочный режим включен, на экран будет выводиться каждая команда, передаваемая удаленному компьютеру. Строки будут начинаться с символа > ("больше").


Ftp: delete

Удаляет файлы на удаленном компьютере.

Синтаксис

delete удаленный файл

Параметры

удаленный_файл
Задает имя файла для удаления.
? delete
Отображение справки для команды delete.


Ftp: dir

Выводит список файлов и подкаталогов в каталоге, расположенном на удаленном компьютере.

Синтаксис

dir [удаленный_каталог] [локальный_файл]

Параметры

удаленный_каталог
Задает каталог, список содержимого которого будет выведен. Если имя каталога не задано, используется текущий рабочий каталог.
локальный_файл
Задает локальный файл для сохранения списка. Если локальный файл не указан, результаты отображаются на экране.
? dir
Отображение справки для команды dir.


Ftp: disconnect

Отсоединение от удаленной системы с сохранением командной строки вида ftp>.

Синтаксис

disconnect

Параметры

? disconnect
Отображение справки для команды disconnect.


Ftp: get

Копирует удаленный файл на локальный компьютер с использованием текущих настроек типов файлов.

Синтаксис

get удаленный_файл [локальный_файл]

Параметры

удаленный_файл
Задает удаленный файл для копирования.
локальный_файл
Задает имя файла на локальном компьютере.
? get
Отображение справки для команды get.

Примечания

  • Если параметр локальный_файл не указан, файлу присваивается имя удаленный_файл.
  • Команда get идентична команде recv.


Ftp: glob

Включает режим использования подстановочных знаков в именах локальных файлов.

Синтаксис

glob

Параметры

? glob
Выводит справку о команде.

Примечания

  • По умолчанию этот режим включен.
  • Данный режим позволяет использовать звездочку (*) или вопросительный знак (?) в качестве подстановочных знаков в именах локальных файлов и путей.


Ftp: hash

Включает режим вывода на печать символа (#) для каждого переданного блока данных.

Синтаксис

hash

Параметры

? hash
Выводит справку о команде.

Примечания

  • Размер блока данных составляет 2048 байт.
  • По умолчанию данный режим отключен.


Ftp: help

Выводит описания подкоманд ftp.

Синтаксис

help [Команда]

? [Команда]

Параметры

Команда
Задает имя команды для получения ее описания. Если команда не указана, выводится список всех команд.


Ftp: lcd

Смена текущего каталога на локальном компьютере. По умолчанию текущим каталогом является каталог, из которого была запущена команда ftp.

Синтаксис

lcd [Каталог]

Параметры

каталог
Задает имя нового текущего каталога на локальном компьютере. Если параметр каталог не задан, на экран будет выведено имя текущего каталога.
? lcd
Выводит справку о команде.
.


Ftp: literal

Отправка аргументов удаленному серверу FTP (без преобразований). Сервер возвращает единственный ответный код FTP.

Синтаксис

literal аргумент [ ...]

Параметры

Аргумент
Задает аргумент для отправки.
? literal
Выводит справку о команде.


Ftp: ls

Вывод сокращенного списка файлов и подкаталогов в удаленном каталоге.

Синтаксис

ls [удаленный_каталог] [локальный_файл]

Параметры

удаленный_каталог
Задает каталог, для которого выводится список содержимого. Если имя каталога не задано, используется текущий рабочий каталог удаленного компьютера.
локальный_файл
Задает локальный файл для сохранения списка. Если локальный файл не указан, результаты отображаются на экране.
? ls
Выводит справку о команде.


Ftp: mdelete

Удаление файлов на удаленном компьютере.

Синтаксис

mdelete удаленные_файлы [ ...]

Параметры

удаленные_файлы
Задает имена файлов, которые будут удалены.
? mdelete
Выводит справку о команде.


Ftp: mdir

Выводит список файлов и подкаталогов в удаленном каталоге.

Синтаксис

mdir удаленные_файлы [ ...] локальный_файл

Параметры

удаленные_файлы
Задает каталог, для которого выводится список содержимого.
локальный_файл
Задает локальный файл для сохранения списка.
? mdir
Выводит справку о команде.

Примечания

  • Команду mdir можно использовать для указания нескольких файлов.
  • Параметр удаленные_файлы

    Введите дефис (-) для использования текущего рабочего каталога на удаленном компьютере.

  • Параметр LocalFile

    Введите дефис (-) для вывода списка на экран.


Ftp: mget

Копирует файлы с удаленного компьютера на локальный с использованием текущих настроек типа файлов.

Синтаксис

mget удаленные_файлы [ ...]

Параметры

удаленные_файлы
Задает файлы, которые будут скопированы.
? mget
Выводит справку о команде.


Ftp: mkdir

Создание каталога на удаленном компьютере.

Синтаксис

mkdir каталог

Параметры

Каталог
Задает имя каталога, который будет создан.
? mkdir
Вывод справки для команды mkdir.


Ftp: mls

Вывод сокращенного списка файлов и подкаталогов в удаленном каталоге.

Синтаксис

mls удаленные_файлы [ ...] локальный_файл

Параметры

удаленные_файлы
Задает файлы, для которых будет выведен список.
локальный_файл
Задает локальный файл для сохранения списка.
? mls
Вывод справки для команды mls.

Примечания

  • Указание удаленных_файлов

    Введите дефис (-) для использования текущего рабочего каталога на удаленном компьютере.

  • Указание локального_файла

    Введите дефис (-) для вывода списка на экран.


Ftp: mput

Копирование файлов на удаленный компьютер с использованием текущей настройки типа передаваемых файлов.

Синтаксис

mput локальные_файлы [ ...]

Параметры

локальные_файлы
Задает имена локальных файлов, которые будут скопированы.
? mput
Вывод справки для команды mput.


Ftp: open

Подключение к заданному FTP-серверу.

Синтаксис

open компьютер [порт]

Параметры

компьютер
Обязательный параметр. Указание удаленного компьютера, к которому выполняется подключение.
порт
Указание номера TCP-порта для работы с FTP-сервером. По умолчанию используется TCP-порт 21.
? open
Вывод справки для команды open.

Примечания

  • Для указания компьютера можно использовать его IP-адрес или имя (в этом случае должны быть доступны сервер DNS или файл Hosts). Если установлен режим автоподключения, ftp пытается автоматически выполнить вход пользователя на FTP-сервер.


Ftp: prompt

Включение и отключение интерактивного режима.

Синтаксис

prompt

Параметры

? prompt
Вывод справки для команды prompt.

Примечания

  • По умолчанию интерактивный режим включен.
  • При обработке нескольких файлов команда ftp может запрашивать подтверждение на каждый файл, что позволяет выборочно извлекать или хранить файлы. Если интерактивный режим отключен, команды mget и mput передают все файлы.


Ftp: put

Копирование локального файла на удаленный компьютер с использованием текущей настройки типа передаваемого файла.

Синтаксис

put локальный_файл [удаленный_файл]

Параметры

локальный_файл
Задает имя локального файла для копирования.
удаленный_файл
Задает имя файла на удаленном компьютере.
? put
Вывод справки для команды put.

Примечания

  • Если локальный_файл не указан, файлу присваивается имя удаленный_файл.


Ftp: pwd

Печать имени текущего каталога на удаленном компьютере.

Синтаксис

pwd

Параметры

? pwd
Вывод справки для команды pwd.


Ftp: quit

Окончание сеанс FTP с выходом из программы ftp в командную строку.

Синтаксис

quit

Параметры

? quit
Вывод справки для команды quit.


Ftp: quote

Отправка аргументов удаленному серверу FTP (без преобразований). Возвращается единственный ответный код FTP.

Синтаксис

quote аргумент [ ...]

Параметры

аргумент
Задает аргумент для отправки на FTP-сервер.
? quote
Вывод справки для команды quote.

Примечания

  • Команда quote эквивалентна команде literal.


Ftp: recv

Копирование удаленного файла на локальный компьютер с использованием текущих настроек типов файлов.

Синтаксис

recv удаленный_файл [локальный_файл]

Параметры

удаленный_файл
Задает удаленный файл для копирования.
локальный_файл
Задает имя файла на локальном компьютере.
? recv
Вывод справки для команды recv.

Примечания

  • Команда recv эквивалентна команде get.
  • Если локальный_файл не указан, файлу присваивается имя удаленного_файла.


Ftp: remotehelp

Вывод справки о командах удаленной системы.

Синтаксис

remotehelp [команда]

Параметры

команда
Задает имя команды для получения справки. Если команда не указана, ftp выводит список всех команд удаленной системы.
? remotehelp
Вывод справки для команды remotehelp.


Ftp: rename

Переименование удаленных файлов.

Синтаксис

rename имя_файла новое_имя_файла

Параметры

имя_файла
Задает имя файла для переименования.
новое_имя_файла
Задает новое имя файла.
? rename
Вывод справки для команды rename.


Ftp: rmdir

Удаление каталога на удаленной системе.

Синтаксис

rmdir каталог

Параметры

каталог
Задает имя каталога для удаления.
? rmdir
Вывод справки для команды rmdir.


Ftp: send

Копирование локального файла на удаленный компьютер с использованием текущей настройки типа передаваемого файла.

Синтаксис

send локальный_файл [удаленный_файл]

Параметры

локальный_файл
Задает имя локального файла для копирования.
удаленный_файл
Задает имя файла на удаленном компьютере.
? send
Вывод справки для команды send.

Примечания

  • Команда send эквивалентна команде put.
  • Если локальный_файл не указан, файлу присваивается имя удаленный_файл.


Ftp: status

Отображение текущего состояние FTP-подключений.

Синтаксис

status

Параметры

? status
Вывод справки для команды status.


Ftp: trace

Переключение трассировки пакетов.

Синтаксис

trace

Параметры

? trace
Вывод справки для команды trace.

Примечания

  • Команда trace выводит набор внутренних вызовов FTP при выполнении команд ftp.


Ftp: type

Установка или вывод настройки текущего типа передаваемых файлов.

Синтаксис

type [имя_типа]

Параметры

имя_типа
Задает тип передачи файла.
? type
Вывод справки для команды type.

Примечания

  • Если имя_типа не указано, будет выведен текущий тип передаваемых файлов.
  • Ftp поддерживает два типа передачи файлов: ASCII и двоичный.

    По умолчанию используется тип передачи файлов ASCII. Команда ascii должна использоваться при передаче текстовых файлов. В режиме ASCII выполняются преобразования некоторых символов, в соответствии с особенностями сетевых стандартов. Например, символ конца строки будет преобразован в соответствии с типом операционной системы, в которую передается файл.

    Команда binary должна использоваться при передаче исполняемых файлов. В этом режиме файлы передаются единицами размером в один байт.


Ftp: user

Указание имени пользователя для удаленного компьютера

Синтаксис

user имя_пользователя [пароль] [учетная_запись]

Параметры

имя_пользователя
Задает имя пользователя для подключения к удаленному компьютеру.
пароль
Задает пароль для указанного имени_пользователя. Если пароль не указан, но его ввод является обязательным, команда ftp запросит ее у пользователя.
учетная запись
Задает учетную запись, которая будет использована при подключении к удаленному компьютеру. Если учетная_запись не указана, но ввод учетной записи требуется для подключения, команда ftp запросит ее у пользователя.
? user
Вывод справки для команды user.


Ftp: verbose

Переключение режима verbose.

Синтаксис

verbose

v

Параметры

? verbose
Вывод справки для команды verbose.

Примечания

  • По умолчанию режим verbose включен. Если режим verbose включен, отображаются все отклики ftp. Когда передача файла завершена, выводится также статистика, связанная со скоростью передачи.


Подкоманды команды Ftp

Для получения дополнительных сведений щелкните команду.

  • Ftp: !
  • Ftp: ?
  • Ftp: append
  • Ftp: ascii
  • Ftp: bell
  • Ftp: binary
  • Ftp: Bye
  • Ftp: cd
  • Ftp: close
  • Ftp: debug
  • Ftp: delete
  • Ftp: dir
  • Ftp: disconnect
  • Ftp: get
  • Ftp: glob
  • Ftp: hash
  • Ftp: help
  • Ftp: lcd
  • Ftp: literal
  • Ftp: ls
  • Ftp: mdelete
  • Ftp: mdir
  • Ftp: mget
  • Ftp: mkdir
  • Ftp: mls
  • Ftp: mput
  • Ftp: open
  • Ftp: prompt
  • Ftp: put
  • Ftp: pwd
  • Ftp: quit
  • Ftp: quote
  • Ftp: recv
  • Ftp: remotehelp
  • Ftp: rename
  • Ftp: rmdir
  • Ftp: send
  • Ftp: status
  • Ftp: trace
  • Ftp: type
  • Ftp: user
  • Ftp: verbose


Change logon

Включает или отключает вход сеансов или отображает текущее состояние входа. Эта служебная программа используется для настройки системы.

Синтаксис

change logon {/enable|/disable|/query}

Параметры

/enable
Включает вход пользователя из сеанса, а не из консоли.
/disable
Отключает вход пользователя из сеанса, а не из консоли. Не влияет на вход текущего пользователя.
/query
Отображает текущий режим входа сеанса.
/?
Отображает справку в командной строке.

Примечания

  • Команду change logon может использовать только администратор.
  • При перезагрузке системы параметры входов сеансов включаются заново. Если происходит подключение к серверу терминалов из сеанса клиента с отключенными параметрами входа, то при выходе из системы до включения заново параметров входа будет невозможно снова подключиться к этому сеансу. Для включения параметров входа из сеансов клиента войдите в консоль.


Change port

Отображает и изменяет сопоставления COM-портов для совместимости MS-DOS приложений.

Синтаксис

change port [{порт_х=порт_у|/d порт_х|/query}]

Параметры

порт_х=порт_у
Сопоставляет порт x и порт y.
/d порт_х
Удаляет сопоставление для порта x.
/query
Отображает текущее сопоставление портов.
/?
Отображает справку в командной строке.

Примечания

  • Большинство приложений MS-DOS поддерживают только последовательные порты с COM1 до COM4. Команда change port, сопоставляющая различные номера последовательных портов, позволяет приложениям, не работающим с COM-портами с высокими номерами, получить доступ к последовательным портам. Например, для сопоставления COM12-порта COM1-порту для использования в приложениях MS-DOS введите команду change port com12=com1. Сопоставление действительно только для текущего сеанса. Оно не сохраняется при выходе и новом подключении к старому сеансу.
  • Для отображения доступных последовательных портов и их текущего сопоставления используйте команду change port без параметров.


Change user

Изменяет параметры сопоставления файлов .ini.

Синтаксис

change user {/execute | /install | /query}

Параметры

/execute
Разрешает выполнение сопоставления файлов .ini в основном каталоге. Это устанавливается по умолчанию.
/install
Запрещает выполнение сопоставления файлов .ini в основном каталоге. Все файлы .ini читаются и записываются в системный каталог. При установке приложений на сервер терминалов необходимо запретить сопоставление файлов .ini.
/query
Отображает текущие параметры сопоставления файлов .ini.
/?
Отображает справку в командной строке.

Примечания

  • Для создания файлов .ini приложений в системном каталоге используйте команду change user /install до начала процесса установки приложений. Эти файлы являются основными копиями для пользовательских файлов .ini. Для возвращения к стандартному сопоставлению файлов .ini используйте команду change user /execute.
  • При первом запуске приложения оно ищет основной каталог для нахождения своих файлов .ini. Если файлы .ini не найдены в основном каталоге, но найдены в системном каталоге, то службы терминалов копируют их в основной каталог и убеждаются в том, что у каждого пользователя есть своя копия файлов .ini приложения. Новые файлы .ini создаются в основном каталоге.
  • Каждый пользователь должен иметь собственную копию этих файлов для приложения. Это должно предотвратить ситуации, когда различные пользователи имеют несовместимые конфигурации приложений, например, различное положение каталогов или различные разрешения экрана.
  • При нахождении системы в режиме установки (change user /install) выполняются следующие операции. Все записи реестра, созданные в HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\TerminalServer\Install, становятся недоступными. Разделы, добавленные в папку HKEY_CURRENT_USER, копируются в раздел \SOFTWARE, а разделы, добавленные в папку HKEY_LOCAL_MACHINE, копируются в раздел \MACHINE. Если приложение запрашивает папку Windows, используя системный вызов, например GetWindowsDirectory, то сервер терминалов отправляет его в системный_корневой_каталог. Любые записи файла .ini, добавленные с использованием системного вызова, например WritePrivateProfileString, добавляются в файлы .ini, расположенные в системном_корневом_каталоге.
  • При возвращении системы в режим выполнения (change user /execute) и при попытке приложения прочитать записи реестра в папке HKEY_CURRENT_USER, которые не существуют, службы терминалов проверяют, существует ли копия раздела в папке \TerminalServer\Install. Если она существует, то разделы копируются в необходимое расположение в папке HKEY_CURRENT_USER. Если приложение пытается прочитать несуществующий файл .ini, то службы терминалов ищут этот файл в корневой папке системы. Если файл .ini находится в корневой папке системы, то он копируется в подкаталог \Windows основного каталога пользователя. Если приложение обращается к каталогу Windows, то сервер терминалов перенаправляет запрос в подкаталог \Windows основного каталога пользователя.
  • При входе пользователя службы терминалов проверяют, являются ли ее системные файлы .ini более новыми, чем файлы на пользовательском компьютере. Если это так, то пользовательские файлы .ini будут заменены их новой версией. Это зависит от того, установлен или нет бит INISYNC, 0x40, для этих файлов .ini. Предыдущая версия файла .ini будет переименована в Inifile.ctx. Если значение реестра в разделе \TerminalServer\Install создано позже того, что расположено в папке HKEY_CURRENT_USER, то старая версия удаляется и заменяется новой из раздела \TerminalServer\Install.


Cprofile

Освобождение неиспользуемого места в указанных профилях и удаление из реестра отключенных пользовательских сопоставлений для расширений имен файла. Текущий профиль не изменяется.

Синтаксис

cprofile [/l] [/i] [/v] [список_файлов]

cprofile [/i] [/v] список_файлов

Параметры

/l
Очистка всех локальных профилей. Можно также задать список дополнительных профилей в параметре Список_файлов.
/i
Интерактивные запросы у пользователя о каждом профиле.
/v
Отображает сведения о выполненных действиях.
список_файлов
Список файлов, которые необходимо удалить из пользовательского сопоставления для расширений имен файлов. Каждый файл в списке должен быть отделен пробелом. Имена файлов должны содержать символы подстановки.
/?
Отображение справки в командной строке.

Примечания

  • Команду cprofile может выполнить только администратор.
  • Сервер терминалов использует сопоставление расширений файлов для определения приложения, используемого для доступа к файлам различных типов. Типы файлов регистрируются в проводнике.
  • Сопоставление файлов для каждого пользователя позволяет им назначать различные приложения для заданных типов файлов. Например, один пользователь использует для файлов .doc приложение Microsoft Word, а другой — приложение Windows WordPad.
  • Если сопоставление включено, то команда cprofile используется только для освобождения неиспользуемого места в указанных профилях. Если сопоставление отключено, то команда cprofile также удаляет из реестра указанные записи.


Flattemp

Включает или отключает плоские временные папки.

Синтаксис

flattemp {/query | /enable | /disable}

Параметры

/query
Запрашивает текущее состояние.
/enable
Включает плоские временные папки.
/disable
Отключает плоские временные папки.
/?
Отображение справки в командной строке.

Примечания

  • Если каждый пользователь имеет отдельную временную папку, то для разрешения ее использования введите команду flattemp /enable.
  • Способом по умолчанию для создания временных папок для нескольких пользователей (обычно указываемых переменными среды TEMP и TMP) является создание подпапок в каталоге \Temp с помощью кода_входа каждого пользователя в качестве имени подпапки. Например, если переменная среды TEMP указывает в качестве временного каталога C:\Temp, то пользователю с кода_входа 4 будет назначена подпапка C:\Temp\4. Используя команду flattemp, можно непосредственно указать папку \Temp и запретить использование подпапок. Это полезно, если необходимо, чтобы временные папки пользователей хранились в основных каталогах либо на локальном диске сервера терминалов, либо на общем сетевом диске. Эту команду нужно использовать только в случае, если каждый пользователь имеет различную временную папку.
  • Для выполнения команды flattemp необходимо иметь административные привилегии.
  • Если временная папка находится на общем сетевом диске, то возможно появление ошибок приложения. Они могут появиться, если общий сетевой диск станет на минуту недоступным. Поскольку временные файлы приложения будут либо недоступны, либо не синхронизированы, то это вызовет сообщение о том, что диск недоступен. Не рекомендуется помещать временную папку на сетевой диск. По умолчанию установлено расположение временной папки на локальном жестком диске. Если поведение диска непредсказуемо или при запуске определенных приложений появляются сообщения о повреждении диска, то стабилизируйте работу с сетью или переместите временную папку назад на локальный жесткий диск.
  • Если запрещено использование различных временных папок для каждого сеанса, то команда flattemp не выполняется. Этот параметр можно установить в настройке служб терминалов.


Logoff

Выход пользователя из сеанса и удаление сеанса с сервера.

Синтаксис

logoff [{код_сеанса|имя_сеанса}] [/server:имя_сервера] [/v]

Параметры

код_сеанса
Отображает числовое значение кода (ID), которое определяет сеанс на сервере.
имя_сеанса
Отображает имя сеанса.
/server имя_сервера
Указывает сервер терминалов, содержащий завершаемый пользовательский сеанс. Если сервер терминалов не задан, то по умолчанию выбирается текущий.
/v
Отображает сведения о выполненных действиях.
/?
Отображение справки в командной строке.

Примечания

  • Пользователь всегда может выйти из сеанса, в который он вошел. Однако, для того чтобы отключить пользователей от других сеансов, необходимо иметь разрешения на «Полный доступ».
  • Необходимо знать, что выход пользователя из системы и завершение сеанса без предупреждения может привести к потере данных сеанса. Чтобы предупредить пользователя о завершении его сеанса, необходимо отправить ему сообщение, используя команду msg.
  • Если не заданы ни код сеанса, ни его имя, то использование команды logoff приведет к выходу из текущего сеанса. Если задано имя сеанса, то он должен быть активным.
  • При выходе пользователя из системы все процессы завершаются и сеанс удаляется с сервера.
  • Выход пользователя из системы из сеанса консоли невозможен.

Примеры

Чтобы выйти из текущего сеанса, введите:

logoff

Чтобы выйти из сеанса с кодом ID 12, введите:

logoff 12

Чтобы выйти из сеанса с использованием имени сеанса и сервера, например сеанс TERM04 на сервере WF12, введите:

logoff TERM04 /server:WF12


Msg

Отправка сообщения пользователю.

Синтаксис

msg {имя_пользователя|имя_сеанса|код_сеанса|@имя_файла|*} [/server:имя_сервера] [/time:секунды] [/v] [/w] [сообщение]

Параметры

имя_пользователя
Задает имя пользователя, получающего сообщение.
имя_сеанса
Задает имя сеанса, получающего сообщение.
код_сеанса
Идентифицирует сеанс, пользователь которого получит сообщение.
@имя_файла
Идентифицирует файл, содержащий список имен пользователей, имен сеансов, коды сеансов, которые получат сообщение.
*
Отправляет сообщение всем пользователям в системе.
/server:имя_сервера
Задает сервер терминалов, сеансы или пользователи которого получат сообщение. Если сервер не указан, параметр /server использует текущий сервер.
/time:секунды
Задает время, в течение которого отправленное сообщение будет отображаться на экране пользователя. При завершении этого времени, сообщение пропадает с экрана. Если ограничение времени не задано, то сообщение будет находиться на экране пользователя до тех пор, пока он не нажмет кнопку OK.
/v
Отображает сведения о выполненных действиях.
/w
Устанавливает режим ожидания ответа от пользователя, получившего сообщение. Этот параметр рекомендуется использовать совместно с параметром /time:секунды, чтобы избежать длительной паузы в случае, если пользователь не может ответить немедленно. Можно также использовать этот параметр совместно с параметром /v.
сообщение
Вводится текст отправляемого сообщения. Если текст сообщения не введен, то система либо попросит сделать это, либо будет использовано стандартное сообщение (STDIN). Чтобы отправить сообщение, содержащее файл, введите символ (>) вслед за именем файла.
/?
Отображает справку в командной строке.

Примечания

  • Если не задано имя пользователя или сеанса, то команда msg выводит на экран сообщение об ошибке. Если задано имя сеанса, то он должен быть активным.
  • Для отправки сообщения пользователь должен иметь специальное разрешение.

Примеры

Чтобы отправить сообщение с заголовком Встречаемся сегодня в 13-00 всем сеансам для пользователя MIKES, введите:

msg MIKES Встречаемся сегодня в 13-00

Чтобы отправить тоже самое сообщение сеансу MODEM02, введите:

msg modem02 Встречаемся сегодня в 13-00

Чтобы отправить сообщение сеансу с кодом 12, введите:

msg 12 Встречаемся сегодня в 13-00

Чтобы отправить сообщение всем сеансам, содержащимся в файле USERLIST, введите:

msg @userlist Встречаемся сегодня в 13-00

Чтобы отправить сообщение всем вошедшим пользователям, введите:

msg * Встречаемся сегодня в 13-00

Чтобы отправить сообщение всем пользователям, установив режим ожидания ответа (например 10 секунд), введите:

msg */TIME:10 Встречаемся сегодня в 13-00


Mstsc

Создание подключений к серверам терминалов или другим удаленным компьютерам, редактирование существующего файла конфигурации подключения к удаленному рабочему столу (.rdp) и перенос подключений Wndows XP (подключения, созданные с помощью диспетчера клиентских подключений) в новые файлы .rdp

Синтаксис

mstsc.exe {файл_подключения|/v:сервер} [/console] [/f] [/w:ширина /h:высота]

mstsc.exe /edit"файл_подключения"

mstsc.exe /migrate

Параметры

файл_подключения
Задает имя файла .rdp для подключения.
/v:сервер
Задает имя удаленного компьютера, к которому необходимо подключиться.
/console
Подключается к сеансу консоли указанного компьютера под управлением Windows 2000 Server.
/f
Запускает подключение удаленного рабочего стола в полноэкранном режиме.
/w:ширина /h:высота
Указывает размеры экрана удаленного рабочего стола.
/edit
Открывает указанный файл .rdp для редактирования.
/migrate
Переносит устаревшие файлы подключений, созданные диспетчером клиентских подключений, в новые файлы .rdp.

Примечания

  • Для создания подключения к удаленной консоли необходимо быть администратором на сервере, к которому происходит подключение.
  • Для каждого пользователя файлы .rdp хранятся в папке «Мои документы» как скрытые.


Query process

Отображает сведения о процессах, запущенных на сервере терминалов. Эту команду можно использовать для нахождения программ, запущенных выбранным пользователем, а также для нахождения пользователей, запустивших данную программу.

Синтаксис

  • query process [{ *|код_процесса|имя_пользователя|имя_сеанса|/id:nn|имя_программы}] [/server:имя_сервера] [/system]

    Параметры

    *
    Отображает список процессов для всех сеансов.
    код_процесса
    Указывает процесс, заданный этим цифровым кодом.
    имя_пользователя
    Указывает имя пользователя, процессы которого нужно отобразить в списке.
    имя_сеанса
    Указывает имя сеанса, процессы которого нужно отобразить в списке.
    /id:nn
    Указывает код сеанса, процессы которого нужно отобразить в списке.
    имя_программы
    Указывает имя программы, процессы которой запрашиваются. Для этого необходимо иметь расширение .exe.
    /server:имя_сервера
    Определяет процессы на вибранном сервере терминалов. Если сервер терминалов не задан, то по умолчанию выбирается текущий.
    /system
    Отображает текущие сведения о системных процессах. Если нет необходимости в отображении сведений о системных процессах, то этот параметр не используется.
    /?
    Отображает справку в командной строке.

    Примечания

    • Для выполнения команды query process администратор должен иметь разрешение на «Полный доступ».
    • Если не задать ни один из параметров имя_пользователя, имя_сеанса, /id:код_сеанса, имя_программы, *, то команда query process отображает только процессы, принадлежащие текущему пользователю.
    • Если задан сеанс, то он должен быть активным. Для задания процесса можно использовать подстановочные символы.
    • С помощью команды query process можно получить следующие сведения:
      • сведения о пользователе, который владеет процессом;
      • сведения о сеансе, который владеет процессом;
      • сведения о коде сеанса;
      • сведения об имени процесса;
      • сведения о состоянии процесса;
      • сведения о коде процесса.
    • При отображении сведений командой query process выводится символ (>) перед каждым процессом, принадлежащим текущему пользователю.


Query termserver

Отображает список всех серверов терминалов в сети.

Синтаксис

query termserver [имя_сервера] [/domain:домен] [/address] [/continue]

Параметры

имя_сервера
Задает имя сервера терминалов.
/domain:домен
Задает домен для запроса серверов терминалов. Если запрашивается домен, в котором пользователь работает в данный момент, то нет необходимости задавать его дополнительно.
/адрес
Отображает адреса сети и узлов для каждого сервера.
/continue
Запрещает остановку после отображения каждого экрана со сведениями.
/?
Отображает справку в командной строке.

Примечания

  • Команда query termserver ищет в сети все серверы терминалов и сообщает о них следующие сведения:
    • имя сервера;
    • сеть (и адрес узла, если используется параметр /address).

Примеры

Чтобы отобразить сведения о всех серверах терминалов в сети, введите:

query termserver

Чтобы отобразить сведения о сервере терминалов с именем server3, введите:

query termserver server3

Чтобы отобразить сведения о всех серверах терминалов в домене SYSTEM, введите:

query termserver /domain:system

Чтобы отобразить адреса сети и узла для сервера терминалов с именем server3, введите:

query termserver server3 /address


Query session

Отображает сведения о сеансах на сервере терминалов. Этот список включает не только сведения об активных сеансах, но и о других сеансах, запущенных на сервере.

Синтаксис

query session [{имя_сеанса|имя_пользователя|код_сеанса}] [/server:имя_сервера] [/mode] [/flow] [/connect] [/counter]

Параметры

имя_сеанса
Отображает имя запрашиваемого сеанса.
имя_пользователя
Отображает имя пользователя, сеанс которого необходимо запросить.
код_сеанса
Отображает код запрашиваемого сеанса.
/server:имя_сервера
Задает сервер терминалов для запроса. По умолчанию — это текущий сервер.
/mode
Отображает текущие параметры линии.
/flow
Отображает текущие параметры управления потоком.
/connect
Отображает текущие параметры подключения.
/counter
Отображает текущие сведения о счетчиках, включая общее число созданных сеансов, отключений и подключений заново.
/?
Отображает справку в командной строке.

Примечания

  • Пользователь всегда может запросить сеанс, к которому он подключен. Чтобы запросить другие сеансы, пользователь должен иметь разрешение на запрос сведений.
  • Если сеанс не задан с помощью параметров имя_сеанса, имя_пользоателя, код_сеанса или query session, то отображаются сведения о всех активных сеансах в системе.
  • При отображении сведений командой query process символ (>) выводится перед текущим сеансом.

Примеры

Чтобы отобразить сведения о всех активных сеансах на сервере SERVER2, введите:

query session /server:SERVER2

Чтобы отобразить сведения об активном сеансе MODEM02, введите:

query session MODEM02

После выполнения команды query session на экран будут выведены следующие сведения:

C:\>query session
 СЕАНС   ПОЛЬЗОВАТЕЛЬ       ID СТАТУС  ТИП   УСТРОЙСТВО
>console        administrator   0 active wdcon
 rdp-tcp#1      client1         1 active wdtshare
 rdp-tcp                        2 listen wdtshare
                                4 idle
                                5 idle

Символом (>) отмечен текущий сеанс. В столбце СЕАНС выводится имя, назначенное сеансу. В столбце ПОЛЬЗОВАТЕЛЬ отображается имя пользователя, подключенного к сеансу. В столбце СТАТУС отображаются сведения о текущем состоянии сеанса. В столбце ТИП отображаются сведения о типе сеанса. В столбце УСТРОЙСТВО, который не отображается для сеансов консоли или сетевых сеансов, собраны сведения об именах устройств, назначенные сеансу. Комментарии, следующие за сведениями о сеансе, появляются из профиля сеанса.

Любые сеансы, исходное состояние которых настроено как «Отключено», не отображаются в списке запроса сеансов, до своего разрешения.


Query user

Отображает сведения о пользовательских сеансах на сервере терминалов.

Синтаксис

query user [{имя_пользователя|имя_сеанса|код_сеанса}] [/server:имя_сервера]

Параметры

имя_пользователя
Задает запрашиваемое имя пользователя для входа.
имя_сеанса
Отображает имя запрашиваемого сеанса.
код_сеанса
Отображает код запрашиваемого сеанса.
/server:имя_сервера
Отображает запрашиваемый сервер терминалов. В противном случае используется текущий сервер терминалов.
/?
Отображает справку в командной строке.

Примечания

  • Эта команда может использоваться для выяснения того, вошел ли определенный пользователь на заданный сервер терминалов. С помощью команды query user можно получить следующие сведения:
    • имя пользователя;
    • имя сеанса на сервере терминалов;
    • код сеанса;
    • состояние сеанса (активно или отключено);
    • время простоя сеанса (количество минут, прошедшее с последнего нажатия клавиши клавиатуры или движения указателя мыши);
    • дату и время входа пользователя.
  • Для использования команды query user необходимо иметь разрешение «Полный доступ» или специальное разрешение на запрос информации.
  • При использовании команды query user без задания имени пользователя, имени сеанса или кода сеанса на экран выводится список всех пользователей, которые вошли на сервер. Кроме того, можно использовать команду query session для отображения списка всех сеансов на сервере.
  • При отображении сведений командой query user символ (>) выводится перед текущим сеансом.
  • Параметр /server необходимо использовать только при вводе команды query user с удаленного сервера.

Примеры

Чтобы отобразить сведения о всех пользователях, которые вошли в систему, введите:

query user

Чтобы отобразить сведения о пользователе USER1 на сервере SERVER1, введите:

query user USER1 /server:SERVER1


Register

Регистрация программы для придания ей особых характеристик выполнения.

Синтаксис

register имя_файла [{/system|/user}] [/v]

Параметры

имя_файла
Указывает имя файла, который следует зарегистрировать.
/system
Регистрирует файл как глобальный системный ресурс.
/user
Регистрирует файл как глобальный пользовательский ресурс.
/v
Отображает дополнительные сведения.
/?
Отображает справку в командной строке.

Примечания

  • Команду register может выполнить только администратор.
  • Некоторые сложные приложения и подсистемы необходимо выполнить глобально для создания ресурсов, которые будут использоваться для нескольких входов в систему.
  • Данные регистрации программы необходимы только при ее установке. Если команда register будет выполнена для установленной программы, то изменения вступят в силу только при последующей установке программ.


Reset session

Позволяет сбросить (удалить) сеансы с сервера терминалов.

Синтаксис

reset session {имя_сеанса|код_сеанса} [/server:имя_сервера] [/v]

Параметры

имя_сеанса
Отображает имя сбрасываемого сеанса. Для определения имени сеанса используйте команду query session.
код_сеанса
Отображает код сбрасываемого сеанса.
/server:имя_сервера
Определяет сервер терминалов, содержащий сбрасываемый сеанс. В противном случае используется текущий сервер терминалов.
/v
Отображает сведения о выполненных действиях.
/?
Отображает справку в командной строке.

Примечания

  • Всегда можно сбросить собственный сеанс, но для сброса сеанса других пользователей необходимо иметь разрешение «Полный доступ».
  • Необходимо знать, что сброс пользовательского сеанса без предупреждения может привести к потере данных этого сеанса.
  • Сбросить сеанс необходимо только в случае неисправности или при отсутствии ответа.
  • Параметр /server необходимо использовать только при вводе команды query session с удаленного сервера.


Shadow

Позволяет удаленно управлять активными сеансами другого пользователя.

Синтаксис

shadow {имя_сеанса | код_сеанса} [/server:имя_сервера] [/v]

Параметры

имя_сеанса
Отображает имя удаленно управляемого сеанса.
код_сеанса
Отображает код удаленно управляемого сеанса. Для отображения списка сеансов и их кодов используйте команду query user.
/server:имя_сервера
Определяет сервер терминалов, содержащий удаленно управляемый сеанс. По умолчанию используется текущий сервер терминалов.
/v
Отображает сведения о выполненных действиях.
/?
Отображает справку в командной строке.

Примечания

  • Можно либо просматривать, либо активно управлять сеансом. При выборе активного управления пользовательским сеансом, можно выполнять различные действия в этом сеансе с помощью клавиатуры и мыши.
  • Удаленно управлять своим сеансом можно всегда (кроме того случая, если это — текущий сеанс), а для удаленного управления другим сеансом необходимо иметь разрешение на «Полный доступ».
  • Можно также установить удаленное управление с помощью диспетчера служб терминалов.
  • До начала наблюдения сервер предупреждает пользователя о том, что его сеанс будет удаленно управляться, даже если вывод этого предупреждения отключен. Сеанс будет находиться в неопределенном состоянии несколько секунд, пока он будет ждать ответа от пользователя. Для настройки удаленного управления для пользователей или сеансов используйте расширения «Настройка служб терминалов» или «Службы терминалов — расширение» оснасток «Локальные пользователи и группы» и «Пользователи и компьютеры Active Directory».
  • Сеанс должен поддерживать разрешение экрана, которое используется для того сеанса, которым пользователь удаленно управляет, в противном случае произойдет сбой.
  • Сеанс консоли не может ни удаленно управлять, ни управляться другим сеансом.
  • Для завершения сеанса удаленного управления нажмите клавиши CTRL+* (используйте символ *, расположенный на цифровой клавиатуре) или те клавиши, которые были заданы в поле «Сочетание клавиш». Сочетание клавиш можно задать при помощи диспетчера служб терминалов.

Примеры

Для наблюдения за сеансом 93 введите:

shadow 93

Для наблюдения за сеансом ACCTG01 введите:

shadow ACCTG01


Tscon

Подключает к другому сеансу.

Синтаксис

tscon {код_сеанса | имя_сеанса} [/dest:имя_сеанса] [/password:пароль] [/v]

Параметры

код_сеанса
Отображает код подключаемого сеанса. Если используется необязательный параметр /dest:имя_сеанса, то он отображает код подключаемого сеанса.
имя_сеанса
Отображает имя подключаемого сеанса.
/dest:имя_сеанса
Определяет имя текущего сеанса. При подключении к новому сеансу этот сеанс будет отключен.
/password:пароль
Пароль владельца подключаемого сеанса. Этот пароль необходим при подключении пользователя, который не является владельцем сеанса.
/v
Отображает сведения о выполненных действиях.
/?
Отображает справку в командной строке.

Примечания

  • Для подключения к другому сеансу необходимо иметь разрешение на «Полный доступ» или разрешение на специальное подключение.
  • Параметр /dest:имя_сеанса позволяет подключить сеанс другого пользователя к чужому сеансу.
  • Если пароль не задан в параметре пароль и конечный сеанс не принадлежит текущему пользователю, то подключение с помощью команды tscon невозможно.
  • Невозможно подключиться к сеансу консоли.

Примеры

Чтобы подключиться к сеансу с кодом 12 на сервере терминалов и отключиться от текущего сеанса, введите:

tscon 12

Чтобы подключиться к сеансу с кодом 23 на сервере терминалов, используя пароль mypass, введите:

tscon 23 /password:mypass

Чтобы подключить сеанс с именем TERM03 к сеансу с именем TERM05, а затем отключить сеанс TERM05, если он подключен, введите:

tscon TERM03 /v /dest:TERM05


Tsdiscon

Отключает сеанс от сервера терминалов.

Синтаксис

tsdiscon [{код_сеанса | имя_сеанса}] [/server:имя_сервера] [/v]

Параметры

код_сеанса
Отображает код отключаемого сеанса.
имя_сеанса
Отображает имя отключаемого сеанса.
/server:имя_сервера
Определяет сервер терминалов, содержащий отключаемый сеанс. В противном случае используется текущий сервер терминалов.
/v
Отображает сведения о выполненных действиях.
/?
Отображает справку в командной строке.

Примечания

  • Для отключения другого пользователя от сеанса необходимо иметь разрешение «Полный доступ».
  • Если не заданы ни имя сеанса, ни его код, то команда tsdiscon отключит текущий сеанс.
  • Любые приложения, запущенные при отключении сеанса, автоматически запускаются при подключении заново к этому сеансу, так что никакие данные не будут утеряны. Используйте команду Reset session для завершения приложений отключенных сеансов, однако необходимо помнить, что результатом выполнения этой команды будет потеря всех данных сеанса.
  • Параметр /server необходимо использовать только при вводе команды tsdiscon с удаленного сервера.
  • Сеанс консоли не может быть отключен.

Примеры

Чтобы отключить текущий сеанс, введите:

tsdiscon

Чтобы отключить сеанс с кодом 10, введите:

tsdiscon 10

Чтобы отключить сеанс с именем TERM04, введите:

tsdiscon TERM04


Tskill

Завершает процесс.

Синтаксис

tskill {код_процесса | имя_процесса} [/server:имя_сервера] [{/id:код_сеанса | /a}] [/v]

Параметры

код_процесса
Отображает код завершаемого сеанса.
имя_процесса
Отображает имя завершаемого сеанса. Для задания этого аргумента можно использовать подстановочные символы.
/server:имя_сервера
Определяет сервер терминалов, содержащий завершаемый процесс. В противном случае используется текущий сервер терминалов.
/id:код_сеанса
Завершает процесс, запущенный в выбранном сеансе.
/a
Завершает процесс, запущенный во всех сеансах.
/v
Отображает сведения о выполненных действиях.
/?
Отображает справку в командной строке.

Примечания

  • Если пользователь не обладает правами администратора, то он может использовать команду tskill для завершения только тех процессов, которые принадлежат ему. Администраторы имеют полный доступ ко всем функциям команды tskill и могут завершить процесс, запущенный в любых пользовательских сеансах.
  • При завершении всех запущенных процессов в сеансе он тоже завершается.


Tsprof

Копирует сведения о конфигурации одного пользователя (отображенные в расширениях служб терминалов, расположенных в оснастках «Локальные пользователи и группы» и «Active Directory - пользователи и компьютеры») другому. Команда tsprof также может задать путь к профилю для пользователя.

Синтаксис

tsprof /update {/domain:имя_домена | /local} /profile:путь имя_пользователя

tsprof /copy {/domain:имя_домена | /local}[/profile:путь] исходный_пользователь конечный_пользователь

tsprof /q {/domain:имя_домена | /local} имя_пользователя

Параметры

имя_пользователя
Отображает имя пользователя, для которого необходимо обновить или запросить путь к профилю на сервере.
исходный_пользователь
Отображает имя пользователя, сведения о конфигурации которого необходимо скопировать.
конечный_пользователь
Отображает имя пользователя, которому будут скопированы сведения о конфигурации.
/domain:имя_домена
Отображает имя используемого для операции домена.
/local
Применяет операции только к локальным учетным записям.
/profile:путь
Отображает путь к профилю, как указано в расширениях служб терминалов в оснастках «Локальные пользователи и группы» и «Пользователи и компьютеры Active Directory».
/update
Обновляет сведения о пути к профилю для пользователя, заданного в параметре имя_пользователя в домене имя_домена, до значения путь.
/copy
Копирует конфигурацию пользователя из исходного_пользователя в конечного_пользователя и обновляет сведения о пути к профилю для конечного_пользователя до значения путь. И исходный_пользователь, и конечный_пользователь должны быть локальными или должны находится в домене, заданном в параметре имя_домена.
/q
Отображает текущий путь к профилю пользователя, для которого необходимо запросить путь к профилю на сервере.
/?
Отображает справку в командной строке.

Примечания

  • Команду tsprof может выполнить только администратор.


Tsshutdn

Позволяет администратору, пользующемуся удаленным управлением, завершить работу или перезагрузить сервер терминалов. Если компьютер поддерживает программное управление питанием от сети, то можно также выключить питание у сервера.

Синтаксис

tsshutdn [время_ожидания] [/server:имя_сервера] [/reboot] [/powerdown] [/delay:задержка_выхода] [/v]

Параметры

время_ожидания
Задает время (в секундах), которое должно пройти с момента уведомления всех пользователей до отключения их от сеансов. По умолчанию это время составляет 60 секунд.
/server:имя_сервера
Задает имя сервера терминалов, который завершает работу. Если имя сервера не задано, то работу завершит текущий сервер терминалов.
/reboot
Перезагружает сервер терминалов после завершения пользовательских сеансов.
/powerdown
Если компьютер поддерживает программное управление питанием от сети, то выключает питание сервера терминалов.
/delay:задержка_выхода
После выхода всех пользователей из сеансов задает время, которое должно пройти до остановки всех процессов и завершения работы сервера терминалов. По умолчанию это время составляет 30 секунд.
/
Отображает сведения о выполненных действиях.
/?
Отображает справку в командной строке.

Примечания

  • Для выполнения команды tsshutdn необходимо иметь административные привилегии.
  • Для завершения работы сервера терминалов не рекомендуется использовать команду Завершение работы, расположенную в меню Пуск. При помощи этого способа невозможно уведомить пользователей до завершения их сеансов.
  • Все подключенные сеансы получат уведомление о том, что они скоро будут завершены. Сеансы, в которых есть запущенные приложения с открытыми файлами, получат уведомление о необходимости сохранить эти файлы. После выполнения команды завершения работы сервера команда tsshutdn ждет заданный интервал времени (по умолчанию 30 секунд, заданный в аргументе /delay) до завершения всех процессов.
  • С помощью команды tsshutdn невозможно перезагрузить сервер, кроме случая, когда указан аргумент /reboot.


Команды изменения служб терминалов

Сведения о командах изменения служб терминалов см. в следующих разделах.

  • Change logon
  • Change port
  • Change user


Команды запросов служб терминалов

Сведения о командах запросов служб терминалов.

  • Query process
  • Query session
  • Query termserver
  • Query user


Debug

Запуск Debug.exe, программы для проверки и отладки исполнительных файлов MS-DOS. Выполненная без параметров команда debug запускает программу Debug.exe и выводит приглашение команды debug, представленное дефисом (-).

Синтаксис

debug [[диск:][путь] имя_файла [параметры]]

Параметры

[диск:][путь] имя_файла
Задание расположения и имени исполняемого файла для тестирования.
параметры
Указание параметров командной строки, передаваемых отлаживаемой программе.
?
Вывод списка подкоманд команды debug.

Примечания

  • Использование команд подсистемы MS-DOS

    Команда debug — это команда подсистемы MS-DOS, которая выполняется в среде WOW/NTVDM.

  • Разделитель параметров команды

    Параметры можно вводить через запятые или пробелы, но это требуется только для шестнадцатеричных значений. Например, следующие команды эквивалентны:

    dcs:100 110

    d cs:100 110

    d,cs:100,110

  • Использование команд debug

    Существует несколько команд debug, которыми можно воспользоваться.


Debug: a (assemble)

Создание двоичного кода процессоров 8086/8087/8088 непосредственно в памяти. Выполненная без параметров команда a начинает работу с точки последнего останова.

Синтаксис

a [адрес]

Параметры

адрес
Задает адрес, по которому записаны инструкции на языке ассемблер. Параметр адрес принимает шестнадцатеричные значения без знака h.
?
Вывод списка команд debug.

Примечания

  • Задание правильных записей адреса

    Адрес состоит из двух частей: первая содержит буквенное обозначение сегментного регистра или адрес сегмента из четырех цифр, а вторая содержит значение смещения. Адрес сегмента или сегментный регистр можно пропустить. По умолчанию для команд debug a, g, l, t, u и w адрес сегмента содержится в регистре CS. Для других подкоманд по умолчанию используется сегмент DS. Все числовые значения при этом представлены в шестнадцатеричном формате. Между именем сегмента и значением смещения следует вставлять двоеточие. Примеры правильных адресов:

    CS:0100

    04BA:0100

  • Задание мнемоник префикса

    Задайте мнемонику префикса инструкции перед кодом операции (т. е. opcode), к которой она относится. Команда a создает исполняемый машинный код из инструкций на языке ассемблера. Все числовые значения должны быть представлены в шестнадцатеричном формате и записаны как набор от 1 до 4 символов.

  • Использование мнемоник

    Мнемоники cs:, ds:, es: и ss:. Мнемоникой, вызывающей возврат управления в другой сегмент кода (far return), является retf. Мнемоники для работы со строками должны точно определять размер элементов строк. Например, для перемещения строк из слов (16 бит) следует использовать movsw, а для перемещения строк из байтов (8 бит) следует использовать movsb.

  • Задание переходов и вызовы функций

    Ассемблер автоматически обрабатывает переходы и вызовы (т. е. префиксы short, near или far ) в зависимости от смещения байтов. Имеется возможность переопределить переходы или вызовы с помощью префиксов near или far. Например:

    -a0100:0500
    0100:0500 jmp 502 ; короткий (short) переход на 2 байта
    0100:0502 jmp near 505 ; ближний (near) переход на 3 байта
    0100:0505 jmp far 50a ; длинный (far) переход на 5 байтов

    Вместо префикса near можно использовать сокращение ne.

  • Задание адреса слова или байта в памяти

    Если операнды ссылаются на адреса слов или байтов в памяти, тип данных должен быть задан с использованием префикса word ptr или byte ptr, которые можно сократить до wo для word ptr и до by для byte ptr. Например:

    dec wo [si]
    neg byte ptr [128]

  • Задание операндов

    В программе Debug.exe используется общее соглашение о том, что операнды, указывающие на адрес в памяти, заключаются в квадратные скобки ([ ]). Это единственный способ, который позволяет различать непосредственные операнды и ссылки на области в памяти в Debug.exe. Например:

    mov ax,21 ; загрузить число 21h в регистр AX
    mov ax,[21] ; загрузить содержимое
    ; памяти по адресу 21h
    ; в регистр AX

  • Псевдоинструкции

    С командой a часто используются две псевдоинструкции: операция db, которая размещает байты непосредственно в памяти, и операция dw, которая размещает в памяти слова. Например:

    db 1,2,3,4,"ЭТО ПРИМЕР"
    db 'ЭТО КАВЫЧКА: "'
    db "ЭТО КАВЫЧКА: '"
    dw 1000,2000,3000,"BACH"

  • Ввод данных в определенные байты
  • Деассемблирование байт

Примеры

Команда a допускает различное использование ссылок на регистры. Например:

add bx,34[bp+2].[si-1]
pop [bp+di]
push [si] )

Кроме того, команда a поддерживает использование синонимов дополнительных кодов операций: Например:

loopz 100
loope 100
ja 200
jnbe 200

Для дополнительных кодов операций процессора 8087 необходимо задать префиксы wait или fwait. Например:

fwait fadd st,st(3) ; эта строка вставляет
; в код префикса fwait


Debug: c (compare)

Сравнение двух блоков памяти.

Синтаксис

c диапазон адрес

Параметры

диапазон
Обязательный параметр. Задание начального и конечного адреса или начального адресы и длины первой области в памяти для сравнения.
адрес
Обязательный параметр. Задание начального адреса второй области памяти для сравнения.
?
Вывод списка команд debug.

Примечания

  • Задание правильных записей диапазона

    Параметр диапазон используется в командах debug для задания диапазона памяти. Для задания диапазона можно использовать один из следующих форматов: начальный и конечный адрес или начальный адрес и длина (разделяются символом l) диапазона. Например, обе следующих команды задают 16-разрядный диапазон, начинающийся с адреса CS:100:

    cs:100 10f

    cs:100 l 10

  • Задание правильных записей адреса

    Адрес состоит из двух частей: первая содержит буквенное обозначение сегментного регистра или адрес сегмента из четырех цифр, а вторая содержит значение смещения. Адрес сегмента или сегментный регистр могут быть пропущены. По умолчанию для команд debug a, g, l, t, u и w адрес сегмента содержится в регистре CS. Для других подкоманд по умолчанию используется сегмент DS. Все числовые значения при этом представлены в шестнадцатеричном формате. Между именем сегмента и значением смещения следует вставлять двоеточие. Следующие адреса являются допустимыми:

    CS:0100

    04BA:0100

  • Если параметры диапазон и адрес совпадают, команда c ничего не выводит и возвращается к приглашению debug. Если при сравнении блоков памяти обнаружены различия, они выводятся командой c в следующем виде:

    адрес1 байт1 байт2 адрес2

Примеры

Чтобы сравнить блок памяти от 100h до 10Fh с блоком памяти от 300h до 30Fh, введите следующую команду:

c100,10f 300

или

c100l10 300

Обе эти команды выведут следующие данные (предполагается, что DS = 197F):

197F:0100 4D E4 197F:0300
197F:0101 67 99 197F:0301
197F:0102 A3 27 197F:0302
197F:0103 35 F3 197F:0303
197F:0104 97 BD 197F:0304
197F:0105 04 35 197F:0305
197F:0107 76 71 197F:0307
197F:0108 E6 11 197F:0308
197F:0109 19 2C 197F:0309
197F:010A 80 0A 197F:030A
197F:010B 36 7F 197F:030B
197F:010C BE 22 197F:030C
197F:010D 83 93 197F:030D
197F:010E 49 77 197F:030E
197F:010F 4F 8A 197F:030F

Адреса 197F:0106 и 197F:0306 отсутствуют в списке. Это означает, что значения, расположенные по этим адресам, совпадают.


Debug: d (dump)

Просмотр содержимого заданного диапазона адресов памяти. Выполненная без параметров команда d выводит на экран содержимое 128 байт, начиная с конца диапазона адресов, заданного в предыдущей команде d.

Синтаксис

d [диапазон]

Параметры

диапазон
Задание начального и конечного адреса или начального адреса и длины блока памяти для просмотра его содержимого.
?
Вывод списка команд debug.

Примечания

  • Задание правильных записей диапазона

    Параметр диапазон используется в подкомандах debug для задания диапазона памяти. Параметр диапазон можно задать в одном из следующих форматов: начальный адрес и конечный адрес или начальный адрес и длина (обозначаемая l) диапазона. Например, оба следующих выражения задают диапазон из 16 байтов, начинающийся с адреса CS:100:

    cs:100 10f

    cs:100 l 10

  • Если используется подкоманда d, содержимое памяти выводится командой Debug.exe двумя частями: шестнадцатеричной (каждый байт представлен в шестнадцатеричном формате) и текстовой (каждый байт представлен символом ASCII). Непечатаемые символы отображаются точкой (.) в текстовой части. Каждая строка на экране представляет содержимое 16 байт со знаком тире между восьмым и девятым байтом. Все строки начинаются на 16-ти байтной границе.

Примеры

Введите следующую команду:

dcs:100 10f

Команда debug.exe выводит содержимое диапазона в следующем формате:

04BA:0100 54 4F 4D 00 53 41 57 59-45 52 00 00 00 00 00 00.....

Команда Debug.exe выводит сведения в таком формате, если подкоманда d выполнена без параметров. Каждая строка на экране начинается с адреса, который отстоит от адреса предыдущей строки на 16 байт (или на 8 байт для экрана с 40 колонками). Для каждой последующей подкоманды d, вводимой без параметров, Debug.exe выводит следующую часть сведений непосредственно за предыдущей.

Чтобы вывести содержимое 20h байт, начиная с CS:100, введите следующую команду:

dcs:100 l 20

Чтобы вывести содержимое всех байт в диапазоне от 100h до 115h в сегменте CS, введите следующую команду:

dcs:100 115


Debug: e (enter)

Ввод данных в память по заданному адресу.

Синтаксис

e адрес [список]

Параметры

адрес
Обязательный параметр. Адрес начала области памяти для ввода данных.
список
Задание списка байтов, которые требуется ввести в память.
?
Вывод списка подкоманд debug.

Примечания

  • Задание правильных записей адреса

    Адрес состоит из двух частей: первая содержит буквенное обозначение сегментного регистра или адрес сегмента из четырех цифр, а вторая содержит значение смещения. Адрес сегмента или сегментный регистр могут быть пропущены. По умолчанию для подкоманд a, g, l, t, u и w команды debug адрес сегмента содержится в регистре CS. Для других подкоманд по умолчанию используется сегмент DS. Все числовые значения при этом представлены в шестнадцатеричном формате. Между именем сегмента и значением смещения следует вставлять двоеточие. Следующие адреса являются допустимыми:

    CS:0100

    04BA:0100

  • Использование параметра адрес

    При задании параметра адрес без указания параметра список Debug.exe выведет на экран адрес и его содержимое, затем повторит адрес на следующей строке и будет ждать ввода новой команды. В этот момент можно выполнить одно из следующих действий.

    • Заменить байт данных. Для этого введите новое значение. Если введенное значение не является допустимым шестнадцатеричным числом или содержит более двух цифр, Debug.exe не выводит на экран неверные или избыточные символы.
    • Перейти к следующему байту. Для этого нажмите клавишу ПРОБЕЛ. Для изменения данного байта введите новое значение после текущего. Если при нажатии клавиши ПРОБЕЛ пройдена 8-байтная граница, Debug.exe выводит на экран новую строку с новым адресом в начале строки.
    • Возвратиться к предыдущему байту. Для этого нажмите клавишу МИНУС. Для перемещения назад более чем на один байт нажмите эту клавишу несколько раз. При нажатии клавиши МИНУС Debug.exe выводит новую строку с текущим адресом и значением.
    • Остановить выполнение подкоманды e. Для этого нажмите клавишу ENTER. Это можно сделать в любой позиции курсора.
  • Использование параметра список

    Если введен параметр список, подкоманда e последовательно заменяет существующие значения значениями из списка. При возникновении ошибки никакие значения не будут изменены.

    Список может быть задан как шестнадцатеричными числами, так и строкой. При этом числа разделяются пробелами, запятыми или символами табуляции. Строки необходимо заключать в апострофы (т. е. 'строка') или кавычки (т. е. "строка").

  • Создание двоичного кода
  • Просмотр содержимого области памяти

Примеры

Введите следующую команду:

ecs:100

Debug.exe выведет содержимое первого байта в следующем формате:

04BA:0100 EB._

Чтобы заменить это значение числом 41, введите 41 в позицию курсора, как показано ниже:

04BA:0100 EB.41_

Последовательность байтов можно ввести в одной подкоманде e. Вместо нажатия клавиши Enter после нового значения, нажмите клавишу ПРОБЕЛ. Программа Debug.exe выведет следующее значение. В данном примере, если клавиша ПРОБЕЛ нажата три раза, Debug.exe выведет на экран следующие значения:

04BA:0100 EB.41 10. 00. BC._

Чтобы заменить шестнадцатеричное значение BC числом 42, введите 42 в позицию курсора, как показано ниже:

04BA:0100 EB.41 10. 00. BC.42_

Чтобы изменить значение 10 на 6F, дважды нажмите клавишу МИНУС для возврата к адресу 0101 (значение 10). Программа Debug.exe выводит следующие сведения:

04BA:0100 EB.41 10. 00. BC.42-
04BA:0102 00.-
04BA:0101 10._

Введите 6F в позицию курсора для изменения значения, как показано ниже:

04BA:0101 10.6F_

Нажмите клавишу ENTER для завершения выполнения подкоманды e и возврата к приглашению программы debug.

Рассмотрим пример ввода строковой величины:

eds:100 "Это пример текста"

Эта строка будет занимать 24 байта, начиная с адреса DS:100.


Debug: f (fill)

Заполнение адресов в определенной области памяти заданными значениями.

Синтаксис

f диапазон список

Параметры

диапазон
Обязательный параметр. Задание начального и конечного адреса или начального адреса и длины области памяти, которую требуется заполнить.
список
Обязательный параметр. Задание данных, которые требуется ввести.
?
Вывод списка подкоманд debug.

Примечания

  • Задание правильных записей диапазона

    Параметр диапазон используется в подкомандах debug для задания диапазона памяти. Параметр диапазон можно задать в одном из следующих форматов: начальный адрес и конечный адрес или начальный адрес и длина (обозначаемая l) диапазона. Например, оба следующих выражения задают диапазон из 16 байтов, начинающийся с адреса CS:100:

    cs:100 10f

    cs:100 l 10

  • Задание данных

    Данные можно задать в шестнадцатеричном или текстовом формате. Данные, ранее находившиеся по данному адресу, будут удалены.

  • Использование параметра список

    Список может состоять из шестнадцатеричных чисел или строки, заключенной в кавычки (т. е. "строка").

Примеры

Чтобы заполнить область памяти с 04BA:100 по 04BA:1FF пятью определенными значениями (например 42, 45, 52, 54, 41) и повторять этот набор, пока 100h байт не будут заполнены программой Debug.exe, введите следующую команду:

f04ba:100l100 42 45 52 54 41


Debug: g (go)

Выполнение загруженной программы. Запущенная без параметров подкоманда g начинает выполнение с текущего адреса в реестрах CS:IP.

Синтаксис

g [=адрес] [точки_останова]

Параметры

адрес
Задание адреса в памяти, с которого требуется начать выполнение программы.
точки_останова
Указание до 10 временных точек останова, которые могут быть заданы как часть подкоманды g.
?
Вывод списка подкоманд debug.

Примечания

  • Задание правильных записей адреса

    Адрес состоит из двух частей: первая содержит буквенное обозначение сегментного регистра или адрес сегмента из четырех цифр, а вторая содержит значение смещения. Адрес сегмента или сегментный регистр могут быть пропущены. По умолчанию для подкоманд a, g, l, t, u и w команды debug адрес сегмента содержится в регистре CS. Для других подкоманд по умолчанию используется сегмент DS. Все числовые значения при этом представлены в шестнадцатеричном формате. Между именем сегмента и значением смещения следует вставлять двоеточие. Следующие адреса являются допустимыми:

    CS:0100

    04BA:0100

  • Использование параметра адрес

    Введите знак равенства (=) перед параметром адрес, чтобы отличить адрес от адресов точек останова (точки_останова).

  • Задание точек останова

    Выполнение программы будет остановлено в первой встретившейся точке останова, независимо от расположения этой точки останова в списке параметра точки_останова. Debug.exe заменяет код, находящийся в точках останова, на инструкции прерывания.

    Когда выполнение программы дошло до точки останова, Debug.exe восстанавливает код в точках останова и выводит на экран содержимое всех регистров, все флаги состояния и деассемблированную инструкцию, которая была выполнена последней. Debug.exe выводит те же сведения, которые получают при использовании полкоманды r (регистр) и указании адреса данной точки останова.

    Если программа не остановлена ни в одной точке, Debug.exe не заменяет коды прерываний первоначальными инструкциями.

    Точки останова могут быть установлены только по адресам, содержащим первый байт кода операции 8086 (opcode). Если установлено больше 10 точек останова, выводится следующее сообщение:

    bp Error

  • Использование указателя на стек, задаваемый пользователем

    Указатель на стек, задаваемый пользователем, должен быть допустимым, а емкость стека должна быть не менее 6 байт для подкоманды g. Для перехода к тестируемой программе в подкоманде g используется инструкция iret. Debug.exe устанавливает указатель на стек пользователя, помещает туда пользовательские флаги состояния, значение регистра кодового сегмента и указатель на текущую команду. (Если заданный пользователем стек неверен или имеет недостаточный объем, возможен сбой в операционной системе). Debug.exe записывает код прерывания (т. е. 0CCh) в указанные точки останова или адреса.

  • Перезапуск программы

    Не перезапускайте программу при получении следующего сообщения:

    Program terminated normally

    Чтобы правильно запустить программу, перезагрузите ее с помощью подкоманд n (name) и l (load).

Примеры

Чтобы запустить текущую программу и выполнить ее до точки останова по адресу 7550 в сегменте CS, введите следующую команду.

gcs:7550

Debug.exe выведет на экран содержимое регистров и состояние флагов, а затем остановит подкоманду g.

Чтобы установить две точки останова, введите следующую команду:

gcs:7550, cs:8000

Если подкоманда g введена снова после остановки в точке останова, выполнение начнется с инструкции, следующей за точкой останова, а не с обычного адреса начала программы.


Debug: h (hexadecimal)

Выполнение шестнадцатеричных арифметических операций над двумя заданными числами.

Синтаксис

h число1 число2

Параметры

число1
Обязательный параметр. Первое шестнадцатеричное число в диапазоне от 0 до FFFFh.
число2
Обязательный параметр. Второе шестнадцатеричное число в диапазоне от 0 до FFFFh.
?
Вывод списка подкоманд debug.

Заметки

  • В программе Debug.exe два введенных числа складываются, а затем вычисляется их разность. Результаты вычислений выводятся в одной строке — вначале сумма, затем разность.

Примеры

Введите следующую команду:

h19f 10a

Результаты вычислений Debug.exe будут выведены в виде:

02A9 0095


Debug: i (input)

Считывание и вывод на экран одного байта из указанного порта ввода.

Синтаксис

i порт

Параметры

порт
Обязательный параметр. Задание порта ввода адресом. Адрес может быть 16-битным значением.
?
Вывод списка подкоманд debug.

Примеры

Введите следующую команду:

i2f8

Если находящаяся в порту величина равна 42h, Debug.exe считает ее и выведет в следующем виде:

42


Debug: l (load)

Загрузка файла или содержимого сектора диска в память. Выполненная без параметров подкоманда l загружает файл, указанный в командной строке программы debug, в память, начиная с адреса CS:100. В регистрах BX и CX указывается количество загруженных байт. Если имя файла не было задано в командной строке debug, используется файл, ранее заданный при вызове последней подкоманды n.

Синтаксис

l [адрес]

l [адрес] [диск] [первый_сектор] [число]

Параметры

адрес
Задание адреса области памяти, в которую требуется загрузить содержимое файла или сектора. Если параметр адрес не задан, используется текущий адрес в регистре CS.
диск
Задание накопителя, содержащего диск, с которого считываются определенные сектора. Данный параметр задается числом: 0 = A, 1 = B, 2 = C и т. д.
первый_сектор
Задание шестнадцатеричного номера первого сектора, содержимое которого требуется загрузить.
число
Задание шестнадцатеричного числа последовательных секторов, содержимое которых требуется загрузить. Параметры диск, первый_сектор и число используются только в том случае, когда необходимо загрузить содержимое определенных секторов, а не файл, указанный в командной строке debug или в последней подкоманде n (name).
?
Вывод списка подкоманд debug.

Заметки

  • Для загрузки задаваемого регистрами BX:CX числа байтов из файла на диске используется следующий синтаксис:

    l [адрес]

  • Для пропуска файловой системы и прямой загрузки указанных секторов используется следующий синтаксис:

    l [адрес] [диск] [первый_сектор] [число]

  • Задание правильных записей адреса

    Адрес состоит из двух частей: первая содержит буквенное обозначение сегментного регистра или адрес сегмента из четырех цифр, а вторая содержит значение смещения. Адрес сегмента или сегментный регистр могут быть пропущены. По умолчанию для подкоманд a, g, l, t, u и w команды debug адрес сегмента содержится в регистре CS. Для других подкоманд по умолчанию используется сегмент DS. All numeric values are in hexadecimal format. Между именем сегмента и значением смещения следует вставлять двоеточие. Следующие адреса являются допустимыми:

    CS:0100

    04BA:0100
  • Использование параметра адрес

    При вызове подкоманды l с указанием параметра адрес Debug.exe загрузит файл или содержимое сектора диска в область памяти, начиная с адреса.

  • Использование всех параметров

    При вызове подкоманды l со всеми параметрами Debug.exe загружает содержимое сектора диска, а не файла.

  • Загрузка содержимого сектора диска

    Каждый сектор в указанном диапазоне считывается с диска, заданного параметром диск. Debug.exe начинает загрузку с первого_сектора и последовательно загружает сектора в память, пока не будет загружено заданное число секторов.

  • Загрузка файла .exe

    Для файлов с расширением .exe параметр адрес игнорируется. В этом случае Debug.exe использует загрузочный адрес, задаваемый в заголовке .exe файла. При загрузке заголовок отделяется от самого .exe файла, загружаемого в память, поэтому размер файла, указанный в заголовке, и фактически занимаемый размер в памяти будут различаться. Для просмотра .exe файла целиком он может быть переименован в файл с другим расширением и затем просмотрен в программе Debug.

  • Загрузка файлов .hex

    В программе Debug.exe файлы с расширением .hex распознаются как файлы в шестнадцатеричном формате. Подкоманду l можно запустить без параметров для загрузки такого шестнадцатеричного файла, начиная с адреса, указанного в данном файле. Если подкоманда l запущена с параметром адрес, начальная точка загрузки определяется как сумма заданного адреса и адреса, содержащегося в шестнадцатеричном файле.

Примеры

В командной строке введите:

debug

Введите следующую команду:

nfile.com

Чтобы загрузить файл File.com, введите следующую команду:

l

Debug.exe загружает этот файл и выводит приглашение debug.

Чтобы загрузить содержимое 109 (6Dh) секторов диска C, начиная с логического сектора 15 (0Fh), в область памяти, начиная с адреса 04BA:0100, введите следующую команду:

l04ba:100 2 0f 6d


Debug: m (move)

Копирование содержимого одного блока памяти в другой.

Синтаксис

m диапазон адрес

Параметры

диапазон
Обязательный параметр. Задание начального и конечного адреса или начального адреса и длины области памяти, содержимое которой требуется скопировать.
адрес
Обязательный параметр. Задание начального адреса области памяти, в которую требуется скопировать содержимое диапазона.
?
Вывод списка подкоманд debug.

Примечания

  • Задание правильных записей диапазона

    Параметр диапазон используется в подкомандах debug для задания диапазона памяти. Параметр диапазон можно задать в одном из следующих форматов: начальный адрес и конечный адрес или начальный адрес и длина (обозначаемая l) диапазона. Например, оба следующих выражения задают диапазон из 16 байтов, начинающийся с адреса CS:100:

    cs:100 10f

    cs:100 l 10

  • Задание правильных записей адреса

    Адрес состоит из двух частей: первая содержит буквенное обозначение сегментного регистра или адрес сегмента из четырех цифр, а вторая содержит значение смещения. Адрес сегмента или сегментный регистр могут быть пропущены. По умолчанию для подкоманд a, g, l, t, u и w команды debug адрес сегмента содержится в регистре CS. Для других подкоманд по умолчанию используется сегмент DS. Все числовые значения при этом представлены в шестнадцатеричном формате. Между именем сегмента и значением смещения следует вставлять двоеточие. Следующие адреса являются допустимыми:

    CS:0100

    04BA:0100
  • Копирование данных

    Если адреса в копируемом блоке памяти заданы так, что в этот блок не записываются новые данные, то информация в этом блоке не изменяется. Если же операция копирования является перекрывающей, перекрывающиеся данные перезаписываются. (Операция копирования является перекрывающей, если два блока памяти имеют общую часть).

  • Перекрывающееся копирование двух областей памяти

    Подкоманда m выполняет перекрывающее копирование без потери данных в области назначения. Содержимое адресов, которые будут перезаписаны, копируется в первую очередь. Если данные копируются из старших адресов в младшие адреса, операция копирования начинается с младшего адреса исходного блока и продолжается в направлении старшего адреса. И наоборот, если данные копируются из младших адресов в старшие, копирование начинается со старших адресов исходного блока и продолжается в направлении младшего адреса.

Примеры

Чтобы скопировать содержимое адресов с CS:110 по CS:510, а затем с CS:10F по CS:50F и так далее, пока все содержимое адресов с CS:100 по CS:500 не будет скопировано, введите следующую команду:

mcs:100 110 cs:500

Чтобы просмотреть результаты, воспользуйтесь подкомандой d (dump), указав адреса, заданные в подкоманде m.


Debug: n (name)

Задание имени исполняемого файла для команд debug l (load) или w (write) или задание параметров для отлаживаемого исполняемого файла. Выполненная без параметров подкоманда n очищает текущие значения.

Синтаксис

n [путь][исполняемый_файл]

n [параметры_файла]

Параметры

[путь][исполняемый_файл
Задание расположения и имени исполняемого файла для тестирования.
[параметры_файла]
Задание параметров и ключей командной строки для тестируемого исполняемого файла.
?
Вывод списка подкоманд debug.

Примечания

  • Использование подкоманды n

    Подкоманду n можно использовать двумя способами. Во-первых, для задания имени файла для последующих подкоманд l (load) или w (write). Если программа Debug.exe вызвана без задания имени файла для отладки, команда n имя_файла должна быть вызвана перед использованием команды l для загрузки файла. Имя файла форматируется соответствующим образом для контрольного блока файла (FCB) по адресу CS:5C. Во-вторых, подкоманда n может использоваться для задания параметров и ключей командной строки отлаживаемого файла.

  • Области памяти

    В следующей таблице перечислены четыре области памяти, которые используются командой n.

    Область памяти | Contents
    CS:5C | Блок управления файлом (FCB) для файла 1
    CS:6C | Блок управления файлом (FCB) для файла 2
    CS:80 | Длина строки команды n (в символах)
    CS:81 | Начало строки команды n

    Первое имя файла, задаваемое командой n, размещается в блоке управления файлом по адресу CS:5C. Если задано второе имя, оно помещается в блок управления файлом по адресу CS:6C. Количество символов в командной строке команды n (кроме первого символа, n) сохраняется по адресу CS:80. Собственно командная строка n (снова без символа n) сохраняется, начиная с адреса CS:81. Эти символы могут быть любыми параметрами и разделителями, которые допустимо вводить с командной строки в Windows 2000.

Примеры

В этом примере запускается команда debug и загружается программа Prog.com для отладки. Чтобы указать два параметра для программы Prog.com и запустить эту программу, введите следующую команду:

debug prog.com
nparam1 param2
g

В этом случае подкоманда g (go) запускает программу так, как если бы она была запущена с командной строки в виде:

prog param1 param2

При тестировании и отладке создается среда времени исполнения для программы Prog.com.

В следующей последовательности команд первая подкоманда n задает имя файла File1.exe для последующей подкоманды l (load), которая загружает файл File1.exe в память. Вторая подкоманда n задает параметры для файла File1.exe. Наконец, подкоманда g запускает File1.exe так, как если бы с командной строки было бы введено File1 File2.dat File2.dat.

nfile1.exe
l
nfile2.dat file3.dat
g

После команды l во втором экземпляре команда n не используется. Если подкоманда w (write) используется во втором экземпляре подкоманды n, файл File1.exe (т. е. отлаживаемый) сохраняется под именем File2.dat. Чтобы этого не произошло, всегда вызывайте команду l или w сразу же после команды n в первой форме.


Debug: o (output)

Вывод байта в порт вывода.

Синтаксис

o порт байт

Параметры

порт
Обязательный параметр. Задание адреса порта вывода. Адрес порта может быть 16-битным значением.
байт
Обязательный параметр. Задание значения байта, выводимого в порт.
?
Вывод списка подкоманд debug.

Примеры

Чтобы отправить байт 4Fh в порт вывода по адресу 2F8h, введите следующую команду:

o2f8 4f


Debug: p (proceed)

Выполнение цикла, строковой инструкции, программного прерывания или процедур, а также вход в другую инструкцию. Выполненная без параметров команда p выводит список реестров и их текущих значений.

Синтаксис

p [=адрес] [число]

Параметры

адрес
Задание адреса инструкции, которая будет выполнена первой. Если адрес не указан, по умолчанию выполнение начнется с инструкции, задаваемой регистрами CS:IP.
число
Задание количества инструкций, которые будут выполнены перед возвратом управления программе Debug.exe. По умолчанию используется значение 1.
?
Вывод списка подкоманд debug.

Примечания

  • Задание правильных записей адреса

    Адрес состоит из двух частей: первая содержит буквенное обозначение сегментного регистра или адрес сегмента из четырех цифр, а вторая содержит значение смещения. Адрес сегмента или сегментный регистр могут быть пропущены. По умолчанию для подкоманд a, g, l, t, u и w команды debug адрес сегмента содержится в регистре CS. Для других подкоманд по умолчанию используется сегмент DS. Все числовые значения при этом представлены в шестнадцатеричном формате. Между именем сегмента и значением смещения следует вставлять двоеточие. Следующие адреса являются допустимыми:

    CS:0100

    04BA:0100

  • Использование параметра адрес

    Если в параметре адрес не указан сегмент, Debug.exe использует регистр CS тестируемой программы. Если параметр адрес опущен, выполнение программы начинается с адреса, указываемого регистрами CS:IP. Чтобы отличить параметр адрес от параметра число, перед адресом обязательно должен быть введен знак равенства (=). В случае если инструкция по заданному адресу не является циклом, строковой инструкцией, программным прерыванием или процедурой, подкоманда p работает также, как подкоманда t (trace).

  • Передача управления тестируемой программе

    Если в программе Debug.exe управление передано тестируемой программе с помощью команды p, выполнение продолжается до тех пор, пока цикл, строковая инструкция, программное прерывание или процедура не будут закончены или пока не будет выполнено заданное количество инструкций. Затем управление возвращается к Debug.exe.

  • Просмотр сообщений

    После запуска подкоманды p Debug.exe выводит на экран содержимое регистров, флаги состояния и следующую инструкцию в деассемблированном виде.

    Предупреждение!

    • Подкоманда p не может быть использована для отладки инструкций, содержащихся в ПЗУ.

Примеры

В этом примере тестируемая программа содержит инструкцию call по адресу CS:143F. Чтобы выполнить процедуру, указанную в call, и возвратиться в программу Debug.exe, введите следующую команду:

p=143f

Результаты программы Debug.exe будут выведены в следующем формате:

AX=0000 BX=0000 CX=0000 DX=0000 SP=FFEE BP=0000 SI=0000 DI=0000
DS=2246 ES=2246 SS=2246 CS=2246 IP=1443 NV UP EI PL NZ AC PO NC
2246:1442 7505 JNZ 144A


Debug: q (quit)

Окончание работы программы Debug.exe без сохранения тестируемого файла и возврат в командную строку.

Синтаксис

q

Параметры

?
Вывод списка подкоманд debug.


Debug: r (register)

Редактирование содержимого одного или нескольких регистров ЦПУ. Выполненная без параметров команда r выводит содержимое всех регистров и флагов из временного хранилище регистра, состояния всех всех флагов и декодированную инструкцию в текущей области.

Синтаксис

r [регистр]

Параметры

регистр
Задание имени регистра, содержащего сведения, которые требуется вывести на экран.
?
Вывод списка подкоманд debug.

Примечания

  • Использование подкоманды r

    Если задан регистр, Debug.exe выводит на экран его 16-разрядное значение в шестнадцатеричном формате и двоеточие в качестве приглашения. Если требуется изменить значение содержащееся в регистре, введите новое значение и нажмите клавишу ENTER. В противном случае нажмите клавишу ENTER для возврата к приглашению программы debug.

  • Допустимые регистры x86

    В следующей таблице перечислены допустимые регистры x86 для параметра регистр.

    Значение
    ax
    bp
    bx
    cs
    cx
    di
    ds
    dx
    es
    f
    ip
    pc
    si
    sp
    ss

    Если задан недопустимый регистр, выводится следующее сообщение:

    Ошибка: br

  • Использование f вместо регистра

    Если указать f вместо регистра, Debug.exe выводит на экран текущее значение каждого флага состояния в виде двухбуквенного кода и приглашение debug. Для изменения значения флага введите соответствующий двухбуквенный код, воспользовавшись следующей таблицей.

    Флаг | Установлен | Снят
    Переполнение | ov | nv
    Направление | dn (уменьшение) | up (увеличение)
    Прерывание | ei (включено) | di (выключено)
    Знак | ng (отрицательный) | pl (положительный)
    Ноль | zr | nz
    Добавочный перенос | ac | na
    Четность | pe (четный) | po (нечетный)
    Перенос | cy | nc

    Новые значения флагов могут быть введены в любой последовательности. Между этими значениями не нужно вводить пробел. Чтобы завершить выполнение подкоманды r, нажмите клавишу ENTER. Флаги, новые значения для которых не вводились, останутся неизмененными.

  • Сообщения подкоманды r

    При задании более одного значения для флага выводится следующее сообщение:

    Ошибка: df

    При вводе кода, не содержащегося в таблице, выводится следующее сообщение:

    Ошибка: bf

    В обоих случаях Debug.exe пропустит все значения, следующие после неверного ввода.

  • Значения, используемые по умолчанию в программе Debug.exe

    Когда запускается программа Debug.exe, сегментный регистр указывает на нижнюю границу свободной памяти, указатель инструкций устанавливается равным 0100h, все флаги состояния очищаются, оставшиеся регистры обнуляются, за исключением sp, который устанавливается равным FFEEh.

Примеры

Если текущее положение указателя инструкций равно CS:11A, выводятся следующие сведения:

AX=0E00 BX=00FF CX=0007 DX=01FF SP=039D BP=0000 SI=005C DI=0000
DS=04BA ES=04BA SS=04BA CS=O4BA IP=011A NV UP DI NG NZ AC PE NC
04BA:011A CD21 INT 21

Чтобы просмотреть только состояния флагов, введите следующую команду:

rf

Результаты программы Debug.exe выводятся в следующем формате:

NV UP DI NG NZ AC PE NC - _

Введите одно и несколько допустимых значений флагов с пробелами или без них. Например:

nv up di ng nz ac pe nc - pleicy

Debug.exe завершит выполнение подкоманды r и выведет приглашение debug. Для просмотра изменений воспользуйтесь командой r или rf. Программа Debug.exe выводит следующие сведения:

NV UP EI PL NZ AC PE CY - _

Нажмите клавишу ENTER для возврата к приглашению программы debug.


Debug: s (search)

Поиск в области памяти по шаблону из одного или нескольких байт.

Синтаксис

s диапазон список

Параметры

диапазон
Обязательный параметр. Задает начальный и конечный адреса области памяти, в которой будет производиться поиск.
список
Обязательный параметр. Задание шаблона из одного или нескольких байт или символьной строки для поиска.
?
Вывод списка подкоманд debug.

Примечания

  • Задание правильных записей диапазона

    Параметр диапазон используется в подкомандах debug для задания диапазона памяти. Параметр диапазон можно задать в одном из следующих форматов: начальный адрес и конечный адрес или начальный адрес и длина (обозначаемая l) диапазона. Например, оба следующих выражения задают диапазон из 16 байтов, начинающийся с адреса CS:100:

    cs:100 10f

    cs:100 l 10

  • Использование параметра список

    Если используется параметр список, отделяйте значение каждого байта пробелом или запятой, а строки заключайте в кавычки (т. е. "строка"). Если список содержит несколько значений, выводится только первый адрес, в котором встречается данное значение. Если список содержит только одно значение, выводятся все адреса из указанного диапазона, в которых встречается данное значение.

Примеры

Чтобы найти все адреса в диапазоне от CS:100 до CS:110, содержащие значение 41, введите следующую команду:

scs:100 110 41

Результаты программы Debug.exe будут выведены в следующем формате:

04BA:0104
04BA:010D
-

Чтобы найти строку «Ph» в диапазоне от CS:100 до CS:1A0, введите следующую команду:

scs:100 1a0 "Ph"


Подкоманды команды Debug

Дополнительные сведения см. по ссылке команды.

  • Debug: a (assemble)
  • Debug: c (compare)
  • Debug: d (dump)
  • Debug: e (enter)
  • Debug: f (fill)
  • Debug: g (go)
  • Debug: h (hexadecimal)
  • Debug: i (input)
  • Debug: l (load)
  • Debug: m (move)
  • Debug: n (name)
  • Debug: o (output)
  • Debug: p (proceed)
  • Debug: q (quit)
  • Debug: r (register)
  • Debug: s (search)
  • Debug: t (trace)
  • Debug: u (unassemble)
  • Debug: w (write)
  • Debug: xa (allocate expanded memory)
  • Debug: xd (deallocate expanded memory)
  • Debug: xm (map expanded memory pages)
  • Debug: xs (display expanded memory status)


Debug: t (trace)

Выполнение одной инструкции с выводом содержимого регистров, флагов состояния и декодированной формы выполняемой инструкции. При запуске подкоманды t без параметров выполнение начинается с адреса, указанного в регистрах CS:IP программы.

Синтаксис

t [=адрес] [число]

Параметры

адрес
Задание адреса, с которого Debug.exe начнет выполнение инструкций.
число
Указывает число инструкций для выполнения. Указанное значение должно быть шестнадцатеричным числом. По умолчанию значение равно 1.
?
Вывод списка подкоманд debug.

Примечания

  • Задание правильных записей адреса

    Адрес состоит из двух частей: первая содержит буквенное обозначение сегментного регистра или адрес сегмента из четырех цифр, а вторая содержит значение смещения. Адрес сегмента или сегментный регистр могут быть пропущены. По умолчанию для подкоманд a, g, l, t, u и w команды debug адрес сегмента содержится в регистре CS. Для других подкоманд по умолчанию используется сегмент DS. Все числовые значения при этом представлены в шестнадцатеричном формате. Между именем сегмента и значением смещения следует вставлять двоеточие. Следующие адреса являются допустимыми:

    CS:0100

    04BA:0100

  • Трассировка инструкций, записанных в ПЗУ

    Подкоманда t использует аппаратный режим трассировки микропроцессоров 8086 и 8088. Следовательно, также можно трассировать инструкции, хранимые в ПЗУ.

Примеры

Если текущая позиция указателя кода является 04BA:011A, Debug.exe выведет следующие сведения:

AX=0E00 BX=00FF CX=0007 DX=01FF SP=039D BP=0000 SI=005C DI=0000
DS=04BA ES=04BA SS=04BA CS=O4BA IP=011A NV UP DI NG NZ AC PE NC
04BA:011A CD21 INT 21


Debug: u (unassemble)

Деассемблирование байтов и просмотр соответствующего исходного кода, включая адреса и двоичные значения. Деассемблированный код выводится в формате, похожем на распечатку ассемблерного файла. Выполненная без параметров подкоманда u деассемблирует 20h байт (значение по умолчанию), начиная с первого адреса после адреса, использованного в предыдущей подкоманде u.

Синтаксис

u [диапазон]

Параметры

диапазон
Задание начального и конечного адреса или начального адреса и длины участка двоичного кода, который требуется деассемблировать.
?
Вывод списка подкоманд debug.

Примечания

  • Задание правильных записей диапазона

    Параметр диапазон используется в подкомандах debug для задания диапазона памяти. Параметр диапазон можно задать в одном из следующих форматов: начальный адрес и конечный адрес или начальный адрес и длина (обозначаемая l) диапазона. Например, оба следующих выражения задают диапазон из 16 байтов, начинающийся с адреса CS:100:

    cs:100 10f

    cs:100 l 10

Примеры

Чтобы деассемблировать 16 (10h) байт, начиная с адреса 04BA:0100, введите следующую команду:

u04ba:100l10

Результаты программы Debug.exe выводятся в следующем формате:

04BA:0100 206472 AND [SI+72],AH
04BA:0103 69 DB 69
04BA:0104 7665 JBE 016B
04BA:0106 207370 AND [BP+DI+70],DH
04BA:0109 65 DB 65
04BA:010A 63 DB 63
04BA:010B 69 DB 69
04BA:010C 66 DB 66
04BA:010D 69 DB 69
04BA:010E 63 DB 63
04BA:010F 61 DB 61

Чтобы просмотреть сведения только об адресах с 04BA:0100 по 04BA:0108, введите следующую команду:

u04ba:0100 0108

Программа Debug.exe выводит следующие сведения:

04BA:0100 206472 AND [SI+72],AH
04BA:0103 69 DB 69
04BA:0104 7665 JBE 016B
04BA:0106 207370 AND [BP+DI+70],DH


Debug: w (write)

Запись файла или определенных секторов на диск. При запуске подкоманды w без параметров запись начинается с адреса CS:100.

Синтаксис

w [адрес]

w [адрес] [диск] [первый_сектор] [число]

Параметры

адрес
Задание начального адреса файла или части файла, которые требуется записать на диск.
диск
Задание дисковода, содержащего диск назначения. Данный параметр задается числом: 0 = A, 1 = B, 2 = C и т. д.
первый_сектор
Задание шестнадцатеричного адреса первого сектора для записи.
число
Задание количества секторов, которые требуется записать.
?
Вывод списка подкоманд debug.

Примечания

  • Для записи количества байт, заданного в регистрах BX:CX, в файл на диске используется следующий синтаксис команды:

    w [адрес]

  • Для пропуска файловой системы и прямой записи указанных секторов используется следующий синтаксис команды:

    w [адрес] [диск] [первый_сектор] [число]

  • Задание правильных записей адреса

    Адрес состоит из двух частей: первая содержит буквенное обозначение сегментного регистра или адрес сегмента из четырех цифр, а вторая содержит значение смещения. Адрес сегмента или сегментный регистр могут быть пропущены. По умолчанию для подкоманд a, g, l, t, u и w команды debug адрес сегмента содержится в регистре CS. Для других подкоманд по умолчанию используется сегмент DS. Все числовые значения при этом представлены в шестнадцатеричном формате. Между именем сегмента и значением смещения следует вставлять двоеточие. Следующие адреса являются допустимыми:

    CS:0100

    04BA:0100

  • Имя файла на диске нужно задать при запуске программы Debug.exe или в последней вызванной подкоманде n (name). Оба эти метода правильно форматируют имя файла для блока управления файлом (FCB) по адресу CS:5C.
  • Сброс значений регистров BX:CX перед использованием команды w без параметров.

    Если используются подкоманды g (go), t (trace), p (proceed) или r (register), перед использованием команды w без параметров значения регистров BX:CX необходимо сбросить.

  • Запись измененного файла на диск

    Если файл был изменен, но имя, размер и начальный адрес не менялись, Debug.exe позволяет записать файл в его исходное расположение на диске.

  • Запись файлов .exe или .hex

    Файлы с расширениями .exe и .hex нельзя записать с помощью этой команды.

    Предупреждение!

    • Непосредственная запись в сектор диска является исключительно опасной, так как в этом случае не выполняется дескриптор файла Windows XP. Логическая структура диска может быть повреждена при вводе неверного значения.

Примеры

Чтобы записать содержимое области памяти, начиная с адреса CS:100, на диск B и собрать данные из 2Bh секторов, начиная с логического сектора диска под номером 37h, введите следующую команду:

wcs:100 1 37 2b

После окончания операции записи выводится приглашение программы debug.


Debug: xa (allocate expanded memory)

Выделение заданного количества страниц памяти EMS. Выполненная без параметров подкоманда xa проверяет наличие или отсутствие поддержки дополнительной памяти (EMS).

Синтаксис

xa [число_страниц]

Параметры

число_страниц
Задание числа выделяемых страниц памяти EMS. Размер страницы составляет 16 килобайт.
?
Вывод списка подкоманд debug.

Примечания

  • Система Windows XP не поддерживает память EMS. Для использования памяти EMS на компьютере должен быть установлен драйвер памяти EMS, поддерживающий версию 4.0 спецификации Lotus/Intel/Microsoft Expanded Memory Specification (LIM EMS).
  • Если запрашиваемое количество страниц доступно, Debug.exe выводит сообщение о шестнадцатеричном номере созданного дескриптора. В противном случае выводится сообщение об ошибке.

Примеры

Чтобы выделить восемь страниц дополнительной памяти, введите следующую команду:

xa8

Если команда успешно выделит память, выводятся следующие сведения:

Создан дескриптор=0003


Debug: xd (deallocate expanded memory)

Освобождение дескриптора памяти EMS. Выполненная без параметров подкоманда xd проверяет наличие или отсутствие поддержки дополнительной памяти (EMS).

Синтаксис

xd [дескриптор]

Параметры

дескриптор
Задание освобождаемого дескриптора.
?
Вывод списка подкоманд debug.

Примечания

  • Система Windows XP не поддерживает память EMS. Для использования памяти EMS на компьютере должен быть установлен драйвер памяти EMS, поддерживающий версию 4.0 спецификации Lotus/Intel/Microsoft Expanded Memory Specification (LIM EMS).

Примеры

Чтобы освободить дескриптор 0003, введите следующую команду:

xd 0003

При успешном выполнении программы Debug.exe будет выведено сообщение:

Дескриптор 0003 освобожден


Debug: xm (мар expanded memory pages)

Отображение логической страницы памяти EMS, соответствующей заданному дескриптору, в физическую страницу памяти EMS. Выполненная без параметров подкоманда xm проверяет наличие или отсутствие поддержки памяти EMS.

Синтаксис

xm [лог_страница] [физ_страница] [дескриптор]

Параметры

лог_страница
Задание номера логической страницы памяти EMS, которая будет отображена в физическую страницу физ_страница.
физ_страница
Задание номера физической страницы памяти EMS, в которую будет отображена логическая страница лог_страница.
дескриптор
Задание дескриптора.
?
Вывод списка подкоманд debug.

Примечания

  • Система Windows XP не поддерживает память EMS. Для использования памяти EMS на компьютере должен быть установлен драйвер памяти EMS, поддерживающий версию 4.0 спецификации Lotus/Intel/Microsoft Expanded Memory Specification (LIM EMS).

Примеры

Чтобы отобразить логическую страницу 5 дескриптора 0003 в физическую страницу 2, введите следующую команду:

xm 5 2 0003

При успешном выполнении программы Debug.exe будет выведено сообщение:

Логическая страница 05 отображена на физическую страницу 02


Debug: xs (display expanded memory status)

Вывод сведений о состоянии памяти EMS.

Синтаксис

xs

Параметры

?
Вывод списка подкоманд debug.

Примечания

  • Для использования памяти EMS на компьютере должен быть установлен драйвер памяти EMS, поддерживающий версию 4.0 спецификации Lotus/Intel/Microsoft Expanded Memory Specification (LIM EMS).
  • Результаты программы Debug.exe выводятся в следующем формате:

    Для дескриптора xx выделено xx страниц
    Физическая страница xx = Сегмент EMS xx
    Выделено xx из xx страниц EMS
    Выделено xx из xx дескрипторов EMS

Примеры

Чтобы вывести сведения о состоянии памяти EMS, введите следующую команду:

xs

Подкоманда xs выводит сведения в следующем виде:

    Handle 0000 has 0000 pages allocated
    Для дескриптора 0001 выделено 0002 страниц

    Физическая страница 00 = Сегмент EMS C000
    Физическая страница 01 = Сегмент EMS C400
    Физическая страница 02 = Сегмент EMS C800
    Физическая страница 03 = Сегмент EMS CC00
       Выделено  2 из 80 страниц EMS
       Выделено 2 из FF дескрипторов EMS


Edlin

Запуск программы Edlin — строкового редактора, позволяющего создавать и редактировать текстовые файлы в формате ASCII.

Синтаксис

edlin [диск:][путь] имя_файла [/b]

Параметры

[диск:][путь] имя_файла
Задает расположение и имя текстового файла на диске. Параметр имя_файла является обязательным. Если файл существует, Edlin открывает его. Если нет — файл будет создан в памяти, а заданное расположение и имя будут использованы для создания файла на диске при вызове подкоманды e редактора.
/b
Задает игнорирование символа конца файла (CTRL+Z).
?
Выводит список подкоманд edlin.

Примечания

  • Использование программы Edlin.exe

    Все строки текстового файла, загруженного в память, нумеруются. Программа Edlin.exe позволяет осуществлять вставку, изменение, копирование, перемещение и удаление строк. Для редактирования в полноэкранном режиме используется программа edit.

  • Максимальная длина строки

    В программе Edlin максимально допустимая длина строки составляет 253 символа.

  • Использование подкоманд edlin
  • Использование символа звездочки

    Когда в строке не присутствует других символов, кроме звездочки — это строка приглашения программы edlin для ввода подкоманд. Когда этот же символ изображен после номера строки, он указывает на то, что в данной строке расположен курсор.

  • Отображение страницы текста.

    Страницей считается экран, заполненный текстом. В режиме отображения 25-ти строк редактор выводит по 24 строки текста на страницу. Если используется режим с другим количеством строк на экране, количество строк на странице также будет изменено.

  • Включение и отключение режима вставки

    Для вставки строк в редактируемый файл используется команда i (Insert). После того как необходимое количество строк вставлено, нажмите клавишу ENTER, а затем — сочетание клавиш CTRL+C для выключения режима вставки.

  • Клавиши редактирования

    Имеется ряд клавиш, которые можно использоввать для редактирования загруженного в память файла.


Edlin: a (append)

Загрузка части файла, если недостаток памяти не позволяет загрузить файл целиком. При использовании без параметров данная команда загружает строки из файла на диске до тех пор, пока память не окажется заполнена на 75%. Если 75 процентов памяти уже занято, не будет загружено ни одной строки.

Синтаксис

[число]a

Параметры

число
Задает количество строк, которые будут загружены в память программой Edlin.
?
Выводит список подкоманд edlin.

Примечания

  • При запуске программы Edlin в память загружается столько строк файла, сколько позволяет объем свободной памяти. Если размер файла больше, чем объем свободной памяти, файл следует редактировать в несколько этапов. Вначале редактируется первая часть файла, затем она записывается на диск с помощью подкоманды w (write), после чего загружается следующая часть файла.
  • После загрузки в память с помощью подкоманды a последней строки файла будет выведено следующее сообщение:

    Конец входного файла

Примеры

Предположим, что последние 100 строк редактируемого файла не поместились в памяти. После внесения изменений в первую часть файла ее следует сохранить на диске. Теперь, чтобы загрузить в память оставшиеся 100 строк, введите:

100a


Edlin: c (copy)

Копирует блок последовательно расположенных строк в другое место внутри редактируемого файла. Данная операция может быть выполнена несколько раз.

Синтаксис

[строка1],[строка2],строка3,[число_опер]c

Параметры

строка1
Задает первую строку для копирования.
строка2
Задает последнюю строку для копирования.
строка3
Обязательный параметр. Задает номер строки назначения, перед которой будут помещены копируемые строки.
число_опер
Задает количество операций копирования.

Примечания

  • Пропуск значений параметров

    Если пропущен параметр строка1 или строка2, будет скопирована только текущая строка. Если пропущен какой-либо параметр, запятые в строке вызова команды все равно должны присутствовать. Кроме того, необходимо указать номер строки назначения.

    При пропуске параметра число_опер копирование выполняется один раз.

  • Изменение нумерации строк

    Для просмотра новой нумерации строк после копирования следует ввести подкоманду l (list) в командную строку вида *.

  • Копирование с перекрытием

    Номер строки, заданный параметром строка3, не может находиться внутри набора копируемых строк. В этом случае операция копирования не будет выполнена полностью и на экран будет выведено следующее сообщение:

    Ошибка ввода

Примеры

Чтобы один раз скопировать строки с первой по пятую, разместив их начиная с шестой страницы, введите:

1,5,6c

В результате строки с 6 по 10 становятся такими же, как строки с 1 по 5.

Чтобы скопировать текущую строку в строку 5, введите:

,,5c

Чтобы ознакомиться с ссобщением об ошибке, возникающем при копировании с перекрытием, введите:

3,20,15c


Edlin: d (delete)

Удаление заданного блока последовательно расположенных строк. При использовании без параметров команда d удаляет текущую строку.

Синтаксис

[строка1][,строка2]d

Параметры

строка1
Задает номер первой строки для удаления.
строка2
Задает номер последней строки для удаления.
?
Выводит список подкоманд команды edlin.

Примечания

  • Пропуск значений параметров

    Если пропущен параметр строка2 или оба параметра, будет удалена текущая строка. В тоже время, если будет пропущен только параметр строка1, то удалены будут строки, начиная с текущей строки и до строки строка2. При этом значение параметра строка2 не может быть меньше, чем номер текущей строки. Число, указанное в качестве значения параметра строка2, не может быть меньше значения параметра строка1. Если пропущен только параметр строка1, необходимо вставить заменяющую его запятую перед параметром строка2, как показано в описании синтаксиса команды.

  • Изменение нумерации строк

    Для просмотра новой нумерации оставшихся после удаления строк следует ввести подкоманду l (list) в командную строку вида *.

Примеры

Чтобы удалить строку 7, введите:

7d

Чтобы удалить текст на участке с 22-ой по 32-ую строку, введите:

22,32d

Предположим, что строка номер 7 является текущей. Следующая команда вызовет удаление строк с текущей по одиннадцатую:

,11d


Edlin: e (end)

Переименовывает исходную версию редактируемого файла на диске в резервный файл с расширением .bak, заменяя ее версией в текущей редакции и заканчивает работу программы.

Синтаксис

e

Параметры

отсутствуют

Примечания

  • Если редактируемый файл не был загружен с диска, а создан программой Edlin, резервная копия (с расширением .bak) не будет создаваться.
  • Редактируемый файл записывается в то место на диске, которое было задано при запуске программы Edlin. Если имя диска пропущено, файл будет записан на текущий диск. Если имя каталога пропущено, файл будет записан в текущий каталог.
  • Перед использованием подкоманды e необходимо удостовериться в наличии на диске свободного места, достаточного для сохранения редактируемого файла. В противном случае, часть файла может быть потеряна.
  • Если при сохранении редактируемого файла на диске резервная копия (файл с расширением .BAK) оказывается защищенным от записи, будет выведено сообщение о невозможности заменить .BAK файл:

    Нет доступа - [диск:][путь] имя_файла.bak

    При этом сам файл и его копия не изменятся.


Edlin: i (insert)

Вставляет строки перед заданой строкой редактируемого файла. При использовании команды i без параметров вставка производится в текущую строку.

Синтаксис

i [строка]

Параметры

строка
Задает номер строки, перед которой будет сделана вставка. Значением параметра строка по умолчанию является текущая строка.

Примечания

  • Использование подкоманды i

    При создании нового файла команда i должна быть выполнена перед добавлением новых строк. При каждом нажатии на клавишу ENTER будет выводиться номер следующей строки. Чтобы выйти из режима вставки, используйте сочетание клавиш CTRL+C.

  • Изменение нумерации строк

    При выходе из режима вставки последняя вставленная строка становится текущей. Для просмотра обновленной нумерации следует ввести подкоманду l (list) в командную строку вида *.

  • Управляющие символы

    Чтобы вставить в текст управляющий символ, введите:

    ^V символ_ASCII

    Параметр символ_ASCII указывает на соответствующий символ, служащий управляющим символом. Например, символ ESC (CTRL+[) может быть введен следующим образом:

    ^V[

    Управляющий символ "гудок" (CTRL+G) может быть введен следующим образом:

    ^VG

  • Добавление текста

    Если значение параметра строка превосходит число строк в редактируемом файле или если для параметра строка указан символ (#), Edlin добавляет вставляемые строки в конец файла. В любом случае, последняя вставленная строка становится текущей. Если в память загружена только часть файла, строки будут добавлены в конец этой части.

Примеры

После использования подкоманды l на экране появляется следующий текст:

1: Уважаемый г. Мутный:
2:
3: Поздравляю с назначением
4: на должность старшего
5: инженера. Нахожусь под большим
6: впечатлением от результатов Вашей работы.
7:
8: С уважением,
9:
10: Профессор Григорий

Для добавления строк перед строкой номер 8 введите:

8I

Программа Edlin.exe выведет на экран следующее:

8:*_

В строке 8 введем следующий текст, начиная с позиции курсора:

8:*Я думаю, Вам будет приятно работать с

Закончив набор каждой новой строки, нажимайте клавишу ENTER. Введите теперь:

9: *доктором Чекушкиным над новым проектом. Пожалуйста
10: *сообщите
11: *чем я могу Вам помочь.

Программа Edlin.exe выведет на экран следующее:

12:*_

Вставим пустую строку нажатием клавиши ENTER и завершим работу в режиме вставки, использовав сочетание клавиш CTRL+C в следующей строке. Введите команду 1l для просмотра обновленной нумерации строк:

1: Уважаемый г. Мутный:
2:
3: Поздравляю с назначением
4: на должность старшего
5: инженера. Нахожусь под большим
6: впечатлением от результатов Вашей работы.
7:
8: Я думаю, для Вас будет приятно работать с
9: доктором Чекушкиным над новым проектом. Пожалуйста
10: сообщите
11: чем я могу Вам помочь.
12:
13: *С уважением,
14:
15: Профессор Григорий


Edlin: l (list)

Выводит на экран заданый набор строк. При использовании команды l без параметров на экран выводится до одной страницы с текстом, начинающимся за 11 строк до текущей строки.

Синтаксис

l [строка1][,строка2]

Параметры

строка1
Задает первую строку, выводящуюся на экран программой Edlin.exe.
строка2
Задает последнюю строку, выводящуюся на экран программой Edlin.exe.
?
Выводит список подкоманд команды edlin.

Примечания

  • Пропуск значений параметров

    Оба параметра или один из параметров строка1 и строка2 могут быть пропущены. Следующий список содержит значения по умолчанию для каждого такого случая.

    • Если пропущен только параметр строка1, на экран будет выведено до 1 страницы текста (то есть, весь экран будет им заполнен), начинающейся на 11 строк раньше текущей строки и заканчивающейся строкой, задаваемой параметром строка2. Если пропущен только параметр строка1, обязательно должна быть введена заменяющая его запятая.
    • Если пропущен только параметр строка2, на экран будет выведено до страницы текста, начиная со строки, заданной параметром строка1.
    • Если подкоманда l (List) используется без параметров, на экран будет выведено до страницы текста, начинающейся на 11 строк раньше текущей строки. При установке драйвера дисплея Ansi.sys количество выводимых на одной странице строк зависит от типа используемого дисплея. Это число может быть больше 24.
  • Работа с большими фрагментами текста

    Если текстовый блок превосходит объем одной страницы, вначале будет выведена первая страница, а затем следующее сообщение, позволяющее управлять просмотром оставшейся части текста:

    Продолжить [Y(да)/N(нет)]?

    При каждом ответе "Да" на экран выводится еще одна страница.

Примеры

Следующая команда выведет строки с 5 по 10:

5,10l


Edlin: [line]

Выводит строку с заданным номером на экран.

Синтаксис

[строка]

Параметры

строка
Задает номер строки для вывода на экран. Для вывода номера и содержимого текущей строки нажмите клавишу ENTER.
?
Выводит список подкоманд edlin.

Примечания

  • Если в качестве команды введен номер строки, на экран будут выведены две строки. Первая содержит номер строки и относящейся к строке текст. Вторая содержит номер строки и курсор. Первая строка служит шаблоном для редактирования строки текста во второй строке экрана. Текст может быть заменен, отредактирован, либо оставлен без изменений, для чего нажимается клавиша ENTER без ввода нового текста. После редактирования строки нажмите клавишу ENTER для записи изменений в память.

    Внимание!

    • Если клавиша ENTER была нажата, когда курсор находился в середине строки, часть строки, находящаяся правее курсора, будет удалена.

Примеры

В этом примере файл загружен в память и допускает редактирование. При использовании подкоманды l программа Edlin.exe выводит на экран содержимое файла.

1: Уважаемый г. Федоров:
2:
3: Поздравляю с назначением
4: на должность старшего
5: инженера. Нахожусь под большим
6: впечатлением от результатов Вашей работы.

Чтобы отредактировать строку 6, введите:

6

Программа Edlin.exe выведет на экран следующее:

6:* впечатлением от результатов Вашей работы.
6:*_

Первая строка содержит номер указанной строки и соответствующий текст. Вторая строка содержит тот же номер и курсор.

Чтобы вставить слово "отличной" перед словом "работы" (см. предыдущий пример), следует добиться повторного вывода после курсора на второй строке части первой строки. Для этого вначале нажмите клавишу F2, затем, введите р. Будут выведены символы от начала шестой строки до первого символа «р», как показано ниже:

6:* впечатлением от _

Нажмите клавишу F2 и снова введите р. На экран будет выведена строка вплоть до следующей буквы "р", как показано ниже:

6:* впечатлением от результатов Вашей _

Нажмите клавишу INSERT, введите отличной, нажмите клавишу ПРОБЕЛ, а затем — клавишу F3. Программа выведет на экран редактируемую строку:

6:* впечатлением от результатов Вашей отличной работы.

Нажмите клавишу ENTER для подтверждения изменений.

Для просмотра измененного файла после приглашения * введите подкоманду l (list). Программа Edlin.exe выведет на экран следующее:

1: Уважаемый г. Федоров:
2:
3: Поздравляю с назначением
4: на должность старшего
5: инженера. Нахожусь под большим
6*: впечатлением от результатов Вашей отличной работы.


Edlin: m (move)

Перемещает блока последовательно расположенных строк на другое место в редактируемом файле.

Синтаксис

[строка1],[строка2],строка3 m

[строка1],[+n],строка3 m

Параметры

строка1
Задает номер первой строки для перемещения.
строка2
Задает номер последней строки для перемещения.
строка3
Обязательный параметр. Задает номер строки, перед которой будут помещены перемещаемые строки.
+n
Задает число строк в перемещаемом блоке, начинающемся со строки строка1 и включающего следующие n строк. Если опущен параметр строка1, текстовый фрагмент будет вставлен в текущую строку.

Примечания

  • Изменение нумерации строк

    Для просмотра обновленной нумерации можно использовать команду l.

  • Перемещение с перекрытием

    Номер строки, заданный параметром строка3, не может находиться внутри набора перемещаемых строк. Например, следующая команда будет ошибочной:

    5,100,8m

    В этом случае операция перемещения не может быть выполнена полностью и на экран будет выведено сообщение:

    Ошибка ввода

Примеры

В этом примере файл загружен в память и допускает редактирование. При использовании подкоманды l программа Edlin.exe выводит на экран содержимое файла.

1: Уважаемый г. Федоров:
2:
3: Поздравляю с назначением
4: на должность старшего
5: инженера. Нахожусь под большим
6: впечатлением от результатов Вашей отличной работы.
7:
8: Я думаю, для Вас будет приятно работать с
9: доктором Петровым над новым проектом. Пожалуйста
10: сообщите
11: чем я могу Вам помочь.
12:
13: С уважением,
14:
15: Профессор Бондаренко
16: ООО Контеско
17: мировой лидер в химической технологии

Чтобы переместить название и девиз компании в начало (то есть, поставить строки 16 и 17 перед строкой 1), введите:

16,17,1m

Для просмотра измененного файла после приглашения * введите подкоманду l (list). Программа Edlin.exe выведет на экран следующее:

1: ООО Контеско
2: мировой лидер в химической технологии
3: Уважаемый г. Федоров:
4:
5: Поздравляю с назначением
6: на должность старшего
7: инженера. Нахожусь под большим
8: впечатлением от результатов Вашей отличной работы.
9:
10: Я думаю, для Вас будет приятно работать с
11: доктором Петровым над новым проектом. Пожалуйста
12: сообщите
13: чем я могу Вам помочь.
14:
15: С уважением,
16:
17: Профессор Бондаренко

Чтобы переместить блок строк, начинающийся с текущей строки и заканчивающийся через 25 строк, перед строкой 100, введите:

,+25,100m


Edlin: p (page)

Производит постраничное отображение файла или его части (т. е. по одному полному экрану текста). Если параметры не указаны, команда p отобразит страницу текста, начиная со строки, следующей за текущей.

Синтаксис

[строка1][, строка2]p

Параметры

строка1
Указывает первую строку, которую требуется вывести на экран программой Edlin.exe.
строка2
Указывает последнюю строку, которую требуется вывести на экран программой Edlin.exe.
?
Отображает список подкоманд команды edlin.

Примечания

  • Последняя выведенная на экран строка становится текущей для нового экрана.
  • Пропуск параметров

    Когда пропущен параметр строка1, программа Edlin.exe выведет страницу текста с текущей строки по строку, задаваемую параметром строка2. Когда пропущен параметр строка2, программа Edlin.exe выведет страницу текста со строки, задаваемой параметром строка1. Когда пропущены оба параметра строка1 и строка2, программа Edlin.exe выведет страницу текста со строки, следующей за текущей.

Примеры

Для постраничного просмотра текста со строки с номером 100 по строку с номером 200 введите:

100,200p


Edlin: q (quit)

Останавливает работу программы Edlin без записи редактируемого файла на диск.

Синтаксис

q

Параметры

нет параметров

Примечания

  • Для записи редактируемого файла из памяти на диск перед окончанием работы программы следует использовать подкоманду e (end).


Edlin: r (replace)

Осуществляет поиск в блоке текста строки из одного или более указанных символов и заменяет каждое ее вхождение другой указанной строкой.

Синтаксис

[строка1][,строка2][?]r[строка_поиска][CTRL+Z строка_замены]

Параметры

строка1
Задает первую строку блока текста, в котором будет производиться замена строки строка_поиска.
строка2
Задает последнюю строку блока текста, в котором будет производиться замена строки, заданной параметром строка_поиска.
?
Запрашивает подтверждение перед тем, как программа Edlin.exe выполнит замену вхождения строки, заданной параметром строка_поиска.
строка_поиска
Задает строку, которую следует найти и заменить.
CTRL + Z
Эта комбинация клавиш отделяет значения параметров строка_поиска и строка_замены. В качестве разделителя должен быть использован только символ конца файла (CTRL+Z), который на экране будет выглядеть как ^Z.
строка_замены
Задает новую строку, которая будет вставлена в текст вместо строки, заданной параметром строка_поиска.

Примечания

  • Последней строкой, в которой программой Edlin.exe производится замена строки строка_поиска, является новая текущая строка.
  • Использование пробелов в командной строке

    Не допускается ввод пробелов между командой r и ее параметрами.

  • Пропуск параметров

    Если параметр строка1 не задан, программа Edlin.exe начинает поиск со строки, следующей за текущей. Если параметр строка2 не задан, программа Edlin.exe закончит поиск в последней строке файла или части файла, которая находится в памяти.

    Если параметр строка_поиска не задан, программа Edlin.exe будет использовать строку, заданную в параметре строка_поиска1 при последнем использовании подкоманд r или s в течение этого сеанса. Если параметр строка_поиска не задан и подкоманды r или s не были использованы в течение текущего сеанса, подкоманда r будет немедленно остановлена.

    Если не был задан параметр строка_замены, программа Edlin.exe будет использовать последнее значение этого параметра для команды r в течение текущего сеанса. Если параметр строка_замены не задан, а команда r в течение текущего сеанса редактирования не применялась, программа Edlin.exe удалит все вхождения строки, заданной параметром строка_поиска, в заданном блоке текста.

  • Использование сочетания клавиш CTRL+Z

    Следует разделять значения параметров строка_поиска и строка_замены с помощью сочетания клавиш CTRL+Z. Даже если параметр строка_поиска был пропущен, следует нажать клавиши CTRL+Z для обозначения начала параметра строка_замены. При нажатии клавиш CTRL+Z, на экране появятся следующие символы.

    ^Z

  • Использование знака вопроса (?)

    Если параметр ? включен в команду, программа Edlin.exe отобразит строку с первым вхождением строки, заданной параметром строка_поиска, и выведет следующий запрос о подтверждении замены.

    O.K.? _

    При нажатии клавиш Y или ENTER программа Edlin.exe произведет замену вхождения строки_поиска на строку_замены и продолжит поиск следующего вхождения. При нажатии клавиши N замена данного появления строки_поиска производиться не будет и редактор продолжит поиск дальше по тексту.

    Если для подтверждения замен параметр ? не использовался, программа Edlin.exe произведет все замены строки_поиска за один раз и затем выведет на экран строки, в которых были сделаны замены. Если в одной строке было произведено несколько замен, программа выведет эту строку один раз для каждой произведенной замены.

Примеры

Чтобы заменить каждое вхождения слова «mine» на слово «ours» в первых 20 строках редактируемого файла и получить запрос на подтверждение замены, введите следующую команду, но не нажимайте клавишу ENTER.

1,20?rmineCTRL+Zours

CTRL+Z отображается на экране как ^Z. Команда отображается на экране следующим образом:

1,20?rmine^Zours

В этом примере файл, загруженный в память для редактирования, выглядит как показано ниже. При использовании подкоманды l (list — список) программа Edlin.exe выводит на экран содержимое файла.

1: Dear Mr. Muth:
2:
3: Congratulations on your promotion
4: to the position of Senior Chemical
5: Engineer. I continue to be most
6: impressed with your fine work.
7:
8: I think you will enjoy working with
9: Mr. Lang on the new project. Please
10: let me know if there is anything I
11: can do to assist you.
12:
13: Sincerely,
14:
15: Clay Martin, President
16: Contoso, Ltd
17: "A World Leader in Technology"

Чтобы заменить все вхождения слова «I» на слова «yours truly» в строках с 5 по 10 без получения запроса на подтверждение удаления, введите следующее.

5,10rICTRL+Zyours truly

CTRL+Z отображается на экране как ^Z. Команда отображается на экране следующим образом:

5,10rI^Zyours truly

Так как параметр ? не использовался, все три замены будут произведены программой Edlin.exe без запроса на подтверждение удаления. Когда команда будет выполнена, на экран будут выведены строки, получившиеся после произведения замен.

5: Engineer. yours truly continue to be most
8: yours truly think you will enjoy working with
10: let me know if there is anything yours truly

В приведенном выше примере произведено две непредусмотренные замены в строках 5 и 8. Чтобы избежать этого, добавьте в команду параметр ?. Окончательный вид команды будет следующим:

5,10?rI^Zyours truly

Теперь для каждого вхождения строки, заданной параметром строка_поиска, будет выводиться запрос на подтверждение удаления и будут выполняться только подтвержденные замены, как показано ниже.

5: Engineer. yours truly continue to be most
O.K.? n
8: yours truly think you will enjoy working with
O.K.? n
10: let me know if there is anything yours truly
O.K.? y

Когда используется параметр ? измененные строки не будут автоматически выведены на экран. Для просмотра изменений может быть использована подкоманда l (list). Программа Edlin.exe отобразит отредактированный файл, который будет иметь следующий вид.

1: Dear Mr. Muth:
2:
3: Congratulations on your promotion
4: to the position of Senior Chemical
5: Engineer. I continue to be most
6: impressed with your fine work.
7:
8: I think you will enjoy working with
9: Mr. Lang on the new project. Please
10: let me know if there is anything yours truly
11: can do to assist you.
12:
13: Sincerely,
14:
15: Clay Martin, President
16: Contoso, Ltd
17: "A World Leader in Technology"


Edlin: s (search)

Производит поиск файла по заданной строке.

Синтаксис

[строка1][,строка2][?]s[строка_поиска]

Параметры

строка1
Задает первую строку области поиска.
строка2
Задает последнюю строку области поиска.
?
Запрашивает подтверждение перед тем, как программа Edlin.exe найдет первое вхождение строки, заданной параметром строка_поиска.
строка_поиска
Задает строку, которую необходимо найти в тексте. При вызове команды s дополнительные пробелы перед этим параметром недопустимы, так как они будут рассматриваться как часть строки поиска.

Примечания

  • Программа Edlin.exe выведет на экран все строки в заданной области файла, содержащие строку поиска. После того, как первое вхождение найдено, процесс поиска останавливается и строка, содержащая строку_поиска становится текущей.
  • Пропуск параметров

    Если параметр строка1 не задан, программа Edlin.exe начинает поиск со строки, следующей за текущей. Если параметр строка2 не задан, поиск будет закончен в последней строке файла.

    Если параметр строка_поиска не задан, программа Edlin.exe будет использовать строку, заданную в параметре строка_поиска1 при последнем использовании подкоманд r или s в течение этого сеанса. Если параметр строка_поиска не задан и подкоманды r или s не были использованы в течение текущего сеанса, подкоманда s будет немедленно остановлена.

  • Использование параметра ?

    Если параметр ? включен в команду, программа Edlin.exe отобразит строку с первым вхождением строки, заданной параметром строка_поиска, и выведет следующий запрос о подтверждении.

    O.K.? _

    При нажатии клавиш Y или ENTER строка, выведенная перед сообщением, становится текущей и поиск останавливается. При нажатии клавиши N поиск будет продолжен до тех пор, пока строка поиска не будет найдена снова или пока не появится сообщение следующего вида, информирующее о просмотре всех заданных строк.

    Не найден

Примеры

В этом примере файл, загруженный в память для редактирования, выглядит как показано ниже. При использовании подкоманды l (list — список) программа Edlin.exe выводит на экран содержимое файла.

1: Dear Mr. Muth:
2:
3: Congratulations on your promotion
4: to the position of Senior Chemical
5: Engineer. I continue to be most
6: impressed with your fine work.
7:
8: I think you will enjoy working with
9: Mr. Lang on the new project. Please
10: let me know if there is anything I
11: can do to assist you.
12:
13: Sincerely,
14:
15: Clay Martin, President

Чтобы задать поиск в строках со 2 по 12 первого появления слова «to», введите следующую команду:

2,12sto

Программа Edlin.exe выведет следующую строку.

4: to the position of Senior Chemical

Чтобы отобразить строку с первым вхождением слова «to» и получить запрос на подтверждение, введите:

1,?sto

Программа Edlin.exe выведет следующие строки.

4: to the position of Senior Chemical
O.K.? _

Если будет нажата любая клавиша, отличная от Y или ENTER, поиск будет продолжен. Например, если введен символ N, как показано ниже:

O.K.? n

Программа Edlin.exe продолжит поиск до следующей строки и выведет на экран следующее.

5: Engineer. I continue to be most
O.K.? _

Для окончания поиска нажмите клавишу Y.


Подкоманды Edlin

Для получения дополнительных выберите одну из ссылок.

  • Edlin: [line]
  • Edlin: a (append)
  • Edlin: c (copy)
  • Edlin: d (delete)
  • Edlin: e (end)
  • Edlin: i (insert)
  • Edlin: l (list)
  • Edlin: m (move)
  • Edlin: p (page)
  • Edlin: q (quit)
  • Edlin: r (replace)
  • Edlin: s (search)
  • Edlin: t (transfer)
  • Edlin: w (write)


Edlin: t (transfer)

Производит объединение редактируемого файла с другим файлом на диске.

Синтаксис

[строка]t[диск:][путь] имя_файла

Параметры

строка
Задает номер строки, перед которой будет вставлено содержимое другого файла. Значением по умолчанию является текущая строка.
[диск:][путь] имя_файла
Задает размещение и имя файла, который требуется вставить перед строкой, заданной параметром строка. Параметр имя_файла является обязательным. По умолчанию считается, что диск является текущим диском, а путь указывает на текущий каталог.

Примечания

  • Для просмотра обновленной нумерации строк после объединения файлов может быть использована команда Edlin l (list).

Примеры

Для того чтобы вставить содержимое файла Taxes.mem в строку номер 12 редактируемого файла, введите:

12t taxes.mem


Edlin: w (write)

Производит запись первой части редактируемого файла на диск. Если команда w используется без параметров, то запись из редактируемого файла на диск производится до тех пор, пока не заполнится 25 процентов памяти.

Синтаксис

[число_строк]w

Параметры

число_строк
Задает количество строк, которые будут записаны на диск. Запись начинается с первой строки, находящейся в памяти.
?
Отображает список подкоманд команды edlin.

Примечания

  • При запуске программы Edlin в память загружается столько строк файла, сколько позволяет объем свободной памяти. Если размер файла больше, чем объем свободной памяти, следует редактировать файл в несколько этапов. Если редактируется часть файла, то для ее записи на диск используется подкоманда w, а для загрузки следующей части — подкоманда a (append).
  • При загрузке файла программа Edlin считывает строки с диска в память до тех пор, пока не будет заполнено 75 процентов памяти. Оставшиеся 25 процентов резервируются для сохранения добавлений, сделанных в процессе редактирования. Если файл полностью поместился в памяти, на экран будет выведено следующее сообщение.

    Конец входного файла

    Если это сообщение появилось в процессе загрузки, то необходимости в использовании подкоманд w и a (append) нет.

    Если же такого сообщения не было выведено на экран, это означает, что файл не поместился в памяти полностью. Следует производить редактирование по частям, с использованием команд w и a для записи очередной редактируемой части файла и загрузки следующей части соответственно.

    Команда w не производит записи на диск изменений в случае, когда в этом нет необходимости. При использовании команды w для файла, целиком разместившегося в памяти, после выхода из редактора edlin с помощью команды q (quit) изменения не будут сохранены.

  • Изменение нумерации строк

    После записи программой edlin первой части файла на диск можно использовать команду l (list) для просмотра нумерации оставшихся строк, начиная со строки номер 1.

Примеры

Предположим, что последние 100 строк редактируемого файла не поместились в памяти. Чтобы освободить достаточно пространства для загрузки оставшейся части файла и продолжить редактирование, введите:

125w


Net accounts

Служит для обновления базы учетных данных пользователей, изменения паролей и параметров подключения для всех пользователей.

Синтаксис

net accounts [/forcelogoff:{минуты | no}] [/minpwlen:длина] [/maxpwage:{дни | unlimited}] [/minpwage:дни] [/uniquepw:число] [/domain]

Параметры

/forcelogoff:{минуты | no}
Время ожидания в минутах перед отключением пользователя от сервера в случае, если период действия пользовательского имени закончился или истекло время, выделенное для подключения. Используемое по умолчанию правило no не позволяет пользователям принудительно выходить из системы.
/minpwlen:длина
Минимальная длина пользовательского пароля. Допустимы значения от 0 до 127 знаков, по умолчанию используется значение 6 знаков.
/maxpwage:{дни | unlimited}
Период времени в днях, в течение которого будет действовать пароль пользователя. Значение unlimited снимает ограничение по времени. Значение параметра /maxpwage должно быть больше, чем значение параметра /minpwage. Допустимы значения от 1 до 49 710 дней (т. е. значение unlimited равно 49 710 дней), по умолчанию используется значение 90 дней.
/minpwage:дни
Минимальное количество дней, которые должны пройти перед сменой пароля пользователем. По умолчанию используется нулевое значение, т. е. ограничение отсутствует. Допустимы значения от 0 до 49 710 дней.
/uniquepw:число
Запрет на повторное использование заданного числа последних паролей. Допустимы значения от 0 до 24, по умолчанию запрещено использование пяти последних паролей.
/domain
Выполнении операции на основном контроллере текущего домена. В противном случае операция осуществляется на локальном компьютере.
net help команда
Отображение справки для указанной команды net.

Заметки

  • На компьютере, для которого будут изменяться учетные параметры, должна быть запущена служба входа в сеть (Net Logon). Команда net accounts без параметров служит для вывода текущих параметров пароля, параметров входа в систему и сведений о домене.
  • Перед использованием команды net accounts необходимо выполнить следующие действия.
    • Создать учетные записи пользователей Для этого следует воспользоваться диспетчером пользователей или командой net user.
    • Запустить службу Net Logon на всех серверах, проверяющих вход в домен. Эта служба запускается автоматически при загрузке компьютера.
  • При использовании параметра /forcelogoff:минуты за указанное количество минут перед принудительным выходом из сети пользователю отправляется сообщение. Пользователи также получают уведомления об открытых файлах. Если число минут меньше двух, сообщение пользователю будет отправлено немедленно.

Примеры

Чтобы вывести текущие параметры, требования для пароля и роль сервера для определенного компьютера, введите:

net accounts

Чтобы задать длину пароля не менее 7 знаков, введите:

net accounts /minpwlen:7

Чтобы запретить повторное использование последних пяти паролей, введите:

net accounts /uniquepw:5

Чтобы разрешить пользователю менять пароль не чаще, чем раз в 7 дней, принудительно изменять пароль раз в 30 дней, а также задать 5-минутное ожидание перед принудительным отключением с отправкой сообщения, введите:

net accounts /minpwage:7 /maxpwage:30 /forcelogoff:5

Чтобы гарантировать действие вышеуказанных параметров во всем домене, к которому принадлежит компьютер, введите:

net accounts /minpwage:7 /maxpwage:30 /domain


Обзор служб Net

Многие службы используют сетевые команды, начинающиеся со слова net. Эти команды net имеют некоторые общие свойства.

  • Чтобы просмотреть список всех доступных команд net, введите net /? в командной строке.
  • Чтобы получить справку о синтаксисе команды net, введите в командной строке net help команда. Например, чтобы получить справку о команде net accounts, введите:

    net help accounts

  • Все команды net поддерживают использование параметров командной строки /y (да) и /n (нет). Например, команда net stop server запрашивает подтверждение на остановку всех зависимых служб «Сервер», а команда net stop server /y автоматически получает подтверждение и, не выводя запрос, останавливает службу «Сервер».
  • Если имя службы содержит пробелы, его следует заключать в кавычки (т. е. "имя службы"). Например, следующая команда запускает службу сетевого входа в систему.

    net start "Сетевой вход в систему"


Net computer

Служит для добавления или удаления имени компьютера из базы данных домена.

Синтаксис

net computer \\имя_компьютера {/add | /del}

Параметры

\\имя_компьютера
Имя компьютера для добавления или удаления из домена.
{/add | /del}
Добавление или удаление указанного компьютера из базы данных домена.
net help команда
Отображение справки для указанной команды net.

Заметки

  • Команда Net computer пересылает все добавления и удаления компьютера на контроллер домена.

Примеры

Чтобы добавить компьютер Grizzlybear в домен, введите:

net computer \\grizzlybear /add


Net config

Служит для вывода сведений о запущенных настраиваемых службах, а также просмотра и изменения параметров службы «Сервер» или «Рабочая станция». Команда net config без параметров выводит список настраиваемых служб.

Синтаксис

net config [{server|workstation}]

Параметры

server
Отображение и изменение параметров службы «Сервер», если она запущена.
workstation
Отображение и изменение параметров службы «Рабочая станция», если она запущена.
/?
Отображение справки в командной строке.

Заметки

  • Команда net config server служит для настройки параметров службы «Сервер». Изменения вступают в силу немедленно и являются постоянными.
  • Команда net config server позволяет изменять не все параметры службы «Сервер». Команда net config server выводит следующие сведения, которые нельзя изменить:
    • Имя сервера
    • Комментарий для сервера
    • Версия программы
    • Активный сервер на (описание сети)
    • Скрытый сервер (параметр /hidden)
    • Максимальное число пользователей (максимальное количество пользователей, могущих использовать общие ресурсы этого сервера)
    • Максимальное число открытых файлов в сеансе (максимальное количество файлов сервера, которое пользователь может открыть в течение сеанса)
    • Время холостого хода сеанса (мин)
  • Команда net config workstation служит для настройки параметров службы «Рабочая станция».
  • Команда Net config workstation выводит следующие сведения:
    • Имя компьютера
    • Полное имя компьютера
    • Имя пользователя
    • Активная рабочая станция на (описание сети)
    • Версия программы
    • Домен рабочей станции
    • DNS-имя домена рабочей станции
    • Домен входа
    • Интервал ожидания открытия COM-порта (с)
    • Отсчет передачи COM-порта (байт)
    • Таймаут передачи COM-порта (мс)


Net continue

Служит для возобновления работы службы, приостановленной командой net pause.

Синтаксис

net continue служба

Параметры

служба
Обязательный параметр. Служба, работу которой требуется возобновить. В следующей таблице приведены некоторые значения службы.
Значение | Описание
netlogon | Возобновление работы службы «Сетевой вход в систему».
"Поставщик поддержки безопасности NT LM" | Возобновление работы службы «Поставщик поддержки безопасности NT LM».
schedule | Возобновление службы «Планировщик заданий»
server | Возобновление работы службы «Сервер».
workstation | Возобновление работы службы «Рабочая станция».
net help команда
Отображение справки для указанной команды net.

Заметки

  • Чтобы внести незначительные изменения в ресурс, приостановите работу службы. После этого можно использовать команду net continue для повторной активации службы или принтера без отключения пользователей.
  • Результат приостановки и активации службы может быть различным для каждой службы.
  • Если имя службы содержит пробелы, его следует заключать в кавычки (например "имя службы").

Примеры

Следующая команда возобновляет работу службы «Рабочая станция».

net continue workstation

Если имя службы состоит из двух или более слов, необходимо заключать его в прямые кавычки. Например, чтобы возобновить работу службы «Поставщик поддержки безопасности NT LM», введите:

net continue "Поставщик поддержки безопасности NT LM"


Net file

Вывод имен открытых общих файлов на сервере и количества блокировок для каждого файла, если они установлены. Также команда позволяет закрыть общий файл и удалить блокировки. Команда net file без параметров выводит список открытых файлов на сервере.

Синтаксис

net file [номер [/close]]

Параметры

номер
Идентификационный номер файла.
/close
Закрытие открытого файла и снятие блокировки. Данная команда запускается на сервере, где находятся общие файлы.
net help команда
Отображение справки для указанной команды net.

Заметки

  • Для запуска этой команды можно ввести net files.
  • Команда net file используется для просмотра и управления файлами, совместно используемыми в сети. Иногда пользователь по ошибке оставляет совместно используемый файл открытым и заблокированным. Когда это происходит, другие компьютеры в сети не могут получить доступ к заблокированным частям файла. Для снятия блокировки и закрытия файлов используется параметр /close команды net file. Команда Net file выводит следующие сведения:

    Код      Путь           Пользователь   # блокировок

    ---------------------------------------------

    0        C:\A_FILE.TXT  MARYSL         0

    1        C:\DATABASE    DEBBIET        2

Примеры

Чтобы просмотреть сведения о совместно используемых файлах, введите:

net file

Чтобы закрыть файл под номером 1, введите:

net file 1 /close


Net group

Добавление, отображение и изменение глобальных групп в доменах.

Синтаксис

net group [имя_группы [/comment:"текст"]] [/domain]

net group [имя_группы {/add [/comment:"текст"] | /delete} [/domain]]

net group [имя_группы имя_пользователя[ ...] {/add | /delete} [/domain]]

Параметры

имя_группы
Имя группы для добавления, удаления или вывода информации. Для вывода списка пользователей в группе задается только имя группы.
/comment:"текст"
Добавление комментария для новой или существующей группы. Комментарий может включать до 48 знаков. Текст следует заключать в кавычки.
/domain
Выполнение операции на контроллере текущего домена. В противном случае операция осуществляется на локальном компьютере.
/add
Добавление группы или имени пользователя в группу. Для пользователей, добавляемых в группу этой командой, необходимо завести учетную запись.
/delete
Удаление группы или пользователя из группы.
имя_пользователя[ ...]
Список из одного или нескольких имен пользователей, которых требуется добавить или удалить из группы. Несколько имен должны быть разделены пробелами.
net help команда
Отображение справки для указанной команды net.

Заметки

  • Команда net group без параметров выводит имя сервера и имена групп на сервере.
  • Также можно ввести команду net groups.
  • Команда net group служит для группирования пользователей, подключаемых к сети со схожими параметрами. Когда группе присваиваются некоторые права, эти права автоматически получают все члены группы. При выводе на экран команда net group предваряет группы, включающие пользователей и группы, звездочкой (*).

    Сведения, выводимые на экран командой net group, имеют следующий вид:

    Учетные записи групп для \\PRODUCTION

    ----------------------------------------------

    *Администраторы домена           *Пользователи домена

Примеры

Чтобы вывести список всех групп на локальном сервере, введите:

net group

Чтобы добавить группу «Exec» в локальную базу учетных записей, введите:

net group exec /add

Чтобы добавить группу «Exec» в базу учетных записей домена, введите:

net group exec /add /domain

Чтобы добавить существующих пользователей «stevev», «ralphr» и «jennyt» в группу «exec», введите:

net group exec stevev ralphr jennyt /add

Чтобы добавить учетные записи существующих пользователей «stevev», «ralphr» и «jennyt» в группу «exec» домена, введите:

net group exec stevev ralphr jennyt /add /domain

Чтобы вывести список пользователей группы «Exec», введите:

net group exec

Чтобы добавить комментарий к группе «Exec», введите:

net group exec /comment:"Руководящий персонал"


Net help

Служит для вывода списка команд и разделов, по которым можно получить справку, либо справки по указанной команде. Команда net help без параметров выводит список команд и разделов, по которым может быть получена справка.

Синтаксис

net help [команда]

Параметры

/help
Отображение синтаксиса и справки по команде.
команда
Команда, справку по которой требуется получить.

Примеры

Чтобы вывести справку по команде net use, введите:

net help use

либо

net use /help

Чтобы просмотреть только синтаксис команды net help, введите:

net help /?


Net helpmsg

Служит для вывода причины возникновения ошибки и инструкций по ее устранению.

Синтаксис

net helpmsg №сообщения

Параметры

№сообщения
Обязательный параметр. Четырехзначный номер сообщения, дополнительные сведения о котором требуется получить.
net help команда
Отображение справки для указанной команды net.

Заметки

  • При возникновении ошибки в ходе сетевой операции на экран будет выведено сообщение, аналогичное следующему:

    2182: Затребованная служба уже запущена.

Примеры

Чтобы получить дополнительные сведения о сообщении об ошибке NET 2182, введите:

net helpmsg 2182


Net localgroup

Добавление, отображение и изменение локальных групп. Команда net localgroup без параметров выводит имя сервера и имена локальных групп компьютера.

Синтаксис

net localgroup [имя_группы [/comment:"текст"]] [/domain]

net localgroup [имя_группы {/add [/comment:"текст"] | /delete} [/domain]]

net localgroup [имя_группы имя [ ...] {/add | /delete} [/domain]]

Параметры

имя_группы
Имя локальной группы для добавления, удаления или раскрытия. При запуске команды net localgroup имя_группы без дополнительных параметров выводится список пользователей или глобальных групп, входящих в локальную группу.
/comment:"текст"
Добавление комментария для новой или существующей группы. Длина комментария может составлять до 48 знаков. Текст следует заключать в кавычки.
/domain
Выполнении операции на основном контроллере текущего домена. В противном случае операция осуществляется на локальном компьютере.
имя [ ...]
Список из одного или нескольких имен пользователей или групп для добавления или удаления из локальной группы.
/add
Добавление глобальной группы или пользователя в локальную группу. Для пользователей или глобальных групп группы, добавляемых в локальную группу, должны иметься учетные записи.
/delete
Удаление группы или пользователя из локальной группы.
net help команда
Отображение справки для указанной команды net.

Заметки

  • Использование параметра /domain

    Параметр /domain применим только к компьютерам Windows XP Professional, являющимся членами домена. По умолчанию серверы осуществляет операции на основном контроллере домена.

  • Использование значения имя

    Несколько имен должны быть разделены пробелами. Имена могут быть именами локальных пользователей, пользователей домена, глобальными группами, но не другими локальными группами. Если задан пользователь другого домена, его имя должно быть введено вместе с именем домена (например Sales\Ralphr).

  • Группировка пользователей

    Команда net localgroup служит для группирования пользователей, подключаемых к сети со схожими параметрами. Когда локальной группе присваиваются некоторые права, эти права автоматически получают все члены группы.

Примеры

Чтобы вывести список всех локальных групп на локальном сервере, введите:

net localgroup

Чтобы добавить локальную группу «Exec» в локальную базу учетных записей пользователей, введите:

net localgroup exec /add

Чтобы добавить локальную группу «Exec» в базу учетных записей пользователей домена, введите:

net localgroup exec /add /domain

Чтобы добавить учетные записи существующих пользователей «stevev», «ralphr» (из домена «Sales») и «jennyt» в группу «exec» локального компьютера, введите:

net localgroup exec stevev sales\ralphr jennyt /add

Чтобы добавить учетные записи существующих пользователей «stevev», «ralphr» и «jennyt» в группу «exec» домена, введите:

net localgroup exec stevev ralphr jennyt /add /domain

Чтобы вывести список пользователей локальной группы «Exec», введите:

net localgroup exec

Чтобы добавить комментарий к локальной группе «Exec», введите:

net localgroup exec /comment:"Руководящий персонал"


Net name

Служит для добавления и удаления синонима (т. е. псевдонима) или вывода списка имен, под которыми компьютер принимает сообщения. Команда net name без параметров выводит список имен, используемых в настоящее время.

Синтаксис

net name [имя {/add|/delete}]

Параметры

имя
Имя для получения сообщений. Имя может содержать до 15 знаков.
/add
Добавление имени.
/delete
Удаление имени.

Заметки

  • Команда net name задает имя для получения сообщений. Прежде чем использовать команду net name, необходимо запустить службу сообщений. Каждое такое имя должно быть уникальным в сети. Имена, созданные командой net name, можно использовать только для обмена сообщениями, а не в качестве имен групп. В Windows XP используются следующие три типа имен:
    • Имя для обмена сообщениями (добавляемое командой net name).
    • Имя компьютера (добавляемое при запуске службы «Рабочая станция»).
    • Имя пользователя (добавляемое при входе в систему, если указанное имя пользователя еще не используется для обмена сообщения в данной сети).
  • Параметр add является необязательным. Команды Net name имя и net name имя add действуют одинаково. Для добавления имени можно использовать любую из этих команд.
  • Имя компьютера нельзя удалить. Но можно удалить имя пользователя.

Примеры

Чтобы вывести список имен локального компьютера, введите:

net name

Чтобы добавить на компьютер имя Rsvp, введите:

net name rsvp

Чтобы удалить имя Rsvp с компьютера, введите:

net name rsvp /delete


Net pause

Служит для приостановки запущенной службы.

Синтаксис

net pause служба

Параметры

служба
Обязательный параметр. Служба, работу которой требуется приостановить. В следующей таблице приведены некоторые значения службы.
Значение | Описание
netlogon | Приостановка службы входа в сеть.
"Поставщик поддержки безопасности NT LM" | Приостановка службы обеспечения защиты NT LM (NT LM Security Support Provider).
schedule | Приостановка службы «Планировщик заданий»
server | Приостановка службы «Сервер».
workstation | Приостановка службы «Рабочая станция».
net help команда
Отображение справки для указанной команды net.

Заметки

  • На сервере команду net pause следует использовать перед остановкой службы, чтобы дать пользователям возможность закончить работу и отключиться от сетевых ресурсов. Служба будет приостановлена, но программное обеспечение останется в памяти. Пользователи, уже работающие со службой, будут иметь возможность закончить работу, но новые пользователи к службе не подключаются.

    Если планируется остановить службу, обеспечивающую доступ к сетевым ресурсам, сначала необходимо ее приостановить. Воспользуйтесь командой net send для рассылки сообщения о грядущей остановке службы. По истечении времени, достаточного для отключения пользователей от ресурсов, воспользуйтесь командой net stop для остановки службы.

    Чтобы возобновить работу приостановленной службы, воспользуйтесь командой net continue.

  • Нельзя приостановить все службы. Приостановка действует на службы следующим образом:
    • Приостановка службы сетевых подключений отключает обработку запросов на подключение к компьютеру. Если в домене есть еще серверы входа в сеть, пользователи могут подключиться к сети.
    • Приостановка службы «Сервер» запрещает подключение в общим ресурсам сервера новых пользователей. Если в сети нет других серверов входа в сеть, пользователи не смогут входить в сеть. Уже установленные подключения не разрываются. Администраторы могут подключаться к серверу, даже если он приостановлен.
    • Приостановка службы рабочей станции сохраняет имена пользователей, пароли и подключения, но обращения к сетевым принтерам будут направляться к локальному принтеру.
  • Если имя службы содержит пробелы, его следует заключать в кавычки (например "имя службы").

Примеры

Чтобы приостановить службу «Сервер», введите:

net pause server

Если имя службы состоит из двух или более слов, необходимо заключать его в прямые кавычки. Например, чтобы приостановить службу «Поставщик поддержки безопасности NT LM», введите:

net pause "Поставщик поддержки безопасности NT LM"


Net print

Вывод сведений об указанной очереди печати, обо всех очередях печати на указанном сервере печати, об указанном задании печати либо управление указанным заданием печати. При вызове команды net print без параметров в командной строке отображается справка по команде net print.

Вывод сведений об указанной очереди печати или обо всех очередях печати на указанном сервере печати

Синтаксис

net print \\имя_компьютера[\имя_очереди]

Параметры

\\имя_компьютера
Обязательный параметр. Имя компьютера, на котором находится очередь печати, сведения о которой требуется просмотреть.
\имя_очереди
Имя очереди печати, сведения о которой требуется просмотреть. Если задан компьютер, но не задана очередь, выводятся сведения обо всех очередях печати указанного компьютера.
net help net print
Отображение справки по команде net print.

Заметки

  • Команда Net print выводит сведения нескольких типов об очередях печати. Ниже приведен пример отчета по всем очередям печати на сервере Production:

    Принтеры на \\PRODUCTION

    Имя             Задание #   Размер   Состояние

---------------------------------------------------------

LASER Очередь   1 задание            *Активный принтер*

     USER1          84      0        Постановка в очередь

Примеры

Чтобы просмотреть содержимое очереди печати Dotmatrix на компьютере \\Production, введите:

net print \\production\dotmatrix

Вывод сведений и изменение свойств задания печати

Синтаксис

net print [\\имя_компьютера] номер_задания [{/hold | /release | /delete}]

Параметры

\\имя_компьютера
Имя компьютера, на котором находится очередь печати, состояние которой требуется изменить. Если компьютер не указан, используется локальный компьютер.
номер_задания
Обязательный параметр. Номер задания печати, свойства которого требуется изменить. Этот номер назначается компьютером, на котором находится очередь печати, в которую отправлено задание печати. После того как компьютер назначит номер заданию печати, этот номер не назначается никакому другому заданию печати на этом же компьютере.
{/hold | /release | /delete}
Действие, выполняемое над заданием печати. Параметр /hold приостанавливает обработку задания печати, что позволяет ускорить выполнение других заданий печати. Параметр /release возобновляет обработку приостановленного задания печати. Параметр /delete удаляет задание печати из очереди печати. Если задан номер задания, но не задано никакое действие, выводятся сведения об этом задании печати.
net help net print
Отображение справки по команде net print.

Заметки

  • Ниже приведен пример отчета о задании печати:

    Задание #                 35

Состояние                 Ожидание

Размер                    3096

Примечания

Получено от пользователя  USER2

Уведомить                 USER2

Тип данных задания

Параметры задания

Дополнительные сведения

Примеры

Чтобы вывести сведения о задании номер 35 на компьютере \\Production, введите:

net print \\production 35

Чтобы приостановить обработку задания номер 263 на компьютере \\Production, введите:

net print \\production 263 /hold

Чтобы возобновить обработку задания номер 263 на компьютере \\Production, введите:

net print \\production 263 /release


Net send

Служит для отправки сообщений другому пользователю, компьютеру или псевдониму, доступному в сети.

Синтаксис

net send {имя | * | /domain[:имя] | /users} сообщение

Параметры

имя
Имя пользователя, имя компьютера или псевдоним, которому требуется отправить сообщение. Если аргументы параметров команды содержат пробелы, их следует заключать в кавычки (например "имя компьютера"). Возможны трудности при использовании длинных имен пользователей как имен NetBIOS. Имена NetBIOS имеют длину до 16 знаков, а шестнадцатый знак зарезервирован.
*
Отправка сообщений всем членам домена или рабочей группы.
/domain:имя
Отправка сообщения всем именам в домене компьютера. Для отправки сообщения всем именам в указанном домене или рабочей группе можно задать имя.
/users
Отправка сообщения всем пользователям, подключенным к серверу.
сообщение
Обязательный параметр. Текст сообщения.
net help команда
Отображение справки для указанной команды net.

Заметки

  • Сообщение может быть отправлено только активному объекту в сети. Если сообщение отправляется пользователю, он должен быть подключен к компьютеру, на котором работает служба сообщений.
  • Можно отправить сообщение всем именам в домене компьютера (с помощью * или /domain) или в другом домене (/domain:домен). Предельная длина широковещательных сообщений составляет 128 знаков. Проявляйте осторожность при отправке сообщений нескольким пользователям.
  • Параметр /users позволяет отправить сообщение всем подключенным к серверу пользователям. Проявляйте осторожность при отправке сообщений нескольким пользователям.
  • Для возможности получения сообщений на компьютере должна быть запущена служба сообщений.

Примеры

Чтобы отправить сообщение "Встреча переносится на 15.00. Место то же." пользователю robertf, введите:

net send robertf Встреча переносится на 15.00. Место то же.

Чтобы отправить сообщение всем пользователям, подключенным к серверу, введите:

net send /users Сервер будет выключен через 5 минут.

Чтобы отправить сообщение, текст которого включает косую черту, введите:

net send robertf "Форматируйте диск командой FORMAT /4"


Net session

Служит для управления подключениями к серверу. Команда net session без параметров выводит сведения обо всех сеансах локального компьютера.

Синтаксис

net session [\\имя_компьютера] [/delete]

Параметры

\\имя_компьютера
Имя компьютера, сеансы которого требуется просмотреть или отключить.
/delete
Завершение сеанса с компьютером и закрытие всех открытых файлов данного сеанса. Если имя_компьютера не задано, закрываются все сеансы на локальном компьютере.
net help команда
Отображение справки для указанной команды net.

Внимание!

  • Использование команды net session может привести к потере данных. Рекомендуется уведомлять пользователей перед принудительным завершением сеанса.

Заметки

  • Для вызова команды net session также можно использовать синтаксис net sessions или net sess.
  • Команда net session служит для вывода имен пользователей и компьютеров, имеющих доступ к серверу, со сведениями об открытых файлах и о времени холостого хода сеанса.

    Эти сведения выводятся в следующем формате:

    Компьютер     Пользователь     Тип клиента  Ожидание открытия

------------------------------------------------------------------------
\\BASSETT     CHRISDR          Windows 2000   1     00:00:13
\\SHARONCA    Администратор    DOS LM 2.1     0     01:05:13

  • Чтобы вывести сведения о сеансе одного пользователя, задайте имя_компьютера. Сведения об одном пользователе включают список общих ресурсов, к которым подключен пользователь.
  • Запись о сеансе появляется, когда пользователь компьютера-клиента успешно соединяется с сервером. Успешный сеанс возможен в случае, если два компьютера находятся в одной сети, а имя и пароль пользователя приняты сервером. Прежде чем клиент сможет использовать ресурсы сервера, он должен установить сеанс с сервером. Сеанс будет длиться до тех пор, пока пользователь подключен к ресурсу. Клиент и сервер могут иметь только один сеанс, однако допускается несколько подключений к ресурсам.
  • Чтобы задать время простоя сеанса до автоматического отключения, включите режим автоматического отключения, используя команду net config server /autodisconnect. Для получения дополнительных сведений о команде net config server щелкните ссылку «См. также». Автоматическое отключение незаметно для пользователя, поскольку сеанс автоматически восстанавливается, когда пользователь снова обращается к ресурсу.
  • Чтобы завершить сеанс с сервером, введите команду net session \\имя_компьютера /delete.

Примеры

Чтобы вывести сведения о сеансе для локального сервера, введите:

net session

Чтобы вывести сведения о сеансе для клиента с компьютера Shepherd, введите:

net session \\shepherd

Чтобы завершить все сеансы между сервером и подключенными к нему клиентами, введите:

net session /delete


Net share

Управление общими ресурсами. При вызове команды net share без параметров выводятся сведения обо всех общих ресурсах локального компьютера.

Синтаксис

net share [имя_ресурса] net share [имя_ресурса=диск:путь [{/users:число|/unlimited}] [/remark:"текст"] [/cache: {manual|automatic|no}]]net share [имя_ресурса [{/users:число|unlimited}] [/remark:"текст"] [/cache: {manual|automatic|no}]] net share [{имя_ресурса|диск:путь} /delete]

Параметры

имя_ресурса
Сетевое имя общего ресурса. Команда net share имя_ресурса выводит сведения об отдельном ресурсе.
диск:путь
Абсолютный путь к папке, которую требуется сделать общей.
/users:число
Максимальное количество пользователей, которым разрешен одновременный доступ к общему ресурсу.
/unlimited
Отмена ограничения на число пользователей, которым разрешен одновременный доступ к общему ресурсу.
/remark:"текст"
Добавление описательного комментария к ресурсу. Текст следует заключать в кавычки.
/cache:automatic
Включение автономного кэширования клиентов с автоматической реинтеграцией.
/cache:manual
Включение автономного кэширования клиентов с реинтеграцией вручную.
/cache:no
Оповещение клиента о невозможности автономного кэширования.
/delete
Отмена общего доступа к ресурсу.
net help команда
Отображение справки для указанной команды net.

Заметки

  • Чтобы предоставить общий доступ к папке, имя которой содержит пробелы, заключите диск и путь к папке в кавычки (например "C:\Новая папка").
  • При запросе списка всех общих ресурсов компьютера выводятся: имя общего ресурса, имена устройств или путь, связанный с устройством, а также комментарий к этому ресурсу. Вывод будет иметь следующий вид:

    Общее имя  Ресурс                       Заметки
------------------------------------------------------
ADMIN$     C:\WINNT                     Удаленный Admin
C$         C:\                          Стандартный общий ресурс
print$     C:\WINNT\SYSTEM\SPOOL
IPC$                                    Удаленный IPC
LASER      LPT1               Очередь   Лазерный принтер

  • Когда общий ресурс создается на сервере, его конфигурация сохраняется. После остановки службы «Сервер» все общие ресурсы отключаются, но после следующего запуска службы «Сервер» они будут восстановлены.
  • Имена общих ресурсов, заканчивающиеся знаком $, не отображаются при обзоре локального компьютера с удаленного компьютера.

Примеры

Чтобы вывести сведения об общих ресурсах компьютера, введите:

net share

Чтобы сделать папку «C:\Данные» общим ресурсом Данные и включить примечание к нему, введите:

net share ОбщиеДанные=c:\Данные /remark:"Для отдела 123"

Чтобы отменить общий доступ к ресурсу ОбщиеДанные, созданному в предыдущем примере, введите:

net share ОбщиеДанные /delete

Чтобы сделать папку «C:\Список рисунков» общим ресурсом Список, введите:

net share Список="c:\Список рисунков"


Net start

Служит для запуска службы. При запуске команды net start без параметров выдается список запущенных служб.

Синтаксис

net start [служба]

Параметры

служба
Запуск указанной службы. В следующей таблице перечислены значения атрибута служба.
Значение | Описание | Заметки
alerter Запуск службы «Оповещатель».
  • Служба Оповещатель позволяет отправлять сообщения отдельному пользователю или пользователям, подключенным к данному серверу. Эти сообщения служат для оповещения пользователей о проблемах безопасности, доступа и пользовательских сеансов.
  • Используйте диспетчер серверов (системный_корневой_каталог\System32\Srvmgr.exe) для указания администраторов, которые будут получать административные оповещения. Диспетчер серверов входит в состав только Windows Server 2000.
  • Оповещения отправляются с сервера на пользовательский компьютер как сообщения. Для приема оповещений на компьютере пользователя должна быть запущена служба сообщений.
browser Запуск службы «Обозреватель компьютеров».
  • Служба «Обозреватель компьютеров» поддерживает текущий список компьютеров в локальной сети и предоставляет этот список запрашивающим его приложениям.
"Клиент для сетей NetWare" Запуск службы «Клиент для сетей NetWare».
  • Эта команда доступна, только если установлена служба «Клиент для сетей NetWare».
"Сервер папки обмена" Запуск службы «Сервер папки обмена».
  • Служба «Сервер папки обмена» позволяет копировать и вставлять текстовые и графические данные по сети.
  • Служба «Сервер папки обмена» поддерживает окно папки обмена, с помощью которой можно просматривать страницы удаленных папок обмена.
dhcp client Запуск службы «DHCP-клиент».
  • Эта команда доступна, только если установлен протокол TCP/IP.
  • Служба «DHCP-клиент» поддерживает сетевую конфигурацию, запрашивая и обновляя IP-адреса и имена DNS. Служба «DHCP-клиент» поддерживает получение IP-адреса от DHCP-сервера.
  • Служба «DHCP-клиент» не может быть приостановлена или остановлена.
eventlog Запуск службы «Журнал событий».
  • Служба «Журнал событий» заносит в журнал сообщения о событиях, получаемые от программ и Windows XP. Отчеты журнала событий содержат сведения, которые могут быть полезны при поиске причины неполадок. Эти отчеты можно просматривать в окне «Просмотр событий». Просмотр этих событий возможен только после запуска службы «Журнал событий».
  • Эту службу нельзя остановить или приостановить.
file replication | Запуск службы репликации файлов.
messenger Запуск службы сообщений.
  • Эта служба позволяет компьютеру получать сообщения.
  • Сообщения отправляются компьютеру с использованием идентификационного имени компьютера.
netlogon Запуск службы «Сетевой вход в систему».
  • Служба «Сетевой вход в систему» проверяет запросы на подключение и управляет репликацией учетных записей пользователей в домене.
  • Служба «Сетевой вход в систему» должна быть запущена на всех серверах домена, где хранятся копии учетных данных пользователей.
"Поставщик поддержки безопасности NT LM" Запуск службы «Поставщик поддержки безопасности NT LM».
  • Эта команда доступна после установки системы обеспечения защиты NT LM.
"plug and play" | Запуск службы «Plug and Play».
"Диспетчер подключений удаленного доступа" Запуск службы диспетчера подключений удаленного доступа.
  • Эта команда доступна, только если установлена служба удаленного доступа.
"Маршрутизация и удаленный доступ" | Запуск службы «Маршрутизация и удаленный доступ».
rpclocator Запуск службы «Локатор удаленного вызова процедур (RPC)».
  • Эта служба позволяет распределенным приложениям использовать службу имени RPC Microsoft.
  • Служба «Локатор удаленного вызова процедур (RPC)» является службой имен RPC для Microsoft Windows XP. Служба локатора RPC управляет базой данных службы имен RPC.
  • Серверная часть распределенного приложения регистрирует свою доступность с помощью службы локатора RPC. Клиентская служба распределенного приложения запрашивает службу локатора RPC для поиска доступного серверного компонента приложения.
rpcss Запуск службы «Удаленный вызов процедур (RPC)».
  • Служба «Удаленный вызов процедур (RPC)» является подсистемой удаленного вызова процедур Windows XP. Эта подсистема включает определитель точек вызова и другие службы протокола RPC. Команда Net start rpcss запускает службу удаленного вызова процедур, что позволяет распределенным приложениям использовать динамические удаленные вызовы. Служба удаленного вызова процедур управляет базой данных регистрации распределенных приложений.

    Серверная часть распределенного приложения регистрирует свое местоположение на сервере службы удаленного вызова процедур. Библиотека времени исполнения клиентской части приложения запрашивает службу удаленного вызова процедур для определения местоположения серверной части и получения информации о серверной части приложения. Сведения об использовании распределенным приложением службы определителя точек вызова должны быть приведены в документации к приложению.

schedule Запуск службы «Планировщик заданий».
  • Планировщик заданий позволяет запускать программы в указанное время с помощью команды at. Перед запуском команд по расписанию может потребоваться запуск других служб.
  • Первоначально планировщик заданий настраивается на запуск всех программ с системной учетной записью на локальном компьютере. Запуск планировщика заданий с этой учетной записью позволяет выполнять любые программы без ограничений. Однако доступ к сети будет ограничен, так как системные привилегии на локальном компьютере могут не распознаваться другими компьютерами.
  • Для преодоления этого ограничения можно настроить планировщик заданий на запуск с учетной записью пользователя. В этом случае выполнение задач планировщиком заданий определяется правами доступа учетной записи пользователя. Однако, так как в этом случае планировщик заданий не имеет системных прав доступа в локальной системе, могут быть запущены только программы, не требующие вывода в окно.
server Запуск службы «Сервер».
  • Пользователь имеет возможность применить службу сервера для совместного использования ресурсов сервера с другими пользователями сети.
spooler Запуск службы «Диспетчер очереди печати».
  • Служба диспетчера очереди печати загружает файлы в память для печати.
"Модуль поддержки NetBIOS через TCP/IP" Запуск службы поддержки NetBIOS через TCP, позволяющей работать службам NetBIOS через TCP/IP (NetBT).
  • Службы NetBT поддерживают датаграммы NetBIOS, сеансы NetBIOS и управление именами NetBIOS (регистрацию имен и их разрешение в адреса) для приложений NetBIOS, использующих протокол TCP/IP.
  • Эта команда доступна, только если в свойствах сетевого адаптера в объекте Сетевые подключения в качестве компонента установлен протокол Интернета (TCP/IP).
ups Запуск службы «Источник бесперебойного питания».
  • Служба бесперебойного питания управляет подключенным к компьютеру источником бесперебойного питания (ИБП).
  • Настройка службы бесперебойного питания задается в окне «Электропитание» панели управления. Если в настройке службы бесперебойного питания задается выполнение командного файла при выключении компьютера, то выполнение файла должно заканчиваться за 30 секунд. Большее время выполнения создает угрозу безаварийному завершению работы Windows XP.
workstation Запуск службы «Рабочая станция».
  • Эта служба позволяет компьютеру подключаться и использовать общие сетевые ресурсы.
net help команда
Отображение справки для указанной команды net.

Заметки

  • Набор отображаемых служб и приложений может изменяться в зависимости от параметров, выбранных при установке или настройке.
  • Некоторые службы могут зависеть от других служб.
  • Кроме того, для настройки автоматического запуска или остановки служб можно использовать оснастку «Службы». Эта оснастка позволяет запускать, останавливать, приостанавливать и возобновлять работу сетевых служб.
  • Команду Net start можно использовать и для запуска служб, не входящих в состав Windows XP.
  • Если имя службы содержит пробелы, его следует заключать в кавычки (например "имя службы").

Примеры

Чтобы получить список текущих запущенных служб, введите:

net start

Чтобы запустить службу клиента для сетей Netware, введите:

net start "Клиент для сетей NetWare"


Net statistics

Вывод журнала статистики для служб локальной рабочей станции, сервера или запущенных служб, для которых доступна статистика. При использовании команды net statistics без параметров выводится список запущенных служб, для которых возможен вывод статистических сведений.

Синтаксис

net statistics [{workstation | server}]

Параметры

workstation
Выводит сведения для локальной службы рабочей станции.
server
Выводит сведения для локальной службы сервера.
net help команда
Отображение справки для указанной команды net.

Примечания

  • Также можно ввести команду net stats.
  • Для службы рабочей станции в Windows XP будет выведено имя компьютера, дата и время последнего обновления статистики, а также следующие сведения.
    • Количество принятых и переданных байт и блоков сообщений сервера SMB.
    • Количество успешных и ошибочных операций чтения и записи.
    • Количество сетевых ошибок.
    • Количество ошибочных, отключенных и подключенных повторно сеансов.
    • Количество ошибочных и успешных подключений к общим ресурсам.
  • Для службы сервера в Windows XP будет выведено имя компьютера, дата и время последнего обновления статистики, а также следующие сведения.
    • Количество сеансов: запущенных, отключенных автоматически и отключенных из-за ошибок.
    • Количество переданных и принятых килобайт и среднее время ответа сервера.
    • Количество ошибок, нарушений паролей и превышений ограничений доступа.
    • Количество обращений к общим файлам, принтерам и коммуникационным устройствам.
    • Количество превышений размера буфера памяти.

Примеры

Для вывода статистических сведений о службе сервера с паузой поле заполнения каждого экрана служит следующая команда:

net statistics server | more


Net stop

Останавливает работу службы

Синтаксис

net stop служба

Параметры

служба
Останавливает работу указанной службы. В следующей таблице перечислены значения параметра служба.
Значение | Описание | Примечания
alerter Остановка работы службы «Оповещатель».
  • Останавливает работу службы «Оповещатель», позволяющей отправлять оповещения тем пользователям, которые подключены к данному серверу. Эти оповещения предупреждают пользователей о проблемах безопасности, доступа и пользовательских сеансов.
  • Используйте диспетчер серверов (системный_корневой_каталог\System32\Srvmgr.exe) для указания администраторов, которые будут получать административные оповещения. Диспетчер серверов доступен только с компьютеров Windows 2000 Server.
  • Оповещения отправляются в виде ссобщений с сервера на пользовательский компьютер. Для приема оповещений на компьютере пользователя должна быть запущена служба сообщений.
обозреватель Остановка работы службы «Обозреватель компьютеров».
  • Служба «Обозреватель компьютеров» поддерживает обновляемый список компьютеров в локальной сети и предоставляет этот список запрашивающим его приложениям.
"Клиент для сетей NetWare" Остановка работы службы «Клиент для сетей NetWare».
  • Эта команда доступна, только если установлена служба «Клиент для сетей NetWare».
"Сервер папки обмена" Остановка работы службы «Сервер папки обмена».
  • Служба «Сервер папки обмена» позволяет копировать и вставлять текстовые и графические данные по сети.
  • Служба «Сервер папки обмена» поддерживает окно папки обмена, позволяющее просматривать страницы с помощью удаленных папок обмена.
dhcp client Служба «DHCP-клиент» не может быть приостановлена или остановлена.
  • Служба «DHCP-клиент» поддерживает сетевую конфигурацию, запрашивая и обновляя IP-адреса и имена DNS. Служба «DHCP-клиент» поддерживает получение IP-адреса от DHCP-сервера.
file replication | Запуск службы репликации файлов.
messenger Останавливает работу службы сообщений.
  • Эта служба позволяет компьютеру получать сообщения.
  • Сообщения отправляются компьютеру с использованием идентификационного имени компьютера.
netlogon Останавливает работу службы «Сетевой вход в систему».
  • Служба «Сетевой вход в систему» проверяет запросы на вход и управляет репликацией учетных записей пользователей в домене.
  • Остановка работы службы «Сетевой вход в систему» происходит на всех серверах домена, использующих копию базы данных с учетными данными пользователей.
"Поставщик поддержки безопасности NT LM" Останавливает работу службы «Поставщик поддержки безопасности NT LM» (NT LM Security Support Provider).
  • Эта команда доступна после установки системы обеспечения защиты NT LM.
"Диспетчер подключений удаленного доступа" Останавливает работу службы диспетчера подключений удаленного доступа.
  • Эта команда доступна, только если установлена служба удаленного доступа.
"Маршрутизация и удаленный доступ" | Остановка работы службы «Маршрутизация и удаленный доступ».
rpclocator Остановка работы службы «Локатор удаленного вызова процедур (RPC)».
  • Эта служба позволяет распределенным приложениям использовать службу имени RPC Microsoft.
  • Служба «Локатор удаленного вызова процедур (RPC)» является службой имен RPC для Microsoft Windows XP. Данная служба управляет базой данных службы имен RPC.
  • Серверная часть распределенного приложения регистрирует свою доступность с помощью службы локатора RPC. Клиентская часть распределенного приложения запрашивает службу локатора RPC для поиска доступных и в то же время совместимых серверных приложений.
schedule Остановка работы службы «Планировщик заданий».
  • Планировщик заданий позволяет запускать программы в указанное время с помощью команды at. Перед запуском команд по расписанию может потребоваться запуск других служб.
  • Первоначально планировщик заданий настраивается на запуск всех программ с системной учетной записью на локальном компьютере. Запуск планировщика заданий с этой учетной записью позволяет выполнять любые программы без ограничений. Однако доступ к сети со стороны этих заданий будет ограничен, так как системные привилегии на локальном компьютере не распознаются другими компьютерами.
  • Преодолеть это ограничение можно, настроив планировщик заданий на запуск с учетной записью пользователя. В этом случае выполнение задач планировщиком заданий определяется правами доступа учетной записи пользователя. Так как в этом случае планировщик заданий не имеет системных прав доступа в локальной системе, могут быть запущены только программы, не требующие вывода в окно.
server Останавливает работу службы сервера.
  • Служба сервера применяется для совместного использования ресурсов сервера с другими пользователями сети.
spooler Остановка работы службы «Диспетчер очереди печати».
  • Служба диспетчера очереди печати загружает файлы в память для печати.
"Модуль поддержки NetBIOS через TCP/IP" Остановка работы службы поддержки NetBIOS через TCP, позволяющей службам NetBIOS работать с использованием протокола TCP/IP (NetBT).
  • Службы NetBT поддерживают датаграммы NetBIOS, сеансы NetBIOS и управление именами NetBIOS (регистрацию имен и их разрешение в адреса) для приложений NetBIOS, использующих протокол TCP/IP.
  • Эта команда доступна, только если в свойствах сетевого адаптера в объекте Сетевые подключения в качестве компонента установлен протокол Интернета (TCP/IP).
ups Запуск службы «Источник бесперебойного питания».
  • Служба бесперебойного питания управляет подключенным к компьютеру источником бесперебойного питания (ИБП).
  • Настройка службы бесперебойного питания задается в окне «Электропитание» панели управления. Если при настройке службы бесперебойного питания задается выполнение командного файла при выключении компьютера, то время выполнения файла не должно превышать 30 секунд. Большое время выполнения создает угрозу безаварийному завершению работы Windows.
workstation Остановка работы службы «Рабочая станция».
  • Эта служба позволяет компьютеру подключаться к общим сетевым ресурсам и использовать их.
net help команда
Отображение справки для указанной команды net.

Примечания

  • Набор отображаемых служб и приложений может изменяться в зависимости от параметров, выбранных при установке или настройке.
  • Некоторые службы могут зависеть от других служб.
  • Команда net stop используется для остановки работы службы и выгрузки соответствующего приложения из памяти.
  • Остановка службы сервера не позволяет пользователям получать доступ к общим ресурсам компьютера. Если данная служба будет остановлена в то время, когда пользователи обращаются к ресурсам сервера, появится предупреждающее сообщение. Ввод y (то есть, yes) отключит всех пользователей от компьютера и его ресурсов. Перед остановкой службы сервера выполните следующие действия.
  • Введите команду net pause, которая приостановит службу и запретит новые подключения к компьютеру.
  • Воспользуйтесь командой net send для посылки подключенным пользователям сообщения о необходимости отключиться от ресурсов сервера.
  • Если имя службы содержит пробелы, его следует заключать в кавычки (например "имя службы").
  • Net stop может использоваться также для остановки работы служб, не снабженных Windows XP.

Примеры

Остановить работу службы сервера можно с помощью следующей команды:

net stop server

Имена служб, состоящие из двух или более слов, следует заключать в кавычки. Например, службу клиента для сетей Netware следует останавливать с помощью команды:

net stop "Клиент для сетей NetWare"


Команды сетевых служб

Для получения дополнительных сведений щелкните ссылку.

  • Net accounts
  • Net computer
  • Net config
  • Net continue
  • Net file
  • Net group
  • Net help
  • Net helpmsg
  • Net localgroup
  • Net name
  • Net pause
  • Net print
  • Net send
  • Net session
  • Net share
  • Net start
  • Net statistics
  • Net stop
  • Net time
  • Net use
  • Net user
  • Net view


Net time

Синхронизация часов компьютера с часами другого компьютера или домена. Использованная без параметров, команда выводит время на другом компьютере или домене.

Синтаксис

net time [{\\имя_компьютера | /domain[:имя_домена] | /rtsdomain[:имя_домена]}] [/set]

net time [\\имя_компьютера] [/querysntp] [/setsntp[:список_серверов_NTP]]

Параметры

\\имя_компьютера
Указывает имя сервера, время на котором нужно проверить или с которым нужно синхронизировать таймер.
/domain[:имя_домена]
Задает имя домена, с которым синхронизируются часы.
/rtsdomain[:имя_домена]
Указывает домен сервера надежного времени (RTS), с которым будут синхронизироваться часы.
/set
Синхронизирует часы с временем указанного компьютера или домена.
/querysntp
Выводит имя сервера NTP (Network Time Protocol), сконфигурированного для локального компьютера, или компьютера, указанного в параметре \\имя_компьютера.
/setsntp[:список_серверов_NTP]
Указывает список серверов времени NTP для использования на локальном компьютере. Список может содержать IP-адреса или имена DNS, разделенные пробелами. Если планируется использование серверов, использующих различные временные зоны, список таких серверов следует заключить в кавычки.
net help команда
Отображение справки для указанной команды net.


Net use

Подключение к общим сетевым ресурсам или вывод информации о подключениях компьютера. Команда также управляет постоянными сетевыми соединениями. Вызванная без параметров, команда net use извлекает список сетевых подключений.

Синтаксис

net use [{имя_устройства | *}] [\\имя_компьютера\ресурс[\том]] [{пароль | *}]] [/user:[имя_домена\]] [/user:[имя_домена_с_точкой\]имя_пользователя] [/user: [имя_пользователя@имя_домена_с_точкой] [/savecred] [/smartcard] [{/delete | /persistent:{yes | no}}]

net use [имя_устройства [/home[{пароль | *}] [/delete:{yes | no}]]

net use [/persistent:{yes | no}]

Параметры

Имя_устройства
Задает имя ресурса при подключении или имя устройства при отключении. Существует два вида имен устройств: имена для дисковых устройств (то есть, диски с буквенными обозначениями от D: до Z:) и для принтеров (соответственно, от LPT1: до LPT3:). Ввод звездочки (*) вместо имени определенного устройства обеспечит присвоение такому устройству ближайшего доступного имени.
\\имя_компьютера\имя_ресурса
Указывает имя сервера и общего ресурса. Если параметр имя_компьютера содержит пробелы, все имя компьютера от двойной обратной черты (\\) до конца (например, "\\Computer Name\Share Name") должно быть заключено в прямые кавычки ("). Имя компьютера может иметь длину от 1 до 15 знаков.
\том
Задает имя тома системы NetWare. Для подключения к серверам Netware необходимо установить и запустить клиент для сетей NetWare.
пароль
Задает пароль, необходимый для подключения к общему ресурсу. Введите звездочку (*) для вывода приглашения на ввод пароля. При вводе с клавиатуры символы пароля не выводятся на экран.
/user
Задает другое имя пользователя для подключения к общему ресурсу.
имя_домена
Задает имя другого домена. Пропуск параметра имя_домена приводит к тому, что команда net use использует имя домена, заданное при входе в систему.
имя_пользователя
Указывает имя пользователя для подключения.
имя_домена _с_точкой
Указывает полное имя домена, в котором присутствует учетная запись пользователя.
/savecred
Сохраняет введенные учётные данные для дальнейшего использования.
/smartcard
Указывает необходимость считывания учетных данных со смарт-карты для сетевого подключения. При наличии нескольких смарт-карт появится запрос на указание одной из них.
/delete
Отменяет указанное сетевое подключение. Если подключение задано с символом звездочки (*), будут отменены все сетевые подключения.
/persistent:{yes | no}
Управляет постоянными сетевыми подключениями. По умолчанию берется последнее использованное значение. Подключения без устройства не являются постоянными. Выбор значения Yes приводит к сохранению всех существующих соединений и восстанавлению их при следующем подключении. При выборе значения No выполняемые и последующие подключения не сохраняются. Существующие подключения восстанавливаются при следующем входе в систему. Для удаления постоянных подключений используется ключ /delete.
/home
Подключает пользователя к его основному каталогу.
net help команда
Отображение справки для указанной команды net.

Заметки

  • Подключение и отключение от сетевого ресурса

    Команда net use используется для подключения и отключения от сетевых ресурсов и для вывода сведений о текущих подключениях к таким ресурсам. Если сетевой ресурс является текущим диском или его использует какое-либо работающее приложение, отключиться от такого ресурса невозможно.

  • Просмотр сведений о подключениях

    Чтобы просмотреть сведения о подключении, можно использовать любой из следующих способов:

    • Введите команду net use имя_устройства для получения сведений о конкретном подключении.
    • Введите команду net use для получения списка всех подключений компьютера.
  • Использование подключений без устройств

    Подключения без устройств не являются постоянными.

  • Подключение к серверам NetWare

    Установка и запуск клиента для сетей NetWare дает возможность подключаться к серверам NetWare или сети Novell. При этом используется тот же синтаксис, что и при подключении к серверам сети Windows, с добавлением имени тома для подключения.

  • Использование кавычек

    Если вводимое имя_сервера содержит пробелы, его следует заключать в кавычки (т. е. "имя_сервера"). Пропуск кавычек влечет за собой появление сообщения об ошибке.

Примеры

Чтобы назначить относящееся к дисковому устройству имя Е: общему каталогу Letters на сервере \\Financial, следует ввести:

net use e: \\financial\letters

Чтобы назначить относящееся к дисковому устройству имя М: каталогу Mike тома Letters на сервере \\Financial Netware, следует ввести:

net use m: \\financial\letters\mike

Чтобы подключить пользователя с идентификатором Dan так, как если бы он подключался из домена Accounts, следует ввести:

net use d:\\server\share /user:Accounts\Dan

Для отключения от каталога \\Financial\Public служит команда:

net use f: \\financial\public /delete

Для подключения к совместно используемым запискам ресурса на сервере \\Financial 2 служит команда:

net use k: "\\financial 2" \memos

Для восстановления текущих подключений при следующих входах в сеть, независимо от будущих изменений, служит команда:

net use /persistent:yes


Net user

Добавление, редактирование или просмотр учетных сведений пользователя.

Синтаксис

net user [имя_пользователя [пароль | *] [параметры]] [/domain]

net user имя_пользователя {пароль | *} /add [параметры] [/domain]

net user имя_пользователя [/delete] [/domain]

Параметры

имя_пользователя
Указывает имя учётной записи пользователя, которую можно добавить, удалить, отредактировать или просмотреть. Имя может иметь длину до 20 символов.
пароль
Присваивает или изменяет пароль пользователя. Введите звездочку (*) для вывода приглашения на ввод пароля. При вводе с клавиатуры символы пароля не выводятся на экран.
/domain
Выполняет операцию на контроллере основного для данного компьютера домена.
параметры
Задает параметр командной строки. Данные параметры приведены в следующей таблице.
Синтаксис параметров командной строки | Описание
/active:{no | yes} | Блокирует (no) и активирует (yes) учетную запись пользователя. Если пользователь блокирован, он не сможет подключиться к ресурсам компьютера. По умолчанию используется значение yes (запись активна).
/comment:"текст" | Добавляет комментарий к пользовательской записи. Длина комментария может составлять до 48 символов. Текст следует заключать в кавычки.
/countrycode:nnn | Указывает код страны, определяющий файлы, которые используются при выводе справочной информации и сообщений об ошибках. Нулевое значение приводит к использованию кода страны по умолчанию.
/expires:{{мм/дд/гггг | дд/мм/гггг | ммм,дд ,гггг} | never} | Делает недействительной учетную запись пользователя по наступлении заданной даты. Взависимости от кода страны дата может задаваться в следующих форматах: мм/дд/гггг | дд/мм/гггг | ммм,дд ,гггг Следует иметь в виду, что срок действия учетной записи пользователя истекает сразу по окончании предыдущего дня. Названия месяцев можно вводить целиком, сокращать их до трёхбуквенного обозначения (то есть, янв, фев, мар, май, июн, июл, авг, сеп, окт, нов, дек) или использовать вместо названий их порядковые номера. Год можно обозначать как двумя, так и четырьмя цифрами. В качестве разделителей следует использовать запятую или косую черту. Пробелы использовать не следует. Если параметр гггг пропущен, будет использована ближайшая будущая дата, соответствующая указанным месяцу и дню (с учетом текущей системной даты и времени компьютера). Например, следующие три варианта эквивалентны, если они введены между 10 января 1994 г. и 8 января 1995 г.: янв, 9 1/9/95 январь, 9,1995 1/9
/fullname:"имя" | Задает действительное имя пользователя, а не его логическое имя. Заключается в кавычки.
/homedir:путь | Задает основной каталог пользователя. Должен быть указан существующий каталог.
/passwordchg:{yes | no} | Устанавливает, допускается (yes) или нет (no) изменение пароля самим пользователем. Значение по умолчанию равно yes.
/passwordreq:{yes | no} | Задает, является обязательным (yes) или нет (no) использование пароля. Значение по умолчанию равно yes.
/profilepath:[путь] | Задает путь к профилю входа пользователя. Этот путь указывает на профиль реестра.
/scriptpath:путь | Задает путь к файлу сценария входа. Параметр путь не может быть абсолютным. путь указывается относительно %systemroot%\System32\Repl\Import\Scripts.
/times:{день[-день][,день[-день]] ,час[-час][,час[-час]] [;…] | all} | Задает интервалы времени, в которые пользователю разрешено использование компьютера. Параметр час задается с шагом в одну единицу. Значения параметра день задаются целиком, либо в сокращенном виде (то есть, Пн,Вт,Ср,Чт,Пт,Сб,Вс). Часы могут быть указаны в 12- или 24-часовом формате. Для 12-часового формата используются обозначения AM (до полудня) или PM (после полудня) или A.M., P.M. Значение all отменяет ограничения на время входа в систему. Пустое значение не позволяет пользователю подключаться никогда. Дни и часы разделяются запятыми, отдельные интервалы — точкой с запятой (например Пн,4AM-5PM;Вт,1PM-3PM). использование пробелов не допускается.
/usercomment:"текст" | Добавление или изменения комментария к учетной записи пользователя. Текст следует заключать в кавычки.
/workstations:{имя_компьютера[,...] | *} | Задает до восьми имен рабочих станций, с которых пользователь может входить в сеть. Элементы списка разделяются запятыми. Если в параметре /workstations список не задан или задан звездочкой (*), пользователь может входить в сеть с любого компьютера.
net help команда
Отображение справки для указанной команды net.

Заметки

  • Вызванная без параметров, команда net user выводит список пользователей, зарегистрированных на данном компьютере. Также можно ввести команду net users.
  • Длина пароля должна удовлетворять минимальному значению, устанавливаемому командой net accounts /minpwlen. Пароль может иметь длину до 127 символов. Однако, если компьютер с Windows 2000 или Windows XP используется в сети, к которой подключены компьютеры, работающие под управлением Windows 95 или Windows 98, следует использовать пароли не длиннее 14 символов. Системы Windows 95 и Windows 98 поддерживают пароли длиной до 14 знаков. Если пароль имеет большую длину, войти в сеть с этих компьютеров не удастся.

Примеры

Для вывода списка всех пользователей данного компьютера служит команда:

net user

Для вывода информации о пользователе "jimmyh" служит следующая команда:

net user jimmyh

Для добавления учетной записи пользователя Jay Jamison с полным именем пользователя и правом на подключение с 8 до 17 часов с понедельника по пятницу при обязательном вводе пароля (jayj) используется следующая команда:

net user jayj /add /passwordreq:yes /times:Пн-Пт,08:00-17:00/fullname:"Jay Jamison"

Для задания времени подключения (в 24-часовом формате) пользователя johnsw в интервале с 8 до 17 часов используется команда:

net user johnsw /time:Пн-Пт,08:00-17:00

Для задания того же интервала подключения пользователя johnsw в 12-часовом формате используется команда:

net user johnsw /time:Пн-Пт,8am-5pm

Для задания времени подключения с 4 до 17 часов в понедельник, с 13 до 15 часов во вторник и с 8 до 17 часов со среды по пятницу для пользователя marysl используется следующая команда:

net user marysl /time:Пн,4:00-17:00;Вт,13:00-15:00;Ср-Пт,8:00-17:00


Net view

Выводит список доменов, компьютеров или общих ресурсов на данном компьютере. Вызванная без параметров, команда net view выводит список компьютеров в текущем домене.

Синтаксис

net view [\\имя_компьютера] [/domain[:имя_домена]]

net view /network:nw [\\имя_компьютера]

Параметры

\\имя_компьютера
Задает имя компьютера для просмотра расположенных на нем общих ресурсов.
/domain[:имя_домена]
Задает домен, для которого выводится список компьютеров. Если параметр имя_домена не задан, команда выводит список всех доменов сети.
/network:nw
Выводит список всех доступных серверов сети NetWare. При указании имени компьютера команда отображает все доступные ресурсы на данном компьютере. Кроме того, можно указать дополнительные сети.
net help команда
Отображение справки для указанной команды net.

Заметки

  • Команда net view выводит список компьютеров. Данный список будет иметь следующий вид:

    Имя сервера            Заметки

    -------------------------------------------------

    \\Production          Файловый сервер производства

    \\Print1              Комната принтеров, первый этаж

    \\Print2              Комната принтеров, второй этаж

Примеры

Список общих ресурсов компьютера \\Production может быть получен с помощью команды:

net view \\production

Для просмотра ресурсов сервера NetWare с именем \\Marketing служит команда:

net view /network:nw \\marketing

Для вывода списка компьютеров в домене или рабочей группе sales служит команда:

net view /domain:sales

Для вывода списка всех серверов в сети NetWare можно использовать следующую команду:

net view /network:nw


Использование команды Netsh

Netsh представляет собой поддерживающую сценарий программу с командной строкой, позволяющую локально или удаленно отображать и изменять параметры сети текущего компьютера. Netsh также обеспечивает средства написания сценариев, которые позволяют запускать группу команд в пакетном режиме на определенном компьютере. Программа Netsh может также сохранять сценарии конфигурации в текстовом файле для помещения в архив или для настройки других серверов.

Контексты Netsh

Netsh взаимодействует с другими компонентами операционной системы с помощью файлов библиотеки динамической компоновки (DLL). Каждая библиотека модуля поддержки Netsh содержит широкий набор средств, или контекст, представлющий собой группу команд, относящуюся к конкретному сетевому компоненту. Эти контексты расширяют возможности netsh, обеспечивая поддержку настройки и наблюдения за одной или несколькими службами, служебными программами или протоколами. Например, файл Dhcpmon.dll обесечивает для netsh контекст и набор команд, необходимых для настройки и управления серверами DHCP.

Чтобы выполнить команду netsh, необходимо запустить netsh из командной строки интерпретатора Cmd.exe и перейти к контексту, который содержит нужную команду. Доступность контекстов зависит от того, какие сетевые компоненты были установлены. Например, при вводе dhcp в командной строке Netsh происходит переход в контекст DHCP, но если не был установлен компонент DHCP, появляется следующее сообщение:

Команда не найдена: dhcp.

Дополнительные сведения о контекстах Netsh см. в следующих разделах.

  • Команды Netsh для протокола AAAA
  • Команды Netsh для протокола DHCP
  • Команды диагностики (diag) Netsh
  • Команды Netsh для интерфейса IP
  • Команды Netsh для службы RAS
  • Команды Netsh для маршрутизации
  • Команды Netsh для протокола WINS

Использование нескольких контекстов

Внутри контекста могут существовать подчиненные контексты. Например, внутри контекста маршрутизации можно переключиться на подчиненные контексты IP или IPX.

Чтобы вывести список команд и подчиненных контекстов, которые могут быть использованы в данном контексте, на запрос netsh введите имя контекста, а затем — /? или help. Например, для вывода списка подчиненных команд и команд, которые могут быть использованы в контексте «Routing», в строке netsh (то есть, netsh>), введите один из следующих вариантов:

routing /?

routing help

Для выполнения задач в других контекстах без изменения текущего контекста введите путь требуемый команды в командной строке netsh. Например, для добавления интерфейса подключения по локальной сети в контекст IGMP без его изменения в строке netsh введите:

routing ip igmp add interface "Local Area Connection" startupqueryinterval=21

Запуск Netsh из командной строки интерпретатора Cmd.exe

При запуске команды Netsh из командной строки интерепретатора Cmd.exe netsh используется приведеный далее синтаксис. Чтобы запустить эти команды Netsh на удаленном сервере Windows 2000 Server, необходимо сначала использовать подключение к удаленному рабочему столу для соединения с Windows 2000 Server, работающим под управлением сервера терминалов. Между командами Windows 2000 и контекстными командами Netsh могут существовать некоторые различия Windows XP.

netsh

Netsh представляет собой поддерживающую сценарий программу с командной строкой, позволяющую локально или удаленно отображать и изменять параметры сети текущего компьютера. При использовании без параметров команда netsh открывает командную строку Netsh.exe (то есть, netsh>).

Синтаксис

netsh [-a файл_псевдонима] [-c контекст] [-r уд_компьютер] [{команда_Netsh|-f файл_сценария}]

Параметры

-a
Возвращает к командной строке netsh после выполнения команды файл_псевдонимов.
файл_псевдонимов
Указывает имя текстового файла, который содержит одну или несколько команд netsh.
-c
Переход к заданному контексту netsh.
Контекст
Задает контекст netsh. В следующей таблице перечислены доступные контексты netsh.
Контекст | Описание
AAAA | Отображает и задает конфигурацию базы данных (AAAA) проверки подлинности, авторизации, создания учетных записей и аудита, используемой Службой идентификации в Интернете (IAS) и службой маршрутизации и удаленного доступа.
DHCP | Администрирование серверов DHCP и обеспечение эквивалентной замены управлению с помощью консоли.
Diag | Аминистрирование и устранение неполадок операционной системы и параметров сетевых служб.
Интерфейс | Производит настройку протокола TCP/IP (включая адреса, используемые по умолчанию шлюзы, серверы DNS и WINS) и отображает конфигурацию и статистические данные.
RAS | Администрирование серверов удаленного доступа.
Маршрутизация | Администрирование серверов маршрутизации.
WINS | Администрирование серверов WINS.
-r
Настройка удаленного компьютера.
уд_компьютер
Указывает список настаиваемых удаленных компьютеров.
команда_Netsh
Указывается команда netsh, которую требуется запустить.
-f
Выход из программы Netsh.exe после выполнения сценария.
файл_сценария
Выбор сценария, который требуется запустить.
/?
Отображает справку в командной строке.

Примечания

  • Использование команды -r

    Если указать -r после другой команды, программа netsh выполняет команду на удаленном компьютере, а затем снова возвращается в окно командной строки Cmd.exe. Если увказать -r без другой команды, netsh откроется в удаленном режиме. Этот процесс напоминает использование команды set machine в командной строке Netsh. При использовании команды -r задается конечный компьютер только для текущей команды netsh. После выхода и повторного ввода команды netsh конечный компьютер настраивается так же, как и локальный компьютер. Можно запускать команды netsh на удаленном компьютере, указав имя компьютера, хранящееся на сервере WINS, имя UNC, имя для Интернета, которое должно быть разрешено сервером DNS, или числовой IP-адрес.

Запуск команд Netsh из командной строки программы Netsh.exe

Netsh использует перечисленные далее стандартные команды во всех контекстах, которые запускаются из командной строки программы Netsh.exe (то есть, netsh>). Чтобы запустить эти команды Netsh на удаленном сервере Windows 2000 Server, необходимо сначала использовать подключение к удаленному рабочему столу для соединения с Windows 2000 Server, работающим под управлением сервера терминалов. Между командами Windows 2000 и контекстными командами Netsh могут существовать некоторые различия Windows XP.

Переход к контексту, расположенному на один уровень выше.

Синтаксис

..

Параметры

/?
Отображает справку в командной строке.

abort

Отказ от всех изменений, сделанных в автономном режиме. Команда Abort в интерактивном режиме влияния не оказывает.

Синтаксис

abort

Параметры

/?
Отображает справку в командной строке.

add helper

Установка DLL модуля поддержки netsh.

Синтаксис

add helper имя_DLL

Параметры

имя_DLL
Обязательный параметр. Задает имя DLL модуля поддержки, который требуется установить.
/?
Отображает справку в командной строке.

псевдоним

Добавление псевдонима, состоящего из определенной пользователем символьной строки, которую netsh обрабатывает как эквивалентную другой строке. При использовании без параметров команда alias отображает все доступные псевдонимы.

Синтаксис

alias [имя_псевдонима] [строка1 [строка2 ...]]

Параметры

alias [имя_псевдонима]
Отображение указанного псевдонима.
alias [имя_псевдонима][строка1[строка2 ...]]
Настраивает имя_псевдонима для указанной строки (строк).
/?
Отображает справку в командной строке.

Примеры

Приведенный ниже образец сценария netsh задает два псевдонима netsh, «Shaddr» и «Shp», а затем сохраняет командную строку Netsh в контексте IP-интерфейса:

alias shaddr show interface ip addr
alias shp show helpers
interface ip

При вводе команды shaddr в командной строке Netsh, программа Netsh.exe интерпретирует ее как команду show interface ip addr. При вводе команды shp в командной строке Netsh программа Netsh.exe интерпретирует ее как команду show helpers.

Выход из программы Netsh.exe.

Синтаксис

вспомогательный

Параметры

/?
Отображает справку в командной строке.

выделенная память

Фиксация всех изменений, внесенных в маршрутизатор в автономном режиме. Команда Commit в интерактивном режиме влияния не оказывает.

Синтаксис

commit

Параметры

/?
Отображает справку в командной строке.

Удаление DLL модуля поддержки из netsh.

Синтаксис

delete helper имя_DLL

Параметры

имя_DLL
Обязательный параметр. Указывает имя DLL модуля поддержки, который требуется удалить.
/?
Отображает справку в командной строке.

Создание сценария, содержащего текущую конфигурацию. При сохранении сценария в виде файла можно использовать его для восстановления измененных параметров конфигурации. При использовании без параметров команда dump отображает конфигурацию всех контекстов netsh.

Синтаксис

dump [имя_файла]

Параметры

[имя_файла]
Указывает имя файла, в который требуется перенаправить вывод.
/?
Отображает справку в командной строке.

Загрузка файла сценария и запуск команд в нем.

Синтаксис

exec файл_сценария

Параметры

файл_сценария
Обязательный параметр. Указывает имя сценария, который требуется загрузить и запустить.

Примечания

  • Команда файл_сценария может выполняться на одном или нескольких компьютерах.

Выход из программы Netsh.exe.

Синтаксис

exit

Параметры

/?
Отображает справку в командной строке.

Вывод справки.

Синтаксис

{/?|?|help|h}

Параметры

отсутствуют

автономный

Переключение в автономный режим работы.

Синтаксис

offline

Параметры

/?
Отображает справку в командной строке.

Примечания

  • Изменения, произведенные в данном режиме, сохраняются, но для внесения изменений в маршрутизатор необходимо запустить команду commit или online.
  • При переключении из автономного режима в интерактивный режим изменения, внесенные в автономном режиме, вносятся в текущую конфигурацию.
  • Изменения, внесенные в интерактивном режиме, немедленно вносятся в текущую конфигурацию.

Переключение в интерактивный режим работы.

Синтаксис

online

Параметры

/?
Отображает справку в командной строке.

Примечания

  • Изменения, внесенные в интерактивном режиме, немедленно вносятся в текущую конфигурацию.
  • При переключении из автономного режима в интерактивный режим изменения, внесенные в автономном режиме, вносятся в текущую конфигурацию.

Восстановление контекста из стека.

Синтаксис

popd

Параметры

/?
Отображает справку в командной строке.

Примечания

  • При использовании вместе с командой pushd команда popd позволяет изменять контекст, запускать команду в новом контексте, а затем возобновлять прежний контекст.

Примеры

Приведенный образец сценария превращает корневой контекст в контекст interface ip, добавляет статический IP-маршрут, а затем возвращается к корневому контексту:

netsh>pushd
netsh>interface ip
netsh interface ip>set address local static 10.0.0.9 255.0.0.0 10.0.0.1 1
netsh interface ip>popd netsh>

Сохранение текущего контекста в стеке буфера FILO.

Синтаксис

pushd

Параметры

/?
Отображает справку в командной строке.

Примечания

  • При использовании вместе с командой popd команда pushd позволяет изменять контекст, запускать команду в новом контексте, а затем возобновлять прежний контекст.

Выход из программы Netsh.exe.

Синтаксис

quit

Параметры

/?
Отображает справку в командной строке.

Задать для файла

Копирование вывода окна командной строки в файл.

Синтаксис

set file {open имя_файла|append имя_файла|close}

Параметры

open имя_файла
Отправка вывода окна командной строки в указанный файл.
append имя_файла
Присоединения вывода окна командной строки к указанному существующему файлу.
закрыть
Прекращение отправки вывода и закрытие файла.
/?
Отображает справку в командной строке.

Примечания

  • Использование команды имя_файла

    Если указанное имя_файла не существует, программа netsh создает новый файл с этим именем. Если указаное имя_файла существует, программа netsh перезаписывает существующий файл.

Примеры

Чтобы создать новый файл журнала с именем Session.log и скопировать весь последующий ввод и вывод программы netsh в файл Session.log, введите:

set file open c:\session.log

Задает текущий компьютер, на котором будут выполняться задачи по настройке. При использовании без параметров команда set machine задает локальный компьютер.

Синтаксис

set machine [[имя_компьютера=]строка]

Параметры

Имя_компьютера
Задает текущий компьютер, на котором будут выполняться задачи по настройке.
строка
Указывает расположение удаленного компьютера.
/?
Отображает справку в командной строке.

Примечания

  • Выполнение задач по настройке на нескольких компьютерах

    Запуск команд на нескольких компьютерах можно производить с помощью одного сценария. Команду set machine можно использовать для указания компьютера назначения (например, компьютер_А), а затем запустить команды, которые следуют за командой set machine на данном компьютере (то есть, компьютере А). Команду set machine можно использовать для указания еще одного компьютера назначения (например, компьютер_B), а затем выполнить команды на этом компьютере (то есть, на компьютере B).

Устанавливает интерактивный или автономный режим работы.

Синтаксис

set mode {online|offline}

Параметры

интерактивные
Выполняет переключение в интерактивный режим работы.
автономный
Выполняет переключение в автономный режим работы.
/?
Отображает справку в командной строке.

Отображение псевдонима, модуля поддержки и текущего режима.

Синтаксис

show {alias|helper|mode}

Параметры

псевдоним
Выводит список всех заданных псевдонимов.
модуль поддержки
Отображает список всех модулей поддержки верхнего уровня.
режим
Отображает текущий режим.
/?
Отображает справку в командной строке.

Удаление указанного псевдонима.

Синтаксис

unalias имя_псевдонима

Параметры

имя_псевдонима
Обязательный параметр. Задает имя псевдонима.
/?
Отображает справку в командной строке.


Команды Netsh для базы данных AAAA

Команды Netsh для базы данных AAAA используются для отображения и изменения параметров базы данных (authentication, authorization, accounting, and auditing), используемой (AAAA) службой проверки подлинности в Интернете (IAS), а также службой маршрутизации и удаленного доступа. Базу AAAA также называют базой данных IAS (Ias.mdb). В основном команды Netsh AAAA применяются для экспорта конфигурации сервера IAS в виде сценария Netsh и последующего импорта этой конфигурации на друглй сервер IAS с помощью команды netsh exec.

Команды Netsh не могут быть запущены локально под Windows XP Professional или Windows XP Home Edition. Для запуска этих команд Netsh на удаленном сервере под управлением Windows 2000 Server необходимо подключиться к серверу, на котором запущен сервер терминалов, с помощью программы «Подключение к удаленному рабочему столу». Эти команды запускаются из командной строки Windows 2000 или из командной строки средства Netsh для AAAA. Для запуска этих команд из командной строки Windows 2000 необходимо перед вводом команд и параметров (описанных ниже) ввести netsh aaaa. Функции команд Netsh для Windows 2000 и Windows XP могут различаться.

Дополнительные сведения о команде Netsh см. в разделе Использование команды Netsh.

Отображение конфигурации базы данных IAS (Ias.mdb) с виде сценария командной строки Netsh.

Синтаксис

dump

Примечания

  • Команда dump отображает сценарий командной строки, который может быть использован для дублирования конфигурации сервера с IAS или службой маршрутизации и удаленного доступа, на котором запущена данная команда. Сценарий командной строки Netsh содержит конфигурацию файла базы данных IAS (Ias.mdb) в сжатом текстовом формате в виде большого блока данных. Этот большой блок данных используется командой сценария set config для импорта конфигурации в существующую базу данных IAS на данном или другом компьютере с помощью команды netsh exec. Для сохранения сценария Netsh в файле введите в командной строке команду netsh aaaa show config > путь\файл.txt
  • Команда dump недоступна на компьютерах с операционной системой Windows 2000 Server.

Отображение конфигурации базы данных IAS (Ias.mdb) с виде сценария командной строки Netsh.

Синтаксис

show config

Примечания

  • Команда show config аналогична команде dump.
  • Команда show config отображает сценарий командной строки, который может быть использован для дублирования конфигурации сервера с IAS или службой маршрутизации и удаленного доступа, на котором запущена данная команда. Сценарий командной строки Netsh содержит конфигурацию файла базы данных IAS (Ias.mdb) в сжатом текстовом формате в виде большого блока данных. Этот большой блок данных используется командой сценария set config для импорта конфигурации в существующую базу данных IAS на данном или другом компьютере с помощью команды netsh exec. Для сохранения сценария Netsh в файле введите в командной строке команду netsh aaaa show config > путь\файл.txt
  • Команда show config недоступна на компьютерах с операционной системой Windows 2000 Server.

Настройка базы данных IAS с помощью сведений в указанном блоке данных.

Синтаксис

set config [blob=] блок_данных

Параметры

[blob=] блок/_данных
Обязательный параметр. Указание конфигурации базы данных IAS в сжатом текстовом файле, выводимом командой dump или show config.
/?
Отображение справки в командной строке.

Примечания

  • Команда set config не используется отдельно. Она используется только со сценарием командной строки Netsh, созданном с помощью команды dump или show config.
  • Версия базы IAS, в которую импортируется блок данных, должна соответствовать версии базы, из которой данные импортировались. Версия базы данных IAS, из которой была экспортирована конфигурация, содержится в сценарии командной строки Netsh. Версия базы данных IAS, на которой выполняется сценарий Netsh, используется команда show version.

Отображение версии базы данных IAS.

Синтаксис

show version

Примеры

Чтобы отобразить сценарий командной строки Netsh, содержащий текущее состояние базы данных IAS, введите команду:

show config

Для вывода версии базы данных IAS, используемой на сервере, введите команду:

show version


Команды Netsh для протокола DHCP

Команды Netsh для службы DHCP предлагают средство администрирования серверов DHCP из командной строки, которое может быть использовано в качестве альтернативы управлению с помощью консоли. Это может быть полезно в следующих ситуациях:

  • при управлении серверами DHCP в глобальных сетях можно использовать команды Netsh в интерактивном режиме для лучшего управления через сетевые связи с низкой скоростью передачи данных;
  • при управлении большим числом серверов DHCP можно использовать команды в пакетном режиме в командной строке Netsh для создания сценариев и автоматизации повторяющихся административных задач, которые требуется выполнить для всех серверов DHCP.

Следующие команды доступны в командной строке Netsh (отличной от командной строки Windows XP). Эти команды Netsh нельзя запускать локально в Windows XP Professional или Windows XP Home Edition. Чтобы запустить эти команды Netsh на удаленном сервере Windows 2000 Server, необходимо сначала использовать подключение к удаленному рабочему столу для соединения с Windows 2000 Server, работающим под управлением сервера терминалов. В Windows 2000 и в Windows XP между контекстными командами Netsh могут существовать некоторые различия.

Пример по использованию команд Netsh для протокола DHCP в пакетных файлах и сценариях см. в разделе Пример команд Netsh DHCP.

Дополнительные сведения о командах netsh см. в разделе Использование Netsh.

Netsh DHCP

Следующие команды доступны для выполнения из командной строки dhcp>, вложенной в среду netsh.

Добавление сервера DHCP в список авторизованных серверов в Active Directory.

Синтаксис

add server DNS_сервера IP_сервера

Параметры

DNS_сервера
Обязательный параметр. Указание DHCP-сервера, который необходимо добавить. Определение сервера по доменному имени DNS.
IP_сервера
Обязательный параметр. Указание DHCP-сервера, который необходимо добавить. Определение сервера по IP-адресу.

Примеры

В представленном далее примере при помощи этой команды сервер с DNS-именем dhcpsrv1.example.microsoft.com и IP адресом 10.2.2.2 добавляется в список авторизованных серверов в Active Directory.

add server dhcpsrv1.example.microsoft.com 10.2.2.2

Удаление сервера DHCP из списка авторизованных серверов в Active Directory.

Синтаксис

delete server DNS_сервера IP_сервера

Параметры

DNS_сервера
Обязательный параметр. Задает DHCP-сервер, который будет удален. Определение сервера по доменному имени DNS.
IP_сервера
Обязательный параметр. Задает DHCP-сервер, который будет удален. Определяет сервер по IP-адресу.

Примеры

В представленном далее примере при помощи этой команды сервер с DNS-именем dhcpsrv1.example.microsoft.com и IP адресом 10.2.2.2 удаляется из списка авторизованных серверов в Active Directory.

delete server dhcpsrv1.example.microsoft.com 10.2.2.2

Выводит конфигурацию DHCP-сервера в окно командной строки или в текстовый файл. При использовании без параметров эта команда выводит конфигурацию локального сервера в окно командной строки.

Синтаксис

[{\\Имя_сервера | IP-адрес}] dump > [Имя_файла]

Параметры

[{\\Имя_сервера | IP-адрес}]
Определяет имя удаленного (не локального) DHCP-сервера, конфигурацию которого необходимо вывести. Определение сервера по имени или IP-адресу. Если этот параметр не определен, создается копия конфигурации локального сервера.
Имя_файла
Указывает имя файла, в котором требуется создать копию конфигурации DHCP-сервера. Если параметр не определен, в окне командной строки выводится конфигурация DHCP-сервера.

Примечания

  • При помощи этой команды конфигурация DHCP-сервера выводится в окне командной строки в текстовом формате. Можно также скопировать или перенаправить результат в файл для последующего просмотра в текстовом редакторе. При получении файла вывода можно использовать команду exec, чтобы выполнить файл для настройки конфигурации другого DHCP-сервера.
  • Перед выполнением команды dump на исходном сервере следует согласовать все области и устранить имеющиеся несоответствия.
  • Следующая команда выводит сведения о текущей конфигурации локального сервера DHCP (исходного сервера) в текстовый файл с именем dhcpcfg.dmp. Этот файл можно скопировать на другой DHCP-сервер (конечный сервер) и использовать для воссоздания исходной конфигурации на конечном сервере.

    dump > dhcpcfg.dmp

  • Перед использованием команды exec для выполнения файла выхода на исходном выполните следующий действия.
    1. Закройте консоль DHCP на конечном сервере. Не открывайте повторно консоль до завершения выполнения команды exec.
    2. Удалите определения всех параметров по умолчанию, а также все классы вендоров и классы пользователей на сервере назначения.
  • В следующих примерах показано использование команд Netsh delete optiondef и del class для удаления определений всех параметров по умолчанию и классов вендоров и пользователей. Следующие команды можно запустить из командной строки dhcp server>, вложенной в среду netsh.
    • delete optiondef 01
    • delete optiondef 76
    • del class "Класс маршрутизации и удаленного доступа по умолчанию"
    • del class "Класс BOOTP по умолчанию"
    • del class "Параметры Microsoft Windows 2000"
    • del class "Параметры Microsoft Windows 98"
    • del class "Параметры Microsoft"
  • На сервере назначения команда exec используется для загрузки и выполнения сохраненной конфигурации.

    netsh exec dhcpcfg.dmp

  • После использования команды exec для загрузки файла копии памяти следует снова согласовать все области. Команда net stop dhcpserver используется для остановки службы сервера DHCP, а команда net start dhcpserver — для повторного запуска. После повторного запуска службы сервера вступают в силу изменения базы данных DHCP.

Примеры

В первом примере при помощи этой команды конфигурация DHCP-сервера \\DHCP-A выводится в текстовом файле с именем dhcpcfg.dmp.

Во втором примере при помощи этой команды конфигурация DHCP-сервера 10.0.0.1 выводится в текстовом файле с именем dhcpcfg.dmp.

В третьем примере при помощи этой команды конфигурация локального DHCP-сервера выводится в текстовом файле с именем dhcpcfg.dmp.

\\DHCP-A dump > dhcpcfg.dmp

10.0.0.1 dump > dhcpcfg.dmp

dump > dhcpcfg.dmp

Переход из текущего контекста командной строки Netsh DHCP на другой DHCP-сервер. При использовании команды server без параметров выполняется переход их текущего контекста командной строки на локальный компьютер.

Синтаксис

server [{\\Имя_сервера | IP_сервера}]

Параметры

{\\Имя_сервера | IP_сервера}
Определяет DHCP-сервер, на который необходимо перейти из текущего контекста командной строки. Определение сервера по имени NetBIOS или IP-адресу.

Примеры

В первом примере при помощи этой команды контекст командной строки Netsh DHCP изменяется на DHCP-сервер с именем \\DHCP-SRV1.

Во втором примере при помощи этой команды контекст командной строки Netsh DHCP изменяется на DHCP-сервер с IP-адресом 10.0.0.1.

server \\DHCP-SRV1

server 10.0.0.1

Отображает список авторизованных серверов в Active Directory.

Синтаксис

show server

Параметры

отсутствуют

Netsh DHCP server

Следующие команды доступны для выполнения из командной строки dhcp server>, вложенной в среду netsh.

Добавление класса на указанный сервер DHCP.

Синтаксис

add class Имя_класса [Дополнительные_данные_о_классе] [Данные] [[IsVendor=]{0 | 1}] [[IsBinary=]{B | b}]

Параметры

Имя_класса
Обязательный параметр. Определяет имя создаваемого класса.
Дополнительные_данные_о_классе
Определяет дополнительные сведения о классе.
Данные
Определяет данные класса в формате ASCII или в двоичном формате в зависимости от параметра IsBinary. Если параметр не определен, предполагается, что данные имеют формат ASCII.
[IsVendor=]{0 | 1}
Указывает, является ли добавляемый класс классом пользователей или классом вендоров: 0 — класс пользователей (по умолчанию), 1 — класс вендоров.
[IsBinary=]{B | b}
Указывает, что данные класса имеют двоичный формат. Если параметр не определен, предполагается, что данные имеют формат ASCII.

Примеры

В первом примере командой создается класс вендоров с именем MyClass, дополнительными сведениями TestClass, данными класса TestDataForMyClass в формате ASCII.

Во втором примере командой создается класс пользователей с именем MyUserClass и данными в двоичном формате 4345335532 (ASCII-CE3U2).

В третьем примере представлен альтернативный синтаксис команды для второго примера.

add class MyClass TestClass TestDataForMyClass 1

add class MyUserClass TestClass1 4345335532 B

add class MyUserClass TestClass1 4345335532 0 b

Добавление многоадресной области на определенный сервер DHCP.

Синтаксис

add mscope Имя_многоадресной_области [Дополнительные_сведения_о_многоадресной_области] [TTL]

Параметры

Имя_многоадресной_области
Обязательный параметр. Задание имени добавляемой многоадресной области.
Дополнительные_сведения_о_многоадресной_области
Задание описания текущей многоадресной области.
TTL
Задание значения времени жизни (TTL) для многоадресной области. В этом поле значения могут находиться в диапазоне от 1 до 255 (значение по умолчанию — 32).

Примеры

В представленном далее примере этой командой создается многоадресное поле с именем My MultiCast Scope, дополнительными сведениями MyTestMulticastScope и многоадресным сроком жизни, равным 40 минутам.

add mscope "My MultiCast Scope" MyTestMulticastScope 40

Добавление определения нового типа параметра на сервер DHCP.

Синтаксис

add optiondef Код_параметра Имя_параметра {BYTE | WORD | DWORD | STRING | IPADDRESS} [[IsArray=]{0 | 1}] [vendor=Класс_вендоров] [comment=Дополнительные_сведения_о_параметре] [Значение_по_умолчанию]

Параметры

Код_параметра
Обязательный параметр. Задание типа определяемого параметра. Задание типа параметра с уникальным кодом параметра. В качестве значения кода выбирается число в диапазоне от 0 до 255.
Имя_параметра
Обязательный параметр. Определение имени типа параметра.
{BYTE | WORD | DWORD | STRING | IPADDRESS}
Обязательный параметр. Указывает тип данных параметра.
[IsArray=]{0 | 1}
Указывает, является ли тип данных массивом или не массивом: 0 — унарный формат или не массив (по умолчанию), 1 — массив.
vendor=Класс_вендоров
Указывает класс вендоров для параметра. Если параметр не определен, используется класс вендора по умолчанию, класс стандартного параметра DHCP.
comment=Дополнительные_сведения_о_параметре
Указывает дополнительные сведения, которые необходимо добавить в определение типа нового параметра. Если параметр не определен, по умолчанию используется значение NULL.
Значение_по_умолчанию
Указывает значение по умолчанию, которое необходимо использовать для этого параметра, если значение не указано.

Примечания

  • Для параметров типа STRING должно использоваться значение 0 параметра IsArray.

Примеры

В первом примере этой командой определяется тип нового параметра с именем ExtensionsPath, кодом 18, типом данных STRING, и тип включается в класс стандартных параметров DHCP. При этом назначается значение по умолчанию c:\temp.

Во втором примере этой командой определяется тип нового параметра с именем TestOption, кодом 231 и типом данных IPADDRESS. Во втором примере параметр определен для предоставления только одного IP-адреса. Параметры IsArray и Значение_по_умолчанию не являются обязательными, поскольку подразумеваются значения по умолчанию. В третьем примере параметры Значение_по_умолчанию и IsArray являются обязательными для создания массива, содержащего значения IP-адреса 10.1.1.1, 10.1.1.2 и 10.1.1.3.

add optiondef 18 ExtensionsPath STRING 0 c:\temp

add optiondef 231 TestOption IPADDRESS

add optiondef 231 TestOption IPADDRESS 1 vendor=MyVendorClass 10.1.1.1 10.1.1.2 10.1.1.3

Добавление области на указанный сервер DHCP.

Синтаксис

add scope Адрес_области Маска_подсети Имя_области [Дополнительные_сведения_об_области]

Параметры

Адрес_области
Обязательный параметр. Указывает добавляемую область. Определение области по номеру сети IP.
Маска_подсети
Обязательный параметр. Указывает маску подсети для добавляемой области.
Имя_области
Обязательный параметр. Указывает имя области.
Дополнительные_сведения_об_области
Указывает дополнительные сведения об области

Примеры

В представленном далее примере этой командой добавляется область для DHCP-сервера с адресом области 10.2.2.0, маской подсети 255.255.255.0, именем маски MyScope и дополнительными сведениями об области MyComment.

add scope 10.2.2.0 255.255.255.0 MyScope MyComment

Удаление класса с определенного сервера DHCP.

Синтаксис

delete class Имя

Параметры

Имя
Обязательный параметр. Указывает класс пользователей или вендоров, который необходимо удалить.

Примеры

В представленном далее примере этой командой удаляется класс с именем MyClass.

delete class MyClass

Удаление многоадресной области с определенного сервера DHCP.

Синтаксис

delete mscope Имя_многоадресной_области

Параметры

Имя_многоадресной_области
Обязательный параметр. Указывает многоадресную область, которую необходимо удалить. При вводе значения Имя_многоадресной_области учитывается регистр.

Примеры

В представленном далее примере этой командой удаляется многоадресная область MyMulitcastScope из текущего DHCP-сервера.

delete mscope MyMulitcastScope

Удаление типа определенного параметра из указанного сервера DHCP.

Синтаксис

delete optiondef Код_параметра [[vendor=]Имя_вендора]

Параметры

Код_параметра
Обязательный параметр. Указывает уникальный идентификатор для удаляемого типа параметра.
vendor=Имя_вендора
Задание имени класса вендоров, с которым связан тип параметра. Если параметр не определен, определение типа параметра удаляется из класса стандартных параметров DHCP, определяемых не для вендоров.

Примечания

  • Этот параметр используется только на DHCP-серверах, работающих под управлением Windows 2000 Server.

Примеры

В представленном далее примере из класса стандартных параметров DHCP этой командой удаляется тип параметра с кодом 18.

delete optiondef 18

Удаление текущего значения типа определенного параметра для заданного DHCP-сервера.

Синтаксис

delete optionvalue Код_параметра [[vendor=]Класс_вендоров] [[user=]Класс_пользователей]

Параметры

Код_параметра
Обязательный параметр. Указание уникального идентификатора параметра глобального сервера, значение которого удаляется.
vendor=Класс_вендоров
Задает имя класса вендоров, с которым связан параметр. Если тег не включен, используется глобальное Имя_вендора, заданное командой set vendorclass. Если указан тег без значения, никакой класс вендоров не используется. Этот параметр доступен только на компьютерах, работающих под управлением Windows 2000 Server.
user=Класс_пользователей
Задает имя класса пользователей, с которым связан параметр. Если тег не включен, используется глобальное Имя_пользователя, заданное командой set userclass. Если указан тег без значения, никакой класс пользователей не используется. Этот параметр доступен только на компьютерах, работающих под управлением Windows 2000 Server.

Примеры

В представленном далее примере этой командой удаляется текущее значение типа параметра с кодом 18.

delete optionvalue 18

Удаление области с определенного сервера DHCP.

Синтаксис

delete scope Адрес_области {DHCPNOFORCE | DHCPFULLFORCE}

Параметры

Адрес_области
Обязательный параметр. Задает адрес области, которую необходимо удалить.
{DHCPNOFORCE | DHCPFULLFORCE}
Обязательный параметр. Указывает условие удаления области: DHCPNOFORCE — удаление области, если в области нет активных клиентов, DHCPFULLFORCE — удаление области вне зависимости от наличия активных клиентов.

Примеры

В представленном далее примере командой игнорируются все предупреждения и удаляется область 10.2.2.0 с DHCP-сервера.

delete scope 10.2.2.0 dhcpfullforce

Удаление суперобласти с определенного сервера DHCP.

Синтаксис

delete superscope Имя_суперобласти

Параметры

Имя_суперобласти
Обязательный параметр. Задает имя удаляемой суперобласти.

Примечания

  • Суперобласть можно задать из контекста области при помощи команды set superscope.
  • При вводе имени суперобласти учитывается регистр.

Примеры

В представленном далее примере этой командой удаляется суперобласть с именем My Superscope из текущего DHCP-сервера.

delete superscope "My Superscope"

Экспорт конфигурации службы DHCP в файл.

Синтаксис

export [Путь]Имя_файла {all | Список_областей}

Параметры

[Путь] Имя_файла
Обязательный параметр. Указывает имя файла, в котором будет сохранена конфигурация DHCP. Если путь, имя файла или оба этих параметра содержат пробелы, необходимо использовать кавычки.
{all | Список_областей}
Обязательный параметр. Указывает области, которые необходимо удалить. При выборе параметра all экспортируются все области. При выборе параметра Список_областей будут экспортированы области, соответствующие IP-адресам в списке. Каждый IP-адрес в списке должны быть отделен пробелами.

Примечания

  • Эта команда работает только на локальном сервере.
  • При запуске команды export работа службы DHCP останавливается и служба не отвечает клиентам DHCP, посылающим запросы аренды или на обновление аренды.
  • Если в службе DHCP имеется большое количество областей или большое количество арендованных адресов клиентов, для выполнения команды может понадобиться некоторое время.

Примеры

В первом примере этой командой в файл c:\temp\dhcpdb экспортируется полная конфигурация службы DHCP.

Во втором примере этой командой в файл c:\temp\dhcpdb экспортируется конфигурация DHCP областей 10.0.0.0 и 192.168.0.0.

В третьем примере этой командой в файл C:\My Folder\Dhcp Configuration экспортируется полная конфигурация службы DHCP. Оба пути и имени файлов содержат пробелы, поэтому необходимо использовать кавычки.

export c:\temp\dhcpdb all

export c:\temp\dhcpdb 10.0.0.0 192.168.0.0

export "C:\My Folder\Dhcp Configuration" all

Импорт конфигурации службы DHCP из файла в локальную службу.

Синтаксис

import [Путь]Имя_файла {all | Список_областей}

Параметры

[Путь] Имя_файла
Обязательный параметр. Указывает имя файла, из которого будет импортирована конфигурация DHCP. Если путь, имя файла или оба этих параметра содержат пробелы, необходимо использовать кавычки.
{all | Список_областей}
Обязательный параметр. Указывает области, которые необходимо импортировать. При выборе параметра all все области в указанном файле будут импортированы. При выборе параметра Список_областей будут импортированы области, соответствующие IP-адресам в списке. IP-адреса в списке должны быть отделены пробелами.

Примечания

  • Эта команда работает только на локальном сервере.
  • При запуске команды import работа службы DHCP останавливается и служба не отвечает клиентам DHCP, посылающим запросы аренды или на обновление аренды.
  • Если в службе DHCP имеется большое количество областей или большое количество арендованных адресов клиентов, для выполнения команды может понадобиться некоторое время.

Примеры

В первом примере этой командой из файла c:\temp\dhcpdb импортируется полная конфигурация службы DHCP.

Во втором примере этой командой из файла c:\temp\dhcpdb импортируется конфигурация DHCP областей 10.0.0.0 и 192.168.0.0.

В третьем примере этой командой из файла C:\My Folder\Dhcp Configuration импортируется полная конфигурация службы DHCP. Оба пути и имени файлов содержат пробелы, поэтому необходимо использовать кавычки.

import c:\temp\dhcpdb all

import c:\temp\dhcpdb 10.0.0.0 192.168.0.0

import "C:\My Folder\Dhcp Configuration" all

Инициирование авторизации определенного сервера DHCP в Active Directory.

Синтаксис

initiate auth

Параметры

отсутствуют

Переключение контекста командной строки на многоадресную область DHCP.

Синтаксис

mscope Имя_многоадресной_области

Параметры

Имя_многоадресной_области
Обязательный параметр. Определяет имя многоадресной области, на которую необходимо переключить контекст командной строки.

Примечания

  • Эта команда позволяет использовать любые доступные команды для многоадресной области DHCP в определенной многоадресной области DHCP. Дальнейшие операции будут выполнены в этой многоадресной области на указанном сервере.
  • При вводе имени многоадресной области учитывается регистр.

Примеры

В представленном далее примере этой командой переключается контекст командной строки на многоадресную область с именем My Multicast Scope.

mscope "My Multicast Scope"

Переключение контекста командной строки на область DHCP.

Синтаксис

scope IP-адрес_области

Параметры

IP-адрес_области
Обязательный параметр. Определяет область, на которую необходимо переключить контекст командной строки. Определяет область по имени или IP-адресу сети или подсети.

Примечания

  • Эта команда позволяет использовать любые доступные команды для области DHCP в определенной области DHCP. Дальнейшие операции будут выполнены в этой области на указанном сервере.

Примеры

В представленном далее примере этой командой переключается контекст командной строки на область с IP-адресом 10.0.0.0.

scope 10.0.0.0

Задание параметров пути журнала аудита для определенного сервера DHCP.

Синтаксис

set auditlog Путь_нового_журнала_аудита

Параметры

Путь_нового_журнала_аудита
Обязательный параметр. Указывает локальную папку для DHCP-сервера, используемую для сохранения файлов журнала аудита. Необходимо указать допустимый путь папки, а папка должна быть расположена на DHCP-сервере, на котором определен путь.

Примечания

  • Чтобы это изменение вступило в действие, необходимо остановить и заново запустить службу DHCP после выполнения команды.

Примеры

В представленном далее примере этой командой в папке c:\logpath DHCP-сервера сохраняются файлы журнала аудита.

set auditlog c:\logpath

Задание интервала резервного копирования указанного сервера DHCP.

Синтаксис

set databasebackupinterval Новый_интервал

Параметры

Новый_интервал
Обязательный параметр. Указывает интервал резервного копирования в минутах.

Примеры

В представленном далее примере этой командой задается интервал 1440 минут (24 часа) резервного копирования базы данных для указанного DHCP-сервера.

set databasebackupinterval 1440

Задание интервала резервного копирования базы данных для указанного сервера DHCP.

Синтаксис

set databasebackuppath Новый_путь_резервной_копии

Параметры

Новый_путь_резервной_копии
Обязательный параметр. Указывает локальную папку для DHCP-сервера, используемую для сохранения файлов журнала аудита. Необходимо указать допустимый путь папки, а папка должна быть расположена на DHCP-сервере, на котором определен путь.

Примеры

В представленном далее примере этой командой задается путь резервной копии базы данных c:\winnnt\dhcp\backup.

set databasebackuppath c:\winnt\dhcp\backup

Задание интервала очистки базы данных указанного сервера DHCP.

Синтаксис

set databasecleanupinterval Новый_интервал

Параметры

Новый_интервал
Обязательный параметр. Указывает интервал очистки базы данных в минутах.

Примеры

В представленном далее примере этой командой задается интервал очистки базы данных 10080 минут (каждые семь дней).

set databasecleanupinterval 10080

Задание значения и сброс флага ведения журнала базы данных указанного сервера DHCP. В случае использования без параметров этой командой сбрасывается значение флага ведения журнала базы данных.

Синтаксис

set databaseloggingflag [{0 | 1}]

Параметры

{0 | 1}
Указывает параметр флага ведения журнала базы данных: 0 — сброс флага (по умолчанию), 1 — установка флага.

Примеры

В представленном далее примере этой командой сбрасывается флаг ведения журнала для текущего текущего DHCP-сервера.

set databaseloggingflag 0

Задание имени файла базы данных сервера DHCP для указанного сервера DHCP.

Синтаксис

set databasename Новое_имя_файла

Параметры

Новое_имя_файла
Обязательный параметр. Указывает новое имя файла базы данных DHCP-сервера.

Примечания

  • Чтобы это изменение вступило в действие, необходимо остановить и заново запустить службу сервера DHCP.

Примеры

В представленном далее примере этой командой задается имя файла newdatabase.mdb базы данных DHCP-сервера.

set databasename newdatabase.mdb

Задание пути файла базы данных сервера DHCP для указанного сервера DHCP.

Синтаксис

set databasepath Новый_путь

Параметры

Новый_путь
Обязательный параметр. Указывает путь файла базы данных DHCP.

Примечания

  • Чтобы это изменение вступило в действие, необходимо остановить и заново запустить службу сервера DHCP.

Примеры

В представленном далее примере этой командой задается путь файла c:\winnnt\dhcp\backup базы данных DHCP-сервера.

set databasepath c:\winnt\dhcp

Задание значения и сброс флага восстановления базы данных указанного сервера DHCP. В случае использования без параметров этой командой сбрасывается значение флага восстановления базы данных.

Синтаксис

set databaserestoreflag [{0 | 1}]

Параметры

{0 | 1}
Указывает параметр флага восстановления базы данных: 0 — сброс флага (по умолчанию), 1 — установка флага.

Примеры

В представленном далее примере этой командой задается флаг восстановления для текущего текущего DHCP-сервера.

set databaserestoreflag 1

Задание числа попыток обнаружения конфликтов для указанного сервера DHCP.

Синтаксис

set detectconflictretry Число_попыток

Параметры

Число_попыток
Обязательный параметр. Указывает число попыток обнаружения конфликтов сервером DHCP перед передачей в аренду IP-адреса клиенту.

Примечания

  • Значение параметра Число_попыток не может превышать 5. При указании значения, превышающего 5, по умолчанию используется значения 5.

Примеры

В представленном далее примере при помощи этой команды DHCP сервером будут предприняты 4 попытки обнаружить конфликт для IP-адреса области перед использованием этого IP-адреса области для аренды нового адреса.

set detectconflictretry 4

Задание параметров динамического обновления DNS для указанного сервера DHCP.

Синтаксис

set dnsconfig [Enable=]{0|1} [[Update=]{0|1}] [[Lookup=]{0|1}] [[NonDyn=]{0|1}]

Параметры

[Enable=]{0|1}
Обязательный параметр. Определяет включение или отключение динамического обновления сведений о клиенте DNS: 0 — отключение динамического обновления сведений о клиенте DNS, 1 — включение динамического обновления сведений о клиенте DNS.
[Update=]{0|1}
Указывает тип просмотров обновления: 0 — обновление в соответствии с запросом клиента, 1 — обновление прямых и обратные просмотров имен.
[Lookup=]{0|1}
Определяет включение или отключение прямых просмотров для клиентов в случае истекшей аренды: 0 — отключение прямых просмотров, 1 — включение прямых просмотров.
[NonDyn=]{0|1}
Определяет обновление сведений DNS для клиентов, не поддерживающих динамические обновления: 0 — отключение обновлений для клиентов, не поддерживающих динамические обновления, 1 — включение динамических обновлений.

Примечания

  • Эта команда поддерживается только на DHCP-серверах, работающих под управлением Windows 2000 Server.
  • Настроенный предпочитаемый сервер DNS в свойствах TCP/IP сервера DHCP будет обновлен с помощью записей клиента DHCP при включении динамических обновлений. Если настроенный предпочитаемый DNS-сервер не доступен в сети, будет обновлен дополнительный DNS-сервер.

Примеры

В следующем примере этой командой включается динамическое обновление сведений DNS DHCP-сервером, а также задаются обновления как для прямых, так и для обратных просмотров. В этом примере также отключается выполнение прямых просмотров в случае истечения аренды и включаются обновления для не динамических клиентов.

set dnsconfig 1 1 0 1

Задание значения параметра DHCP-сервера, которое будет применяться для всех областей, определенных на заданном сервере DHCP

Синтаксис

set optionvalue Код_параметра {BYTE | WORD | DWORD | STRING | IPADDRESS} [[user=]Имя_пользователя] [[vendor=]Имя_вендора] [Значение_параметра]

Параметры

Код_параметра
Обязательный параметр. Указывает уникальный идентификатор для типа параметра, значение которого задается.
{BYTE | WORD | DWORD | STRING | IPADDRESS}
Обязательный параметр. Указывает тип данных для типа параметра, значение которого задается.
[user=]Имя_пользователя
Задает имя применимого класса пользователей, к которому будет применена команда. Если параметр не определен, используется класс пользователей по умолчанию.
[vendor=]Имя_вендора
Задает имя применимого класса вендоров, к которому будет применена команда. Если параметр не определен, используются класс стандартных параметров DHCP.
[Значение_параметра]
Указывает новое серверное значение по умолчанию для типа параметра, определенного параметром Код_параметра. Значение должно иметь связанный тип данных.

Примечания

  • Классы вендоров и пользователей поддерживаются только для серверов DHCP под управлением Windows 2000 Server.
  • Изменить текущие значения по умолчанию для незаданного класса можно с помощью команды set userclass или set vendorclass.

Примеры

В первом примере командой в качестве значения параметра с кодом 003 задаются IP-адреса 10.1.1.1 и 10.1.1.2.

Во втором содержатся дополнительные параметры, не содержащиеся в первом примере, и командой применяется заданное значение только для клиентов областей, определивших себя в качестве участников класса вендоров Vendor1. Чтобы этот пример работал, этот класс должен быть уже определен на сервере с указанным типом параметра, определенным для его использования.

set optionvalue 003 IPADDRESS 10.1.1.1 10.1.1.2

set optionvalue 003 IPADDRESS 10.10,1.1 10.1.1.2

Изменение контекста командной строки Netsh DHCP на указанный сервер. Если параметры не указаны, используется локальный сервер.

Синтаксис

set server [{IP_сервера | \\DNS_сервера}]

Параметры

{IP_сервера | \\DNS_сервера}
Указывает имя DNS или IP-адрес определенного DHCP-сервера.

Примечания

  • При использовании этой команды контекст командной строки Netsh изменяется на другой сервер, а все дальнейшие операции выполняются на указанном сервере. Чтобы операции выполнялись на другом сервере, эта команда должна быть выполнена еще раз с IP-адресом или именем DNS нового сервера, указанного в параметре.

Примеры

В представленном далее примере этой командой переключается контекст командной строки DHCP-сервера на сервер с IP-адресом 10.10.10.1.

set server 10.1.1.1

Задание имени текущего класса пользователей. Если параметры не указаны, в качестве текущего класса пользователей используется класс пользователей по умолчанию.

Синтаксис

set userclass [Класс_пользователей]

Параметры

Класс_пользователей
Задает имя класса пользователей для текущего сервера DHCP.

Примечания

  • Команда доступна для использования только с DHCP-серверами под управлением Windows 2000 Server.

Примеры

В первом примере этой командой задается имя класса пользователей MyUserClass.

Во втором примере этой командой сбрасывается текущее имя класса пользователей и задается использование класса пользователей по умолчанию.

set userclass MyUserClass

set userclass

Задание имени текущего класса вендоров. Если параметры не указаны, в качестве текущего класса вендоров используется класс вендоров по умолчанию, стандартные параметры DHCP.

Синтаксис

set vendorclass [Класс_вендоров]

Параметры

Класс_вендоров
Задает имя класса вендоров для текущего сервера.

Примечания

  • Команда доступна для использования только с DHCP-серверами под управлением Windows 2000 Server.

Примеры

В первом примере этой командой задается имя класса вендоров MyVendorClass.

Во втором примере этой командой сбрасывается текущее имя класса вендоров и задается использование класса вендоров по умолчанию, стандартные параметры DHCP.

set vendorclass MyVendorClass

set vendorclass

Вывод всех сведений о состояниях и конфигурации для указанного сервера DHCP.

Синтаксис

show all

Параметры

отсутствуют

Примечания

  • При помощи этой команды выводятся все состояния текущего сервера и сведения о конфигурации, включая сведения сохраненной информационной базы управления (MIB) для текущего DHCP-сервера.

Вывод всех сведений журнала аудита для текущего сервера DHCP.

Синтаксис

show auditlog

Параметры

отсутствуют

Вывод сведений о привязках указанного сервера DHCP.

Синтаксис

show bindings

Параметры

отсутствуют

Примечания

  • Эта команда отображает сведенья о привязках текущего сервера DHCP с указанием отключенных и включенных для обслуживания DHCP-клиентов в сети активных сетевых подключений, настроенных с помощью статических IP-адресов.
  • Служба DHCP автоматически отключает сетевые подключения, динамически получающие их конфигурацию IP-адресов при помощи привязок службы. Такие действия выполняются по умолчанию.

Перечисление и вывод всех сведений о классах для указанного сервера DHCP. Перечисляются и выводятся сведения о классах вендоров и классах пользователей.

Синтаксис

show class

Параметры

отсутствуют

Вывод заданного числа попыток обнаружения конфликтов для указанного сервера DHCP.

Синтаксис

show detectconflictretry

Параметры

отсутствуют

Примечания

  • Этой командой отображается текущее число попыток проверки связи, используемых для обнаружения конфликтов адресов в области IP-адресов, выдаваемых сервером.

Вывод параметров динамического обновления DNS для указанного сервера DHCP.

Синтаксис

show dnsconfig

Параметры

отсутствуют

Примечания

  • Если конфигурация DNS не была включена или задана, можно использовать консоль DNS или команду set dnsconfig для настройки этих параметров.

Вывод сведений информационной базы управления (MIB) для указанного сервера DHCP.

Синтаксис

show mibinfo

Параметры

отсутствуют

Вывод всех сведений о многоадресных областях для указанного сервера DHCP.

Синтаксис

show mscope

Параметры

отсутствуют

Вывод всех определенных и доступных параметров для указанного сервера DHCP. При использовании без параметров выводятся все параметры.

Синтаксис

show optiondef [vendor=Имя_вендора]

Параметры

vendor=Имя_вендора
Указывает, какие определенные и доступные типы параметров следует отображать. Если параметр не определен, по умолчанию в качестве значения параметра Имя_вендора используется класс вендора по умолчанию, установленный для DHCP-сервера.

Примечания

  • Класс вендоров, используемый по умолчанию, может быть сброшен при помощи команды set vendorclass.
  • Параметр Имя_вендора используется только на DHCP-серверах, работающих под управлением Windows 2000 Server.

Примеры

В первом примере этой командой отображаются все типы определенных параметров для текущего класса вендоров.

Во втором примере этой командой отображаются типы определенных параметров, доступные для использования с указанным классом Vendor1.

show optiondef

show optiondef vendor=Vendor1

Вывод текущих значений всех доступных параметров, заданных для указанного сервера DHCP. При использовании без параметров отображаются все значения параметров, включая значения, используемые для классов вендоров и пользователей.

Синтаксис

show optionvalue [user=Имя_пользователя | vendor=Имя_вендора]

Параметры

user=Имя_пользователя
Определяет значения по умолчанию, заданные для типов параметров, доступных для использования с текущим классом пользователей.
vendor=Имя_вендора
Определяет значения по умолчанию, заданные для типов параметров, доступных для использования с текущим классом вендоров.

Примечания

  • Параметры User=Имя_пользователя и vendor=Имя_вендора доступны для использования только с DHCP-серверами под управлением Windows 2000 Server.
  • В случае указания значения Имя_пользователя или Имя_вендора, соответствующие теги (user= или vendor=) являются обязательными. Если теги не включены, по умолчанию используется текущий класс пользователей, заданный при помощи команды set userclass.

Примеры

В представленном далее примере этой командой отображаются все доступные типы параметров, для которых заданы значения на текущем сервере DHCP.

show optionvalue

Вывод сведений о областях для указанного сервера DHCP.

Синтаксис

show scope

Параметры

отсутствуют

Отображает сведения об определенном сервере DHCP, включая полное доменное имя сервера и его IP-адрес.

Синтаксис

show server

Параметры

отсутствуют

Вывод сведений о конфигурации базы данных определенного сервера DHCP.

Синтаксис

show dbproperties

Параметры

отсутствуют

Примечания

  • Этой командой отображаются следующие сведения о конфигурации базы данных.
    • Имя_базы_данных
    • Путь_базы_данных
    • Путь_резервной_копии_базы_данных
    • Интервал_резервного_копирования_базы_данных
    • Флаг_ведения_журнала_базы_данных
    • Флаг_восстановления_базы_данных
    • Интервала_очистки_базы_данных

Вывод сведений о состоянии указанного сервера DHCP.

Синтаксис

show serverstatus

Параметры

отсутствуют

Примечания

  • Пример сведений о типах состояний, отображаемых этой командой:

    Server Attrib - Server Servicing Clients :TRUE

    Server Attrib - Dynamic BootP Support Enabled :TRUE

    Server Attrib - DHCP Server Part Of DS :TRUE

    Server Attrib - DHCP Server Bindings Aware :TRUE

    Server Attrib - Administrative Rights :TRUE

Вывод текущего класса пользователя на указанном сервере DHCP.

Синтаксис

show userclass

Параметры

отсутствуют

Примечания

  • Пример сведений о типах параметров, отображаемых этой командой.

    Current Class Name set for the Server dhcpsrv1.example.microsoft.com is None.

Вывод текущего класса вендора на указанном сервере DHCP.

Синтаксис

show vendorclass

Параметры

отсутствуют

Примечания

  • Пример сведений о типах параметров, отображаемых этой командой.

    Current Vendor Name set for the Server dhcpsrv1.example.microsoft.com is None.

Вывод сведений о текущей версии для указанного сервера DHCP.

Синтаксис

show version

Параметры

отсутствуют

Примечания

  • Пример сведений о типах версий, отображаемых этой командой.

    The version of the DHCP Server 192.168.0.100 is 5.6.

Netsh DHCP server scope

Следующие команды доступны для выполнения из командной строки dhcp server scope>, вложенной в среду netsh.

Добавление диапазона адресов для исключения из текущей области выдаваемых адресов.

Синтаксис

add excluderange Начальный_IP Конечный_IP

Параметры

Начальный_IP
Обязательный параметр. Указывает начальный IP-адрес диапазона исключения.
Конечный_IP
Обязательный параметр. Указывает конечный IP-адрес диапазона исключения.

Примеры

В представленном далее примере этой командой из распределения области исключаются IP-адреса в диапазоне от 10.2.2.10 до 10.2.2.20.

add excluderange 10.2.2.10 10.2.2.20

Добавление диапазона IP-адресов в текущую область.

Синтаксис

add iprange Начальный_IP Конечный_IP [{DHCP | BOOTP | BOTH}] [Максимальное_число_клиентов_BootP]

Параметры

Начальный_IP
Обязательный параметр. Указывает начальный IP-адрес диапазона.
Конечный_IP
Обязательный параметр. Указывает конечный IP-адрес диапазона.
{DHCP | BOOTP | BOTH}
Указывает тип клиента, обслуживаемого областью и диапазоном IP-адресов. Параметр DHCP используется по умолчанию.
Максимальное_число_клиентов_BootP
Устанавливает максимальное число клиентов BOOTP.

Примечания

  • Параметр Максимальное_число_клиентов_BootP используется, только если Тип_клиента поддерживает клиенты типа BOOTP для области. Если используется не обязательный параметр командной строки, все параметры командной строки (обязательные и необязательные), указываемые до команды по выбору, являются необходимыми и должны применяться в правильной последовательности.

Примеры

В представленном далее примере этой командой добавляются клиенты DHCP в диапазоне IP-адресов от 10.2.2.10 до 10.2.2.20 в диапазон распределения в области.

add iprange 10.2.2.10 10.2.2.20

Резервирование IP-адреса для использования указанным MAC-адресом в текущей области.

Синтаксис

add reservedip Зарезервированный_IP-адрес MAC-адрес [Имя_клиента] [Сведения_о_клиенте] [{DHCP | BOOTP | BOTH}]

Параметры

Зарезервированный_IP-адрес
Обязательный параметр. Указывает IP-адрес для резервирования.
MAC-адрес
Обязательный параметр. Указывает физический, аппаратный или MAC-адрес, связываемый с зарезервированным IP-адресом.
Имя_клиента
Указывает имя клиента, связываемое с зарезервированным клиентским устройством. Если параметр не указан, имя клиента не связывается с зарезервированным клиентским устройством.
Сведения_о_клиенте
Указывает сведения о клиенте, связываемые с зарезервированным клиентским устройством. Если параметр не указан, сведения о клиенте не связываются с зарезервированным клиентским устройством.
{DHCP | BOOTP | BOTH}
Указывает тип клиентов, связываемый с зарезервированным клиентским устройством. Параметр DHCP используется по умолчанию.

Примечания

  • Если используется не обязательный параметр командной строки, все параметры командной строки (обязательные и необязательные), указываемые до параметра командной строки по выбору, являются необходимыми и должны применяться в правильной последовательности.

Примеры

В переставленном далее примере этой командой резервируется IP-адрес 10.2.2.32 для использования клиентом DHCP, определяющим MAC-адрес 08-00-2b-30-36-9b при получении аренды в текущей области.

add reservedip 10.2.2.32 08002b30369B

Удаление диапазона исключенных IP-адресов из текущей области.

Синтаксис

delete excluderange Начальный_IP Конечный_IP

Параметры

Начальный_IP-адрес
Обязательный параметр. Указывает начальный IP-адрес диапазона исключения.
Конечный_IP-адрес
Обязательный параметр. Указывает конечный IP-адрес диапазона исключения.

Примеры

В представленном далее примере этой командой удаляется исключенный диапазон, начинающийся с IP-адреса 10.2.1.5 и заканчивающийся IP-адресом 10.2.1.10 из текущей области.

delete excluderange 10.2.1.5 10.2.1.10

Удаление диапазона IP-адресов из текущей области.

Синтаксис

delete iprange Начальный_IP Конечный_IP

Параметры

Начальный_IP-адрес
Обязательный параметр. Указывает начальный IP-адрес удаляемого диапазона.
Конечный_IP-адрес
Обязательный параметр. Указывает конечный IP-адрес удаляемого диапазона.

Примеры

В представленном далее примере этой командой из текущей области удаляются IP-адреса в диапазоне от 10.2.1.5 до 10.2.1.10.

delete iprange 10.2.1.5 10.2.1.10

Удаление или очистка значения параметра области из текущей области.

Синтаксис

delete optionvalue Код_параметра [user=Имя_пользователя] [vendor=Имя_вендора]

Параметры

Код_параметра
Обязательный параметр. Указывает уникальный идентификатор для параметра, значение которого необходимо удалить.
user=Имя_пользователя
Указывает класс пользователей, из которого будет удалено текущее значение параметра. Если указан тег без значения, подразумевается текущий класс пользователя по умолчанию.
vendor=Имя_вендора
Указывает класс вендоров, из которого будет удалено текущее значение параметра. Если указан тег без значения, подразумевается текущий класс вендоров по умолчанию.

Примечания

  • Классы вендоров и пользователей поддерживаются только для серверов DHCP под управлением Windows 2000 Server.
  • При указании класса пользователей, класса вендоров или обоих классов этой командой удаляется значение параметра только из клиентов области, являющихся участниками указанного класса или классов.
  • Изменить текущие значения по умолчанию для незаданного класса, используемые с данной командой, можно с помощью команды set userclass или set vendorclass.

Примеры

В первом примере этой командой из текущей области удаляется текущее значение параметра для кода параметра 18.

Во втором примере этой командой из класса вендоров MyVendorClass удаляется текущее значение параметра для кода параметра 18.

delete optionvalue 18

delete optionvalue 18 vendor="MyVendorClass"

Удаление резервирования для IP-адреса из текущей области.

Синтаксис

delete reservedip Зарезервированный_IP-адрес MAC-адрес

Параметры

Зарезервированный_IP
Обязательный параметр. Указывает зарезервированный IP-адрес, который необходимо удалить из текущей области.
MAC-адрес
Обязательный параметр. Указывает строку МАС-адреса (адрес уровня управления доступом к среде передачи) или физического аппаратного адреса, из которой был зарезервирован IP-адрес.

Примеры

В представленном далее примере этой командой из текущей области удаляется IP-адрес 10.2.1.32 для MAC-адреса 08002B30369B.

delete reservedip 10.2.1.32 08002B30369B

Удаление значения параметра, назначенного для зарезервированного клиента в текущей области.

Синтаксис

delete reservedoptionvalue Зарезервированный_IP-адрес Код_параметра [User=Имя_пользователя] [vendor=Имя_вендора]

Параметры

Зарезервированный_IP-адрес
Обязательный параметр. Задает IP-адрес зарезервированного клиента.
Код_параметра
Обязательный параметр. Указывает уникальный код для типа параметра, назначенного в текущий момент зарезервированному клиенту.
User=Имя_пользователя
Указывает класс пользователей, из которого будет удалено значение параметра. Если указан тег без значения, подразумевается текущий класс пользователя по умолчанию.
vendor=Имя_вендора
Указывает класс вендоров, из которого будет удалено значение параметра. Если указан тег без значения, подразумевается текущий класс вендора.

Примечания

  • Классы вендоров и пользователей поддерживаются только для серверов DHCP под управлением Windows 2000 Server.
  • Изменить текущие значения по умолчанию для незаданного класса, используемые с данной командой, можно с помощью команды set userclass или set vendorclass.

Примеры

В следующем примере этой командой из текущей области удаляется текущее значение параметра с кодом 18 для зарезервированного IP-адреса 10.2.2.32.

delete reservedoptionvalue 10.2.2.32 18

Проверка и согласование текущей области. При использовании без параметров этой командой области проверяются на несоответствие, однако найденные в базе данных несоответствия не устраняются.

Синтаксис

initiate reconcile [fix]

Параметры

[fix]
Указывает, что при использовании команды все несоответствия, найденные в базе данных, по возможности, будут устраняться.

Примеры

В первом примере этой командой области проверяются на наличие несоответствий.

Во втором примере этой командой области проверяются на наличие несоответствий, а найденные несоответствия исправляются.

initiate reconcile

initiate reconcile fix

Задание комментария для текущей области. При использовании без параметров командой set comment удаляется текущий комментарий.

Синтаксис

set comment [Новый_комментарий]

Параметры

[Новый_комментарий]
Указывает строку нового или измененного комментария для области.

Примеры

В первом примере этой командой задается строка комментария, не содержащая пробелов.

Во втором примере этой командой задается строка комментария, содержащая пробелы.

set comment Новый_комментарий_без_пробелов

set comment "Новый комментарий с пробелами"

Задание имени текущей области.

Синтаксис

set name Новое_имя

Параметры

Новое_имя
Обязательный параметр. Указывает новое имя области.

Примеры

В первом примере этой командой задается имя, не содержащее пробелов.

Во втором примере этой командой задается имя, содержащее пробелы.

set name Новое_имя_без_пробелов

set name "Новое имя с пробелами"

Задание значения параметра для текущей области.

Синтаксис

set optionvalue Код_параметра {BYTE | WORD | DWORD | STRING | IPADDRESS} [user=Имя_пользователя] [vendor=Имя_вендора] Значение_параметра

Параметры

Код_параметра
Обязательный параметр. Указывает код типа параметра, для которого задается значение.
{BYTE | WORD | DWORD | STRING | IPADDRESS}
Обязательный параметр. Указывает тип данных типа параметра, для которого задается значение.
user=Имя_пользователя
Указывает класс пользователей. Если указан тег без значения, подразумевается текущий класс пользователей по умолчанию.
vendor=Имя_вендора
Указывает класс вендоров. Если указан тег без значения, подразумевается текущий класс вендоров по умолчанию.
Значение_параметра
Обязательный параметр. Указывает назначенное значение для типа параметра, определенного в параметре Код_параметра. Если тип параметра поддерживает массив, содержащий более одного числового значения или значения IP-адреса, в конце команды следует указать дополнительные значения для использования. Значения должны быть отделены пробелами.

Примечания

  • Классы вендоров и пользователей поддерживаются только для серверов DHCP под управлением Windows 2000 Server.
  • Изменить текущие значения по умолчанию для незаданного класса, используемые с данной командой, можно с помощью команды set userclass или set vendorclass.

Примеры

В первом примере этой командой в качестве значения параметра с кодом 003 задаются два IP-адреса маршрутизаторов (10.1.1.1, 10.1.1.2).

Во втором примере эта команда используется для того, чтобы значение, определенное в первом примере, применялось только для клиентов области, определивших себя как члены класса вендоров Vendor1 (класса, предварительного определенного на сервере с указанным типом параметров, определенным для его использования).

set optionvalue 003 IPADDRESS 10.1.1.1 10.1.1.2

set optionvalue 003 IPADDRESS 10.10,1.1 10.1.1.2

Задание значения параметра для резервирования IP-адреса в текущей области.

Синтаксис

set reservedoptionvalue Зарезервированный_IP-адрес Код_параметра {BYTE | WORD | DWORD | STRING | IPADDRESS} [user=Имя_пользователя] [vendor=Имя_вендора] Значение_параметра

Параметры

Зарезервированный_IP-адрес
Обязательный параметр. Указывает зарезервированный IP-адрес, для которого задается значение параметра.
Код_параметра
Обязательный параметр. Указывает код типа параметра, для которого задается значение.
{BYTE | WORD | DWORD | STRING | IPADDRESS}
Обязательный параметр. Указывает тип данных типа параметра, для которого задается значение.
user=Имя_пользователя
Указывает текущий класс пользователей по умолчанию или класс, определенный параметром Имя_пользователя. Если указан тег без значения, подразумевается текущий класс пользователя по умолчанию.
vendor=Имя_вендора
Указывает текущий класс вендоров по умолчанию или класс, определенный параметром Имя_вендора. Если указан тег без значения, подразумевается текущий класс вендора по умолчанию.
Значение_параметра
Обязательный параметр. Указывает назначенное значение для типа параметра, определенного в параметре Код_параметра. Если тип параметра поддерживает массив, содержащий более одного числового значения или значения IP-адреса, в конце команды следует указать дополнительные значения для использования. Значения должны быть отделены пробелами.

Примечания

  • Классы вендоров и пользователей поддерживаются только для серверов DHCP под управлением Windows 2000 Server.
  • Изменить текущие значения по умолчанию для незаданного класса, используемые с данной командой, можно с помощью команды set userclass или set vendorclass.

Примеры

В представленном далее примере эта команда задает для зарезервированного IP-адреса клиента 10.1.1.50 в текущей области значение параметра маршрутизатора с кодом 003, в соответствии с которым его настроенным маршрутизаторам (стандартным шлюзам) должны быть назначены адреса 10.1.1.1 и 10.1.1.2.

set reservedoptionvalue 10.1.1.50 003 IPADDRESS 10.1.1.1 10.1.1.2

Задание области для использования в дальнейших операциях.

Синтаксис

set scope Адрес_области

Параметры

Адрес_области
Обязательный параметр. Задает IP-адрес области для использования в дальнейших операциях.

Примеры

В представленном далее примере этой командой задается текущая область 10.2.2.0 для последующих операций.

set scope 10.2.2.0

Изменение состояния текущей области на активное или неактивное. При использовании без параметров этой командой область активизируется.

Синтаксис

set state [{0 | 1 | 2 | 3}]

Параметры

{0 | 1 | 2 | 3}
Указывает состояние области: 0 — отмена активизации области, 1 — активизация области (по умолчанию), 2 — отмена активизации и пометка области как отключенной, 3 активизация области и пометка области как активной.

Примечания

  • Значения 2 и 3 обычно используются для коммутируемых сетей или сетей, где несколько логических сетей расположены в отдельной физической сети.

Примеры

В первом примере этой командой активизируется область.

Во втором первом примере этой командой отменяется активизация области.

set state 1

set state 0

Задание суперобласти для использования в дальнейших операциях.

Синтаксис

set superscope Имя_суперобласти {0 | 1}

Параметры

Имя_суперобласти
Обязательный параметр. Задает имя суперобласти, включаемой в текущую область. При задании значения параметра Имя_суперобласти необходимо учитывать регистр.
{0 | 1}
Обязательный параметр. Указывает, является ли суперобласть активной или неактивной: 0 — отмена активизации суперобласти 1 — активизация суперобласти.

Примеры

В представленном далее примере этой командой текущая область добавляется в суперобласть MySuperScope, а суперобласть активизируется.

set superscope MySuperScope 1

Вывод всех доступных клиентов версии 4 для текущей области. При использовании без параметров этой командой выводятся следующие сведения о каждом клиенте: IP-адрес, маска подсети, уникальный код, срок действия аренды и тип.

Синтаксис

show clients [{0 | 1}]

Параметры

{0 | 1}
Указывает уровень подробностей в выводящихся данных: 0 — выводятся следующие сведения о каждом клиенте: IP-адрес, маска подсети, уникальный код, срок действия аренды и тип, 1 — выводятся все сведения, как при выборе параметра 0, а также полное имени домена для каждого клиента.

Примечания

  • Для эффективного просмотра данных, выводящихся командой, следует увеличить ширину окна командной строки по крайней мере до 95 знаков.

Вывод всех доступных клиентов версии 5 для текущей области. При использовании без параметров этой командой выводятся следующие сведения о каждом клиенте: IP-адрес, маска подсети, уникальный код, срок действия аренды и тип.

Синтаксис

show clientsv5 [{0 | 1}]

Параметры

{0 | 1}
Указывает уровень подробностей в выводящихся данных: 0 — выводятся следующие сведения о каждом клиенте: IP-адрес, маска подсети, уникальный код, срок действия аренды и тип (по умолчанию), 1 — выводятся все сведения, как при выборе параметра 0, а также полное имени домена для каждого клиента.

Примечания

  • Для эффективного просмотра данных, выводящихся командой, следует увеличить ширину окна командной строки по крайней мере до 95 знаков.

Вывод всех исключаемых диапазонов IP-адресов для текущей области.

Синтаксис

show excluderange

Параметры

отсутствуют

Примечания

  • Для добавления и удаления исключаемых диапазонов следует использовать другие команды для области.

Вывод всех доступных диапазонов адресов для текущей области.

Синтаксис

show iprange

Параметры

отсутствуют

Вывод всех значений параметров, заданных для текущей области. При использовании без параметров подразумеваются текущие классы пользователей и вендоров по умолчанию.

Синтаксис

show optionvalue [user=Имя_пользователя] [vendor=Имя_вендора]

Параметры

user=Имя_пользователя
Задает отображение параметров, установленных для указанного класса пользователей. Если указан тег без значения, подразумевается текущий класс пользователя по умолчанию.
vendor=Имя_вендора
Задает отображение параметров, установленных для указанного класса вендоров. Если указан тег без значения, подразумевается текущий класс вендора по умолчанию.

Примечания

  • Классы вендоров и пользователей поддерживаются только для серверов DHCP под управлением Windows 2000 Server.
  • Изменить текущие значения по умолчанию для незаданного класса, используемые с данной командой, можно с помощью команды set userclass или set vendorclass.

Примеры

В представленном далее примере этой командой отображаются все параметры и значения, заданные для текущей области для определенного пользователем класса My User Class.

show optionvalue user="My User Class"

Вывод всех IP-адресов, зарезервированных для текущей области.

Синтаксис

show reservedip

Параметры

отсутствуют

Удаление всех заданных значений параметров для зарезервированного IP-адреса клиента в текущей области.

Синтаксис

show reservedoptionvalue Зарезервированный_IP-адрес [user=Имя_пользователя] [vendor=Имя_вендора]

Параметры

Зарезервированный_IP-адрес
Обязательный параметр. Указывает зарезервированные IP-адреса, для которых отображаются текущие параметры.
user=Имя_пользователя
Задает отображение параметров, установленных для указанного класса пользователей. Если указан тег без значения, подразумевается текущий класс пользователя по умолчанию.
vendor=Имя_вендора
Задает отображение параметров, установленных для указанного класса вендоров. Если указан тег без значения, подразумевается текущий класс вендора по умолчанию.

Примечания

  • Классы вендоров и пользователей поддерживаются только для серверов DHCP под управлением Windows 2000 Server.
  • Изменить текущие значения по умолчанию для незаданного класса, используемые с данной командой, можно с помощью команды set userclass или set vendorclass.

Примеры

В представленном далее примере этой командой отображаются значения параметров, заданных для зарезервированного IP-адреса 10.2.2.100 в текущей области.

show reservedoptionvalue 10.2.2.100

Вывод сведений о текущей области.

Синтаксис

show scope

Параметры

отсутствуют

Вывод состояния текущей области (активна или неактивна).

Синтаксис

show state

Параметры

отсутствуют

Netsh DHCP server mscope

Следующие команды доступны для выполнения из командной строки dhcp server mscope>, вложенной в среду netsh.

Чтобы посмотреть синтаксис команды, щелкните команду:

Добавление диапазона исключаемых адресов в текущую многоадресную область.

Синтаксис

add excluderange Начальный_IP Конечный_IP

Параметры

Начальный_IP-адрес
Обязательный параметр. Указывает начальный IP-адрес диапазона исключения.
Конечный_IP-адрес
Обязательный параметр. Указывает конечный IP-адрес диапазона исключения.

Примечания

  • Диапазон исключений должен быть подмножеством диапазона всех адресов области.

Примеры

В представленном далее примере этой командой удаляется диапазон исключений, начинающийся с IP-адреса 224.2.2.10 и заканчивающийся IP-адресом 224.2.2.20 в диапазон распределения текущей многоадресной области.

add excluderange 224.2.2.10 224.2.2.20

Добавление диапазона IP-адресов в текущую многоадресную область.

Синтаксис

add iprange Начальный_IP Конечный_IP

Параметры

Начальный_IP-адрес
Обязательный параметр. Указывает начальный IP-адрес диапазона.
Конечный_IP-адрес
Обязательный параметр. Указывает конечный IP-адрес диапазона.

Примечания

  • Диапазон должен водить в диапазон IP-адресов многоадресной области (от 224.0.0.0 до 239.255.255.255).

Примеры

В представленном далее примере этой командой добавляется диапазон IP-адресов от 224.20.20.10 до 224.20.20.20. в диапазон распределения многоадресной области.

add iprange 224.2.2.10 224.2.2.20

Удаление диапазона исключенных IP-адресов из текущей многоадресной области.

Синтаксис

delete excluderange Начальный_IP Конечный_IP

Параметры

Начальный_IP-адрес
Обязательный параметр. Указывает начальный IP-адрес диапазона исключения.
Конечный_IP-адрес
Обязательный параметр. Указывает конечный IP-адрес диапазона исключения.

Примеры

В представленном далее примере этой командой удаляется исключенный диапазон многоадресной области, начинающийся с IP-адреса 224.20.20.10 и заканчивающийся IP-адресом 224.20.20.20.

delete excluderange 224.20.20.10 224.20.20.20

Удаление диапазона IP-адресов из текущей многоадресной области.

Синтаксис

delete iprange Начальный_IP Конечный_IP

Параметры

Начальный_IP-адрес
Обязательный параметр. Указывает начальный IP-адрес удаляемого диапазона.
Конечный_IP-адрес
Обязательный параметр. Указывает конечный IP-адрес удаляемого диапазона.

Примеры

В представленном далее примере этой командой из всего диапазона полной многоадресной области удаляется диапазон IP-адресов в диапазоне от 224.20.20.10 до 224.20.20.20.

delete iprange 224.20.20.10 224.20.20.20

Проверка и согласование текущей многоадресной области.

Синтаксис

initiate reconcile

Параметры

отсутствуют

Примечания

  • Этой командой проверяется целостность текущей многоадресной области путем сравнения текущего содержания серверной базы данных с зеркальной копией тех же сведений в реестре Windows. Если в базе данных обнаружены несоответствия, они устраняются на основе сведений, дублируемых в реестре. В случае обнаружения несоответствия всегда предпринимается попытка его устранения.

Задание комментария для текущей многоадресной области.

Синтаксис

set comment Новый_комментарий

Параметры

Новый_комментарий
Обязательный параметр. Указывает новый или измененный комментарий для многоадресной области.

Примеры

В первом примере этой командой комментарий многоадресной области изменяется на новый комментарий, не содержащий пробелов.

Во втором примере этой командой комментарий многоадресной области изменяется на новый комментарий, содержащий пробелы.

set comment Новый_комментарий_без_пробелов

set comment "Новый комментарий с пробелами"

Задание продолжительности аренды IP-адресов многоадресной области.

Синтаксис

set lease Время

Параметры

Время
Обязательный параметр. Указывает продолжительности аренды IP-адресов для клиента многоадресной области. При выборе значения -1 продолжительность аренды IP-адреса не ограничивается во времени или бесконечна.

Примеры

В представленном далее примере этой командой задается продолжительность аренды 691200 секунд (восемь дней) для клиентов текущей многоадресной области.

set lease 691200

Задание многоадресной области для использования в дальнейших операциях.

Синтаксис

set mscope Новое_имя

Параметры

Новое_имя
Обязательный параметр. Определяет имя многоадресной области, на которую необходимо изменить контекст командной строки. При вводе значения параметра Новое_имя необходимо учитывать регистр.

Примечания

  • Этой командой изменяется контекст командной строки netsh dhcp server mscope> с одной многоадресной области на другую.
  • Этой командой не задается новое имя текущей многоадресной области. Чтобы изменить имя текущей многоадресной области, следует использовать команду set name.

Примеры

В первом примере этой командой изменяется контекст командной строки на многоадресную область с именем MyMulticastScope. Имя многоадресной области не содержит пробелов.

Во втором примере этой командой изменяется контекст командной строки на многоадресную область с именем My Multicast Scope. Имя многоадресной области содержит пробелы.

set mscope MyMulticastScope

set mscope "My Multicast Scope"

Изменение имени текущей многоадресной области.

Синтаксис

set name Новое_имя

Параметры

Новое_имя
Обязательный параметр. Задание нового имени текущей многоадресной области.

Примеры

В первом примере этой командой задается новое имя для текущей многоадресной области, не содержащее пробелов.

Во втором примере этой командой задается новое имя для текущей многоадресной области, содержащее пробелы.

set name Новое_имя_без_пробелов

set name "Новое имя с пробелами"

Изменение состояния текущей многоадресной области на активное или неактивное.

Синтаксис

set state {0 | 1}

Параметры

{0 | 1}
Обязательный параметр. Задание состояния текущей многоадресной области: 0 — отмена активизации текущей многоадресной области, 1 — активизация текущей многоадресной области.

Примеры

В первом примере этой командой активизируется текущая многоадресная область.

Во втором примере этой командой дезактивизируется текущая многоадресная область.

set state 1

set state 0

Задание значения времени жизни (TTL) для текущей многоадресной области.

Синтаксис

set ttl TTL

Параметры

TTL
Обязательный параметр. Задание значения времени жизни (TTL). Это значение может находиться в диапазоне от 1 до 255.

Примеры

В представленном далее примере этой командой задается значение времени жизни 32 для текущей многоадресной области.

set ttl 32

Вывод всех доступных клиентов для текущей многоадресной области.

Синтаксис

show clients

Параметры

отсутствуют

Примечания

  • Для эффективного просмотра данных, выводящихся командой, следует увеличить ширину окна командной строки по крайней мере до 95 знаков.

Вывод всех исключаемых диапазонов IP-адресов для текущей многоадресной области.

Синтаксис

show excluderange

Параметры

отсутствуют

Примечания

  • Если диапазон исключения не был предварительно определен, командой будет выведен пустой список.

Вывод всех доступных диапазонов IP-адресов для текущей многоадресной области.

Синтаксис

show iprange

Параметры

отсутствуют

Вывод текущих параметров продолжительности аренды IP-адресов для текущей многоадресной области.

Синтаксис

show lease

Параметры

отсутствуют

Вывод сведений информационной базы управления (MIB) для текущей многоадресной области.

Синтаксис

show mibinfo

Параметры

отсутствуют

Вывод сведений о текущей многоадресной области.

Синтаксис

show mscope

Параметры

отсутствуют

Вывод состояния текущей многоадресной области.

Синтаксис

show state

Параметры

отсутствуют

Вывод значения времени жизни (TTL) для текущей многоадресной области.

Синтаксис

show ttl

Параметры

отсутствуют


Пример команд Netsh DHCP

Команды Netsh для службы DHCP могут использоваться в пакетных файлах и других сценариях для автоматизации задач. В следующем примере показано использование команд Netsh для службы DHCP при выполнении различных связанных с ней задач.

в данном примере DHCP-01 — это DHCP-сервер с IP-адресом 192.168.0.2. При выполнении процедуры к DHCP-01 добавляется новая область MyScope с IP-адресом 192.168.10.0, макой подсети 255.255.255.0 и комментарием NewScope. После этого выполняется настройка области с диапазоном адресов (с 192.168.10.1 по 192.168.10.254), диапазоном исключения (с 192.168.10.1 по 192.168.10.25) и IP-адресом маршрутизатора (код параметра DHCP 003). Затем область переводится в активное состояние.

Дополнительные сведения и полный список команд Netsh для DHCP см. в разделе Команды Netsh для протокола DHCP.

В следующем примере процедуры строки комментариев начинаются с «rem». Комментарии командой Netsh игнорируются.

rem один DHCP-сервер:
rem (DHCP-01) 192.168.0.2

rem 1. Подключение к (DHCP-01) и добавление области MyScope с IP-адресом 192.168.10.0,
rem 1.1  маской подсети 255.255.255.0 и комментарием NewScope.
netsh dhcp server 192.168.0.2 add scope 192.168.10.0 255.255.255.0 MyScope NewScope

rem 2. Подключение к (DHCP-01 MyScope)
и добавление диапазона IP-адресов с 192.168.10.1 по 192.168.10.254 для распределения
rem 2.1  и стандартного типа клиента "DHCP".
netsh dhcp server 192.168.0.2 scope 192.168.10.0 add iprange 192.168.10.1 192.168.10.254

rem 3. Подключение к (DHCP-01 MyScope)
и добавление диапазона исключения IP-адресов с 192.168.10.1 по 192.168.100.25
rem 3.1  и стандартного типа клиента "DHCP".
netsh dhcp server 192.168.0.2 scope 192.168.10.0 add excluderange 192.168.10.1 192.168.10.25

rem 4. Подключение к (DHCP-01 MyScope) и задание значения кода параметра 003
rem 4.1   для вывода списка двух IP-адресов маршрутизатора (10.1.1.1, 10.1.1.2).
netsh dhcp server 192.168.0.2 scope 192.168.10.0 set optionvalue 003 IPADDRESS 10.1.1.1 10.1.1.2

rem 5.  Подключение к (DHCP-01 MyScope) и установка активного состояния области.
netsh dhcp server 192.168.0.2 scope 192.168.10.0 set state 1

rem 6. Конец примера пакетного файла.

В следующей таблице представлен список команд netsh dhcp, используемых в этом примере процедуры.

Команда | Описание
server | Переход из текущего контекста командной строки DHCP на сервер, заданный либо именем, либо IP-адресом.
add scope | Добавление новой области на указанный сервер DHCP.
scope | Переход из контекста команды в область DHCP, заданную IP-адресом.
add iprange | Добавление диапазона IP-адресов в текущую область.
add excluderange | Добавление диапазона исключаемых адресов в текущую область.
set optionvalue | Задание значения параметра для текущей области.
set state | Изменение состояния текущей области на активное или неактивное.


Команды диагностики (diag) Netsh

Команды сетевой диагностики Netsh (diag) используются для управления и устранения неполадок операционной системы и параметров сети из командной строки. Для сетевой диагностики Netsh используется командная строка netsh diag>.

Для сетевой диагностики с помощью команды Netsh (запускаемой из командной строки Windows XP) служат следующие команды. Контекст Diag для Netsh — это новое средство Windows XP. Команды контекста Diag для Netsh не могут быть использованы удаленно на Windows 2000 Server.

Дополнительные сведения о командах netsh см. в разделе Использование Netsh.

Установка, проверка и разрыв подключения TCP/IP к прокси-серверу, указанному в параметрах Internet Explorer.

Синтаксис

connect ieproxy

Параметры

отсутствуют

Примечания

  • Если в параметрах Internet Explorer прокси-сервер не указан, выводится следующее:
    Internet Explorer Proxy (Не задан)
    Не задан
  • Если в параметрах Internet Explorer задан прокси-сервер «corpproxy», порт 80, выводятся следующие результаты:
    Internet Explorer Proxy (Не задан)
    IEProxyPort = 80
    IEProxy = corpproxy
    Сервер запущен с порта(s) [80]

Установка, проверка и разрыв подключения TCP/IP к указанному узлу через указанный порт.

Синтаксис

connect iphost узел порт

Параметры

узел
Указание IP-адреса, имени NetBIOS или полного имени домена для узла, с которому необходимо подключиться.
порт
Порт, по которому необходимо подключаться

Примеры

Чтобы подключиться к узлу microsoft.com через порт 28, введите:

connect iphost microsoft.com 28

Установка, проверка и разрыв подключения TCP/IP с узлом, указанным в качестве почтового сервера Outlook Express по умолчанию в параметрах профиля текущего пользователя.

Синтаксис

connect mail

Параметры

отсутствуют

Установка, проверка и разрыв подключения TCP/IP с узлом, указанным в качестве сервера групп новостей Outlook Express по умолчанию в параметрах профиля текущего пользователя.

Синтаксис

connect news

Параметры

отсутствуют

Создание сценария, содержащего текущую конфигурацию.

Синтаксис

dump

Параметры

отсутствуют

Примечания

  • Если сохранить этот сценарий в фале, он может быть использован для восстановления прежних параметров конфигурации.

Открытие средства диагностики сети в центре справки и поддержки.

Синтаксис

gui

Параметры

отсутствуют

Проверка подключения у указанному удаленному узлу.

Синтаксис

ping узел

Параметры

узел
Указание IP-адреса, имени NetBIOS или полного имени домена для узла, с которым необходимо проверить подключение.

Проверка связи с компьютерами и другими устройствами (например, маршрутизаторами), определенными в свойствах протокола TCP/IP указанного сетевого адаптера или адаптеров. При запуске без параметров команда ping adapter проверяет наличие связи через все установленные адаптеры.

Синтаксис

ping adapter [{номер_индекса | полное_имя_адаптера | частичное_имя_адаптера}]

Параметры

{номер_индекса | полное_имя_адаптера | частичное_имя_адаптера}
Указание адаптера или адаптеров, для которых проверяется наличие связи. Параметр номер_индекса указывает адаптер посредством номера индекса. Параметр полное_имя_адаптера указывает адаптер посредством имени, под которым он зарегистрирован в операционной системе. Параметр частичное_имя_адаптера указывает адаптер или адаптеры, чьи имена содержат последовательность символов, указанную в параметре. Если последовательность символов отражает начало имени, после значения параметра необходимо ввести символ звездочки (*). Если последовательность символов отражает окончание имени, перед значением параметра необходимо ввести символ звездочки (*). Если последовательность символов может содержаться в любом месте имени, перед значением параметра и после значения необходимо ввести символ звездочки (*).

Примечания

  • Данная команда проверяет наличие связи со всеми компьютерами и другими устройствами, указанными в свойствах протокола TCP/IP каждого указанного сетевого адаптера. Например, если имеется адаптер, для которого в свойствах протокола TCP/IP настроены IP-адреса основного сервера DNS, основного шлюза и сервера DHCP, с помощью команды ping adapter будет проверено наличие связи со всеми этими устройствами.
  • Для отображения номеров индекса и полных имен всех адаптеров, определенных на компьютере, используется команда show adapter.
  • Если адаптер задается посредством индексного номера, нет необходимости вводить нули в начале номера.

Примеры

Для проверки наличия связи со всеми компьютерами и другими устройствами, указанными в свойствах протокола TCP/IP каждого указанного сетевого адаптера, введите:

ping adapter

Для проверки наличия связи со всеми компьютерами и другими устройствами, указанными в свойствах протокола TCP/IP сетевого адаптера с индексным номером 2, введите:

ping adapter 2

Для проверки наличия связи со всеми компьютерами и другими устройствами, указанными в свойствах протокола TCP/IP каждого сетевого адаптера с именем, начинающимся с «net», введите:

ping adapter net*

Проверка наличия связи с серверами DHCP, определенными в свойствах протокола TCP/IP указанного сетевого адаптера или адаптеров. При запуске без параметров команда ping dhcp проверяет наличие связи с серверами DHCP через все установленные адаптеры.

Синтаксис

ping dhcp [{номер_индекса | полное_имя_адаптера | частичное_имя_адаптера}]

Параметры

{номер_индекса | полное_имя_адаптера | частичное_имя_адаптера}
Указание адаптера или адаптеров, для которых проверяется наличие связи. Параметр номер_индекса указывает адаптер посредством номера индекса. Параметр полное_имя_адаптера указывает адаптер посредством имени, под которым он зарегистрирован в операционной системе. Параметр частичное_имя_адаптера указывает адаптер или адаптеры, чьи имена содержат последовательность символов, указанную в параметре. Если последовательность символов отражает начало имени, после значения параметра необходимо ввести символ звездочки (*). Если последовательность символов отражает окончание имени, перед значением параметра необходимо ввести символ звездочки (*). Если последовательность символов может содержаться в любом месте имени, перед значением параметра и после значения необходимо ввести символ звездочки (*).

Примечания

  • Для отображения номеров индекса и полных имен всех адаптеров, определенных на компьютере, используется команда show adapter.
  • Если адаптер задается посредством индексного номера, нет необходимости вводить нули в начале номера.

Примеры

Для проверки наличия связи с сервером DHCP, указанным в свойствах протокола TCP/IP каждого указанного сетевого адаптера, введите:

ping dhcp

Для проверки наличия связи с сервером DHCP, указанным в свойствах протокола TCP/IP сетевого адаптера с индексным номером 2, введите:

ping dhcp 2

Для проверки наличия связи с сервером DHCP, указанным в свойствах протокола TCP/IP каждого сетевого адаптера с именем, начинающимся с «net», введите:

ping adapter net*

Проверка наличия связи с серверами DNS, определенными в свойствах протокола TCP/IP указанного сетевого адаптера или адаптеров. При запуске без параметров команда ping dns проверяет наличие связи с серверами DNS через все установленные адаптеры.

Синтаксис

ping dns [{номер_индекса | полное_имя_адаптера | частичное_имя_адаптера}]

Параметры

{номер_индекса | полное_имя_адаптера | частичное_имя_адаптера}
Указание адаптера или адаптеров, для которых проверяется наличие связи. Параметр номер_индекса указывает адаптер посредством номера индекса. Параметр полное_имя_адаптера указывает адаптер посредством имени, под которым он зарегистрирован в операционной системе. Параметр частичное_имя_адаптера указывает адаптер или адаптеры, чьи имена содержат последовательность символов, указанную в параметре. Если последовательность символов отражает начало имени, после значения параметра необходимо ввести символ звездочки (*). Если последовательность символов отражает окончание имени, перед значением параметра необходимо ввести символ звездочки (*). Если последовательность символов может содержаться в любом месте имени, перед значением параметра и после значения необходимо ввести символ звездочки (*).

Примечания

  • Для отображения номеров индекса и полных имен всех адаптеров, определенных на компьютере, используется команда show adapter.
  • Если адаптер задается посредством индексного номера, нет необходимости вводить нули в начале номера.

Примеры

Для проверки наличия связи с сервером DNS, указанным в свойствах протокола TCP/IP каждого указанного сетевого адаптера, введите:

ping dns

Для проверки наличия связи с сервером DNS, указанным в свойствах протокола TCP/IP сетевого адаптера с индексным номером 2, введите:

ping dns 2

Для проверки наличия связи с сервером DNS, указанным в свойствах протокола TCP/IP каждого сетевого адаптера с именем, начинающимся с «net», введите:

ping dns net*

Проверка наличия связи c основными шлюзами, определенными в свойствах протокола TCP/IP указанного сетевого адаптера или адаптеров. При запуске без параметров команда ping gateway проверяет наличие связи через все установленные адаптеры.

Синтаксис

ping gateway [{номер_индекса | полное_имя_адаптера | частичное_имя_адаптера}]

Параметры

{номер_индекса | полное_имя_адаптера | частичное_имя_адаптера}
Указание адаптера или адаптеров, для которых проверяется наличие связи. Параметр номер_индекса указывает адаптер посредством номера индекса. Параметр полное_имя_адаптера указывает адаптер посредством имени, под которым он зарегистрирован в операционной системе. Параметр частичное_имя_адаптера указывает адаптер или адаптеры, чьи имена содержат последовательность символов, указанную в параметре. Если последовательность символов отражает начало имени, после значения параметра необходимо ввести символ звездочки (*). Если последовательность символов отражает окончание имени, перед значением параметра необходимо ввести символ звездочки (*). Если последовательность символов может содержаться в любом месте имени, перед значением параметра и после значения необходимо ввести символ звездочки (*).

Примечания

  • Для отображения номеров индекса и полных имен всех адаптеров, определенных на компьютере, используется команда show adapter.
  • Если адаптер задается посредством индексного номера, нет необходимости вводить нули в начале номера.

Примеры

Для проверки наличия связи с сервером шлюза, указанным в свойствах протокола TCP/IP каждого указанного сетевого адаптера, введите:

ping gateway

Для проверки наличия связи с сервером шлюза, указанным в свойствах протокола TCP/IP сетевого адаптера с индексным номером 2, введите:

ping gateway 2

Для проверки наличия связи с сервером шлюза, указанным в свойствах протокола TCP/IP каждого сетевого адаптера с именем, начинающимся с «net», введите:

ping gateway net*

Проверка наличия связи с прокси-сервером, указанным в параметрах Internet Explorer.

Синтаксис

ping ieproxy

Параметры

отсутствуют

Проверка наличия связи со всеми IP-адресами для указанного адаптера или адаптеров. При запуске без параметров команда ping ip проверяет наличие связи через все установленные адаптеры.

Синтаксис

ping ip [{номер_индекса | полное_имя_адаптера | частичное_имя_адаптера}]

Параметры

{номер_индекса | полное_имя_адаптера | частичное_имя_адаптера}
Указание адаптера или адаптеров, для которых проверяется наличие связи. Параметр номер_индекса указывает адаптер посредством номера индекса. Параметр полное_имя_адаптера указывает адаптер посредством имени, под которым он зарегистрирован в операционной системе. Параметр частичное_имя_адаптера указывает адаптер или адаптеры, чьи имена содержат последовательность символов, указанную в параметре. Если последовательность символов отражает начало имени, после значения параметра необходимо ввести символ звездочки (*). Если последовательность символов отражает окончание имени, перед значением параметра необходимо ввести символ звездочки (*). Если последовательность символов может содержаться в любом месте имени, перед значением параметра и после значения необходимо ввести символ звездочки (*).

Примечания

  • Для отображения номеров индекса и полных имен всех адаптеров, определенных на компьютере, используется команда show adapter.
  • Если адаптер задается посредством индексного номера, нет необходимости вводить нули в начале номера.

Примеры

Для проверки наличия связи посредством каждого сетевого адаптера введите:

ping ip

Для проверки наличия связи посредством сетевого адаптера с индексным номером 2, введите:

ping ip 2

Для проверки наличия связи посредством каждого сетевого адаптера с именем, начинающимся с «net», введите:

ping ip net*

Проверка наличия связи с удаленным или локальным узлом.

Синтаксис

ping iphost узел

Параметры

узел
Указание узла посредством IP-адреса, имени NetBIOS или полного доменного имени.

Примеры

Для проверки наличия связи с локальным узлом (с IP-адресом замыкания на себя 127.0.0.1) введите:

ping iphost 127.0.0.1

Для проверки наличия связи с узлом microsoft.com введите:

ping iphost microsoft.com

Проверка наличия связи с адресом замыкания на себя локального узла (127.0.0.1).

Синтаксис

ping loopback

Параметры

отсутствуют

Проверка наличия связи с узлом, указанным в качестве почтового сервера Outlook Express по умолчанию в параметрах профиля текущего пользователя.

Синтаксис

ping mail

Параметры

отсутствуют

Проверка наличия связи с узлом, указанным в качестве сервера групп новостей Outlook Express по умолчанию в параметрах профиля текущего пользователя.

Синтаксис

ping news

Параметры

отсутствуют

Проверка наличия связи с основным и дополнительными серверами WINS (Windows Internet Name Service) для указанного сетевого адаптера или адаптеров. При запуске без параметров команда ping wins проверяет наличие связи через все установленные адаптеры.

Синтаксис

ping wins [{номер_индекса | полное_имя_адаптера | частичное_имя_адаптера}]

Параметры

{номер_индекса | полное_имя_адаптера | частичное_имя_адаптера}
Указание адаптера или адаптеров, для которых проверяется наличие связи. Параметр номер_индекса указывает адаптер посредством номера индекса. Параметр полное_имя_адаптера указывает адаптер посредством имени, под которым он зарегистрирован в операционной системе. Параметр частичное_имя_адаптера указывает адаптер или адаптеры, чьи имена содержат последовательность символов, указанную в параметре. Если последовательность символов отражает начало имени, после значения параметра необходимо ввести символ звездочки (*). Если последовательность символов отражает окончание имени, перед значением параметра необходимо ввести символ звездочки (*). Если последовательность символов может содержаться в любом месте имени, перед значением параметра и после значения необходимо ввести символ звездочки (*).

Примечания

  • Для отображения номеров индекса и полных имен всех адаптеров, определенных на компьютере, используется команда show adapter.
  • Если адаптер задается посредством индексного номера, нет необходимости вводить нули в начале номера.

Примеры

Для проверки наличия связи с серверами WINS, указанными в свойствах протокола TCP/IP каждого указанного сетевого адаптера, введите:

ping wins

Для проверки наличия связи с серверами WINS, указанными в свойствах протокола TCP/IP сетевого адаптера с номером индекса 2, введите:

ping wins 2

Отображение сведений об указанном адаптере или адаптерах. При вводе команды show adapter без параметров выводятся сведения о всех адаптерах, установленных на данном сервере.

Синтаксис

show adapter [{номер_индекса | полное_имя_адаптера | частичное_имя_адаптера}] [{/v | /p}]

Параметры

{номер_индекса | полное_имя_адаптера | частичное_имя_адаптера}
Указание адаптера или адаптеров, для которых необходимо вывести сведения. Параметр номер_индекса указывает адаптер посредством номера индекса. Параметр полное_имя_адаптера указывает адаптер посредством имени, под которым он зарегистрирован в операционной системе. Параметр частичное_имя_адаптера указывает адаптер или адаптеры, чьи имена содержат последовательность символов, указанную в параметре. Если последовательность символов отражает начало имени, после значения параметра необходимо ввести символ звездочки (*). Если последовательность символов отражает окончание имени, перед значением параметра необходимо ввести символ звездочки (*). Если последовательность символов может содержаться в любом месте имени, перед значением параметра и после значения необходимо ввести символ звездочки (*).
{/v | /p}
Указание, следует ли отображать поля без значений. Параметр /v задает необходимость отображения этих полей. Параметр /p указывает, что такие поля выводить не следует.

Примечания

  • С помощью данной команды выводится список адаптеров, содержащим номер индекса адаптера в квадратных скобках, следующий за регистрационным именем адаптера. Обычно результат выполнения команды выглядит следующим образом:

    • Сетевые адаптеры

    1. [00000001] 3Com 3C920 Integrated Fast Ethernet Controller (3C905C-TX Compatible)
    2. [00000002] RAS Async Adapter
    3. [00000003] WAN Miniport (L2TP)
    4. [00000004] WAN Miniport (PPTP)
    5. [00000005] WAN Miniport (PPPOE)
    6. [00000006] Direct Parallel
    7. [00000007] WAN Miniport (IP)
    8. [00000008] WAN Miniport (Network Monitor)

Примеры

Чтобы отобразить определенные на компьютере логические адаптеры, введите:

show adapter

Список всех сетевых объектов, определенных для локального сервера. При вводе команды show all без параметров выводятся сведения о конфигурации следующих программных и аппаратных компонентов: почтовая служба Outlook Express (по умолчанию), служба новостей Outlook Express (по умолчанию), веб прокси Internet Explorer, замыкание на себя, компьютерная система, операционная система, версия, модемы, сетевые платы и клиенты сети.

Синтаксис

show all [{/v | /p}]

Параметры

{/v | /p}
Указание, следует ли отображать поля без значений. Параметр /v задает необходимость отображения этих полей. Параметр /p указывает, что такие поля выводить не следует.

Примечания

  • Результаты выполнения этой команды, включающие сведения о настройке почтовой службы, службы новостей и прокси-сервера, могут быть слишком подробными. В них включены сведения об адресе замыкания на себя TCP/IP и подробные сведения о компьютере, операционной системе и всех сетевых адаптерах и клиентах.

Вывод списка всех сетевых клиентов, определенных для указанного адаптера или адаптеров. При запуске без параметров команда ping wins выводит список клиентов для всех установленных адаптеров.

Синтаксис

show client [{номер_индекса | полное_имя_адаптера | частичное_имя_адаптера}] [{/v | /p}]

Параметры

{номер_индекса | полное_имя_адаптера | частичное_имя_адаптера}
Указание адаптера или адаптеров, для которых необходимо вывести список клиентов. Параметр номер_индекса указывает адаптер посредством номера индекса. Параметр полное_имя_адаптера указывает адаптер посредством имени, под которым он зарегистрирован в операционной системе. Параметр частичное_имя_адаптера указывает адаптер или адаптеры, чьи имена содержат последовательность символов, указанную в параметре. Если последовательность символов отражает начало имени, после значения параметра необходимо ввести символ звездочки (*). Если последовательность символов отражает окончание имени, перед значением параметра необходимо ввести символ звездочки (*). Если последовательность символов может содержаться в любом месте имени, перед значением параметра и после значения необходимо ввести символ звездочки (*).
{/v | /p}
Указание, следует ли отображать поля без значений. Параметр /v задает необходимость отображения этих полей. Параметр /p указывает, что такие поля выводить не следует.

Примечания

  • Для отображения номеров индекса и полных имен всех адаптеров, определенных на компьютере, используется команда show adapter.
  • Если адаптер задается посредством индексного номера, нет необходимости вводить нули в начале номера.

Примеры

Чтобы вывести список всех клиентов сети, определенных для всех сетевых адаптеров узла, введите:

show client

Чтобы просмотреть все поля с непустыми значениями для всех клиентов сети, определенных для адаптера с номером индекса 2, введите:

show client 2 /p

Вывод сведений интерфейса WMI (Windows Management Interface) для сервера. При вводе команды show computer без параметров выводится имя NetBIOS локального компьютера.

Синтаксис

show computer [{/v | /p}]

Параметры

{/v | /p}
Указание, следует ли отображать поля без значений. Параметр /v задает необходимость отображения этих полей. Параметр /p указывает, что такие поля выводить не следует.

Примеры

Для вывода всех непустых параметров интерфейса WMI сервера введите:

show computer /p

Вывод списка всех серверов DHCP, определенных для указанного адаптера. При вводе команды show dhcp без параметров выводится список серверов, определенных для всех адаптеров.

Синтаксис

show dhcp {номер_индекса | полное_имя_адаптера | частичное_имя_адаптера} [{/v | /p}]

Параметры

{номер_индекса | полное_имя_адаптера | частичное_имя_адаптера}
Указание адаптера или адаптеров, для которых необходимо вывести список серверов. Параметр номер_индекса указывает адаптер посредством номера индекса. Параметр полное_имя_адаптера указывает адаптер посредством имени, под которым он зарегистрирован в операционной системе. Параметр частичное_имя_адаптера указывает адаптер или адаптеры, чьи имена содержат последовательность символов, указанную в параметре. Если последовательность символов отражает начало имени, после значения параметра необходимо ввести символ звездочки (*). Если последовательность символов отражает окончание имени, перед значением параметра необходимо ввести символ звездочки (*). Если последовательность символов может содержаться в любом месте имени, перед значением параметра и после значения необходимо ввести символ звездочки (*).
{/v | /p}
Указание, следует ли отображать поля без значений. Параметр /v задает необходимость отображения этих полей. Параметр /p указывает, что такие поля выводить не следует.

Примечания

  • Для отображения номеров индекса и полных имен всех адаптеров, определенных на компьютере, используется команда show adapter.
  • Если адаптер задается посредством индексного номера, нет необходимости вводить нули в начале номера.

Примеры

Для вывода сведений о всех серверах DHCP, определенных для всех сетевых адаптеров, введите:

show dhcp /v

Для вывода сведений о всех серверах DHCP, определенных для адаптера 2, введите:

show dhcp 2

Вывод списка всех серверов DNS, определенных для указанного адаптера. При вводе команды show dns без параметров выводится список серверов, определенных для всех адаптеров.

Синтаксис

show dns [{номер_индекса | полное_имя_адаптера | частичное_имя_адаптера}] [{/v | /p}]

Параметры

{номер_индекса | полное_имя_адаптера | частичное_имя_адаптера}
Указание адаптера или адаптеров, для которых необходимо вывести список серверов. Параметр номер_индекса указывает адаптер посредством номера индекса. Параметр полное_имя_адаптера указывает адаптер посредством имени, под которым он зарегистрирован в операционной системе. Параметр частичное_имя_адаптера указывает адаптер или адаптеры, чьи имена содержат последовательность символов, указанную в параметре. Если последовательность символов отражает начало имени, после значения параметра необходимо ввести символ звездочки (*). Если последовательность символов отражает окончание имени, перед значением параметра необходимо ввести символ звездочки (*). Если последовательность символов может содержаться в любом месте имени, перед значением параметра и после значения необходимо ввести символ звездочки (*).
{/v | /p}
Указание, следует ли отображать поля без значений. Параметр /v задает необходимость отображения этих полей. Параметр /p указывает, что такие поля выводить не следует.

Примечания

  • Для отображения номеров индекса и полных имен всех адаптеров, определенных на компьютере, используется команда show adapter.
  • Если адаптер задается посредством индексного номера, нет необходимости вводить нули в начале номера.

Примеры

Для вывода всех непустых полей, содержащих сведения о всех серверах DNS, определенных для всех сетевых адаптеров, введите:

show dns /p

Для вывода сведений о всех серверах DNS, определенных для адаптера 2, введите:

show dns 2

Вывод списка всех шлюзов Интернета, определенных для указанного адаптера или адаптеров. ¦При вводе команды show gateway без параметров выводится список шлюзов, определенных для всех установленных адаптеров.

Синтаксис

show gateway [{номер_индекса | полное_имя_адаптера | частичное_имя_адаптера}] [{/v | /p}]

Параметры

{номер_индекса | полное_имя_адаптера | частичное_имя_адаптера}
Указание адаптера или адаптеров, для которых необходимо вывести список шлюзов. Параметр номер_индекса указывает адаптер посредством номера индекса. Параметр полное_имя_адаптера указывает адаптер посредством имени, под которым он зарегистрирован в операционной системе. Параметр частичное_имя_адаптера указывает адаптер или адаптеры, чьи имена содержат последовательность символов, указанную в параметре. Если последовательность символов отражает начало имени, после значения параметра необходимо ввести символ звездочки (*). Если последовательность символов отражает окончание имени, перед значением параметра необходимо ввести символ звездочки (*). Если последовательность символов может содержаться в любом месте имени, перед значением параметра и после значения необходимо ввести символ звездочки (*).
{/v | /p}
Указание, следует ли отображать поля без значений. Параметр /v задает необходимость отображения этих полей. Параметр /p указывает, что такие поля выводить не следует.

Примечания

  • Для отображения номеров индекса и полных имен всех адаптеров, определенных на компьютере, используется команда show adapter.
  • Если адаптер задается посредством индексного номера, нет необходимости вводить нули в начале номера.

Примеры

Для вывода всех сведений о всех шлюзах Интернета, определенных для всех сетевых адаптеров, введите:

show gateway /v

Чтобы просмотреть все поля с непустыми значениями для всех шлюзов, определенных для адаптера с номером индекса 3, введите:

show gateway 3 /p

Вывод списка всех прокси-серверов Internet Explorer, определенных для указанного адаптера или адаптеров. При запуске без параметров команда show ieproxy выводит список прокси-серверов для всех установленных адаптеров.

Синтаксис

show ieproxy [{номер_индекса | полное_имя_адаптера | частичное_имя_адаптера}] [{/v | /p}]

Параметры

{номер_индекса | полное_имя_адаптера | частичное_имя_адаптера}
Указание адаптера или адаптеров, для которых необходимо вывести список серверов. Параметр номер_индекса указывает адаптер посредством номера индекса. Параметр полное_имя_адаптера указывает адаптер посредством имени, под которым он зарегистрирован в операционной системе. Параметр частичное_имя_адаптера указывает адаптер или адаптеры, чьи имена содержат последовательность символов, указанную в параметре. Если последовательность символов отражает начало имени, после значения параметра необходимо ввести символ звездочки (*). Если последовательность символов отражает окончание имени, перед значением параметра необходимо ввести символ звездочки (*). Если последовательность символов может содержаться в любом месте имени, перед значением параметра и после значения необходимо ввести символ звездочки (*).
{/v | /p}
Указание, следует ли отображать поля без значений. Параметр /v задает необходимость отображения этих полей. Параметр /p указывает, что такие поля выводить не следует.

Примечания

  • Для отображения номеров индекса и полных имен всех адаптеров, определенных на компьютере, используется команда show adapter.
  • Если адаптер задается посредством индексного номера, нет необходимости вводить нули в начале номера.

Примеры

Чтобы вывести список всех прокси-серверов Internet Explorer, определенных для всех сетевых адаптеров сервера, введите:

show ieproxy

Вывод сведений об указанном адаптере или адаптерах, для которых включен протокол TCP/IP. ¦При вводе команды show ip без параметров выводятся сведения для всех установленных адаптеров.

Синтаксис

show ip [{номер_индекса | полное_имя_адаптера | частичное_имя_адаптера}] [{/v | /p}]

Параметры

{номер_индекса | полное_имя_адаптера | частичное_имя_адаптера}
Указание адаптера или адаптеров, для которых необходимо вывести сведения. Параметр номер_индекса указывает адаптер посредством номера индекса. Параметр полное_имя_адаптера указывает адаптер посредством имени, под которым он зарегистрирован в операционной системе. Параметр частичное_имя_адаптера указывает адаптер или адаптеры, чьи имена содержат последовательность символов, указанную в параметре. Если последовательность символов отражает начало имени, после значения параметра необходимо ввести символ звездочки (*). Если последовательность символов отражает окончание имени, перед значением параметра необходимо ввести символ звездочки (*). Если последовательность символов может содержаться в любом месте имени, перед значением параметра и после значения необходимо ввести символ звездочки (*).
{/v | /p}
Указание, следует ли отображать поля без значений. Параметр /v задает необходимость отображения этих полей. Параметр /p указывает, что такие поля выводить не следует.

Примечания

  • Для отображения номеров индекса и полных имен всех адаптеров, определенных на компьютере, используется команда show adapter.
  • Если адаптер задается посредством индексного номера, нет необходимости вводить нули в начале номера.

Примеры

Что вывести номера индекса, имена и адреса TCP/IP для всех адаптеров с включенным протоколом TCP/IP, введите:

show ip

Вывод почтового сервера Outlook Express, указанного для локального компьютера. При вводе команды show mail без параметров отображается общие сведения о настройке почтовой службы Outlook Express по умолчанию.

Синтаксис

show mail [{/v | /p}]

Параметры

{/v | /p}
Указание, следует ли отображать поля без значений. Параметр /v задает необходимость отображения этих полей. Параметр /p указывает, что такие поля выводить не следует.

Примеры

Чтобы вывести сведения о почтовом сервере, настроенном на данном компьютере, введите:

show mail

Вывод сведений об указанном модеме или модемах, установленных на данном компьютере. При запуске команды show modem отображаются сведения о всех установленных модемах.

Синтаксис

show modem [{номер_индекса | полное_имя_модема | частичное_имя_модема}] [{/v | /p}]

Параметры

{номер_индекса | полное_имя_модема | частичное_имя_модема}
Указание модема или модемов, для которых необходимо вывести сведения. Параметр номер_индекса позволяет указать модем посредством номера индекса. Параметр полное_имя_модема позволяет указать модем посредством имени, под которым он зарегистрирован в операционной системе. Параметр частичное_имя_модема позволяет указать модем или модемы, чьи имена содержат последовательность символов, указанную в параметре. Если последовательность символов отражает начало имени, после значения параметра необходимо ввести символ звездочки (*). Если последовательность символов отражает окончание имени, перед значением параметра необходимо ввести символ звездочки (*). Если последовательность символов может содержаться в любом месте имени, перед значением параметра и после значения необходимо ввести символ звездочки (*).
{/v | /p}
Указание, следует ли отображать поля без значений. Параметр /v задает необходимость отображения этих полей. Параметр /p указывает, что такие поля выводить не следует.

Примеры

Чтобы вывести все сведения (включая пустые поля) о всех модемах, установленных на данном компьютере, введите:

show modem /v

Чтобы вывести имя и номер индекса для всех модемов компьютера, чье имя начинается с «dialup», введите:

show modem dialup*

Вывод сведений о настройке сервера групп новостей Outlook Express, указанного для локального компьютера. При вводе команды show news без параметров отображается общие сведения о настройке службы новостей Outlook Express по умолчанию.

Синтаксис

show news [{/v | /p}]

Параметры

{/v | /p}
Указание, следует ли отображать поля без значений. Параметр /v задает необходимость отображения этих полей. Параметр /p указывает, что такие поля выводить не следует.

Примеры

Для вывода адреса TCP/IP сервера групп новостей введите:

show news

Вывод сведений об операционной системе локального компьютера.

Синтаксис

show os [/v]

Параметры

/v
Указание отображать поля без значений.

Примечания

  • Сведения, выводимые данной командой, собираются компонентом WMI win32_operatingsystem.

Отображение всех сетевых объектов локального компьютера и проверка наличия связи с каждым объектом с помощью команды ping. При вводе команды show test без параметров выводятся сведения о конфигурации следующих программных и аппаратных компонентов: почтовая служба Outlook Express (по умолчанию), служба новостей Outlook Express (по умолчанию), веб прокси Internet Explorer, замыкание на себя, компьютерная система, операционная система, версия, модемы, сетевые платы и клиенты сети. Кроме того, проверяется наличие связи с локальным адаптером (замыкание на себя) и IP-адресами, указанными в свойствах TCP/IP каждого сетевого адаптера.

Синтаксис

show test [{/v | /p}]

Параметры

{/v | /p}
Указание, следует ли отображать поля без значений. Параметр /v задает необходимость отображения этих полей. Параметр /p указывает, что такие поля выводить не следует.

Примечания

  • Результаты выполнения этой команды могут быть слишком подробными и на их вывод может потребоваться несколько минут. Результаты включают сведения о конфигурации почтовых серверов, серверов групп новостей, прокси-серверов, а также результаты проверки наличия связи с этими серверами с помощью команды ping. Эта команда выводит сведения для адреса замыкания на себя TCP/IP и результаты проверки наличия связи. Кроме того, выводятся сведения о компьютере, операционной системе, сетевых адаптерах и клиентах сети. Отображаются результаты проверки (с помощью команды ping) наличия связи с сетевыми адаптерами и клиентами сети.

Примеры

Для вывода всех сведений, доступных в контексте диагностики Netsh, введите:

show test /v

Вывод версии операционной системы и, при необходимости, версии интерфейса WMI (Windows Management Infrastructure). При вводе команды show version без параметров отображается номер версии операционной системы, установленной на локальном компьютере.

Синтаксис

show version [{/v | /p}]

Параметры

{/v | /p}
Указание, следует ли отображать поля без значений. Параметр /v задает необходимость отображения этих полей. Параметр /p указывает, что такие поля выводить не следует.

Примечания

  • В первой строке результатов выполнения данной команды отображается версия операционной системы. Во второй — версия интерфейса WMI. Обычно результат выполнения команды выглядит следующим образом:
    • Version (5.1.2416)
    Version = 5.1.2416
    BuildVersion = 2416.0000

Примеры

Для отображения версии операционной системы и интерфейса WMI (включая поля с пустыми значениями), введите:

show version /v

Вывод списка WINS-серверов, определенных для указанного адаптера или адаптеров. При вводе команды show wins без параметров отображается список серверов, определенных для всех установленных адаптеров.

Синтаксис

show wins [{номер_индекса | полное_имя_адаптера | частичное_имя_адаптера}] [{/v | /p}]

Параметры

{номер_индекса | полное_имя_адаптера | частичное_имя_адаптера}
Указание адаптера или адаптеров, для которых необходимо вывести список серверов. Параметр номер_индекса указывает адаптер посредством номера индекса. Параметр полное_имя_адаптера указывает адаптер посредством имени, под которым он зарегистрирован в операционной системе. Параметр частичное_имя_адаптера указывает адаптер или адаптеры, чьи имена содержат последовательность символов, указанную в параметре. Если последовательность символов отражает начало имени, после значения параметра необходимо ввести символ звездочки (*). Если последовательность символов отражает окончание имени, перед значением параметра необходимо ввести символ звездочки (*). Если последовательность символов может содержаться в любом месте имени, перед значением параметра и после значения необходимо ввести символ звездочки (*).
{/v | /p}
Указание, следует ли отображать поля без значений. Параметр /v задает необходимость отображения этих полей. Параметр /p указывает, что такие поля выводить не следует.

Примечания

  • Для отображения номеров индекса и полных имен всех адаптеров, определенных на компьютере, используется команда show adapter.
  • Если адаптер задается посредством индексного номера, нет необходимости вводить нули в начале номера.
  • Обычно результат выполнения команды выглядит следующим образом:
    • WINS-серверы
    2. [00000002] 3Com 3C920 Integrated Fast Ethernet Controller (3C905C-TX Compatible)
    WINSPrimaryServer = 172.16.44.17
    WINSSecondaryServer = 172.16.32.22

Примеры

Чтобы вывести список WINS-серверов, определенных для всех адаптеров сервера, введите:

show wins

Чтобы вывести список WINS-серверов, определенных адаптера под номером 2, введите:

show wins 2


Команды Netsh для интерфейса IP

Команды Netsh для интерфейса IP используются для настройки протокола TCP/IP (адресов, основных шлюзов, служб DNS и серверов WINS), а также для отображения сведений о конфигурации и данных статистики.

Эти команды запускаются из командной строки Windows XP или из командной строки средства Netsh для интерфейса IP. Для запуска команд из командной строки Windows XP необходимо перед вводом команд и параметров (описанных ниже) ввести netsh interface ip. Для запуска этих команд Netsh на удаленном сервере под управлением Windows 2000 Server необходимо подключиться к серверу,, на котором запущен сервер терминалов, с помощью программы «Подключение к удаленному рабочему столу». Функции команд Netsh для Windows 2000 и Windows XP могут различаться.

Дополнительные сведения о команде Netsh см. в разделе Использование команды Netsh.

Настройка IP-адреса и основного шлюза для указанного интерфейса.

Синтаксис

  • set address [name=]имя_интерфейса [source=]{dhcp | static [addr=]IP-адрес [mask=]маска_подсети [gateway=]{none | основной_шлюз [[gwmetric=]метрика_шлюза]}}

    Параметры

    [name =] имя_интерфейса
    Обязательный параметр. Указывает имя интерфейса, для которого настраивается IP-адрес и шлюз. Значение параметра имя_интерфейса должно совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если значение параметра имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    [source=]{dhcp | static [addr=]IP-адрес [mask=]маска_подсети [gateway=]{none | основной_шлюз [[gwmetric=]метрика_шлюза]}}
    Обязательный параметр. Указывают, задается ли IP-адрес автоматически с помощью протокола DHCP (Dynamic Host Configuration Protocol) или является статическим. Если IP-адрес является статическим, параметр IP-адрес указывает настраиваемый адрес, а параметрмаска_подсети указывает маску подсети настраиваемого IP-адреса. Кроме того, для статического адреса также можно указать, использовать ли текущий основной шлюз (если указан), или настроить его для данного адреса. если шлюз необходимо настроить, значение параметра основной_шлюз указывает IP-адрес настраиваемого основного шлюза, а значение параметра метрика_шлюза задает метрику шлюза.
    /?
    Отображает справку в командной строке.

    Примечания

    • Эта команда может использоваться для переключения интерфейса между конфигурацией DHCP и статической конфигурацией. Если для интерфейса указан статический IP-адрес, адреса серверов DNS и WINS также должны быть заданы статически.
    • Пропуск параметра основной_шлюз не удаляет текущую настройку шлюза, настроенные ранее значения сохраняются.

    Добавление IP-адреса и основного шлюза для указанного интерфейса со статическим адресом.

    Синтаксис

  • add address [name=]имя_интерфейса [addr=]IP-адрес [mask=]маска_подсети [[gateway=] основной_шлюз [gwmetric=]метрика_шлюза]

    Параметры

    [name =] имя_интерфейса
    Обязательный параметр. Указывает имя интерфейса, для которого добавляется IP-адрес и шлюз. Значение параметра имя_интерфейса должно совпадать с именем интерфейса, указанным в окне «Сетевые подключения». If Если значение параметра имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    [addr=]IP-адрес [mask=]маска_подсети
    Обязательный параметр. Указание добавляемого IP-адреса и маски подсети.
    [gateway=]основной_шлюз [gwmetric=]метрика_шлюза
    Указание IP-адреса основного шлюза и метрики.
    /?
    Отображает справку в командной строке.

    Удаление IP-адреса или основного шлюза для указанного интерфейса со статическим IP-адресом.

    Синтаксис

    delete address [name=]имя_интерфейса [addr=]IP-адрес [[gateway=] основной_шлюз | all}]

    Параметры

    [name =] имя_интерфейса
    Обязательный параметр. Указание имени интерфейса, для которого необходимо удалить IP-адрес и шлюз. Значение параметра имя_интерфейса должно совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если значение параметра имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    [addr=]IP-адрес
    Обязательный параметр. Указание удаляемого IP-адреса.
    [gateway=]основной_шлюз | all}
    Указание, следует ли удалять один основной шлюз или все шлюзы. Если необходимо удалить только один основной шлюз, значение параметра основной_шлюз задает IP-адрес удаляемого шлюза.
    /?
    Отображение справки в командной строке.

    Примечания

    • Данная команда не удаляет последний IP-адрес в интерфейсе.

    Отображение сведений о статическом IP-адресе и основных шлюзах указанного интерфейса. При вводе без параметров команда show address отображает сведения об адресе для всех интерфейсов.

    Синтаксис

    show address [[name=] имя_интерфейса]

    Параметры

    [name =] имя_интерфейса
    Указание имени интерфейса, для которого необходимо отобразить сведения об IP-адресе. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если значение параметра имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    /?
    Отображение справки в командной строке.

    Примечания

    • Для отображения назначенных IP-адресов, параметров аренды и прочих сведения DHCP интерфейсов, настраиваемых посредством протокола DHCP, используется команда ipconfig.

    Настройка адреса сервера DNS для указанного интерфейса.

    Синтаксис

  • set dns [name=]имя_интерфейса [source=]{dhcp | static [addr=]{адрес_DNS | none}} [[ddns=]{disabled | enabled}] [[suffix=]{interface | primary}]

    Параметры

    [name =] имя_интерфейса
    Обязательный параметр. Указание имени интерфейса, для которого указываются данные DNS. Значение параметра имя_интерфейса должно совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если значение параметра имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    [source=]{dhcp | static [addr =]{адрес_DNS | none}}
    Обязательный параметр. Указывает, является ли IP-адрес статическим или задается посредством протокола DHCP. Если IP-адрес является статическим, параметр адрес_DNS указывает IP-адрес настраиваемого сервера DNS, а параметр none указывает, что настройка DNS должна быть удалена.
    [ddns=]{disabled | enabled}
    Указание использования динамического обновления DNS для регистрации IP-адресов этого подключения и полного имени компьютера. Полное имя компьютера задается на вкладке Имя компьютера компонента Система панели управления. Параметр enabled задает использование данной функции. Параметр enabled отключает данную функцию.
    [suffix=]{interface | primary}
    Указание использования динамического обновления DNS для регистрации IP-адресов имени и имени домена для указанного подключения в дополнение к полному имени компьютера. Зависящее от подключения имя DNS для данного подключения составляется из имени компьютера (первая часть полного имени компьютера) и DNS-суффикса подключения. Параметр interface указывает, что должно быть зарегистрировано как полное имя компьютера, так и зависящее от подключения имя. Параметр primary указывает, что должно быть зарегистрировано только полное имя компьютера.
    /?
    Отображение справки в командной строке.

    Примечания

    • Если для интерфейса уже настроен статический адрес, параметр static заменяет имеющийся список сервера DNS списком, указанным в команде.
    • Для параметра ddns= по умолчанию используется значение enabled.
    • Для параметра suffix= по умолчанию используется значение primary.

    Добавление сервера DNS в список серверов DNS указанного интерфейса.

    Синтаксис

    add dns [name=]имя_интерфейса [addr=] адрес_DNS [[index=]индекс_DNS]

    Параметры

    [name =] имя_интерфейса
    Обязательный параметр. Указание имени интерфейса, для которого необходимо добавить данные DNS. Значение параметра имя_интерфейса должно совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если значение параметра имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    [addr=]адрес_DNS
    Обязательный параметр. Указание IP-адреса добавляемого DNS-сервера.
    [index=]индекс_DNS
    Указание позиции добавляемого сервера DNS в списке серверов DNS интерфейса.
    /?
    Отображение справки в командной строке.

    Примечания

    • Меньшее значение параметра индекс_DNS соответствует более высокому приоритету. Если индекс не указан, сервер добавляется с самым низким приоритетом.

    Удаление сервера или всех серверов DNS из списка для указанного интерфейса или всех интерфейсов.

    Синтаксис

    delete dns [name=]имя_интерфейса [addr=]{адрес_DNS | all}

    Параметры

    [name =] имя_интерфейса
    Обязательный параметр. Указание имени интерфейса, для которого необходимо удалить данные DNS. Значение параметра имя_интерфейса должно совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если значение параметра имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    [addr=]адрес_DNS | all}
    Обязательный параметр. Указание, следует ли удалить адрес одного сервера DNS или всех серверов для всех интерфейсов. Если необходимо удалить только один сервер DNS, значение параметра адрес_DNS задает IP-адрес удаляемого сервера.
    /?
    Отображение справки в командной строке.

    Отображение конфигурации DNS для указанного интерфейса. При вводе без параметров команда show dns отображает данные DNS для всех интерфейсов.

    Синтаксис

    show dns [[name=] имя_интерфейса]

    Параметры

    [name =] имя_интерфейса
    Указание имени интерфейса, для которого необходимо отобразить конфигурацию DNS. Значение параметра имя_интерфейса должно совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если значение параметра имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    /?
    Отображение справки в командной строке.

    Задание конфигурации сервера WINS либо для режима DHCP, либо для статического адреса указанного интерфейса.

    Синтаксис

    set wins [name=]имя_интерфейса [source=]{dhcp | static [addr=]{адрес_WINS | none }}

    Параметры

    [name =] имя_интерфейса
    Обязательный параметр. Указание имени интерфейса, для которого указываются данные WINS. Значение параметра имя_интерфейса должно совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если значение параметра имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    [source=]{dhcp | static [addr=]{адрес_WINS | none }}
    Обязательный параметр. Указание, является ли IP-адрес сервера WINS статическим или задается посредством протокола DHCP. Если IP-адрес является статическим, параметр адрес_WINS указывает IP-адрес настраиваемого сервера WINS, а параметр none указывает, что настройка WINS должна быть удалена.
    /?
    Отображение справки в командной строке.

    Примечания

    • Если для интерфейса уже настроен статический адрес, параметр static заменяет имеющийся список серверов WINS списком, указанным в команде set wins.

    Добавление сервера WINS в список серверов WINS указанного интерфейса.

    Синтаксис

    add wins [name=]имя_интерфейса [addr=] адрес_WINS [[index=]индекс_WINS]

    Параметры

    [name =] имя_интерфейса
    Обязательный параметр. Указание имени интерфейса, для которого необходимо добавить данные WINS. Значение параметра имя_интерфейса должно совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если значение параметра имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    [addr=]адрес_WINS
    Обязательный параметр. Указание IP-адреса добавляемого сервера WINS.
    [index=]индекс_WINS
    Указание позиции добавляемого сервера WINS в списке серверов WINS интерфейса.
    /?
    Отображение справки в командной строке.

    Примечания

    • Меньшее значение параметра индекс_WINS соответствует более высокому приоритету. Если индекс не указан, сервер добавляется с самым низким приоритетом.

    Удаление сервера или всех серверов WINS из списка для указанного интерфейса или всех интерфейсов.

    Синтаксис

    delete wins [name=]имя_интерфейса [addr=]{адрес_WINS | all}

    Параметры

    [name =] имя_интерфейса
    Обязательный параметр. Указание имени интерфейса, для которого необходимо удалить сервер или серверы WINS. Значение параметра имя_интерфейса должно совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если значение параметра имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    [addr=]адрес_WINS | all}
    Обязательный параметр. Указание, следует ли удалить адрес одного сервера WINS или всех серверов для всех интерфейсов. Если необходимо удалить только один сервер WINS, значение параметра адрес_WINS задает IP-адрес удаляемого сервера.
    /?
    Отображение справки в командной строке.

    Отображение конфигурации WINS для указанного интерфейса. При вводе без параметров команда show wins отображает данные DNS для всех интерфейсов.

    Синтаксис

    show wins [[name=] имя_интерфейса]

    Параметры

    [name =] имя_интерфейса
    Указание имени интерфейса, для которого необходимо отобразить сведения WINS. Значение параметра имя_интерфейса должно совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если значение параметра имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    /?
    Отображение справки в командной строке.

    Выводит статистику протокола ICMP. При вводе без параметров команда show icmp отображает статистику один раз.

    Синтаксис

    show icmp [[rr=]частота_обновления]

    Параметры

    [rr=]частота_обновления
    Задание частоты обновления (число секунд между обновлениями экрана статистики).
    /?
    Отображение справки в командной строке.

    Отображение статистики для указанного интерфейса. При вводе без параметров команда show icmp отображает статистику для всех интерфейсов один раз.

    Синтаксис

    show interface [[index=]индекс_интерфейса] [[rr=]частота_обновления]

    Параметры

    [index=]индекс_интерфейса
    Указание индекса интерфейса (целое число, определяющее интерфейс).
    [rr=]частота_обновления
    Задание частоты обновления (число секунд между обновлениями экрана статистики).
    /?
    Отображение справки в командной строке.

    Примечания

    • Для просмотра индекса всех интерфейсов используйте команду show interface без параметров.

    Отображение сведения для указанного IP-адреса. При вводе без параметров команда show ipaddress отображает сведения для всех IP-адресов всех интерфейсов один раз.

    Синтаксис

    show ipaddress [[index=]IP-адрес] [[rr=]частота_обновления]

    Параметры

    [index=]IP-адрес
    Указывает IP-адрес интерфейса.
    [rr=]частота_обновления
    Задание частоты обновления (число секунд между обновлениями экрана статистики).
    /?
    Отображение справки в командной строке.

    Примечания

    • Для просмотра IP-адресов всех интерфейсов используйте команду show ipaddress без параметров.

    Отображение содержимого кэша протокола ARP ( Address Resolution Protocol), содержащего аппаратные адреса полученных IP-адресов следующего перехода. При вводе без параметров команда show ipnet отображает сведения один раз.

    Синтаксис

    show ipnet [[rr=]частота_обновления]

    Параметры

    [rr=]частота_обновления
    Задание частоты обновления (число секунд между обновлениями экрана статистики).
    /?
    Отображение справки в командной строке.

    Отображение статистики протокола IP. При вводе без параметров команда show ipstats отображает данные статистики один раз.

    Синтаксис

    show ipstats [[rr=]частота_обновления]

    Параметры

    [rr=]частота_обновления
    Задание частоты обновления (число секунд между обновлениями экрана статистики).
    /?
    Отображение справки в командной строке.

    Отображение многоадресных групп IP, в которые включен указанный IP-адрес. При вводе без параметров команда show address отображает сведения для всех IP-адресов.

    Синтаксис

    show joins [[index=]IP-адрес]

    Параметры

    [index=]IP-адрес
    Указание IP-адреса интерфейса.
    /?
    Отображение справки в командной строке.

    Примечания

    • Для просмотра IP-адресов всех интерфейсов используйте команду show ipaddress без параметров.

    Отображение сведения для указанного подключения TCP. При вводе без параметров команда show address отображает сведения для всех соединений TCP.

    Синтаксис

  • show tcpconn [[index=]{локальный_IP_адрес | локальный_порт | удаленный_IP_адрес | удаленный_порт}] [[rr=]частота_обновления]

    Параметры

    [index=]{локальный_IP_адрес | локальный_порт | удаленный_IP_адрес | удаленный_порт}
    Указание подключение, для которого следует отобразить сведения. Параметр локальный_IP_адрес указывает IP-адрес интерфейса. Параметр локальный_порт задает порт TCP локального процесса. Параметр удаленный_IP_адрес указывает IP-адрес удаленного узла. Параметр локальный_порт задает порт TCP удаленного процесса.
    [rr=]частота_обновления
    Задание частоты обновления (число секунд между обновлениями экрана сведений).
    /?
    Отображение справки в командной строке.

    Отображение статистики протокола TCP. При вводе без параметров команда show tcpstats отображает данные статистики один раз.

    Синтаксис

    show tcpstats [[rr=]частота_обновления]

    Параметры

    [rr=]частота_обновления
    Задание частоты обновления (число секунд между обновлениями экрана статистики).
    /?
    Отображение справки в командной строке.

    Отображение сведений о портах UDP, используемых для каждого IP-адреса. При вводе без параметров команда show udpconn отображает сведения о портах UDP для всех IP-адресов.

    Синтаксис

    show udpconn [[index=]{локальный_IP_адрес | локальный_порт}] [[rr=]частота_обновления]

    Параметры

    [index=]{локальный_IP_адрес | локальный_порт}
    Указание подключения, для которого необходимо отобразить сведения. Параметр локальный_IP_адрес указывает IP-адрес интерфейса. Параметр локальный_порт задает порт UDP локального процесса.
    [rr=]частота_обновления
    Задание частоты обновления (число секунд между обновлениями экрана статистики).
    /?
    Отображение справки в командной строке.

    Отображение статистики протокола UDP. При вводе без параметров команда show udpstats отображает данные статистики один раз.

    Синтаксис

    show udpstats [[rr=]частота_обновления]

    Параметры

    [rr=]частота_обновления
    Задание частоты обновления (число секунд между обновлениями экрана статистики).
    /?
    Отображение справки в командной строке.

    Отображение IP-адреса и прочих сведений конфигурации для указанного интерфейса. При вводе без параметров команда show config отображает сведения о конфигурации всех интерфейсов.

    Синтаксис

    show config [[name=] имя_интерфейса]

    Параметры

    [name =] имя_интерфейса
    Указание имени интерфейса, для которого необходимо отобразить сведения конфигурации. Значение параметра имя_интерфейса должно совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если значение параметра имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    /?
    Отображение справки в командной строке.

    Отображение задач, которые могут быть выполнены сетевым адаптером для указанного интерфейса, связанного с установленным сетевым оборудованием. При вводе без параметров команда show offload отображает сведения о задачах для всех интерфейсов, связанных с установленным сетевым оборудованием.

    Синтаксис

    show offload [[name=] имя_интерфейса]

    Параметры

    [name =]имя_интерфейса
    Указание имени интерфейса, для которого необходимо отобразить сведения о задачах. Значение параметра имя_интерфейса должно совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если значение параметра имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    /?
    Отображение справки в командной строке.

    Удаление записей из кэша протокола ARP (Address Resolution Protocol) для указанного интерфейса. При запуске без параметров команда delete arpcache удаляет записи в кэше протокола ARP (Address Resolution Protocol)для всех интерфейсов.

    Синтаксис

    delete arpcache [[name=]имя_интерфейса]

    Параметры

    [name =]имя_интерфейса
    Указание имени интерфейса, для которого необходимо удалить данные из кэша протокола ARP. Значение параметра имя_интерфейса должно совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если значение параметра имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    /?
    Отображение справки в командной строке.

    тображение текущей конфигурациии с использованием серии команд Netsh для интерфейса IP.

    Синтаксис

    dump

    Параметры

    отсутствуют

    Примечания

    • Для создания файла сценария конфигурации следует перенаправить вывод данной команды в файл.

    Пример команды Netsh интерфейса IP.

    Следующая команда настраивает интерфейс с именем Подключение к локальной сети, статическим IP-адресом 10.0.5.99, маской подсети 255.255.255.0 и основным шлюзом 10.0.5.1:

    set address name="Подключение к локальной сети" source=static addr=10.0.5.99 mask=255.255.255.0 gateway=10.0.5.1


Команды Netsh для службы RAS

Администрирование серверов удаленного доступа осуществляется путем ввода команд в командной строке для контекста Netsh RAS. Благодаря использованию команд Netsh RAS в командной строке администрирование серверов с медленными сетевыми подключениями осуществляется быстрее, а также имеется возможность создавать сценарии для автоматизации администрирования различных серверов.

Чтобы запустить эти команды Netsh на удаленном сервере Windows 2000 Server, необходимо сначала использовать подключение к удаленному рабочему столу для соединения с Windows 2000 Server, работающим под управлением сервера терминалов. Между контекстными командами Netsh в Windows 2000 и Windows XP могут существовать некоторые различия.

Дополнительные сведения о команде Netsh см. в разделе Использование команды Netsh.

Вывод в командной строке справки о командах, которые могут использоваться в контексте Netsh RAS.

Синтаксис

help

Параметры

отсутствуют

Примечания

  • Для вывода справки в командной строке можно также ввести в ней любое из следующих выражений для контекста Netsh RAS: ?, /? или -?.

Вывод списка оповещений сервера удаленного доступа.

Синтаксис

show activeservers

Параметры

отсутствуют

Вывод списка клиентов удаленного доступа, подключенных к данному серверу.

Синтаксис

show client

Параметры

отсутствуют

Вывод конфигурации сервера удаленного доступа в форме сценария.

Синтаксис

dump

Параметры

отсутствуют

Включение отслеживания для указанного компонента. При использовании без параметров команда show tracing выводит список всех установленных компонентов с указанием, включено ли для них отслеживание.

Синтаксис

show tracing [компонент]

Параметры

компонент
Указание компонента, сведения о котором выводятся.

Включение или отключение отслеживания для указанного компонента.

Синтаксис

set tracing компонент {enabled | disabled}

Параметры

компонент
Обязательный параметр. Указание каталога, для которого включается или отключается отслеживание. Для указания всех компонентов используется звездочка (*).
{enabled | disabled}
Обязательный параметр. Определяет включение или отключение отслеживания для указанного компонента.

Примечания

  • Для просмотра всех установленных компонентов используется команда show tracing без параметров.

Примеры

Чтобы задать отслеживание для компонента PPP введите:

set tracing ppp enabled

Вывод сведений о включенной проверке подлинности для клиентов удаленного доступа, использующих определенные типы устройств.

Синтаксис

show authmode

Параметры

отсутствуют

Включение или отключение проверки подлинности для клиентов удаленного доступа, использующих определенные типы устройств.

Синтаксис

set authmode {standard | nodcc | bypass}

Параметры

{standard | nodcc | bypass}
Обязательный параметр. Включение или отключение проверки подлинности для клиентов удаленного доступа, использующих определенные типы устройств. Параметр standard указывает проверку подлинности для клиентов, использующих устройства любых типов. Параметр nodcc указывает проверку подлинности для клиентов, использующих устройства любых типов кроме устройств прямого подключения. Параметр standard указывает на отсутствие проверки подлинности для всех клиентов.

Добавление типа проверки подлинности к списку типов, используемых сервером удаленного доступа для согласования при проверке подлинности.

Синтаксис

add authtype {pap|spap|md5chap|mschap|mschapv2|eap}

Параметры

{pap|spap|md5chap|mschap|mschapv2|eap}
Обязательный параметр. Указание типа проверки подлинности для добавления к списку типов, используемых сервером удаленного доступа для согласования при проверке подлинности. Параметр pap задает использование сервером удаленного доступа протокола PAP (чистый текст). Параметр spap задает использование сервером удаленного доступа протокола SPAP. Параметр md5chap задает использование сервером удаленного доступа протокола CHAP (с использованием стандартной схемы хеширования Message Digest 5 (MD5) для шифрования ответа). Параметр mschap задает использование сервером удаленного доступа протокола MSCHAP. Параметр mschapv2 задает использование сервером удаленного доступа протокола MSCHAP версии 2. Параметр eap задает использование сервером удаленного доступа протокола EAP.

Примечания

  • Сервер удаленного доступа использует при попытке согласования проверки подлинности протоколы в порядке уменьшения их безопасности. После согласования клиентом и сервером типа проверки подлинности выполняется согласование PPP, описанное в соответствующих документах RFC.

Удаление типа проверки подлинности из списка типов, используемых сервером удаленного доступа для согласования при проверке подлинности.

Синтаксис

delete authtype {pap|spap|md5chap|mschap|mschapv2|eap}

Параметры

{pap|spap|md5chap|mschap|mschapv2|eap}
Обязательный параметр. Указание типа проверки подлинности для удаления из списка типов, используемых сервером удаленного доступа для согласования при проверке подлинности. Параметр pap отключает использование сервером удаленного доступа протокола PAP (чистый текст). Параметр spap отключает использование сервером удаленного доступа протокола SPAP. Параметр md5chap отключает использование сервером удаленного доступа протокола CHAP (с использованием стандартной схемы хеширования Message Digest 5 (MD5) для шифрования ответа). Параметр mschap отключает использование сервером удаленного доступа протокола MSCHAP. Параметр mschapv2 отключает использование сервером удаленного доступа протокола MSCHAP версии 2. Параметр eap отключает использование сервером удаленного доступа протокола EAP.

Вывод списка типов проверки подлинности, используемых сервером удаленного доступа для согласования при проверке подлинности.

Синтаксис

show authtype

Параметры

отсутствуют

Добавление свойства связи в список свойств, для которых PPP выполняет согласование.

Синтаксис

add link {swc | lcp}

Параметры

{swc | lcp}
Обязательный параметр. Указание свойства связи для добавления в список свойств, для которых PPP выполняет согласование. Параметр swc указывает на добавление программного сжатия (MPPC). Параметр lcp указывает на добавление расширений протокола LCP из пакета PPP.

Удаление свойства связи из списка свойств, для которых PPP выполняет согласование.

Синтаксис

delete link {swc | lcp}

Параметры

{swc | lcp}
Обязательный параметр. Указание свойства связи для удаления из списка свойств, для которых PPP выполняет согласование. Параметр swc указывает на удаление программного сжатия (MPPC). Параметр lcp указывает на удаление расширений протокола LCP из пакета PPP.

Вывод свойств связи для согласования PPP.

Синтаксис

show link

Параметры

отсутствуют

Добавление многоканального типа в список типов, для которых PPP выполняет согласование.

Синтаксис

add multilink {multi | bacp}

Параметры

{multi | bacp}
Обязательный параметр. Указание многоканального типа для добавления в список типов, для которых PPP выполняет согласование. Параметр multi указывает на добавление многоканальных сеансов PPP. Параметр bacp указывает на добавление протокола BACP (Bandwidth Allocation Control Protocol).

Удаление многоканального типа из списка типов, для которых PPP выполняет согласование.

Синтаксис

delete multilink {multi | bacp}

Параметры

{multi | bacp}
Обязательный параметр. Указание многоканального типа для удаления из списка типов, для которых PPP выполняет согласование. Параметр multi указывает на удаление многоканальных сеансов PPP. Параметр bacp указывает на удаление протокола BACP (Bandwidth Allocation Control Protocol).

Вывод многоканальных типов для согласования PPP.

Синтаксис

show multilink

Параметры

отсутствуют

Регистрация указанного сервера в качестве сервера удаленного доступа в данном домене Active Directory. При использовании без параметров команда add registeredserver регистрирует компьютер, с которого введена команда, в его основном домене.

Синтаксис

add registeredserver [[domain=]имя_домена] [[server=]имя_сервера]

Параметры

[domain=]имя_домена
Указание имени домена для регистрации сервера. Если домен не указан, сервер регистрируется в своем основном домене.
[server=]имя_сервера
Указание имени DNS или IP-адреса сервера для регистрации. Если сервер не указан, регистрируется компьютер, с которого введена команда.

Удаление регистрации указанного сервера в качестве сервера удаленного доступа из данного домена Active Directory. При использовании без параметров команда delete registeredserver удаляет регистрацию компьютера, с которого введена команда, из его основного домена.

Синтаксис

delete registeredserver [[domain=]имя_домена] [[server=]имя_сервера]

Параметры

[domain=]имя_домена
Указание имени домена для удаления регистрации сервера. Если домен не указан, регистрация удаляется из основного домена компьютера, с которого введена команда.
[server=]имя_сервера
Указание IP-адреса или имени DNS сервера для удаления регистрации. Если сервер не указан, удаляется регистрация компьютера, с которого введена команда.

Вывод сведений о состоянии указанного сервера, зарегистрированного в качестве сервера удаленного доступа в определенном домене Active Directory. При использовании без параметров команда show registeredserver выводит сведения о компьютере, с которого введена команда, в его основном домене.

Синтаксис

show registeredserver [[domain=]имя_домена] [[server=]имя_сервера]

Параметры

[domain=]имя_домена
Указание имени домена, в котором зарегистрирован сервер, сведения о котором требуется вывести. Если домен не указан, выводятся сведения о сервере, поскольку он зарегистрирован в качестве основного домена компьютера, с которого введена команда.
[server=]имя_сервера
Указание IP-адреса или имени DNS сервера, сведения о котором требуется вывести. Если сервер не указан, выводятся сведения о компьютере, с которого введена команда.

Вывод свойств указанных пользователей удаленного доступа. При использовании без параметров команда show user выводит свойства всех пользователей удаленного доступа.

Синтаксис

show user [name=имя_пользователя] [[mode=] {permit | report}]

Параметры

name=имя_пользователя
Указание имени для входа пользователя, свойства которого требуется вывести. Если пользователь не указан, выводятся свойства всех пользователей.
mode= {permit | report}
Определение вывода свойств для всех пользователей или только для имеющих разрешение удаленного доступа. Параметр permit указывает вывод свойств только для пользователей, которым разрешен удаленный доступ. Параметр report указывает вывод свойств для всех пользователей.

Задание свойств указанного пользователя удаленного доступа.

Синтаксис

  • set user [name=]имя_пользователя [dialin] {permit | deny | policy} [cbpolicy] {none | caller | admin [cbnumber=]номер_для_ответного_вызова}

    Параметры

    name=имя_пользователя
    Обязательный параметр. Указание имени для входа пользователя, свойства которого требуется задать.
    [dialin] {permit | deny | policy}
    Обязательный параметр. Указание обстоятельств, при которых пользователю должно быть разрешено подключение. Параметр permit указывает отсутствие ограничений на подключение пользователя. Параметр deny указывает запрет подключения пользователя. Параметр policy указывает определение разрешения на подключение пользователя политиками удаленного доступа.
    [cbpolicy] {none | caller | admin [cbnumber=]номер_для_ответного_вызова}
    Обязательный параметр. Указание политики для ответного вызова пользователя. Возможность ответного вызова позволяет пользователю сэкономить на стоимости телефонного звонка, используемого для подключения к серверу удаленного доступа. Параметр none указывает отсутствие ответного вызова для пользователя. Параметр caller указывает ответный вызов по номеру, определенный пользователем при подключении. Параметр caller указывает ответный вызов пользователя по номеру, определенный номер_для_ответного_вызова.

    Примечания

    • Для пользователей в домене, работающем в смешанном режиме, параметр policy эквивалентен параметру deny.

    Примеры

    Чтобы разрешить пользователю GuestUser подключение и включить для него ответный вызов по номеру 4255551212, введите:

    set user guestuser permit admin 4255551212

    Команды Netsh в контексте RAS IP

    Описанные ниже команды используются в контексте RAS IP среды Netsh.

    Создание сценария, содержащего конфигурацию IP сервера удаленного доступа. При сохранении сценария в виде файла можно использовать его для восстановления параметров конфигурации IP.

    Синтаксис

    dump

    Параметры

    отсутствуют

    Вывод текущей конфигурации IP сервера удаленного доступа.

    Синтаксис

    show config

    Параметры

    отсутствуют

    Разрешение сервером удаленного доступа настройки конфигурации IP для любых клиентских подключений, принимаемых сервером.

    Синтаксис

    set negotiation {allow | deny}

    Параметры

    {allow | deny}
    Обязательный параметр. Разрешение или запрещение клиентских подключений по протоколу IP. Параметр allow разрешает клиентские подключения по протоколу IP. Параметр deny запрещает клиентские подключения по протоколу IP.

    Разрешение или запрещение перенаправления IP-трафика от клиентов в сети, к которым подключен сервер удаленного доступа.

    Синтаксис

    set access {all | serveronly}

    Параметры

    {all | serveronly}
    Обязательный параметр. Разрешение или запрещение доступа клиентов к серверу удаленного доступа и любым сетям, к которым они подключены. Параметр all разрешает клиентам доступ к сетям через сервер. Параметр serveronly разрешает клиентам доступ только к серверу.

    Определение способа, с помощью которого сервер удаленного доступа назначает IP-адреса своим клиентам.

    Синтаксис

    set addrassign {auto | pool}

    Параметры

    {auto | pool}
    Обязательный параметр. Указание способа назначения IP-адресов: с использованием DHCP или из пула адресов, хранящегося на сервере удаленного доступа. Параметр auto указывает назначение адресов с использованием DHCP. Если DHCP-сервер недоступен, назначается произвольно выбранный доступный адрес в частной сети. Параметр pool указывает назначение адресов из пула.

    Разрешение или запрещение запроса клиентами удаленного доступа своих IP-адресов.

    Синтаксис

    set addrreq {allow | deny}

    Параметры

    {allow | deny}
    Обязательный параметр. Разрешение или запрещение запроса клиентами своих IP-адресов. Параметр allow разрешает клиентам запрос адресов. Параметр deny запрещает клиентам запрос адресов.

    Включение или отключение широковещания при разрешении имен с использованием NetBIOS через TCP/IP.

    Синтаксис

    set broadcastnameresolution {enabled | disabled}

    Параметры

    {enabled | disabled}
    Обязательный параметр. Указание включения или отключения широковещания при разрешении имен с использованием NetBIOS через TCP/IP.

    Добавление диапазона адресов в пул статических IP-адресов, которые могут назначаться сервером удаленного доступа клиентам.

    Синтаксис

    add range [from=]начальный_IP-адрес [to=]конечный_IP-адрес

    Параметры

    [from=]начальный_IP-адрес [to=]конечный_IP-адрес
    Обязательный параметр. Определение диапазона IP-адресов для добавления. Параметр начальный_IP-адрес указывает первый IP-адрес в диапазоне. Параметр конечный_IP-адрес указывает последний IP-адрес в диапазоне.

    Примеры

    Чтобы добавить диапазон IP-адресов с 10.2.2.10 по 10.2.2.20 в статический пул IP-адресов, которые могут назначаться сервером удаленного доступа, введите:

    add range from=10.2.2.10 to=10.2.2.20

    Удаление диапазона адресов из пула статических IP-адресов, которые могут назначаться сервером удаленного доступа клиентам.

    Синтаксис

    delete range [from=]начальный_IP-адрес [to=]конечный_IP-адрес

    Параметры

    [from=]начальный_IP-адрес [to=]конечный_IP-адрес
    Обязательный параметр. Задание диапазона IP-адресов для удаления. Параметр начальный_IP-адрес указывает первый IP-адрес в диапазоне. Параметр конечный_IP-адрес указывает последний IP-адрес в диапазоне.

    Примеры

    Чтобы удалить диапазон IP-адресов с 10.2.2.10 по 10.2.2.20 из пула статических IP-адресов, которые могут назначаться сервером удаленного доступа, введите:

    delete range from=10.2.2.10 to=10.2.2.20

    Удаление всех адресов из пула статических IP-адресов, которые могут назначаться сервером удаленного доступа клиентам.

    Синтаксис

    delete pool

    Параметры

    отсутствуют

    Команды Netsh в контексте RAS IPX

    Описанные ниже команды используются в контексте RAS IPX среды Netsh. XOX

    Создание сценария, содержащего конфигурацию IPX сервера удаленного доступа. При сохранении сценария в виде файла можно использовать его для восстановления параметров конфигурации IPX.

    Синтаксис

    dump

    Параметры

    отсутствуют

    Вывод текущей конфигурации IPX сервера удаленного доступа.

    Синтаксис

    show config

    Параметры

    отсутствуют

    Разрешение сервером удаленного доступа настройки конфигурации IPX для любых клиентских подключений, принимаемых сервером.

    Синтаксис

    set negotiation {allow | deny}

    Параметры

    {allow | deny}
    Обязательный параметр. Разрешение или запрещение настройки IPX. Параметр allow разрешает настройку IPX. Параметр deny запрещает настройку IPX.

    Разрешение или запрещение перенаправления IPX-трафика от клиентов в сети, к которым подключен сервер удаленного доступа.

    Синтаксис

    set access {all | serveronly}

    Параметры

    {all | serveronly}
    Обязательный параметр. Включение или отключение перенаправления IPX-трафика. Значение all разрешает перенаправление IPX-трафика. Значение serveronly запрещает перенаправление трафика.

    Указание способа, с помощью которого сервер удаленного доступа назначает IPX-адреса своим клиентам.

    Синтаксис

    set netassign [method] {auto | pool | autosame | poolsame}

    Параметры

    [method] {auto | pool | autosame | poolsame}
    Обязательный параметр. Указание способа, с помощью которого сервер удаленного доступа назначает IPX-адреса клиентам. Параметр auto указывает назначение сервером удаленного доступа разных произвольно выбираемых сетевых номеров IPX каждому клиенту. Параметр pool указывает назначение сервером удаленного доступа разных IPX-адресов из пула каждому клиенту. Параметр autosame указывает создание сервером удаленного доступа произвольного сетевого номера IPX и назначение его всем клиентам. Параметр poolsame указывает назначение сервером удаленного доступа одного IPX-адреса из пула всем клиентам.

    Примечания

    • Для большинства конфигураций рекомендуется использование параметра autosame или poolsame, поскольку при этом сохраняются сетевые номера и снижается сетевой трафик.
    • Перед назначением сервером удаленного доступа сетевого номера клиенту сервер должен проверить, не используется ли уже этот номер в интрасети, к которой подключен сервер удаленного доступа. В результате некоторые адреса из пула не смогут быть назначены.

    Указание пула IPX-адресов, которые могут назначаться сервером удаленного доступа клиентам.

    Синтаксис

    set pool [firstnet=]IPX_адрес [size=]{размер_пула | 0}

    Параметры

    [firstnet=]IPX_адрес
    Обязательный параметр. Указание первого IPX-адреса в пуле в шестнадцатеричном формате.
    [size=]{размер_пула | 0}
    Обязательный параметр. Размер пула или размер, которого он может достигнуть при необходимости. Параметр размер_пула указывает в шестнадцатеричном формате число IPX-адресов в пуле. Параметр 0 указывает на отсутствие ограничений на будущий размер пула.

    Примеры

    Чтобы указать, что пул IPX-адресов должен начинаться с адреса AAAAAAA и расширяться, как необходимо, введите:

    set pool AAAAAAA 0

    Разрешение или запрещение запроса клиентами удаленного доступа своих номеров узла IPX.

    Синтаксис

    set nodereq {allow | deny}

    Параметры

    {allow | deny}
    Обязательный параметр. Определяет, могут ли клиенты запрашивать собственные номера узлов. Параметр allow разрешает такие запросы. Параметр deny запрещает такие запросы.

    Команды Netsh в контексте RAS AppleTalk

    Описанные ниже команды используются в контексте RAS AppleTalk среды Netsh. Протокол AppleTalk недоступен в операционной системе Windows XP Home Edition или Windows XP Professional.

    Создание сценария, содержащего конфигурацию AppleTalk сервера удаленного доступа. При сохранении сценария в виде файла можно использовать его для восстановления параметров конфигурации AppleTalk.

    Синтаксис

    dump

    Параметры

    отсутствуют

    Вывод текущей конфигурации AppleTalk сервера удаленного доступа.

    Синтаксис

    show config

    Параметры

    отсутствуют

    Разрешение сервером удаленного доступа настройки конфигурации AppleTalk для любых клиентских подключений, принимаемых сервером.

    Синтаксис

    set negotiation {allow | deny}

    Параметры

    {allow | deny}
    Обязательный параметр. Разрешение или запрещение настройки AppleTalk. Параметр allow разрешает конфигурацию. Параметр deny запрещает конфигурацию.

    Разрешение или запрещение перенаправления AppleTalk-трафика от клиентов в сети, к которым подключен сервер удаленного доступа.

    Синтаксис

    set access {all | serveronly}

    Параметры

    {all | serveronly}
    Обязательный параметр. Определение того, перенаправляется сетевой трафик AppleTalk или нет. Значение all разрешает перенаправление трафика. Значение serveronly запрещает перенаправление трафика.

    Команды Netsh в контексте RAS AAAA

    Описанные ниже команды используются в контексте RAS AAAA среды Netsh.

    Вывод конфигурации AAAA сервера удаленного доступа в форме сценария.

    Синтаксис

    dump

    Параметры

    отсутствуют

    Указание IP-адреса или имени DNS сервера RADIUS для использования в целях учета и задание соответствующих параметров.

    Синтаксис

  • add acctserv [name=]код_сервера [[secret=]общий_секрет] [[init-score=]приоритет_сервера] [[port=]порт] [[timeout=]секунды] [[messages] {enabled | disabled}]

    Параметры

    [name=]код_сервера
    Обязательный параметр. Указание IP-адреса или имени DNS сервера RADIUS.
    [secret=]общий_секрет
    Задание общего секрета.
    [init-score=]приоритет_сервера
    Указание начальной оценки (приоритета сервера).
    [port=]порт
    Порт, на который должны отправляться запросы учета.
    [timeout=]секунды
    Задает в секундах таймаут, в течение которого сервер RADIUS может простаивать, после чего он помечается как недоступный.
    [messages] {enabled | disabled}
    Разрешение или запрещение отправки сообщений о включении/отключении учета. Параметр enabled включает отправку сообщений. Параметр disabled отключает отправку сообщений.

    Удаление сервера учета RADIUS.

    Синтаксис

    delete acctserv [name=]код_сервера

    Параметры

    [name=]код_сервера
    Обязательный параметр. Указание имени DNS или IP-адреса сервера для удаления.

    Указание IP-адреса или имени DNS сервера RADIUS для использования в целях учета.

    Синтаксис

  • add acctserv [name=]код_сервера [[secret=]общий_секрет] [[init-score=]приоритет_сервера] [[port=]порт] [[timeout=]секунды] [[messages] {enabled | disabled}]

    Параметры

    [name=]код_сервера
    Обязательный параметр. Указание IP-адреса или имени DNS сервера RADIUS.
    [secret=]общий_секрет
    Задание общего секрета.
    [init-score=]приоритет_сервера
    Указание начальной оценки (приоритета сервера).
    [port=]порт
    Указание порта, на который отправляются запросы проверки подлинности.
    [timeout=]секунды
    Указание периода времени, по прошествии которого сервер RADIUS помечается как недоступный.
    [messages=] {enabled | disabled}
    Разрешение или запрещение отправки сообщений о включении/отключении учета.

    Вывод подробных сведений о сервере учета. При использовании без параметров команда show acctserv выводит сведения о всех настроенных серверах учета.

    Синтаксис

    show acctserv [[name=]код_сервера]

    Параметры

    [name=]код_сервера
    Определение имени DNS или IP-адреса сервера RADIUS, сведения о котором требуется вывести.

    Указание IP-адреса или имени DNS сервера RADIUS, которому передаются запросы проверки подлинности.

    Синтаксис

  • add authserv [name=]код_сервера [[secret=]общий_секрет] [[init-score=]приоритет_сервера] [[port=]порт] [[timeout=]секунды] [[signature] {enabled | disabled}]

    Параметры

    [name=]код_сервера
    Обязательный параметр. Указание IP-адреса или имени DNS сервера RADIUS.
    [secret=]общий_секрет
    Задание общего секрета.
    [init-score=]приоритет_сервера
    Указание начальной оценки (приоритета сервера).
    [port=]порт
    Порт, на который должны отправляться запросы проверки подлинности.
    [timeout=]секунды
    Задает в секундах таймаут, в течение которого сервер RADIUS может простаивать, после чего он помечается как недоступный.
    [signature] {enabled | disabled}
    Включение использования цифровых подписей. Параметр enabled включает использование цифровых подписей. Параметр disabled отключает использование цифровых подписей.

    Удаление сервера проверки подлинности RADIUS.

    Синтаксис

    delete authserv [name=]код_сервера

    Параметры

    [name=]код_сервера
    Обязательный параметр. Указание имени DNS или IP-адреса сервера для удаления.

    Указание IP-адреса или имени DNS сервера RADIUS, которому передаются запросы проверки подлинности.

    Синтаксис

  • set authserv [name=]код_сервера [[secret=]общий_секрет] [[init-score=]приоритет_сервера] [[port=]порт] [[timeout=]секунды] [[signature] {enabled | disabled}]

    Параметры

    [name=]код_сервера
    Обязательный параметр. Указание IP-адреса или имени DNS сервера RADIUS.
    [secret=]общий_секрет
    Задание общего секрета.
    [init-score=]приоритет_сервера
    Указание начальной оценки (приоритета сервера).
    [port=]порт
    Указание порта, на который отправляются запросы проверки подлинности.
    [timeout=]секунды
    Указание периода времени в секундах, по прошествии которого сервер RADIUS помечается как недоступный.
    [signature=] {enabled | disabled}
    Указание включения или отключения использования цифровых подписей.

    Вывод подробных сведений о сервере проверки подлинности. При использовании без параметров команда show authserv выводит сведения о всех настроенных серверах проверки подлинности.

    Синтаксис

    show authserv [[name=]код_сервера]

    Параметры

    [name=]код_сервера
    Определение имени DNS или IP-адреса сервера RADIUS, сведения о котором требуется вывести.

    Указание службы учета.

    Синтаксис

    set acco provider {windows | radius | none}

    Параметры

    provider {windows | radius | none}
    Обязательный параметр. Включение учета и указание сервера, используемого для этих целей. Параметр windows указывает выполнение учета с использованием службы безопасности Windows. Параметр radius указывает выполнение учета с использованием сервера RADIUS. Параметр none указывает на отсутствие учета.

    Вывод службы учета.

    Синтаксис

    show acco

    Параметры

    отсутствуют

    Указание службы проверки подлинности.

    Синтаксис

    set authe provider {windows | radius}

    Параметры

    provider {windows | radius}
    Обязательный параметр. Указание технологии для проверки подлинности. Параметр windows указывает проверку подлинности с использованием службы безопасности Windows. Параметр radius указывает проверку подлинности с использованием сервера RADIUS.

    Вывод службы проверки подлинности.

    Синтаксис

    show authe

    Параметры

    отсутствуют


Команды Netsh для маршрутизации

Команды Netsh для маршрутизации используются для администрирования серверов маршрутизации из командной строки, а не с помощью консоли «Маршрутизация и удаленный доступ». Администрирование серверов из командной строки полезно в следующих ситуациях.

  • Администрировать сервера маршрутизации из командной строки быстрее, чем при использовании консоли. Эта возможность особенно важна в сетевых соединениях с низкой скоростью передачи данных, например, подключение по глобальной сети (WAN).
  • Объединяя команды в сценарий, который выполняется на нескольких серверах, можно администрировать сервера маршрутизации согласованно.

Следующие команды используются в командной строке для соответствующего контекста Netsh (в отличие от командной строки Windows XP) для администрирования серверов маршрутизации. Чтобы запустить эти команды Netsh на удаленном сервере Windows 2000 Server, необходимо сначала использовать подключение к удаленному рабочему столу для соединения с Windows 2000 Server, работающим под управлением сервера терминалов. Между контекстными командами Netsh Windows 2000 и Windows XP могут существовать функциональные различия.

Команды Netsh Routing IP IGMP

Следующие команды доступны для использования в контексте «Netsh Routing IP IGMP».

Чтобы посмотреть синтаксис команды, щелкните команду.

Настраивает IGMP в соответствии с заданным интерфейсом.

Синтаксис

  • add interface [InterfaceName=]имя_интерфейса [[IgmpPrototype=]{igmprtrv1 | igmprtrv2 | igmprtrv3 | igmpproxy}] [[IfEnabled=]{enable | disable}] [[RobustVar=]целое] [[GenQueryInterval=]целое] [[GenQueryRespTime=]целое] [[StartUpQueryCount=]целое] [[StartUpQueryInterval=]целое] [[LastMemQueryCount=]целое] [[LastMemQueryInterval=целое] [[AccNonRtrAlertPkts=]{yes | no}]

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Отображает имя интерфейса, на который требуется настроить IGMP. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    [IgmpPrototype=]{igmprtrv1 | igmprtrv2 | igmprtrv3 | igmpproxy}
    Указывает тип протокола, который требуется настроить на интерфейс. Тип по умолчанию igmprtrv2.
    [IfEnabled=]{enable | disable}
    Определяет состояние настраиваемого протокола. По умолчанию включен.
    [RobustVar=]=целое
    Задает переменную надежности. Значение должно превышать нуль (0). По умолчанию значение равно 2.
    [GenQueryInterval=]целое
    Указывает интервал в секундах, с которым общие запросы должны отправляться на интерфейс. По умолчанию задается интервал в 125 секунд.
    [GenQueryRespTime=]целое
    Задает максимальное время отклика узлов на общий запрос в секундах. По умолчанию задается интервал в 10 секунд.
    [StartUpQueryCount=]целое
    Определяет количество общих запросов, которые посылаются во время загрузки. По умолчанию значение равно 2.
    [StartUpQueryInterval=]целое
    Указывает интервал в секундах между отправкой общих запросов при запуске. По умолчанию задается интервал в 31 секунд.
    [LastMemQueryCount=]целое
    Задает число запросов определенной группы, отправленных после получения уведомления о выходе компьютера из группы. По умолчанию значение равно 2.
    [LastMemQueryInterval=]целое
    Указывает интервал между запросами определенных групп в миллисекундах. По умолчанию значение равно 1000 миллисекунд.
    [AccNonRtrAlertPkts=]{yes | no}
    Определяет принятие пакетов IGMP, не имеющих установленного параметра оповещения маршрутизатора. Значение по умолчанию равно yes.

    Примеры

    Чтобы изменить интервал по умолчанию между запросами при загрузке до 21 секунды, чтобы использовать этот интервал в конфигурации IGMP интерфейса «Подключение по локальной сети», введите команду:

    add interface "Подключение по локальной сети" startupqueryinterval=21

    Устанавливает IGMP-маршрутизатор или IGMP-прокси и задает глобальное ведение журналов. При использовании без параметров команда install устанавливает IGMP-маршрутизатор или IGMP-прокси и указывает, что ошибки, связанные с IGMP, заносятся в журнал, а другие события, связанные с IGMP, не записываются.

    Синтаксис

    install [[LogLevel=]{none | error | warn | info}]

    Параметры

    [LogLevel=]{none | error | warn | info}
    Определяет события для занесения в журнал. Параметр none означает, что события, связанные с IGMP, записываться в журнал не будут. Параметр error означает, что только ошибки, касающиеся IGMP, будут заноситься в журнал. Параметр warn определяет, что только предупреждения, касающиеся IGMP, будут записываться в журнал. Параметр info указывает, что все события, связанные с IGMP, будут заноситься в журнал.

    Удаляет IGMP-маршрутизатор или прокси с определенного интерфейса.

    Синтаксис

    delete interface [InterfaceName=]имя_интерфейса

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Указывает по имя интерфейса, с которого необходимо удалить IGMP-маршрутизатор или прокси. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").

    Примеры

    delete interface "Подключение по локальной сети"

    Удаляет маршрутизатор или прокси IGMP со всех интерфейсов.

    Синтаксис

    uninstall

    Параметры

    Отсутствуют.

    Изменяет параметры настройки интерфейса.

    Синтаксис

  • set interface [InterfaceName=]имя_интерфейса [[IgmpPrototype=]{igmprtrv1 | igmprtrv2 | igmprtrv3 | igmpproxy}] [[IfEnabled=]{enable | disable}] [[RobustVar=]целое] [[GenQueryInterval=]целое] [[GenQueryRespTime=]целое] [[StartUpQueryCount=]целое] [[StartUpQueryInterval=]целое] [[LastMemQueryCount=]целое] [[LastMemQueryInterval=]целое] [[AccNonRtrAlertPkts=]{yes | no}]

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Отображает имя интерфейса, на который требуется настроить IGMP. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    [IgmpPrototype=]{igmprtrv1 | igmprtrv2 | igmprtrv3 | igmpproxy}
    Указывает тип протокола, который требуется настроить на интерфейс. Тип по умолчанию igmprtrv2.
    [IfEnabled=]{enable | disable}
    Определяет состояние настраиваемого протокола. По умолчанию включен.
    [RobustVar=]=целое
    Задает переменную надежности. Значение должно превышать нуль (0). По умолчанию значение равно 2.
    [GenQueryInterval=]целое
    Указывает интервал в секундах, с которым общие запросы должны отправляться на интерфейс. По умолчанию задается интервал в 125 секунд.
    [GenQueryRespTime=]целое
    Задает максимальное время отклика узлов на общий запрос в секундах. По умолчанию задается интервал в 10 секунд.
    [StartUpQueryCount=]целое
    Определяет количество общих запросов, которые посылаются во время загрузки. По умолчанию значение равно 2.
    [StartUpQueryInterval=]целое
    Указывает интервал в секундах между отправкой общих запросов при запуске. По умолчанию задается интервал в 31 секунд.
    [LastMemQueryCount=]целое
    Задает число запросов определенной группы, отправленных после получения уведомления о выходе компьютера из группы. По умолчанию значение равно 2.
    [LastMemQueryInterval=]целое
    Определяет интервал между запросами определенных групп в миллисекундах. По умолчанию значение равно 1 000 миллисекунд.
    [AccNonRtrAlertPkts=]{yes | no}
    Определяет принятие пакетов IGMP, не имеющих установленного параметра оповещения маршрутизатора. По умолчанию пакеты принимаются.

    Примеры

    Чтобы изменить интервал по умолчанию между запросами при загрузке до 21 секунды, чтобы использовать этот интервал в конфигурации IGMP интерфейса «Подключение по локальной сети», введите команду:

    set interface "Подключение по локальной сети" startupqueryinterval=21

    Задает глобальные параметры IGMP. При использовании без параметров, команда set global указывает, что заносятся в журнал предупреждения, а другие события, связанные с IGMP, не записываются.

    Синтаксис

    set global [LogLevel=]{none | error | warn | info}

    Параметры

    [LogLevel=]{none | error | warn | info}
    Обязательный параметр. Определяет события для занесения в журнал. Параметр none означает, что события, связанные с IGMP, записываться в журнал не будут. Параметр error означает, что только ошибки, касающиеся IGMP, будут заноситься в журнал. Параметр warn определяет, что только предупреждения, касающиеся IGMP, будут записываться в журнал. Параметр info указывает, что все события, связанные с IGMP, будут заноситься в журнал.

    Отображает конфигурацию IGMP определенного интерфейса. При использовании без параметров команда show interface выводит на экран сведения о конфигурации IGMP для всех интерфейсов.

    Синтаксис

    show interface [InterfaceName=]имя_интерфейса

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, сведения о котором необходимо отобразить. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").

    Отображает глобальные параметры IGMP.

    Синтаксис

    show global

    Параметры

    Отсутствуют.

    Отображает статистику IGMP для определенного интерфейса. При использовании без параметров команда show ifstats показывает статистику IGMP сразу для всех интерфейсов.

    Синтаксис

    show ifstats [[Index=]целое] [[Rr=]целое]

    Параметры

    [Index=]целое
    Задает номер, определяющий интерфейс, сведения для которого необходимо отобразить.
    [Rr=]целое
    Указывает интервал обновления сведения в секундах.

    Примеры

    Чтобы показывать статистику IGMP каждые 5 секунд для интерфейса со значением индекса 1001, введите команду:

    show ifstats index=1001 rr=5

    Отображает группы компьютеров IGMP для указанного интерфейса. При использовании без параметров команда show iftable показывает группы компьютеров IGMP сразу для всех интерфейсов.

    Синтаксис

    show iftable [[Index=]целое] [[Rr=]целое]

    Параметры

    [Index=]целое
    Указывает интерфейс, сведения о котором необходимо отобразить, с помощью номера индекса.
    [Rr=]целое
    Указывает интервал обновления сведения в секундах.

    Примеры

    Чтобы показывать группы компьютеров IGMP каждые 5 секунд для интерфейса со значением индекса 1001, введите команду:

    show iftable index=1001 rr=5

    Выводит на экран таблицу групп узлов IGMP для группы многоадресной рассылки. При использовании без параметров команды show grouptable отображает таблицы групп узлов IGMP для все групп многоадресной рассылки на всех интерфейсах, связанных с маршрутизатором.

    Синтаксис

    show grouptable [[Index=]целое] [[Rr=]целое]

    Параметры

    [Index=]целое
    Задает IP-адрес группы многоадресной рассылки, сведения о которой необходимо отобразить.
    [Rr=]целое
    Указывает интервал обновления сведения в секундах.

    Примеры

    Чтобы выводить на экран таблицу групп узлов IGMP каждые 5 секунд для группы многоадресной рассылки с IP-адресом 192.168.100.239, введите команду:

    show grouptable index=192.168.100.239 rr=5

    Выводит на экран таблицу групп узлов для интерфейса клиента удаленного доступа. При использовании без параметров команда show rasgrouptable отображает таблицы групп узлов сразу для всех интерфейсов клиента удаленного доступа.

    Синтаксис

    show rasgrouptable [[Index=]IP-адрес] [[Rr=]целое]

    Параметры

    [Index=]IP-адрес
    Задает IP-адрес интерфейса клиента удаленного доступа, сведения о котором необходимо отобразить.
    [Rr=]целое
    Указывает интервал обновления сведения в секундах.

    Примеры

    Чтобы вывести на экран таблицу групп узлов для интерфейса клиента удаленного доступа с IP-адресом 10.10.1.100 и обновлять сведения каждые пять секунд, введите команду:

    show rasgrouptable index=10.10.1.100 rr=5

    Отображает таблицу групп узлов IGMP для интерфейса IGMP-прокси. При использовании без параметров команда show proxygrouptable показывает сведения сразу для всех интерфейсов.

    Синтаксис

    show proxygrouptable [[InterfaceName=]имя_интерфейса] [[Rr=]целое]

    Параметры

    [InterfaceName=]имя_интерфейса
    Задает имя интерфейса, сведения для которого необходимо отобразить. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    [Rr=]целое
    Указывает в секундах интервал обновления сведений.

    Примеры

    Чтобы вывести на экран таблицы групп узлов IGMP для всех интерфейсов IPMP-прокси и обновлять сведения каждые пять секунд, введите команду:

    show proxygrouptable rr=5

    Команды Netsh Routing IP Routerdiscovery

    Следующие команды доступны для использования в контексте «Netsh Routing IP Routerdiscovery».

    Чтобы посмотреть синтаксис команды, щелкните команду.

    Настраивает обнаружение маршрутизатора для указанного интерфейса.

    Синтаксис

  • add interface [InterfaceName=]имя_интерфейса [[Disc=]{enable | disable}] [[MinInt=]целое] [[MaxInt=]целое] [[Life=]целое] [[Level=]целое]

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, для которого необходимо настроить обнаружение маршрутизатора. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    [Disc=]{enable | disable}
    Определяет должно ли обнаружение маршрутизатора произойти на этом интерфейсе. Параметр enable указывает, что обнаружение должно произойти, а параметр disable задает, что не должно.
    [MinInt=]число
    Определяет минимальный интервал между отправлением пакетов обнаружения маршрутизаторов в минутах.
    [MaxInt=]число
    Указывает максимальный интервал между отправлением пакетов обнаружения маршрутизаторов в минутах.
    [Life=]целое
    Задает время в минутах, в течение которого пакет обнаружения маршрутизатора, отправленный с этого маршрутизатора или сервера, является действительным.
    [Level=]целое
    Определяет число, указывающее уровень предпочтения для использования этого интерфейса в качестве основного шлюза. Когда обнаружение маршрутизаторов включено на нескольких интерфейсах, большее значение указывает более высокий уровень предпочтения.

    Примечания

    • После добавления, объявления обнаружения маршрутизатора отправляются через произвольные промежутки времени, ограниченные максимальным и минимальным интервалом.

    Примеры

    Чтобы включить обнаружение маршрутизатора для интерфейса «Подключение по локальной сети» с минимальным интервалом в 7 минут, максимальным интервалом в 10 минут, интервалом в 30 минут, в течение которого пакеты обнаружения маршрутизаторов действительны, и нулевым уровнем предпочтения, введите команду:

    add interface "Подключение по локальной сети" enable 7 10 30 0

    Настраивает обнаружение маршрутизатора для интерфейса.

    Синтаксис

  • set interface [InterfaceName=]имя_интерфейса [[Disc=]{enable | disable}] [[MinInt=]целое] [[MaxInt=]целое] [[Life=]целое] [[Level=]целое]

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, для которого необходимо настроить обнаружение маршрутизатора. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    [Disc=]{enable | disable}
    Определяет должно ли обнаружение маршрутизатора произойти на этом интерфейсе. Параметр enable указывает, что обнаружение должно произойти, а параметр disable задает, что не должно.
    [MinInt=]число
    Определяет минимальный интервал между отправлением пакетов обнаружения маршрутизаторов в минутах.
    [MaxInt=]число
    Определяет максимальный интервал между отправлением пакетов обнаружения маршрутизаторов в минутах.
    [Life=]целое
    Задает время в минутах, в течение которого пакет обнаружения маршрутизатора, отправленный с этого маршрутизатора или сервера, является действительным.
    [Level=]целое
    Определяет число, указывающее уровень предпочтения для использования этого интерфейса в качестве основного шлюза. Большее число соответствует более высокому уровню предпочтения.

    Примеры

    Чтобы включить обнаружение маршрутизатора для интерфейса «Подключение по локальной сети» с минимальным интервалом в 7 минут, максимальным интервалом в 10 минут, интервалом в 30 минут, в течение которого пакеты обнаружения маршрутизаторов действительны, и нулевым уровнем предпочтения, введите команду:

    set interface "Подключение по локальной сети" enable 7 10 30 0

    Удаляет настройку обнаружения маршрутизатора.

    Синтаксис

    delete interface [InterfaceName=]имя_интерфейса

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, для которого необходимо удалить настройку обнаружения маршрутизатора. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").

    Примеры

    Чтобы удалить настройку обнаружения маршрутизатора для интерфейса «Подключение по локальной сети», введите команду:

    delete interface name="Подключение по локальной сети"

    Выводит сведения об обнаружении маршрутизатора. При использовании без параметров команда show interface показывает сведения сразу для всех интерфейсов.

    Синтаксис

    show interface [InterfaceName=]имя_интерфейса]

    Параметры

    [InterfaceName=]имя_интерфейса
    Задает имя интерфейса, сведения для которого необходимо отобразить. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").

    Примеры

    Чтобы вывести на экран сведения об обнаружении маршрутизатора для интерфейса «Подключение по локальной сети», введите команду:

    show interface "Подключение по локальной сети"

    Команды Netsh Routing IP RIP

    Следующие команды доступны для использования в контексте «Netsh Routing IP RIP».

    Чтобы посмотреть синтаксис команды, щелкните команду.

    Добавляет фильтр для серверов, которые считаются серверами одноранговой сети.

    Синтаксис

    add peerfilter [Server=]IP-адрес

    Параметры

    [Server=]IP-адрес
    Обязательный параметр. Указывает IP-адрес сервер одноранговой сети, трафик которого необходимо профильтровать.

    Добавляет избирательный фильтр для маршрутов, полученных на интерфейсе.

    Синтаксис

  • add acceptfilter [InterfaceName=]имя_интерфейса [Addr=]IP-адрес1 IP-адрес2

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Определяет имя интерфейса, допускающего использование протокола RIP. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    [Addr=]IP-адрес1 IP-адрес2
    Обязательный параметр. Указывает соответствие IP-адресов. Первый IP-адрес — наименьший адрес диапазона, используемого при построении фильтра, а второй IP-адрес — наибольший адрес этого диапазона.

    Примеры

    Чтобы добавить избирательный фильтр для интерфейса «Подключение по локальной сети» с диапазоном IP-адресов 10.0.0.2. — 10.11.21.154, введите команду:

    add acceptfilter "Подключение по локальной сети" 10.0.0.2 10.11.21.154

    Добавляет фильтр для маршрутов, объявленных на интерфейсе.

    Синтаксис

  • add announcefilter [InterfaceName=]имя_интерфейса [Addr=]IP-адрес1 IP-адрес2

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Указывает имя интерфейса, допускающего использование протокола RIP. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    [Addr=]IP-адрес1 IP-адрес2
    Обязательный параметр. Указывает соответствие IP-адресов. Первый IP-адрес — наименьший адрес диапазона, используемого при построении фильтра, а второй IP-адрес — наибольший адрес этого диапазона.

    Примеры

    Чтобы добавить фильтр для маршрутов, объявленных на интерфейсе «Подключение по локальной сети» с диапазоном IP-адресов 10.0.0.2. — 10.11.21.154, введите команду:

    add announcefilter "Подключениение по локальной сети" 10.0.0.2 10.11.21.154

    Добавляет соседа RIP из интерфейса.

    Синтаксис

    add neighbor [InterfaceName=]имя_интерфейса [addr=]IP-адрес

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Определяет имя интерфейса, допускающего использование протокола RIP. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    [addr=]IP-адрес
    Обязательный параметр. Задает IP-адрес соседа RIP для добавления.

    Примеры

    Чтоб добавить соседа RIP, находящегося по IP-адресу 10.0.0.2, для интерфейса «Подключение по локальной сети», введите команду:

    add neighbor "Подключение по локальной сети" 10.0.0.2

    Добавляет протокол RIP на указанный интерфейс.

    Синтаксис

  • add interface [InterfaceName=]имя_интерфейса [[Metric=]целое][[UpdateMode=]{demand | periodic}] [[Announce=]{none | rip1 | rip1compat | rip2}][[Accept=]{none | rip1 | rip1compat | rip2}][[Expire=]целое] [[Remove=]целое] [[Update=]целое][[AuthMode=]{authnone | authsimplepassword}] [[Tag=]целое] [[Unicast=]{also | only | disable}][[AccFiltMode=]{include | exclude | disable}][[AnnFiltMode=]{include | exclude | disable}] [[Password=]строка]

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Указывает имя интерфейса, на который требуется добавить протокол RIP. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    [Metric=]целое
    Задает значение метрики для маршрутов, базирующихся на этом интерфейсе.
    [UpdateMode=]{demand | periodic}
    Определяет время обновления. Параметр demand означает обновление по требованию. Параметр periodic указывает обновление через постоянные интервалы.
    [Announce=]{none | rip1 | rip1compat | rip2}
    Определяет маршруты для объявления. Параметр none означает, что все маршруты объявляются. Параметр rip1 указывает, что только маршруты RIP версии 1 объявляются. Параметр rip1compat соответствует выполнению объявлений в режиме совместимости с версией RIP. Параметр rip2 задает, что только маршруты RIP версии 2 объявляются.
    [Accept=]{none | rip1 | rip1compat | rip2}
    Определяет маршруты для принятия. Параметр none означает, что все маршруты принимаются. Параметр rip1 указывает, что только маршруты RIP версии 1 принимаются. Параметр rip1compat соответствует принятию объявлений в режиме совместимости с версией RIP. Параметр rip2 указывает, что только маршруты RIP версии 2 принимаются.
    [Expire=]целое
    Задает в секундах интервал действия маршрута.
    [Remove=]целое
    Указывает в секундах интервал удаления маршрута.
    [Update=]целое
    Определяет в секундах интервал полного обновления.
    [AuthMode=]{authnone | authsimplepassword}
    Указывает необходимость проверки подлинности. Параметр authnone означает, что проверка подлинности не требуется. Параметр authsimplepassword определяет необходимость проверки подлинности.
    [Tag=]целое
    Задает тег маршрута.
    [Unicast=]{also | only | disable}
    Обозначает одноадресный режим. Параметр also определяет, что одноадресный режим также используется. Параметр only означает использование только одноадресного режима. Параметр disable отключает одноадресный режим.
    [AccFiltMode=]{include | exclude | disable}
    Определяет включение или отключение избирательных фильтров. Параметр include означает включение избирательных фильтров. Параметр exclude определяет, что избирательные фильтры не будут включены. Параметр disable отключает избирательные фильтры.
    [AccFiltMode=]{include | exclude | disable}
    Определяет включение или отключение фильтров объявлений. Параметр include означает включение фильтров объявлений. Параметр exclude определяет, что фильтры объявлений не будут включены. Параметр disable отключает фильтры объявлений.
    [Password=]строка
    Задает текстовый пароль, длина которого не более 16 символов.

    Устанавливает библиотеку модуля поддержки под RIP.

    Синтаксис

    add helper имя_DLL

    Параметры

    имя_DLL
    Обязательный параметр. Задает DLL, поддерживающий данный контекст.

    Удаляет фильтр для принятого сервера одноранговой сети.

    Синтаксис

    delete peerfilter [Server=]IP-адрес

    Параметры

    [Server=]IP-адрес
    Обязательный параметр. Указывает IP-адрес сервера одноранговой сети,трафик которого не требуется фильтровать.

    Удаляет избирательный фильтр для маршрутов, полученных на интерфейсе.

    Синтаксис

    delete acceptfilter [InterfaceName=]имя_интерфейса [Addr=]IP-адрес1 IP-адрес2

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Определяет имя интерфейса, допускающего использование протокола RIP. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    [Addr=]IP-адрес1 IP-адрес2
    Обязательный параметр. Указывает соответствие IP-адресов. Первый IP-адрес — наименьший адрес диапазона, используемого при построении фильтра, а второй IP-адрес — наибольший адрес этого диапазона.

    Примеры

    Чтобы удалить избирательный фильтр для интерфейса «Подключение по локальной сети» с диапазоном IP-адресов 10.0.0.2. — 10.11.21.154, введите команду:

    delete acceptfilter "Подключение по локальной сети" 10.0.0.2 10.11.21.154

    Удаляет фильтр объявлений, установленный для интерфейса.

    Синтаксис

    delete announcefilter [InterfaceName=]имя_интерфейса [Addr=]IP-адрес1 IP-адрес2

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Указывает имя интерфейса, допускающего использование протокола RIP. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    [Addr=]IP-адрес1 IP-адрес2
    Обязательный параметр. Указывает соответствие IP-адресов. Первый IP-адрес — наименьший адрес диапазона, используемого при построении фильтра, а второй IP-адрес — наибольший адрес этого диапазона.

    Примеры

    Чтобы удалить фильтр объявлений для интерфейса «Подключение по локальной сети» с диапазоном IP-адресов 10.0.0.2. — 10.11.21.154, введите команду:

    delete announcefilter "Подключение по локальной сети" 10.0.0.2 10.11.21.154

    Удаляет соседа RIP из интерфейса.

    Синтаксис

    delete neighbor [InterfaceName=]имя_интерфейса IP-адрес

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Определяет имя интерфейса, допускающего использование протокола RIP. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    IP-адрес
    Обязательный параметр. Задает IP-адрес соседа RIP для удаления.

    Примеры

    Чтоб удалить соседа RIP, находящегося по IP-адресу 10.0.0.2, для интерфейса «Подключение по локальной сети», введите команду:

    delete neighbor "Подключение по локальной сети" 10.0.0.2

    Удаляет RIP из указанного интерфейса.

    Синтаксис

    delete interface [InterfaceName=]имя_интерфейса

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Указывает имя интерфейса, из которого требуется удалить RIP. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").

    Удаляет библиотеку модуля поддержки из Netsh.

    Синтаксис

    delete helper имя_DLL

    Параметры

    имя_DLL
    Обязательный параметр. Указывает имя файла библиотеки модуля поддержки для удаления.

    Настраивает RIP в соответствии с заданным интерфейсом.

    Синтаксис

  • set interface [InterfaceName=]имя_интерфейса [[Metric=]целое][[UpdateMode=]{demand | periodic}][[Announce=]{none | rip1 | rip1compat | rip2}] [[Accept=]{none | rip1 | rip1compat | rip2}][[Expire=]целое] [[Remove=]целое] [[Update=]целое][[AuthMode=]{authnone | authsimplepassword}] [[Tag=]целое] [[Unicast=]{also | only | disable}][[AccFiltMode=]{include | exclude | disable}][[AnnFiltMode=]{include | exclude | disable}] [[Password=]строка]

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Указывает имя интерфейса, на котором требуется настроить протокол RIP. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    [Metric=]целое
    Задает значение метрики для маршрутов, базирующихся на этом интерфейсе.
    [UpdateMode=]{demand | periodic}
    Определяет время, когда произойдет обновление. Параметр demand означает обновление по требованию. Параметр periodic указывает обновление через постоянные интервалы.
    [Announce=]{none | rip1 | rip1compat | rip2}
    Определяет маршруты для объявления. Параметр none означает, что все маршруты объявляются. Параметр rip1 указывает, что только маршруты RIP версии 1 объявляются. Параметр rip1compat соответствует выполнению объявлений в режиме совместимости с версией RIP. Параметр rip2 задает, что только маршруты RIP версии 2 объявляются.
    [Accept=]{none | rip1 | rip1compat | rip2}
    Определяет маршруты для принятия. Параметр none означает, что все маршруты принимаются. Параметр rip1 указывает, что только маршруты RIP версии 1 принимаются. Параметр rip1compat означает, что принятие объявлений выполняется в режиме совместимости с версией RIP. Параметр rip2 указывает, что только маршруты RIP версии 2 принимаются.
    [Expire=]целое
    Задает в секундах время простоя маршрутизатора до истечения срока действия.
    [Remove=]целое
    Указывает в секундах время простоя маршрутизатора до его удаления.
    [Update=]целое
    Определяет в секундах интервал между полными обновлениями.
    [AuthMode=]{authnone | authsimplepassword}
    Указывает необходимость проверки подлинности. Параметр authnone означает, что проверка подлинности не требуется. Параметр authsimplepassword определяет необходимость проверки подлинности.
    [Tag=]целое
    Задает тег маршрута.
    [Unicast=]{also | only | disable}
    Обозначает одноадресный режим. Параметр also определяет, что одноадресный режим также используется. Параметр only означает использование только одноадресного режима. Параметр disable отключает одноадресный режим.
    [AccFiltMode=]{include | exclude | disable}
    Определяет включение избирательных фильтров. Параметр include означает включение избирательных фильтров. Параметр exclude определяет, что избирательные фильтры не будут включены. Параметр disable отключает избирательные фильтры.
    [AccFiltMode=]{include | exclude | disable}
    Определяет включение или отключение фильтров объявлений. Параметр include означает включение фильтров объявлений. Параметр exclude определяет, что фильтры объявлений не будут включены. Параметр disable отключает фильтры объявлений.
    [Password=]строка
    Задает текстовый пароль не длиннее 16 символов.

    Примеры

    Чтобы изменить конфигурацию RIP на интерфейсе «Подключение по локальной сети», задав значение метрики 2 и обновление по требованию, введите команду:

    set interface "Подключение по локальной сети" metric=2 updatemode=periodic

    Устанавливает флажки, связанные с RIP, для определенного интерфейса.

    Синтаксис

  • setflags[InterfaceName=]имя_интерфейса[clear,][splithorizon,][poisonreverse,][triggeredupdates,

    ][cleanupupdates][accepthostroutes,][acceptdefaultroutes,][senddefaultroutes,][nosubnetsummary]

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Указывает имя интерфейса, на котором требуется установить флажки. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    [clear,][splithorizon,][poisonreverse,][triggeredupdates,][cleanupupdates,][accepthostroutes,]
    [acceptdefaultroutes,][senddefaultroutes,][nosubnetsummary]
    Определяет политики для флажков, связанных с RIP. Параметр clear означает, что все установленные флажки RIP должны быть сняты. Параметр splithorizon задает включение RIP по горизонту расщепления. Параметр poisonreverse определяет включение RIP для запретного возврата. Параметр triggeredupdates обозначает, что инициируемые обновления RIP должны произойти. Параметр cleanupupdates определяет, что обновления очистки RIP будут выполнены. Параметр accepthostroutes принимает маршруты к узлам. Параметр acceptdefaultroutes принимает основные маршруты. Параметр acceptdefaultroutes отправляет основные маршруты. Параметр nosubnetsummary определяет, что суммирование подсетей не должно выполняться.

    Примечания

    • После последнего параметра политики не нужно ставить запятую.

    Задает глобальные параметры RIP.

    Синтаксис

  • set global {[[loglevel=]{none | error | warn | info}] | [[mintrig=]целое] | [[peermode=]{include | exclude | disable}]}

    Параметры

    [loglevel=]{none | error | warn | info}
    Указывает события RIP для записи в журнал. Параметр none указывает, что события RIP не будут заноситься в журнал. Параметр error задает только занесение ошибок, связанных с RIP. Параметр warn определяет только занесение предупреждений, связанных с RIP. Параметр info означает, что все события RIP будут занесены в журнал.
    [mintrig=]целое
    Указывает в минутах минимальное интервал времени между процедурами инициирования.
    [peermode=]{include | exclude | disable}
    Задает включение равноправных пользователей в сеть и отключение режима одноранговых узлов. Параметр include означает включение равноправных пользователей, exclude указывает, что равноправные пользователи не будут включены. Параметр disable отключает режим одноранговых узлов.

    Отображает конфигурации RIP для указанного интерфейса. При использовании без параметров команда show interface выводит сведения о конфигурации для всех интерфейсов.

    Синтаксис

    show interface [[InterfaceName=]имя_интерфейса]

    Параметры

    [InterfaceName=]имя_интерфейса
    Задает имя интерфейса, сведения о котором требуется вывести на экран. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").

    Отображает флажки RIP, заданные для указанного интерфейса. При использовании без параметров команда show flags выводит сведения для всех интерфейсов.

    Синтаксис

    show flags [[InterfaceName=]имя_интерфейса]

    Параметры

    [InterfaceName=]имя_интерфейса
    Задает имя интерфейса, для которого требуется отобразить сведения. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").

    Показывает глобальные параметры RIP.

    Синтаксис

    show global

    Параметры

    Отсутствуют.

    Отображает статистику RIP для указанного интерфейса. При использовании без параметров команда show ifstats выводит сведения сразу для всех интерфейсов.

    Синтаксис

    show ifstats [[Index=]целое] [[Rr=]целое]

    Параметры

    [Index=]целое
    Задает номер индекса интерфейса, для которого требуется отобразить сведения.
    [Rr=]целое
    Указывает в секундах интервал обновления сведений.

    Примечания

    • Чтобы показать список значений индексов для каждого интерфейса, используйте команду show interface в контексте «Netsh Interface IP».

    Примеры

    Чтобы выводить статистику RIP каждые 5 секунд для интерфейса со значением индекса 1, введите команду:

    show ifstats index=1 rr=5

    Отображает привязки IP-адресов интерфейса RIP. При использовании без параметров команда show ifbinding выводит сведения сразу для всех интерфейсов.

    Синтаксис

    show ifbinding [[Index=]целое] [[Rr=]целое]

    Параметры

    [Index=]целое
    Задает номер индекса интерфейса, для которого требуется отобразить сведения.
    [Rr=]целое
    Указывает в секундах интервал обновления сведений.

    Примечания

    • Чтобы показать список значений индексов для каждого интерфейса, используйте команду show interface в контексте «Netsh Interface IP».

    Примеры

    Чтобы выводить привязки каждые 5 секунд для интерфейса со значением индекса 1, введите команду:

    show ifbinding index=1 rr=5

    Команды Netsh Routing IP Relay

    Следующие команды доступны для использования в контексте «Netsh Routing IP Relay».

    Чтобы посмотреть синтаксис команды, щелкните команду:

    Добавляет DHCP-сервер к списку DHCP-серверов, сообщения которого будут перенаправлены агентом DHCP-ретрансляции.

    Синтаксис

    add dhcpserver IP-адрес

    Параметры

    IP-адрес
    Обязательный параметр. Указывает IP-адрес DHCP-сервера для добавления.

    Включает агента DHCP-ретрансляции на заданном интерфейсе.

    Синтаксис

    add interface [InterfaceName=]имя_интерфейса

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, на котором требуется включить агента DHCP-ретрансляции. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").

    Отключает агента DHCP-ретрансляции на заданном интерфейсе.

    Синтаксис

    delete interface [InterfaceName=]имя_интерфейса

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, на котором требуется отключить агента DHCP-ретрансляции. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").

    Удаляет DHCP-сервер из списка DHCP-серверов, сообщения которого будут перенаправлены агентом DHCP-ретрансляции.

    Синтаксис

    delete dhcpserver IP-адрес

    Параметры

    IP-адрес
    Обязательный параметр. Указывает IP-адрес DHCP-сервера для удаления.

    Задание глобальных параметров ведения журнала для конфигурации агента DHCP-ретрансляции.

    Синтаксис

    set global [LogLevel=]{none | error | warn | info}

    Параметры

    [LogLevel=]{none | error | warn | info}
    Обязательный параметр. Указывает события агента DHCP-ретрансляции для записи в журнал. Параметр none означает, что события агента DHCP-ретрансляции не будут занесены в журнал. Параметр error задает только занесение ошибок, связанных с агентом DHCP-ретрансляции. Параметр warn определяет только занесение предупреждений, связанных с агентом DHCP-ретрансляции. Параметр info означает, что все события агента DHCP-ретрансляции будут занесены в журнал.

    Обновляет конфигурацию агента DHCP-ретрансляции на интерфейсе.

    Синтаксис

  • set interface [InterfaceName=]имя_интерфейса [relaymode=]{enable | disable} [[maxhop=]целое] [[minsecs=]целое]

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, на котором требуется обновить конфигурацию агента DHCP-ретрансляции. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    [relaymode=]{enable | disable}
    Обязательный параметр. Указывает состояние агента DHCP-ретрансляции. Параметр enable соответствует включенному состоянию агента DHCP-ретрансляции для данного интерфейса. Параметр disable — отключенному состоянию.
    [maxhop=]целое
    Указывает число переходов пакета DHCP до момента, когда его следует отбросить и больше не передавать.
    [minsecs=]целое
    Задает минимальное число секунд с момента загрузки до появления пакета DHCP перед его отправлением серверу DHCP из списка серверов, сообщения который перенаправляются агентом DHCP-ретрансляции.

    Примеры

    Чтоб обновить конфигурацию агента DHCP-ретрансляции на интерфейсе «Подключение по локальной сети» с максимальным числом переходов 16 и минимальным количеством секунд с момента загрузки 4, введите команду:

    set interface "Подключение по локальной сети" enable 16 4

    Выводит сведения о конфигурации агента DHCP-ретрансляции на заданном интерфейсе.

    Синтаксис

    show interface [InterfaceName=]имя_интерфейса

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, для которого требуется отобразить сведения. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").

    Выводит глобальную конфигурацию агента DHCP-ретрансляции.

    Синтаксис

    show global [[Rr=]целое]

    Параметры

    [Rr=]целое
    Указывает в секундах интервал обновления сведений.

    Выводит сведения о конфигурации агента DHCP-ретрансляции для заданного интерфейса. При использовании без параметров команда show ifconfig отображает сведения сразу для всех интерфейсов, где включен агент DHCP-ретрансляции.

    Синтаксис

    show ifconfig [[Index=]целое] [[Rr=]целое]

    Параметры

    [Index=]целое
    Задает значение индекса интерфейса, для которого требуется отобразить сведения.
    [Rr=]целое
    Указывает в секундах интервал обновления сведений.

    тображает привязки IP-адресов для указанного интерфейса. При использовании без параметров команда show ifbinding отображает сведения сразу для всех интерфейсов, где включен для использования агент DHCP-ретрансляции.

    Синтаксис

    show ifbinding [[Index=]целое] [[Rr=]целое]

    Параметры

    [Index=]целое
    Задает значение индекса интерфейса, для которого требуется отобразить сведения.
    [Rr=]целое
    Указывает в секундах интервал обновления сведений.

    Выводит статистику агента DHCP-ретрансляции для заданного интерфейса. При использовании без параметров команда show ifstats отображает сведения сразу для всех интерфейсов, где включен для использования агент DHCP-ретрансляции.

    Синтаксис

    show ifstats [[Index=]целое] [[Rr=]целое]

    Параметры

    [Index=]целое
    Задает значение индекса интерфейса, для которого требуется отобразить сведения.
    [Rr=]целое
    Указывает в секундах интервал обновления сведений.

    Команды Netsh Routing IP OSPF

    Следующие команды доступны для использования в контексте «Netsh Routing IP OSPF».

    Чтобы посмотреть синтаксис команды, щелкните команду:

    Примечание

    • Протокол OSPF недоступен в операционной системе Windows XP 64-Bit Edition.

    Добавляет пару IP-адреса и маски, определяющих диапазон адресов, принадлежащих данной области.

    Синтаксис

    add range [Areaid=]IP-адрес [Range=]IP-адрес маска_подсети

    Параметры

    [Areaid=]IP-адрес
    Обязательный параметр. Указывает IP-адрес области, к которой добавляется диапазон адресов.
    [Range=]IP-адрес маска_подсети
    Обязательный параметр. Задает IP-адрес и маску диапазона для добавления.

    Примечания

    • Диапазоны OSPF служат для суммирования маршрутов внутри данной OSPF-области.

    Добавляет код для области.

    Синтаксис

    add area [Areaid=]IP-адрес

    Параметры

    [Areaid=]IP-адрес
    Обязательный параметр. Определяет IP-адрес области, к которой необходимо добавить диапазон.

    Примечания

    • Параметр Areaid — 32-разрядное число, представленное в точечно-десятичной нотации, определяющее область OSPF. Код области может не совпадать с IP-адресом или кодом сети IP. Код области 0.0.0.0 зарезервирован для магистрали. Если сетевая область разбита на несколько подсетей, можно воспользоваться для кода области номером этой сети IP.

    Добавляет виртуальный интерфейс для маршрутизатора.

    Синтаксис

    add virtif [transareaid=]код_транзитной_области [virtnbrid=]код_виртуального_соседа

    Параметры

    [transareaid=]код_транзитной_области
    Обязательный параметр. Указывает IP-адрес транзитной области, используемой для обмена сведениями о маршрутизации между граничным маршрутизатором магистральной области и и граничным маршрутизатором непоследовательной области.
    [virtnbrid=]код_виртуального_соседа
    Обязательный параметр. Определяет IP-адрес кода маршрутизатора виртуального соседа для добавления.

    Добавляет соседа OSPF к указанному интерфейсу.

    Синтаксис

    add neighbor [InterfaceName=]имя_интерфейса [addr=]IP-адрес [nbraddr=]IP-адрес [nbrprio=]приоритет

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, к которому необходимо добавить соседа. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    [Areaid=]IP-адрес
    Обязательный параметр. Указывает IP-адрес OSPF-интерфейса.
    [nbraddr=]IP-адрес
    Обязательный параметр. Определяет IP-адрес соседа для добавления.
    [nbrprio=]приоритет
    Обязательный параметр. Задает приоритет OSPF-маршрутизатора соседа, которого требуется добавить.

    Настраивает OSPF в соответствии с заданным интерфейсом.

    Синтаксис

    add interface [InterfaceName=]имя_интерфейса [areaid=]IP-адрес [addr=]IP-адрес [mask=]маска_подсети

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Определяет имя интерфейса, на который необходимо добавить OSPF. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    [areaid=]IP-адрес
    Обязательный параметр. Указывает IP-адрес области, к которой принадлежит интерфейс.
    [addr=]IP-адрес
    Обязательный параметр. Определяет IP-адрес интерфейса для добавления.
    [mask=]маска_подсети
    Обязательный параметр. Задает маску подсети интерфейса для добавления.

    Добавляет фильтр маршрутов OSPF.

    Синтаксис

    add routefilter [Filter=]IP-адрес маска_подсети

    Параметры

    [Filter=]IP-адрес маска_подсети
    Обязательный параметр. Задает IP-адрес и маску подсети для маршрута, который необходимо профильтровать.

    Добавляет фильтр протокола OSPF.

    Синтаксис

    add protofilter [filter=]{autostatic | local | rip | snmp | nondod | static}

    Параметры

    [filter=]{autostatic | local | rip | snmp | nondod | static}
    Обязательный параметр. Указывает фильтр протокола, который необходимо добавить. Параметр autostatic задает автостатический маршрут RIP. Параметр local указывает маршрут, добавленный из сети, к которой подключен компьютер. Параметр rip означает, что фильтр добавлен с использованием RIP. Параметр snmp указывает, что фильтр добавлен с использованием SNMP. Параметр nondod определяет маршрут RTM, который присутствует только при подключенном интерфейсе DOD. Параметр static задает маршрут RTM.

    Примечания

    • Команда add protofilter используется на маршрутизаторе OSPF, который действует в качестве граничного маршрутизатора автономной системы. Добавленные фильтры фильтруют другие источники маршрутов по протоколу (например статические маршруты и протокол RIP) так, что они не перераспределяются в автономной системе OSPF.

    Устанавливает OSPF.

    Синтаксис

    install

    Параметры

    Отсутствуют.

    Удаляет указанный диапазон для кода области.

    Синтаксис

    delete range [Areaid=]IP-адрес [Range=]IP-адрес маска_подсети

    Параметры

    [Areaid=]IP-адрес
    Обязательный параметр. Указывает IP-адрес области для удаления.
    [Range=]IP-адрес маска_подсети
    Обязательный параметр. Определяет IP-адрес и маску подсети диапазона области, который требуется удалить.

    Удаляет указанную область.

    Синтаксис

    delete area [Areaid=]IP-адрес

    Параметры

    [Areaid=]IP-адрес
    Обязательный параметр. Указывает IP-адрес области для удаления.

    Примечания

    Код области — 32-разрядное число, представленное в точечно-десятичной нотации, определяющее область OSPF. Код области может не совпадать с IP-адресом или кодом сети IP. Код области 0.0.0.0 зарезервирован для магистрали. Если сетевая область разбита на несколько подсетей, можно воспользоваться для кода области номером этой сети IP.

    Удаляет указанный виртуальный интерфейс.

    Синтаксис

    delete virtif [transareaid=]код_транзитной_области [virtnbrid=]код_виртуального_соседа

    Параметры

    [transareaid=]код_транзитной_области
    Обязательный параметр. Указывает IP-адрес транзитной области, используемой для обмена сведениями о маршрутизации между граничным маршрутизатором магистральной области и и граничным маршрутизатором непоследовательной области.
    [virtnbrid=]код_виртуального_соседа
    Обязательный параметр. Задает код маршрутизатора виртуального соседа для удаления.

    Удаляет указанного соседа OSPF.

    Синтаксис

    delete neighbor [InterfaceName=]имя_интерфейса [addr=]IP-адрес [nbraddr=]IP-адрес [nbrprio=]приоритет

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, из которого необходимо удалить соседа. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    [addr=]IP-адрес
    Обязательный параметр. Задает IP-адрес интерфейса, из которого необходимо удалить соседа.
    [nbraddr=]IP-адрес
    Обязательный параметр. Задает IP-адрес области, которую необходимо удалить.
    [nbrprio=]приоритет
    Обязательный параметр. Задает приоритет маршрутизатора OSPF для удаления.

    Удаляет OSPF с заданного интерфейса.

    Синтаксис

    delete interface [InterfaceName=]имя_интерфейса [addr=]IP-адрес [mask=]маска_подсети

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, с которого необходимо удалить OSPF. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    [addr=]IP-адрес
    Обязательный параметр. Указывает IP-адрес интерфейса для удаления.
    [mask=]маска_подсети
    Обязательный параметр. Указывает маску подсети интерфейса для удаления.

    Удаляет указанный фильтр маршрутов OSPF.

    Синтаксис

    delete routefilter [Filter=]IP-адрес маска_подсети

    Параметры

    [Filter=]IP-адрес маска_подсети
    Обязательный параметр. Определяет IP-адрес и маску подсети фильтра маршрутов, который требуется удалить.

    Удаляет указанный фильтр протокола OSPF.

    Синтаксис

    delete protofilter [filter=]{autostatic | local | rip | snmp | nondod | static}

    Параметры

    [filter=]{autostatic | local | rip | snmp | nondod | static}
    Обязательный параметр. Задает фильтр протокола для удаления. Параметр autostatic указывает автостатический маршрут RIP. Параметр local указывает маршрут, удаленный из сети, к которой подключен компьютер. Параметр rip означает, что фильтр удален с использованием RIP. Параметр snmp указывает, что фильтр удален с использованием SNMP. Параметр nondod определяет маршрут RTM, который присутствует только при подключенном интерфейсе DOD. Параметр static задает маршрут RTM.

    Примечания

    • Команда delete protofilter используется на маршрутизаторе OSPF, который действует в качестве граничного маршрутизатора автономной системы. Добавленные фильтры фильтруют другие источники маршрутов по протоколу (например статические маршруты и протокол RIP) так, что они не перераспределяются в автономной системе OSPF.

    Удаляет OSPF.

    Параметры

    Отсутствуют.

    Изменяет параметры данной области.

    Синтаксис

  • set area [areaid=]код_области [[auth=]{none | password}] [[stubarea=]{yes | no}] [[metric=]изолированная_метрика] [[sumadv=]{yes | no}]

    Параметры

    [areaid=]код_области
    Обязательный параметр. Указывает IP-адрес OSPF-области, параметры которой требуется изменить.
    [auth=]{none | password}
    Определяет разрешение паролей для области. При разрешении паролей для области, все интерфейсы данной области и на том же сегменте сети используют одинаковый пароль, а интерфейсы данной области, но на других сегментах сети могут иметь разные пароли. По умолчанию пароли разрешены и пароль — 12345678. Пароли передаются обычным текстом, поэтому это параметр идентификации, а не безопасности.
    [stubarea=]{yes | no}
    Указывает настойку области в качестве изолированной, которая является OSPF-областью, не включающей внешние маршруты. Маршруты, не входящие в автономную систему OSPF, не распространяются на изолированные области или через них. Маршрутизация к внешним назначениям автономной системы в этих областях основана только на сведениях маршрута по умолчанию. Это снижает расходы на маршрутизаторы в изолированной области.
    [metric=]изолированная_метрика
    Задает стоимость свободного маршрута по умолчанию, объявляемого в изолированной области.
    [sumadv=]{yes | no}
    Определяет необходимость импорта итоговых объявлений.

    Настраивает параметры для данного виртуального интерфейса.

    Синтаксис

  • set virtif [transareaid=]код_транзитной_области [virtnbrid=]код_виртуального_соседа [[transdelay=]задержка_транзита] [[retrans=]интервал_повтора_передачи] [[hello=]интервал_приветствия] [[dead=]интервал_исчезновения] [[password=]пароль]

    Параметры

    [transareaid=]код_транзитной_области
    Обязательный параметр. Указывает IP-адрес транзитной области.
    [virtnbrid=]код_виртуального_соседа
    Обязательный параметр. Задает код маршрутизатора виртуального соседа.
    [transdelay=]задержка_транзита
    Определяет оценочное количество времени (в секундах), которое требуется для передачи пакетов обновления состояния связи через данный интерфейс. Если параметр не указан, оценочное время задержки — 1 секунда.
    [retrans=]интервал_повтора_передачи
    Указывает количество секунд между повторами передачи объявления состояния связи для соседств данного интерфейса. Стандартное значение для локальной сети равно 5 секундам.
    [hello=]интервал_приветствия
    Задает в секундах интервал между передачами пакетов приветствия маршрутизатором данного интерфейса. Этот параметр на всех маршрутизаторах, подключенных к одной сети, должен быть одинаковым. Стандартное значение для локальной сети равно 10 секундам.
    [dead=]интервал_исчезновения
    Определяет в секундах интервал, в течение которого маршрутизатор не отвечает, пока соседний маршрутизатор не поймет, что данный не работает. Интервал исчезновения должен быть кратен интервалу приветствия (обычно с множителем 4). Этот параметр на всех маршрутизаторах OSPF, подключенных к одному сегменту сети, должен быть одинаковым.
    [password=]пароль
    Задает пароль для интерфейса, если пароли разрешены для области. Все интерфейсы одной области и находящиеся в одной сети, должны использовать одинаковый пароль. По умолчанию пароли разрешены и пароль — 12345678.

    Настраивает параметры OSPF для интерфейса.

    Синтаксис

  • set interface [interfacename=]имя_интерфейса [addr=]IP-адрес [mask=]маска_подсети [[state=]{enable | disable}] [[areaid=]код_области] [[type=]{nbma | p2p | broadcast}] [[prio=]приоритет] [[transdelay=]задержка_транзита] [[retrans=]интервал_повтора_передачи] [[hello=]интервал_приветствия] [[dead=]интервал_исчезновения] [[poll=]интервал_опроса] [[metric=]метрика] [[password=]пароль] [[mtu=]размер_MTU]

    Параметры

    [interfacename=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, для которого требуется настроить параметры. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    [addr=]IP-адрес
    Обязательный параметр. Указывает IP-адрес интерфейса.
    [mask=]маска_подсети
    Обязательный параметр. Задает маску подсети интерфейса.
    [state=]{enable | disable}
    Определяет состояние интерфейса. Параметр enable включает интерфейс. Параметр disable отключает его.
    [areaid=]код_области
    Указывает IP-адрес области интерфейса.
    [type=]{nbma | p2p | broadcast}
    Задает тип интерфейса OSPF, для которого требуется настроить параметры. Параметр nbma означает, что OSPF-интерфейс является интерфейсом NBMA (нешироковещательного множественного доступа). Параметр p2p указывает, что OSPF-интерфейс является интерфейсом «точка-точка». Параметр broadcast задает широковещательный OSPF-интерфейс.
    [prio=]приоритет
    Указывает приоритет интерфейса.
    [transdelay=]задержка_транзита
    Определяет оценочное количество времени (в секундах), которое требуется для передачи пакетов обновления состояния связи через данный интерфейс. Если параметр не указан, оценочное время задержки — 1 секунда.
    [retrans=]интервал_повтора_передачи
    Указывает количество секунд между повторами передачи объявления состояния связи для соседств данного интерфейса. Стандартное значение для локальной сети равно 5 секундам.
    [hello=]интервал_приветствия
    Задает в секундах интервал между передачами пакетов приветствия маршрутизатором данного интерфейса. Этот параметр на всех маршрутизаторах, подключенных к одной сети, должен быть одинаковым. Стандартное значение для локальной сети равно 10 секундам.
    [dead=]интервал_исчезновения
    Определяет в секундах интервал, в течение которого маршрутизатор не отвечает, пока соседний маршрутизатор не поймет, что данный не работает. Интервал исчезновения должен быть кратен интервалу приветствия (обычно с множителем 4). Этот параметр на всех маршрутизаторах OSPF, подключенных к одному сегменту сети, должен быть одинаковым.
    [poll=]интервал_опроса
    Указывает интервал (в секундах) между опросами сети OSPF только интерфейсов NMBA (нешироковещательного множественного доступа). Интервал опроса должен быть хотя бы в два раза больше, чем интервал исчезновения. Стандартное значение для сети X.25 равно 2 минутам.
    [metric=]метрика
    Определяет стоимость отправления пакета с данного интерфейса. Значение в этом параметре объявляется стоимостью связи для данного интерфейса в объявлении состояния связи маршрутизатора. Обычно более быстрые интерфейсы имеют более низкую стоимость. Максимальное значение равно 32767.
    [password=]пароль
    Задает пароль для интерфейса, если пароли разрешены для области. Все интерфейсы одной области и находящиеся в одной сети, должны использовать одинаковый пароль. По умолчанию пароли разрешены и пароль — 12345678.
    [mtu=]размер_MTU
    Указывает максимальный размер (в байтах) IP-пакетов со сведениями OSPF, которые можно отправить без фрагментации. По умолчанию, размер IP-пакета MTU для сети Ethernet — 1500 байтов.

    Настраивает глобальные параметры OSPF.

    Синтаксис

    set global [routerid=]IP-адрес [asborder=]{yes | no} [[loglevel=]{none | error | warn | info}]

    Параметры

    [routerid=]IP-адрес
    Обязательный параметр. Указывает IP-адрес маршрутизатора, для которого необходимо настроить параметры.
    [asborder=]{yes | no}
    Обязательный параметр. Задает работу в режиме граничного маршрутизатора автономной системы (AS).
    [loglevel=]{none | error | warn | info}
    Указывает события для записи в журнал. Параметр none означает, что все события OSPF будут занесены в журнал. Параметр error задает только занесение ошибок, связанных с OSPF. Параметр warn определяет только занесение предупреждений, связанных с OSPF. Параметр info означает, что все события OSPF будут занесены в журнал.

    Настраивает действия фильтра маршрутов OSPF.

    Синтаксис

    set routefilter [action=]{drop | accept}

    Параметры

    [action=]{drop | accept}
    Обязательный параметр. Указывает фильтру маршрутов отбрасывать или принимать пакеты. Параметр drop означает отбрасывание пакетов. Параметр accept означает принятие пакетов.

    Настраивает действия фильтра протокола OSPF.

    Синтаксис

    set protofilter [action=]{drop | accept}

    Параметры

    [action=]{drop | accept}
    Обязательный параметр. Указывает фильтру протокола отбрасывать или принимать пакеты. Параметр drop означает отбрасывание пакетов. Параметр accept означает принятие пакетов.

    тображает глобальные параметры OSPF.

    Синтаксис

    show global

    Параметры

    Отсутствуют.

    Отображает параметры области.

    Синтаксис

    show area

    Параметры

    Отсутствуют.

    Отображает параметры всех виртуальных интерфейсов.

    Синтаксис

    show virtif

    Параметры

    Отсутствуют.

    Выводит сведения о конфигурации OSPF для заданного интерфейса.

    Синтаксис

    show interface [InterfaceName=]имя_интерфейса

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, для которого требуется отобразить сведения. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").

    Выводит сведения о фильтре маршрутов OSPF.

    Синтаксис

    show routefilter

    Параметры

    Отсутствуют.

    Выводит сведения о фильтре протокола OSPF.

    Синтаксис

    show protofilter

    Параметры

    Отсутствуют.

    Отображает сведения об областях OSPF.

    Синтаксис

    show area

    Параметры

    Отсутствуют.

    Вывод сведений о виртуальных OSPF-интерфейсах.

    Синтаксис

    show virtif

    Параметры

    Отсутствуют.

    Команды Netsh Routing IP Autodhcp

    Следующие команды доступны для использования в контексте «Netsh Routing IP Autodhcp».

    Чтобы посмотреть синтаксис команды, щелкните команду.

    Добавляет исключение в область DHCP-распределителя.

    Синтаксис

    add exclusion IP-адрес

    Параметры

    IP-адрес
    Обязательный параметр. Указывает IP-адрес, чтобы исключить его из области DHCP-распределителя.

    Удаляет исключение из области DHCP-распределителя.

    Синтаксис

    delete exclusion IPAddress

    Параметры

    IP-адрес
    Обязательный параметр. Указывает IP-адрес, уже исключенный из области DHCP-распределителя.

    Устанавливает протокол маршрутизации под IP.

    Синтаксис

    install

    Параметры

    Отсутствуют.

    Настраивает глобальные параметры DHCP-распределителя.

    Синтаксис

  • set global {[[scopenetwork=]IP-адрес] | [[scopemask=]маска_подсети] | [[leasetime=]минуты] | [[loglevel=]{none | error | warn | info}]}

    Параметры

    [scopenetwork=]IP-адрес
    Указывает IP-адрес для области DHCP-распределителя.
    [scopemask=]маска_подсети
    Задает маску подсети, связанную с IP-адресом для области.
    [leasetime=]минуты
    Определяет продолжительность аренды в минутах.
    [LogLevel=]{none | error | warn | info}
    Указывает события для записи в журнал. Параметр none означает, что все события DHCP будут занесены в журнал. Параметр error задает только занесение ошибок, связанных с DHCP. Параметр warn определяет только занесение предупреждений, связанных с DHCP. Параметр info означает, что все события DHCP будут занесены в журнал.

    Примеры

    Чтобы задать значение IP сети для DHCP-распределителя 10.10.10.10, с соответствующей маской подсети 255.255.255.0, продолжительностью аренды в11520 минут (8 дней) и записывать в журнал все связанные события, введите команду:

    set global 10.10.10.0 255.255.255.0 11520 info

    Чтобы указать время аренды глобально для всех областей на всех интерфейсах, равное 4320 минутам (3 дням), введите команду:

    set global leasetime=4320

    Настраивает параметры DHCP-распределителя для данного интерфейса.

    Синтаксис

    set interface [InterfaceName=]имя_интерфейса [mode=]{enable | disable}

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, на котором требуется настроить параметры. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    [mode=]{enable | disable}
    Обязательный параметр. Указывает состояние DHCP-распределителя для данного интерфейса.

    Отображает глобальную конфигурацию DHCP-распределителя.

    Синтаксис

    show global

    Параметры

    Отсутствуют.

    Отображение конфигурации DHCP-распределителя для указанного интерфейса.

    Синтаксис

    show interface [InterfaceName=]имя_интерфейса

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, для которого требуется отобразить сведения. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").

    Удаляет протокол маршрутизации из IP.

    Синтаксис

    uninstall

    Параметры

    Отсутствуют.

    Команды Netsh Routing IP Dnsproxy

    Следующие команды доступны для использования в контексте «Netsh Routing IP Dnsproxy».

    Чтобы посмотреть синтаксис команды, щелкните команду.

    адает глобальные параметры DNS-прокси.

    Синтаксис

  • set global [querytimeout=]целое [[dnsmode=]{enable | disable}] [[winsmode=]{enable | disable}] [[loglevel=]{none | error | warn | info}]

    Параметры

    [querytimeout=]целое
    Обязательный параметр. Указывает время ожидания в секундах для запросов DNS от имени клиентов.
    [dnsmode=]{enable | disable}
    Определяет включение или отключение операции DNS-прокси.
    [winsmode=]{enable | disable}
    Задает включение или отключение операции WINS-прокси.
    [loglevel=]{none | error | warn | info}
    Указывает события для записи в журнал. Параметр none означает, что все события DNS-прокси будут занесены в журнал. Параметр error задает только занесение ошибок, связанных с DNS-прокси. Параметр warn определяет только занесение предупреждений, связанных с DNS-прокси. Параметр info означает, что все события DNS-прокси будут занесены в журнал.

    Примеры

    Чтобы определить время ожидания для запросов в 10 секунд, включить операцию DNS-прокси и операцию WINS-прокси, и не заносить события DNS-прокси, введите команду:

    set global 10 enable enable none

    Устанавливает протокол маршрутизации под IP.

    Синтаксис

    install

    Параметры

    Отсутствуют.

    страивает параметры DNS-прокси для интерфейса.

    Синтаксис

    set interface [InterfaceName=]имя_интерфейса [[mode=]{enable | disable | default}]

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, для которого требуется настроить параметры. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    [mode=]{enable | disable | default}
    Определяет включение, отключение или установку использования по умолчанию DNS-прокси для указанного интерфейса. Параметр enable включает DNS-прокси. Параметр disnable отключает DNS-прокси. Параметр default указывает, что DNS-прокси настроен по умолчанию для интерфейса.
    тображает глобальную конфигурацию DNS-прокси.

    Синтаксис

    show global

    Параметры

    Отсутствуют.

    Отображает конфигурацию DNS-прокси для указанного интерфейса.

    Синтаксис

    show interface [InterfaceName=]имя_интерфейса

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, для которого требуется отобразить сведения. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").

    даляет протокол маршрутизации из IP.

    Синтаксис

    uninstall

    Параметры

    Отсутствуют.

    Команды Netsh Routing IP NAT

    Следующие команды доступны для использования в контексте «Netsh Routing IP NAT».

    Чтобы посмотреть синтаксис команды, щелкните команду.

    Добавляет сопоставление IP-адресов в пул трансляции сетевых адресов (NAT) для указанного интерфейса.

    Синтаксис

  • add addressmapping [InterfaceName=]имя_интерфейса [public=]IP-адрес [private=]IP-адрес [inboundsessions=]{enable | disable}

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Определяет имя интерфейса, на котором необходимо использовать трансляцию сетевых адресов. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    [public=]IP-адрес
    Обязательный параметр. Указывает IP-адрес, используемый в общедоступной сети.
    [private=]IP-адрес
    Обязательный параметр. Задает IP-адрес из диапазона адресов в пуле доступных для использования в частной сети.
    [inboundsessions=]{enable | disable}
    Обязательный параметр. Определяет состояние сетевых сеансов. Параметр enable означает, что входящие сеансы включены. Параметр disable указывает, что входящие сеансы отключены.

    Примеры

    Чтобы сопоставить общий IP-адрес 10.11.11.1 частному IP-адресу 10.10.10.1 и отключить входящие сеансы для данного сопоставления таблицы трансляции сетевых адресов, введите команду:

    add addressmapping "Подключение по локальной сети" 10.11.11.1 10.10.10.1 disable

    Добавляет диапазон адресов в пул трансляции сетевых адресов для указанного интерфейса.

    Синтаксис

    add addressrange [InterfaceName=]имя_интерфейса [start=]IP-адрес [end=]IP-адрес [mask=]маска_подсети

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Указывает имя интерфейса, к пулу интерфейса которого необходимо добавить диапазон адресов.
    [start=]IP-адрес
    Обязательный параметр. Указывает начальный IP-адрес диапазона адресов.
    [end=]IP-адрес
    Обязательный параметр. Указывает конечный IP-адрес диапазона адресов.
    [mask=]маска_подсети
    Обязательный параметр. Указывает маску подсети, связанную с диапазоном сетевых адресов, ограниченным начальным и конечным IP-адресами.

    Настраивает NAT в соответствии с заданным интерфейсом.

    Синтаксис

    add interface [InterfaceName=]имя_интерфейса [[mode=]{full | addressonly | private}]

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, на который требуется настроить NAT. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    [mode=]{full | addressonly | private}
    Указывает режим, который использует интерфейс: полный, только адресный или частный.

    Добавляет сопоставление порта протокола в интерфейс NAT.

    Синтаксис

    add portmapping [InterfaceName=]имя_интерфейса [proto=]{tcp | udp} [publicip=]{IP-адрес | 0.0.0.0} [publicport=]целое [privateip=]IP-адрес [privateport=]целое

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, к которому необходимо добавить сопоставление порта. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    [proto=]{tcp | udp}
    Обязательный параметр. Указывает тип протокола TCP или UDP.
    [publicip=]{IP-адрес | 0.0.0.0}
    Обязательный параметр. Задает либо внешний IP-адрес в общей сети, либо 0.0.0.0 для любого не указанного IP-адреса в диапазоне адресов частной сети.
    [publicport=]целое
    Обязательный параметр. Определяет порт общего протокола с помощью номера от 0 до 9999.
    [privateip=]IP-адрес
    Обязательный параметр. Задает IP-адрес из диапазона частной сети.
    [privateport=]целое
    Обязательный параметр. Определяет порт частного протокола с помощью номера от 0 до 9999.

    Удаляет соответствие адресов из пула трансляции сетевых адресов для указанного интерфейса.

    Синтаксис

    delete addressmapping [InterfaceName=]имя_интерфейса [[public=]IP-адрес]

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, для которого необходимо удалить сопоставление адресов. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    [public=]IP-адрес
    Задает IP-адрес для удаления. Если адрес не указан, с интерфейса все соответствия адресов из пула трансляции сетевых адресов удаляются.

    Удаляет диапазон адресов из пула трансляции сетевых адресов для указанного интерфейса.

    Синтаксис

    delete addressrange [InterfaceName=]имя_интерфейса [start=]IP-адрес

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, для которого необходимо удалить диапазон адресов. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    [start=]IP-адрес
    Обязательный параметр. Указывает начальный IP-адрес диапазона для удаления.

    Удаляет трансляцию сетевых адресов (NAT) с указанного интерфейса.

    Синтаксис

    delete interface [InterfaceName=]имя_интерфейса

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, для которого необходимо удалить использование NAT. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").

    Удаляет сопоставление порта протокола из указанного для интерфейса с включенным NAT.

    Синтаксис

    delete portmapping [InterfaceName=]имя_интерфейса [[proto=]{tcp | udp}] [publicip=]{IP-адрес | 0.0.0.0}] [[publicport=]целое] [[privateip=]IP-адрес] [privateport=]целое]

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, для которого необходимо удалить сопоставление порта. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    [proto=]{tcp | udp}
    Указывает тип протокола. Параметр tcp означает, что тип протокола — Transmission Control Protocol. Параметр udp указывает тип протокола User Datagram Protocol.
    [publicip=]{IP-адрес | 0.0.0.0}
    Задает либо внешний IP-адрес в общей сети, либо 0.0.0.0 для любого не указанного IP-адреса в диапазоне адресов частной сети.
    [publicport=]целое
    Определяет порт общего протокола с помощью номера от 0 до 9999.
    [privateip=]IP-адрес
    Задает IP-адрес из диапазона частной сети.
    [privateport=]целое
    Определяет порт частного протокола с помощью номера от 0 до 9999.

    Задает глобальные параметры для NAT.

    Синтаксис

    set global {[[tcptimeoutmins=]целое] | [[udptimeoutmins=]целое] | [[LogLevel=]{none | error | warn | info}]}

    Параметры

    [tcptimeoutmins=]целое
    Указывает в минутах значение времени ожидания для сопоставлений TCP.
    [udptimeoutmins=]целое
    Указывает в минутах значение времени ожидания для сопоставлений UDP.
    [LogLevel=]{none | error | warn | info}
    Указывает события для записи в журнал. Параметр none означает, что все события NAT будут занесены в журнал. Параметр error задает только занесение ошибок, связанных с NAT. Параметр warn определяет только занесение предупреждений, связанных с NAT. Параметр info означает, что все события NAT будут занесены в журнал.

    Настраивает параметры NAT в соответствии с заданным интерфейсом.

    Синтаксис

    set interface [InterfaceName=]имя_интерфейса [mode=]{полный | только_адресный | частный}

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, для которого требуется настроить параметры. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    [mode=]{полный | только_адресный | частный}
    Обязательный параметр. Указывает включенный режим интерфейса: полный, только адресный или частный.

    Отображает глобальную конфигурацию трансляции сетевых адресов (NAT).

    Синтаксис

    show global

    Параметры

    Отсутствуют.

    Отображает конфигурацию трансляции сетевых адресов (NAT) для указанного интерфейса.

    Синтаксис

    show interface [InterfaceName=]имя_интерфейса

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, для которого требуется отобразить сведения. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").

    Команды Netsh Routing IPX

    Следующие команды доступны для использования в контексте «Netsh Routing IPX».

    Чтобы посмотреть синтаксис команды, щелкните команду.

    Выводит сведения о конфигурации для заданного интерфейса.

    Синтаксис

    show interface [InterfaceName=]имя_интерфейса

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, для которого требуется отобразить сведения. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").

    Добавляет записи интерфейса к конфигурации протокола IPX.

    Синтаксис

    add interface [InterfaceName=]имя_интерфейса

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, записи которого необходимо добавить. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").

    Удаляет записи интерфейса из конфигурации протокола IPX

    Синтаксис

    delete interface [InterfaceName=]имя_интерфейса

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, записи которого требуется удалить. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").

    Обновляет конфигурацию IPX на определенном интерфейсе.

    Синтаксис

    set interface [InterfaceName=]имя_интерфейса {[[admstate=]{enabled | disabled}] | [[wanprotocol=]{ppp | ipxwan}]}

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, для которого требуется обновить конфигурацию IPX. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    [admstate=]{enabled | disabled}
    Указывает включен или выключен параметр «admstate».
    [wanprotocol=]{ppp | ipxwan}
    Определяет протокол интерфейса: PPP или ipxwan.

    Отображает сведения о маршрутах для данного сетевого адреса.

    Синтаксис

    show route сетевой_адрес

    Параметры

    сетевой_адрес
    Обязательный параметр. Задает, что длина сетевого адреса четырехбайтового типа не должна превышать 8 шестнадцатеричных цифр. 0s в начале является необязательным символом.

    Отображает сведения о конфигурации.

    Синтаксис

    show staticroute [InterfaceName=]имя_интерфейса сетевой_адрес

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, для которого требуется отобразить сведения. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    сетевой_адрес
    Обязательный параметр. Задает, что длина сетевого адреса четырехбайтового типа не должна превышать 8 шестнадцатеричных цифр. 0s в начале является необязательным символом.

    Добавляет записи к конфигурации протокола IPX указанного интерфейса.

    Синтаксис

    add staticroute [InterfaceName=]имя_интерфейса {[сетевой_адрес] | [[nexthopmacaddress=]Mac-адрес] | [[ticks=]целое] | [[hops=]целое]}

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, к конфигурации IPX которого необходимо добавить записи. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    сетевой_адрес
    Задает сетевой адрес в 4 байта не длиннее, чем 8 шестнадцатеричных чисел. 0x в начале является необязательным символом.
    [nexthopmacaddress=]Mac-адрес
    Задает, что длина МАС-адреса следующего прыжка шестибайтового типа не должна превышать 12 шестнадцатеричных цифр. 0s в начале является необязательным символом.
    [ticks=]целое
    Указывает количество тиков (десятичное целое).
    [hops=]целое
    Определяет количество прыжков (десятичное целое).

    Удаляет запись из конфигурации протокола IPX указанного интерфейса.

    Синтаксис

    delete staticroute [InterfaceName=]имя_интерфейса {[сетевой_адрес] | [[nexthopmacaddress=]Mac-адрес] | [[ticks=]целое] | [[hops=]целое]}

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, с которого необходимо удалить запись. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    сетевой_адрес
    Задает, что длина сетевого адреса четырехбайтового типа не должна превышать 8 шестнадцатеричных цифр. 0s в начале является необязательным символом.
    [nexthopmacaddress=]Mac-адрес
    Задает, что длина МАС-адреса следующего прыжка шестибайтового типа не должна превышать 12 шестнадцатеричных цифр. 0s в начале является необязательным символом.
    [ticks=]целое
    Указывает количество тиков (десятичное целое).
    [hops=]целое
    Определяет количество прыжков (десятичное целое).

    Обновляет конфигурацию IPX определенного интерфейса.

    Синтаксис

    set staticroute [InterfaceName=]имя_интерфейса {[сетевой_адрес] | [[nexthopmacaddress=]Mac-адрес] | [[ticks=]целое] | [[hops=]целое]}

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, конфигурацию IPX которого требуется обновить. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    сетевой_адрес
    Задает, что длина сетевого адреса четырехбайтового типа не должна превышать 8 шестнадцатеричных цифр. 0s в начале является необязательным символом.
    [nexthopmacaddress=]Mac-адрес
    Задает, что длина МАС-адреса следующего прыжка шестибайтового типа не должна превышать 12 шестнадцатеричных цифр. 0s в начале является необязательным символом.
    [ticks=]целое
    Указывает количество тиков (десятичное целое).
    [hops=]целое
    Определяет количество прыжков (десятичное целое).

    Отображает сведения о конфигурации имени службы. При использовании без параметров команда show service выводит на экран все типы и имена службы.

    Синтаксис

    show service [тип_службы] [имя_службы]

    Параметры

    тип_службы
    Задает, что длина службы двухбайтового типа не должна превышать 4 шестнадцатеричных цифры. 0s в начале является необязательным символом.
    имя_службы
    Задает имя службы, для которой требуется отобразить сведения.

    Отображает сведения о конфигурации службы статического маршрута.

    Синтаксис

    show staticservice [InterfaceName=]имя_интерфейса [тип_службы] [имя_службы]

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, для которого требуется отобразить сведения. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    тип_службы
    Задает, что длина службы двухбайтового типа не должна превышать 4 шестнадцатеричных цифры. 0s в начале является необязательным символом.
    имя_службы
    Определяет имя службы.

    Добавляет записи к конфигурации протокола IPX указанного интерфейса.

    Синтаксис

    add staticservice [InterfaceName=]имя_интерфейса {[тип_службы] | [имя_службы] | [сетевой_адрес] | [[node=]адрес_узла] | [[socket=]адрес_сокета] | [[hops=]целое]}

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, к конфигурации которого необходимо добавить записи. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    тип_службы
    Задает, что длина службы двухбайтового типа не должна превышать 4 шестнадцатеричных цифры. 0s в начале является необязательным символом.
    имя_службы
    Определяет имя службы.
    сетевой_адрес
    Задает, что длина сетевого адреса четырехбайтового типа не должна превышать 8 шестнадцатеричных цифр. 0s в начале является необязательным символом.
    [node=]адрес_узла
    Указывает, что длина адреса узла шестибайтового типа не должна превышать 12 шестнадцатеричных цифр. 0s в начале является необязательным символом.
    [socket=]адрес_сокета
    Определяет, что длина адреса сокета двухбайтового типа не должна превышать 4 шестнадцатеричных цифр. 0s в начале является необязательным символом.
    [hops=]целое
    Определяет количество прыжков (десятичное целое).

    Удаляет запись из конфигурации протокола IPX указанного интерфейса.

    Синтаксис

    delete staticservice [InterfaceName=]имя_интерфейса {[тип_службы] | [имя_службы] | [сетевой_адрес] | [[node=]адрес_узла] | [[socket=]адрес_сокета] | [[hops=]целое]}

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, с конфигурации IPX которого необходимо удалить запись. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    тип_службы
    Задает, что длина службы двухбайтового типа не должна превышать 4 шестнадцатеричных цифры. 0s в начале является необязательным символом.
    имя_службы
    Определяет имя службы.
    сетевой_адрес
    Задает, что длина сетевого адреса четырехбайтового типа не должна превышать 8 шестнадцатеричных цифр. 0s в начале является необязательным символом.
    [node=]адрес_узла
    Указывает, что длина адреса узла шестибайтового типа не должна превышать 12 шестнадцатеричных цифр. 0s в начале является необязательным символом.
    [socket=]адрес_сокета
    Определяет, что длина адреса сокета двухбайтового типа не должна превышать 4 шестнадцатеричных цифр. 0s в начале является необязательным символом.
    [hops=]целое
    Определяет количество прыжков (десятичное целое).

    Обновляет конфигурацию статического маршрута IPX.

    Синтаксис

    set staticservice [InterfaceName=]имя_интерфейса {[тип_службы] | [имя_службы] | [сетевой_адрес] | [[node=]адрес_узла] | [[socket=]адрес_сокета] | [[hops=]целое]}

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, конфигурацию которого требуется обновить. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    тип_службы
    Задает, что длина службы двухбайтового типа не должна превышать 4 шестнадцатеричных цифры. 0s в начале является необязательным символом.
    имя_службы
    Определяет имя службы.
    сетевой_адрес
    Задает, что длина сетевого адреса четырехбайтового типа не должна превышать 8 шестнадцатеричных цифр. 0s в начале является необязательным символом.
    [node=]адрес_узла
    Указывает, что длина адреса узла шестибайтового типа не должна превышать 12 шестнадцатеричных цифр. 0s в начале является необязательным символом.
    [socket=]адрес_сокета
    Определяет, что длина адреса сокета двухбайтового типа не должна превышать 4 шестнадцатеричных цифр. 0s в начале является необязательным символом.
    [hops=]целое
    Определяет количество прыжков (десятичное целое).

    Обновляет конфигурацию фильтра IPX-маршрутизатора.

    Синтаксис

    set filter [InterfaceName=]имя_интерфейса [[mode=]{input | output}] [[action=]{permit | deny}]

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, конфигурацию которого требуется обновить. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    [mode=]{input | output}
    Указывает режим ввода или вывода.
    [action=]{permit | deny}
    Определяет действие: разрешить или запретить.

    Выводит сведения о конфигурации IPX для заданного интерфейса.

    Синтаксис

    show filter [InterfaceName=]имя_интерфейса

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, для которого требуется отобразить сведения. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").

    Добавляет записи фильтра маршрутизатора к конфигурации протокола IPX.

    Синтаксис

    add filter [InterfaceName=]имя_интерфейса [mode=]{input | output} [[srcnet=]подсеть_источника] [[srcnode=]узел_источника] [[srcsocket=]сокет_источника] [[dstnet=]подсеть_результата] [[dstnode=]узел_результата] [[dstsocket=]сокет_результата] [[pkttype=]тип_пакета]

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, к которому необходимо добавить записи фильтра. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    [mode=]{input | output}
    Обязательный параметр. Задает режим.
    [srcnet=]подсеть_источника
    Задает, что длина маски сети четырехбайтового типа не должна превышать 8 шестнадцатеричных цифр. 0s в начале является необязательным символом.
    [srcnode=]узел_источника
    Указывает, что длина адреса узла шестибайтового типа не должна превышать 8 шестнадцатеричных цифр. 0s в начале является необязательным символом.
    [srcsocket=]сокет_источника
    Определяет, что длина адреса сокета двухбайтового типа не должна превышать 8 шестнадцатеричных цифр. 0s в начале является необязательным символом.
    [dstnet=]подсеть_результата
    Задает, что длина маски сети четырехбайтового типа не должна превышать 8 шестнадцатеричных цифр. 0s в начале является необязательным символом.
    [dstnode=]узел_результата
    Указывает, что длина адреса узла шестибайтового типа не должна превышать 8 шестнадцатеричных цифр. 0s в начале является необязательным символом.
    [dstsocket=]сокет_результата
    Определяет, что длина адреса сокета двухбайтового типа не должна превышать 8 шестнадцатеричных цифр. 0s в начале является необязательным символом.
    [pkttype=]тип_пакета
    Задает, что длина пакета однобайтового типа не должна превышать 8 шестнадцатеричных цифр. 0s в начале является необязательным символом.

    Удаляет записи фильтра маршрутизатора из конфигурации протокола IPX

    Синтаксис

    delete filter [InterfaceName=]имя_интерфейса [mode=]{input | output} [[srcnet=]подсеть_источника] [[srcnode=]узел_источника] [[srcsocket=]сокет_источника] [[dstnet=]подсеть_результата] [[dstnode=]узел_результата] [[dstsocket=]сокет_результата] [[pkttype=]тип_пакета]

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, с которого необходимо удалить запись фильтра. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    [mode=]{input | output}
    Обязательный параметр. Задает режим.
    [srcnet=]подсеть_источника
    Задает, что длина маски сети четырехбайтового типа не должна превышать 8 шестнадцатеричных цифр. 0s в начале является необязательным символом.
    [srcnode=]узел_источника
    Указывает, что длина адреса узла шестибайтового типа не должна превышать 8 шестнадцатеричных цифр. 0s в начале является необязательным символом.
    [srcsocket=]сокет_источника
    Определяет, что длина адреса сокета двухбайтового типа не должна превышать 8 шестнадцатеричных цифр. 0s в начале является необязательным символом.
    [dstnet=]подсеть_результата
    Задает, что длина маски сети четырехбайтового типа не должна превышать 8 шестнадцатеричных цифр. 0s в начале является необязательным символом.
    [dstnode=]узел_результата
    Указывает, что длина адреса узла шестибайтового типа не должна превышать 8 шестнадцатеричных цифр. 0s в начале является необязательным символом.
    [dstsocket=]сокет_результата
    Определяет, что длина адреса сокета двухбайтового типа не должна превышать 8 шестнадцатеричных цифр. 0s в начале является необязательным символом.
    [pkttype=]тип_пакета
    Задает , что длина пакета однобайтового типа не должна превышать 8 шестнадцатеричных цифр. 0s в начале является необязательным символом.

    Отображает глобальные сведения о конфигурации IPX.

    Синтаксис

    show global

    Параметры

    Отсутствуют.

    Настраивает глобальные параметры IPX.

    Синтаксис

    set global [LogLevel=]{none | error | warn | info}

    Параметры

    [LogLevel=]{none | error | warn | info}
    Обязательный параметр. Указывает события для записи в журнал. Параметр none означает, что все события IPX будут занесены в журнал. Параметр error задает только занесение ошибок, связанных с IPX. Параметр warn определяет только занесение предупреждений, связанных с IPX. Параметр info означает, что все события IPX будут занесены в журнал.

    Команды Netsh Routing IPX NetBIOS

    Следующие команды доступны для использования в контексте «Netsh Routing IPX NetBIOS».

    Чтобы посмотреть синтаксис команды, щелкните команду.

    Отображает распространение широковещательных сообщений NetBIOS и трафик на интерфейсах маршрутизаторов.

    Синтаксис

    show interface [InterfaceName=]имя_интерфейса

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, для которого требуется отобразить сведения. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").

    Настраивает распространение широковещательных сообщений NetBIOS и трафик на интерфейсах маршрутизаторов.

    Синтаксис

    set interface [InterfaceName=]имя_интерфейса [[bcastaccept=]{enabled | disabled}] [[bcastdeliver=]{enabled | disabled | staticonly | onlywhenup}]

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Определяет имя интерфейса, на котором необходимо настроить распространение. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    [bcastaccept=]{enabled | disabled}
    Определяет необходимость принятия широковещательных сообщений NetBIOS и трафика интерфейсом маршрутизатора.
    [bcastdeliver=]{enabled | disabled | staticonly | onlywhenup}
    Определяет необходимость и способ поставки широковещательных сообщений NetBIOS и трафика интерфейсом маршрутизатора. Если параметр bcastdeliver включен, все сообщения и трафик перенаправляются. Если параметр bcastdeliver выключен, сообщения и трафик не перенаправляются. Параметр onlywhenup означает, что широковещательные сообщения и трафик перенаправляются только, когда данный интерфейс включен. Параметр staticonly указывает, что широковещательные сообщения и трафик перенаправляются только для статических маршрутов.

    Отображает статические имена NetBIOS на указанном интерфейсе маршрутизатора.

    Синтаксис

    show nbname [InterfaceName=]имя_интерфейса

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, для которого требуется отобразить сведения. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").

    Добавляет статическое имя NetBIOS к указанному интерфейсу маршрутизатора.

    Синтаксис

    add nbname [InterfaceName=]имя_интерфейса имя_NetBIOS [[nbtype=]тип]

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, к которому необходимо добавить имя. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    имя_NetBIOS
    Обязательный параметр. Указывает имя NetBIOS для добавления.
    [nbtype=]тип
    Задает, что длина имени NetBIOS однобайтового типа не должна превышать 2 шестнадцатеричных цифры. 0s в начале является необязательным символом.

    даляет статическое имя NetBIOS из указанного интерфейса маршрутизатора.

    Синтаксис

    delete nbname [InterfaceName=]имя_интерфейса имя_NetBIOS [nbtype=]тип

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, из которого необходимо удалить имя. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    имя_NetBIOS
    Обязательный параметр. Указывает имя NetBIOS для удаления.
    [nbtype=]тип
    Задает, что длина имени NetBIOS однобайтового типа не должна превышать 2 шестнадцатеричных цифры. 0s в начале является необязательным символом.

    Команды Netsh Routing IPX RIP

    Следующие команды доступны для использования в контексте «Netsh Routing IPX RIP».

    Чтобы посмотреть синтаксис команды, щелкните команду.

    Отображает состояние IPX RIP указанного интерфейса. При использовании без параметров команда show interface выводит сведения для всех интерфейсов.

    Синтаксис

    show interface [[InterfaceName=]имя_интерфейса]

    Параметры

    [InterfaceName=]имя_интерфейса
    Задает имя интерфейса, для которого требуется отобразить сведения. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").

    Настраивает интерфейсы IPX RIP.

    Синтаксис

    set interface [InterfaceName=]имя_интерфейса [[admstate=]{enabled | disabled}] [[advertise=]{enabled | disabled}] [[listen=]{enabled | disabled}] [[gnsreply=]{enabled | disabled}] [[updatemode=]{standard | none | autostatic}] [[interval=]целое] [[agemultiplier=]целое]

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, который необходимо настроить. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    [admstate=]{enabled | disabled}
    Указывает, включен или выключен параметр «admstate».
    [advertise=]{enabled | disabled}
    Указывает, включено или выключено объявление.
    [listen=]{enabled | disabled}
    Указывает, включено или выключено прослушивание.
    [gnsreply=]{enabled | disabled}
    Указывает, включен или выключен параметр «gnsreply».
    [updatemode=]{standard | none | autostatic}
    Указывает время и способ выполнения обновления.
    [interval=]целое
    Определяет в секундах интервал обновления.
    [agemultiplier=]целое
    Задает множитель устаревания службы.

    Отображает глобальные параметры IPX RIP.

    Синтаксис

    show global

    Параметры

    Отсутствуют.

    Настраивает глобальные параметры IPX RIP.

    Синтаксис

    set global [LogLevel=]{none | error | warn | info}

    Параметры

    [LogLevel=]{none | error | warn | info}
    Обязательный параметр. Указывает события для записи в журнал. Параметр none указывает, что события IPX RIP не будут заноситься в журнал. Параметр error задает только занесение ошибок, связанных с IPX RIP. Параметр warn определяет только занесение предупреждений, связанных с IPX RIP. Параметр info означает, что все события IPX RIP будут занесены в журнал.

    Настраивает IPX RIP на заданный интерфейс.

    Синтаксис

    set filter [InterfaceName=]имя_интерфейса [mode=]{input | output} [action=]{permit | deny}

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, конфигурацию которого требуется обновить. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    [mode=]{input | output}
    Обязательный параметр. Указывает режим ввода или вывода.
    [action=]{permit | deny}
    Обязательный параметр. Определяет действие: разрешить или запретить.

    тображает сведения о конфигурации IPX RIP.

    Синтаксис

    show filter [InterfaceName=]имя_интерфейса [[mode=]{input | output}]

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, для которого требуется отобразить сведения. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    [mode=]{input | output}
    Указывает режим ввода или вывода.

    Добавляет записи фильтра маршрутизации к конфигурации протокола IPX RIP указанного интерфейса.

    Синтаксис

    add filter [InterfaceName=]имя_интерфейса [mode=]{input | output} [net=]сетевой_адрес [mask=]маска_подсети

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, к конфигурации IPX RIP которого необходимо добавить записи. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    [mode=]{input | output}
    Обязательный параметр. Указывает режим ввода или вывода.
    [net=]сетевой_адрес
    Обязательный параметр. Задает, что длина сетевого адреса четырехбайтового типа не должна превышать 8 шестнадцатеричных цифр. 0s в начале является необязательным символом.
    [mask=]маска_подсети
    Обязательный параметр. Задает, что длина маски сети четырехбайтового типа не должна превышать 8 шестнадцатеричных цифр. 0s в начале является необязательным символом.

    Удаляет записи фильтра маршрутизации из конфигурации протокола IPX RIP указанного интерфейса.

    Синтаксис

    delete filter [InterfaceName=]имя_интерфейса [mode=]{input | output} [net=]сетевой_адрес [mask=]маска_подсети

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, с конфигурации IPX RIP которого необходимо удалить запись. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    [mode=]{input | output}
    Обязательный параметр. Указывает режим ввода или вывода.
    [net=]сетевой_адрес
    Обязательный параметр. Задает, что длина сетевого адреса четырехбайтового типа не должна превышать 8 шестнадцатеричных цифр. 0s в начале является необязательным символом.
    [mask=]маска_подсети
    Обязательный параметр. Задает, что длина маски сети четырехбайтового типа не должна превышать 8 шестнадцатеричных цифр. 0s в начале является необязательным символом.

    Команды Netsh Routing IPX SAP

    Следующие команды доступны для использования в контексте «Netsh Routing IPX SAP».

    Чтобы посмотреть синтаксис команды, щелкните команду.

    Отображает состояние IPX SAP для указанного интерфейса. При использовании без параметров команда show interface выводит сведения для всех интерфейсов.

    Синтаксис

    show interface [[InterfaceName=]имя_интерфейса]

    Параметры

    [InterfaceName=]имя_интерфейса
    Задает имя интерфейса, для которого требуется отобразить сведения. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").

    Настраивает интерфейсы IPX SAP.

    Синтаксис

    set interface [InterfaceName=]имя_интерфейса [[admstate=]{enabled | disabled}] [[advertise=]{enabled | disabled}] [[listen=]{enabled | disabled}] [[gnsreply=]{enabled | disabled}] [[updatemode=]{standard | none | autostatic}] [[interval=]целое] [[agemultiplier=]целое]

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, для которого требуется настроить IPX SAP. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    [admstate=]{enabled | disabled}
    Указывает, включен или выключен параметр «admstate».
    [advertise=]{enabled | disabled}
    Указывает, включено или выключено объявление.
    [listen=]{enabled | disabled}
    Указывает, включено или выключено прослушивание.
    [gnsreply=]{enabled | disabled}
    Указывает, включен или выключен параметр «gnsreply».
    [updatemode=]{standard | none | autostatic}
    Указывает время и способ выполнения обновления.
    [interval=]целое
    Определяет интервал обновления в секундах.
    [agemultiplier=]целое
    Задает множитель устаревания службы.

    Отображает глобальные параметры IPX SAP.

    Синтаксис

    show global

    Параметры

    Отсутствуют.

    Настраивает глобальные параметры IPX SAP.

    Синтаксис

    set global [LogLevel=]{none | error | warn | info}

    Параметры

    [LogLevel=]{none | error | warn | info}
    Обязательный параметр. Указывает события для записи в журнал. Параметр none указывает, что события IPX SAP не будут заноситься в журнал. Параметр error задает только занесение ошибок, связанных с IPX SAP. Параметр warn определяет только занесение предупреждений, связанных с IPX SAP. Параметр info означает, что все события IPX SAP будут занесены в журнал.

    Обновляет конфигурацию IPX SAP.

    Синтаксис

    set filter [InterfaceName=]имя_интерфейса [mode=]{input | output} [action=]{permit | deny}

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, конфигурацию которого требуется обновить. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    [mode=]{input | output}
    Обязательный параметр. Указывает режим ввода или вывода.
    [action=]{permit | deny}
    Обязательный параметр. Определяет действие: разрешить или запретить.

    Выводит сведения о конфигурации IPX SAP для заданного интерфейса.

    Синтаксис

    show filter [InterfaceName=]имя_интерфейса [[mode=]{input | output}]

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, для которого требуется отобразить сведения. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    [mode=]{input | output}
    Указывает режим ввода или вывода.

    Добавляет записи к конфигурации протокола IPX SAP указанного интерфейса.

    Синтаксис

    add filter [InterfaceName=]имя_интерфейса [mode=]{input | output} [svtype=]тип_службы [svname=]имя_службы

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, к конфигурации которого необходимо добавить записи. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    [mode=]{input | output}
    Обязательный параметр. Указывает режим ввода или вывода.
    [svtype=]тип_службы
    Обязательный параметр. Задает, что длина службы двухбайтового типа не должна превышать 4 шестнадцатеричных цифры. 0s в начале является необязательным символом.
    [svname=]имя_службы
    Обязательный параметр. Определяет имя службы.

    Удаляет записи конфигурации фильтра из конфигурации протокола IPX SAP указанного интерфейса.

    Синтаксис

    delete filter [InterfaceName=]имя_интерфейса [mode=]{input | output} [svtype=]тип_службы [svname=]имя_службы

    Параметры

    [InterfaceName=]имя_интерфейса
    Обязательный параметр. Задает имя интерфейса, из конфигурации которого необходимо удалить записи. Параметр имя_интерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если имя_интерфейса содержит пробелы, его следует заключать в кавычки (например "имя интерфейса").
    [mode=]{input | output}
    Обязательный параметр. Указывает режим ввода или вывода.
    [svtype=]тип_службы
    Обязательный параметр. Задает, что длина службы двухбайтового типа не должна превышать 4 шестнадцатеричных цифры. 0s в начале является необязательным символом.
    [svname=]имя_службы
    Обязательный параметр. Определяет имя службы.

    Пример использования Netsh Routing

    Чтобы включить обнаружение маршрутизатора для интерфейса «Подключение по локальной сети», указав минимальный интервал 7 минут, максимальный — 10 минут, время жизни пакетов обнаружения маршрутизатора 30 минут и нулевой (0), т.е. отсутствующий, уровень предпочтения, введите команду:

    add interface "Подключение по локальной сети" enable 7 10 30 0


Команды Netsh для WINS

Команды Netsh для службы WINS предоставляют средство администрирования серверов WINS из командной строки, которое может быть использовано в качестве альтернативы управлению с помощью консоли. Это средство полезно в следующих ситуациях.

  • при управлении серверами WINS в глобальных сетях (WAN) команды могут быть использованы в интерактивном режиме в командной строке Netsh для лучшего управления медленными сетевыми соединениями;
  • при управлении большим числом серверов WINS команды могут быть использованы в пакетном режиме для записи и автоматизации повторяющихся административных задач, которые должны быть выполнены на всех серверах WINS.

В средстве Netsh (запускаемом из командной строки Windows XP) используются следующие команды.

Примечания

  • За исключением оговоренных случаев, теги полей (такие как Name= и EndChar=) не являются обязательными. При использовании тегов они должны применяться ко всем параметрам команды. Если теги пропущены, необходимо вводить значение для каждого поля, используемого в команде.
  • Термин «Persona Non Grata» соответствует функции WINS-сервера Windows 2000 Блокировать записи указанных владельцев.
  • Дополнительные сведения о командах netsh см. в разделе Использование Netsh.
  • Примеры использования команд Netsh для WINS в пакетных файлах и сценариях см. в разделе Пример команд Netsh WINS.
  • Команды Netsh не могут быть запущены локально под Windows XP Professional или Windows XP Home Edition. Для запуска этих команд Netsh на удаленном сервере под управлением Windows 2000 Server необходимо подключиться к серверу, на котором запущен сервер терминалов, с помощью программы «Подключение к удаленному рабочему столу». Эти команды запускаются из командной строки Windows 2000 или из командной строки контекста Netsh WINS. Для запуска этих команд из командной строки Windows 2000 необходимо перед вводом команд и параметров (описанных ниже) ввести netsh dhcp. Функции команд Netsh для Windows 2000 и Windows XP могут различаться.

Netsh WINS

Следующие команды доступны из приглашения wins>, открываемого в среде netsh.

Переключение в контекст указанного сервера. Используется без параметров, по умолчанию принят локальный WINS-сервер.

Синтаксис

server [{\\имя_сервера | IP-адрес}]

Параметры

{\\имя_сервера | IP-адрес}
Указание удаленного (не локального) WINS-сервера, на который необходимо переключить контекст командной строки Netsh WINS. Сервер задается именем или IP-адресом.

Примеры

В первом примере команда изменяет контекст Netsh на локальный WINS-сервер.

Во втором примере команда изменяет контекст Netsh на удаленный сервер WINS-сервер с именем \\WINS-SRV1.

В третьем примере примере команда изменяет контекст Netsh на удаленный сервер WINS-сервер с IP-адресом 10.0.0.1.

server

server \\WINS-SRV1

server 10.0.0.1

Команды Netsh WINS server

Следующие команды доступны из приглашения wins server>, доступного в среде netsh.

Добавление определенного пользователем фильтра в указанный WINS-сервер.

Синтаксис

add filter [ID=]код [Desc=]описание_фильтра

Параметры

[ID=]код
Обязательный параметр. Указание шестнадцатеричного кода добавляемого фильтра.
[Desc=]описание_фильтра
Обязательный параметр. Указание описания добавляемого фильтра.

Добавление записи имени в базу данных указанного WINS-сервера.

Синтаксис

  • add name [Name=]имя_компьютера [[EndChar=]16-й_знак_в_шестнадцатеричной_форме] [[Scope=]имя_области] [[RecType=]{0 | 1}] [[Group=]{0 | 1 | 2 | 3 | 4}] [[Node=]{0 | 1 | 3}] [IP=]{IP_адрес_1[,IP_адрес_2,IP_адрес_3… ]}

    Параметры

    [Name=]имя_компьютера
    Обязательный параметр. Указание имени для добавления и регистрации в базе данных WINS-сервера.
    [EndChar=]16-й_знак_в_шестнадцатеричной_форме
    Указание шестнадцатого знака имени в шестнадцатеричной форме. Если не указано, типы записи добавляются на основании значения параметра Group=. Дополнительные сведения см. в разделе «Заметки».
    [Scope=]имя_области
    Указание имени области NetBIOS.
    [RecType=]{0 | 1}
    Указание типа записи: 0 — статическая (по умолчанию), 1 — динамическая.
    [Group=]{0 | 1 | 2 | 3 | 4}
    Указание типа группы: 0 — уникальная (default), 1 — группа, 2 — Интернет3 — многосетевая, 4 — имя домена.
    [Node=]{0 | 1 | 3}
    Указание типа узла NetBIOS: 0 — узел B, 1 — узел P (по умолчанию), 3 — узел H.
    [IP=]{IP_адрес_1[,IP_адрес_2,IP_адрес_3…]}
    Обязательный параметр. Указание IP-адреса добавляемой записи. Если компьютер является многосетевым, имеется возможность указать несколько адресов. IP-адреса разделяются запятыми, строка адресов заключается в фигурные скобки ({}).

    Примечания

    • Если введены значения обоих параметров EndChar= и Group= , значение параметра EndChar= переопределяет значение Group=.
    • Если значение параметра EndChar= не указано, в базу данных WINS-сервера на основании значения параметра Group= добавляется запись следующего типа:
      Значение параметра группы | Тип добавляемой записи
      Уникальная группа (0) | 03h, 20h, 00h
      Нормальна группа (1) | 1eh
      Особая группа/Интернет (2) | 20h
      Многосетевая группа (3) | 03h, 20h, 00h
      Особая группа/домен (4) | 1ch

    Примеры

    В первом примере команда добавляет стандартный набор NetBIOS из записей 00h, 03h и 20h для компьютера с именем УЗЕЛ_А и IP-адресом 10.0.0.1.

    Во втором примере добавляется запись статического типа с типом узла Р для многосетевого компьютера УЗЕЛ_Б с IP-адресами 10.0.0.2 и10.0.0.3, расположенного в подсети ПОДСЕТЬ_Б.

    add name Name=УЗЕЛ_А IP={10.0.0.1}

    add name УЗЕЛ_Б 20 ПОДСЕТЬ_Б 0 3 1{10.0.0.2,10.0.0.3}

    Добавление партнера репликации в список на указанном WINS-сервере.

    Синтаксис

    add partner [Server=]IP_адрес [[NetBIOS=]имя_NetBIOS_сервера] [[Type=]{0 | 1 | 2}]

    Параметры

    [Server=]IP_адрес
    Обязательный параметр. Указывает партнера репликации для WINS-сервера. Партнер указывается с помощью IP-адреса.
    [NetBIOS=]имя_NetBIOS_сервера
    Указывает партнера репликации для WINS-сервера. Партнер указывается с помощью имени NetBIOS.
    [Type=]{0 | 1 | 2}
    Указывает тип добавляемого партнера: 0 — опрашивающий, 1 — извещающий, 2 — оба типа (по умолчанию).

    Примечания

    • Если IP-адрес не был сопоставлен, для создания записи партнера используется имя NetBIOS. В противном случае имя NetBIOS не используется.

    Примеры

    В следующем примере команда добавляет опрашивающего/извещающего партнера репликации с IP-адресом 10.2.2.2 на текущий WINS-сервер.

    add partner 10.2.2.2

    Добавление списка запрещенных серверов в указанный WINS-сервер.

    Синтаксис

    add pngserver [Servers=]{список-IP-адресов_серверов}

    Параметры

    [Servers=]{список_IP-адресов_серверов}
    Обязательный параметр. Указывает добавляемый запрещенный сервер или серверы посредством IP-адреса (адресов), заключенных в фигурные скобки ({}). В списке IP-адреса должны быть разделены запятыми и заключены в фигурные скобки ({}).

    Примечания

    • Эта команда добавляет новый сервер или серверы после проверки на наличие дубликатов. Список запрещенных серверов серверов (Persona Non Grata, PNG) используется для указания владельцев (других WINS-серверов), записи которых блокируются во время репликации.

    Примеры

    В следующем примере команда добавляет WINS-серверы 10.2.2.2 и 10.2.2.3 в список запрещенных серверов текущего WINS-сервера.

    add pngserver {10.2.2.2,10.2.2.3}

    Добавление сервера WINS в оснастку «WINS».

    Синтаксис

    add server [Server=]{\\имя_сервера | IP_адрес_сервера}

    Параметры

    [Server=]{\\имя_сервера | IP_адрес_сервера}
    Обязательный параметр. Указывает добавляемый WINS-сервер посредством имени NetBIOS IP-адреса.

    Примеры

    В следующем примере в консоль «WINS» добавляется сервер с IP-адресом 172.17.32.28.

    add server Server=172.17.32.28

    Проверяет соответствие базы данных WINS. При использовании без параметров проверка соответствия выполняется всех репликах, где истек интервал проверки. При наличии перегрузки проверка не начинается немедленно, а выполняется по истечении настроенного интервала проверки.

    Синтаксис

    check database [[All=]{1 | 0}] [[Force=]{1 | 0}]

    Параметры

    [All=]{1 | 0}
    Указывает, следует ли выполнять проверку соответствия на всех репликах или только на репликах с истекшим интервалом проверки: 1 — все, 0 — только с истекшим интервалом (по умолчанию).
    [Force=]{1 | 0}
    Указывает, следует ли выполнять поверку соответствия в условиях перегрузки: 1 — выполнять, 0 — не выполнять (по умолчанию).

    Примечания

    • Проверка соответствия всех реплик является ресурсоемкой и загружающей сеть операцией.
    • Если в течение часа проводится повторная проверка соответствия — наступает перегрузка.

    Примеры

    В следующем примере выполняется проверка соответствия для всех реплик. Если имеет место перегрузка, проверка выполняется после истечения настроенного интервала проверки.

    check database 1

    Проверка списка записей имен на соответствие указанному набору WINS-серверов.

    Синтаксис

  • check name {NameFile=имя_файла | NameList={список_имен}} {ServerFile=имя_файла | ServerList={список_IP_адресов_серверов}}[InclPartner={Y | y}]

    Параметры

    {NameFile=имя_файла | NameList={список_имен}}
    Обязательный параметр. Указывает файл, содержащий список имен для проверки или указывает непосредственно список имен. При вводе списка имена должны быть разделены запятыми и заключены в фигурные скобки ({}).
    {ServerFile=имя_файла | ServerList={список_IP_адресов_сервера}}
    Обязательный параметр. Указывает файл со списком IP-адресов серверов или непосредственно список адресов для проверки. В списке IP-адреса должны быть разделены запятыми и заключены в фигурные скобки ({}).
    InclPartner={Y | y}
    Указывает, что в список серверов будут включены все партнеры. По умолчанию партнеры не включаются.

    Примечания

    • Для этой команды необходимы теги. При обнаружении несогласованности выполняется восстановление.
    • Для имени в параметрах имя_файла и имя_списка используется формат имя*16й_знак, где имя — это имя записи, а «16й_знак» — шестнадцатый знак в записи.
    • В файле имена разделяются запятыми или парой возврат каретки /перевод строки.

    Примеры

    В первом примере данные WINS проверяются на соответствие файлам «Names.txt» и «Servers.txt», расположенным по указанному пути (в корневом каталоге диска D).

    В втором примере на соответствие серверам с IP-адресами 10.2.2.2 и 10.2.2.3 проверяются имена «Имя1» с кодом шестнадцатого знака 03, 00 и 20h соответственно.

    check name NameFile=D:\Names.txt ServerFile=D:\Servers.txt

    check name NameList={Имя1*03,Имя1*00,Имя1*20} ServerList={10.2.2.2,10.2.2.3}

    Проверка соответствия кодов версий для владельцев записей WINS в базе данных WINS.

    Синтаксис

    check version [Server=]IP_адрес [[File=]имя_файла]

    Параметры

    [Server=]IP_адрес
    Обязательный параметр. Задает IP-адрес WINS-сервера.
    [File=]имя_файла
    Указывает файл, содержащий индекс таблицы IP-адресов. если параметр на задан, командой check version в текущей папке будет создан файл «Wins.rec», содержащий индекс таблицы IP-адресов.

    Примечания

    • При указании неверного имени_файла в текущей папке создается файл «Wins.rec».
    • Для правильного просмотра таблицы может потребоваться увеличить ширину окна команды.

    Примеры

    В следующем примере проверяется соответствие номера версии записей WINS-сервера с IP-адресом 10.2.2.2 и его партнеров репликации.

    check version 10.2.2.2

    Удаляет зарегистрированное имя из базы данных WINS-сервера.

    Синтаксис

    delete name [Name=]зарегистрированное_имя [EndChar=]16-й_знак_в_шестнадцатеричной_форме [[Scope=]имя_области]

    Параметры

    [Name=]зарегистрированное_имя
    Обязательный параметр. Указывает имя удаляемой записи.
    [EndChar=]16-й_знак_в_шестнадцатеричной_форме
    Обязательный параметр. Указывает шестнадцатый знак имени удаляемой записи в шестнадцатеричной форме.
    [Scope=]имя_области
    Указывает идентификатор области NetBIOS для удаляемой записи.

    Примеры

    В следующем примере из базы данных WINS удаляются записи службы сообщений (03h) с именем УЗЕЛ_А.

    delete name Name=УЗЕЛ_А EndChar=03

    Удаление или захоронение списка владельцев и их записей из базы данных указанного WINS-сервера.

    Синтаксис

    delete owners [Servers=]{список_IP_адресов_серверов} [[Op=]{0 | 1}]

    Параметры

    [Servers=]{список_IP-адресов_серверов}
    Обязательный параметр. Указывает список удаляемых серверов-владельцев записей. В списке IP-адреса должны быть разделены запятыми и заключены в фигурные скобки ({}).
    [Op=]{0 | 1}
    Действие команды: 0 — захоронение (по умолчанию), 1 — удаление.

    Примеры

    В следующем примере удаляются все записи, владельцем которых является WINS-сервер с IP-адресом 10.0.0.1.

    delete owners Servers={10.0.0.1} Op=1

    Удаление либо всех, либо указанных партнеров репликации из списка партнеров указанного WINS-сервера. При запуске команды без параметров без подтверждения удаляются все партнеры репликации как из списка опрашивающих, так и из списка извещающих партнеров.

    Синтаксис

    delete partner [[Server=]IP-адрес] [[Type=]{0 | 1 | 2}] [[Confirm=]{Y|y}]

    Параметры

    [Server=]IP_адрес
    Указывает удаляемого партнера. Партнер задается IP-адресом.
    [Type=]{0 | 1 | 2}
    Указывает тип списка удаляемого партнера: 0 — опрашивающий, 1 — извещающий, 2 — оба типа (по умолчанию).
    [Confirm=]{Y|y}
    Задает выполнение всех операций без запроса подтверждения.

    Примеры

    В следующем примере команда удаляет опрашивающего/извещающего партнера репликации с IP-адресом 10.00.00.1 в текущем WINS-сервер без запроса подтверждения.

    delete partner Server=10.0.0.1 Type=2 Confirm=Y

    Удаление всех или указанных запрещенных серверов из соответствующего списка указанного WINS-сервера.

    Синтаксис

    delete pngserver [Servers=]{список-IP-адресов_серверов}

    Параметры

    [Servers=]{список_IP-адресов_серверов}
    Обязательный параметр. Указывает список запрещенных серверов для удаления. Запрещенные серверы указываются посредством IP-адресов, которые должны быть разделены запятыми и заключены в фигурные скобки ({}).

    Примечания

    • Список запрещенных серверов серверов (Persona Non Grata, PNG) определяет владельцев (других WINS-серверов), записи которых блокируются во время репликации. При использовании пустых фигурных скобок({}) команда delete pngserver удаляет все серверы в списке запрещенных.

    Примеры

    В следующем примере команда удаляет WINS-серверы 10.2.2.2 и 10.2.2.3 из списка запрещенных серверов текущего WINS-сервера.

    delete pngserver Servers={10.2.2.2,10.2.2.3}

    Удаление всех записей или набора записей на текущем WINS-сервере или пометка записей как захороненных.

    Синтаксис

  • delete records [MinVer=]{минимальная_высшая_версия,минимальная__низшая_версия} [MaxVer=]{максимальная_высшая_версия,максимальная_низшая_версия} [[Op=]{0 | 1}]

    Параметры

    [MinVer=]{минимальная_высшая_версия,минимальная__низшая_версия}
    Обязательный параметр. Указывает минимальную высшую и минимальную низшую версии записей, с которых начинается удаление. Высшее и низшее значения должны быть разделены запятыми и заключены в фигурные скобки ({}).
    [MaxVer=]{максимальная_высшая_версия,максимальная__низшая_версия}
    Обязательный параметр. Указывает максимальную высшую и максимальную низшую версии записей, на которых удаление заканчивается. Высшее и низшее значения должны быть разделены запятыми и заключены в фигурные скобки ({}).
    [Op=]{0 | 1}
    Действие команды: 0 — удаление (по умолчанию), 1 — захоронение.

    Примечания

    • При задании для параметров MinVer= и MaxVer= значения {0,0} команда delete records удаляет все записи.

    Примеры

    В первом примере все записи WINS-сервера помечаются как захороненные.

    Во втором примере удаляются все записи между 2de2d и 2de3f включительно.

    delete records MinVer={0,0} MaxVer={0,0} Op=1

    delete records MinVer={0,2de2d} MaxVer={0,2de3f}

    Удаление сервера WINS из консоли WINS.

    Синтаксис

    delete server [Server=]{\\имя_сервера | IP_адрес_сервера}

    Параметры

    [Server=]{\\имя_сервера | IP_адрес_сервера}
    Обязательный параметр. Указывает удаляемый WINS-сервер. Сервер задается сервера именем NetBIOS или IP-адресом.

    Примеры

    В следующем примере из консоли «WINS» удаляется сервер с IP-адресом 172.310.255.254.

    delete server Server=172.31.255.254

    Запускает архивацию базы данных WINS в указанную папку. При запуске без параметров выполняется полная архивация в папку, заданную в настоящий момент по умолчанию.

    Синтаксис

    init backup [[Dir=]папка_для_архивации] [[Type=]{0 | 1}]

    Параметры

    [Dir=]папка_для архивации
    Указывает папку, в которую выполняется архивация. Если параметр не указан, используется папка для архивации, заданная по умолчанию.
    [Type=]{0 | 1}
    Указание типа архивации: 0 — полная (по умолчанию), 1 — добавочная.

    Примечания

    • Архивация WINS может применяться только для локальной архивации локального сервера. Архивация удаленных WINS-серверов не поддерживается.
    • В подпапке «wins_bak» папки, заданной параметром Dir=, автоматически создаются файлы архива.

    Примеры

    В следующем примере выполняется полная архивация базы данных WINS локального сервера в папку «C:\WINSfiles\wins_bak». Будет создана подпапка «wins_bak».

    init backup Dir=C:\WINSfiles Type=0

    Сжатие базы данных WINS-сервера.

    Синтаксис

    init compact

    Параметры

    отсутствуют

    Экспорт базы данных WINS-сервера в файл.

    Синтаксис

    init export

    Параметры

    отсутствуют

    Запускает импорт статических соответствий из файла Lmhosts.

    Синтаксис

    init import [File=]импортируемый_файл

    Параметры

    [File=]импортируемый_файл
    Обязательный параметр. Указание текстового файла формата Lmhosts, из которого необходимо импортировать статические соответствия в базу данных WINS.

    Примеры

    В следующем примере новые статические соответствия импортируются в локальную базу WINS из файла Fixedip.sam, расположенного в папке C:\WINSfiles.

    init import File=C:\WINSfiles\Fixedip.sam

    Инициирует и отправляет опрашивающий триггер другому серверу WINS.

    Синтаксис

    init pull [Server=]{имя_опрашивающего сервера | IP-адрес}

    Параметры

    [Server] {\\имя_сервера | IP-адрес}
    Обязательный параметр. Указывает WINS-сервер, на который отправляется опрашивающий триггер. Сервер задается именем или IP-адресом.

    Примечания

    • Если задано имя сервера, которое не удается разрешить в IP-адрес, операция не выполняется

    Примеры

    В следующем примере команда инициирует и отправляет опрашивающий триггер на WINS-сервер 10.20.20.2.

    init pull Server=10.2.2.2

    Запускает опрос диапазона записей другого сервера WINS.

    Синтаксис

  • init pullrange [Owner=]IP_адрес_владельца [Server=]IP-адрес_опрашивающего сервера [MaxVer=]{максимальная_высшая_версия,максимальная_низшая_версия} [MinVer=]{минимальная_высшая_версия,минимальная__низшая_версия}

    Параметры

    [Owner=]IP_адрес_владельца
    Обязательный параметр. Указывает WINS-сервер опрашиваемых записей. Сервер задается IP-адресом.
    [Server=]IP-адрес_опрашивающего сервера
    Обязательный параметр. Указывает WINS-сервер, опрашивающий диапазон записей. Сервер задается IP-адресом.
    [MaxVer=]{максимальная_высшая_версия,максимальная__низшая_версия}
    Обязательный параметр. Указывает максимальную высшую и максимальную низшую версии опрашиваемых записей. Высшее и низшее значения должны быть разделены запятыми и заключены в фигурные скобки ({}).
    [MinVer=]{минимальная_высшая_версия,минимальная__низшая_версия}
    Обязательный параметр. Указывает минимальную высшую и минимальную низшую версии опрашиваемых записей. Высшее и низшее значения должны быть разделены запятыми и заключены в фигурные скобки ({}).

    Примечания

    • При задании для параметров MinVer= и MaxVer= значения {0,0} команда init pullrange опрашивает весь диапазон записей.

    Примеры

    В следующем примере команда инициирует и отправляет опрашивающий триггер на WINS-сервер 10.2.2.3 для всех записей, владельцем которых является WINS-сервер 10.2.2.2.

    init pullrange Owner=10.2.2.2 Server=10.2.2.3 MaxVer={0,0} MinVer={0,0}

    Инициирует и отправляет извещающий триггер другому серверу WINS.

    Синтаксис

    init push [Server=]{\\имя_извещающего сервера | IP-адрес} [[PropReq=]{0 | 1}]

    Параметры

    [Server] {\\имя_извещающего_сервера | IP-адрес}
    Обязательный параметр. Указывает WINS-сервер, на который отправляется извещающий триггер. Сервер задается IP-адресом.
    [PropReq=]{0 | 1}
    Определяет расширенный запрос: 0 — известить только указанный сервер (по умолчанию), 1 — сервер распространяет извещающий триггер всем своим партнерам.

    Примечания

    • Если задано имя сервера, которое не удается разрешить в IP-адрес, операция не выполняется.

    Примеры

    В следующем примере команда инициирует и отправляет извещающий триггер на WINS-сервер 10.2.2.2, а этот сервер распространяет триггер всем своим партнерам репликации.

    init push Server=10.2.2.2 PropReq=1

    Запускает немедленную репликацию базы данных WINS партнерам репликации.

    Синтаксис

    init replicate

    Параметры

    отсутствуют

    Примечания

    • Команда вызывает опрашивающую/извещающую репликацию всем партнерам для данного сервера.

    Вызывает восстановление базы данных WINS из указанной папки и файла на указанный WINS-сервер.

    Синтаксис

    init restore [Dir=]папка_для_восстановления

    Параметры

    [Dir=]папка_для восстановления
    Обязательный параметр. Указывает папку, из которой восстанавливаются файлы.

    Примечания

    • Архив базы WINS может быть восстановлен только для локально и для локального сервера. Восстановление базы данных WINS с удаленного компьютера невозможно.
    • Папка, заданная параметром Dir=, должна содержать подпапку wins_bak, в которой находится файл базы данных, однако эту подпапку не следует указывать в значении параметра Dir=.

    Примеры

    В следующем примере выполняется восстановление базы WINS их резервной базы данных, расположенной в папке C:\WINSfiles.

    init restore Dir=C:\WINSfiles

    Выполняет очистку базы данных WINS указанного сервера.

    Синтаксис

    init scavenge

    Параметры

    отсутствуют

    Примечания

    • С помощью данной команды из базы данных WINS удаляются устаревшие данные.

    Поиск в базе данных WINS указанного имени записи.

    Синтаксис

    init search [Name=]имя_записи [[EndChar=]последний_знак] [[Case=]{0 | 1}] [[File=]имя_файла]

    Параметры

    [Name=]имя_записи
    Обязательный параметр. Указание имени записи, которую необходимо найти.
    [EndChar=]последний_знак
    Указание шестнадцатого знака записи имени NetBIOS. Если не параметр не задан, возвращаются все записи, содержащие строку, указанную для параметра Name=. Дополнительные сведения см. в разделе «Заметки».
    [Case=]{0 | 1}
    Переключатель режима учета регистра знаков для имени: 0 — регистр знаков не учитывается (по умолчанию), 1 — регистр учитывается.
    [File=]имя_файла
    Указывает файл, в который будут выведены результаты в текстовом формате ASCII. Если параметр не задан, результаты отображаются в окне командной строки.

    Примечания

    • Если не параметр EndChar= не задан, возвращаются все записи, содержащие строку, указанную для параметра Name=. Например, если база данных содержит запись с именем MYPC-1, при поиске с указанием значения параметра имени «MYPC» будут найдены все записи, начинающиеся с этих знаков, независимо от типа записи:

      • Имя записи | Тип записи
      MYPC-1 | [00h]Workstation
      MYPC-1 | [01h]Other
      MYPC-1 | [03h]Messenger

      Если задать значение параметра EndChar=, будут найдены значения, соответствующие заданному имени и типу. Например, если для параметра Name= задать значение «MYPC», а для параметра «EndChar» — «00», будут найдены следующие записи:

      Имя записи | Тип записи
      MYPC-1 | [00h]Workstation

    Примеры

    В следующем примере выполняется поиск записей с именем «dc1» и кодом последнего знака «1c», без учета регистра знаков, с выводом результатов в файл names.txt, расположенный в папке C:\WINSfiles.

    init search Name=dc1 EndChar=1c Case=0 File=C:\WINSfiles \names.txt

    Сброс статистики локального WINS-сервера.

    Синтаксис

    reset counter

    Параметры

    отсутствуют

    Установка сведений автоматической конфигурации партнеров репликации для сервера. При запуске без параметров автоматическая конфигурация партнеров сбрасывается (отключается).

    Синтаксис

    set autopartnerconfig [[State=]{0 | 1}] [[Interval=]значение] [[TTL=]значение]

    Параметры

    [State=]{0 | 1}
    Указывает параметр сведений автоматической настройки партнеров репликации: 0 — сбросить (по умолчанию), 1 — установить.
    [Interval=]значение.
    Указывает значение интервала вещания в секундах.
    [TTL=]значение
    Задает срок жизни (TTL) многоадресных датаграмм серверов-партнеров. Значение срока жизни должно лежать в пределах от 1 до 32.

    Примеры

    В следующем примере устанавливаются сведения автоматической конфигурации для данного WINS-сервера с интервалом вещания 3600 секунд сроком жизни датаграмм 20.

    set autopartnerconfig State=0 Interval=3600 TTL=20

    Установка параметров архивации для указанного WINS-сервера.

    Синтаксис

    set backuppath [Dir=]новый_путь [[Shutdown=]{0 | 1}]

    Параметры

    [Dir=]новый_путь
    Обязательный параметр. Задает путь архивации для базы данных сервера. Если путь не задан, по умолчанию используется путь C:\.
    [Shutdown=]{0 | 1}
    Задает параметр выполнения архивации при завершении работы: 0 — архивация базы данных WINS при завершении работы отключена (по умолчанию), 1 — архивация базы данных WINS при завершении работы включена.

    Примеры

    В следующем примере для WINS-сервера задается автоматическая архивация базы данных в папку C:\WINSfiles при каждом завершении работы.

    set backuppath Dir=C:\WINSfiles Shutdown=1

    Установка параметров пакетного режима для указанного WINS-сервера.

    Синтаксис

    set burstparam [State=]{0 | 1} [[Value=]размер_очереди]

    Параметры

    [State=]{0 | 1}
    Обязательный параметр. Параметр пакетного режима: 0- сброс или отключение пакетного режима для WINS-сервера, 1- установка (включение) пакетного режима.
    [Value=]размер_очереди
    Указывает размер очереди пакетов. Это значение должно лежать в диапазоне от 50 до 5 000.

    Примеры

    В следующем примере задается размер очереди пакетов для разрешения 1000 регистраций клиентов и запросов обновлений до использования WINS-сервером пакетной обработки.

    set burstparam State=1 Value=1000

    Устанавливает для параметров конфигурации WINS-сервера значения по умолчанию.

    Синтаксис

    set defaultparam

    Параметры

    отсутствуют

    Примечания

    • Данная команда устанавливает значения по умолчанию для всех параметров конфигурации WINS-сервера. Рекомендуется запускать эту команду после установки службы WINS для параметров сервера в соответствии со значениями по умолчанию.

    Установка или сброс параметров ведения журнала базы данных и журнала событий. При запуске без параметров используются текущие значения.

    Синтаксис

    set logparam [[DBChange=]{0 | 1}] [[Event=]{0 | 1}]

    Параметры

    [DBChange=]{0 | 1}
    Указывает, следует ли вести журнал изменений базы данных: 1 — включение записи изменений базы данных в файлы журнала JET (по умолчанию), 0 — сброс данного параметра.
    [Event=]{0 | 1}
    Указывает, следует ли вести подробный журнал событий: 1 — запись подробного журнала событий в журнал системных событий, 0 — сброс данного параметра (по умолчанию).

    Примечания

    • Изменения базы данных WINS могут записываться в отдельные файлы. Поскольку данный параметр повышает производительность операций с базой данных, по умолчанию о включен.
    • WINS-сервер может сохранять подробные сведения событий в журнал системных событий. Поскольку эта функция требует интенсивного использования ресурсов, по умолчанию она отключена.

    Примеры

    В следующем примере для WINS-сервера включается запись изменений базы данных в файлы JET и запись подробных сведений о событиях в журнал системных событий.

    set logparam Event=1

    Устанавливает флаг миграции для указанного WINS-сервера.

    Синтаксис

    set migrateflag [State=]{0 | 1}

    Параметры

    [State=]{0 | 1}
    Обязательный параметр. Указывает состояние флага миграции: 0 — отключен (миграция выключена), 1 — включен (миграция включена)

    Примечания

    • Флаг миграции определяет, могут ли уникальные статические соответствия быть заменены динамическими записями.

    Примеры

    В следующем примере для указанного WINS-сервера задан влаг миграции с тем, чтобы разрешить замену статических соответствий динамическими записями.

    set migrateflag State=1

    Указание интервалов, используемых для определения момента обновления, удаления и проверки записей имен WINS на указанном WINS-сервере. При запуске без параметров используются текущие значения.

    Синтаксис

    set namerecord [[Renew=]значение] [[Extinction=]значение] [[ExTimeout=]значение] [[Verification=]значение]

    Параметры

    [Renew=]значение
    Указывает значение частоты обновления в секундах.
    [Extinction=]значение
    Указывает значение интервала удаления в секундах.
    [ExTimeout=]значение
    Указывает значение таймаута устаревания удаления в секундах.
    [Verification=]значение
    Указывает значение интервала проверки в секундах.

    Примечания

    • Все параметры не являются обязательными. При запуске без параметров используются предыдущие значения.

    Примеры

    В следующем примере для данного WINS-сервера задается каждое из значений.

    set namerecord Renew=3600 Extinction=7200 ExTimeout=86400 Verification=2073600

    Устанавливает параметры периодической проверки соответствия для указанного WINS-сервера. При запуске без параметров используются текущие значения.

    Синтаксис

  • set periodicdbchecking [[State=]{0 | 1}] [[MaxRec=]значение] [[CheckAgainst=]{0 | 1}] [[CheckEvery=]значение] [[Start=]значение]

    Параметры

    [State=]{0 | 1}
    Обязательный параметр. Указывает необходимость проверки состояния базы данных WINS: 0 — отключена, 1 — включена (по умолчанию). Если для данного параметра установить значение 0, все проверки будут отключены независимо от значений других параметров.
    [MaxRec=]значение
    Указывает максимальное число записей, проверяемых за каждый период. Если значение не указано, по умолчанию используется 30 000.
    [CheckAgainst=]{0 | 1}
    Указывает сервер, с которым сравниваются записи: 0- сервер-владелец (по умолчанию), 1 — произвольно выбранный сервер.
    [CheckEvery=]значение
    Указывает, как часто необходимо выполнять проверку соответствия базы данных WINS, в часах. Если значение не указано, по умолчанию используется значение 24.
    [Start=]значение
    Указывает время в секундах, по истечении которого начинается проверка соответствия.

    Примечания

    • Для задания интервалов периодической проверки соответствия рекомендуется указать значения параметров CheckEvery и Start. Для согласования с уже с использующимися параметрами периодической проверки соответствия укажите только значения параметра State и параметра (параметров), которые необходимо изменить. Параметры, для которых не были указаны значения, остаются неизменными.

    Примеры

    В следующем примере база данных WINS проверяется на соответствие произвольно выбранному партнеру репликации каждый час, начиная по истечении 3600 секунд.

    set periodicdbchecking State=1 MaxRec=1000 CheckAgainst=1 CheckEvery=1 Start=3600

    Устанавливает параметры по умолчанию опрашивающего партнера репликации для указанного WINS-сервера. При запуске без параметров используется предыдущий набор значений или параметры по умолчанию.

    Синтаксис

    set pullparam [[State=]{0 | 1}] [[Strtup=]{0 | 1}] [[Start=]значение] [[Interval=]значение] [[Retry=]значение]

    Параметры

    [State=]{0 | 1}
    Обязательный параметр. Указывает, следует ли использовать постоянные подключения к опрашивающим партнерам: 0 — не использовать постоянные подключения к опрашивающим партнерам, 1 — использовать постоянные подключения к опрашивающим партнерам.
    [Strtup=]{0 | 1}
    Указывает, должна ли начинаться опрашивающая репликация при запуске: 0 — не начинать опрашивающую репликацию при запуске (по умолчанию), 1 — начинать опрашивающую репликацию при запуске.
    [Start=]значение
    Указывает время начала для опрашивающего триггера в секундах.
    [Interval=]значение.
    Указывает интервал репликации в секундах.
    [Retry=]значение
    Указывает количество повторов репликации.

    Примечания

    • Если не указывать значение параметраInterval=, выполняется только одна репликация.
    • Если не указано значение параметра Start= опрашивающий триггер инициируется при запуске команды.

    Примеры

    В следующем примере для WINS-сервера задаются следующие параметры по умолчанию опрашивающего партнера репликации: начинать репликацию при запуске, инициировать опрашивающий триггер в 23600 секунд с интервалом 259200 секунд, повторить репликацию семь раз.

    set pullparam State=1 Strtup=1 Start=23600 Interval=259200 Retry=7

    Устанавливает параметры конфигурации для указанного запрашивающего партнера репликации.

    Синтаксис

    set pullpartnerconfig [[State=]{0 | 1}] [Server=]имя_сервера [[Start=]значение] [[Interval=]значение]

    Параметры

    [State=]{0 | 1}
    Указывает состояние флага постоянного подключения: 0 — отключен , 1 — включен (по умолчанию).
    [Server=]имя_сервера
    Обязательный параметр. Указывает запрашивающего партнера репликации при помощи имени сервера или IP-адреса.
    [Start=]значение
    Указывает время начала репликации в секундах.
    [Interval=]значение.
    Указывает интервал между опрашивающими репликациями в секундах.

    Примечания

    • Если в параметре Server= задано имя сервера, которое не удается разрешить в IP-адрес, операция не выполняется.

    Примеры

    В следующем примере для текущего WINS-сервера задается конфигурация опрашивающего партнера для WINS-сервера-партнера 10.2.2.2. Опрашивающая репликация начинается в 3600 секунд и запускается каждые 4320 секунд.

    set pullpartnerconfig State=1 Server=10.2.2.2 Start=3600 Interval=4320

    Устанавливает параметры по умолчанию извещающего партнера репликации для указанного WINS-сервера.

    Синтаксис

    set pushparam [State=]{0 | 1} [[Strtup=]{0 | 1}] [[AddChange=]{0 | 1}] [[Update=]значение]

    Параметры

    [State=]{0 | 1}
    Обязательный параметр. Указывает, следует ли использовать постоянные подключения к извещающим партнерам: 0 — не использовать постоянные подключения к извещающим партнерам, 1 — использовать постоянные подключения к извещающим партнерам.
    [Strtup=]{0 | 1}
    Указывает, должна ли начинаться извещающая репликация при запуске: 0 — не начинать извещающую репликацию при запуске (по умолчанию), 1 — начинать извещающую репликацию при запуске.
    [AddChange=]{0 | 1}
    Указывает, должна ли при изменении адреса инициироваться репликация: 0 — не инициировать репликацию при изменении адреса (по умолчанию), 1 — инициировать репликацию при изменении адреса.
    [Update=]Значение
    Указывает количество изменений кода версии, вызывающее репликацию.

    Примеры

    В следующем примере для данного WINS-сервера задаются следующие параметры по умолчанию извещающего партнера репликации: использовать постоянные подключения к извещающим партнерам, начинать извещающую репликацию при запуске и при изменении адреса, начинать извещающую репликацию партнерам после двух изменений кода версии записей, владельцем которых является данный WINS-сервер.

    set pushparam State=1 Strtup=1 AddChange=1 Update=2

    Устанавливает параметры конфигурации для указанного партнера извещающей репликации.

    Синтаксис

    set pushpartnerconfig [[State=]{0 | 1}] [Server=]\\имя_сервера [Update=]значение

    Параметры

    [State=]{0 | 1}
    Указывает состояние флага постоянного подключения: 0 — отключен , 1 — включен (по умолчанию).
    [Server=]{\\имя_сервера
    Обязательный параметр. Указывает имя извещающего партнера, для которого необходимо задать параметры конфигурации. Сервер задается именем или IP-адресом.
    [Update=]значение
    Обязательный параметр. Указывает порог для обновлений.

    Примечания

    • Если задано имя сервера, которое не удается разрешить в IP-адрес, операция не выполняется.

    Примеры

    В следующем примере для текущего WINS-сервера задается конфигурация извещающего партнера с IP-адресом 10.2.2.2 и устанавливается порог изменений кода версии, при превышении которого необходимо извещение, равный 2.

    set pushpartnerconfig State=1 Server=10.2.2.2 Update=2

    Устанавливает флаг репликации для указанного WINS-сервера.

    Синтаксис

    set replicateflag [State=]{0 | 1}

    Параметры

    [State=]{0 | 1}
    Обязательный параметр. Указывает состояние флага репликации: 0 — отключена (флаг репликации снят), 1 — включена (флаг репликации установлен).

    Примеры

    В следующем примере флаг репликации устанавливается для данного сервера.

    set replicateflag State=1

    Установка значения начального кода версии для базы данных.

    Синтаксис

    set startversion [Version=]{максимальное_значение,минимальное_значение}

    Параметры

    [Version=]{максимальное_значение,минимальное_значение}
    Обязательный параметр. Указывает начальный номер версии для базы данных WINS. Максимально и минимальное значения должны быть разделены запятыми и заключены в фигурные скобки ({}).

    Примеры

    В следующем примере для базы данных WINS задается начальный код версии 0.

    set startversion Version={0,0}

    Отображает все записи основного обозревателя домена [1Bh] для указанного WINS-сервера.

    Синтаксис

    show browser

    Параметры

    отсутствуют

    Отображение базы данных и записей для частичного или полного списка указанных серверов-владельцев.

    Синтаксис

  • show database [Servers=]{IP-адрес} [[RecType=]{0 | 1 | 2}] [[Count=]счетчик] [[Start=]{0 | 1}] [[EndChar=]16-й_знак_в_шестнадцатеричной_форме] [[File=]имя_файла]

    Параметры

    [Servers=]{IP-адрес}
    Обязательный параметр. Указывает список серверов-владельцев записей, чьи записи необходимо отобразить. Серверу-владельцы задаются с помощью IP-адресов, которые должны быть разделены запятыми и заключены в фигурные скобки ({}).
    [RecType=]{0 | 1 | 2}
    Указание типа записи: 0 — оба типа (по умолчанию), 1 — статические, 2 — динамические.
    [Count=]счетчик
    Указывает количество записей, которые необходимо отобразить. Если параметр не указан, выводятся все записи, соответствующие условиям запроса.
    [Start=]{0 | 1}
    Указывает способ сортировки результатов: 0 — сортировать с начала базы данных (по умолчанию), 1 — сортировать с конца.
    [EndChar=]16-й_знак_в_шестнадцатеричной_форме
    Указание шестнадцатого знака записей в шестнадцатеричной форме. Это значение используется для фильтрации записей, извлекаемых из базы данных. Если параметр не указан, возвращаются все типы записей.
    [File=]имя_файла
    Указывает файл, в котором сохраняются результаты. Если параметр не задан, результаты отображаются в окне командной строки.

    Примечания

    • Если в паарметре Servers= указать пустой набор ({}), команда show database отобразить записи для всех серверов-владельцев.

    Примеры

    В следующем примере в текстовый файл output.txt выводится первые 1000 динамических записей базы данных сервера 10.2.2.2.

    show database Servers={10.2.2.2} RecType=2 Count=1000 Start=0 Endchar=0 File=C:\WINSfiles\output.txt

    Отображение сведений конфигурации указанного WINS-сервера.

    Синтаксис

    show info

    Параметры

    отсутствуют

    Примечания

    • Данная команда отображает для текущего сервера следующие сведения конфигурации:
      • Путь к архиву
      • Параметр записей имен
      • Периодичность проверки соответствия базы данных
      • Пакетный режим
      • Параметры записи журнала
      • Счетчик начальной версии

    Запрос и отображение подробных сведений для указанной записи базы данных текущего WINS-сервера.

    Синтаксис

    show name [Name=]имя_записи [EndChar=]16-й_знак_в_шестнадцатеричной_форме [[Scope=]имя_области]

    Параметры

    [Name=]имя_записи
    Обязательный параметр. Указывает запрашиваемую запись.
    [EndChar=]16-й_знак_в_шестнадцатеричной_форме
    Необходим для всех запросов кроме записей уникальных типов. Указание шестнадцатого знака в шестнадцатеричной форме.
    [Scope=]имя_области
    Указывает область NetBIOS, если используется.

    Примеры

    В следующем примере отображаются текущие сведения о записи с именем УЗЕЛ_А, имеющей тип файлового сервера [20h], расположенной в базе данных указанного WINS-сервера.

    show name Name=УЗЕЛ_А EndChar=20

    Отображение всех опрашивающих и извещающих партнеров, либо партнеров указанного WINS-сервера. При запуске без параметров отображаются все опрашивающие и извещающие партнеры, а также опрашивающие/извещающие партнеры указанного WINS-сервера.

    Синтаксис

    show partner [[Type=]{0 | 1 | 2 | 3}]

    Параметры

    [Type=]{0 | 1 | 2 | 3}
    Указывает тип отображаемых партнеров: 0 — все (по умолчанию), 1 — опрашивающие, 2 — извещающие, 3 — опрашивающие и извещающие.

    Примеры

    В следующем примере отображается имя сервера, IP-адрес и тип репликации каждого партнера репликации для данного WINS-сервера.

    show partner

    Отображение сведений конфигурации партнера по умолчанию для указанного WINS-сервера.

    Синтаксис

    show partnerproperties

    Параметры

    отсутствуют

    Примечания

    • Данная команда отображает параметры автоматической конфигурации партнеров и параметры по умолчанию опроса/извещения для текущего WINS-сервера.

    Отображение сведений конфигурации для опрашивающего партнера.

    Синтаксис

    show pullpartnerconfig [Server=]{имя | IP-адрес}

    Параметры

    [Server=]{имя | IP-адрес}
    Обязательный параметр. Указывает опрашивающего партнера, для которого необходимо вывести сведения конфигурации. Партнер задается с помощью имени или IP-адреса.

    Примечания

    • Если задано имя сервера, которое не удается разрешить в IP-адрес, операция не выполняется.

    Примеры

    В следующем примере отображаются сведения конфигурации опрашивающего партнера WINS-сервера 10.20.20.2.

    show pullpartnerconfig Server=10.2.2.2

    Отображает сведения конфигурации для извещающего партнера.

    Синтаксис

    show pushpartnerconfig [Server=]{имя | IP-адрес}

    Параметры

    [Server=]{имя | IP-адрес}
    Обязательный параметр. Указывает извещающего партнера, для которого необходимо вывести сведения конфигурации. Партнер задается с помощью имени или IP-адреса.

    Примечания

    • Если задано имя сервера, которое не удается разрешить в IP-адрес, операция не выполняется.

    Примеры

    В следующем примере отображаются сведения конфигурации извещающего партнера WINS-сервера 10.2.2.2.

    show pushpartnerconfig Server= 10.2.2.2

    Отображение для владельца набора записей, заданных диапазоном кодов версий, и сортировка записей по версиям.

    Синтаксис

    show recbyversion [Server=]IP-адрес [MaxVer=]{максимальное_значение,минимальное значение} [MinVer=]{максимальное_значение,минимальное значение} [[Name=]имя_записи] [[EndChar=]16-й_знак_в_шестнадцатеричной_форме] [Case=]{0 | 1}

    Параметры

    [Server=]IP_адрес
    Обязательный параметр. Указывает сервер-владельца, для которого необходимо отобразить набор записей. Сервер задается IP-адресом.
    [MaxVer=]{максимальное значение,минимальное значение}
    Обязательный параметр. Указывает максимальную высшую и максимальную низшую версии записей диапазона. Высшее и низшее значения должны быть разделены запятыми и заключены в фигурные скобки ({}).
    [MinVer=]{максимальное_значение,минимальное_значение}
    Обязательный параметр. Указывает минимальную высшую и минимальную низшую версии записей диапазона. Высшее и низшее значения должны быть разделены запятыми и заключены в фигурные скобки ({}).
    [Name=]имя_записи
    Указывает запрашиваемые записи.
    [EndChar=]16-й_знак
    Указание искомого знака в шестнадцатеричной форме.
    [Case=]{0 | 1}
    Указывает, следует ли при сравнении учитывать регистр: 0 — не учитывать регистр (по умолчанию), 1 — учитывать регистр.

    Примечания

    • Если для параметра Name= значение не указано, значения параметров EndChar= и Case= игнорируются.
    • При задании для параметров MinVer= и MaxVer= значения {0,0} команда show recbyversion отображает весь диапазон записей.

    Примеры

    В следующем примере отображается общее количество записей (по версии записи) , владельцем которых является WINS-сервер 10.2.2.2.

    show recbyversion Server=10.2.2.2 MaxVer={0,0} MinVer={0,0}Name=dc1 EndChar=1c Case=0

    Отображает число записей, владельцем которых является указанный WINS-сервер.

    Синтаксис

  • show reccount [Server=]IP_адрес [MaxVer=]{максимальная_высшая_версия,максимальная_низшая_версия} [MinVer=]{минимальная_высшая_версия,минимальная__низшая_версия}

    Параметры

    [Server=]IP_адрес
    Обязательный параметр. Указывает сервер-владельца, для которого необходимо отобразить количество записей. Сервер задается IP-адресом.
    [MaxVer=]{максимальная_высшая_версия,максимальная_низшая_версия}
    Обязательный параметр. Указывает максимальную высшую и максимальную низшую версии отображаемых записей. Высшее и низшее значения должны быть разделены запятыми и заключены в фигурные скобки ({}).
    [MinVer=]{минимальная__высшая_версия,минимальная__низшая_версия}
    Обязательный параметр. Указывает минимальную высшую и минимальную низшую версии отображаемых записей. Высшее и низшее значения должны быть разделены запятыми и заключены в фигурные скобки ({}).

    Примечания

    • При задании для параметров MinVer= и MaxVer= значения {0,0} команда show reccount подсчитывает весь диапазон записей.

    Примеры

    В следующем примере отображается общее количество записей WINS-сервера 10.2.2.2.

    show reccount Server=10.2.2.2 MaxVer={0,0} MinVer={0,0}

    Отображение сведений об указанном WINS-сервере.

    Синтаксис

    show server

    Параметры

    отсутствуют

    Примечания

    • Отображение имени и IP-адреса указанного WINS-сервера.

    Отображение статистики указанного WINS-сервера.

    Синтаксис

    show statistics

    Параметры

    отсутствуют

    Отображение текущего максимального значения счетчика версий для указанного сервера WINS.

    Синтаксис

    show version

    Параметры

    отсутствуют

    Отображение кода владельца в таблицу отображений максимального номера версии для указанного сервера WINS.

    Синтаксис

    show versionmap

    Параметры

    отсутствуют


Пример команд Netsh WINS

Команды Netsh для службы WINS могут использоваться в пакетных файлах и других сценариях для автоматизации задач. В следующем примере показано использование команд Netsh для службы WINS при выполнении различных связанных с ней задач.

В этом примере WINS-A — это WINS-сервер с IP-адресом 192.168.125.30, а WINS-B — это WINS-сервер с IP-адресом 192.168.0.189. При выполнении процедуры происходит добавление записи динамического имени с IP-адресом 192.168.0.205, MY_RECORD [04h] на сервер WINS-A, назначение сервера WINS-B извещающим/опрашивающим партнером репликации для сервера WINS-A, подключение к WINS-B и назначение WINS-A извещающим/опрашивающим партнером репликации для сервера WINS-B. Затем инициируется извещающая репликация с WINS-A на WINS-B с последующим подключением к WINS-B для проверки успешной репликации новой записи MY_RECORD.

Полный список команд Netsh для WINS см. в разделе Команды Netsh для протокола WINS.

В следующем примере процедуры строки комментариев начинаются с «rem». Комментарии командой Netsh игнорируются.

rem два WINS-сервер:
rem (WINS-A) 192.168.125.30
rem (WINS-B) 192.168.0.189

rem 1. Подключение к (WINS-A) и добавление динамического имени MY_RECORD [04h] в базу данных (WINS-A).
netsh wins server 192.168.125.30 add name Name=MY_RECORD EndChar=04 IP={192.168.0.205}

rem 2. Подключение к (WINS-A) и назначение (WINS-B) извещающим/опрашивающим партнером репликации (WINS-A).
netsh wins server 192.168.125.30 add partner Server=192.168.0.189 Type=2

rem 3. Подключение к (WINS-B) и назначение (WINS-A) извещающим/опрашивающим партнером репликации (WINS-B).
netsh wins server 192.168.0.189 add partner Server=192.168.125.30 Type=2

rem 4. Подключение к (WINS-A) и инициация извещающией репликации на (WINS-B).
netsh wins server 192.168.125.30 init push Server=192.168.0.189 PropReq=0

rem 5. Подключение к (WINS-B) и проверка успешной репликации записи MY_RECORD [04h].
netsh wins server 192.168.0.189 show name Name=MY_RECORD EndChar=04

rem 6. Конец примера пакетного файла.

В следующей таблице представлен список команд netsh wins, используемых в этом примере процедуры.

Команда | Описание
server | Переход из текущего контекста командной строки WINS на сервер, заданный либо именем, либо IP-адресом.
add name | Регистрирует имя на сервере.
add partner | Добавляет партнера репликации на сервер.
init push | Инициализирует и отправляет извещающий триггер серверу WINS.
show name | Вывод подробных сведений для конкретной записи в базе данных WINS-сервера.


Nslookup

Предоставляет сведения, предназначенные для диагностики инфраструктуры DNS. Для использования этого средства необходимо быть знакомым с принципами работы системы DNS. Средство командной строки Nslookup доступно, только если установлен протокол TCP/IP.

Синтаксис

nslookup [-подкоманда ...] [{искомый_компьютер| [-сервер]}]

Параметры

-подкоманда ...
Задает одну или несколько подкоманд nslookup как параметры командной строки. Список подкоманд см. в разделе «См. также».
искомый_компьютер
Ищет данные для параметра искомый_компьютер, используя текущий, заданный по умолчанию сервер имен DNS, если никакого другого сервера не указано. Чтобы получить сведения о компьютере не из текущего домена DNS, в конец имени должна быть добавлена точка.
-сервер
Указывает, что данный сервер следует использовать в качестве сервера имен DNS. Если параметр -сервер не указан, используется сервер DNS, заданный по умолчанию.
{help|?}
Выводит краткое описание подкоманд nslookup.

Замечания

  • Если искомый_компьютер задан IP-адресом, а запрашивается запись ресурса типа A или PTR, будет выведено имя компьютера. Если искомый_компьютер задан именем без замыкающей точки, имя домена DSN, используемого по умолчанию, будет добавлено к указанному имени. Поведение зависит от состояния следующих подкоманд команды set: domain, srchlist, defname и search.
  • Если в командной строке введен дефис (-) вместо параметра искомый_компьютер, команда nslookup перейдет в интерактивный режим.
  • Длина строки вызова команды не может превышать 256 символов.
  • Команда nslookup может работать в двух режимах: интерактивном и обычном (автономном).

    Если требуется вывод только небольшой части информации, следует использовать обычный режим. В качестве первого параметра следует использовать имя или IP-адрес компьютера, о котором требуется получить данные. В качестве второго параметра введите имя или IP-адрес сервера имен DNS. Если второй параметр не задан, командой nslookup используется сервер имен DNS, установленный по умолчанию.

    Если требуется получить более полные сведения, следует использовать интерактивный режим. В качестве первого параметра следует ввести знак дефиса (-) и имя или IP-адрес сервера имен DNS в качестве второго параметра. Если оба параметра не заданы, командой nslookup используется сервер имен DNS, установленный по умолчанию. Далее перечислено несколько советов по работе в интерактивном режиме.

    • Для прерывания интерактивной команды в любой момент следует нажать CTRL+B.
    • Для выхода необходимо ввести exit.
    • Для ввода имени компьютера, совпадающего с какой-либо командой, перед именем следует ввести обратную косую черту (\).
    • Нераспознанные команды воспринимаются как имена компьютеров.
  • Если при обработке запроса возникла ошибка, командой nslookup на экран будет выведено сообщение. В следующей таблице перечислены возможные сообщения об ошибках.
    Сообщение об ошибке | Описание
    Timed out | Сервер не ответил на запрос в течение определенного времени и после определенного числа повторных попыток. Имеется возможность установить период ожидания с помощью подкоманды set timeout. Имеется возможность установить число повторных попыток с помощью подкоманды set retry.
    No response from server | Сервер имен DNS не запущен на сервере
    No records | Сервер имен DNS не содержит записей о ресурсах указанного типа, хотя имя сервера задано верно. Тип запроса задается командой set querytype.
    Nonexistent domain | Заданный компьютер или имя домена DNS не существует.
    Connection refused

    -или-

    Network is unreachable

             Невозможно подключиться к серверу имен DNS или к серверу службы finger. Эта ошибка обычно возникает с запросами команд ls и finger.
    Server failure | Сервер имен DNS обнаружил внутреннее несоответствие в своей базе данных и не может корректно ответить на запрос.
    Refused | Отказано в обработке запроса сервером имен DNS.
    Format error | Сервер DNS обнаружил ошибку в формате полученного пакета. Это может свидетельствовать об ошибке в команде nslookup.

Примеры

Каждый параметр состоит из дефиса (-) и следующей за ним без пробелов команды, а также, в некоторых случаях, знака равенства (=) и значения. Например, чтобы изменить установленный по умолчанию тип запроса о сведениях для узла и установить начальное время ожидания равным 10 секундам, следует ввести команду:

nslookup -querytype=hinfo -timeout=10


Подкоманды Nslookup

Для получения дополнительных сведений щелкните ссылку на соответствующую команду.

  • Nslookup: exit
  • Nslookup: finger
  • Nslookup: help
  • Nslookup: ls
  • Nslookup: lserver
  • Nslookup: root
  • Nslookup: server
  • Nslookup: set
  • Nslookup: set all
  • Nslookup: set class
  • Nslookup: set d2
  • Nslookup: set debug
  • Nslookup: set defname
  • Nslookup: set domain
  • Nslookup: set ignore
  • Nslookup: set port
  • Nslookup: set querytype
  • Nslookup: set recurse
  • Nslookup: set retry
  • Nslookup: set root
  • Nslookup: set search
  • Nslookup: set srchlist
  • Nslookup: set timeout
  • Nslookup: set type
  • Nslookup: set vc
  • Nslookup: view


Nslookup: exit

Осуществляет выход из nslookup.

Синтаксис

exit

Параметры

{help|?}
Выводит краткое описание подкоманд nslookup.


Nslookup: finger

Осуществляет подключение к серверу finger на текущем компьютере.

Синтаксис

finger [имя_пользователя] [{[>] имя_файла|[>>] имя_файла}]

Параметры

имя_пользователя
Задает имя пользователя, о котором требуется получить данные.
имя_файла
Задает имя файла для сохранения выходной информации. С помощью символов (>) и (>>) выход может быть перенаправлен обычным способом.
{help|?}
Выводит краткое описание подкоманд nslookup.

Замечания

  • Текущий компьютер определяется, если предыдущий поиск компьютера был успешным и в результате выполнения команды был возвращен адрес компьютера.


Nslookup: help

Выводит краткое описание подкоманд nslookup.

Синтаксис

{help|?}

Параметры

{help|?}
Выводит краткое описание подкоманд nslookup.


Nslookup: ls

Выводит сведения для домена DNS.

Синтаксис

ls [параметр] домен_DNS [{[>] имя_файла|[>>] имя_файла}]

Параметры

Параметр
В следующей таблице представлен список допустимых параметров.
Параметр | Описание
-t тип_запроса | Перечисляет все записи указанного типа. Описание параметра тип_запроса см. в разделе set querytype ссылки «См.также».
-a | Выводит псевдонимы компьютеров в домене DNS. Этот параметр является синонимом параметра -t CNAME.
-d | Выводит все записи для домена DNS. Этот параметр является синонимом параметра -t ANY.
-h | Выводит сведения о процессорах и операционных системах в домене DNS. Этот параметр является синонимом параметра -t HINFO.
-s | Выводит список общеизвестных служб в домене DNS. Этот параметр является синонимом параметра -t WKS.
домен_DNS
Задает имя домена DNS, сведения о котором требуется получить.
имя_файла
Задает имя файла для сохранения выходной информации. С помощью символов (>) и (>>) выход может быть перенаправлен обычным способом.
{help|?}
Выводит краткое описание подкоманд nslookup.

Замечания

  • По умолчанию будут выведены имена компьютеров и их IP-адреса. Когда вывод направлен в файл, после вывода каждых 50 записей на экран будет выводиться знак #.


Nslookup: lserver

Производит изменение сервера, используемого по умолчанию для заданного домена DNS.

Синтаксис

lserver домен_DNS

Параметры

домен_DNS
Задает новый домен DNS для сервера, используемого по умолчанию.
{help|?}
Выводит краткое описание подкоманд nslookup.

Замечания

  • Команда lserver использует первоначально установленный сервер для получения сведений о заданном сервере DNS. Это отличает ее от команды server, использующей текущий используемый по умолчанию сервер.


Nslookup: root

Производит замену сервера, используемого по умолчанию, на корневой сервер пространства имен DNS.

Синтаксис

root

Параметры

{help|?}
Выводит краткое описание подкоманд nslookup.

Замечания

  • В настоящий момент используется сервер ns.nic.ddn.mil. Команда эквивалентна команде lserver ns.nic.ddn.mil. Имя корневого сервера может быть изменено командой set root.


Nslookup: server

Производит замену сервера, используемого по умолчанию, для заданного домена DNS.

Синтаксис

server домен_DNS

Параметры

домен_DNS
Обязательный параметр. Задает новый домен DNS для сервера, используемого по умолчанию.
{help|?}
Выводит краткое описание подкоманд nslookup.

Замечания

  • Команда server использует текущий используемый по умолчанию сервер для поиска сведений о заданном домене DNS. Это отличает ее от команды lserver, которая использует первоначально установленный сервер.


Nslookup: set

Изменяет настройки, которые определяют работу функций lookup.

Синтаксис

set ключевое_слово[=значение]

Параметры

ключевое_слово
Указывает подкоманды, производные от подкоманды set. Например, подкоманда set d2 имеет ключевое слово [no]d2.
Значение
Указывает значение параметра конфигурации nslookup для каждой подкоманды.
{help|?}
Выводит краткое описание подкоманд nslookup.

Замечания

  • Для вывода всех текущих параметров следует ввести команду set all.


Nslookup: set all

Выводит текущие значения параметров настройки.

Синтаксис

set all

Параметры

{help|?}
Выводит краткое описание подкоманд nslookup.

Замечания

  • Команда set all также выводит сведения о сервере, используемом по умолчанию, и о узловом компьютере.


Nslookup: set class

Изменяет класс запроса. Класс запроса определяет группу протоколов с информацией.

Синтаксис

set cl[ass]=класс

Параметры

класс
По умолчанию используется класс IN. В следующей таблице перечислены допустимые значения для этой команды.
Значение | Описание
IN | Определяет класс Internet.
CHAOS | Определяет класс Chaos.
HESIOD | Определяет класс MIT Athena Hesiod.
ANY | Определяет любой класс из перечисленных выше.
{help | ?}
Выводит краткое описание подкоманд nslookup.


Nslookup: set d2

Включает и отключает углубленный режим отладки. В этом режиме будут выводиться все поля каждого пакета.

Синтаксис

set [no]d2

Параметры

nod2
Отключает углубленный режим отладки. По умолчанию используется синтаксис nod2.
d2
Включает углубленный режим отладки.
{help|?}
Выводит краткое описание подкоманд nslookup.


Nslookup: set debug

Включает и отключает режим отладки.

Синтаксис

set [no]deb[ug]

Параметры

nodeb[ug]
Отключает режим отладки. По умолчанию используется синтаксис nodebug.
deb[ug]
Включает режим отладки.
{help|?}
Выводит краткое описание подкоманд nslookup.

Замечания

  • Если режим отладки включен, будут выводиться более подробные сведения о пакетах, отправленных серверу, и о полученных ответах.


Nslookup: set defname

Добавляет имя домена DNS, используемого по умолчанию, к запросу поиска одиночного компонента. Одиночным называется компонент, не содержащий точек.

Синтаксис

set [no]def[name]

Параметры

nodef[name]
Перестает добавлять имя домена DNS, используемого по умолчанию, к запросу поиска одиночного компонента.
def[name]
Добавляет имя домена DNS, используемого по умолчанию, к запросу поиска одиночного компонента. По умолчанию используется синтаксис defname.
{help|?}
Выводит краткое описание подкоманд nslookup.


Nslookup: set domain

Производит замену имени сервера DNS, используемого по умолчанию, на указанное имя.

Синтаксис

set do[main]=имя_домена

Параметры

имя_домена
Указывает новое имя для используемого по умолчанию домена DNS. По умолчанию в качестве имени домена задается имя узла.
{help|?}
Выводит краткое описание подкоманд nslookup.

Замечания

  • Используемое по умолчанию имя домена DNS добавляется к имени, задаваемому в запросе, в соответствии с параметрами defname и search. Список поиска домена DNS содержит родительские домены для домена, используемого по умолчанию, если его имя содержит хотя бы два компонента. Например, для домена DNS mfg.widgets.com список поиска будет включать mfg.widgets.com и widgets.com. Команда set srchlist используется для задания другого списка, а команда set all для отображения списка.


Nslookup: set ignore

Игнорирует ошибки усечения пакетов.

Синтаксис

set [no]ig[nore]

Параметры

noig[nore]
Не игнорирует ошибки усечения пакетов. По умолчанию используется параметр noignore.
ig[nore]
Игнорирует ошибки усечения пакетов.
{help|?}
Выводит краткое описание подкоманд nslookup.


Nslookup: set port

Производит изменение порта TCP/UDP сервера имен DNS, используемого по умолчанию, на указанное значение.

Синтаксис

set po[rt]=порт

Параметры

порт
Указывает новое значение порта TCP/UDP сервера имен DNS. По умолчанию используется порт 53.
{help|?}
Выводит краткое описание подкоманд nslookup.


Nslookup: set querytype

Изменяет тип записи ресурса для запроса.

Синтаксис

set q[uerytype]=тип_записи_ресурса

Параметры

тип_записи_ресурса
Указывает тип записи ресурса DNS. По умолчанию используется тип A. В следующей таблице перечислены допустимые значения для этой команды.
Значение | Описание
A | Указывает IP-адрес компьютера.
ANY | Указывает все типы данных.
CNAME | Указывает каноническое имя для псевдонима.
GID | Указывает идентификатор группы для имени группы.
HINFO | Указывает тип процессора и операционной системы компьютера.
MB | Указывает имя домена почтового ящика.
MG | Указывает члена почтовой группы.
MINFO | Предоставляет сведения о почтовом ящике или списке рассылки.
MR | Указывает имя домена переименования почты.
MX | Указывает почтовый обменник.
NS | Указывает сервер имен DNS для заданной зоны.
PTR | Выдает имя компьютера, если запрос состоит из IP-адреса, иначе выдает указатель на другие сведения.
SOA | Указывает начальную запись для зоны DNS.
TXT | Выдает текстовую информацию.
UID | Указывает идентификатор пользователя.
UINFO | Выдает информацию пользователя.
WKS | Выдает описание известных служб.
{help|?}
Выводит краткое описание подкоманд nslookup.

Замечания

  • Команда set type выполняет ту же функцию, что и команда set querytype.


Nslookup: set recurse

Указывает серверу имен DNS, что необходимо отправить запрос другим серверам в случае, если он сам не располагает требуемой информацией.

Синтаксис

set [no]rec[urse]

Параметры

norec[urse]
Отменяет требование к серверу имен DNS отправлять запрос другим серверам в случае, если он сам не располагает требуемой информацией.
rec[urse]
Указывает серверу имен DNS, что необходимо отправить запрос другим серверам в случае, если он сам не располагает требуемой информацией. По умолчанию используется синтаксис recurse.
{help | ?}
Выводит краткое описание подкоманд nslookup.


Nslookup: set retry

Устанавливает число повторных попыток.

Синтаксис

set ret[ry]=число

Параметры

число
Указывает новое значение числа повторных попыток. По умолчанию число повторных попыток равно 4.
{help|?}
Выводит краткое описание подкоманд nslookup.

Замечания

  • Если в течение указанного периода времени ответ на запрос не получен, интервал будет удвоен, а запрос повторен. Заданное параметру значение определяет, сколько раз запрос будет повторен. Имеется возможность изменить период ожидания с помощью подкоманды set timeout.


Nslookup: set root

Производит замену имени корневого сервера, используемого для запросов.

Синтаксис

set ro[ot]=корневой_сервер

Параметры

корневой_сервер
Указывает новое имя корневого сервера. По умолчанию используется имя ns.nic.ddn.mil.
{help|?}
Выводит краткое описание подкоманд nslookup.

Замечания

  • Подкоманда set root влияет на команду root.


Nslookup: set search

Присоединяет имена доменов DNS из списка поиска доменов DNS в запрос, пока не будет получен ответ. Это применяется, когда запросы set и lookup содержат по крайней мере одну точку, но содержат завершающей точки.

Синтаксис

set [no]sea[rch]

Параметры

nosea[rch]
Прекращает присоединение имен доменов DNS из списка поиска доменов DNS в запрос.
sea[rch]
Присоединяет имена доменов DNS из списка поиска доменов DNS в запрос, пока не будет получен ответ. По умолчанию используется синтаксис search.
{help|?}
Выводит краткое описание подкоманд nslookup.


Nslookup: set srchlist

Производит изменение используемого по умолчанию имени домена DNS и списка поиска.

Синтаксис

Set srchl[ist]=имя_домена[/...]

Параметры

имя_домена
Указывает новые имена для используемого по умолчанию домена DNS и списка поиска. По умолчанию в качестве основы для имени домена задается имя узла. Может быть указано до шести имен, разделенных косыми чертами (/).
{help|?}
Выводит краткое описание подкоманд nslookup.

Замечания

  • Команда set srchl переопределяет используемое по умолчанию имя домена DNS и список поиска команды set domain. Для вывода всего списка должна быть использована команда set all.

Примеры

Чтобы задать домену DNS имя mfg.widgets.com и указать список поиска из трех имен, введите следующее.

set srchlist=mfg.widgets.com/mrp2.widgets.com/widgets.com


Nslookup: set timeout

Изменяет начальный период времени в секундах, в течение которого система будет ожидать ответа на запрос.

Синтаксис

set ti[meout]=число

Параметры

Число
Указывает число секунд для периода ожидания. Период ожидания, используемый по умолчанию, составляет 5 секунд.
{help|?}
Выводит краткое описание подкоманд nslookup.

Замечания

  • Если в течение указанного периода времени ответ на запрос не получен, интервал будет удвоен, а запрос повторен. Имеется возможность установить число повторных попыток с помощью подкоманды set retry.


Nslookup: set type

Изменяет тип записи ресурса для запроса.

Синтаксис

set ty[pe]=тип_записи_ресурса

Параметры

тип_записи_ресурса
Указывает тип записи ресурса DNS. По умолчанию используется тип A. В следующей таблице перечислены допустимые значения для этой команды.
Значение | Описание
A | Указывает IP-адрес компьютера.
ANY | Указывает все типы данных.
CNAME | Указывает каноническое имя для псевдонима.
GID | Указывает идентификатор группы для имени группы.
HINFO | Указывает тип процессора и операционной системы компьютера.
MB | Указывает имя домена почтового ящика.
MG | Указывает члена почтовой группы.
MINFO | Предоставляет сведения о почтовом ящике или списке рассылки.
MR | Указывает имя домена переименования почты.
MX | Указывает почтовый обменник.
NS | Указывает сервер имен DNS для заданной зоны.
PTR | Выдает имя компьютера, если запрос состоит из IP-адреса, иначе выдает указатель на другие сведения.
SOA | Указывает начальную запись для зоны DNS.
TXT | Выдает текстовую информацию.
UID | Указывает идентификатор пользователя.
UINFO | Выдает информацию пользователя.
WKS | Выдает описание известных служб.
{help|?}
Выводит краткое описание подкоманд nslookup.

Замечания

  • Команда set type выполняет ту же функцию, что и команда set querytype.


Nslookup: set vc

Указывает, использовать или нет виртуальную цепь при оправке запросов серверу.

Синтаксис

set [no]v[c]

Параметры

nov[c]
Указывает никогда не использовать виртуальную цепь при отправке запросов серверу. По умолчанию используется значение yes.
v[c]
Указывает всегда использовать виртуальную цепь при отправке запросов серверу.
{help|?}
Выводит краткое описание подкоманд nslookup.


Nslookup: view

Сортирует и перечисляет вывод предыдущих подкоманд и команд ls.

Синтаксис

view имя_файла

Параметры

имя_файла
Указывает имя файла, содержащего результаты работы предыдущих подкоманд и команд ls.
{help|?}
Выводит краткое описание подкоманд nslookup.


Logman

Logman

Управляет и задает расписания для счетчиков производительности и журнала трассировки событий на локальном или удаленных компьютерах.

Синтаксис действий

Logman [create {counter | trace} имя_выборки ] [start имя_выборки] [stop имя_выборки] [delete имя_выборки] [query {имя_выборки|providers}] [update имя_выборки]

Параметры

create {counter | trace} имя_выборки
Создает запросы на выборку данных для счетчика или трассировки. Имеется возможность использовать командную строку для указания параметров.
start collection_name
Производит запуск запроса имя_выборки на выборку данных. Этот параметр применяется для перехода к сбору данных вручную вместо сбора по расписанию. Для восстановления режима сбора данных по расписанию используйте параметр update с ключами времени начала (–b), окончания (–e) или повтора (–rt).
stop имя_выборки
Производит остановку запроса имя_выборки на выборку данных. Этот параметр применяется для перехода к сбору данных вручную вместо сбора по расписанию. Для восстановления режима сбора данных по расписанию используйте параметр update с ключами времени начала (–b), окончания (–e) или повтора (–rt).
delete имя_выборки
Удаляет запрос имя_выборки на выборку данных. Если запрос имя_выборки не существует, появится сообщение об ошибке.
query {имя_выборки|providers}
Если не задан аргумент имя_выборки или providers, отображается состояние всех существующих запросов на выборку данных. Используйте аргумент имя_выборки для отображения свойств конкретной выборки. Чтобы отобразить свойства на удаленных компьютерах, в командной строке введите: -s удаленный_компьютер. Аргумент providers может использоваться в качестве ключевого слова вместо аргумента имя_выборки для отображения зарегистрированных поставщиков, установленных на локальном компьютере. Чтобы перечислить зарегистрированных поставщиков на удаленном компьютере используйте ключ -s в командной строке.
update имя_выборки
Производит обновление запросов для счетчика и для выборок данных трассировки. После изменения параметров выборку данных счетчика необходимо перезапустить. Для выборок данных трассировки используйте в командной строке следующие параметры, чтобы сделать запрос, не прекращая выборку: -p поставщик [(флаги[,флаги ...])] уровень, - max n, - o путь, -ft мм:сс, или -fd.

Синтаксис модификаторов

[-s имя_компьютера] [-config имя_файла] [-b М/д/гггг ч:мм:сс[AM | PM]] [-e М/д/гггг ч:мм:сс[AM | PM]] [-m [start] [stop]] [-[-]r] [-o {путь | DSN!журнал_счетчиков}] [-f {bin | bincirc | csv | tsv | SQL}] [-[-]a] [-[-]v [{nnnnn | ммддччмм}]] [-[-] rc [имя_файла]] [-[-] max {значение}] [-[-]cnf [[[чч:]]мм:]сс] [-c {путь [путь ...] | -cf имя_файла}] [-si [[чч:]мм:]сс] [-ln имя_сеанса] [-ets] [-[-] rt] [-p {GUID | поставщик [(флаги [,флаги...]}] уровень | -pf имя_файла}] [-[-] ul] [-bs значение] [-ft [[чч:]мм:]сс] [-nb мин макс] [-fd имя_сеанса] [-[-]u пароль_пользователя] [-rf [[чч:]мм:]сс] [-y] [-mode {режим_трассировки [режим трассировки ...]}]

Параметры

-s имя_компьютера
Указывает, что команды создания, запуска, остановки, удаления, запроса или обновления будут выполнятся на удаленном компьютере. По умолчанию используется локальный компьютер.
-config имя_файла
Задает путь к файлу, содержащему параметры командной строки.
-b М/д/гггг ч:мм:сс[AM | PM]
Указывает время (в 24-часовом формате) начала записи выборки данных. Можно задать время в 12-часовом формате, добавив в командную строку параметр AM или PM. По умолчанию используются текущие день и время, если не заданы другие данные. Чтобы немедленно начать выборку, воспользуйтесь возможностью запуска вручную.
-e М/д/гггг ч:мм:сс[AM | PM]
Указывает время (в 24-часовом формате) завершения записи выборки данных. Можно задать время в 12-часовом формате, добавив в командную строку параметр AM или PM. По умолчанию используются текущие день и время, если не заданы другие данные. Используйте остановку вручную, а затем параметр повтора, чтобы установить значение времени завершения меньше значения текущего времени, иначе будет выдано сообщение об ошибке.
-m start stop
Определяет, что выборки будут запускаться и останавливаться вручную в командной строке с помощью параметров start и stop. Невозможно вместе использовать параметры -m start и -b или -m stop и -e или -rf в одном запросе.
-r
Производит повторную запись выборки данных каждый день в течение интервала времени, задаваемом параметрами -b и -rf или параметрами –b и –e. Эта команда действительна только для интервалов, время начала и окончания которых приходится на один и тот же день, месяц и год.
--r
Выключает параметр повторения записи.
-o {путь | DSN!журнал_счетчиков}
Указывает путь к файлу, в котором записываются данные счетчиков производительности или данные трассировки, или местоположение базы и набора данных SQL. Чтобы база данных SQL использовала формат «DNS!журнал_счетчиков», введите в командной строке ключ -f. По умолчанию в качестве имени файла журнала используется имя выборки с расширением .blg для счетчиков производительности или .etl для данных трассировки.
-f {bin | bincirc | csv | tsv | SQL}
Указывает формат файла, используемый для сбора данных счетчиков производительности и данных трассировки. Для журнала может быть выбран один из следующих форматов: двоичный, циклический двоичный, текст с разделителями-запятыми и текст с разделителями-знаками табуляции, а также формат базы данных SQL. С параметром «DNS!;журнал_счетчиков» следует использовать в командной строке ключ -o. Для форматов базы данных SQL должно быть заранее определено имя источника данных (DSN), а пользователь должен иметь право записи в эту базу данных. Набор данных журнал_счетчиков создается в базе данных и определяется DSN. По умолчанию используется двоичный формат.
-a
Этот параметр используется для записи в конец файла.
--a
Выключает режим записи в конец и возвращает систему к режиму перезаписи.
-v {nnnnn | ммддччмм}
Добавляет данные контроля версий в конец выходного файла и пути. Используйте для контроля версий числовой формат nnnnn или формат даты ммддччмм, включающий месяц, день, час (в 24-часовой нотации) и минуты.
--v
Выключает параметр добавления данных контроля версий.
-rc имя_файла
Запускает эту команду после после того, как файл был закрыт при достижении его конца или во время выборки. Чтобы закрывать файлы во время выборки, используйте ключ -rf совместно с ключом -cnf. Использование ключа -stop отключит этот режим. Команды всегда выполняются в активном режиме.
--rc
Выключает режим закрытия файлов во время выборки.
-max значение
Указывает максимальный размер файла журнала в мегабайтах. Если размер журнала превышает максимальный, накопление данных прекращается. Для базы данных SQL максимальный размер представляет максимальное число записей.
--max
Выключает ограничение на размер журнала. Этот параметр используется по умолчанию.
-cnf [[чч:]мм:]сс
Создает новый файл, когда файлы для хранения выходной информации превышают максимально допустимый размер или когда истекает указанное время. Необходимо включить ключ -v при выполнении этой команды. По умолчанию создается только один файл журнала для каждой выборки.
--cnf
Выключает параметр создания нового файла журнала.
-c {путь [путь...] | -cf имя_файла}
Указывает путь к журналу для счетчика производительности или путь и имя файла журнала, в котором содержится список этих счетчиков. Чтобы задать несколько путей счетчиков, используйте пробел для разделения командной строки или параметр -cf, чтобы ввести список путей счетчиков из входного файла (по одному в строке).

Общий формат для путей счетчиков выглядит следующим образом: [\\компьютер]\объект[родительский_объект/экземпляр#индекс]\счетчик], где:

Компоненты «родительский_объект», «экземпляр», «индекс» и «счетчик» могут содержать допустимое имя или подстановочный знак. Компоненты «компьютер», «родительский_объект», «экземпляр» и «индекс» не являются необходимыми для всех счетчиков.

Путь к счетчику определяется для каждого счетчика отдельно. Например, объект логический_диск имеет индекс экземпляра, поэтому для него необходимо задать значение #индекс или ввести подстановочный знак. Таким образом, можно использовать следующий формат.

\логический_диск(*/*#*)\*

Для объекта процесс не требуется задавать индекс экземпляра. Таким образом, можно использовать следующий формат.

\процесс(*)\идентификатор_процесса

Ниже приведен список допустимых форматов.

  • \\компьютер\объект(родительский_объект/экземпляр#индекс)\счетчик
  • \\компьютер\объект(родительский_объект/экземпляр)\счетчик
  • \\компьютер\объект(экземпляр#индекс)\счетчик
  • \\компьютер\объект(экземпляр)\счетчик
  • \\компьютер\объект\счетчик
  • \объект(родительский_объект/экземпляр#индекс)\счетчик
  • \объект(родительский_объект/экземпляр)\счетчик
  • \объект(экземпляр#индекс)\счетчик
  • \объект(экземпляр)\счетчик
  • \объект\счетчик

Если подстановочный знак используется в имени родительского объекта, будут возвращены все экземпляры указанного объекта, соответствующие заданным полям «экземпляр» и «счетчик».

Если подстановочный знак используется в имени экземпляра, будут возвращены все экземпляры указанного объекта и родительского объекта, если имена всех экземпляров, соответствующих указанному индексу, соответствуют подстановочному знаку.

Если подстановочный знак используется в имени счетчика, будут возвращены все счетчики указанного объекта.

Частичное совпадение пути счетчика (например «pro*») не поддерживается.

-si [[чч:]мм:]сс
Указывает интервал обновления для выборки данных счетчиков в часах, минутах и секундах По умолчанию этот интервал составляет 15 секунд.
-ln имя_сеанса
Указывает имя, определенное пользователем, для сеанса трассировки событий. По умолчанию в качестве имени сеанса используется имя выборки.
-ets
Создает и запускает сеанс трассировки событий с помощью параметров, определенных в командной строке. Имеется возможность использовать этот дополнительный параметр вместе с действиями create trace, update, query и delete.
-rt
Указывает, что сеанс трассировки событий выполняется в режиме реального времени и не записывается в журнал. По умолчанию данные записываются в журнал.
--rt
Выключает параметр работы в режиме реального времени.
-p {GUID | поставщик [(флаги[,флаги ...])] уровень] | -pf {имя_файла}
Указывает поставщиков (выборщиков данных трассировки), которых можно использовать для накопления данных трассировки. Используйте поставщиков запросов logman, чтобы найти параметр pname (поставщики с именем) в списке зарегистрированных поставщиков. Чтобы перечислить нескольких поставщиков, используйте ключ -pf. Ключ -pf определяет входной файл, содержащий имена поставщиков. Имена поставщиков заключаются в кавычки ("") или в коды GUID в фигурных скобках, маски флагов и целые числа (уровень разрешения). Флаги используются или в шестнадцатеричном (OXFFFF) формате или в формате (флаг, флаг).
-ul
Указывает, что сеанс трассировки событий выполняется в пользовательском режиме. При использовании ключа -ul только один поставщик может быть включен для сеанса трассировки событий.
--ul
Отключает пользовательский режим, и сеанс трассировки событий выполняется в режиме ядра.
-bs значение
Указывает размер буфера (в килобайтах) для выборок данных трассировки.
-ft [[чч:]мм:]сс
Указывает интервал таймера сброса (в минутах и секундах) для выборок данных трассировки.
-nb мин макс
Указывает минимальное и максимальное число буферов для выборки данных трассировки. Минимальное значение по умолчанию равно числу процессоров системы плюс два. Максимальное значение по умолчанию равно 25.
-fd имя_сеанса
Сбрасывает все активные буферы существующего сеанса трассировки событий на диск. Используйте эту команду вместе с ключом -ln.
-u пароль_пользователя
Указывает имя учетной записи и пароль, которые используются запросом на выборку данных на локальном и удаленных компьютерах. Чтобы начать сбор данных по запросам на выборку данных, откройте оснастку «Оповещения и журналы производительности» для удаленного компьютера. Можно использовать символ * в качестве пароля в командной строке, чтобы было предложено ввести пароль.
--u
Восстанавливает имя учетной записи в службе «Оповещения и журналы производительности».
-rf [[чч:]мм:]сс
Указывает, что выборки выполняются за установленный период времени.
-y
Перезаписывает параметры имени выборки, а затем применяет новые параметры без запроса конечного пользователя.
-mode {режим_трассировки [режим_трассировки ...]}
Указывает дополнительные параметры только тех для сеансов трассировки, у которых режим_трассировки может иметь значения globalsequence, localsequence или pagedmemory. При работе в режиме globalsequence трассировщик событий добавляет последовательный номер каждому получаемому событию, не зависимо от того, в каком сеансе трассировки было получено событие. При работе в режиме localsequence трассировщик событий добавляет последовательный номер событиям из определенного сеанса трассировки. При использовании режима localsequence последовательные номера могут повторятся от сеанса к сеансу, но внутри одного сеанса все номера уникальны. При работе в режиме pagedmemory трассировщик событий использует для внутренних выделений буфера выгружаемую память, а не определенный по умолчанию невыгружаемый пул.
/?
Отображает справку в командной строке.

Примечания

  • Ниже перечислены допустимые параметры для действий командной строки create, update, start, stop, delete и query.

    -s имя_удаленного_компьютера

    -[-]u домен/пароль_пользователя

  • Ниже перечислены допустимые параметры для действий create и update и общие ключи для аргументов счетчик и трассировка.

    -y

    -b М/д/гггг ч:мм:сс [AM|PM]

    -e М/д/гггг ч:мм:сс [AM|PM]

    -rf чч:мм:сс

    -m start stop

    -f bin|bincirc

    -[-]r

    -o путь

    -[-]a

    -[-]v nnnnn|ммддччмм

    -[-]rc команда путь

    -[-]max n

    -[-]cnf чч:мм:сс

  • Для аргумента счетчики существует всего два общих параметра:

    -f bin|bincirc|csv|tsv|SQL

    -o путь | DSN!журнал_счетчиков

  • Для действия create счетчик существует всего два общих параметра:

    -c путь_счетчика | -cf входной_файл

    -si [[чч:]мм:]сс

    Этот параметры обновляют счетчик, останавливают и запускают выборки.

  • Ниже перечислены параметры выборки данных трассировки для действия update.

    - max n

    - o путь

    -ft мм:сс

    -fd

    Эти параметры осуществляют запрос на выборку данных трассировки, не прекращая выборки.

  • Для аргумента счетчики существует всего два допустимых параметра:

    -f bin|bincirc|csv|tsv|SQL

    -o путь | DSN!журнал_счетчиков

  • Для действия create счетчик существует всего две допустимых команды:

    путь_счетчика | -cf входной_файл

    -si чч:мм:сс

  • Ниже перечислены допустимые команды для действия create трассировка.

    -ln имя_сеанса

    -[-]rt

    -p Guid | поставщик (флаги[,флаги ...]) уровень | -pf имя_файла

    -[-]ul

    -bs n

    -ft мм:сс

    -nb мин макс

    -fd имя_сеанса

    -ets

  • Использование параметра -config

    Содержимое файла настроек, используемого с параметром -config, должно иметь следующий формат:

    [параметр_команды]

    значение

    где параметр_команды — параметр командной строки, а значение — его значение. Например:

    [create]

    counter logx

    [-s]

    mysystem

    [-u]

    mypassword

  • Использование параметра -mode

    Этот параметр следует использовать только опытным пользователям.

  • Управление системным монитором

    Можно использовать команду Logman для управления системами Windows 2000 и Windows XP.

  • Дополнительные сведения о включении команды Logman в сценарии инструментария управления Windows см. ссылку Scripting Logs and Monitoring на веб-узле Microsoft Windows Resource Kits.(http://www.microsoft.com/)

Примеры

Форматы данных в следующих примерах используются только с местным временем США.

Чтобы создавать ежедневные запросы на выборку данных счетчика с указанием времени начала и окончания, повторных выборок, номеров контроля версий, путей счетчиков и интервалов обновления, введите следующее.

Logman create counter daily_perf_log -b 7/27/2000 13:00:00 -e 7/27/2000 15:00:00 -r -v mmddhhmm -c "\Processor(_Total)\% Processor Time" "\Memory\Available bytes" -si 00:15 -o "c:\perflogs\daily_log"

Чтобы создавать ежедневные запросы на выборку данных с указанием времени начала и окончания, выборок выходных файлов, повторных выборок, номеров контроля версий, путей счетчиков и интервалов обновления, введите следующее.

Logman create counter daily_perf_log -b 7/27/2000 13:00:00 -e 7/27/2000 15:00:00 -r -o "c:\perflogs\daily_log" -v mmddhhmm -c "\Processor(_Total)\% Processor Time" "\Memory\Available bytes" -si 00:15

Чтобы создавать ежедневные запросы на выборку данных с помощью файла config, а не файла командной строки, введите следующее.

Logman -config file daily_perf.txt

Чтобы создавать ежедневные запросы на выборку данных трассировки с указанием времени начала и окончания, повторных выборок, номеров контроля версий, имен поставщиков, выборок входных и выходных файлов, введите следующее.

Logman create trace daily_kernel_trace_log -b 7/27/2000 13:00:00 -e 7/27/2000 15:00:00 -r -v mmddhhmm -p "Windows Kernel Trace" 0xFFFFFFFF -rf 100 -o "c:\perflogs\daily_nt_trace"

Чтобы создавать ежедневные запросы на выборку данных трассировки с указанием времени начала и окончания, повторных выборок, имен Guid и сеансов, выборок входных и выходных файлов, введите следующее.

Logman create trace daily_lsass_trace_log -b 7/27/2000 13:00:00 -e 7/27/2000 15:00:00 -r -v mmddhhmm -p "Local Security Authority(LSA) " 0x00000001 -rf 30:00 -o " c:\perflogs\daily_lsass_trace"

Чтобы создавать ежедневные запросы на выборку данных с указанием времени начала и окончания, повторных выборок, номеров контроля версий, путей счетчиков, интервалов обновления, форматов SQL и выборок выходных файлов, введите следующее.

Logman create counter daily_perf_log -b 7/27/2000 13:00:00 -e 7/27/2000 15:00:00 -r -v mmddhhmm -c "\Processor(_Total)\% Processor Time" "\Memory\Available bytes" -si 00:15 -f sql -o perfdb!daily_log

Чтобы запускать ежедневные выборки с интервалами обновления, именами учетных записей и паролями, введите следующее.

Logman start daily_perf_log -s \\%computer_name% -u admin "adminpassword"

Чтобы запускать выборки данных, которые будут осуществляться вручную, введите следующее.

Logman start daily_perf_log

Чтобы остановить выборки данных, введите следующее.

Logman stop daily_perf_log

Чтобы удалить выборки данных, введите следующее.

Logman delete daily_perf_log

Для просмотра состояния запросов на выборку введите следующие команды.

Logman query

Logman query daily_perf_log


Perfmon

Позволяет открыть консоль «Производительность» Windows XP с настройками системного монитора из файлов настройки версии для Windows NT 4.0.

Синтаксис

perfmon.exe [имя_файла] [/HTMLFILE:преобразованный_файл файл_параметров]

Параметры

.exe
Задает расширение файла.
имя_файла
Задает имя файла параметров.
/HTMLFILE:преобразованный_файл файл_параметров
Задает имя преобразованных файлов и имя исходного файла параметров Windows NT 4.0.

Примечания

  • Эта процедура применима к файлам параметров системного монитора Windows NT 4.0 следующих типов: диаграмма (.pmc), отчет (.pmr), оповещение (.pma) и журнал (.pml).
  • Для отображения файла параметров Windows NT 4.0 в системном мониторе этот файл временно преобразуется в формат системного монитора Windows XP, но после запуска консоли преобразованная версия удаляется. Если файл параметров требуется сохранить для дальнейшего использования в системном мониторе, введите следующую команду:

    Perfmon [имя_файла] [/HTMLFILE:преобразованный_файл файл_параметров]

    где /HTMLFILE:преобразованный_файл — имя, с которым должен быть сохранен преобразованный файл, а файл_параметров — имя исходного файла параметров Windows NT 4.0.

Примеры

Чтобы перечислить файлы параметров, введите следующее.

Perfmon myfile_overview

Чтобы перечислить преобразованные и исходные имена файлов, введите следующее.

Perfmon myfile_overview /Commands:newfile_review oldfile_sample.pml


Relog

Сохраняет данные счетчиков производительности из файлов журналов в файлы других форматов, такие как текстовый-TSV (разделитель — табуляция), текстовый-CSV (разделитель — запятая), двоичный-BIN или SQL.

Синтаксис

relog [имя_файла [имя_файла...]] [-a] [-c путь [путь...]] [-cf имя_файла] [-f {bin|csv|tsv|SQL}] [-t значение] [-o {файл_вывода | DSN!журнал_счетчиков}] [-b М/д/гггг [[чч:]мм:]сс] [-e М/д/гггг [[чч:]мм:]сс] [-config имя_файла] [-q]

Параметры

имя_файла [имя_файла ...]
Указывает путь к существующему журналу счетчиков производительности. Можно указать несколько файлов ввода.
-a
Производит запись в конец файла вывода, вместо перезаписи. Этот параметр не применяется для формата SQL, где по умолчанию установлен режим записи в конец.
-c путь [путь ...]
Указывает путь к журналу счетчиков производительности. Чтобы указать несколько путей, разделите их пробелом и заключите в кавычки (например, "Путь1 Путь2").
-cf имя_файла
Указывает путь к текстовому файлу, в котором перечислены счетчики производительности, которые следует включить в файл журнала. Этот ключ используется для перечисления путей к счетчикам во входном файле друг за другом. По умолчанию все счетчики из исходного файла журнала загружаются повторно.
-f {bin|csv|tsv|SQL}
Указывает путь к формату выходного файла. По умолчанию используется двоичный формат (bin). Для баз данных SQL, выходной файл определяет DSN!журнал_счетчиков. Имеется возможность указать расположение базы данных, используя диспетчер ODBC для настройки DSN.
-t значение
Указывает интервалы обновления через каждые "n" записей. Каждая n-ая запись добавляется в файл журнала. По умолчанию добавляются все записи.
-o {выходной_файл | DSN!журнал_счетчиков}
Указывает путь к выходному файлу или базе данных SQL, где счетчики будут записаны.
-b М/д/гггг чч[:мм[:сс]]
Указывает время начала копирования первой записи из входного файла. Дату и время необходимо вводить в следующем формате М/д/гггг чч:мм:сс.
-e М/д/гггг чч[:мм[:сс]]
Указывает время окончания копирования последней записи из входного файла. Дату и время необходимо вводить в следующем формате М/д/гггг чч:мм:сс.
-config имя_файла
Задает путь к файлу, содержащему параметры командной строки.
-q
Отображает счетчики производительности и временные диапазоны файлов журнала, указанные во входном файле.
/?
Отображает справку в командной строке.

Примечания

  • Формат пути счетчика

    Общий формат для путей счетчиков выглядит следующим образом: [\\компьютер]\объект[родительский_объект/экземпляр#индекс]\счетчик], где:

    Компоненты «родительский_объект», «экземпляр», «индекс» и «счетчик» могут содержать допустимое имя или подстановочный знак. Компоненты «компьютер», «родительский_объект», «экземпляр» и «индекс» не являются необходимыми для всех счетчиков.

    Путь к счетчику определяется для каждого счетчика отдельно. Например, объект логический_диск имеет код экземпляра, поэтому для него необходимо задать значение #индекс или ввести подстановочный знак. Таким образом, можно использовать следующий формат.

    \логический_диск(*/*#*)\*

    Для объекта процесс не требуется задавать индекс экземпляра. Таким образом, можно использовать следующий формат.

    \процесс(*)\ID_процесса

    Ниже приведен список допустимых форматов.

    • \\компьютер\объект(родительский_объект/экземпляр#индекс)\счетчик
    • \\компьютер\объект(родительский_объект/экземпляр)\счетчик
    • \\компьютер\объект(экземпляр#индекс)\счетчик
    • \\компьютер\объект(экземпляр)\счетчик
    • \\компьютер\объект\счетчик
    • \объект(родительский_объект/экземпляр#индекс)\счетчик
    • \объект(родительский_объект/экземпляр)\счетчик
    • \объект(экземпляр#индекс)\счетчик
    • \объект(экземпляр)\счетчик
    • \объект\счетчик

    Если подстановочный знак используется в имени родительского объекта, будут возвращены все экземпляры указанного объекта, соответствующие заданным полям «экземпляр» и «счетчик».

    Если подстановочный знак используется в имени экземпляра, будут возвращены все экземпляры указанного объекта и родительского объекта, если имена всех экземпляров, соответствующих указанному коду, соответствуют подстановочному знаку.

    Если подстановочный знак используется в имени счетчика, будут возвращены все счетчики указанного объекта.

    Частичное совпадение пути счетчика (например «pro*») не поддерживается.

  • Файлы счетчика

    Файлы счетчика — это текстовые файлы, в которых перечислены один или более счетчиков производительности в существующем журнале. Полное имя счетчика копируется из журнала или результата выполнения ключа -q в формате [\\компьютер \ объект [экземпляр] \ счетчик]. Пути счетчиков отображаются по одному в строке.

  • Копирование счетчиков

    При выполнении команды Relog производится копирование указанных счетчиков из каждой записи входного файла, производится преобразование формата, если необходимо. Разрешается использовать подстановочные пути в файле счетчика.

  • Сохранение подкаталогов входных файлов

    С помощью ключа -t можно производить вставку входных файлов в выходные через каждую n-ую запись. По умолчанию данные загружаются повторно из каждой записи.

  • Использование -b и -e ключей с файлами журнала.

    Имеется возможность указать, что выходные журналы будут включать записи до времени начала (параметр -b), чтобы обеспечить данные для счетчиков, которым требуются промежуточные значения форматируемых значений. В выходном файле будут содержаться последние записи из входного файла со штампом времени, более ранним, чем время завершения в параметре -e.

  • Использование параметра -config

    Содержимое файла настроек, используемого с параметром -config, должно иметь следующий формат:

    [параметр_команды]

    значение

    где параметр_команды — параметр командной строки, а значение — его значение. Например:

    [o]

    output.txt

    [f]

    csv

    [t]

    5

Примеры

Чтобы обновлять существующие журналы трассировки через фиксированные интервалы в 30 записей, перечислять пути счетчиков, выходные файлы и форматы, введите следующую команду.

Relog c:\perflogs\daily_trace_log.blg -cf counter_file.txt -o c:\perflogs\reduced_log.csv -t 30 -f csv

Чтобы обновлять существующие журналы трассировки через фиксированные интервалы в 30 записей, перечислять пути счетчиков и выходные файлы, введите следующую команду.

Relog c:\perflogs\daily_trace_log.blg -cf counter_file.txt -o c:\perflogs\reduced_log.blg -t 30


Tracerpt

Обрабатывает журналы трассировки событий и данные, поступающие в реальном масштабе времени от поставщиков трассировочных данных, и позволяет создавать отчеты с анализом данных трассировки и файлы CSV (с разделителем запятой) для создающихся событий.

Синтаксис

tracerpt [имя_файла [имя_файла ...]] [-o [имя_файла]] [-report [имя_файла]] [-rt имя_сеанса [имя_сеанса ...]] [-summary [имя_файла]] [-config [имя_файла]

Параметры

имя_файла [имя_файла ...]
Указывает имя файла для сеанса трассировки событий. Можно указать несколько файлов.
-o [имя_файла]
Задает имя файла CSV (с разделителем запятой). Если ни одного файла не указано, тогда по умолчанию используется файл dumpfile.csv, а не summary.txt.
-report [имя_файла]
Задает имя выходного файла отчета. По умолчанию используется файл workload.txt.
-rt имя_сеанса [имя_сеанса ...]
Получает данные из источника данных реального времени. Чтобы использовать этот параметр, включите сеанс трассировки событий.
-summary [имя_файла]
Задает имя сокращенного выходного файла. По умолчанию используется файл summary.txt.
-config имя_файла
Задает путь к файлу, содержащему параметры командной строки. Используйте этот ключ для ввода своих параметров командной строки в файл.
/?
Отображает справку в командной строке.

Примечания

  • Просмотр файлов dumpfile.csv в Microsoft Excel

    Открытие формата dumpfile.csv в Microsoft Excel позволяет просматривать события в хронологическом порядке. Файлы включают состоят из заголовка, за которым следует текст с разделителями запятыми. Поля заголовков перечислены ниже.

    Поле | Описание
    TID | Идентификатор потока
    Clock time | Штамп времени события
    Kernel (ms) | Процессорное время в режиме ядра
    User (ms) | Процессорное время в режиме пользователя
    User data | Переменный фрагмент данных заголовка использует структуру формата управляемых объектов (MOF).
    IID | Экземпляр ID
    PIID | Родительский экземпляр ID
  • Использование параметра -report

    Чтобы использовать этот параметр, необходимо включить имя файла «Windows kernel trace» и любого другого файла трассировки событий в командную строку. Без этого будет выдано сообщение об ошибке.

  • Использование параметра -summary

    При использовании параметра -summary создается следующий файл.

    Files processed | список файлов
    Total buffers processed | N
    Total events processed | N
    Total events lost | N
    Start time | dd MMM yyyy hh:mm:ss.ttt
    End time | dd MMM yyyy hh:mm:ss.ttt
    Elapsed time | N sec
  • Использование параметра -config

    Содержимое файла настроек, используемого с параметром -config, должно иметь следующий формат:

    [параметр_команды]

    значение

    где параметр_команды — параметр командной строки, а значение — его значение. Например:

    [o]

    output.txt

    [report]

    report.txt

    [summary]

    summary.txt


Typeperf

Записывает данные счетчика производительности в командное окно или в файл журнала поддерживаемого формата. Чтобы остановить выполнение команды Typeperf нажмите CTRL+C.

Синтаксис

Typeperf [путь [путь ...]] [-cf имя_файла] [-f {csv|tsv|bin}] [-si интервал] [-o имя_файла] [-q [объект]] [-qx [объект]] [-sc отсчеты] [-config имя_файла] [-s имя_компьютера]

Параметры

-c {путь [путь...] | -cf имя_файла}
Указывает путь к журналу счетчиков производительности. Чтобы перечислить несколько путей счетчиков, следует отделить их друг от друга пробелами.
-cf имя_файла
Указывает имя файла, в котором содержатся пути счетчиков, для которых следует ввести наблюдение, по одному пути в линии.
-f {csv|tsv|bin}
Задает формат выходного файла. Формат файла может быть: csv (с разделителем запятой), tsv (с разделителем табуляцией) и bin (двоичный). По умолчанию используется формат csv.
-si интервал [мм:] сс
Указывает интервал между отсчетами в формате [мм] сс. По умолчанию этот интервал составляет 1 секунду.
-o [имя_файла]
Указывает путь к выходному файлу. По умолчанию используется параметр stdout.
-q [объект]
Отображает и запрашивает доступные счетчики без экземпляров. Чтобы отображать счетчики для одного объекта, включите имя объекта.
-qx [объект]
Отображает и запрашивает все доступные счетчики с экземплярами. Чтобы отображать счетчики для одного объекта, включите имя объекта.
-sc отсчет
Указывает число отсчетов для сбора. По умолчанию выборка производится до тех пор, пока не нажата комбинация клавиш CTRL+C.
-config имя_файла
Задает путь к файлу, содержащему параметры командной строки.
-s имя_компьютера
Указывает систему для наблюдения, если в пути счетчика не задано ни одного сервера.
/?
Отображает справку в командной строке.

Примечания

  • Формат пути счетчика

    Общий формат для путей счетчиков выглядит следующим образом: [\\компьютер]\объектродительский_объект/экземпляр#индекс]\счетчик], где:

    Компоненты «родительский_объект», «экземпляр», «индекс» и «счетчик» могут содержать допустимое имя или подстановочный знак. Компоненты «компьютер», «родительский_объект», «экземпляр» и «индекс» не являются необходимыми для всех счетчиков.

    Путь к счетчику определяется для каждого счетчика отдельно. Например, объект логический_диск имеет код экземпляра, поэтому для него необходимо задать значение #индекс или ввести подстановочный знак. Таким образом, можно использовать следующий формат.

    \логический_диск(*/*#*)\*

    Для объекта процесс не требуется задавать индекс экземпляра. Таким образом, можно использовать следующий формат.

    \процесс(*)\ID_процесса

    Ниже приведен список допустимых форматов.

    • \\компьютер\объект(родительский_объект/экземпляр#индекс)\счетчик
    • \\компьютер\объект(родительский_объект/экземпляр)\счетчик
    • \\компьютер\объект(экземпляр#индекс)\счетчик
    • \\компьютер\объект(экземпляр)\счетчик
    • \\компьютер\объект\счетчик
    • \объект(родительский_объект/экземпляр#индекс)\счетчик
    • \объект(родительский_объект/экземпляр)\счетчик
    • \объект(экземпляр#индекс)\счетчик
    • \объект(экземпляр)\счетчик
    • \объект\счетчик

    Если подстановочный знак используется в имени родительского объекта, будут возвращены все экземпляры указанного объекта, соответствующие заданным полям «экземпляр» и «счетчик».

    Если подстановочный знак используется в имени экземпляра, будут возвращены все экземпляры указанного объекта и родительского объекта, если имена всех экземпляров, соответствующих указанному коду, соответствуют подстановочному знаку.

    Если подстановочный знак используется в имени счетчика, будут возвращены все счетчики указанного объекта.

    Частичное совпадение пути счетчика (например «pro*») не поддерживается.

  • Форматы запросов

    Для запросов пути счетчика используйте следующий формат: Typeperf [{-q | -qx [\\компьютер\] [объект] [-o выходной_файл}].

    Используйте следующие командные строки для полных запросов.

    Typeperf [\\компьютер]\объект[экземпляр]\счетчик]

    Typeperf -cf входной_файл

  • Использование параметра -config

    Содержимое файла настроек, используемого с параметром -config, должно иметь следующий формат:

    [параметр_команды]

    значение

    где параметр_команды — параметр командной строки, а значение — его значение. Например:

    [-c]

    \Windows\mypath

    [-o]

    report.csv

    [-s]

    mysystem

Примеры

Чтобы отобразить счетчики процессора и памяти, введите:

typeperf "\Memory\Available bytes" "\processor(_total)\% processor time"

Чтобы отображать счетчики процесса Explorer каждые три секунды в выходном файле- CSV, введите:

typeperf "\Process(Explorer)\Thread Count" -si 3 -o typeperf.csv

Чтобы отобразить 50 отсчетов счетчиков RAS на компьютере Server_name, введите:

typeperf "\RAS port(LPT1)\Bytes Transmitted" -sc 50 -s Server_name

Чтобы отобразить значения счетчиков для 50 отсчетов счетчиков, перечисленных в файле input.txt, с интервалом выборки в 120 секунд, введите:

typeperf -cf input.txt -si 120 -sc 50 -f TSV -o domain2.tsv

Чтобы запросить установленные счетчики с экземплярами, введите следующую команду. Имейте в виду, что ключ -qx вернет гораздо большее число счетчиков производительности, чем ключ -q.

typeperf -qx

Чтобы запросить счетчики физического диска без экземпляров на компьютере Server5 и записать их в файл diskctrs.txt, введите:

typeperf -q \\Server5\PhysicalDisk -o diskctrs.txt


Arp

Служит для вывода и изменения записей кэша протокола ARP, который содержит одну или несколько таблиц, использующихся для хранения IP-адресов и соответствующих им физических адресов Ethernet или Token Ring. Для каждого сетевого адаптера Ethernet или Token Ring, установленного в компьютере, используется отдельная таблица. Запущенная без параметров, команда arp выводит справку.

Синтаксис

arp [-a [инет_адрес] [-N иф_адрес]] [-g [инет_адрес] [-N иф_адрес]] [-d инет_адрес [иф_адрес]] [- инет_адрес е_адрес [иф_адрес]]

Параметры

-a [инет_адрес] [-N иф_адрес]
Вывод таблиц текущего протокола ARP для всех интерфейсов. Чтобы вывести записи ARP для определенного IP-адреса, воспользуйтесь командой arp -a с параметром инет_адрес, где инет_адрес — это IP-адрес. Чтобы вывести таблицы кэша ARP для определенного интерфейса, укажите параметр -N иф_адрес, где иф_адрес — это IP-адрес, назначенный интерфейсу. Параметр -N вводится с учетом регистра.
-g [инет_адрес] [-N иф_адрес]
Совпадает с -a.
-d инет_адрес [иф_адрес]
Удаление записи с определенным IP-адресом, где инет_адрес — это IP-адрес. Чтобы запись таблицы для определенного интерфейса, укажите параметр иф_адрес, где иф_адрес — это IP-адрес, назначенный интерфейсу. Чтобы удалить все записи, введите звездочку (*) вместо параметра инет_адрес.
-s инет_адрес е_адрес [иф_адрес]
Добавление статической записи, которая сопоставляет IP-адрес инет_адрес с физическим адресом е_адрес, в кэш ARP. Чтобы добавить статическую запись кэша ARP в таблицу для определенного интерфейса, укажите параметр иф_адрес, где иф_адрес — это IP-адрес, назначенный интерфейсу.
/?
Отображение справки в командной строке.

Заметки

  • IP-адреса для параметров инет_адрес и иф_адрес записываются в точечно-десятичной нотации.
  • Физический адрес для параметра е_адрес состоит из шести байт, записанных в шестнадцатеричном формате и разделенных дефисами (например 00-AA-00-4F-2A-9C).
  • Записи, добавленные с параметром -s, являются статическими и не удаляются из кэша ARP после истечения периода времени. Записи удаляются, если остановлен и запущен протокол TCP/IP. Чтобы создать постоянные статические записи кэша ARP, введите соответствующие команды arp и воспользуйтесь планировщиком заданий для выполнения этого файла при запуске.
  • Эта команда доступна, только если в свойствах сетевого адаптера в объекте "Сетевые подключения" в качестве компонента установлен протокол Интернета (TCP/IP).

Примеры

Чтобы вывести таблицы кэша ARP для всех интерфейсов, введите:

arp -a

Чтобы вывести таблицу кэша ARP для интерфейса, которому назначен IP-адрес 10.0.0.99, введите:

arp -a -N 10.0.0.99

Чтобы добавить статическую запись кэша ARP, которая сопоставляет IP-адрес 10.0.0.80 с физическим адресом 00-AA-00-4F-2A-9C, введите:

arp - 10.0.0.80 00-AA-00-4F-2A-9C


Finger

Отображает сведения о пользователе или пользователях конкретного удаленного компьютера (обычно с операционной системой UNIX), запускающего службу Finger или демон. Удаленный компьютер указывает формат и вывод экрана сведений пользователя. Запущенная без параметров, команда finger выводит справку.

Синтаксис

finger [-l] [пользователь] [@узел] [...]

Параметры

-l
Выводит сведения пользователя в форме длинного списка.
Пользователь
Задает пользователя, информация о котором будет получена. Если параметр пользователь не задан, командой finger будет выведена информация обо всех пользователях на указанном компьютере.
@узел
Удаленный компьютер, запускающий службу Finger, на котором производится поиск сведений пользователя. Можно указать имя компьютера или IP-адрес.
/?
Отображение справки в командной строке.

Заметки

  • Может быть указано несколько параметров пользователь@узел.
  • Перед параметром finger необходимо поместить дефис (-), а не косую черту (/).
  • Эта команда доступна, только если в свойствах сетевого адаптера в объекте Сетевые подключения в качестве компонента установлен протокол Интернета (TCP/IP).
  • Операционные системы Microsoft Windows 2000 и Microsoft Windows XP не предоставляют службу finger.

Примеры

Чтобы отобразить сведения для user1 на компьютере users.microsoft.com, введите следующую команду:

finger user1@users.microsoft.com

Чтобы отобразить сведения для всех пользователей на компьютере users.microsoft.com, введите следующую команду:

finger @users.microsoft.com


Rcp

Копирует файлы между компьютером c системой Windows XP и компьютером, на котором запущен сервер rshd. Windows XP и Windows 2000 не работают с rshd. Команда rcp, запущенная без параметров, выводит справку.

Синтаксис

rcp [{-a | -b}] [-h] [-r] [узел][.пользователь:] [источник] [узел][.пользователь:] [путь\точка_назначения]

Параметры

-a
Задает режим передачи (ASCII). В этом режиме символ конца строки для систем UNIX заменяется символом возврата каретки, а для персональных компьютеров — парой возврат каретки /перевод строки. Этот режим используется по умолчанию.
-b
Задает режим передачи двоичных файлов. Преобразование комбинации возврат каретки/перевод строки не выполняется.
-h
Передает исходные файлы с атрибутом «скрытый» на компьютер с Windows XP. В противном случае скрытые файлы не копируются.
-r
Рекурсивно копирует в точку назначения все каталоги источника.
узел
Задает имя локального или удаленного узла. Если узел задан с помощью IP-адреса или имя узлового компьютера содержит точки (.), необходимо задать пользователя.
пользователь
Задает имя пользователя Если имя пользователя не задано, то используется имя текущего пользователя, вошедшего в систему.
источник
Задает файлы для копирования.
путь\точка_назначения
Задает путь каталога для входа в систем на удаленном узле. Для задания пути на удаленном компьютере используются подстановочные знаки (\ , " или '). При задании нескольких исходных файлов точкой назначения является каталог.
/?
Отображает справку в командной строке.

Примечания

  • Передача данных кому-либо еще ( третьей стороне).

    Команду rcp, осуществляющую подключение, можно также использовать для передачи файлов третьй стороне. Команду rcp можно запустить с компьютера с системой Windows XP для копирования файлов между двумя компьютерами, на которых запущены серверы rshd. Сервер (демон) rshd доступен на компьютерах с системой UNIX, поэтому компьютер под управлением Windows XP при передаче данных третьей стороне может выступать только в роли компьютера, с которого запускаются команды.

  • Использование параметра -r

    И источник, и путь\точка_назначения должны быть каталогами. Если источник не является каталогом, параметр -r можно использовать без рекурсии.

  • Использование параметров источник и путь\точка_назначения

    Если имя файла не начинается с косой черты (/) для системы UNIX или обратной косой черты (\) для системы Windows XP, предполагается, что местоположение файла указано относительно текущего рабочего каталога. Для системы Windows XP — это каталог, из которого запущена команда. Для удаленной системы — это каталог входа удаленного пользователя в систему. Точка (.) указывает на текущий каталог. При задании пути на удаленном компьютере для указания подстановочных знаков следует использовать управляющие символы (\ , " или ').

  • Права доступа на удаленной системе

    Команда rcp не запрашивает пароль. Имя текущего или заданного пользователя должно существовать на удаленном компьютере и допускать выполнение команды rcp.

  • Файл .rhosts

    Файл .rhosts задает имена удаленных систем и пользователей, которым разрешен доступ к локальным ресурсам с использованием команд rsh или rcp. Этот файл (или его эквивалент, HOSTS) требуется для доступа к удаленной системе, использующей эти команды. Команды rsh и rcp, передают имя локального пользователя удаленной системе. Удаленная система использует это имя и IP-адрес (обычно сопоставляемый с именем компьютера) запрашиваемой системы для предоставления доступа. Пароль для доступа к ресурсам с использованием этих команд не требуется.

    Если пользователь подключен к домену, основной контроллер домена должен быть доступен для сопоставления имени входа в систему, так как имя не кэшируется на локальном компьютере. Поскольку имя пользователя является частью протокола rsh, команда не будет выполняться, если его нельзя получить.

    Файл .rhosts — это текстовый файл, каждая строка которого является записью. Запись включает имя локального компьютера, имя локального пользователя и произвольный комментарий. Каждое поле отделяется символом табуляции или пробелом, комментарий начинается со знака (#), например:

    computer5marie #Этот компьютер находится в комнате 31A

    Файл .rhosts должен находиться в основном каталоге пользователя на удаленном компьютере. Дополнительные сведения о специфическом использовании файла .rhosts на удаленном компьютере см. в документации удаленного компьютера.

    Кроме того, можно добавить имя компьютера в файл /Etc/Hosts на удаленном компьютере. Это позволит удаленной системе проверять подлинность удаленных запросов к компьютеру с использованием TCP/IP-утилит Windows XP.

  • Задание имен компьютеров (узлов)

    Для использования имени пользователя, отличающегося от имени текущего пользователя задайте компьютер.пользователь. Если параметр компьютер.пользователь задан вместе с источником, файл .rhosts на удаленном компьютере должен содержать следующую запись для пользователя :

    rcp host99.user7:file1 corp7.admin:file2

    Файл .rhosts на компьютере corp7 должен иметь запись для пользователя user7 , подключенного к компьютеру host99.

    Если имя компьютера задано как полное доменное имя, содержащее точки, имя пользователя должно быть добавлено к имени компьютера, как было описано выше. Иначе последняя часть имени домена будет рассматриваться как имя пользователя, как показано ниже:

    rcp domain-name1.user:user92 domain-name2.user:user7

  • Удаленная обработка

    На большинстве систем UNIX удаленная обработка производится командой, запускаемой пользовательской оболочкой. Файлы .profile или .cshrc исполняются до анализа имен файлов, что позволяет использовать экспортируемые переменные оболочки (выделяя их кавычками или управляющими символами) в именах файлов удаленной системы.

  • Копирование файлов

    При попытке копировать несколько файлов в файл, а не в каталог, будет скопирован только последний файл из списка. Команда rcp не копирует файл сам в себя (источник и точка назначения не должны быть одинаковыми.)

    Если пользователь подключен к компьютеру с Windows XP Professional с помощью имени домена, отличного от локального, а основной контроллер домена недоступен, то при команда rcp сбойнет, так как не сможет определит локальное имя пользователя. Это же ограничение действует и для команды rsh.

  • Эта команда доступна только если в свойствах сетевого адаптера в объекте Сетевые подключения в качестве компонента установлен протокол Интернета (TCP/IP).

Примеры

Для копирования локального файла в каталог подключения удаленного компьютера введите:

rcp filename remotecomputer:

Для копирования локального файла в существующий каталог с новым именем файла на удаленном компьютере введите:

rcp filename remotecomputer:/directory/newfilename

Для копирования нескольких локальных файлов в подкаталог в удаленном каталоге подключения введите:

rcp file1 file2 file3 remotecomputer:subdirectory/filesdirectory

Для копирования из удаленного источника в текущий каталог на локальном компьютере введите:

rcp remotecomputer:filename

Для копирования нескольких файлов с удаленных компьютеров на удаленный компьютер с другим именем пользователя введите:

rcp remote1.user1:file1 remote2.user2:file2 remotedest.destuser:directory


Hostname

Отображение имени узла, входящего в состав полного имени компьютера.

Синтаксис

hostname

Параметры

/?
Отображение справки в командной строке.

Заметки

  • Эта команда доступна, только если в свойствах сетевого адаптера в объекте Сетевые подключения в качестве компонента установлен протокол Интернета (TCP/IP).

Примеры

Чтобы просмотреть имя компьютера, введите:

hostname


Rexec

Запускает команды на удаленных компьютерах с работающей службой Rexec. Команда rexec проверяет подлинность имени пользователя на удаленном компьютере до выполнения определенной команды. Операционные системы Windows XP и Windows 2000 не предоставляют возможности службы Rexec. Запущенная без параметров команда rexec выводит справку.

Синтаксис

rexec [узел] [-l имя_пользователя] [-n] [команда]

Параметры

узел
Указывает имя или IP-адрес удаленного узла (компьютера), на котором необходимо выполнить команду.
-l имя_пользователя
Задает имя пользователя, которое будет использовано на удаленном компьютере. Если этот параметр опущен, используется имя текущего пользователя, вошедшего в систему.
-n
Перенаправляет ввод команды rexec с устройства NUL. Это предотвращает отображение результатов команды на локальном компьютере.
команда
Задает команду, которая будет запущена на удаленном компьютере.
/?
Отображает справку в командной строке.

Примечания

  • Стандартные операции

    Команда rexec запрашивает пароль пользователя и проверяет его на удаленном компьютере. Заданная команда будет выполняться после подтверждения подлинности пароля.

    Команда rexec копирует стандартный ввод в удаленную команду, стандартный вывод удаленной команды в свой стандартный поток вывода и стандартные ошибки удаленной команды в свой стандартный поток сообщений об ошибках. Команда rexec обычно завершает работу после окончания работы удаленной команды.

  • Использование символов перенаправления

    Для выполнения перенаправления на удаленном компьютере следует заключать символы перенаправления в кавычки (например, ">>"). При отсутствии кавычек перенаправление выполняется на локальном компьютере. Например, следующая команда будет добавлять удаленный файл уд_файл к локальному файлу лок_файл:

    rexec уд_компьютер cat уд_файл >> лок_файл

    Следующая команда будет добавлять удаленный файл уд_файл1 к файлу уд_файл2 на удаленном компьютере:

    rexec уд_компьютер cat уд_файл1">>" уд_файл2

  • Интерактивные команды

    Большинство интерактивных команд не могут быть запущены командой rexec. Например, командой rexec не могут быть запущены программы vi или emacs. Однако, имеется возможность использовать команды telnet.

  • Эта команда доступна, только если в свойствах сетевого адаптера в объекте Сетевые подключения в качестве компонента установлен протокол Интернета (TCP/IP).

Примеры

Чтобы выполнить команду telcon на удаленном компьютере «vax1», используя имя «admin1», введите следующую команду:

rexec vax1 -l admin1 telcon


Ipconfig

Служит для отображения всех текущих параметров сети TCP/IP и обновления параметров DHCP и DNS. При вызове команды ipconfig без параметров выводится только IP-адрес, маска подсети и основной шлюз для каждого сетевого адаптера.

Синтаксис

ipconfig [/all] [/renew [адаптер]] [/release [адаптер]] [/flushdns] [/displaydns] [/registerdns] [/showclassid адаптер] [/setclassid адаптер [код_класса]]

Параметры

/all
Вывод полной конфигурации TCP/IP для всех адаптеров. Без этого параметра команда ipconfig выводит только IP-адреса, маску подсети и основной шлюз для каждого адаптера. Адаптеры могут представлять собой физические интерфейсы, такие как установленные сетевые адаптеры, или логические интерфейсы, такие как подключения удаленного доступа.
/renew [адаптер]
Обновление конфигурации DHCP для всех адаптеров (если адаптер не задан) или для заданного адаптера. Данный параметр доступен только на компьютерах с адаптерами, настроенными для автоматического получения IP-адресов. Чтобы указать адаптер, введите без параметров имя, выводимое командой ipconfig.
/release [адаптер]
Отправка сообщения DHCPRELEASE серверу DHCP для освобождения текущей конфигурации DHCP и удаление конфигурации IP-адресов для всех адаптеров (если адаптер не задан) или для заданного адаптера. Этот адаптер отключает протокол TCP/IP для адаптеров, настроенных для автоматического получения IP-адресов. Чтобы указать адаптер, введите без параметров имя, выводимое командой ipconfig.
/flushdns
Сброс и очистка содержимого кэша сопоставления имен DNS клиента. Во время устранения неполадок DNS эту процедуру используют для удаления из кэша записей отрицательных попыток сопоставления и других динамически добавляемых записей.
/displaydns
Отображение содержимого кэша сопоставления имен DNS клиента, включающего записи, предварительно загруженные из локального файла Hosts, а также последние полученные записи ресурсов для запросов на сопоставление имен. Эта информация используется службой DNS клиента для быстрого сопоставления часто встречаемых имен без обращения к указанным в конфигурации DNS-серверам.
/registerdns
Динамическая регистрация вручную имен DNS и IP-адресов, настроенных на компьютере. Этот параметр полезен при устранении неполадок в случае отказа в регистрации имени DNS или при выяснении причин неполадок динамического обновления между клиентом и DNS-сервером без перезагрузки клиента. Имена, зарегистрированные в DNS, определяются параметрами DNS в дополнительных свойствах протокола TCP/IP.
/showclassid адаптер
Отображение кода класса DHCP для указанного адаптера. Чтобы просмотреть код класса DHCP для всех адаптеров, вместо параметра адаптер укажите звездочку (*). Данный параметр доступен только на компьютерах с адаптерами, настроенными для автоматического получения IP-адресов.
/setclassid адаптер [код_класса]
Задание кода класса DHCP для указанного адаптера. Чтобы задать код класса DHCP для всех адаптеров, вместо параметра адаптер укажите звездочку (*). Данный параметр доступен только на компьютерах с адаптерами, настроенными для автоматического получения IP-адресов. Если код класса DHCP не задан, текущий код класса удаляется.
/?
Отображение справки в командной строке.

Заметки

  • Команда ipconfig является эквивалентом для командной строки команды winipcfg, имеющейся в Windows Millennium Edition, Windows 98 и Windows 95. Хотя Windows XP не имеет графического эквивалента команде winipcfg, для просмотра и обновления IP-адреса можно воспользоваться окном «Сетевые подключения». Для этого откройте окно Сетевые подключения, щелкните правой кнопкой мыши сетевое подключение, выберите команду Состояние, а затем откройте вкладку Поддержка.
  • Данная команда доступна только на компьютерах с адаптерами, настроенными для автоматического получения IP-адресов. Это позволяет пользователям определять, какие значения конфигурации были получены с помощью DHCP, APIPA или другой конфигурации.
  • Если имя адаптер содержит пробелы, его следует заключать в кавычки (т. е. "имя_адаптера").
  • В именах адаптеров, задаваемых для команды ipconfig, поддерживается использование подстановочного знака звездочки (*) для задания имен, начинающихся с указанной строки или содержащих указанную строку. Например, имя Подкл* будет включать все адаптеры, начинающиеся со строки «Подкл», а имя *сет* — все адаптера, содержащие строку «сет».
  • Эта команда доступна, только если в свойствах сетевого адаптера в объекте Сетевые подключения в качестве компонента установлен протокол Интернета (TCP/IP).

Примеры

Чтобы вывести основную конфигурацию TCP/IP для всех адаптеров, введите:

ipconfig

Чтобы вывести полную конфигурацию TCP/IP для всех адаптеров, введите:

ipconfig /all

Чтобы обновить конфигурацию IP-адреса, назначенного DHCP-сервером, только для адаптера Подключение по локальной сети, введите:

ipconfig /renew "Подключение по локальной сети"

Чтобы сбросить кэш сопоставления имен DNS при наличии неполадок в сопоставлении имен, введите:

ipconfig /flushdns

Чтобы вывести код класса DHCP для всех адаптеров с именами, начинающимися со слова Подключение, введите:

ipconfig /showclassid Подключение*

Чтобы задать код класса DHCP TEST для адаптера Подключение по локальной сети, введите:

ipconfig /setclassid "Подключение по локальной сети" TEST


Route

Выводит на экран и изменяет записи в локальной таблице IP-маршрутизации. Запущенная без параметров, команда route выводит справку.

Синтаксис

route [-f] [-p] [команда [конечная_точка] [mask маска_сети] [шлюз] [metric метрика]] [if интерфейс]]

Параметры

-f
Очищает таблицу маршрутизации от всех записей, которые не являются узловыми маршрутами (маршруты с маской подсети 255.255.255.255), сетевым маршрутом замыкания на себя (маршруты с конечной точкой 127.0.0.0 и маской подсети 255.0.0.0) или маршрутом многоадресной рассылки (маршруты с конечной точкой 224.0.0.0 и маской подсети 240.0.0.0). При использовании данного параметра совместно с одной из команд (таких, как add, change или delete) таблица очищается перед выполнением команды.
-p
При использовании данного параметра с командой add указанный маршрут добавляется в реестр и используется для инициализации таблицы IP-маршрутизации каждый раз при запуске протокола TCP/IP. По умолчанию добавленные маршруты не сохраняются при запуске протокола TCP/IP. При использовании параметра с командой print выводит на экран список постоянных маршрутов. Все другие команды игнорируют этот параметр. Постоянные маршруты хранятся в реестре по адресу HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\PersistentRoutes
команда
Указывает команду, которая будет запущена на удаленной системе. В следующей таблице представлен список допустимых параметров.
Команда | Назначение
add | Добавление маршрута
change | Изменение существующего маршрута
delete | Удаление маршрута или маршрутов
print | Печать маршрута или маршрутов
конечная_точка
Определяет конечную точку маршрута. Конечной точкой может быть сетевой IP-адрес (где разряды узла в сетевом адресе имеют значение 0), IP-адрес маршрута к узлу, или значение 0.0.0.0 для маршрута по умолчанию.
mask маска_сети
Указывает маску сети (также известной как маска подсети) в соответствии с точкой назначения. Маска сети может быть маской подсети соответствующей сетевому IP-адресу, например 255.255.255.255 для маршрута к узлу или 0.0.0.0. для маршрута по умолчанию. Если данный параметр пропущен, используется маска подсети 255.255.255.255. Конечная точка не может быть более точной, чем соответствующая маска подсети. Другими словами, значение разряда 1 в адресе конечной точки невозможно, если значение соответствующего разряда в маске подсети равно 0.
шлюз
Указывает IP-адрес пересылки или следующего перехода, по которому доступен набор адресов, определенный конечной точкой и маской подсети. Для локально подключенных маршрутов подсети, адрес шлюза — это IP-адрес, назначенный интерфейсу, который подключен к подсети. Для удаленных маршрутов, которые доступны через один или несколько маршрутизаторов, адрес шлюза — непосредственно доступный IP-адрес ближайшего маршрутизатора.
metric метрика
Задает целочисленную метрику стоимости маршрута (в пределах от 1 до 9999) для маршрута, которая используется при выборе в таблице маршрутизации одного из нескольких маршрутов, наиболее близко соответствующего адресу назначения пересылаемого пакета. Выбирается маршрут с наименьшей метрикой. Метрика отражает количество переходов, скорость прохождения пути, надежность пути, пропускную способность пути и средства администрирования.
if интерфейс
Указывает индекс интерфейса, через который доступна точка назначения. Для вывода списка интерфейсов и их соответствующих индексов используйте команду route print. Значения индексов интерфейсов могут быть как десятичные, так и шестнадцатеричные. Перед шестнадцатеричными номерами вводится 0х. В случае, когда параметр if пропущен, интерфейс определяется из адреса шлюза.
/?
Отображает справку в командной строке.

Примечания

  • Большие значения в столбце metric таблицы маршрутизации — результат возможности протокола TCP/IP автоматически определять метрики маршрутов таблицы маршрутизации на основании конфигурации IP-адреса, маски подсети и стандартного шлюза для каждого интерфейса ЛВС. Автоматическое определение метрики интерфейса, включенное по умолчанию, устанавливает скорость каждого интерфейса и метрики маршрутов для каждого интерфейса так, что самый быстрый интерфейс создает маршруты с наименьшей метрикой. Чтобы удалить большие метрики, отключите автоматическое определение метрики интерфейса в дополнительных свойствах протокола TCP/IP для каждого подключения по локальной сети.
  • Имена могут использоваться для параметра конечная_точка, если существует соответствующая запись в файле базы данных Networks, находящемся в папке системный_корневой_каталог\System32\Drivers\Etc. В параметре шлюз можно указывать имена до тех пор, пока они разрешаются в IP-адреса с помощью стандартных способов разрешения узлов, таких как запрос службы DNS, использование локального файла Hosts, находящегося в папке системный_корневой_каталог\system32\drivers\etc, или разрешение имен NetBIOS.
  • Если команда — print или delete, параметр шлюз опускается и используются подстановочные знаки для указания точки назначения и шлюза. Значение конечной_точки может быть подстановочным значением, которое указывается звездочкой (*). При наличии звездочки (*) или вопросительного знака (?) в описании конечной точки, они рассматриваются как подстановки, тогда печатаются или удаляются только маршруты, соответствующие точке назначения. Звездочка соответствует любой последовательности символов, а вопросительный знак — любому одному символу. 10.*.1, 192.168.*, 127.* и *224* являются допустимыми примерами использования звездочки в качестве подстановочного символа.
  • При использовании недопустимой комбинации значений конечной точки и маски подсети (маски сети) выводится следующее сообщение об ошибке : «Маршрут: неверная маска подсети адреса шлюза». Ошибка появляется, когда одно или несколько значений разрядов в адресе конечной точки равно 1, а значения соответствующих разрядов маски подсети — 1. Для проверки этого состояния выразите конечную точку и маску подсети в двоичном формате. Маска подсети в двоичном формате состоит из последовательности единичных битов, представляющей часть сетевого адреса конечной точки, и последовательности нулевых битов, обозначающей часть адреса узла конечной точки. Проверьте наличие единичных битов в части адреса точки назначения, которая является адресом узла (как определено маской подсети).
  • Параметр -p поддерживается в команде route только в операционных системах Windows NT 4.0, Windows 2000, Windows Millennium Edition и Windows XP. Этот параметр не поддерживается командой route в системах Windows 95 и Windows 98.
  • Эта команда доступна, только если в свойствах сетевого адаптера в объекте Сетевые подключения в качестве компонента установлен протокол Интернета (TCP/IP).

Примеры

Чтобы вывести на экран все содержимое таблицы IP-маршрутизации, введите команду:

route print

Чтобы вывести на экран маршруты из таблицы IP-маршрутизации, которые начинаются с 10., введите команду:

route print 10.*

Чтобы добавить маршрут по умолчанию с адресом стандартного шлюза 192.168.12.1, введите команду:

route add 0.0.0.0 mask 0.0.0.0 192.168.12.1

Чтобы добавить маршрут к конечной точке 10.41.0.0 с маской подсети 255.255.0.0 и следующим адресом перехода 10.27.0.1, введите команду:

route add 10.41.0.0 mask 255.255.0.0 10.27.0.1

Чтобы добавить постоянный маршрут к конечной точке 10.41.0.0 с маской подсети 255.255.0.0 и следующим адресом перехода 10.27.0.1, введите команду:

route -p add 10.41.0.0 mask 255.255.0.0 10.27.0.1

Чтобы добавить маршрут к конечной точке 10.41.0.0 с маской подсети 255.255.0.0 и следующим адресом перехода 10.27.0.1 и метрикой стоимости 7, введите команду:

route add 10.41.0.0 mask 255.255.0.0 10.27.0.1 metric 7

Чтобы добавить маршрут к конечной точке 10.41.0.0 с маской подсети 255.255.0.0 и следующим адресом перехода 10.27.0.1 и использованием индекса интерфейса 0х3, введите команду:

route add 10.41.0.0 mask 255.255.0.0 10.27.0.1 if 0x3

Чтобы удалить маршрут к конечной точке 10.41.0.0 с маской подсети 255.255.0.0, введите команду:

route delete 10.41.0.0 mask 255.255.0.0

Чтобы удалить все маршруты из таблицы IP-маршрутизации, которые начинаются с 10., введите команду:

route delete 10.*

Чтобы изменить следующий адрес перехода для маршрута с конечной точкой 10.41.0.0 и маской подсети 255.255.0.0 с 10.27.0.1 на 10.27.0.25, введите команду:

route change 10.41.0.0 mask 255.255.0.0 10.27.0.25


Lpq

Служит для отображения состояния очереди печати на компьютере, использующем программное обеспечение сервера печати Line Printer Daemon (LPD). При вызове команды lpq без параметров в командной строке отображается справка по команде lpq.

Синтаксис

lpq -S имя_сервера -P имя_принтера [-l]

Параметры

-S имя_сервера
Обязательный параметр. Имя компьютера, на котором находится очередь печати, состояние которой требуется просмотреть.
-P имя_принтера
Обязательный параметр. Имя принтера, состояние очереди печати которого требуется просмотреть.
-l
Отображение сведений о состоянии очереди печати.
/?
Отображение справки в командной строке.


Rsh

Выполняет команды на удаленном компьютере, на котором запущена служба RSH или демон. Windows XP и Windows 2000 не поддерживают службу RSH. Службу RSH с именем Rshsvc.exe предоставляет пакет «Windows 2000 Server Resource Kit». Used without parameters, rsh displays help.

Синтаксис

rsh [узел] [-l имя_пользователя] [-n] [команда]

Параметры

узел
Задает удаленный узел (компьютер), на котором запускается команда.
-l имя_пользователя
Задает имя пользователя, используемое при подключении к удаленной системе. Если этот параметр опущен, используется имя текущего пользователя, вошедшего в систему.
-n
Перенаправляет ввод команды rsh с устройства NUL. Это предотвращает отображение результатов команды на локальном компьютере.
команда
Указывает команду, которая будет запущена на удаленной системе.
/?
Отображает справку в командной строке.

Примечания

  • Стандартные операции

    Команда rsh копирует стандартный ввод в удаленную команду, стандартный вывод удаленной команды в свой стандартный поток вывода и стандартные ошибки удаленной команды в свой стандартный поток сообщений об ошибках. Команда Rsh обычно заканчивает работу после окончания работы удаленной команды.

  • Использование символов перенаправления

    Заключайте символы перенаправления в кавычки для выполнения перенаправления на удаленном компьютере (например, ">>"). При отсутствии кавычек перенаправление выполняется на локальном компьютере. Например, следующая команда будет добавлять удаленный файл уд_файл к локальному файлу лок_файл:

    rsh уд_компьютер cat уд_файл >> лок_файл

    Следующая команда будет добавлять удаленный файл уд_файл1 к файлу уд_файл2 на удаленном компьютере:

    rsh уд_компьютер cat уд_файл1">>" уд_файл2

  • Использование команды rsh

    При использовании компьютера, который находится под управлением Windows XP Professional и входит в домен, должен быть доступен основной контроллер домена для проверки имени пользователя, в противном случае, команда rsh не выполняется.

  • Файл .rhosts

    Файл .rhosts обычно управляет правами сетевого доступа к UNIX системам. В этом файле перечислены имена компьютеров и соответствующие имена пользователей, которые имеют доступ к удаленным компьютерам. При обращении к удаленной системе с правильно настроенным файлом .rhosts с помощью команд rcp, rexec и rsh ввод имени пользователя и пароля не требуется.

    Файл .rhosts является текстовым файлом, в котором каждая строка является записью. Запись состоит из локального имени компьютера, локального имени пользователя и произвольного комментария. Каждое поле отделяется символом табуляции или пробелом, комментарий начинается со знака (#), например: Например:

    узел7 #Этот компьютер находится в комнате 31A

    Файл .rhosts должен находиться в основном каталоге пользователя на удаленном компьютере. Дополнительные сведения о специфической реализации файла .rhosts на удаленном компьютере см. в документации удаленного компьютера.

  • Эта команда доступна, только если в свойствах сетевого адаптера в объекте Сетевые подключения в качестве компонента установлен протокол Интернета (TCP/IP).

Примеры

Чтобы выполнить команду telcon на удаленном компьютере «vax1», используя имя «admin1», введите следующую команду:

rsh vax1 -l admin1 telcon


Lpr

Служит для отправки файла на компьютер, использующий программное обеспечение сервера печати Line Printer Daemon (LPD), для подготовки к печати. При вызове команды lpr без параметров в командной строке отображается справка по команде lpr.

Синтаксис

lpr [-S сервера] -P имя_принтера [-C титульный_лист] [-J имя_задания] [{-o | -o l}] [-d] [-x] имя_файла

Параметры

-S сервера
Имя или IP-адрес компьютера, к которому подключен принтер, на котором требуется напечатать файл. Этот параметр не следует задавать, если принтер подключен к локальному компьютеру.
-P имя_принтера
Обязательный параметр. Имя принтера, на котором требуется напечатать файл.
-C титульный_лист
Текст для печати на титульном листе задания печати. Если этот параметр не задан, на титульном листе будет напечатано имя компьютера, с которого поступило задание печати.
-J имя_задания
Имя задания, которое будет напечатано на титульной странице. Если этот параметр не задан, на титульной странице будет напечатано имя файла.
{-o | -o l}
Тип файла, который требуется напечатать. Параметр -o задает печать текстового файла. Параметр -o l задает печать двоичного файла (например PostScript).
-d
Отправка файла данных перед управляющим файлом. Этот параметр следует использовать, если сначала требуется отправить файл данных. Дополнительные сведения можно найти в документации по принтеру.
-x
Включение совместимости команды lpr с операционной системой Sun Microsystems, выпуски которой до версии 4.1.4_u1 включительно назывались SunOS.
имя_файла
Обязательный параметр. Имя файла, который требуется напечатать.
/?
Отображение справки в командной строке.

Заметки

  • Чтобы найти имя принтера, откройте папку «Принтеры и факсы».


Tftp

Осуществляет обмен файлами с удаленным компьютером, обычно с компьютером под управлением UNIX, на котором выполняется служба или демон протокола Trivial File Transfer Protocol (TFTP). Запущенная без параметров, команда tftp выводит справку.

Синтаксис

tftp [-i] [узел] [{get | put}] [источник] [результат]

Параметры

-i
Задает режим передачи двоичных файлов (иногда называемых режимом октета). В двоичном режиме файлы передаются по байту. Режим используется при передаче двоичных файлов. Если ключ -i не задан, передача производится в текстовом режиме ASCII. Этот режим используется по умолчанию. Режим передачи двоичных файлов преобразует символы конца строки (EOL) в соответствующий формат данного компьютера. Режим используется при передаче текстовых файлов. При успешном завершении процесса передачи на экран выводится значение скорости передачи.
узел
Указывает имя локального или удаленного компьютера.
put
Передает файл источник с локального компьютера в файл результат на удаленном компьютере. Так как протокол TFTP не поддерживает проверку полномочий пользователя, пользователь должен войти в систему на удаленном компьютере и иметь права записи файлов.
get
Передает файл источник с удаленного компьютера в файл результат на локальном компьютере.
Источник
Задает имя файла для передачи.
результат
Задает, куда записывать получаемый файл. Если имя результата не задано, будет использовано имя источника.
/?
Отображает справку в командной строке.

Примечания

  • Использование параметра get

    Команда put используется для передачи файлов с локального на удаленный компьютер. Команда get используется для передачи файлов с удаленного компьютера на локальный.

  • Windows XP или Windows 2000 не предоставляет сервер общего назначения TFTP. Windows 2000 предоставляет службу сервера TFTP только для обеспечения возможности удаленной загрузки на компьютерах-клиентах под управлением Windows XP или Windows 2000.
  • Эта команда доступна, только если в свойствах сетевого адаптера в объекте Сетевые подключения в качестве компонента установлен протокол Интернета (TCP/IP).

Примеры

Чтоб передать файл Users.txt с локального компьютера в файл Users19.txt на удаленный компьютер с именем vax1, введите следующую команду:

tftp vax1 put users.txt users19.txt


Nbtstat

Служит для отображения статистики протокола NetBIOS over TCP/IP (NetBT), таблиц имен NetBIOS для локального и удаленного компьютеров, а также кэша имен NetBIOS. Команда Nbtstat позволяет обновить кэш имен NetBIOS и имена, зарегистрированные в службе имен Интернета Windows (WINS). Запущенная без параметров, команда nbtstat выводит справку.

Синтаксис

nbtstat [-a удаленное_имя] [-A IP-адрес] [-c] [-n] [-r] [-R] [-RR] [-s] [-S] [интервал]

Параметры

-a удаленное_имя
Отображение таблицы имен NetBIOS удаленного компьютера, где удаленное_имя является именем NetBIOS удаленного компьютера. Таблица имен NetBIOS является списком имен NetBIOS, соответствующих приложениям NetBIOS, работающим на данном компьютере.
-A IP-адрес
Отображение таблицы имен NetBIOS удаленного компьютера, заданного IP-адресом (десятичные числа, разделенные точками).
-c
Отображение содержимого кэша имен NetBIOS, таблицы имен NetBIOS и их разрешенных IP-адресов.
-n
Отображение таблицы имен NetBIOS локального компьютера. Состояние Зарегистрирован означает, что это имя зарегистрировано на сервере WINS или в качестве широковещательного адреса.
-r
Отображение статистики разрешения имен NetBIOS. На компьютере Windows XP, настроенном для использования WINS, этот параметр возвращает количество имен, разрешенных и зарегистрированных для широковещательной рассылки или WINS.
-R
Очистка содержимого кэша имен NetBIOS и перезагрузка записей #PRE из файла Lmhosts.
-RR
Освобождение и обновление имен NetBIOS для локального компьютера, зарегистрированного на серверах WINS.
-s
Отображение сеансов клиента и сервера NetBIOS с попыткой преобразования конечного IP-адреса в имя.
-S
Вывод сведений о работе сервера и клиента NetBIOS; удаленные компьютеры выводятся только по IP-адресам.
интервал
Обновление выбранной статистики на экране через промежутки времени, заданные значением интервал. Нажатие клавиш CTRL+C останавливает обновление статистики. Если этот параметр не задан, команда nbtstat выводит сведения о текущей конфигурации один раз.
/?
Отображение справки в командной строке.

Заметки

  • При задании параметров команды nbtstat учитывается регистр символов.
  • В следующей таблице приведены заголовки столбцов, отображаемые программой nbtstat.
    Заголовок | Описание
    Ввод | Число полученных байт.
    Вывод | Число отправленных байт.
    Вид | Направление передачи от локального компьютера (Исх) или от удаленного компьютера (Вхд).
    Время жизни | Время, оставшееся до сброса элемента кэша таблицы имен.
    Локальное имя | Локальное имя NetBIOS, соответствующее данному подключению.
    Удаленный узел | Имя или IP-адрес удаленного компьютера.
    <03> | Последний байт имени NetBIOS, преобразованный в шестнадцатеричную форму. Каждое имя NetBIOS может иметь длину 16 знаков. Последний байт часто имеет специальное значение, так как одно имя может встречаться несколько раз на одном компьютере, различаясь только последним байтом. Например, код <20> представляет собой пробел.
    Тип | Тим имени. Имя может быть уникальным именем или именем группы.
    Состояние | «Зарегистрирован» (служба NetBIOS работает на удаленном компьютере) или «Конфликт» (в службе уже зарегистрировано такое же имя компьютера).
    Состояние | Состояние подключений NetBIOS.
  • В следующей таблице приведены возможные состояния подключения NetBIOS.
    Состояние | Описание
    Подключен | Сеансовое подключение установлено.
    Назначен | Конечная точка подключения создана и связана с IP-адресом.
    Ожидание | Конечная точка доступна для входящих подключений.
    Простаивает | Конечная точка создана, но подключение не получено.
    Подключается | Сеанс в состоянии подключения, сопоставление имени и IP адреса для точки назначения определено.
    Прием | Запрос на входящее подключение принят, подключение будет установлено.
    Повторное подключение | Повторная попытка установки подключения (после первой неудачной попытки).
    Исходящий | Сеанс находится в процессе подключения, создается подключение TCP.
    Входящий | Сеанс находится в процессе подключения.
    Отключение | Сеанс находится в процессе отключения.
    Отключен | Локальный компьютер отправил запрос на отключение и ожидает подтверждения от удаленной системы.
  • Эта команда доступна, только если в свойствах сетевого адаптера в объекте Сетевые подключения в качестве компонента установлен протокол Интернета (TCP/IP).

Примеры

Чтобы вывести таблицу имен удаленного компьютера, имеющего имя NetBIOS CORP07, введите:

nbtstat -a CORP07

Чтобы вывести таблицу имен NetBIOS удаленного компьютера, имеющего IP-адрес 10.0.0.99, введите:

nbtstat -A 10.0.0.99

Чтобы вывести таблицу имен локального компьютера, введите:

nbtstat -n

Чтобы вывести содержимое кэша имен NetBIOS локального компьютера, введите:

nbtstat -c

Чтобы очистить кэш имен NetBIOS и перезагрузить записи #PRE из локального файла Lmhosts, введите:

nbtstat -R

Чтобы освободить имена NetBIOS, зарегистрированные на сервере WINS, и снова зарегистрировать их, введите:

nbtstat -RR

Чтобы просмотреть статистику сеанса NetBIOS по IP-адресу с обновлением каждые пять секунд, введите:

nbtstat -S 5


Tracert

Определяет путь до точки назначения с помощью посылки в точку назначения эхо-сообщений протокола Control Message Protocol (ICMP) с постоянным увеличением значений срока жизни (Time to Live, TTL). Выведенный путь — это список ближайших интерфейсов маршрутизаторов, находящихся на пути между узлом источника и точкой назначения. Ближний интерфейс представляют собой интерфейс маршрутизатора, который является ближайшим к узлу отправителя на пути. Запущенная без параметров, команда tracert выводит справку.

Синтаксис

tracert [-d] [-h максимальное_число_переходов] [-j список_узлов] [-w интервал] [имя_конечного_компьютера]

Параметры

-d
Предотвращает попытки команды tracert разрешения IP-адресов промежуточных маршрутизаторов в имена. Увеличивает скорость вывода результатов команды tracert.
-h максимальное_число_переходов
Задает максимальное количество переходов на пути при поиске конечного объекта. Значение по умолчанию равно 30.
-j список_узов
Указывает для сообщений с эхо-запросом использование параметра свободной маршрутизации в заголовке IP с набором промежуточных мест назначения, указанных в списке_узлов. При свободной маршрутизации успешные промежуточные места назначения могут быть разделены одним или несколькими маршрутизаторами. Максимальное число адресов или имен в списке — 9. Список_адресов представляет набор IP-адресов (в точечно-десятичной нотации), разделенных пробелами.
-w интервал
Определяет в миллисекундах время ожидания для получения эхо-ответов протокола ICMP или ICMP-сообщений об истечении времени, соответствующих данному сообщению эхо-запроса. Если сообщение не получено в течение заданного времени, выводится звездочка (*). Таймаут по умолчанию 4000 (4 секунды).
имя_конечного_компьютера
Задает точку назначения, указанную IP-адресом или именем узла.
-?
Отображает справку в командной строке.

Примечания

  • Диагностическое средство, предназначенное для определения маршрута до точки назначения с помощью посылки в точку назначения эхо-запросов протокола Internet Control Message Protocol (ICMP) с различными значениями срока жизни (TTL, Time-To-Live). Каждый маршрутизатор, через который проходит путь, обязан перед дальнейшей пересылкой пакета уменьшить значение его поля TTL по меньшей мере на 1. Фактически, TTL — счетчик узлов. Предполагается, что когда параметр TTL становится равен 0, маршрутизатор посылает системе-источнику сообщение ICMP об истечении времени. Команда tracert определяет маршрут, посылая первый эхо-запрос с полем TTL, равным 1, и увеличивая значение этого поля на единицу для каждого последующего отправляемого эхо-пакета до тех пор, пока конечный узел не ответит или пока не будет достигнуто максимальное значение поля TTL. Максимальное количество переходов по умолчанию равно 30 и может быть изменено с помощью параметра -h. Путь определяется из анализа сообщений ICMP об истечении времени, полученных от промежуточных маршрутизаторов, и это-ответов точки назначения. Однако некоторые маршрутизаторы не посылают сообщений об истечении времени для пакетов с нулевыми значениями TTL и не видны для команды tracert. В этом случае для перехода отображается ряд звездочек (*).
  • Чтобы выполнить трассировку маршрута, вывести значение задержки распространения по сети и потерь пакета на каждом маршрутизаторе и узле в пути, используйте команду pathping.
  • Эта команда доступна, только если в свойствах сетевого адаптера в объекте Сетевые подключения в качестве компонента установлен протокол Интернета (TCP/IP).

Примеры

Чтобы выполнить трассировку пути к узлу corp7.microsoft.com, введите команду:

tracert corp7.microsoft.com

Чтобы выполнить трассировку пути к узлу corp7.microsoft.com и предотвратить разрешение каждого IP-адреса в имя, введите:

tracert -d corp7.microsoft.com

Чтобы выполнить трассировку пути к узлу corp7.microsoft.com и использовать узлы 10.12.0.1-10.29.3.1-10.1.44.1 для свободной маршрутизации, введите следующую команду:

tracert -j 10.12.0.1 10.29.3.1 10.1.44.1 corp7.microsoft.com


Netstat

Отображение активных подключений TCP, портов, прослушиваемых компьютером, статистики Ethernet, таблицы маршрутизации IP, статистики IPv4 (для протоколов IP, ICMP, TCP и UDP) и IPv6 (для протоколов IPv6, ICMPv6, TCP через IPv6 и UDP через IPv6). Запущенная без параметров, команда nbtstat отображает подключения TCP.

Синтаксис

netstat [-a] [-e] [-n] [-o] [-p протокол] [-r] [-s] [интервал]

Параметры

-a
Вывод всех активных подключений TCP и прослушиваемых компьютером портов TCP и UDP.
-e
Вывод статистики Ethernet, например количества отправленных и принятых байтов и пакетов. Этот параметр может комбинироваться с ключом -s.
-n
Вывод активных подключений TCP с отображением адресов и номеров портов в числовом формате без попыток определения имен.
-o
вывод активных подключений TCP и включение кода процесса (PID) для каждого подключения. Код процесса позволяет найти приложение на вкладке Процессы диспетчера задач Windows. Этот параметр может комбинироваться с ключами -a, -n и -p.
-p протокол
Вывод подключений для протокола, указанного параметром протокол. В этом случае параметр протокол может принимать значения tcp, udp, tcpv6 или udpv6. Если данный параметр используется с ключом -s для вывода статистики по протоколу, параметр протокол может иметь значение tcp, udp, icmp, ip, tcpv6, udpv6, icmpv6 или ipv6.
-s
Вывод статистики по протоколу. По умолчанию выводится статистика для протоколов TCP, UDP, ICMP и IP. Если установлен протокол IPv6 для Windows XP, отображается статистика для протоколов TCP через IPv6, UDP через IPv6, ICMPv6 и IPv6. Параметр -p может использоваться для указания набора протоколов.
-r
Вывод содержимого таблицы маршрутизации IP. Эта команда эквивалентна команде route print.
интервал
Обновление выбранных данных с интервалом, определенным параметром интервал (в секундах). Нажатие клавиш CTRL+C останавливает обновление. Если этот параметр пропущен, netstat выводит выбранные данные только один раз.
/?
Отображение справки в командной строке.

Примечания

  • Параметрам, используемым с данной командой, должен предшествовать дефис (-), а не косая черта (/).
  • Команда Netstat выводит статистику для следующих объектов.
    • Протокол

      Имя протокола (TCP или UDP).

    • Локальные адреса

      IP-адрес локального компьютера и номер используемого порта. Имя локального компьютера, соответствующее IP-адресу и имени порта, выводится только в том случае, если не указан параметр -n. Если порт не назначен, вместо номера порта будет выведена звездочка (*).

    • Внешние адреса

      IP-адрес и номер порта удаленного компьютера, подключенного к данному сокету. Имена, соответствующие IP-адресу и порту, выводятся только в том случае, если не указан параметр -n. Если порт не назначен, вместо номера порта будет выведена звездочка (*).

    • (Состояние)

      Указание состояния подключения TCP. Возможные значения:

      CLOSE_WAIT

      CLOSED

      ESTABLISHED

      FIN_WAIT_1

      FIN_WAIT_2

      LAST_ACK

      LISTEN

      SYN_RECEIVED

      SYN_SEND

      TIMED_WAIT

      • Для получения дополнительных сведений о состояниях подключения TCP см. документ RFC 793.

  • Эта команда доступна, только если в свойствах сетевого адаптера в объекте Сетевые подключения в качестве компонента установлен протокол Интернета (TCP/IP).

Примеры

Для вывода статистики Ethernet и статистики по всем протоколам введите следующую команду:

netstat -e -s

Для вывода статистики только по протоколам TCP и UDP введите следующую команду:

netstat -s -p tcp udp

Для вывода активных подключений TCP и кодов процессов каждые 5 секунд введите следующую команду:

nbtstat -o 5

Для вывода активных подключений TCP и кодов процессов каждые с использованием числового формата введите следующую команду:

nbtstat -n -o


Ping

С помощью отправки сообщений с эхо-запросом по протоколу ICMP проверяет соединение на уровне протокола IP с другим компьютером, поддерживающим TCP/IP. После каждой передачи выводится соответствующее сообщение с эхо-ответом. Ping - это основная TCP/IP-команда, используемая для устранения неполадки в соединении, проверки возможности доступа и разрешения имен. Команда ping, запущенная без параметров, выводит справку.

Синтаксис

ping [-t] [-a] [-n счетчик] [-l размер] [-f] [-i TTL] [-v тип] [-r счетчик] [-s счетчик] [{-j список_узлов | -k список_узлов}] [-w интервал] [имя_конечного_компьютера]

Параметры

-t
Задает для команды ping отправку сообщений с эхо-запросом к точке назначения до тех пор, пока команда не будет прервана. Для прерывания команды и вывода статистики нажмите комбинацию CTRL-BREAK. Для прерывания команды ping и выйхода из нее нажмите клавиши CTRL-C.
-a
Задает разрешение обратного имени по IP-адресу назначения. В случае успешного выполнения выводится имя соответствующего узла.
-n счетчик
Задает число отправляемых сообщений с эхо-запросом. По умолчанию — 4.
-l размер
Задает длину (в байтах) поля данных в отправленных сообщениях с эхо-запросом. По умолчанию — 32 байта. Максимальный размер — 65527.
-f
Задает отправку сообщений с эхо-запросом с флагом «Don't Fragment» в IP-заголовке, установленном на 1. Сообщения с эхо-запросом не фрагментируются маршрутизаторами на пути к месту назначения. Этот параметр полезен для устранения проблем, возникающих с максимальным блоком данных для канала (Maximum Transmission Unit).
-i TTL
Задает значение поля TTL в IP-заголовке для отправляемых сообщений с эхо-запросом. По умолчанию берется значение TTL, заданное по умолчанию для узла. Для узлов Windows XP это значение обычно равно 128. Максимальное значение TTL — 255.
-v тип
Задает значение поля типа службы (TOS) в IP-заголовке для отправляемых сообщений с эхо-запросом. По умолчанию это значение равно 0. тип — это десятичное значение от 0 до 255.
-r счетчик
Задает параметр записи маршрута (Record Route) в IP-заголовке для записи пути, по которому проходит сообщение с эхо-запросом и соответствующее ему сообщение с эхо-ответом. Каждый переход в пути использует параметр записи маршрута. По возможности значение счетчика задается равным или большим, чем количество переходов между источником и местом назначения. Параметр счетчик имеет значение от 1 до 9.
-s счетчик
Указывает вариант штампа времени Интернета (Internet Timestamp) в заголовке IP для записи времени прибытия сообщения с эхо-запросом и соответствующего ему сообщения с эхо-ответом для каждого перехода. Параметр счетчик имеет значение от 1 до 4.
-j список_узлов
Указывает для сообщений с эхо-запросом использование параметра свободной маршрутизации в IP-заголовке с набором промежуточных точек назначения, указанным в списке_узлов. При свободной маршрутизации последовательные промежуточные точки назначения могут быть разделены одним или несколькими маршрутизаторами. Максимальное число адресов или имен в списке узлов — 9. Список узлов — это набор IP-адресов (в точечно-десятичной нотации), разделенных пробелами.
-k список_узлов
Указывает для сообщений с эхо-запросом использование параметра строгой маршрутизации в IP-заголовке с набором промежуточных точек назначения, указанным в списке_узлов. При строгой маршрутизации следующая промежуточная точка назначения должна быть доступной напрямую (она должна быть соседней в интерфейсе маршрутизатора). Максимальное число адресов или имен в списке узлов равно 9. Список узлов — это набор IP-адресов (в точечно-десятичной нотации), разделенных пробелами.
-w интервал
Определяет в миллисекундах время ожидания получения сообщения с эхо-ответом, которое соответствует сообщению с эхо-запросом. Если сообщение с эхо-ответом не получено в пределах заданного интервала, то выдается сообщение об ошибке "Request timed out". Интервал по умолчанию равен 4000 (4 секунды).
имя_конечного_компьютера
Задает точку назначения, идентифицированную IP-адресом или именем узла.
/?
Отображает справку в командной строке.

Примечания

  • Команда ping позволяет проверить имя и IP-адрес компьютера. Если проверка IP-адреса успешная, и проверка имени — нет, то имеет место проблема разрешения имен. В этом случае с помощью запросов DNS (Domain Name System) или с помощью методов разрешения имен NetBIOS проверьте, чтобы имя задаваемого компьютера было разрешено в локальном файле Hosts.
  • Эта команда доступна только если в свойствах сетевого адаптера в объекте Сетевые подключения в качестве компонента установлен протокол Интернета (TCP/IP).

Примеры

Приведенный ниже пример содержит результаты работы команды ping:

C:\>ping example.microsoft.com

Pinging example.microsoft.com [192.168.239.132] with 32 bytes of data:

Reply from 192.168.239.132: bytes=32 time=101ms TTL=124

Reply from 192.168.239.132: bytes=32 time=100ms TTL=124

Reply from 192.168.239.132: bytes=32 time=101ms TTL=124

Reply from 192.168.239.132: bytes=32 time=101ms TTL=124

Для отправки сообщения точке назначения 10.0.99.221 и сопоставления с ее узловым именем введите:

ping -a 10.0.99.221

Для отправки точке назначения 10.0.99.221 десяти собщений с эхо-запросом, каждое из которых имеет поле данных из 1000 байт, введите:

ping -n 10 -l 1000 10.0.99.221

Для отправки сообщения точке назначения 10.0.99.221 и записи маршрута для 4 переходов введите:

ping -r 4 10.0.99.221

Для отправки сообщения точке назначения 10.0.99.221 и задания свободной маршрутизации для точек назначения 10.12.0.1-10.29.3.1-10.1.44.1 введите:

ping -j 10.12.0.1 10.29.3.1 10.1.44.1 10.0.99.221


Date

Отображение текущей настройки системной даты. Выполненная без параметров команда date выводит настройку текущей системной даты и приглашение ввести новую дату.

Синтаксис

date [мм-дд-гг] [/t]

Параметры

дд-мм-гг
Установка указанной даты, где мм — месяц, дд — день, гг — год.
/t
Вывод текущей даты без приглашения ввести новую дату.
/?
Отображение справки в командной строке.

Примечания

  • Значения параметров мм, дд и гг должны быть разделены точкой (.), знаком переноса (-) или косой чертой (/).
  • Параметр мм может принимать значения от 1 до 12.
  • Параметр дд может принимать значения от 1 до 31.
  • Параметр гг может принимать значения от 80 до 99 или от 1980 до 2099.
  • Система Windows XP автоматически изменяет текущие месяц и год в зависимости от количества дней в месяце (28, 29, 30 или 31 день).

Примеры

Чтобы изменить дату на 3 августа 2000г., введите одну из следующих команд:

08.03.00

08-03-00

08/03/00

Чтобы вывести текущую системную дату, введите следующую команду:

date /t


Defrag

Поиск и объединение фрагментированных файлов загрузки, файлов данных и папок на локальных томах.

Синтаксис

defrag том

defrag том [/a]

defrag том [/a] [/v]

defrag том [/v]

defrag том [/f]

Параметры

том
Буква диска или точка подключения тома, который требуется дефрагментировать.
/a
Анализ тома и вывод краткого отчета об анализе.
/v
Отображение полных отчетов об анализе и дефрагментации.

Если этот параметр используется вместе с параметром /a, выводится только отчет об анализе. Если данный параметр используется отдельно, выводятся отчеты как об анализе, так и о дефрагментации.

/f
Дефрагментация тома независимо от необходимости выполнения данной операции.
/?
Отображение справки в командной строке.

Примечания

  • Для полной и правильной дефрагментации с помощью команды defrag том должен иметь не менее 15% свободного пространства. Defrag использует этот объем как область для сортировки фрагментов файлов. Если объем составляет менее 15% свободного пространства, то команда defrag выполнит только частичную дефрагментацию. Чтобы освободить дополнительное место на диске, удалите ненужные файлы или переместите их на другой диск.
  • Тома, которые, возможно, повреждены, помечаются файловой системой как «грязные»; дефрагментация таких томов невозможна. Чтобы дефрагментировать «грязный» том, для него необходимо выполнить команду chkdsk. Определить, является ли том «грязным», можно с помощью команды fsutil dirty query.
  • В ходе анализа и дефрагментации тома в программе defrag отображается мигающий курсор. По завершении анализа и дефрагментации тома программа defrag выводит отчет об анализе, отчет о дефрагментации или оба этих отчета, после чего окно командной строки закрывается.
  • По умолчанию программа defrag выводит сводку обоих отчетов (об анализе и о дефрагментации), если не был введен параметр /a или /v.
  • Чтобы экспортировать отчеты в текстовый файл, введите параметр >имя_файла.txt, где имя_файла.txt — имя файла, задаваемое пользователем. Например:

    • defrag том /v >имя_файла.txt

  • Чтобы прервать процесс дефрагментации, нажмите клавиши CTRL+C в окне командной строки.
  • Ввод команды defrag и запуск программы «Дефрагментация диска» являются взаимно исключающими действиями. Если программа «Дефрагментация диска» используется для дефрагментации тома, а пользователь запускает команду defrag из командной строки, то команда defrag не выполняется. И наоборот, если команда defrag выполняется из командной строки, а пользователь открывает программу «Дефрагментация диска», то параметры дефрагментации в окне этой программы являются недоступными.


Del (erase)

Удаление заданных файлов.

Синтаксис

del [диск:][путь] имя_файла [ ...] [/p] [/f] [/s] [/q] [/a[:атрибуты]]

erase [диск:][путь] имя_файла [ ...] [/p] [/f] [/s] [/q] [/a[:атрибуты]]

Параметры

[диск:][путь] имя_файла
Задание расположения и имени файла для удаления. Параметр имя_файла является обязательным. Допускается использование нескольких имен файлов. Имена файлов следует разделять пробелом, запятой или точкой с запятой.
/p
Задание удаления с подтверждением для каждого файла.
/f
Задание удаления файлов с атрибутом «Только чтение».
/s
Удаление заданных файлов в каталоге и всех его подкаталогах. Выводит имена удаляемых файлов.
/q
Задание автоматического режима. Не выводится подтверждение на удаление.
/a
Удаление файлов с заданными атрибутами.
атрибуты
Задание следующих атрибутов файла.
Атрибут | Описание
r | Только чтение
a | Архивный
s | Системный
h | Скрытый
- | Префикс «нет»
/?
Отображение справки в командной строке.

Примечания

  • Использование /p

    Если задан параметр /p, команда del выводит на экран имя каждого удаляемого файла и следующее сообщение:

    имя_файла, Удалить [Y(да)/N(нет)]?

    Для подтверждения удаления следует нажать клавишу Y, для отмены удаления и перехода к следующему файлу следует нажать N (если задана группа файлов) или CRTL+C для остановки работы команды del.

  • Отключение расширений командного процессора

    Если расширения командного процессора отключены, параметр командной строки /s выводит все ненайденные, а не удаленные файлы (т. е. имеет противоположный смысл).

  • Удаление нескольких файлов

    Все файлы в каталоге могут быть удалены с помощью команды del с параметрами [диск:]путь. Например, следующая команда позволяет удалить все файлы в папке \Work:

    del \work

    Кроме того, для удаления нескольких файлов можно воспользоваться подстановочными знаками (* и ?). При использовании символов подстановки в команде del следует быть особенно внимательным во избежание нежелательных удалений. Например, можно ввести следующую команду:

    del *.*

    Команда del выводит следующий запрос:

    Все файлы в каталоге будут удалены. Продолжать [Y(да)/N(нет)]?

    Для удаления всех файлов в текущей папке следует нажать Y и ENTER, для отмены удаления — N и ENTER.

    Перед использованием команды del для удаления группы файлов, заданной с помощью символов подстановки, полезно вначале вызвать команду dir с теми же самыми символами для вывода списка файлов, которые будут удалены.

    Предупреждение!

    • После удаления файлов с диска с помощью команды del, их, возможно, уже не удастся восстановить.
  • Команда del с другими параметрами доступна в консоли восстановления.

Примеры

Чтобы удалить все файлы из папки Test на диске C, введите одну из следующих команд:

del c:\test

del c:\test\*.*


Устройство

Device

Загрузка в память указанного драйвера устройства.

Синтаксис

device=[диск:][путь] имя_файла [параметры]

Параметры

[диск:][путь] имя_файла
Задание месторасположения и имени файла драйвера устройства, который требуется загрузить. Параметр имя_файла является обязательным.
[параметры]
Задание параметров командной строки для драйвера устройства.
/?
Отображение справки в командной строке.

Примечания

  • Для загрузки драйверов, необходимых подсистеме MS-DOS, следует использовать файл системный_корневой_каталог\System32\Config.nt или эквивалентный загрузочный файл, заданный в файле описания программы (.PIF).

Примеры

Для использования управляющих последовательностей ANSI, работающих с дисплеем и клавиатурой подсистемы MS-DOS, в файл Config.nt или эквивалентный файл запуска требуется добавить следующую строку:

device=c:\winnt\system32\ansi.sys


Devicehigh

Загрузка драйвера устройства в верхнюю область памяти. Таким образом освобождается больший объем обычной памяти для использования другими программами. Для загрузки драйверов, необходимых подсистеме MS-DOS, следует использовать файл системный_корневой_каталог\System32\Config.nt или эквивалентный загрузочный файл, заданный в файле описания программы (.PIF).

Синтаксис

device=[диск:][путь] имя_файла [параметры]

devicehigh size=размер [диск:][путь] имя_файла [параметры]

Параметры

[диск:][путь] имя_файла
Задание местонахождения и имени файла драйвера устройства, который будет загружен в верхнюю область памяти. Параметр имя_файла является обязательным.
параметры
Задание параметров командной строки для драйвера устройства.
размер
Обязательный параметр. Задание минимального объема памяти (количество байт в шестнадцатеричном формате), который должен быть доступен, перед тем как команда devicehigh попытается загрузить драйвер в верхнюю память. Параметры size и размер должны присутствовать в строке команды, как показано выше.
/?
Отображение справки в командной строке.

Примечания

  • Использование команды dos=umb

    Для использования команды devicehigh необходимо включить команду dos=umb в файл Config.nt или эквивалентный загрузочный файл. Если это условие не выполнено, все драйверы устройств будут загружаться в обычную память, как при использовании команды device.

  • Установка драйвера Himem.sys

    Перед загрузкой драйверов устройств в верхнюю память с помощью команды device необходимо загрузить драйвер Himem.sys. Это нужно сделать перед использованием какой-либо команды devicehigh в файле Config.nt или эквивалентном загрузочном файле.

  • Ограничение размера

    Если указанный драйвер устройства попытается выделить блок верхней памяти, превышающий доступный размер, система может зависнуть. Чтобы избежать этого, используйте параметр размер. Параметр размер указывает количество памяти (в шестнадцатеричном формате), необходимое для данного драйвера. Чтобы узнать данную величину для определенного драйвера устройства, загрузите этот драйвер в обычную память и запустите команду mem /debug.

  • Загрузка в обычную память

    Если нет достаточного объема верхней памяти для загрузки драйвера устройства с помощью команды devicehigh, подсистема MS-DOS загрузит драйвер в обычную память (как при вызове команды device).

Примеры

Чтобы загрузить драйвер устройства Mydriv.sys в верхнюю область памяти, введите следующую команду в файле Config.nt или эквивалентном загрузочном файле:

device=c:\winnt\system32\himem.sys
dos=umb
devicehigh=mydriv.sys


Dir

Вывод списка файлов и подкаталогов каталога. Вызванная без параметров команда dir выводит метку тома и серийный номер, за которыми следует список каталогов и файлов на диске, включая их имена, дату и время последнего изменения. Для файлов dir выводит также расширение имени и размер в байтах. Команда dir также выводит общее число перечисленных файлов и каталогов, их общий размер и свободное пространство (в байтах) на диске.

Синтаксис

dir [диск:][путь][имя_файла] [...] [/p] [/q] [/w] [/d] [/a[[:]атрибуты]][/o[[:]порядок_сортировки]] [/t[[:]поле_сортировки]] [/s] [/b] [/l] [/n] [/x] [/c] [/4]

Параметры

[диск:][путь]
Задание диска и каталога, список файлов которого будет выведен.
[имя_файла]
Задание файла или группы файлов, сведения о которых требуется вывести.
/p
Постраничный вывод сведений, т. е. с паузой после заполнения экрана. Для продолжения просмотра необходимо нажать любую клавишу.
/q
Вывод сведений о владельце файла.
/w
Вывод сведений в несколько колонок до пяти имен файлов или каталогов в каждой строке.
/d
Соответствует /w, но с сортировкой по столбцам.
/a [[:] атрибуты]
Выводит имена только тех файлов и каталогов, которые имеют указанные атрибуты. Если параметр /a не указан, команда dir выводит имена всех файлов, за исключением системных и скрытых. Если параметр /a указан без атрибутов, команда dir выводит имена всех файлов, включая скрытые и системные. Ниже приведен список значений, которые могут быть использованы при задании параметра атрибуты. Двоеточие (:) является необязательным. Значения из таблицы могут использоваться в любых комбинациях без пробела между ними.
Значение | Описание
h | Скрытые файлы
s | Системные файлы
d | Каталоги
a | Файлы, готовые к архивированию
r | Файлы, доступные только для чтения
-h | Файлы, не являющиеся скрытыми
-s | Файлы, не являющиеся системными
-d | Только файлы (не каталоги)
-a | Файлы, не изменявшиеся после последнего архивирования
-r | Файлы, не имеющие атрибута «Только чтение»
/o [[:]порядок_сортировки]
Управление порядком сортировки и вывода имен файлов и каталогов командой dir. Если параметр /o, не задан, команда dir выводит имена в том порядке, в котором они записаны в каталоге. Если параметр /o использован без параметра порядок_сортировки, команда dir выводит имена каталогов в алфавитном порядке, затем — имена файлов в алфавитном порядке. Двоеточие (:) является необязательным. Ниже приведен список значений, которые могут быть использованы при задании параметра порядок_сортировки. Допускается использование любого их сочетания без пробелов между ними.
Значение | Описание
n | Сортировка по именам в алфавитном порядке
e | Сортировка по расширениям в алфавитном порядке
d | Сортировка по дате и времени от ранних к поздним
s | Сортировка по размеру от меньших к большим
g | Сортировка с группированием каталогов перед файлами
-n | Сортировка по именам в обратном алфавитном порядке (от Z к A)
-e | Сортировка по расширению в обратном алфавитном порядке (от .ZZZ к .AAA)
-d | Сортировка по дате и времени от поздних к ранним
-s | Сортировка по размеру от больших к меньшим
-g | Сортировка с группировкой каталогов после файлов
/t [[:]поле_времени]
Задание поля времени для вывода и сортировки. Ниже приведен список значений, которые могут быть использованы при задании параметра поле_времени.
Значение | Описание
c | Создание
a | Последнее обращение
w | Последняя запись
/s
Перечисление всех случаев обнаружения определенного имени файла в указанном каталоге и всех его подкаталогах.
/b
Перечисление каждого имени файла (включая расширение) или каталога на отдельной строке. При использовании параметра /b заголовочные сведения или сводка не выводятся. Параметр /b отменяет параметр /w.
/l
Вывод несортированного списка имен каталогов и имен файлов строчными буквами. Параметр /l не позволяет преобразовывать дополнительные символы в строчные.
/n
Вывод списка в расширенном формате с именами файлов в правой части экрана.
/x
Вывод сокращенных имен файлов файловых систем NTFS и FAT. Формат совпадает с форматом параметра /n, но сокращенные имена выводятся после полных.
/c
Вывод разделителя десятичных разрядов в размере файлов.
/4
Отображение года в четырехзначном формате.
/?
Отображение справки в командной строке.

Примечания

  • Использование нескольких имен_файлов

    Допускается использование нескольких имен_файлов. Разделяйте имена файлов пробелом, запятой или точкой с запятой. Для вывода группы файлов допускается применение подстановочных знаков (? и *) в параметре имя_файла.

  • Использование подстановочных знаков

    Для вывода списка подгруппы файлов и подкаталогов можно использовать подстановочные знаки (? и *).

  • Задание атрибутов файлов для вывода

    Если параметр /a используется более чем с одним значением параметра атрибуты, команда dir выведет имена только тех файлов, все атрибуты которых совпадают с заданными. Например, при использовании параметра /a со значениями атрибутов r и -h в формате /a:r-h или /ar-h команда dir выведет имена файлов, являющихся одновременно скрытыми и защищенными от записи.

  • Указание порядка сортировки имен файлов

    Если указано несколько значений порядка_сортировки, команда dir сортирует имена файлов сначала по первому условию, затем — по второму и т. д. Например, если указан ключ /o со значениями e и -s порядка_сортировки в формате /o:e-s или /oe-s, команда dir отсортирует имена каталогов и файлов по расширениям, затем от больших файлов к меньшим и выведет окончательный результат. В результате сортировки по алфавиту файлы без расширений будут идти вначале, затем имена каталогов, а потом имена файлов с расширениями.

  • Использование перенаправления и каналов

    Чтобы перенаправить вывод команды dir в файл с помощью символа (>) или использовать канал (|) для передачи вывода в другую команду, необходимо использовать параметры команды dir /a:-d и /b для вывода только списка имен файлов. Параметр имя_файла с параметрами /b и /s можно использовать, чтобы указать поиск командой dir в текущем каталоге и его подкаталогах всех файлов, соответствующих значению имя_файла. При этом команда dir выведет только имя диска, имя каталога, имя файла и расширение по одному файлу в строке. Чтобы использовать перенаправление с помощью каналов, в файле Autoexec.nt должна быть установлена переменная среды TEMP.

  • Предварительное задание параметров команды dir

    Параметры команды dir могут быть предварительно заданы включением команды set для переменной среды DIRCMD в файл Autoexec.nt. В команде set dircmd может быть использована любая допустимая комбинация параметров команды dir, включая расположение и имя файла.

    Например, чтобы использовать переменную среды DIRCMD для задания вывода в расширенном формате (/w) по умолчанию, в файле Autoexec.nt необходимо ввести следующую строку:

    set dircmd=/w

    При однократном использовании команды dir можно отменить параметр с помощью переменной среды DIRCMD. Для этого введите параметр, который требуется отменить, в командной строке dir, указав перед ним знак минус. Например:

    dir /-w

    Чтобы изменить параметры DIRCMD, используемые по умолчанию, введите следующую команду:

    set=новый_параметр

    Новые параметры по умолчанию останутся в силе для всех последующих команд dir, пока команда set dircmd не задаст новые параметры или не будет перезагружен компьютер.

    Чтобы удалить все параметры по умолчанию, введите следующую команду:

    set dircmd=

    Чтобы просмотреть текущие параметры переменной среды DIRCMD, введите следующую команду:

    set

  • Команда dir с другими параметрами доступна в консоли восстановления.

Примеры

Чтобы вывести подряд все каталоги в алфавитном порядке, в несколько колонок и с паузой после заполнения каждого экрана, убедитесь, что корневой каталог является текущим, и введите следующую команду:

dir /s/w/o/p

Команда dir выводит имя корневого каталога, имена его подкаталогов и имена файлов (включая расширения) в этом каталоге. Затем выводятся имена подкаталогов и имена файлов в каждом каталоге дерева каталогов.

Для изменения предыдущего примера так, чтобы команда dir не выводила имена каталогов, введите следующую команду:

dir /s/w/o/p/a:-d

Чтобы напечатать список каталогов, введите следующую команду:

ir > prn

Если указать параметр prn, список каталогов отправляется на принтер, подключенный к порту LPT1. Если принтер подключен к другому порту, необходимо заменить параметр prn именем этого порта.

Вывод команды dir также может быть направлен в файл при замене prn на имя файла. Кроме того, можно также ввести путь. Например, для направления вывода команды dir в файл Dir.doc в каталоге Records введите следующую команду:

dir > \records\dir.doc

Если файл Dir.doc не существует, команда dir создаст его при условии наличия каталога Records. Если этот каталог не существует, выводится следующее сообщение:

Ошибка создания файла

Чтобы вывести список всех файлов с расширением .txt во всех каталогах диска C, введите следующую команду:

dir c:\*.txt /w/o/s/p

Команда dir выводит на экран алфавитный список файлов, удовлетворяющих заданному шаблону, в несколько колонок с паузой после заполнения каждого экрана.


Diskcomp

Сравнение содержимого двух гибких дисков. При запуске команды diskcomp без параметров для сравнения дисков используется текущий дисковод.

Синтаксис

diskcomp [диск1: [диск2:]]

Параметры

диск1
Задание дисковода, содержащего первый гибкий диск.
диск2
Задание дисковода, содержащего второй гибкий диск.
/?
Отображение справки в командной строке.

Примечания

  • Использование дисков

    Команда diskcomp работает только с гибкими дисками. Команду diskcomp нельзя использовать для жестких дисков. Если жесткий диск задан в качестве параметра диск1 или диск2, diskcomp выведет на экран следующее сообщение:

    Диск задан неправильно.
    Указанный диск не существует
    либо является несъемным

  • Сравнение дисков

    Если все дорожки на сравниваемых дисках совпадают, команда diskcomp выводит следующее сообщение:

    Различия не найдены.

    Если обнаружены несовпадающие дорожки, команда diskcomp выведет на экран следующее сообщение:

    Ошибка сравнения:
    сторона 1, дорожка 2

    После окончания сравнения команда diskcomp выведет следующее сообщение:

    Сравнить еще диск [Y(да)/N(нет)]?

    При нажатии клавиши Y программа diskcomp выведет приглашение вставить следующий гибкий диск в дисковод для повторения операции. При нажатии клавиши N работа команды diskcomp завершается.

    В процессе сравнения не учитываются номера томов гибких дисков командой diskcomp.

  • Пропуск параметров

    Если опущен параметр диск2, команда diskcomp использует текущий диск в качестве параметра диск2. Если не заданы оба параметра, diskcomp использует текущий дисковод для обоих дисков. Если текущий диск совпадает с параметром диск1, команда diskcomp выведет приглашение сменить диски по мере необходимости.

  • Использование одного дисковода

    Если один и тот же диск задан в качестве параметров диск1 и диск2, команда diskcomp будет работать с использованием одного дисковода и запрашивать смену дисков, когда потребуется. Возможно, менять диски местами придется несколько раз, в зависимости от емкости дисковода и объема доступной памяти.

  • Сравнение дисков разного типа

    С помощью команды diskcomp невозможно сравнивать односторонние диски с двухсторонними, также как и диски двойной плотности с дисками высокой плотности. Если типы дисков диск1 и диск2 отличаются друг от друга, команда diskcomp выведет на экран следующее сообщение:

    Несовместимые форматы дисководов или дисков.

  • Использование diskcomp для сравнения сетевых и виртуальных дисков

    Команда diskcomp не работает с сетевыми устройствами и дисками, созданными командой subst. При попытке использовать diskcomp с устройством любого из этих типов программа diskcomp выведет следующее сообщение об ошибке:

    Неправильно указан диск.

  • Сравнение дисков при копировании

    Если команда diskcomp используется для сравнения диска, созданного с помощью программы copy, diskcomp может выводить сообщение, аналогичное следующему:

    Ошибка сравнения:
    сторона 0, дорожка 0

    Это сообщение может возникать даже в том случае, если файлы на дисках полностью совпадают. Это связано с тем, что хотя команды copy и дублирует сведения, она не обязательно помещает их в то же место, что и на диске-оригинале.

  • Общее представление о кодах завершения команды diskcomp

    В следующей таблице перечислены коды завершения с кратким описанием.

    Код завершения | Описание
    0 | Диски одинаковы
    1 | Найдены различия
    3 | Возникла невосстановимая ошибка
    4 | Возникла ошибка инициализации

    Для обработки кодов завершения, возвращаемых diskcomp можно воспользоваться параметром уровень_ошибки команды if в пакетном файле.

Примеры

Если в системе установлен только один дисковод гибких дисков (например A) и требуется сравнить два диска, введите следующую команду:

diskcomp a: a:

Программа diskcomp выводит приглашения вставить диски по мере необходимости.

Следующий пример демонстрирует использование параметра errorlevel в строке команды if для обработки кодов завершения программы diskcomp в пакетном файле:

rem Checkout.bat сравнивает два диска в дисководах A и B
echo off
diskcomp a: b:
if errorlevel 4 goto ini_error
if errorlevel 3 goto hard_error
if errorlevel 1 goto no_compare
if errorlevel 0 goto compare_ok
:ini_error
echo ОШИБКА: недостаточно памяти или неверная команда
goto exit
:hard_error
echo ОШИБКА: возникла невосстановимая ошибка
goto exit
:break
echo "Нажата комбинация клавиш CTRL+C" для остановки сравнения
goto exit
:no_compare
echo Диски отличаются
goto exit
:compare_ok
echo Сравнение прошло успешно, диски совпадают
goto exit
:exit


Diskcopy

Копирование содержимого гибкого диска на другой форматированный или неформатированный гибкий диск. При запуске команды diskcopy без параметров для исходного и конечного дисков используется текущий дисковод.

Синтаксис

diskcopy [диск1: [диск2:]] [/v]

Параметры

диск1
Задание дисковода, содержащего диск-источник.
диск2
Задание дисковода, содержащего конечный диск.
/v
Проверка правильности копирования сведений. Этот параметр командной строки замедляет процесс копирования.
/?
Отображение справки в командной строке.

Примечания

  • Использование дисков

    Команда diskcopy работает только со съемными дисками, такими как гибкие диски. Команда diskcopy не может быть использована с жесткими дисками. Если жесткий диск задан в качестве параметра диск1 или диск2, diskcopy выведет на экран следующее сообщение:

    Диск задан неправильно.
    Указанный диск не существует
    либо является несъемным

    Команда diskcopy выведет приглашение вставить в дисководы исходный и конечный диски и нажать любую клавишу для продолжения.

    После завершения копирования diskcopy выведет на экран следующее сообщение:

    Копировать еще диск [Y(да)/N(нет)]?

    При нажатии клавиши Y команда diskcopy выведет приглашение вставить исходный и конечные диски для следующей операции копирования. Для окончания работы команды diskcopy следует нажать N.

    Если diskcopy копирует на неформатированный диск в дисководе, заданном параметром диск2, этот диск будет отформатирован так же, как диск1, с тем же количеством сторон и плотностью. При этом diskcopy выведет на экран сообщение:

    Форматирование в процессе копирования.

  • Серийные номера дисков

    Если диск-источник имеет серийный номер тома, программа diskcopy создаст новую серийную метку тома на диске-результате после завершения процесса копирования.

  • Пропуск параметров

    Если опущен параметр диск2, команда diskcopy будет использовать текущий диск. Если не заданы оба параметра, diskcopy использует текущий дисковод для обоих дисков. Если текущий диск совпадает с параметром диск1, команда diskcopy будет запрашивать смену дисков по мере необходимости.

  • Использование одного дисковода для копирования

    Если параметры диск1 и диск2 совпадают, программа diskcopy выведет приглашение поменять диски. Если не заданы оба параметра диск и текущий диск является дисководом гибкого диска, программа diskcopy будет запрашивать подтверждения каждый раз, когда будет требоваться смена диска. Если на диске содержится больше информации, чем объем доступной памяти, команда diskcopy не сможет выполнить копирование за один проход. Команда diskcopy читает исходный диск, записывает сведения на диск-результат, а затем снова приглашает сменить диск. Этот процесс будет продолжаться до тех пор, пока вся информация не будет скопирована.

  • Снижение степени фрагментации дисков

    Поскольку команда diskcopy создает точную копию одного диска на другом, если файлы на диске-источнике были фрагментированы, то же самое будет и на диске-результате. Фрагментацией называется наличие маленьких участков свободного дискового пространства между файлами на диске.

    Фрагментированный диск может вызвать замедление операций поиска, чтения и записи файлов. Чтобы избежать переноса фрагментации с одного диска на другой, рекомендуется использовать команды copy или xcopy для копирования дисков. Так как copy и xcopy выполняют последовательное копирование файлов, новый диск не будет иметь фрагментации.

    Осторожно!

    • Команда xcopy не может быть использована для копирования загрузочных дисков.
  • Общее представление о кодах завершения команды diskcopy

    В следующей таблице перечислены коды завершения с кратким описанием.

    Код завершения | Описание
    0 | Операция копирования прошла успешно
    1 | Возникла нефатальная ошибка чтения/записи
    3 | Возникла невосстановимая ошибка
    4 | Возникла ошибка инициализации

    Для обработки кодов завершения, возвращаемых diskcomp, можно воспользоваться параметром errorlevel команды if в пакетном файле.

Примеры

Чтобы скопировать диск в дисководе B на диск в дисководе A, введите следующую программу:

diskcopy b: a:


Driverquery

Вывод списка всех установленных драйверов устройств и их свойств.

Синтаксис

driverquery [/s компьютер] [/u домен\пользователь /p пароль] [/fo {TABLE|LIST|CSV}] [/nh] [/v] [/si]

Параметры

/s компьютер
Задание имени или IP-адреса удаленного компьютера (не используйте обратную косую черту). По умолчанию используется локальный компьютер.
/u домен\пользователь
Выполнение команды с разрешениями учетной записи пользователя, заданного в параметре пользователь или домен\пользователь. По умолчанию используются разрешения текущего вошедшего пользователя компьютера, с которого поступила эта команда.
/p пароль
Указание пароля учетной записи пользователя, заданной параметром /u.
/fo {TABLE|LIST|CSV}
Задание формата вывода сведений о драйверах. Допустимые значения: TABLE, LIST и CSV. По умолчанию для выходных данных используется формат TABLE.
/nh
Исключение столбца заголовков из отображаемых сведений о драйверах. Данный параметр является допустимым, если параметр /fo имеет значение TABLE или CSV.
/v
Задание вывода подробных сведений о драйверах.
/si
Вывод сведений о цифровой подписи как для подписанных, так и неподписанных драйверов устройств.
/?
Отображение справки в командной строке.

Примеры

Далее приведены примеры использования команды driverquery:

driverquery
driverquery /fo csv
driverquery /nh
driverquery /s ipaddress
driverquery /s server1 /u hirpln /v driverquery /s server1 /u maindom\hirpln /p p@ssw3d /fo list


Программа DiskPart

DiskPart

Программа DiskPart.exe — это работающий в текстовом режиме командный интерпретатор, который позволяет управлять объектами (дисками, разделами или томами) с помощью сценариев или команд, вводимых с командной строки. Перед использованием команд DiskPart.exe для диска, раздела или тома, необходимо сначала составить список объектов, а затем выбрать объект для работы. После этого все введенные команды DiskPart.exe выполняются для данного объекта.

Составить список всех доступных объектов и определить номер объекта или букву диска можно с помощью команд list disk, list volume и list partition. Команды list disk и list volume позволяют вывести все диски и тома компьютера. Команда list partition, однако, выводит разделы только выбранного диска. При использовании команды list рядом с выбранным объектом отображается звездочка (*). Объект выбирается по номеру или букве диска, например диск 0, раздел 1, том 3 или том C.

После выбора объекта он остается выделенным до выбора другого объекта. Например, если фокус установлен на диске 0 и выбран том 8 на диске 2, фокус переместиться с диска 0 на том 8 диска 2. В некоторых командах фокус перемещается автоматически. Например, после создания раздела фокус автоматически перемещается на этот раздел.

Только на выбранном диске можно переместить фокус на раздел. Если фокус установлен на разделе, соответствующий том (если таковой имеется) также получает фокус. Если том имеет фокус, соответствующие диск и раздел также получают фокус при условии, что этот том связан с одним определенным разделом. В противном случае диск и раздел не выделяются.

Команды DiskPart

Пометка имеющего фокус раздела на базовом диске как активного. Эта информация указывает базовой системе ввода/вывода (BIOS) или расширенному интерфейсу микропрограмм, что раздел или том является действительным системным разделом или системным томом.

Только разделы могут быть помечены как активные.

Важно!

  • DiskPart проверяет только тот факт, что раздел может содержать файлы загрузки операционной системы. DiskPart не проверяет содержимое раздела. Если раздел, помеченный по ошибке как «active», не содержит файлы загрузки операционной системы, компьютер не запустится.

Синтаксис

active

Отражение простого тома с фокусом на указанный диск.

Синтаксис

add disk=n [noerr]

Параметры

n
Задание диска, на котором будет создано зеркало. Допускается создавать зеркала только простых томов. Необходимо, чтобы на указанном диске имелось незанятое место, размер которого не меньше размера простого тома, который требуется отразить.
noerr
Только для сценариев. Если задан этот параметр, при возникновении ошибки программа DiskPart продолжает обрабатывать команды, как если бы ошибки не было. Если параметр noerr не задан, при возникновении ошибки работа программы DiskPart завершается и выдается код ошибки.

Назначение буквы диска или точки подключения тому, имеющему фокус. Если буква диска или точка подключения не указана, используется следующая доступная буква. Если буква диска или точка подключения уже используется, возникает ошибка.

Команду assign можно использовать для смены буквы диска, связанной со съемным диском.

Нельзя назначать буквы дисков системным томам, загрузочным томам или томам, содержащим файл подкачки. Кроме того, буква диска не может быть назначена разделу ИВТ или разделу GPT, отличному от раздела MSDATA.

Синтаксис

assign [{letter=d|mount=путь}] [noerr]

Параметры

letter=d
Буква диска, которую требуется назначить тому.
mount=путь
Путь к точке подключения, который требуется назначить тому.
noerr
Только для сценариев. Если задан этот параметр, при возникновении ошибки программа DiskPart продолжает обрабатывать команды, как если бы ошибки не было. Если параметр noerr не задан, при возникновении ошибки работа программы DiskPart завершается и выдается код ошибки.

Применяется только к динамическим дискам. Разбивает зеркальный том, имеющий фокус, на два простых тома. Один простой диск сохраняет букву диска и все точки подключения зеркального тома, а на другой перемещается фокус, таким образом для него можно назначить букву диска.

По умолчанию содержимое обоих половин зеркала сохраняется. Каждая половина становится простым томом. Если задан параметр nokeep, только одна половина зеркала сохраняется как простой том, а другая половина удаляется и преобразуется в свободное пространство. Ни один из томов не получает фокус.

Синтаксис

break disk=n [nokeep] [noerr]

Параметры

n
Задание диска, на котором будет создан отраженный том.
nokeep
Задание сохранения только одного из отраженных томов. Второй простой том удаляется и преобразуется в свободное пространство. Ни том, ни свободное пространство не получают фокус.
noerr
Только для сценариев. Если задан этот параметр, при возникновении ошибки программа DiskPart продолжает обрабатывать команды, как если бы ошибки не было. Если параметр noerr не задан, при возникновении ошибки работа программы DiskPart завершается и выдается код ошибки.

Удаление всех разделов или томов на диске, имеющем фокус. На дисках основной загрузочной записи (MBR) перезаписываются только сведения о разделах диска MBR и скрытых секторах. На дисках таблицы разделов GUID (GPT) перезаписываются сведения о разделах GPT, включая защитную основную загрузочную запись (MBR). Сведения о скрытых секторах отсутствуют.

Синтаксис

clean [all]

Параметр

all
Задание обнуления всех секторов на диске, в результате чего полностью удаляются все данные, содержащиеся на диске.

Преобразование пустого динамического диска в базовый.

Синтаксис

convert basic [noerr]

Параметр

noerr
Только для сценариев. Если задан этот параметр, при возникновении ошибки программа DiskPart продолжает обрабатывать команды, как если бы ошибки не было. Если параметр noerr не задан, при возникновении ошибки работа программы DiskPart завершается и выдается код ошибки.

Преобразование базового диска в динамический.

Синтаксис

convert dynamic [noerr]

Параметр

noerr
Только для сценариев. Если задан этот параметр, при возникновении ошибки программа DiskPart продолжает обрабатывать команды, как если бы ошибки не было. Если параметр noerr не задан, при возникновении ошибки работа программы DiskPart завершается и выдается код ошибки.

На компьютерах с процессором Itanium преобразует пустой базовый диск со стилем разделов основная загрузочная запись в базовый диск со стилем разделов таблица разделов GUID.

Важно!

  • Диск может быть преобразован в GPT-диск, только если он пуст. Перед преобразованием диска создайте архивную копию данных, а затем удалите все разделы и тома.

Синтаксис

convert gpt [noerr]

Параметр

noerr
Только для сценариев. Если задан этот параметр, при возникновении ошибки программа DiskPart продолжает обрабатывать команды, как если бы ошибки не было. Если параметр noerr не задан, при возникновении ошибки работа программы DiskPart завершается и выдается код ошибки.

На компьютерах с процессором Itanium преобразует пустой базовый диск со стилем разделов таблица разделов GUID в базовый диск со стилем разделов основная загрузочная запись.

Важно!

  • Диск может быть преобразован в MBR-диск, только если он пуст. Перед преобразованием диска создайте архивную копию данных, а затем удалите все разделы и тома.

Синтаксис

convert mbr [noerr]

Параметр

noerr
Только для сценариев. Если задан этот параметр, при возникновении ошибки программа DiskPart продолжает обрабатывать команды, как если бы ошибки не было. Если параметр noerr не задан, при возникновении ошибки работа программы DiskPart завершается и выдается код ошибки.

Создание системного раздела EFI (Extensible Firmware Interface) на диске с таблицей разделов GUID (GPT) на компьютерах с процессорами Itanium. После создания раздела фокус перемещается на этот раздел.

Синтаксис

create partition efi [size=n] [offset=n] [noerr]

Параметры

size=n
Размер раздела в мегабайтах (Мбайт). Если размер не указан, раздел занимает все свободное пространство в текущей области.
offset=n
Смещение в байтах для начала нового раздела. Если смещение не указано, раздел помещается в первый диск, имеющий достаточный размер.
noerr
Только для сценариев. Если задан этот параметр, при возникновении ошибки программа DiskPart продолжает обрабатывать команды, как если бы ошибки не было. Если параметр noerr не задан, при возникновении ошибки работа программы DiskPart завершается и выдается код ошибки.

Создание дополнительного раздела на текущем диске. После создания раздела фокус автоматически переносится на этот раздел. На диске можно создать только один дополнительный раздел. Команда не выполняется при попытке создать дополнительный раздел в другом дополнительном разделе. Дополнительный раздел следует создавать до создания логических дисков.

Синтаксис

create partition extended [size=n] [offset=n] [noerr]

Параметры

size=n
Размер дополнительного раздела в мегабайтах (Мбайт). Если размер не указан, раздел занимает все свободное пространство области. Размер определяется цилиндрами. Размер округляется до ближайшей границы цилиндра. Например, если задан размер 500 Мбайт, то размер раздела округляется до 504 Мбайт.
offset=n
Применяется только к дискам, содержащим основную загрузочную запись (MBR). Смещение в байтах для начала дополнительного раздела. Если смещение не указано, раздел начинается с начала свободного пространства на диске. Смещение зависит от цилиндров. Смещение округляется до ближайшей границы цилиндра. Например, если указано смещение 27 Мбайт, а размер цилиндра 8 Мбайт, смещение округляется до границы 24 Мбайт.
noerr
Только для сценариев. Если задан этот параметр, при возникновении ошибки программа DiskPart продолжает обрабатывать команды, как если бы ошибки не было. Если параметр noerr не задан, при возникновении ошибки работа программы DiskPart завершается и выдается код ошибки.

Создание логического диска в дополнительном разделе. После создания раздела фокус автоматически переносится на новый логический диск.

Синтаксис

create partition logical [size=n] [offset=n] [noerr]

Параметры

size=n
Размер логического диска в мегабайтах (Мбайт). Если размер не указан, раздел занимает все свободное пространство в текущей области.
offset=n
Применяется только к дискам, содержащим основную загрузочную запись (MBR). Смещение в байтах для начала нового логического диска. Смещение зависит от цилиндров (т. е. смещение округляется до размера определенного цилиндра). Если смещение не указано, раздел помещается в первое пространство на диске, достаточно большое, чтобы уместить его. Размер раздела в байтах должен быть не меньше числа, указанного в параметре size=n. Если указывается размер логического диска, то он должен быть меньше, чем дополнительный раздел.
noerr
Только для сценариев. Если задан этот параметр, при возникновении ошибки программа DiskPart продолжает обрабатывать команды, как если бы ошибки не было. Если параметр noerr не задан, при возникновении ошибки работа программы DiskPart завершается и выдается код ошибки.

Создание системного раздела EFI (Extensible Firmware Interface) на диске, содержащем таблицу разделов GUID (GPT), в компьютерах с процессорами Itanium.

Внимание!

  • Будьте внимательны при использовании команды create partition msr. Поскольку для дисков GPT используется специальная разметка раздела, создание разделов MSR может привести к тому, что диск станет нечитаемым. На дисках GPT, используемых для запуска системы Windows XP 64-Bit Edition, первым разделом является системный раздел EFI, за которым следует раздел MSR. На дисках, используемых только для хранения данных, системный раздел EFI System отсутствует, а первым разделом является раздел MSR.

    В системе Windows XP 64-Bit Edition подключение разделов MSR не выполняется. Удалять такие разделы, а также сохранять данные в них нельзя.

Синтаксис

create partition msr [size=n] [offset=n] [noerr]

Параметры

size=n
Размер раздела в мегабайтах (Мбайт). Длина раздела в байтах должна быть не менее числа, указанного в параметре size=n. Если размер не указан, раздел занимает все невыделенное пространство в текущей области.
offset=n
Смещение в байтах для начала нового раздела. Раздел начинается со смещения в байтах, заданного параметром offset=n. Смещение зависит от цилиндров (т. е. смещение округляется до размера определенного цилиндра). Если не указано смещение, раздел помещается в первое пространство на диске, достаточно большое, чтобы уместить его.
noerr
Только для сценариев. Если задан этот параметр, при возникновении ошибки программа DiskPart продолжает обрабатывать команды, как если бы ошибки не было. Если параметр noerr не задан, при возникновении ошибки работа программы DiskPart завершается и выдается код ошибки.

Создание основного раздела на текущем базовом диске. После создания раздела фокус автоматически переносится на этот раздел. При этом дополнительный раздел не получает букву диска. Для назначения буквы диска данному разделу воспользуйтесь командой assign.

Синтаксис

  • create partition primary [size=n] [offset=n] [ID={byte|GUID}] [noerr]

    Параметры

    size=n
    Размер раздела в мегабайтах (Мбайт). Если размер не указан, раздел занимает все невыделенное пространство в текущей области. Размер определяется цилиндрами. Размер округляется до ближайшей границы цилиндра. Например, если задан размер 500 Мбайт, то размер раздела округляется до 504 Мбайт.
    offset=n
    Смещение в байтах для начала нового раздела. Если смещение не указано, раздел начинается с начала свободного пространства на диске. Для дисков с основной загрузочной записью (MBR) значение смещения зависит от цилиндров. Смещение округляется до ближайшей границы цилиндра. Например, если указано смещение 27 Мбайт, а размер цилиндра 8 Мбайт, смещение округляется до границы 24 Мбайт.
    ID={byte|GUID}
    Этот параметр предназначен только для использования ИВТ.

    Внимание!

    • Создание разделов с этим параметром может привести к сбоям в работе компьютера или невозможности его загрузки. Использовать параметр ID=byte | GUID при создании GPT-дисков рекомендуется только ИВТ и специалистам в области информационных технологий, имеющим опыт работы с GPT-дисками. Используйте команду create partition efi для создания системных разделов EFI, команду create partition msr для создания разделов MSR и команду create partition primary (без параметра ID=byte | GUID) для создания основных разделов на GPT-дисках.

    Для MBR-дисков можно задавать байт типа раздела в шестнадцатеричном формате. Если байт типа раздела на MBR-диске не задан, команда create partition primary создает раздел с типом 0x6. Любой байт типа раздела может быть задан с помощью параметра ID=byte | GUID. Команда DiskPart не выполняет проверку допустимости байта типа раздела, а также каких-либо других проверок параметра ID.

    Для GPT-дисков можно задать тип GUID создаваемого раздела.
    • Системный раздел EFI: c12a7328-f81f-11d2-ba4b-00a0c93ec93b
    • Раздел MSR: e3c9e316-0b5c-4db8-817d-f92df00215ae
    • Раздел MSDATA: ebd0a0a2-b9e5-4433-87c0-68b6b72699c7
    • Раздел метаданных диспетчера локальных дисков на динамическом диске: 5808c8aa-7e8f-42e0-85d2-e1e90434cfb3
    • Раздел данных диспетчера локальных дисков на динамическом диске: af9b60a0-1431-4f62-bc68-3311714a69ad

    Если тип GUID разделов задан, команда create partition primary создает раздел MSDATA. Любой тип раздела может быть задан с помощью параметра ID={byte | GUID}. Команда DiskPart не выполняет проверку допустимости GUID раздела, а также каких-либо других проверок параметра ID.

    noerr
    Только для сценариев. Если задан этот параметр, при возникновении ошибки программа DiskPart продолжает обрабатывать команды, как если бы ошибки не было. Если параметр noerr не задан, при возникновении ошибки работа программы DiskPart завершается и выдается код ошибки.

    Создание тома RAID-5 на указанных динамических дисках. После создания тома фокус автоматически перемещается на этот том.

    Синтаксис

    create volume raid [size=n] [disk=n[,[n,…]] [noerr]

    Параметры

    size=n
    Размер дискового пространства в мегабайтах (Мбайт), который том будет занимать на каждом диске. Если размер не указан, создается том RAID-5 максимального возможного размера. Размер тома RAID-5 определяется диском с наименьшим размером непрерывного свободного места. Объем того же размера выделяется на каждом диске. Фактический объем доступного дискового пространства на томе RAID-5 меньше суммы всего занятого дискового пространства, поскольку некоторая его часть требуется для четности.
    disk=n
    Динамические диски, на которых создается том. Объем, равный значению size=n, выделяется на каждом диске.
    noerr
    Только для сценариев. Если задан этот параметр, при возникновении ошибки программа DiskPart продолжает обрабатывать команды, как если бы ошибки не было. Если параметр noerr не задан, при возникновении ошибки работа программы DiskPart завершается и выдается код ошибки.

    Создание простого тома. После создания тома фокус автоматически переносится на этот том.

    Синтаксис

    create volume simple [size=n] [disk=n] [noerr]

    Параметры

    size=n
    Размер раздела в мегабайтах (Мбайт). Если размер не задан, новый том занимает все свободное место на диске.
    disk=n
    Динамический диск, на котором создается том. Если диск не задан, используется текущий диск.
    noerr
    Только для сценариев. Если задан этот параметр, при возникновении ошибки программа DiskPart продолжает обрабатывать команды, как если бы ошибки не было. Если параметр noerr не задан, при возникновении ошибки работа программы DiskPart завершается и выдается код ошибки.

    Создание чередующегося тома на указанных дисках. После создания тома фокус автоматически переносится на этот том.

    Синтаксис

    create volume stripe [size=n] [disk=n[,[n,…]] [noerr]

    Параметры

    size=n
    Объем дискового пространства в мегабайтах (Мбайт), который том будет занимать на каждом диске. Если размер не задан, новый том занимает все свободное пространство на самом маленьком диске и равный объем на каждом последующем диске.
    disk=n
    Динамические диски, на которых создается том. На каждом диске выделяется объем, равный значению size=n.
    noerr
    Только для сценариев. Если задан этот параметр, при возникновении ошибки программа DiskPart продолжает обрабатывать команды, как если бы ошибки не было. Если параметр noerr не задан, при возникновении ошибки работа программы DiskPart завершается и выдается код ошибки.

    Синтаксис

    delete disk [noerr] [override]

    Параметры

    noerr
    Только для сценариев. Если задан этот параметр, при возникновении ошибки программа DiskPart продолжает обрабатывать команды, как если бы ошибки не было. Если параметр noerr не задан, при возникновении ошибки работа программы DiskPart завершается и выдается код ошибки.
    override
    Удаление всех простых томов на диске программой DiskPart. Если на диске находится половина зеркального тома, то она удаляется. Если диск входит в том RAID-5, команда delete disk override не выполняется.

    На базовом диске удаляет раздел, имеющий фокус. Нельзя удалить системный раздел, загрузочный раздел, а также любой другой раздел, содержащий активный файл подкачки или аварийную копию памяти (дамп памяти).

    Внимание!

    • Удаление раздела на динамическом диске может привести к удалению всех динамических томов на этом диске, в результате все данные будут удалены, а диск преобразован в базовый. Для удаления динамического тома используйте команду delete volume.

    Разделы динамических дисков можно только удалять, но не создавать. Например, можно удалить неопознанный раздел, содержащий таблицу разделов GUID (GPT), на динамическом GPT-диске. Удаление этого раздела не означает, что полученное в результате свободное пространство станет доступным. Данная команда специально предназначена для восстановления пространства поврежденного автономного динамического диска в аварийной ситуации, когда нельзя воспользоваться командой clean.

    Синтаксис

    delete partition [noerr] [override]

    Параметры

    noerr
    Только для сценариев. Если задан этот параметр, при возникновении ошибки программа DiskPart продолжает обрабатывать команды, как если бы ошибки не было. Если параметр noerr не задан, при возникновении ошибки работа программы DiskPart завершается и выдается код ошибки.
    override
    Удаление программой DiskPart любого раздела, независимо от его типа. Обычно программа DiskPart позволяет удалять только разделы с известными данными.

    Удаление выделенного тома. Нельзя удалить системный том, загрузочный том, а также любой другой том, содержащий активный файл подкачки или аварийную копию памяти (дамп памяти).

    Синтаксис

    delete volume [noerr]

    Параметр

    noerr
    Только для сценариев. Если задан этот параметр, при возникновении ошибки программа DiskPart продолжает обрабатывать команды, как если бы ошибки не было. Если параметр noerr не задан, при возникновении ошибки работа программы DiskPart завершается и выдается код ошибки.

    Синтаксис

    detail disk

    Отображение динамических дисков, на которых размещен текущий том.

    Синтаксис

    detail volume

    Выход из командного интерпретатора DiskPart.

    Синтаксис

    exit

    Расширение тома, имеющего фокус, на смежное невыделенное пространство. Для базовых томов невыделенная область должна находиться на том же диске и следовать (иметь более высокий сектор смещения) за разделом, имеющим фокус. Простой или составной динамический том может быть расширен на пустое место на любом динамическом диске. С помощью этой команды существующий том может быть расширен на новое, только что созданное место.

    Если раздел был ранее отформатирован в файловой системе NTFS, файловая система автоматически расширяется на увеличенный раздел. Данные при этом не теряются. Если раздел был ранее отформатирован в любой файловой системе, отличной от NTFS, имеет место отказ команды без изменения раздела.

    Невозможно расширить текущий системный или загрузочный разделы.

    Синтаксис

    extend [size=n] [disk=n] [noerr]

    Параметры

    size=n
    Объем в мегабайтах (Мбайт), добавляемый к текущему разделу. Если размер не указан, диск расширяется на всю смежную невыделенную область.
    disk=n
    Динамический диск, на который расширяется том. На этом диске выделяется объем, равный значению size=n. Если диск не указан, том расширяется на текущий диск.
    noerr
    Только для сценариев. Если задан этот параметр, при возникновении ошибки программа DiskPart продолжает обрабатывать команды, как если бы ошибки не было. Если параметр noerr не задан, при возникновении ошибки работа программы DiskPart завершается и выдается код ошибки.

    Синтаксис

    справка

    Импорт группы внешних дисков в группу дисков локального компьютера. Команда import импортирует каждый диск, находящийся в одной группе с диском, имеющим фокус.

    Синтаксис

    import [noerr]

    Параметр

    noerr
    Только для сценариев. Если задан этот параметр, при возникновении ошибки программа DiskPart продолжает обрабатывать команды, как если бы ошибки не было. Если параметр noerr не задан, при возникновении ошибки работа программы DiskPart завершается и выдается код ошибки.

    Вывод списка дисков и таких сведений о них, как размер, свободный объем, является ли диск базовым или динамическим, а также, какой стиль раздела используется на диске — основная загрузочная запись (MBR) или таблица разделов GUID (GPT). Диск, помеченный звездочкой (*), имеет фокус.

    Синтаксис

    list disk

    Отображение разделов, перечисленных в таблице разделов текущего диска. Для динамических дисков эти разделы могут не соответствовать динамическим томам на диске. Это различие возникает вследствие того, что динамические диски содержат записи в таблице разделов для системного тома или загрузочного тома (при наличии на диске) и раздела, занимающего остаток диска, что позволяет зарезервировать пространство используемое динамическими томами.

    Синтаксис

    list partition

    Отображение списка базовых и динамических томов на всех дисках.

    Синтаксис

    list volume

    Подключение отключенного диска или тома, на который установлен фокус.

    Синтаксис

    online [noerr]

    Параметр

    noerr
    Только для сценариев. Если задан этот параметр, при возникновении ошибки программа DiskPart продолжает обрабатывать команды, как если бы ошибки не было. Если параметр noerr не задан, при возникновении ошибки работа программы DiskPart завершается и выдается код ошибки.

    Синтаксис

    rem

    Примеры

    rem Эти команды устанавливают 3 драйвера.

    create partition primary size=2048

    assign d:

    create partition extend

    create partition primary size=2048

    assign e:

    create partition logical

    assign f:

    remove

    Удаление буквы диска или точки подключения тома, имеющего фокус. Если используется параметр all, удаляются все текущие буквы дисков и точки подключения. Если буква диска или точка подключения не указана, команда DiskPart удаляет первую обнаруженную букву диска или точку подключения.

    Команду remove можно использовать для смены буквы диска, связанной со съемным диском. Не допускается удаление буквы диска для системного и загрузочного тома, а также для тома, содержащего файл подкачки. Кроме того, не допускается удаление букв диска разделов, созданных ИВТ, любых GPT-разделов с нераспознанной таблицей GUID, а также особых, не содержащих данных GPT-разделов, таких как системные разделы EFI.

    Синтаксис

    remove [{letter=d|mount=путь [all]}] [noerr]

    Параметры

    letter=d
    Удаляемая буква диска.
    mount=путь
    Удаляемый путь к точке подключения.
    all
    Удаление всех текущих букв дисков и точек подключения.
    noerr
    Только для сценариев. Если задан этот параметр, при возникновении ошибки программа DiskPart продолжает обрабатывать команды, как если бы ошибки не было. Если параметр noerr не задан, при возникновении ошибки работа программы DiskPart завершается и выдается код ошибки.

    Поиск новых дисков, добавленных в компьютер.

    Синтаксис

    rescan

    Подготовка существующего динамического простого тома к использованию в качестве загрузочного или системного тома.

    В компьютерах на базе процессоров x86 — создание записи раздела в основной загрузочной записи (MBR) на динамическом простом томе, имеющем фокус. Для создания раздела MBR динамический простой том должен начинаться со смещения, выровненного по цилиндру, а его размер должен равняться целому числу цилиндров.

    В компьютерах на базе процессоров Itanium — создание записи раздела в таблице разделов GUID (GPT) на динамическом простом томе, имеющем фокус.

    Примечание

    • Команда retain предназначена для использования во время установки в автоматическом режиме или изготовителями вычислительной техники (ИВТ).

    Синтаксис

    retain

    Выбор указанного диска и перемещение фокуса на него.

    Синтаксис

    select disk=[n]

    Параметры

    n
    Номер диска, получающего фокус. Если номер диска не указан, команда select отображает текущий диск, имеющий фокус. Чтобы просмотреть номера всех дисков в компьютере, воспользуйтесь командой list disk.

    Выбор указанного раздела и передача ему фокуса. Если раздел не указан, команда select отображает текущий раздел, имеющий фокус. Чтобы просмотреть номера всех разделов в компьютере, воспользуйтесь командой list partition.

    Синтаксис

    select partition=[{n|d}]

    Параметры

    n
    Номер раздела, получающего фокус.
    d
    Буква диска или точка подключения раздела, получающие фокус.

    Выбор указанного тома и перемещение фокуса на него. Если том не указан, команда select отображает текущий том, имеющий фокус. Пользователь может указать том по номеру, букве диска или пути к точке подключения. На базовом диске при выборе тома фокус переводится на соответствующий раздел. Чтобы просмотреть номера всех томов в компьютере, воспользуйтесь командой list volume.

    Синтаксис

    select volume=[{n|d}]

    Параметры

    n
    Номер тома, получающего фокус.
    d
    Буква диска или точка подключения тома, получающие фокус.

    Создание сценариев с помощью программы DiskPart

    С помощью DiskPart можно создавать сценарии для автоматизации задач по работе с дисками, таких как создание томов или преобразование дисков в динамические. Составление сценариев этих задач полезно, если система Windows устанавливается с помощью автоматического режима или программы Sysprep, которые не поддерживают создание томов, за исключением загрузочного тома.

    Чтобы запустить сценарий DiskPart, введите в командной строке следующую команду:

    DiskPart /S имя_сценария.txt

    Где имя_сценария.txt — это имя текстового файла, содержащего сценарий.

    Чтобы направить вывод сценария DiskPart в файл, введите следующую команду:

    DiskPart /S имя_сценария.txt > файл_журнала.txt

    Где файл_журнала.txt — имя текстового файла, в который записывается вывод программы DiskPart.

    При запуске DiskPart версия этой программы и имя компьютера отображаются в командной строке. По умолчанию, если при попытке выполнить задачу сценария в DiskPart возникает ошибка, обработка сценария прекращается и выводится код ошибки (если не указан параметр noerr). Однако программа DiskPart всегда возвращает коды синтаксических ошибок, независимо от использования параметра noerr. Параметр noerr позволяет выполнять такие полезные задачи, как использование одного сценария для удаления всех разделов на всех дисках, независимо от общего числа дисков.

    В следующей таблице перечислены коды ошибок DiskPart.

    Ошибка | Описание
    0 | Ошибки отсутствуют. Сценарий выполнен без ошибок.
    1 | Возникла фатальная ошибка. Возможны серьезные неполадки.
    2 | Указан неверный параметр для команды DiskPart.
    3 | Указанный сценарий или выходной файл не открываются в программе DiskPart.
    4 | Произошел сбой в одной из служб, использованной программой DiskPart.
    5 | Возникла синтаксическая ошибка команды. Сценарий не выполнен, поскольку объект неправильно выбран или его недопустимо использовать с данной командой.


Dos

Задание в подсистеме MS-DOS поддержки связи с верхней областью памяти (UMA) или загрузки части системы в область высокой памяти (HMA).

Синтаксис

dos={high|low}[{,umb|,noumb}]

dos={[high,|low,}]{umb|noumb}

Параметры

{high|low}
Задание загрузки части подсистемы MS-DOS в область высокой памяти HMA. Параметр high позволяет загрузить часть подсистемы MS-DOS в область HMA. Параметр low используется для загрузки всей подсистемы MS-DOS в обычную память. По умолчанию используется параметр low.
{umb|noumb}
Задание поддержки связи между обычной памятью и областью верхней памяти в подсистеме MS-DOS. Параметр umb позволяет установить эту связь. Параметр noumb отключает связь. По умолчанию используется параметр noumb.
/?
Отображение справки в командной строке.

Примечания

  • Установка драйвера Himem.sys для команд dos=umb или dos=high

    Перед использованием параметров dos=umb и dos=high должен быть установлен драйвер Himem.sys.

  • Использование параметра umb

    Для загрузки программ и драйверов устройств в область верхней памяти необходимо указать команду dos=umb. Это позволит высвободить дополнительное свободное пространство в обычной памяти для других программ. Кроме того, необходимо установить драйвер доступа к блоку верхней памяти (UMB).

  • Использование параметра high

    Если задан параметр high, подсистема MS-DOS попытается загрузить часть самой себя в область верхней памяти (HMA). Загрузка части MS-DOS в область HMA освобождает больше обычной памяти для работы программ.

  • Сочетание параметров

    Если задан параметр high, подсистема MS-DOS попытается загрузить часть самой себя в область верхней памяти (HMA). Загрузка части MS-DOS в область HMA позволяет высвободить обычную память для работы программ.

    В одной команде dos можно использовать несколько параметров, разделяя их запятыми. Например, следующие команды являются допустимыми:

    dos=umb,low
    dos=high,umb

    Команду dos можно указать в любом месте файла Config.nt или эквивалентного загрузочного файла.


Команды подсистемы MS-DOS

Система Windows XP включает 16-разрядные (внешние) команды для подсистемы MS-DOS и других подсистем. Это старые команды, такие как edlin и graphics, и команды, используемые только в MS-DOS, такие как debug или exe2bin. Эти 16-разрядные команды включены для обеспечения совместимости с системами MS-DOS и MS OS/2 версии 1.x.

Остальные команды подсистемы MS-DOS, такие как share, выполняют задачи, встроенные в систему Windows XP или подсистему MS-DOS. Эти команды включены для сохранения совместимости с существующими файлами, но их использование в командной строке не влияет на результат, поскольку аналогичные действия выполняются автоматически.

Примечание

  • Следующие 16-разрядные команды подсистемы MS-DOS недоступны в системе Windows XP 64-Bit Edition.

Дополнительные сведения см. по ссылке.

  • Append
  • Debug
  • Подкоманды Debug
  • Edit
  • Edlin
  • Подкоманды Edlin
  • Exe2bin
  • Forcedos
  • Graphics
  • Loadfix
  • Loadhigh (Lh)
  • Mem
  • Nlsfunc
  • Setver
  • Share

Для настройки подсистемы MS-DOS воспользуйтесь командами конфигурирования, такими как device или lastdrive. Укажите эти команды файле Config.nt в каталоге системный_корневой_каталог\SYSTEM32 или в файле настройки, задаваемом файлом PIF определенного приложения. Эти команды влияют только на работу подсистемы MS-DOS. Многие из этих команд, например buffers и break, пропускаются в подсистеме MS-DOS, поскольку они не нужны для ее нормальной работы. Они используются только для обеспечения совместимости.

Дополнительные сведения о командах настройки подсистемы MS-DOS см. по ссылке.

  • Country
  • Device
  • Devicehigh
  • Dos
  • Dosonly
  • Echoconfig
  • Fcbs
  • Files
  • Install
  • Ntcmdprompt
  • Shell
  • Stacks
  • Switches


Новые способы выполнения типичных задач

Система Windows XP поддерживает и расширяет практически все функциональные возможности системы MS-DOS. В нижеприведенных таблицах разъясняются следующие вопросы.

  • Изменения в функциональных возможностях команд MS-DOS.
  • Команды MS-DOS не поддерживаются системой Windows XP.
  • Команды MS-DOS не поддерживаются системой Windows XP 64-Bit Edition.

Изменения в командах MS-DOS

В следующей таблице перечислены изменения в функциональных возможностях команд MS-DOS.

Команда | Изменения
chcp | Изменены кодовые страницы для всех окон командной строки.
diskcomp | Параметры командной строки /1 и /8 больше не поддерживаются.
diskcopy | Параметр командной строки /1 больше не поддерживается.
doskey | Команда может быть использована для всех программ с символьным интерфейсом, которые поддерживают буферизованный ввод. Команда doskey снабжена некоторыми дополнениями.
format | Поддержка гибких магнитных дисков емкостью только 1,44 Мбайт. Магнитооптические диски емкостью 20,8 Мбайт больше не поддерживаются. Параметры командной строки /b, /s, /u, /1, /4 и /8 больше не поддерживаются.
label | В метках тома могут быть использованы символы «^» и «&».
mode | Форматы mode lpt n[:][cols=c][lines=n] и mode lpt n[:][c][,[n]] больше не поддерживаются.
print | Параметры командной строки /b, /c, /m, /p, /q, /s, /t и /u не поддерживаются.
prompt | Новые комбинации символов позволяют добавлять к приглашению амперсанд ($a), скобки ($c и $f) и пробелы ($s).
recover | Восстановление только файлов.
rmdir | Новый параметр командной строки /s позволяет удалять каталоги, содержащие файлы и подкаталоги.
sort | Не требует переменной среды TEMP. Размер файлов не ограничен.
xcopy | Новый параметр командной строки /g позволяет создавать расшифрованные конечные файлы.

Недоступные команды MS-DOS

Не поддерживаются следующие команды системы MS-DOS.

Параметр | Новая процедура или причина для удаления
assign | Не поддерживается системой.
backup | Не поддерживается системой.
choice | Не поддерживается системой.
ctty | Не поддерживается системой.
dblspace | Не поддерживается системой.
deltree | Команда rmdir /s позволяет удалять каталоги, содержащие файлы и подкаталоги. Дополнительные сведения о команде rmdir см. в разделе Rmdir.
dosshell | Возможности этой команды встроены в систему.
drvspace | Не поддерживается системой.
emm386 | Возможности этой команды встроены в систему.
fasthelp | Не поддерживается системой. Используйте команду help в командной строке. Дополнительные сведения о команде help см. в разделе Help. Полный список служебных программ командной строки см. в разделе Средства командной строки.
fdisk | Не поддерживается системой. Воспользуйтесь командой diskpart, позволяющей управлять дисками, разделами и томами. Дополнительные сведения о команде diskpart см. в разделе Diskpart.
include
interlnk | Не поддерживается системой.
intersrv | Не поддерживается системой.
join | Увеличенный размер разделов и улучшенная файловая система не требуют объединения дисков.
memmaker | Использование памяти в подсистеме MS-DOS оптимизируется автоматически.
menucolor
menudefault
menuitem
mirror | Не поддерживается системой.
msav | Не поддерживается системой.
msbackup | Используйте команду ntbackup для компьютеров с ленточными накопителями или команду xcopy для компьютеров без накопителей этого типа. Дополнительные сведения о команде ntbackup см. в разделе Ntbackup. Дополнительные сведения о команде xcopy см. в разделе Xcopy.
mscdex | Подсистему MS-DOS не требуется настраивать для использования дисководов компакт-дисков. Система Windows XP обеспечивает доступ к дисководам компакт-дисков в подсистеме MS-DOS.
msd | Используйте оснастку «Сведения о системе». Чтобы запустить оснастку «Сведения о системе», нажмите кнопку Пуск, выберите команду Выполнить и введите msinfo32.
numlock | Не поддерживается системой.
power | Не поддерживается системой.
restore | Не поддерживается системой.
scandisk | Не поддерживается системой. Используйте команду chkdsk, позволяющую создать и вывести отчет о состоянии диска в форме, зависящей от файловой системы. Команда Chkdsk также составляет список ошибок на диске и исправляет их. Дополнительные сведения о команде chkdsk см. в разделе Chkdsk.
smartdrv | Кэширование в подсистеме MS-DOS выполняется автоматически.
submenu
sys | Система Windows XP не может быть размещена на стандартных гибких магнитных дисках емкостью 1,2 Мбайт и 1,44 Мбайт.
undelete | Не поддерживается системой.
unformat | Не поддерживается системой.
vsafe | Не поддерживается системой.

Команды MS-DOS не поддерживаются системой Windows XP 64-Bit Edition.

Следующие 16-разрядные команды подсистемы MS-DOS не поддерживаются системой Windows XP 64-Bit Edition.

Параметр | Функция
append | Позволяет программам открывать файлы данных из указанных папках так, как будто они находятся в текущей папке.
debug | Запуск Debug.exe — программы для проверки и отладки исполняемых файлов MS-DOS.
edit | Запуск редактора MS-DOS, который позволяет создавать и редактировать текстовые файлы в формате ASCII.
edlin | Запуск программы Edlin.exe — строкового редактора, позволяющего создавать и редактировать текстовые файлы в формате ASCII.
exe2bin | Преобразование исполняемых файлов (.exe) в двоичный формат.
expand | Восстановление одного или нескольких сжатых файлов.
fastopen
forcedos | Запуск заданной программы в подсистеме MS-DOS. Эта команда необходима только для тех программ, которые не распознаются системой Windows XP как программы MS-DOS.
graphics | Загрузка в память программы, позволяющей печатать на принтере изображение с экрана монитора, если используется цветной или графический адаптер.
loadfix | Служит для загрузки программы выше первых 64 Кбайт обычной памяти и запуска этой программы.
loadhigh (lh) | Загрузка программы в верхнюю область памяти. Это позволяет оставить больше свободной обычной памяти для других программ.
mem | Служит для вывода сведений о свободных и занятых областях памяти и программах, находящихся в памяти подсистемы MS-DOS.
nlsfunc | Загрузка сведений, относящихся к определенной стране/региону. XOX
setver | Установка номера версии MS-DOS, который подсистема MS-DOS сообщает программам.
share


Doskey

Вызов программы Doskey.exe, которая позволяет повторно вызывать команды Windows XP, редактировать командные строки и создавать макросы.

Синтаксис

doskey {/reinstall | /listsize=размер | /macros:[{all | программа}] | /history | /insert | /overstrike | /exename=программа | /macrofile=имя_файла | имя_макроса=[текст]}

Параметры

/reinstall
Установка новой копии программы Doskey.exe. Очистка буфера команд.
/listsize=размер
Задание максимального количества команд, сохраняемых в буфере.
/macros
Вывод списка всех макросов, заданных командой doskey. Для перенаправления списка в файл можно использовать символ перенаправления (>) вместе с параметром /macros. Допускается использование сокращения /m вместо /macros.
all
Вывод макросов doskey для всех программ.
программа
Вывод макросов doskey для заданной программы.
/history
Вывод всех команд, сохраняемых в памяти. Для перенаправления списка в файл можно использовать символ перенаправления (>) вместе с параметром /history. Допускается использование сокращения /h вместо /history.
{/insert | /overstrike}
Задание режима замены текста при вводе. Если используется параметр /insert, вводимый текст будет вставляться в старый (как при нажатии клавиши INSERT). При задании параметра /overstrike новый текст будет вводиться взамен старого. По умолчанию используется /overstrike.
/exename=программа
Задание программы (т. е. исполняемого файла), в которой выполняется макрос doskey.
/macrofile=имя_файла
Задание имени файла, содержащего макросы, которые требуется установить.
имя_макроса=[текст]
Создание макроса, который выполняет команды, заданные параметром текст. Параметр имя_макроса задает имя, которое присваивается данному макросу. Текст задает команды, которые записываются в макрос. Если параметр текст оставлен пустым, макрос имя_макроса не будет выполнять никаких команд.
/?
Отображение справки в командной строке.

Примечания

  • Использование Doskey.exe

    Программа Doskey.exe всегда доступна всем интерактивным программам, работающим в символьном режиме (таких как отладчики или программы копирования). Она поддерживает буфер выполнявшихся команд и макросы для каждой запущенной программы. Параметры командной строки doskey нельзя вызвать в программе. Эти параметры необходимо выполнить до запуска программы. Назначения комбинаций клавиш, сделанные в какой-либо программе, имеют приоритет перед назначениями команды doskey.

  • Повторный вызов команд

    Для повторного вызова команды можно использовать любую из нижеперечисленных клавиш. Если Doskey.exe используется в программе, клавиши, назначенные в этой программе, имеют приоритет.

    Клавиша | Описание
    СТРЕЛКА ВВЕРХ | Перемещение на одну команду назад в буфере команд.
    DOWN ARROW | Перемещение на одну команду вперед в буфере команд.
    PAGE UP | Перемещение в начало буфера команд.
    PAGE DOWN | Перемещение в конец буфера команд.
  • Редактирование командных строк

    С помощью программы Doskey.exe можно редактировать текущую командную строку. Если Doskey.exe используется в другой программе, клавиши, заданные в этой программе, будут иметь приоритет, возможно не все клавиши редактирования Doskey.exe будут работать.

    В следующей таблице перечислены команды редактирования doskey.

    Клавиша или сочетание клавиш | Описание
    СТРЕЛКА ВЛЕВО | Перемещение курсора на один символ назад.
    СТРЕЛКА ВПРАВО | Перемещение курсора на один символ вперед.
    CTRL + СТРЕЛКА ВЛЕВО | Перемещение курсора на одно слово назад.
    CTRL + СТРЕЛКА ВПРАВО | Перемещение курсора на одно слово вперед.
    HOME | Перемещение курсора в начало строки.
    END | Перемещение курсора в конец строки.
    ESC | Удаление всех символов командной строки.
    F1 | Копирование одного символа из шаблона в ту же позицию в окне командной строки. (Шаблоном является буфер памяти, в котором содержится последняя выполнявшаяся команда.)
    F2 | Поиск в шаблоне символа, введенного после нажатия F2. Программа Doskey.exe вставит текст из шаблона до символа, который был задан.
    F3 | Копирование оставшейся части шаблона в командную строку. Doskey.exe начинает копирование с позиции в шаблоне, которая соответствует позиции курсора в командной строке.
    F4 | Удаление символов с текущей позиции курсора до указанного символа. Чтобы использовать эту клавишу редактирования, нажмите F4 и введите символ. Doskey.exe удалит текст от текущей позиции до первого появления заданного символа.
    F5 | Копирование шаблона в командную строку.
    F6 | Вставка символа конца файла (CTRL+Z) в текущую позицию курсора.
    F7 | Вывод всех команд, сохраненных в памяти. Используйте клавиши СТРЕЛКА ВВЕРХ и СТРЕЛКА ВНИЗ для выбора требуемой команды и клавишу ENTER для выполнения команды. Кроме того, номер данной команды, который выводится справа от текста команды, может быть использован с клавишей F9.
    ALT+F7 | Удаление всех команд, сохраненных в памяти в текущем буфере.
    F8 | Вывод всех команд из буфера команд, начинающихся с символов текущей команды.
    F9 | Вывод команды, соответствующей введенному номеру в буфере команд. Для запуска команды необходимо нажать ENTER. Для вывода всех номеров и соответствующих команд используется клавиша F7.
    ALT+F10 | Удаление всех макросов.
  • Использование doskey в программах

    Некоторые интерактивные программы с символьным интерфейсом, такие как отладчики программ или программы передачи файлов (FTP), автоматически используют программу Doskey.exe. Для использования Doskey.exe программа должна быть процессом окна командной строки и использовать буферизованный ввод. Назначения комбинаций клавиш, сделанные в какой-либо программе, имеют приоритет перед назначениями команды doskey. Например, если клавиша F7 используется в программе для вызова некоторой функции, вывести содержимое буфера команд программы doskey будет невозможно.

    Программа Doskey.exe поддерживает буфер команд для всех запущенных программ, что позволяет повторять и редактировать ранее вызывавшиеся из командной строки программы и запускать макросы doskey, созданные для этих программ. Если программа перезапускается в том же окне командной строки, все использованные ею команды доступны в буфере команд.

    Doskey.exe необходимо запустить перед выполнением программы. Параметрами doskey нельзя воспользоваться в командной строке другой программы, даже если в ней применяются команды оболочки операционной системы.

    Если требуется настроить режим работы программы Doskey.exe с какой-либо программой и создать макросы doskey для этой программы, можно создать пакетный файл, который сначала будет вызывать Doskey.exe с нужными параметрами, а затем запускать соответствующую программу.

  • Задание режима вставки по умолчанию

    Если нажата клавиша INSERT, текст можно вводить прямо в середину командной строки doskey без удаления предыдущего текста. Однако после нажатия клавиши ENTER режим замены восстанавливается. Для возвращения в режим вставки необходимо снова нажать INSERT.

    Для переключения клавиатуры в режим вставки при нажатии клавиши ENTER используйте параметр /insert. Этот режим сохраняется до тех пор, пока не будет задан параметр /overstrike. Нажатие клавиши INSERT временно восстанавливает режим замены, но при нажатии клавиши ENTER в программе Doskey.exe устанавливается режим вставки.

    Форма курсора изменяется при нажатии клавиши INSERT для смены режимов.

  • Создание макросов

    В программе Doskey.exe можно создавать макросы, выполняющие одну или несколько команд. В следующей таблице перечислены специальные символы, которые можно использовать для управления выполнением команд при записи макросов.

    Символ | Описание
    $G или $g | Перенаправление вывода. Оба эти символа могут быть использованы для направления вывода на устройство или в файл, а не на экран. Эти символы эквивалентны символу перенаправления (>).
    $G$G или $g$g | Добавление вывода в конец файла. Обе эти двухсимвольные комбинации добавляют вывод к существующему файлу, а не заменяют данные в нем. Эти комбинации эквивалентны символу перенаправления вывода с добавлением (>>).
    $L или $l | Перенаправление ввода. Оба эти символа используются для считывания ввода с устройства или из файла, а не с клавиатуры. Эти символы эквивалентны символу перенаправления ввода (<).
    $B или $b | Направление вывода макроса другой команде. Использование этих специальных символов эквивалентно использованию канала (|) в командной строке.
    $T или $t | Разделители команд. Символы используются при создании макросов или вводе команд в командной строке программы doskey. Использование этих специальных символов эквивалентно использованию амперсанда (&) в командной строке.
    $$ Символ доллара ($).
    $1 до $9 | Символы замещения параметров командной строки при вызове макроса. Представляют собой пакетные параметры, позволяющие использовать различные данные в командной строке при каждом вызове программы. Символ $1 в программе doskey аналогичен символу %1 в пакетных программах.
    $* Содержит все параметры командной строки, заданные при вызове макроса. Специальный символ $* — это подставляемый символ, аналогичный пакетным параметрам с $1 по $9, но имеющий одно очень важное отличие: все, что введено в командной строке после имени макроса, подставляется вместо символа $* в макросе.
  • Вызов макросов команды doskey

    Для вызова макроса необходимо ввести его имя, начиная с первой позиции командной строки. Если в макросе используется параметр $* или какой-либо из параметров $1 – $9, вводите пробелы для разделения параметров. Вызов макросов doskey невозможен из пакетных программ.

  • Создание макросов с именами, совпадающими с именами команд Windows XP

    Если постоянно используется команда с определенными параметрами командной строки, можно создать макрос, имя которого будет совпадать с именем команды. Чтобы указать, что следует выполнить — макрос или команду, руководствуйтесь следующими инструкциями.

    • Для вызова макроса его имя должно вводиться с первой позиции командной строки без пробелов перед ним.
    • Для вызова команды перед ее именем, вводимым из командной строки, следует ввести один или несколько пробелов.
  • Удаление макроса

    Чтобы удалить макрос, введите следующую команду:

    doskey имя_макроса=

Примеры

Параметры /macros и /history полезны при создании пакетных программ для сохранения макросов и команд. Например, для сохранения всех текущих макросов doskey введите следующую команду:

doskey /macros > macinit

Чтобы воспользоваться макросами из файла Macinit, введите следующую команду:

doskey /macrofile=macinit

Чтобы создать пакетную программу Tmp.bat, которая содержит ранее использованные команды, введите следующую команду:

doskey /history > tmp.bat

Чтобы создать макрос с несколькими командами, следует использовать символ $t для разделения команд:

doskey tx=cd temp$tdir/w $*

В предыдущем примере макрос TX изменяет текущий каталог на каталог Temp и выводит список каталогов в расширенном формате. Символ $* можно использовать в конце макроса для задания дополнительных параметров команды dir при вызове макроса TX.

Следующий макрос использует пакетный параметр для задания нового имени каталога.

doskey mc=md $1$tcd $1

Макрос создает каталог, а затем делает его текущим.

Чтобы использовать предыдущий макрос для создания каталога Books, введите следующую команду:

mc books

Чтобы создать макрос doskey для программы Ftp.exe, задайте параметр /exename:

doskey /exename:ftp.exe go=open 10.127.1.100$tmget *.TXT c:\reports$bye

Чтобы воспользоваться предыдущим макросом, запустите программу ftp. В командной строке программы ftp введите следующую команду:

go

Программа ftp последовательно выполнит команды open, mget и bye.

Чтобы создать макрос, который выполняет быстрое копирование гибкого диска без подтверждения, введите следующую команду:

doskey qf=format $1 /q /u

Чтобы выполнить быстрое форматирование диска в дисководе A без подтверждения, введите следующую команду:

qf a:


Dosonly

Запрет запуска из командной строки Command.com программ, отличных от приложений MS-DOS.

Синтаксис

dosonly

Параметры

отсутствуют

Примечания

  • Обычно при завершении работы приложения MS-DOS система Windows XP возвращает управление командному интерпретатору Cmd.exe. При вызове резидентной программы (TSR) или временной остановки приложения MS-DOS для возврата к командной строке, система Windows XP запускает Command.com — командный интерпретатор MS-DOS. Это сохраняет среду MS-DOS, позволяя работать непосредственно с резидентной программой.

    Поскольку запуск других приложений из командной строки Command.com может привести к неправильной работе резидентной программы и приостановленного приложения MS-DOS, в Windows XP предусмотрена команда dosonly. Команда dosonly позволяет запускать с командной строки Command.com только исполняемые файлы MS-DOS. Команду dosonly можно поместить в файл Config.nt или в соответствующий ему специальный файл (PIF-файл) настройки приложения MS-DOS.

  • Файл Config.nt используется для инициализации среды MS-DOS, если только в PIF-файле приложения не указан другой загрузочный файл.

Примеры

Включите команду dosonly в файл Config.nt или в загрузочный файл, заданный в PIF-файле. Следующий пример иллюстрирует содержимое файла Config.nt.

dos=high,umb
device=%systemroot%\system32\himem.sys
files=40
@echo off
dosonly


Fc

Сравнение двух файлов и вывод различий между ними.

Синтаксис

fc [/a] [/b] [/c] [/l] [/lb n] [/n] [/t] [/u] [/w] [/nnnn] [диск1:][путь1]имяфайла1 [диск2:][путь2]имяфайла2

Параметры

/a
Задает сокращенный вывод ASCII сравнения. Вместо вывода фсех различающихся строк, fc выводит только начальную и конечную строки отличающихся участков.
/b
Сравнивает файлы в двоичном режиме. Команда fc сравнивает два файла байт за байтом и не пытается сопоставить файлы после найденного отличия. Этот режим используется по умолчанию для сравнения файлов с расширениями: .exe, .com, .sys, .obj, .lib или .bin.
/c
Сравнивает без учета заглавных и строчных букв.
/l
Сравнивает файлы в текстовом (ASCII) режиме. Команда fc сравнивает два файла строка за строкой и пытается сопоставить их, после того как найдено отличие. Этот режим используется по умолчанию для сравнения файлов, исключая файлы со следующими расширениями: .exe, .com, .sys, .obj, .lib или .bin.
/lb n
Задает количество строк n для внутреннего буфера. По умолчанию длина буфера составляет 100 строк. Если количество отличающихся строк в сравниваемых файлах превышает это число, команда fc прекращает сравнение.
/n
Задает вывод номеров строк при сравнении в текстовом режиме.
/t
Предотвращение fc от преобразования меток табуляции в пробелы. По умолчанию табуляторы заменяются пробелами с остановкой в каждой восьмой позиции.
/u
Задает сравнение файлов в текстовом формате Юникод.
/w
Задает сжатие пробелов и табуляций при сравнении. Если в строке содержится несколько пробелов или табуляций подряд, при использовании ключа /w они будут рассматриваться как один. Когда используется ключ /w, программа fc игнорирует (и не сравнивает) пробелы и табуляции в начале и в конце строки.
/nnnn
Задает количество совпадающих строк, используемых программой fc при новом сопоставлении файлов. Если количество совпадающих строк в файле меньше nnnn, программа fc будет выводить совпадающие строки как отличающиеся. По умолчанию значение равно 2.
[диск1:][путь1]имяфайла1
Задает местоположение и имя первого файла для сравнения. Параметр имяфайла1 является обязательным.
[диск2:][путь2]имяфайла2
Задает местоположение и имя второго файла для сравнения. Параметр имяфайла2 является обязательным.
/?
Отображение справки в командной строке.

Заметки

  • Вывод различий между файлами при текстовом сравнении в формате ASCII

    При использовании программы fc для сравнения ASCII, fc отображает различия между двумя файлами в следующем порядке:

    • имя первого файла;
    • строки из параметра имяфайла1, которые отличаются в файлах;
    • первая строка, совпадающая в обоих файлах;
    • имя второго файла;
    • отличающиеся строки из параметра имяфайла2;
    • первая строка совпадения.
  • Использование /b для двоичного сравнения

    /b отображает несоответствия, найденные в течение двоичного сравнения, как показано ниже.

    xxxxxxxx: yy zz

    Величина xxxxxxxx задает относительный шестнадцатеричный адрес пары различающихся байтов, отсчитываемый от начала файла. Адресация начинается с 00000000. Шестнадцатеричные величины yy и zz представляют различающиеся байты из имяфайла1 и имяфайла2 соответственно.

  • Использование подстановочных знаков

    Можно использовать подстановочные знаки (* and ?) в параметрах имяфайла1 и имяфайла2. Если они использованы при задании первого файла имяфайла1, программа fc будет сравнивать все заданные файлы с файлом, указанным в параметре ИмяФайла. Если подстановочные знаки использованы при задании файла имяфайла2, fc при сравнении будет использовать соответствующие значения параметра имяфайла1.

  • Работа с памятью

    При сравнении в текстовом режиме программа fc использует внутренний буфер (достаточный для размещения 100 строк). Если размер файлов больше размера буфера, программа fc будет сравнивать те части, которые поместились в буфер. Если fc не обнаруживает совпадения в загруженных частях файлов, программа остановится и будет выведено следующее сообщение:

    Не удается выполнить синхронизацию строк. Слишком много различий между файлами.

    Если же выполняется двоичное сравнение и размер файлов превосходит размер доступной памяти, fc выполняет сравнение полностью. При необходимости, файлы будут считываться с диска по частям. Вывод команды при этом не будет отличаться от вывода в случае полного размещения файлов в памяти.

Примеры

Чтобы сравнить два текстовых файла с именами Monthly.rpt и Sales.rpt и вывести результат в сокращенном формате, введите:

fc /a monthly.rpt sales.rpt

Для двоичного сравнения двух пакетных файлов Profits.bat и Earnings.bat введите:

fc /b profits.bat earnings.bat

Результат будет иметь следующий вид:

00000002: 72 43
00000004: 65 3A
0000000E: 56 92
00000012: 6D 5C
00000013: 0D 7C
00000014: 0D 0A
00000015: 0A 0D
0000001E: 43 7A
0000001F: 09 0A
00000022: 72 44
...
...
...
000005E0: 00 61
000005E1: 00 73
000005E2: 00 73
000005E3: 00 69
000005E4: 00 67
000005E5: 00 6E
000005E6: 00 6D
000005E7: 00 65
000005E8: 00 6E
FC: Earnings.bat длиннее, чем Profits.bat

Если файлы Profits.bat и Earnings.bat одинаковы, fc выводит на экран следующее сообщение:

FC: различия не найдены

Для сравнения каждого файла .bat в текущем каталоге с файлом New.bat введите:

fc *.bat new.bat

Для сравнения файла New.bat на диске C с файлом New.bat на диске D введите:

fc c:new.bat d:*.bat

Для сравнения каждого пакетного файла в корневом каталоге диска C с файлом с таким же именем в корневом каталоге на диске введите:

fc c:*.bat d:*.bat


Fcbs

Задание числа блоков управления файлом (FCB), которые могут быть одновременно открыты подсистемой MS-DOS. Для указания числа FCB используйте файл системный_корневой_каталог\System32\Config.nt или эквивалентный файл запуска, заданный в PIF-файле.

Синтаксис

fcbs=x

Параметры

x
Обязательный параметр. Задает число блоков управления, которые подсистема MS-DOS может открыть одновременно. Допустимыми являются значения x от 1 до 255. Значение по умолчанию равно 4.
/?
Отображение справки в командной строке.

Заметки

  • Блок управления файлом является структурой данных, в которой хранится информация о файле.
  • Если программа пытается открыть более x файлов с использованием блоков управления файлом, подсистема MS-DOS может закрыть файлы, которые были открыты ранее.
  • Следует использовать команду fcbs только тогда, когда этого требует какая-либо программа. Большинство современных программ не требуют использования блоков управления файлом. Однако для работы некоторых старых программ требуется поместить команду fcbs в файл Config.nt.

Примеры

Чтобы разрешить подсистеме MS-DOS открывать до восьми файлов одновременно с использованием блоков управления файлом, в файл Config.nt необходимо включить следующую команду:

fcbs=8


Files

Задание количества файлов, к которым подсистема MS-DOS может иметь доступ одновременно. Для указания параметра файлы используйте файл системный_корневой_каталог\System32\Config.nt или эквивалентный файл запуска, заданный в PIF-файле.

Синтаксис

files=x

Параметры

x
Обязательный параметр. Указание количества файлов, к которым подсистема MS-DOS может иметь доступ одновременно. Допустимыми являются значения x от 8 до 255. Значение по умолчанию равно 8.
/?
Отображение справки в командной строке.

Заметки

  • Хотя значение по умолчанию x равно 8, некоторые программы требуют большего значения. Типовым значением является 20.

Примеры

Чтобы разрешить подсистеме MS-DOS иметь доступ одновременно к 20 файлам, в файл Config.nt должна быть включена следующая команда:

files=20


Использование фильтров

Фильтр команды используется с символом перенаправления канала команды (|) и является командой внутри команды, которая считывает ввод команды, преобразовывает ввод, а затем записывает выход. Команды-фильтры дают возможность сортировать, просматривать и отбирать часть выходной информации других команд.

Фильтры делят, переупорядочивают или выделяют отдельные части из проходящей через них информации. В приведенной ниже таблице перечислены команды- фильтры.

Для направления данных из файла на вход фильтра используется символ «меньше» (<). Для направления на вход фильтра выхода другой команды используется канал (|).

Использование команды more

Команда more выводит содержимое файла или выхода команды в одном окне командной строки за раз. Например, чтобы отобразить содержимое файла List.txt в одном окне командной строки за раз, введите следующую команду:

more < list.txt

Отображается одно окно командной строки со сведениями, а затем в нижней части окна командной строки отображается строка -- More --. Для перехода к следующему окну командной строки, нажмите любую клавишу на клавиатуре, кроме клавиши PAUSE. Для остановки просмотра следует ввести комбинацию CTRL+C.

Команда more полезна при работе с командами, создающими выход более одного окна командной строки. Например, при выводе дерева каталогов жесткого диска. Если на диске содержится больше каталогов, чем может быть одновременно выведено в окне командной строки, можно использовать команду tree с каналом (|) и команду more.

tree c:\ | more

На экран будет выведен первое окно командной строки с выходом команды tree, а затем отобразится строка -- More --. Выход будет ожидать нажатия любой клавиши для продолжения (кроме клавиши PAUSE).

Использование команды find

Команда find проводит поиск заданной строки или текста в файлах. Команда Cmd.exe отображает каждую строку, которая совпадает со строкой или текстом, указанным в окне коммандной строки. Команда find может быть использована как команда-фильтр и как обычная команда Microsoft Windows XP. Дополнительные сведения об использовании команды find в качестве стандартной команды см. в разделе Find.

Чтобы использовать команду find в качестве команды-фильтра, необходимо включить символ «меньше» (<) и строку или текст, в котором требуется выполнить поиск. По умолчанию при поиске команда find учитывает регистр. Например, следующая команда будет искать строку "Pacific Rim" в файле Trade.txt:

find "Pacific Rim" < trade.txt

Выход не включает вхождение строки "pacific rim". Встречается вхождение строки "Pacific Rim" с прописными буквами.

Для сохранения результатов работы команды find (вместо отображения их в окне командной строки), введите символ «больше» (>) и имя файла, в котором требуется хранить выход. Например, следующая команда ищет строку "Pacific Rim" в файле Trade.txt с сохранением результата в файле Nwtrade.txt:

find "Pacific Rim" < trade.txt > nwtrade.txt

Использование команды sort

Команда sort выполняет сортировку по алфавиту текстового файла или выхода команды. Например, следующая команда сортирует содержимое файла List.txt и отображает результаты в окне командной строки:

sort < list.txt

В этом примере команда sort сортирует строки файла List.txt в алфавитном порядке и выводит результат на экран без изменения файла. Для сохранения результатов работы команды sort (вместо их отображения) введите символ «больше» (>) и имя файла. Например, следующую команду можно использовать для алфавитной сортировки строк файла List.txt и сохранения результатов в файле Alphlist.txt:

sort < list.txt > alphlist.txt

Для сортировки вывода команды следует ввести команду, затем символ канала (|) и команду sort (команда | sort). Например, следующая команда сортирует в алфавитном порядке строки, которые содержат слово "Jones" (вывод команды find):

find "Jones" maillst.txt | sort


Find

Поиск заданной строки текста в файле или нескольких файлах. После поиска в заданных файлах команда find выведет на экран все строки из этих файлов, содержащие заданный образец.

Синтаксис

find [/v] [/c] [/n] [/i] "строка" [[диск:][путь]ИмяФайла[...]]

Параметры

/v
Выводит все строки, не содержащие строку, заданную параметром строка.
/c
Подсчет строк, содержащих строку, указанную параметром строка, и отображение общего количества.
/n
Выводит номера строк перед самими строками.
/i
Задает поиск без различия строчных и заглавных букв.
"строка_поиска"
Обязательный параметр. Указывает группу символов, поиск которой будет производиться. Необходимо заключить параметр строка в кавычки ("строка").
[диск:][путь] ИмяФайла
Задает местоположение и имя файла, в котором будет производиться поиск заданной строки символов.
/?
Отображение справки в командной строке.

Заметки

  • Задание строки

    Если ключ /i не указан, команда find ищет именно то, что указано в параметре строка. Например, для команды find символы "a" и "A" являются различными. Если используется ключ /i, команда find не различает строчные и прописные буквы, и символы "a" и "A" являются одинаковыми.

    Если строка поиска содержит кавычки, при вызове команды каждая кавычка в строке поиска должна быть заменена двумя символами кавычек ("СтрокаСодержания""Кавычки").

  • Использование команды find в качестве фильтра

    Если имя файла пропущено, find действует как фильтр, получая ввод из стандартного источника вывода (обычно клавиатура, канал или файл перенаправления), и выводит все строки, содержащие параметр строка.

  • Порядок синтаксиса команды

    Параметры и ключи команды find могут быть заданы в произвольном порядке.

  • Использование подстановочных знаков

    Подстановочные знаки (* и ?) не могут быть использованы в именах файлов и расширениях, задаваемых в команде find. Чтобы искать строку в множестве файлов, указанных с помощью подстановочных знаков, можно использовать команду find в команде for.

  • Использование ключей /v или /n с ключом /c

    Если в одной команде заданы ключи /c и /v, команда find выведет на экран количество строк, которые не содержат заданную строку поиска. Если в одной команде указаны оба ключа: /c и /n, команда find игнорирует ключ /n.

  • Использование команды find со знаками перевода строки

    Команда find не распознает символ перевода строки. Когда команда find используется для поиска текста в файле, который содержит символы перевода строки, необходимо ограничить строку поиска текстом, который может быть найден между символами перевода строки (строка не может прерываться символом перевода строки). Например, find не найдет совпадение для строки "файл налогов" если перевод строки в файле стоит между словами "файл" и "налогов".

Примеры

Для вывода всех строк из файла Pencil.ad, которые содержат слова «Точилка» служит следующая команда:

find "Точилка" pencil.ad

Для поиска строки, содержащей текст, указанный в кавычках, необходимо сначала заключить в кавычки всю строку. Во-вторых, необходимо использовать двойные кавычки для каждых кавычек, содержащихся в строке. Поиск Ученый пометил свой документ ""только для дискуссии"". Это не окончательный отчет." В Report.doc введите:

find "Ученый пометил свой документ ""только для дискуссии."" Это не окончательный отчет." report.doc

Если поиск требуется провести в нескольких файлах, следует использовать команду find с командой for. Для поиска файлов с расширением .bat, содержащих строку "PROMPT", можно использовать следующую команду:

for %f in (*.bat) do find "PROMPT" %f

Для поиска на жестком диске C файлов, содержащих строку "CPU" и отображения их имен используйте символ канала (|), чтобы направить результаты команды dir в команду find:

dir c:\ /s /b | find "CPU"

Так как команда find проводит поиск, различая строчные и заглавные буквы, а команда dir выводит результаты заглавными буквами, необходимо задать строку "CPU" заглавными буквами или использовать ключ /i в команде find.


Findstr

Поиск образцов текста в файлах с использованием регулярных выражений.

Синтаксис

findstr [/b] [/e] [/l] [/r] [/s] [/i] [/x] [/v] [/n] [/m] [/o] [/p] [/offline] [/g:файл] [/f:файл] [/c:строка] [/d:СписокКаталогов] [/a:АтрибутЦвета] [строки] [[диск:][путь] ИмяФайла [...]]

Параметры

/b
Сравнивает шаблон с началом строки.
/e
Сравнивает шаблон с концом строки.
/l
Использует заданную строку буквально.
/r
Использует строку поиска как регулярное выражение. Команда Findstr интерпретирует все метасимволы как регулярные выражения, если не используется ключ /l.
/s
Задает поиск файлов в текущем каталоге и его подкаталогах.
/i
Задает поиск без различия строчных и заглавных букв.
/x
Печатает точно совпавшие строки.
/v
Печатает строки, не содержащие совпадений.
/n
Печатает в начале совпавшей строки ее номер.
/m
Печатает только имя файла при обнаружении совпадения.
/o
Печатает смещение перед выводом строки с совпадением.
/p
Пропускает файлы с непечатаемыми символами.
/offline
Обработка файлов с автономным атрибутом.
/f:файл
Читает список из заданного файла.
/c:строка
Использует заданный текст как литеральную строку поиска.
/g:файл
Получает строки поиска из заданного файла.
/d:СписокКаталогов
Ищет в списке каталогов, разделенном запятыми.
/a:АтрибутЦвета
Задает атрибуты цвета двумя шестнадцатеричными цифрами.
строки
Текст, поиск которого производится в файле, заданном параметром ИмяФайла.
[диск:][путь] ИмяФайла [...]
Файл или несколько файлов для поиска.
/?
Отображение справки в командной строке.

Заметки

  • Использование регулярных выражений с командой findstr

    Команда findstr способна выполнять точный поиск текста в любом текстовом файле или файлах формата ASCII. Однако иногда имеется только часть информации, которая должна быть найдена, или требуется найти информацию в широком диапазоне. В таких случаях команда findstr предоставляет мощную возможность поиска с использованием регулярных выражений.

    В противоположность точному заданию строки символов для поиска, регулярные выражения позволяют задать образец текста. Для задания образца используются литералы и метасимволы. Каждый символ, который не имеет специального значения в регулярных выражениях, рассматривается как литерал и должен точно совпасть при поиске. Например, буквы и цифры являются литеральными символами. Метасимволы — это символы со специальным значением (оператор или разделитель) в регулярных выражениях.

    В приведенной ниже таблице перечислены метасимволы, допустимые для команды findstr.

    Символ | Значение
    . Подстановочный знак: любой символ
    * Повтор: ноль или более предшествующих символов или классов символов.
    ^ Позиция строки: начало строки
    $ Позиция строки: конец строки
    [класс] | Класс символа: любой символ из множества
    [^класс] | Инвертированный класс: любой символ из множества
    [x-y] | Диапазон: любой символ из диапазона
    \x | Исключение: использование метасимвола x в качестве литерала
    \<xyz | Позиция слова: начало слова
    xyz\> | Позиция слова: конец слова

    Специальные символы в регулярных выражениях дают наилучший результат при совместном использовании. Например, при комбинации символа подстановки (.) и повторителя (*) совпадает любая строка символов:

    .*

    Используйте следующее выражение как часть более объемного выражения, которое совпадает со строкой, начинающейся с "b" и оканчивающейся на "ing":

    b.*ing

Примеры

Для отделения строк поиска друг от друга следует использовать пробелы, кроме тех случаев, когда задан ключ /c. Для поиска слова "hello" или "there" в файле x.y введите следующую каманду:

findstr "hello there" x.y

Для поиска словосочетания "hello there" в файле x.y введите следующую каманду:

findstr /c:"hello there" x.y

Для поиска всех слов "Windows" (с первой заглавной буквой W) в файле Proposal.txt может быть использована следующая команда:

findstr Windows proposal.txt

Для поиска в каждом файле текущего каталога и в файлах всех подкаталогов слова "Windows" без учета строчных и заглавных букв может быть использована следующая команда:

findstr /s /i Windows *.*

Для поиска всех строк, содержащих слово "FOR", перед которым идет несколько пробелов (чтобы найти в программе оператор цикла), с выводом номера каждой строки можно использовать команду:

findstr /b /n /c:" *FOR" *.bas

Если требуется найти несколько разных наборов символов в нескольких файлах, можно создать текстовый файл, каждая строка которого содержит образец для поиска. Также можно задать точный список файлов, если поиск будет производиться в текстовых файлах. Для использования файла Finddata.txt, содержащего образцы для поиска, файла Filelist.txt, содержащего список файлов, в которых будет производиться поиск, и записи результатов работы программы в файл Results.out служит следующая команда:

findstr /g:finddata.txt /f:filelist.txt > results.out

Предположим, необходимо найти каждый файл в текущем каталоге и его подкаталогах, содержащий слово "computer" без различия строчных и заглавных букв. Для вывода списка таких файлов можно использовать следующую команду:

findstr /s /i /m "\<computer\>" *.*

Теперь, предположим, требуется найти не только само слово "computer", но и все другие слова, начинающиеся с тех же букв, таких как "compliment" и "compete". Введите следующую команду:

findstr /s /i /m "\<comp.*" *.*


For

Запуск некоторой команды для каждого файла из заданного множества.

Синтаксис

for {%переменная|%%переменная} in (множество) do команда [ПараметрыКоманднойСтроки]

Параметры

{%переменная|%%переменная}
Обязательный параметр. Замещаемый параметр. Используйте %переменная для выполнения команды for из командной строки. Используйте %%переменная для выполнения команды for в пакетном файле. Переменные учитывают регистр и могут быть представлены со значением альфа, например, %A, %B или %C.
(множество)
Обязательный параметр. Задает один или несколько файлов, каталогов, диапазон значений или текстовых строк, подлежащих обработке заданной командой. Скобки являются обязательными.
команда
Обязательный параметр. Задает команду, которая будет выполнена для каждого файла, каталога диапазона значений или текстовой строки, включенной в указанный параметр (множество).
ПараметрыКоманднойСтроки
Задает параметры командной строки, которые используются с указанной командой.
/?
Отображение справки в командной строке.

Заметки

  • Использование программы for

    Команда for может быть использована в пакетном файле или непосредственно из командной строки.

  • Использование параметров командной строки пакетного файла

    Перечисленные ниже атрибуты применяются к команде for.

    • В команде for переменная %%переменная (или %%переменная) будет заменяться текстовой строкой из заданного параметра множество, пока параметр команда не обработает все файлы этого множества.
    • Имена параметров переменная команды for учитывают регистр буквы, они являются глобальными и одновременно может быть активно не больше 52 переменных.
    • Для обозначения параметра переменная можно использовать любые символы, кроме цифр 0–9, чтобы не было конфликта с параметрами пакетных файлов %0–%9. Для простых пакетных файлов вполне достаточно обозначений с одним символом, например %%f.
    • В сложных пакетных файлах могут быть использованы и другие обозначения для параметра переменная.
  • Задание множества файлов

    Параметр множество может представлять группу файлов или несколько групп файлов. Для задания групп файлов можно использовать подстановочные знаки (* и ?). Следующие множества файлов являются допустимыми:

    (*.doc)

    (*.doc *.txt *.me)

    (jan*.doc jan*.rpt feb*.doc feb*.rpt)

    (ar??1991.* ap??1991.*)

    Когда используется команда for, первое значение в параметре множество заменяет параметр %%переменная (или %переменная), а затем для обработки этого значения выполняется указанная команда. Это продолжается до тех пор, пока не будут обработаны все файлы (или группы файлов), которые соответствуют значению параметра множество.

  • Использование ключевых слов in и do

    In и do не являются параметрами, но они требуются для работы команды for. Если какое-то из слов пропущено, на экран будет выведено сообщение об ошибке.

  • Использование дополнительных форм команды for

    Если расширения командного процессора разрешены (по умолчанию), то поддерживаются следующие дополнительные формы команды for.

    • Только каталоги

      Если параметр множество содержит подстановочные знаки (* и ?), команда, указанная в параметре команда, выполняется для каждого каталога (кроме множества файлов в указанном каталоге), совпадающего с параметром множество. Используется следующий синтаксис.

      for /D {%% | %}переменная in (множество) do команда [ПараметрыКоманднойСтроки]

    • Рекурсивная

      Проходит по дереву каталогов с корнем в [диск:]путь, выполняя инструкцию for для каждого каталога в дереве. Если после ключа /R не задан каталог, предполагается текущий каталог. Если параметр множество задано одной точкой (.), то команда просто перечислит каталоги в дереве. Используется следующий синтаксис.

      for /R [[диск :]путь] {%% | %}переменная in (множество) do команда [ПараметрыКоманднойСтроки]

    • Итерация диапазона значений

      Используйте переменную итерации для установки начального значения (НачальноеЗначение#), а затем перемещайтесь по диапазону значений, пока значение не превысит конечное значение множества (КонечноеЗначение#). /L выполнит итерацию, сравнив параметр НачальноеЗначение# с параметром КонечноеЗначение#. Если параметрНачальноеЗначение# меньше параметра КонечноеЗначение#, то выполняется команда. Когда переменная итерации превысит параметр КонечноеЗначение#, командная оболочка покидает цикл. Также можно использовать отрицательный параметр шаг# для перемещения в диапазоне убывающих значений. Например, (1,1,5) создает последовательность «1 2 3 4 5», а (5,-1,1) создает последовательность «5 4 3 2 1». Используется следующий синтаксис.

      for /L {%% | %}переменная in (НачальноеЗначение#,шаг#,КонечноеЗначение#) do команда [ПараметрыКоманднойСтроки]

    • Итерация и разбор файлов

      Разбор файлов следует использовать для обработки вывода команды, строк и содержимого файла. Используйте переменные итерации для определения содержимого или строк, которые требуется проверить. Параметр КлючевыеСловаРазбора используется для изменения разбора. Используйте параметр КлючевыеСловаРазбора маркер для указания маркеров, которые воспринимаются как переменные итерации. Примечание. Без параметра маркера ключ /F проверяет только первый маркер.

      Разбор файлов состоит в чтении вывода, строки или содержимого файла, разбиении его на отдельные строки текста и разборе каждой строки на ноль или маркеры. Цикл программы for затем называется с переменной итерации, установленной в маркер. По умолчанию /F передает первый отделенный пробелом элемент из каждой строки каждого файла. Пустые строки пропускаются. Используется также другой синтаксис.

      for /F ["КлючевыеСловаРазбора"] {%% | %}переменная in (МножествоИменФайлов) do команда [ПараметрыКоманднойСтроки]

      for /F ["КлючевыеСловаРазбора"] {%% | %}переменная in ("СимвольнаяСтрока") do команда [ПараметрыКоманднойСтроки]

      for /F ["КлючевыеСловаРазбора"] {%% | %}переменная in ('команда') do команда [ПараметрыКоманднойСтроки]

      Аргумент МножествоИменФайлов задает одно или несколько имен файлов. Каждый файл открывается, считывается и обрабатывается до перехода к следующему файлу в аргументе МножествоИменФайлов. Чтобы переопределить стандартное поведение разбора, укажите параметр "КлючевыеСловаРазбора". Это строка, заключенная в кавычки, которая содержит одно или несколько ключевых слов для указания различных режимов разбора.

      Если используется параметр usebackq, используйте один из приведенных ниже синтаксисов:

      for /F ["usebackq КлючевыеСловаРазбора"] {%% | %}переменная in ("МножествоИменФайлов") do команда [ПараметрыКоманднойСтроки]

      for /F ["usebackq КлючевыеСловаРазбора"] {%% | %}переменная in ('СимвольнаяСтрока') do команда [ПараметрыКоманднойСтроки]

      for /F ["usebackq КлючевыеСловаРазбора"] {%% | %}переменная in (`команда`) do команда [ПараметрыКоманднойСтроки]

      В приведенной ниже таблице перечислены ключевые слова разбора, которые используются для параметра КлючевыеСловаРазбора.

      Ключевое слово | Описание
      eol=c | Задает символ конца строки (только один символ).
      skip=n | Задает число строк, пропускаемых в начале файла.
      delims=xxx | Задает набор разделителей. Заменяет набор разделителей по умолчанию, состоящий из пробела и символа табуляции.
      tokens=x,y,m-n | Задает элементы, передаваемые из каждой строки в тело цикла for при каждой итерации. В результате размещаются дополнительные имена переменных. Форма m-n задает диапазон, указывающий элементы с m-го по n-ый. Если последним символом строки tokens= является звездочка (*), то размещается дополнительная переменная, в которую помещается остаток строки после разбора последнего элемента.
      usebackq | Задает возможность использования кавычек для имен файлов в параметре МножествоИменФайлов. Задает исполнение строки, заключенной в обратные кавычки, как команды, а строки в одиночных кавычках — как команды в символьной строке.
    • Подстановка переменных

      Были расширены модификаторы подстановок для ссылок на переменные в for. Приведенная ниже таблица перечисляет варианты синтаксических конструкций (на примере переменной I).

      Переменная с модификатором | Описание
      %~I | Расширение %I, которое удаляет окружающие кавычки ("").
      %~fI | Расширение %I до полного имени пути.
      %~dI | Замена %I именем диска.
      %~pI | Замена %I на путь.
      %~nI | Замена %I одним именем файла.
      %~xI | Замена %I расширением имени файла.
      %~sI | Замена путем, содержащим только короткие имена.
      %~aI | Замена %I атрибутами файла.
      %~tI | Замена %I временем модификации файла.
      %~zI | Замена %I размером файла.
      %~$PATH:I | Поиск в каталогах, перечисленных в переменной среды PATH, и замена %I полным именем первого найденного файла. Если переменная среды не определена или поиск не обнаружил файлов, модификатор выдает пустую строку.

      Приведенная ниже таблица перечисляет комбинации модификаторов, которые можно использовать для получения более сложных результатов.

      Переменная с объединенными модификаторами | Описание
      %~dpI | Замена %I именем диска и путем.
      %~nxI | Замена %I именем файла и расширением.
      %~fsI | Замена %I полным именем пути с короткими именами.
      %~dp$PATH:I | Поиск в каталогах, перечисленных в переменной среды PATH, и замена %I именем диска и путем первого найденного файла.
      %~ftzaI | Замена %I строкой, аналогичной результату работы программы dir.

      В приведенных выше примерах %I и PATH могут быть заменены другими допустимыми значениями. Допустимое имя переменной for прекращает %~ syntax.

      Использование прописных букв в именах переменных, например %I, может улучшить восприятие программы и позволит избежать недоразумений с модификаторами, в которых строчные и прописные буквы не различаются.

  • Разбор строки

    Конструкция for /F может быть использована непосредственно для строки. Для этого поместите параметр МножествоИменФайлов между скобками в одиночные кавычки ('МножествоИменФайлов'). Параметр МножествоИменФайлов будет воспринят как одиночная строка ввода из файла и будет разобран.

  • Разбор вывода

    Команду for /F можно использовать для разбора вывода команды. Для этого поместите параметр МножествоИменФайлов между скобками в обратные кавычки. Он будет воспринят как командная строка, которая передается дочернему интерпретатору командной строки Cmd.exe, а результаты работы команды помещаются в памяти и разбираются, как если бы они являлись файлом.

Примеры

В пакетных файлах используется следующий синтаксис для команды for:

for %%переменная in (множество) do команда [ПараметрыКоманднойСтроки]

Чтобы отобразить содержимое всех файлов, имеющих разрешение .doc или .txt, в текущем каталоге с помощью заменяемой переменной %f, введите следующую команду:

for %f in (*.doc *.txt) do type %f

В предыдущем примере каждый файл с расширением .doc или .txt в текущем каталоге будет подставляться вместо переменной %f, пока не будет выведено содержимое всех файлов. Чтобы использовать данную команду в пакетном файле, следует заменить все вхождения %f на %%f. В противном случае переменная игнорируется, и отображается сообщение об ошибке.

Чтобы произвести разбор файла, игнорируя комментарии, можно использовать следующую команду:

for /F "eol=; tokens=2,3* delims=," %i in (myfile.txt) do @echo %i %j %k

Данная команда производит разбор каждой строки в файле Myfile.txt, игнорируя строки, начинающиеся с точки с запятой, и передает второй и третий элементы из каждой строки в тело цикла команды FOR. Элементы разделяются запятыми и/или пробелами. Тело инструкции FOR использует %i для получения второго элемента, %j для получения третьего элемента и %k для получения оставшихся элементов в строке. Если имена файлов содержат пробелы, их следует заключать в кавычки (например, "ИмяФайла"). Для использования кавычек необходима команда usebackq. В противном случае кавычки рассматриваются как определение символьной строки для разбора.

Переменная %i объявлена явно в инструкции FOR, а %j и %k объявлены неявно с помощью tokens=. С помощью tokens= можно указать до 26 элементов, если это не вызовет попытки объявить переменную с именем, большим буквы "z" или "Z".

Для разбора вывода команды с помощью помещения параметра МножествоИменФайлов в скобки можно использовать следующую команду:

for /F "usebackq delims==" %i IN (`set`) DO @echo %i

В данном примере перечисляются имена переменных среды в текущем окружении.


Forcedos

Запуск заданной программы в подсистеме MS-DOS. Эта команда необходима для тех программ MS-DOS, которые не распознаются системой Microsoft Windows XP.

Синтаксис

forcedos [/d каталог] ИмяФайла [параметры]

Параметры

/d каталог
Задает текущий каталог для запускаемой программы.
ИмяФайла
Обязательный параметр. Задает программу, которая будет запущена. Если файл программы не находится в текущем каталоге, необходимо задать имя каталога и диска.
параметры
Задает параметры, которые будут переданы программе.
/?
Отображает справку в командной строке.

Заметки

  • Некоторые программы MS-DOS не распознаются системой Microsoft Windows XP как программы MS-DOS. Для запуска таких программ служит команда forcedos.
  • Все программы, запускаемые командой forcedos, открываются как приложения MS-DOS.

Примеры

Чтобы запустить программу Myprog из каталога \Oldapps и иметь возможность использовать каталог \Reports, введите следующую команду:

forcedos /d reports \oldapps\myprog


Format

Форматирование диска в заданном дисководе для использования системой Windows.

Синтаксис

format том [/fs:ФайловаяСистема] [/v:метка] [/q] [/a:размер] [/c] [/x]

format том [/v:метка] [/q] [/f:размер]

format том [/v:метка] [/q] [/t:дорожки /n:сектора]

format том [/v:метка] [/q]

format том [/q]

Параметры

том
Задает точку подключения, имя тома или имя диска, который необходимо отформатировать. Если никакие из следующих параметров командной строки не заданы, команда format будет использовать тип тома для определения параметров форматирования диска по умолчанию.
/fs:ФайловаяСистема
Тип файловой системы, которая будет создана на диске: FAT, FAT32 или NTFS. Гибкие диски могут использовать только файловую систему FAT.
/v:метка
Задает метку тома. Если параметр командной строки /v пропущен или использован без задания метки, команда format выведет запрос для ввода метки тома после завершения форматирования. Чтобы отключить вывод запроса для ввода метки, введите параметр со следующим синтаксисом: /v:. Если с помощью команды format форматируется несколько дисков, всем дискам будет присвоена одна метка тома. Чтобы получить дополнительные сведения о метках томов, выберите Dir, Label и Vol из списка в ссылке "См. также".
/a:размер
Задает размер блоков выделения дискового пространства для систем FAT, FAT32 или NTFS. Если параметр размер не задан, он будет определен исходя из размера диска. В приведенной ниже таблице перечислены допустимые значения параметра размер.
Значение | Описание
512 | Кластеры по 512 байта.
1024 | Кластеры по 1024 байта.
2048 | Кластеры по 2048 байта.
4096 | Кластеры по 4096 байта.
8192 | Кластеры по 8192 байта.
16K | Кластеры по 16 Кбайт.
32K | Кластеры по 32 Кбайт.
64K | Кластеры по 64 Кбайт.
/q
Выполняет быстрый формат. Удаляет таблицу файлов и корневой каталог ранее отформатированного тома без поиска поврежденных секторов. Параметр командной строки /q следует использовать только для форматирования дисков, которые находятся в хорошем состоянии.
-f:размер
Задает емкость гибкого диска, под которую он будет отформатирован. По возможности используйте данный параметр параметр командной строки вместо параметров /f и /n. Windows допустимыми являются следующие значения размера:

1440 , 1440k, 1440kb, 1.44, 1.44m, 1.44mb
1,44 Мб, двухсторонний 3,5-дюймовый диск с четверной плотностью

/t:дорожки
Задает количество дорожек на диске. По возможности используйте параметр командной строки /f вместо этого параметра командной строки. Если используется параметр командной строки /t, необходимо также использовать параметр /n. Указанные два параметра командной строки предлагают альтернативный способ задания размера форматируемого диска. Параметр командной строки /f невозможно использовать с параметром /t.
/n:сектора
Задает количество секторов на дорожке. По возможности используйте параметр командной строки /f вместо этого параметра командной строки. Если используется параметр командной строки /n, необходимо также использовать параметр /t. Указанные два параметра командной строки предлагают альтернативный способ задания размера форматируемого диска. Параметр командной строки /f невозможно использовать с параметром /n.
/c
Только для NTFS. Файлы, создаваемые на новом диске, будут по умолчанию сжиматься.
/x
Вызывает отключение тома перед форматированием, если это необходимо. Все открытые дескрипторы тома становятся недействительными.
/?
Отображает справку в командной строке.

Заметки

  • Использование команды format на консоли восстановления

    Команда format с другими параметрами доступна на консоли восстановления.

  • Привилегии администратора

    Чтобы форматировать жесткий диск с помощью этой команды, необходимо быть членом группы администраторов.

  • Использование команды format

    Команда format создает новый корневой каталог и файловую систему на диске. Также возможен поиск сбойных участков на диске и удаление всех данных с диска. Перед использованием нового диска он должен быть отформатирован с использованием этой команды.

  • Ввод метки тома

    После того, как гибкий диск будет отформатирован, команда format выведет на экран следующий запрос:

    Метка тома (11 символов, ENTER - метка не нужна)?

    Метка тома может состоять максимум из 11 символов (считая пробелы). Если ввод метки тома не требуется, следует просто нажать ENTER. Чтобы получить сведения о метках томов, выберите label из списка в ссылке "См. также".

  • Форматирование жестких дисков

    Когда команда format используется для форматирования жесткого диска, перед началом форматирования командой formatна экран будет выведено следующее сообщение:

    ВНИМАНИЕ, ВСЕ ДАННЫЕ НА НЕСЪЕМНОМ ДИСКЕ
    x БУДУТ УНИЧТОЖЕНЫ!
    Приступить к форматированию [Y(да)/N(нет)]?_

    Для форматирования жесткого диска следует нажать Y; для отмены — N. Для форматирования жесткого диска надо иметь права администратора.

  • Размер кластера

    Файловая система FAT позволяет иметь на диске не больше 65526 кластеров. Файловая система FAT32 ограничивает число кластеров диапазоном от 65527 до 4177917.

    Для дисков с размером кластера больше 4096 сжатие NTFS не поддерживается.

  • Сообщения команды Format

    После окончания процесса форматирования программой format на экран будет выведено сообщение, содержащее сведения об общем объеме диска, о сумме размеров поврежденных секторов и о пространстве, доступном для размещения файлов.

  • Быстрое форматирование

    Параметр командной строки /q позволяет ускорить процесс форматирования. Используйте этот параметр только для форматирования жестких дисков, заведомо не содержащих поврежденные сектора.

  • Использование команды format с переназначенными и сетевыми дисками

    Диски, созданные командой subst, не могут быть отформатированы командой format. Также невозможно форматирование сетевых дисков.

  • Коды завершения команды Format

    В следующей таблице перечислены коды завершения с кратким описанием.

    Код завершения | Описание
    0 | Форматирование прошло успешно
    1 | Были заданы недопустимые параметры
    4 | Возникла фатальная ошибка (любая ошибка, кроме 0, 1 или 5).
    5 | В ответ на сообщение "Приступить к форматированию [Y(да)/N(нет)]?" была нажата клавиша N.

    Коды завершения могут быть проверены с помощью переменной errorlevel в пакетной команде if.

Примеры

Чтобы отформатировать новый гибкий диск в дисководе A с использованием размера по умолчанию, следует ввести следующую команду:

format a:

Для быстрого форматирования ранее отформатированного диска в дисководе A можно использовать следующую команду:

format a: /q

Чтобы отформатировать гибкий диск в дисководе A и присвоить метку тома "DATA", следует использовать следующую команду:

format a: /v:DATA


Ftype

Вывод или редактирование связи между типом файла и его расширением. Для просмотра текущих назначений служит команда ftype без параметров.

Синтаксис

Ftype [тип_файла[=[команда_открытия]]]

Параметры

тип_файла
Задает тип файла.
команда_открытия
Задает команду для открытия файлов данного типа.
/?
Отображение справки в командной строке.

Заметки

  • В команде_открытия команда ftype использует следующие подстановки переменных:
    • %0 или %1 замещаются именем открываемого файла.
    • %* замещается всеми параметрами
    • %~n замещаются всеми остальными параметрами, начиная с n-го параметра, где n — любое число от 2 до 9.
    • %2 замещается первым параметром, %3 — вторым и т. д.

Примеры

Чтобы просмотреть текущие типы файлов, для которых определены команды открытия, введите:

ftype

Чтобы просмотреть текущую команду открытия для определенного типа файла, введите:

ftype тип_файла

Чтобы удалить команду открытия для определенного типа файла, введите:

ftype тип_файла=

Введите

ASSOC .pl=PerlScript FTYPE PerlScript=perl.exe %1 %*

Чтобы вызвать сценарий Perl, введите:

script.pl 1 2 3

Чтобы избавиться от необходимости ввода расширений, введите:

set PATHEXT=.pl;%PATHEXT%

Чтобы вызвать сценарий Perl, введите:

script 1 2 3


Fc

Finger

Отображает сведения о пользователе или пользователях конкретного удаленного компьютера (обычно с операционной системой UNIX), запускающего службу Finger или демон. Удаленный компьютер указывает формат и вывод экрана сведений пользователя. Запущенная без параметров, команда finger выводит справку.

Синтаксис

finger [-l] [пользователь] [@узел] [...]

Параметры

-l
Выводит сведения пользователя в форме длинного списка.
Пользователь
Задает пользователя, информация о котором будет получена. Если параметр пользователь не задан, командой finger будет выведена информация обо всех пользователях на указанном компьютере.
@узел
Удаленный компьютер, запускающий службу Finger, на котором производится поиск сведений пользователя. Можно указать имя компьютера или IP-адрес.
/?
Отображение справки в командной строке.

Заметки

  • Может быть указано несколько параметров пользователь@узел.
  • Перед параметром finger необходимо поместить дефис (-), а не косую черту (/).
  • Эта команда доступна, только если в свойствах сетевого адаптера в объекте Сетевые подключения в качестве компонента установлен протокол Интернета (TCP/IP).
  • Операционные системы Microsoft Windows 2000 и Microsoft Windows XP не предоставляют службу finger.

Примеры

Чтобы отобразить сведения для user1 на компьютере users.microsoft.com, введите следующую команду:

finger user1@users.microsoft.com

Чтобы отобразить сведения для всех пользователей на компьютере users.microsoft.com, введите следующую команду:

finger @users.microsoft.com

Условные обозначения форматирования

Формат | Значение
Курсив | Сведения, вводимые пользователем
Полужирный | Элементы, вводимые без изменений
Многоточие (...) | Параметр может быть введен в командной строке несколько раз
В квадратных скобках ([]) | Необязательные элементы
В фигурых скобках ({}); варианты, разделенные вертикальной линией (|), пример: {even|odd} | Набор вариантов, из которых необходимо выбрать один
Шрифт Courier | Выходные данные программы


Fsutil

Fsutil является служебной программой командной строки, которая используется для выполнения связанных задач файловых систем FAT и NTFS, таких как управление точками повторной обработки, управление разреженными файлами, отключение тома или расширение тома. Поскольку программа fsutil является весьма мощной, ее должны применять только опытные пользователи, имеющие опыт работы с Microsoft Windows XP. Для использования программы fsutil необходимо войти в систему с помощью учетной записи администратор или члена группы администраторов.

В следующей таблице перечислены подкоманды команды fsutil.

Команда | Описание
behavior | Запрашивает, изменяет, включает или отключает настройки для создания имен файлов с длиной 8.3 символа, для возможности отображения расширенных символов в имена файлов длиной 8.3 символа в томах NTFS, для обновления штампа времени последнего доступа к томам NTFS, частоты событий, записанных в системных журнал, и количества места на диске, зарезервированного зоной основной таблицы файлов.
dirty | Запрос установки «грязного» бита тома. Задает «грязный» бит тома. Когда установлен «грязный» бит тома, autochk автоматически проверит том на наличие ошибок при следующей перезагрузке компьютера.
file | Обычно используется специалистами по технической поддержке. Поиск файла по идентификатору безопасности, запрос файла в размещенных диапазонах, установка короткого имени файла, допустимой длины данных или нулевых данных для файла.
fsinfo | Обычно используется специалистами по технической поддержке. Перечисляет все диски, запрашивает тип диска, сведения о томе, специальные сведения о томе NTFS или статистику файловой системы.
hardlink | Создает жесткую связь. Жесткая связь представляет запись каталога для файла. Каждый файл можно рассматривать как имеющий по крайней мере одну жесткую связь. В томах NTFS каждый файл имеет несколько жестких связей, следовательно один файл может отображаться во многих каталогах (или даже в одном каталоге под различными именами). Поскольку ссылки на все связи находятся в одном файле, программы могут открывать любую из связей и изменять файл. Файл удаляется из файловой системы только после удаления всех связей. После создания жесткой связи, программы могут использовать ее как любое другое имя файла.
objectid | Обычно используется специалистами по технической поддержке. Управляет идентификаторами объектов, которые используются Windows XP для отслеживания объектов, таких как файлы и каталоги.
quota | Управляет дисковыми квотами в томах NTFS для предоставления более точного контроля за сетевым носителем. Дисковые квоты внедрены в тома и включают внедрение ограничений жестких и съемных носителей в тома.
reparsepoint | Обычно используется специалистами по технической поддержке. Запрашивает или удаляет точки повторной обработки, являющиеся объектами файловой системы NTFS, которые имеют определяемый атрибут, содержащий контролируемые пользователем данные, и используются для расширения функциональности подсистемы ввода/вывода. Точки повторной обработки используют как точки соединения каталогов и точки подключения томов. Они также используются драйверами фильтров файловой системы, чтобы пометить определенные файлы как специфические для этого драйвера.
sparse | Управление разреженными файлами. Разреженным файлом называют файл, внутри которого имеется одна или несколько областей, незанятые данными. Программа будет рассматривать эти незанятые области как содержащие байты с нулевыми значениями, но не будет использовать пространство на диске для представления этих нулей. Другими словами, место выделяется для значимых (ненулевых) данных, тогда как место под незначимые данные (длинные строки, состоящие из нулей) не выделяется. При чтении разреженного файла выделенные данные возвращаются в том виде, в котором они сохранены, а невыделенные данные по умолчанию возвращаются в виде нулей, согласно требованиям спецификации безопасности C2. Поддержка разреженного файла позволяет освобождать данные из любого места в файле.
usn | Обычно используется специалистами по технической поддержке. Управление журналом изменения номеров последовательных обновлений (USN), в котором сохраняется архив всех изменений файлов в томе.
volume | Управление томом. Отсоединяет том или запросы для отображения количества свободного места на диске.

Примечание

  • Для отображения справки для доступных подкоманд в командной строке, введите fsutil, введите подкоманду, а затем введите команду help (fsutil подкоманда help).


Fsutil: behavior

Запрашивает текущие настройки для создания имен файлов с длиной 8.3 символа, для возможности отображения расширенных символов в имена файлов длиной 8.3 символа в томах NTFS, для обновления штампа времени последнего доступа к томам NTFS, частоты событий, записанных в системных журнал, и количества места на диске, зарезервированного зоной основной таблицы файлов (MFT). Включение и отключение использование имен файлов длиной 8.3 символа путем разрешения расширенных символов в именах файлов длиной 8.3 символа в томах NTFS и обновления штампа времени последнего доступа к томам NTFS. Позволяет изменять частоту записи событий квот в системный журнал и количество места на диске, зарезервированная для зоны основной таблицы файлов.

Синтаксис

  • fsutil behavior query {disable8dot3|allowextchar|disablelastaccess|quotanotify|mftzone}

  • fsutil behavior set [{disable8dot3 {1|0}|allowextchar {1|0}|disablelastaccess {1|0}|quotanotify частота|mftzone значение}]

    Параметры

    query
    Запрашивает параметры поведения файловой системы.
    set
    Изменяет параметры поведения файловой системы.
    disable8dot3 {1|0}
    Отключает создание имен файлов длиной 8.3 символа в томах с форматом FAT и NTFS.
    allowextchar {1|0}
    Определяет, могут ли быть использованы символы из расширенного набора симполов, включая диакритические знаки, в коротких именах файлов 8.3 в томах NTFS.
    disablelastaccess {1|0}
    Определяет, обновляет ли NTFS штамп времени последнего доступа в каждом каталоге при перечислении каталогов в томе NTFS.
    quotanotify частота
    Настраивает частоту отчета о нарушении квот NTFS в системном журнале. Введите частоту (от 0 до 4294967295 секунд) записи нарушений квот в системный журнал. Значение по умолчанию составляет 1 час (3600 секунд).
    mftzone значение
    Зона основной таблицы файлов (MFT) является зарезервированной областью, позволяющей основной таблице файлов при необходимости расширяться, чтобы предотвратить фрагментацию основной таблицы файлов. Устанавливает величину параметра значение от 1 (по умолчанию) до 4 (максимум). Параметр значение расположен в 8 части диска.

    Заметки

    • Подкоманда behavior записывает изменения в системный реестр, поэтому для вступления изменений в силу необходимо перезагрузить компьютер.
    • Использование disable8dot3 {1|0}

      Если disable8dot3 имеет значение 0, то каждый раз при создании файла с длинным именем NTFS создает вторую запись файла, имеющую длину имени файла 8.3 символа. Когда NTFS создает файлы в папке, необходимо выполнять поиск имен файлов длиной 8.3 символа, связанных с длинными именами файлов.

      Данный параметр обновляет раздел реестра HKLM\SYSTEM\CurrentControlSet\Control\FileSystem\NtfsDisable8dot3NameCreation.

    • Использование allowextchar {1|0}

      Данный параметр обновляет раздел реестра HKLM\SYSTEM\CurrentControlSet\Control\FileSystem\NtfsAllowExtendedCharacterIn8dot3Name.

    • Использование disablelastaccess {1|0}

      Параметр disablelastaccess разработан для уменьшения воздействия ведения журнала обновления штампа времени последнего доступа к папкам и каталогам. Отключение времени последнего доступа увеличивает скорость доступа к папкам и файлам.

      Каждый файл и папка в томе NTFS содержит атрибут, который называется время последнего доступа. Данный атрибут определяет время последнего доступа к файлу или папке, например, просмотр папок пользователем, добавление файлов в папку, чтение файла или внесение изменений в файл. Самое новое время последнего доступа хранится в памяти и записывается на диск в два различных расположения. Одно расположение внутри атрибута файла, который является частью записи основной таблицы файлов (MFT). Второе расположения является индексом каталога, в котором содержится файл.

      Время последнего доступа на диске не всегда является текущим временем. Данное запаздывание возникает из-за задержки NTFS при записи времени последнего доступа на диск, когда пользователи или программы выполняют над файлом или папкой операции только для чтения, например, перечень содержимого папки или чтение (но не изменение) файла в папке. Если время последнего доступа совпадает с текущим временем на диске для операций чтения, все операции чтения становятся операциями записи и влияют на производительность NTFS.

      Примечание. Запросы времени последнего доступа, основанные на файлах, являются даже если все значения на диске не являются текущими. NTFS возвращает правильное значение на запросы, поскольку точное значение хранится в памяти.

      NTFS обычно обновляет атрибут файла на диске на более поздний, если текущее время последнего доступа в памяти отличается более, чем на час от времени последнего доступа, хранимого на диске, или если все ссылки на файл в памяти пропали. Например, если текущее время последнего доступа к файлу 1:00 P.M., а файл был прочтен в 1:30 P.M., то NTFS не обновляет время последнего доступа. Если файл был прочтен снова в 2:00 P.M., NTFS обновляет время последнего доступа в атрибуте файла на 2:00 P.M., поскольку в атрибуте файла отображалось 1:00 P.M., а в время последнего доступа в памяти отображало 2:00 P.M.

      NTFS обновляет индекс каталога, который содержит файл, при обновлении времени последнего доступа к файлу и обнаруживает, что время последнего доступа к файлу отличается более, чем на час от времени последнего доступа, которое хранится в индексе каталога. Данное обновление обычно происходит после закрытия программой дескриптора, используемого для доступа к файлу внутри каталога. Если пользователь держит дескриптор открытым для расширенного времени, возникает задержка перед отображением изменений в записи индекса каталога.

      Примечание. Один час является максимальным временем, различимым NTFS при обновлении времени последнего доступа на диске. Если NTFS обновляет другие атрибуты файла, например, время последнего изменения, а время последнего доступа отложено, то NTFS обновляет время последнего доступа вместе с другими обновлениями без дополнительного воздействия на быстродействие.

      Примечание. Использование параметра disablelastaccess может влиять на программы, использующие эту возможность, например, создание резервной копии и внешнее хранилище.

      Данный параметр обновляет раздел реестра HKLM\SYSTEM\CurrentControlSet\Control\FileSystem\NtfsDisableLastAccessUpdate.

    • Использование mftzone значение

      Параметр значение приблизительно равен начальному размеру основной таблицы файлов (MFT) плюс зона основной таблицы файлов на новом томе и устанавливается на время подключения для каждой файловой системы. При использовании пространства тома NTFS корректирует пространство, зарезервированное для будущего роста основной таблицы файлов. Если зона основной таблицы файлов уже большая, то полный размер зоны основной таблицы файлов снова не резервируется. Поскольку зона основной таблицы файлов основана на непрерывном диапазоне в конце основной таблицы файлов, она уменьшается, так как пространство используется.

      Файловая система не переопределяет расположение зоны основной таблицы файлов, пока текущая зона основной таблицы файлов не будет полностью использована. В обычных системах этого не произойдет.


Fsutil: dirty

Создает запрос, чтобы проверить, задан ли «грязный» бит тома. Задает «грязный» бит тома. Когда «грязный» бит тома задан, команда autochk автоматически проверит том на наличие ошибок при следующей перезагрузке компьютера.

Синтаксис

fsutil dirty {query|set} путь

Параметры

query
Запрашивает «грязный» бит.
set
Задает «грязный» бит тома.
путь
Указывает букву диска (с последующим двоеточием), точку подключения или имя тома.

Примечания

  • Если «грязный» бит тома задан, это может означать, что файловая система находится в неустойчивом состоянии. «Грязный» бит может быть задан, потому что том находится в подключенном состоянии и в нем имеются незаконченные изменения, из-за того что компьютер был выключен до того, как сделанные изменения были переданы на диск, или из-за обнаруженных повреждений тома. Если «грязный» бит задается при перезагрузке компьютера, командой chkdsk будет проведена проверка целостности тома.

    При каждом запуске Windows XP ядро вызывает файл Autochk.exe для сканирования всех томов и проверки, заданы ли «грязные» биты томов. Если «грязный» бит задан, программа autochk немедленно запускает команду chkdsk /f для этого тома. Команда chkdsk /f проверяет целостность файловой системы и пытается устранить все возможные неисправности тома.

Примеры

Чтобы запросить «грязный» бит на диске C, введите:

fsutil dirty query C:

Пример выходных данных:

Том — C: изменен

или

Том — С: не изменен

Чтобы задать «грязный» бит на диске C, введите:

fsutil dirty set C:


Fsutil: file

Обычно используется специалистами по технической поддержке. Находит файл по идентификатору безопасности, запрашивает выделенные под файл области, задает короткое имя файла, допустимую длину данных файла, нулевые данные для файла, или создает новый файл.

Синтаксис

fsutil file [createnew] путь длина

fsutil file [findbysid] пользователь путь

fsutil file [queryallocranges] offset=смещение length=длина путь

fsutil file [setshortname] путь короткое_имя

fsutil file [setvaliddata] путь длина_данных

fsutil file [setzerodata] offset=смещение length=длина путь

Параметры

createnew
Создает файл с нулевым содержимым для указанных имени и размера.
путь
Указывает букву диска (с последующим двоеточием), точку подключения или имя тома.
длина
Указывает допустимую длину данных файла.
findbysid
Находит файлы указанного пользователя в томах NTFS. Пользователь определяется по идентификатору безопасности файла (SID).
Пользователь
Указывает имя учетной записи или имя, с которым пользователь входит в систему.
путь
Указывает букву диска (с последующим двоеточием), точку подключения или имя тома.
queryallocranges
Запрашивает выделенные для файла области в томе NTFS. Удобно использовать этот параметр для определения, имеет ли файл разреженные области.
offset=смещение
Указывает начало нулевого диапазона.
length=длина
Указывает длину области (в байтах).
путь
Указывает букву диска (с последующим двоеточием), точку подключения или имя тома.
setshortname
Задает короткое имя (формат имени файла 8. 3) для файла в томе NTFS.
путь
Указывает букву диска (с последующим двоеточием), точку подключения или имя тома.
короткое_имя
Указывает короткое имя файла.
setvaliddata
Задает допустимую длину данных для файла области в томе NTFS.
путь
Указывает букву диска (с последующим двоеточием), точку подключения или имя тома.
длина_данных
Указывает длину файла (в байтах).
setzerodata
Устанавливает нулевой диапазон (указанный параметрами смещение и длина), в котором файл будет обнулен. Если файл является разреженным, базовые кластеры не выделяются.
offset=смещение
Указывает смещение файла, начало нулевого диапазона.
length=длина
Указывает длину нулевого диапазона.
путь
Указывает букву диска (с последующим двоеточием), точку подключения или имя тома.

Примечания

  • Использование параметра setvaliddata

    В NTFS существует два основных понятия длины файла: знак конца файла (EOF) и допустимая длина данных (VDL). Знак EOF показывает действительную длину файла. Параметр VDL определяет длину допустимых данных на диске. Все попытки чтения между знаками VDL и EOF автоматически возвращают ноль, чтобы обеспечить требование повторного использования объекта C2.

    Параметр setvaliddata доступен только для администраторов, потому что его использование требует привилегию управления томами. Этот параметр требуется только для усовершенствованных мультимедиа и сценариев сетей SAN.

Примеры

Чтобы найти пользователя scottb на диске C по его идентификатору SID, введите:

fsutil file findbysid scottb C:\users

Чтобы запросить выделенные для файла области в томе NTFS, введите:

fsutil file queryallocranges offset=1024 length=64 C:\Temp\sample.txt

Чтобы задать короткое имя longfile.txt для файла longfilename.txt на диске C, введите:

fsutil file setshortname C:\longfilename.txt longfile.txt

Чтобы задать допустимую длину данных для файла области в томе NTFS, введите:

fsutil file setvaliddata C:\testfile.txt 4096

Чтобы задать нулевой диапазон для файла из тома NTFS, и обнулить этот диапазон введите:

fsutil file setzerodata offset=100 length=150 C:\Temp\sample.txt


Fsutil: fsinfo

Обычно используется специалистами по технической поддержке. Перечисляет все приводы, запрашивает тип приводов, сведения о томах, сведения NTFS о томах и статистику файловой системы.

Синтаксис

fsutil fsinfo [drives]

fsutil fsinfo [drivetype] путь

fsutil fsinfo [ntfsinfo] корневой_путь

fsutil fsinfo [statistics] путь_тома

fsutil fsinfo [volumeinfo] корневой_путь

Параметры

drives
Перечисляет все приводы на компьютере.
drivetype
Запрашивает привод или выводит его тип, например CD-ROM дисковод.
ntfsinfo
Перечисляет сведения NTFS для указанного тома: число секторов, общее число кластеров, свободные кластеры и начало и конец зоны основной таблицы файлов.
statistics
Перечисляет статистику файловой системы для конкретного тома: метаданные, файл журнала, события чтения и записи MFT.
volumeinfo
Перечисляет сведения для конкретного тома о файловой системе, поддержке учета регистра в именах файлов, именах файлов в формате Юникод и о дисковых квотах.
путь
Указывает букву диска (с последующим двоеточием), точку подключения или имя тома.
корневой_путь
Указывает букву диска (с последующим двоеточием) корневого диска.
путь_тома
Указывает букву диска (с последующим двоеточием), точку подключения или имя тома.

Примеры

Чтобы запросить тип диска для диска C, введите:

fsutil fsinfo drivetype C:

Возможные полученные ответы:

  • Неизвестный привод
  • Нет такой корневой папки
  • Съемный диск
  • Жесткий диск
  • Внешний или сетевой диск
  • Компакт-дисковод
  • Электронный диск

Чтобы запросить сведения о томе для тома E, введите:

fsinfo volumeinfo E:\

Пример выходных данных:

Имя тома :
Серийный номер тома : 0xd0b634d9
Максимальная длина компонентов : 255
Имя файловой системы : NTFS
Поддерживает учет регистра в именах файлов
Сохраняет имена файлов с учетом регистра
Поддерживает использование Юникода к именах файлов
Поддерживает обязательное использование списков доступа <ACL>
Поддерживает сжатие файлов
Поддерживает дисковые квоты
Поддерживает разреженные файлы
Поддерживает точки повторной обработки
Поддерживает идентификаторы объектов
Поддерживает шифрование на уровне файловой системы EFS
Поддерживает поименованные объекты

Чтобы запросить сведения NTFS о томе для привода F, введите:

fsutil fsinfo ntfsinfo F:\

Пример выходных данных:

NTFS Volume Serial Number : 0xe660d46a60d442cb
Number Sectors : 0x00000000010ea04f
Total Clusters : 0x000000000021d409
Free Clusters : 0x00000000000f222a
Total Reserved : 0x0000000000003550
Bytes Per Sector : 512
Bytes Per Cluster : 4096
Bytes Per FileRecord Segment : 1024
Clusters Per FileRecord Segment : 0
Mft Valid Data Length : 0x0000000003eab000
Mft Start Lcn : 0x0000000000000004
Mft2 Start Lcn : 0x000000000010ea04
Mft Zone Start : 0x0000000000003ea0
Mft Zone End : 0x0000000000004700

Чтобы запросить статистику файловой системы для привода E, введите:

fsinfo statistics E:

Пример выходных данных:

File System Type : NTFS
Version : 1
UserFileReads : 75021
UserFileReadBytes : 1305244512
UserDiskReads : 71213
UserFileWrites : 8037
UserFileWriteBytes : 207685440
UserDiskWrites : 5278
MetaDataReads : 14377
MetaDataReadBytes : 58888192
MetaDataDiskReads : 14773
MetaDataWrites : 18705
MetaDataWriteBytes : 138108928
MetaDataDiskWrites : 21464

MftReads : 9394
MftReadBytes : 38477824
MftWrites : 17061
MftWriteBytes : 115359744
Mft2Writes : 0
Mft2WriteBytes : 0
RootIndexReads : 0
RootIndexReadBytes : 0
RootIndexWrites : 0
RootIndexWriteBytes : 0
BitmapReads : 136
BitmapReadBytes : 557056
BitmapWrites : 1180
BitmapWriteBytes : 11161600
MftBitmapReads : 4
MftBitmapReadBytes : 16384
MftBitmapWrites : 118
MftBitmapWriteBytes : 491520
UserIndexReads : 2938
UserIndexReadBytes : 12034048
UserIndexWrites : 2738
UserIndexWriteBytes : 20615168
LogFileReads : 4
LogFileReadBytes : 16384
LogFileWrites : 8407
LogFileWriteBytes : 180936704


Fsutil: hardlink

Жесткая связь представляет запись каталога для файла. Каждый файл можно рассматривать как имеющий по крайней мере одну жесткую связь. В томах NTFS каждый файл может иметь несколько жестких связей, таким образом один файл может отображаться во многих папках (или даже в одной папке под разными именами). Поскольку ссылки на все связи находятся в одном файле, программы могут открывать любую из связей и изменять файл. Файл удаляется из файловой системы только после удаления всех связей. После создания жесткой связи, программы могут использовать ее как любое другое имя файла.

Синтаксис

fsutil hardlink create новое_имя_файла существующее_имя_файла

Параметры

create
Устанавливает жесткую связь NTFS между существующим и новым файлами. Жесткая связь NTFS сходна с жесткой связью POSIX.
новое_имя_файла
Указывает файл, к которому требуется создать жесткую связь.
существующее_имя_файла
Указывает файл, от которого требуется создать жесткую связь.


Fsutil: objectid

Обычно используется специалистами по технической поддержке. Управляет идентификаторами объектов (OID), которые являются внутренними объектами, используемыми службой клиента DLT и службой репликации файлов для отслеживания других объектов: файлов, папок и связей. Идентификаторы объектов невидимы для большинства программ, и их не следует изменять.

Внимание!

  • Не следует удалять, задавать или каким-то другим образом изменять идентификатор объекта. Удаление или задание идентификатора объекта может привести к потери данных (от одного файла до целых томов данных). Кроме того, это может вызвать неблагоприятное поведение службы клиента DLT и службы репликации файлов.

Синтаксис

fsutil objectid [create] путь

fsutil objectid [delete] путь

fsutil objectid [query] путь

fsutil objectid [set] ID_объекта ID_тома-источника ID_исходного_объекта ID_домена путь

Параметры

create
Создает идентификатор объекта, если у файла его еще нет, иначе работает так же, как параметр query.
delete
Удаляет идентификатор объекта.
query
Запрашивает идентификатор объекта.
set
Задает идентификатор объекта.
ID_объекта
16-разрядный шестнадцатеричный идентификатор файла, являющийся уникальным внутри тома. Используется службой клиента DLT и службой репликации файлов для идентификации файлов. Каждый файл имеет ID_объекта, а также ID_тома-источника, ID_исходного_объекта и ID_домена. При перемещении файла ID_объекта может измениться, а ID_тома-источника и ID_исходного_объекта остаются прежними, что позволяет системе Windows XP всегда найти файл, куда бы он ни был перемещен.
ID_тома-источника
16-разрядный шестнадцатеричный идентификатор, показывающий том, в котором был расположен файл, когда ему впервые был присвоен ID_объекта. Это значение используется службой клиента DLT.
ID_исходного_объекта
16-разрядный шестнадцатеричный идентификатор, показывающий исходный ID_объекта файла (ID_объекта может изменяться при перемещении файла). Это значение используется службой клиента DLT.
ID_домена
16-разрядный шестнадцатеричный идентификатор домена. Это значение не используется в текущий момент, поэтому должно везде быть равно нулю.
путь
Указывает букву диска (с последующим двоеточием), точку подключения или имя тома.

Примеры

Чтобы создать идентификатор объекта, введите:

  • fsutil objectid create C:\Temp\sample.txt

    Чтобы удалить идентификатор объекта, введите:

  • fsutil objectid delete C:\Temp\sample.txt

    Чтобы запросить идентификатор объекта, введите:

  • fsutil objectid get C:\Temp\sample.txt

    Чтобы задать идентификатор объекта, введите:

  • fsutil objectid set 40dff02fc9b4d4118f120090273fa9fc f86ad6865fe8d21183910008c709d19e 40dff02fc9b4d4118f120090273fa9fc 00000000000000000000000000000000 C:\Temp\sample.txt


Fsutil: quota

Управляет дисковыми квотами на томах NTFS, чтобы обеспечить более точный контроль за хранением файлов в сети.

Синтаксис

fsutil quota [disable] имя_тома

fsutil quota [enforce] имя_тома

fsutil quota [modify] имя_тома порог предел [имя_пользователя]

fsutil quota [query] имя_тома

fsutil quota [track] имя_тома

fsutil quota [violations]

Параметры

disable
Отключает отслеживание и задание квот на указанном томе.
enforce
Задает использование квот на указанном томе.
modify
Вносит изменения в существующую дисковую квоту или создает новую квоту.
query
Перечисляет все существующие дисковые квоты.
track
Отслеживает использование диска на указанном томе.
violations
Производит поиск в системе и в журналах приложений и выводит сообщение, что были выявлены нарушения квот или что пользователем достигнут порог или предел квоты.
имя_тома
Указывает букву для тома (с последующим двоеточием).
порог
Предельный размер, по достижении которого выдается предупреждение.
предел
Максимальный допустимый размер занятого места на диске.
имя_пользователя
Задает имя домена или пользователя.

Примечания

  • Дисковые квоты применяются к томам и позволяют задавать жесткие и нежесткие условия хранения данных для каждого пользователя.
  • Имеется возможность создавать сценарии, которые будут использовать команду fsutil quota для задания пределов квот при каждом добавлении нового пользователя или для автоматического отслеживания пределов квот, составления из них отчета и для автоматической отправки их по электронной почте администратору системы.


Fsutil: reparsepoint

Обычно используется специалистами по технической поддержке. Запрашивает или удаляет точки повторной обработки, являющиеся объектами файловой системы NTFS, которые имеют определяемый атрибут, содержащий контролируемые пользователем данные, и используются для расширения функциональности подсистемы ввода/вывода. Точки повторной обработки используют как точки соединения каталогов и точки подключения томов. Они также используются драйверами фильтров файловой системы, чтобы пометить определенные файлы как специфические для этого драйвера.

Синтаксис

fsutil reparsepoint [query] путь

fsutil reparsepoint [delete] путь

Параметры

query
Извлекает данные о точке повторной обработки, связанной с файлом или каталогом, определенным указанным дескриптором.
delete
Удаляет точку повторной обработки из файла или каталога, определенного указанным дескриптором, но не удаляет файл или каталог.

Внимание!

  • Команда fsutil reparsepoint delete удаляет только файл, но не удаляет связанные с ним точки повторной обработки. Это может вызвать сбои в процессах или в работе служб, которые попытаются открыть файл.
путь
Указывает букву диска (с последующим двоеточием), точку подключения или имя тома.

Примечания

  • На томе NTFS файл или каталог могут содержать точку повторной обработки, которая является выборкой определенных пользователем данных. Формат этих данных используется программой, в которой хранятся данные, и фильтром файловой системы, который устанавливается для интерпретации данных и обработки файла. Когда программа задает точку повторной обработки, в программе сохраняются эти данные, также тэг повторной обработки, единственным образом определяющий хранящиеся данные. Когда файловая система открывает файл с повторной точкой обработки, производится попытка найти фильтр файловой системы, связанный с форматом данных, определенным тэгом повторной обработки. Если такой фильтр найден, он производит обработку файла в соответствии с данными повторной обработки. Если фильтр не найден, попытка открыть файл будет неудачной.

    Например, точки повторной обработки используются для реализации связей NTFS и удаленного хранилища. Удаленное хранилище использует набор правил, определенных администратором, для перемещения редко используемых файлов в долговременное хранилище, например на магнитную ленту или компакт-диск. Точки повторной обработки также используются для хранения сведений о файле в файловой системе. Эти сведения хранятся в программной заглушке, содержащей точку повторной обработки, данные которой указывают на устройство, где требуемый файл находится в настоящее время. Фильтр файловой системы использует эти сведения для извлечения файла.

Примеры

Чтобы извлечь данные точки повторной обработки, связанные с C:\Server, введите:

fsutil reparsepoint query C:\Server

Чтобы удалить точку повторной обработки из указанного файла или каталога, используйте следующий формат.

fsutil reparsepoint delete C:\Server


Fsutil: sparse

Управляет разреженными файлами. Разреженным файлом называют файл, внутри которого имеется одна или несколько областей, незанятые данными. Программа будет рассматривать эти незанятые области как содержащие байты с нулевыми значениями, но не будет использовать пространство на диске для представления этих нулей. Другими словами, место выделяется для значимых (ненулевых) данных, тогда как место под незначимые данные (длинные строки, состоящие из нулей) не выделяется. При чтении разреженного файла выделенные данные возвращаются в том виде, в котором они сохранены, а невыделенные данные по умолчанию возвращаются в виде нулей, согласно требованиям спецификации безопасности C2. Поддержка разреженных файлов позволяет воспользоваться данными, записанными в любой части файла.

Синтаксис

fsutil sparse [queryflag] путь

fsutil sparse [queryrange] путь

fsutil sparse [setflag] путь

fsutil sparse [setrange] путь начальное_смещение длина

Параметры

queryflag
Запрашивает разреженные файлы.
queryrange
Сканирует файл в поисках областей, занятых значимыми (ненулевыми) данными
setflag
Отмечает указанный файл как разреженный.
setrange
Заполняет нулями указанную область внутри файла.
путь
Указывает букву диска (с последующим двоеточием), точку подключения или имя тома.
начальное_смещение
Указывает смещение (офсет), которое служит отличительным признаком разреженного файла.
длина
Задает границы (в байтах) области внутри файла, который будет отмечен как разреженный.

Примечания

  • В случае разреженного файла для записи длинных рядов нулей (незначимых данных) может не использоваться дисковое пространство. Достаточное место на диске для значимых данных будет выделено при записи разреженного файла.
  • Операционная система распознает только те заполненные нулями области, которые имеются в сжатых и разреженных файлах.
  • Если файл является сжатым или разреженным, файловая система NTFS может освободить дисковое пространство внутри файла. При этом необходимые диапазоны байтов заполняются нулями без увеличения размера файла.

Примеры

Чтобы отметить файл как разреженный, введите, например:

fsutil sparse setflag C:\Temp\sample.txt


Fsutil: usn

Обычно используется специалистами по технической поддержке. Управляет журналом изменения номеров последовательных обновлений (USN), в котором сохраняется архив всех изменений файлов в томе. При изменении, добавлении или удалении файлов, каталогов и прочих объектов NTFS в данный журнал вносятся соответствующие записи. Такие журналы создаются для каждого тома. Каждая запись содержит сведения о типе изменения и измененном объекте. Новые записи добавляются к концу существующего журнала.

Программы могут обращаться к журналу изменения номеров последовательных обновлений (USN), чтобы использовать данные о всех изменениях определенного набора файлов. Эффективность такого журнала значительно превышает эффективность таких методов, как проверка штампов времени или регистрация уведомлений об изменении файлов. Журнал изменения номеров последовательных обновлений (USN) используется такими службами, как Indexing Service, File Replication Service (FRS), Remote Installation Service (RIS) и Remote Storage.

Синтаксис

fsutil usn [createjournal] максимальный_размер дельта_выделения буква_тома

fsutil usn [deletejournal] флаги буква_тома

fsutil usn [enumdata] начальный_файл нижняя_граница верхняя_граница путь

fsutil usn [queryjournal] буква_тома

fsutil usn [readdata] путь

Параметры

createjournal
Создает журнал USN.
m=максимальный_размер
Задает максимальный размер журнала в байтах.
a=дельта_выделения
Задает размер выделения памяти (в байтах), которое удаляется из начала журнала и добавляется в его конец.
буква_тома
Указывает букву диска (с последующим двоеточием), точку подключения или имя тома.
deletejournal
Удаляет или отключает активный журнал USN.
флаги
/D: Отключает активный журнал USN с возвратом данных об управлении вводом-выводом в процессе отключения журнала.
/N: Отключает активный журнал USN с возвратом данных об управлении вводом-выводом после отключения журнала.
буква_тома
Указывает букву диска (с последующим двоеточием), точку подключения или имя тома.
enumdata
Перечисляет записи в заданном границами разделе журнала и выводит их список.
начальный_файл
Задает позицию, с которой будет начато перечисление файлов на томе.
нижняя_граница
Задает нижнюю границу диапазона значений USN, которая используется для фильтрации возвращаемых записей. Возвращаются лишь те записи, которые содержат значения дат изменений из диапазона, заданного значениями границ нижняя_граница и верхняя_граница. При этом данному диапазону принадлежат также значения, равные значениям границ.
верхняя_граница
Задает верхнюю границу диапазона значений USN, которая используется для фильтрации возвращаемых записей.
путь
Указывает букву диска (с последующим двоеточием), точку подключения или имя тома.
queryjournal
Запрашивает данные по текущему состоянию журнала тома, его емкости и занесенным в него записям.
буква_тома
Указывает букву диска (с последующим двоеточием), точку подключения или имя тома.
readdata
Считывает данные о USN, сохраняя их в виде файла.
путь
Указывает букву диска (с последующим двоеточием), точку подключения или имя тома.

Примечания

  • Использование параметра createjournal.

    Если журнал тома уже создан, применение параметра createjournal обновит такие его параметры, как максимальный_размер и дельта_выделения. Это дает возможность увеличить число обновляемых записей, которые поддерживает активный журнал, не отключая его. Указание нулевых значений параметров максимальный_размер и дельта_выделения приводит к выбору значения по умолчанию, зависящего от объма тома.

  • Использование параметра m=максимальный_размер

    Размер журнала USN может превышать указанное посредством данного параметра значение. Однако, при этом журнал усекается по достижении ближайшей контрольной точки NTFS, и его размер становится меньше этого значения. Файловая система NTFS проверяет журнал USN и начинает усекать его, когда размер журнала становится больше, чем сумма значений параметров максимальный_размер и дельта_выделения. Контрольные точки указывают на время занесения записей в файл журнала NTFS. В данной файловой системе они используются для определения методов устранения возможных неполадок.

  • Использование параметра a=дельта_выделения

    Перед проведением усечения размер журнала USN может превышать сумму значений параметров максимальный_размер и дельта_выделения.

  • Использование параметра deletejournal

    Удаление или отключение активного журнала может занять очень много времени, так как системе необходимо обработать все записи основной таблицы файлов (MFT) и установить значение последнего атрибута USN равным нулю. Этот процесс может занять несколько минут и, возможно, потребовать перезагрузки системы для продолжения данной процедуры. В ходе ее выполнения журнал USN не считается ни активным, ни отключенным. При выполнении отключения журнала, доступ к нему закрыт, а все попытки обращения к нему приводят к выводу сообщений об ошибках. Отключение активного журнала следует производить с крайней осторожностью, поскольку данная операция может неблагоприятно сказаться на использующих журнал программах.

Примеры

Чтобы создать журнал USN на диске С, введите:

fsutil usn createjournal m=1000 a=100 C:

Чтобы удалить активный журнал USN на диске С, введите:

fsutil usn deletejournal /D C:

Чтобы перечислить записи в заданном границами разделе журнала и ознакомиться с их списком, введите:

fsutil usn enumdata 1 0 1 C:

Чтобы запросить журнал о свободном месте на диске С, введите:

fsutil usn queryjournal C:

Чтобы сохранить данные USN в виде файла во временной папке на диске С, введите следующую команду:

fsutil usn readdata C:\Temp\sample.txt


Fsutil: volume

Управляет томом. Отсоединяет том или выдает запрос о свободном месте на диске.

Синтаксис

fsutil volume [diskfree] имя_диска

fsutil usn [queryjournal] буква_тома

Параметры

diskfree
Выдает запрос о свободном месте тома.
имя_диска
Указывает букву диска (с последующим двоеточием).
dismount
Отсоединяет том.
буква_тома
Указывает букву диска (с последующим двоеточием), точку подключения или имя тома.

Примеры

  • Чтобы отсоединитье том на диске С, введите:

    • fsutil volume dismount C:

  • Чтобы выполнить запрос о свободном месте на диске С, введите:

    • fsutil volume diskfree C:


Echo

Вывод на экран сообщения или задание режима вывода на экран сообщений команд. Вызванная без параметров команда echo выводит текущий режим.

Синтаксис

echo [{on|off}] [сообщение]

Параметры

{on|off}
Включение или отключения режима отображения на экране информации о работе команд.
сообщение
Задание текста для вывода на экран.
/?
Отображение справки в командной строке.

Примечания

  • Команда echo сообщение может оказаться полезной, если отключен режим отображения работы команд. Для вывода сообщений из нескольких строк без вывода дополнительных команд между ними следует использовать несколько последовательных команд echo сообщение после команды echo off в пакетной программе.
  • Если используется команда echo off, приглашение командной строки не отображается на экране. Чтобы отобразить приглашение, введите команду echo on.
  • Чтобы отключить вывод строк, введите символ «коммерческого эт» (@) перед командой в пакетном файле.
  • Чтобы вывести на экране пустую строку, введите следующую команду:

    echo.

  • Чтобы вывести символы канала (|) или перенаправления (< или >) при использовании команды echo, введите символ (^) непосредственно перед символом канала или перенаправления (например ^>, ^< или ^| ). Чтобы вывести символ (^), введите два этих символа подряд (^^).

Примеры

Следующий пример представляет собой пакетный файл, выводящий сообщение из трех строк на экран с пустыми строками до и после него:

echo off
echo.
echo Эта пакетная программа
echo форматирует и проверяет
echo новые диски
echo.

Если требуется отключить режим отображения команд и при этом не выводить на экран строку самой команды echo, введите символ @ перед командой:

@echo off

Оператор if и команду echo можно использовать в одной командной строке: Например:

if exist *.rpt echo Отчет получен.


Echoconfig

Вывод сообщений в процессе обработки файлов сведений о программах Config.nt и Autoexec.nt подсистемы MS-DOS. Если данная команда отсутствует, сообщения не выводятся.

Параметры

отсутствуют

Примечания

  • Данную команду нужно указать в файле Config.nt подсистемы MS-DOS. Следующий пример иллюстрирует содержимое файла Config.nt.

    dos=high,umb
    device=%systemroot%\system32\himem.sys
    files=40
    echoconfig


Edit

Запуск редактора MS-DOS, который позволяет создавать и редактировать текстовые файлы в формате ASCII. Использование данной команды без параметров приводит к запуску редактора MS-DOS.

Синтаксис

edit [[диск:][путь] имя_файла] [/b] [/g] [/h] [/nohi]

Параметры

[диск:][путь] имя_файла
Задает местонахождение и имя текстового файла. Если файл не существует, редактор MS-DOS создаст его. Если файл существует, редактор MS-DOS откроет его и выведет содержимое на экран.
/b
Устанавливает черно-белый режим работы редактора MS-DOS. Этот параметр следует выбирать в случае, когда редактор MS-DOS неправильно отображается на черно-белом мониторе.
/g
Задает режим наиболее быстрого обновления экрана при работе с монитором CGA.
/h
Задает режим вывода максимального количества строк для используемого монитора.
/nohi
Разрешает работу редактора MS-DOS в восьмицветном режиме. Как правило, Windows XP использует шестнадцатицветный режим.
/?
Отображает справку в командной строке.

Примечания

  • Некоторые мониторы по умолчанию не поддерживают отображение клавиш быстрого вызова. В этом случае нужно использовать ключ /b (для мониторов CGA) и ключ /nohi (для систем, не поддерживающих выделение символов на экране полужирным шрифтом).


Endlocal

Окончание использования локального окружения в пакетной программе, восстановление значений переменных среды, имевшихся до выполнения соответствующей команды setlocal.

Синтаксис

endlocal

Параметры

/?
Отображение справки в командной строке.

Примечания

  • Команду endlocal необходимо указать в сценарии и пакетном файле. Команда endlocal не выполняется при использовании вне сценария или пакетного файла.
  • В конце пакетного файла присутствует неявная команда endlocal.
  • Если расширения командного процессора разрешены (установлено по умолчанию), команда endlocal восстанавливает состояния (т. е. разрешение или запрещение) расширений команд, существовавшие до выполнения соответствующей команды setlocal.

Примеры

В пакетном файле можно локально изменить переменные среды. Например:

@echo off

rem Эта программа запускает приложение superapp в сети,

rem записывает вывод в файл и загружает этот файл в программу

rem Блокнот.

setlocal

path=g:\programs\superapp;%path%

call superapp>c:\superapp.out

endlocal

start notepad c:\superapp.out


Eventcreate

Позволяет администратору создать особое событие в указанном журнале событий.

Синтаксис

eventcreate [/s компьютер [/u домен\пользователь [/p пароль]] {[/l {APPLICATION|SYSTEM}]|[/so имя_источника]} /t {ERROR|WARNING|INFORMATION|SUCCESSAUDIT|FAILUREAUDIT} /id код_события /d описание

Параметры

/s компьютер
Задание имени или IP-адреса удаленного компьютера (не используйте обратную косую черту). По умолчанию используется локальный компьютер.
/u домен\пользователь
Выполнение команды с разрешениями учетной записи пользователя, заданного в параметре пользователь или домен\пользователь. По умолчанию используются разрешения текущего вошедшего пользователя компьютера, с которого поступила эта команда.
/p пароль
Указание пароля учетной записи пользователя, заданной параметром /u.
/l {APPLICATION|SYSTEM}
Задание имени журнала событий, в котором будет создано данное событие. Для журнала событий допустимыми являются имена APPLICATION и SYSTEM.
/so имя_источника
Задание источника, используемого для данного события. Допустимый источник может быть представлен любой строкой и должен указывать на приложение или компонент, в котором произошло событие.
/t {ERROR|WARNING|INFORMATION|SUCCESSAUDIT|FAILUREAUDIT}
Задание типа создаваемого события. Допустимыми являются следующие типы: ERROR, WARNING, INFORMATION, SUCCESSAUDIT и FAILUREAUDIT.
/id код_события
Задание кода события. Допустимым кодом может быть любое число от 1 до 65535.
/d описание
Задание описания для вновь создаваемого события.
/?
Отображение справки в командной строке.

Примечания

  • Особые события не заносятся в журнал безопасности.

Примеры

Далее приведены примеры использования команды eventcreate:

eventcreate /t error /id 100 /l application /d

"Создание события в журнале приложения"
eventcreate /t information /id 1000 /so winmgmt /d

"Создание события в источнике WinMgmt"
eventcreate /t error /id 2001 /so winword /l application /d

"новый источник Winword в журнале приложений"
eventcreate /s server /t error /id 100 /l application /d

"Удаленный компьютер без учетных данных пользователя"
eventcreate /s server /u user /p password /id 100 /t error /l application /d

"Удаленный компьютер с учетными данными пользователя"
eventcreate /s server1 /s server2 /u user /p password /id 100 /t error /so winmgmt /d

"Создание событий на нескольких удаленных компьютерах"
eventcreate /s server /u user /id 100 /t warning /so winmgmt /d

"Удаленный компьютер с частью учетных данных пользователя"


Eventquery.vbs

Вывод списка событий и их свойств из одного или нескольких журналов событий.

Синтаксис

  • eventquery[.vbs] [/s компьютер [/u домен\пользователь [/p пароль]]] [/fi имя_фильтра] [/fo {TABLE|LIST|CSV}] [/r диапазон_событий [/nh] [/v] [/l [APPLICATION] [SYSTEM] [SECURITY] [DNS server ] [заданный_пользователем_журнал] [имя_журнала_каталога] [*] ]

    Параметры

    /s компьютер
    Задание имени или IP-адреса удаленного компьютера (не используйте обратную косую черту). По умолчанию используется локальный компьютер.
    /u домен\пользователь
    Выполнение сценария с разрешениями учетной записи пользователя, заданного в параметре пользователь или домен\пользователь. По умолчанию используются разрешения текущего вошедшего пользователя компьютера, с которого поступила эта команда.
    /p пароль
    Указание пароля учетной записи пользователя, заданной параметром /u.
    /fi имя_фильтра
    Задание типов событий, которые следует включить в запрос или исключить из него. Чтобы найти события с каким-то значением, фильтры Type и ID можно использовать совместно в одной инструкции с помощью оператора or. Допустимыми именами фильтров, операторами и значениями являются следующие.
    Имя | Оператор | Значение
    Datetime | eq, ne, ge, le, gt, lt | мм/дд/гг(гггг), чч:мм:ссAM(/PM)
    Type | eq, ne, or | {ERROR|INFORMATION|WARNING|SUCCESSAUDIT|FAILUREAUDIT}
    ID | eq, ne, or, ge, le, gt, lt | Любое допустимое положительное число
    User | eq, ne | Любая допустимая строка
    Computer | eq, ne | Любая допустимая строка
    Source | eq, ne | Любая допустимая строка
    Category | eq, ne | Любая допустимая строка
    /fo {TABLE|LIST|CSV}
    Задание формата выходных данных. Допустимые значения: table, list и csv.
    /r диапазон_событий
    Задание диапазона событий, включаемых в список.
    Значение | Описание
    N | Включение в список последних событий, количество которых задается параметром N.
    -N | Включение в список самых старых событий, количество которых задается параметром N.
    N1-N2 | Включение в список событий с N1 по N2.
    /nh
    Запрещение вывода заголовков столбцов. Этот параметр является допустимым при задании форматов table и csv.
    /v
    Задание отображения подробных сведений о событиях в выходных данных.
    /l [APPLICATION] [SYSTEM] [SECURITY] ["DNS server"] [заданный_пользователем_журнал] [имя_журнала_каталога] [*] ]
    Задание журналов для просмотра. Допустимые значения: Application, System, Security, "DNS server", заданный пользователем журнал и журнал каталога. Значение "DNS server" является допустимым только в том случае, если на компьютере, заданном параметром /s, запущена служба DNS. Чтобы задать несколько журналов для просмотра, повторно воспользуйтесь параметром /l. Допускается использование подстановочного знака (*), который указывается по умолчанию.
    /?
    Отображение справки в командной строке.

    Примечания

    • Чтобы выполнить данный сценарий, необходимо запустить CScript. Если программа CScript не является используемым по умолчанию сервером сценариев Windows, введите следующую команду:

      cscript //h:cscript //s //nologo

    Примеры

    Далее приведены примеры использования команды eventquery:

    eventquery /l system
    eventquery /l mylog
    eventquery /l application /l system
    eventquery /s srvmain /u maindom\hiropln /p p@ssW23 /v /l *
    eventquery /r 10 /l application /nh
    eventquery /r -10 /fo LIST /l security
    eventquery /r 5-10 /l "DNS server"
    eventquery /fi "Type eq Error" /l application
    eventquery /fi "Datetime eq 06/25/00,03:15:00AM/06/25/00,03:15:00PM" /l application
    eventquery /fi "Datetime gt 08/03/00,06:20:00PM" /fi "id gt 700" /fi "Type eq warning" /l system eventquery /fi "ID eq 1000 OR ID ge 4500" eventquery /fi "Type eq error OR Type eq INFORMATION" eventquery /fi "ID eq 250 OR Type eq ERROR"


Eventtriggers

Вывод и настройка триггеров событий на локальном или удаленном компьютере.

Создание нового триггера событий, который отслеживает выполнение определенных условий в журнале событий и действует в соответствии с ними.

Синтаксис

eventtriggers[.exe] /create [/s компьютер [/u домен\пользователь [/p пароль]]] /tr имя_триггера [/l [APPLICATION] [SYSTEM] [SECURITY] ["DNS Server"] [LOG] [имя_журнала_каталога] [*] ] {[/eid код]|[/t {ERROR|INFORMATION|WARNING|SUCCESSAUDIT|FAILUREAUDIT}]|[/so источник]} [/d описание] /tk имя_задания [/ru {[домен\]пользователь | "System"} [/rp пароль]]

Параметры

/s компьютер
Задание имени или IP-адреса удаленного компьютера (не используйте обратную косую черту). По умолчанию используется локальный компьютер.
/u домен\пользователь
Выполнение команды с разрешениями учетной записи пользователя, заданного в параметре пользователь или домен\пользователь. По умолчанию используются разрешения текущего вошедшего пользователя компьютера, с которого поступила эта команда.
/p пароль
Указание пароля учетной записи пользователя, заданной параметром /u.
/tr имя_триггера
Задание понятного имени для триггера событий.
/l [APPLICATION] [SYSTEM] [SECURITY] ["DNS Server"] [LOG] [имя_журнала_каталога] [*] ]
Задание журналов для просмотра. Допустимые типы: Application, System, Security, DNS server, Log и журнал каталога. Допускается использование подстановочного знака (*), который указывается в качестве значения по умолчанию.
/eid код
Задание кода определенного события, которое требуется отслеживать с помощью триггера событий. Допустимым значением является любое целое число. Этот параметр нельзя использовать вместе с параметрами /type или /so.
/t {ERROR|INFORMATION|WARNING|SUCCESSAUDIT|FAILUREAUDIT}
Задание типа события, которое требуется отслеживать с помощью триггера событий. Допускаются следующие значения: ERROR, INFORMATION, WARNING, SUCCESSAUDIT и FAILUREAUDIT. Этот параметр нельзя использовать вместе с параметрами /id или /so.
/so источник
Задание источника события, которое требуется отслеживать с помощью триггера событий. Допустимым значением является любая строка. Этот параметр нельзя использовать вместе с параметрами /id или /type.
/d описание
Задание вывода подробного описания триггера событий. Допустимым значением является любая строка.
/tk имя_задания
Указание задания, команды или строки, выполняемых при соблюдении условий триггера событий.
/ru {[домен\]пользователь | "System"}
Выполнение заданий с разрешениями указанной учетной записи пользователя. По умолчанию задание выполняется с разрешениями пользователя, вошедшего в компьютер, на котором запущена программа SchTasks.
Значение | Описание
[домен\]пользователь | Задание учетной записи пользователя.
"System" или "" | Задание учетной записи NT Authority\System, используемой в операционной системе.
/rp пароль
Указание пароля учетной записи пользователя, заданной параметром /ru. Если при указании учетной записи пропущен пароль, программа SchTasks.exe запросит пароль и скроет вводимый текст. Для заданий, выполняемых с разрешениями учетной записи NT Authority\System, не требуется пароль и программа SchTasks.exe его не запрашивает.
/?
Отображение справки в командной строке.

Примеры

Далее приведены примеры использования команды eventtriggers /create:

  • eventtriggers /create /tr Очистка диска /l system /t error /tk c:\windows\system32\cleanmgr.exe
  • eventtriggers /create /s srvmain /u maindom\hiropln /p p@ssW23 /tr Отсутствие места на диске /eid 4133 /t warning /tk \\server\share\diskcleanup.cmd
  • eventtriggers /create /s srvmain /user maindom\hiropln /p p@ssW23 /tr Создание резервной копии диска /eid 4133 /l system /t error /tk \\server\share\ntbackup.exe

    Удаление триггера событий из системы с помощью его кода.

    Синтаксис

    eventtriggers[.exe] /delete [/s компьютер [/u домен\пользователь [/p пароль]]] /tid {код|*}

    Параметры

    /s компьютер
    Задание имени или IP-адреса удаленного компьютера (не используйте обратную косую черту). По умолчанию используется локальный компьютер.
    /u домен\пользователь
    Выполнение команды с разрешениями учетной записи пользователя, заданного в параметре пользователь или домен\пользователь. По умолчанию используются разрешения текущего вошедшего пользователя компьютера, с которого поступила эта команда.
    /p пароль
    Указание пароля учетной записи пользователя, заданной параметром /u.
    /tid {код|*}
    Задание кодов удаляемых триггеров событий. Допускается использование подстановочного знака (*).
    /?
    Отображение справки в командной строке.

    Примеры

    Далее приведены примеры использования команды eventtriggers /delete:

    eventtriggers /delete /tid 1 /tid 2 /tid 4 /tid 6
    eventtriggers /delete /s srvmain /u maindom\hiropln /p p@ssW23 /tid *
    eventtriggers /delete /s srvmain /u maindom\hiropln /p p@ssW23 /tid 1

    Запрос и отображение свойств и параметров триггера событий системы.

    Синтаксис

    eventtriggers[.exe] /query [/s компьютер [/u домен\пользователь [/p пароль]]] [/fo {TABLE|LIST|CSV}] [/nh] [/v]

    Параметры

    /s компьютер
    Задание имени или IP-адреса удаленного компьютера (не используйте обратную косую черту). По умолчанию используется локальный компьютер.
    /u домен\пользователь
    Выполнение команды с разрешениями учетной записи пользователя, заданного в параметре пользователь или домен\пользователь. По умолчанию используются разрешения текущего вошедшего пользователя компьютера, с которого поступила эта команда.
    /p пароль
    Указание пароля учетной записи пользователя, заданной параметром /u.
    /fo {TABLE|LIST|CSV}
    Задание формата выходных данных запроса. Допустимые значения: TABLE, LIST и CSV. По умолчанию для выходных данных используется формат TABLE.
    /nh
    Запрещение вывода заголовка столбца. Данный параметр является допустимым, если параметр /fo имеет значение TABLE или CSV.
    /v
    Задание вывода подробных сведений в выходных данных.
    /?
    Отображение справки в командной строке.

    Примеры

    Далее приведены примеры использования команды eventtriggers /query:

    eventtriggers /query
    eventtriggers /query /s srvmain
    eventtriggers /query /s srvmain /u maindom\hiropln /p p@ssW23 /fo list

    Примечания

    • Выполненная без операторов команда eventtriggers возвращается список триггеров событий. Чтобы вывести список триггеров событий, введите следующую команду:

      eventtriggers

      Вывод будет иметь следующий вид:

ID триггера Имя триггера событий         Задание
========== ========================== ================================
         1 Очистка диска               c:\windows\system32\cleanmgr.exe
    • Если событие не удается выполнить, команда eventtriggers создает файл журнала TriggerConsumer.log, содержащий сообщение об ошибке триггера, в каталоге \windows\system32\wbem\logs.


Evntcmd

Настройка преобразования событий в ловушки и/или в адреса назначения ловушки в файле конфигурации.

Синтаксис

evntcmd [/s ИмяКомпьютера] [/v УровеньОбъемаСведений] [/n] ИмяФайла

Параметры

/s ИмяКомпьютера
Имя компьютера, на котором требуется настроить преобразование событий в ловушки и/или адреса назначения ловушки. Если компьютер не указан, настройка производится на локальном компьютере.
/v УровеньОбъемаСведений
Типы сообщений состояния, отображающиеся в качестве настроенных ловушек и адресов назначения ловушек. Данный параметр должен быть целым числом от 0 до 10. Если указано число 10, то отображаются все типы сообщений, включая сообщения отслеживания и предупреждения о настройке ловушки. Если указано число 0, сообщения не отображаются.
/n
Служба SNMP не должна перезапускаться, если на данный компьютер получены изменения настройки ловушки.
ИмяФайла
Имя файла, который содержит сведения о преобразовании событий в настраиваемые ловушки и адреса назначения ловушки.
/?
Отображает справку в командной строке.

Заметки

  • Если требуется настроить ловушки, но не адреса назначения ловушки, можно создать допустимый файл конфигурации с помощью трансляции событий в ловушки, которая является графической утилитой. Если установлена служба SNMP, трансляцию событий в ловушки можно запустить, набрав в командной строке evntwin. После определения необходимых ловушек нажмите кнопку Экспорт, чтобы создать файл, который можно использовать с evntcmd. Трансляцию событий в ловушки можно использовать для легкого создания файла конфигурации и последующего использования файла конфигурации с evntcmd в командной строке для быстрой настройки ловушек на нескольких компьютерах.
  • Для настройки ловушки используется следующий синтаксис:

    #pragma ADD ФайлЖурналаСобытий ИсточникСобытия КодСобытия [Счетчик [Период]]

    • текст #pragma должен отображаться в начале каждой записи в файле;
    • параметр ADD указывает, что требуется добавить событие в настройку ловушки;
    • параметры ФайлЖурналаСобытий, ИсточникСобытия и КодСобытия являются обязательными. Параметр ФайлЖурналаСобытий указывает файл, в который записывается событие. Параметр ИсточникСобытия указывает приложение, которое создает событие. Параметр КодСобытия указывает уникальный номер, определяющий каждое событие. Чтобы определить, какие значения соответствуют конкретному событию запустите трансляцию событий в ловушки, набрав в командной строке evntwin. Нажмите кнопку Настройка, а затем кнопку Изменить. В области Источники событий просмотрите папки, пока не найдете событие, которое требуется настроить, щелкните событие, а затем нажмите кнопку Добавить. Сведения об источнике события, файл журнала события и код события соответственно отображаются в областях Источник, Журнал и Код ловушки;
    • параметр Счетчик является необязательным; он указывает количество событий перед отправкой сообщения ловушки. Если параметр Счетчик не используется, сообщения ловушки отправляется после первого событие;
    • параметр Период является необязательным, но он требует использования параметра Счетчик. Параметр Период указывает продолжительность времени (в секундах), в течение которого событие должно произойти число раз, указанное в параметре Счетчик, перед отправкой сообщения ловушки. Если параметр Период не используется, сообщение ловушки отправляется после того, как событие произойдет число раз, указанное в параметре Счетчик, не зависимо от того, сколько времени прошло между событиями.
  • Для удаления ловушки используется следующий синтаксис:

    #pragma DELETE ФайлЖурналаСобытий ИсточникСобытия КодСобытия

    • текст #pragma должен отображаться в начале каждой записи в файле;
    • параметр DELETE указывает, что требуется удалить событие из настройки ловушки;
    • параметры ФайлЖурналаСобытий, ИсточникСобытия и КодСобытия являются обязательными. Параметр ФайлЖурналаСобытий указывает журнал, в который записывается событие. Параметр ИсточникСобытия указывает приложение, которое создает событие. Параметр КодСобытия указывает уникальный номер, определяющий каждое событие.
  • Для настройки адреса назначения ловушки используется следующий синтаксис:

    #pragma ADD_TRAP_DEST ИмяСообщества НомерУзла

    • текст #pragma должен отображаться в начале каждой записи в файле;
    • параметр ADD_TRAP_DEST указывает, что требуется отправить сообщения ловушки на конкретный узел внутри сообщества;
    • параметр ИмяСообщества указывает по имени сообщество, в которое отправляется сообщение ловушки;
    • параметр НомерУзла указывает по имени или IP-адресу узел, на который требуется отправить сообщения ловушки.
  • Для удаления адреса назначения ловушки используется следующий синтаксис:

    #pragma DELETE_TRAP_DEST ИмяСообщества НомерУзла

    • текст #pragma должен отображаться в начале каждой записи в файле;
    • параметр DELETE_TRAP_DEST указывает, что не требуется отправлять сообщения ловушки на конкретный узел внутри сообщества;
    • параметр ИмяСообщества указывает по имени сообщество, в которое отправляются сообщения ловушки;
    • параметр НомерУзла указывает по имени или IP-адресу узел, на который не требуется отправлять сообщения ловушки.

Примеры

Следующие примеры показывают записи в файле конфигурации для команды evntcmd. Они не могут быть введены в командной строке.

Чтобы отправить сообщение ловушки, если служба журнала событий перезапускается, введите:

#pragma ADD System "Eventlog" 2147489653

Чтобы отправить сообщение ловушки, если служба журнала событий перезапускается дважды за три минуты, введите:

#pragma ADD System "Eventlog" 2147489653 2 180

Чтобы остановить отправку сообщения ловушки, когда бы ни перезапускалась служба журнала событий, введите:

#pragma DELETE System "Eventlog" 2147489653

Чтобы отправить сообщения ловушки в сообщество с названием «Public» на узел с IP-адресом 192.168.100.100, введите:

#pragma ADD_TRAP_DEST public 192.168.100.100

Чтобы отправить сообщения ловушки в сообщество с названием «Private» на узел с названием «Host1», введите:

#pragma ADD_TRAP_DEST private Host1

Чтобы остановить отправку сообщений ловушки в сообщество с названием «Private» на тот же компьютер, на котором настраиваются адреса назначений ловушки, введите:

#pragma DELETE_TRAP_DEST private localhost


Exe2bin

Преобразование исполняемых файлов (.exe) в двоичный формат.

Синтаксис

exe2bin [диск1:][путь1]ФайлВвода [[диск2:][путь2]ВыходнойФайл]

Параметры

[диск1:][путь1]ФайлВвода
Местонахождение и имя файла ввода, который требуется преобразовать. Параметр ФайлВвода является обязательным.
[диск2:][путь2]ВыходнойФайл
Местонахождение и имя выходного файла, который требуется создать.
/?
Отображение справки в командной строке.

Заметки

  • Программа Exe2bin включена для помощи разработчикам программ. Она не предназначена для обычных пользователей.
  • При использовании команды exe2bin имеют место следующие ограничения:
    • входной файл должен быть в корректном .exe формате, полученном после компоновки и не должен быть упакованным;
    • резидентная или действующая (код и данные) часть файла не должны превышать объема в 64Кб;
    • в файле не должно быть сегмента stack.
  • Программа Exe2bin выполняет конкретные действия, в зависимости от значений параметров ФайлВвода и ВыходнойФайл:
    • по умолчанию для параметра ФайлВвода используется расширение .exe. Программа Exe2bin преобразует ФайлВвода .exe в файл с двоичным форматом .bin (образ программы в памяти) и использует местоположение и имя, заданные параметрами [диск2:][путь2]ВыходнойФайл для хранения выходного файла;
    • если не заданы диск2 или путь2, программа exe2bin записывает выходной файл на текущий диск и в текущий каталог;
    • если имя файла для параметра ВыходнойФайл не указано, программа exe2bin использует имя файла параметра ФайлВвода;
    • по умолчанию для имени файла, указанного для параметра ВыходнойФайл, используется расширение .bin.
  • Поддерживаются следующие типы преобразования:
    • если значения CS:IP не заданы в .exe файле, exe2bin выполняет чисто двоичное преобразование. Если программа содержит инструкции, требующие отзыва сегмента, exe2bin запрашивает значение исправления. Это значение исправления является абсолютным адресом сегмента, в который должна быть загружена программа. Итоговая программа может быть использована, только будучи загруженной по этому адресу, задаваемому вызывающей программой. Командный интерпретатор не сможет загрузить такую программу;
    • если значения сегментов CS:IP установлены в 0000:100H, итоговый двоичный файл будет вызываться как .com файл с указателем инструкций, установленным в 100H ассемблерной командой ORG. Включите расширение .com в параметр ВыходнойФайл. Исправления сегментов не разрешены, поскольку файлы с расширением .com должны иметь возможность перемещения сегментов. Файлы с расширением .com должны принимать условия ввода, изложенные в документации Microsoft Macro Assembler. Командный интерпретатор будет загружать и запускать программу так же, как и обычные .com программы, поставляемые на диске Windows XP.


Exit

Выход из текущего пакетного сценария или из программы Cmd.exe (командный интерпретатор) и возвращение в программу, запустившую Cmd.exe или в диспетчер программ.

Синтаксис

exit [/b] [КодВыхода]

Параметры

/b
Выход из текущего пакетного сценария.
КодВыхода
Число.
/?
Отображение справки в командной строке.

Заметки

  • Если /b используется вне пакетного сценария, то выход осуществляется из Cmd.exe.
  • Если используется /b, то Cmd.exe устанавливает ERRORLEVEL в указанный КодВыхода. При выходе из Cmd.exe, Cmd.exe устанавливает код процесса выхода вместе с параметром КодВыхода.


Expand

Восстановление одного или нескольких сжатых файлов. Эта команда используется для развертывания уплотненных файлов с дистрибутивных дисков.

Синтаксис

expand [-r] Источник [Результат]

expand -d источник.cab [-f:файлы]

expand источник.cab -f:файлы Результат

Параметры

-r
Переименовывает развернутые файлы.
-d
Выводит список файлов в местоположении источника. Не производит распаковки или выделения файлов.
-f:файлы
Указывает файлы в cab-файле, которые необходимо распаковать. Можно использовать подстановочные символы (* and ?).
Источник
Задает файл, который должен быть развернут. Параметр источник может состоять из имени диска с двоеточием, имени папки, имени файла или их комбинации. Можно использовать подстановочные символы (* and ?).
Назначение
Задает, куда помещать развернутые файлы. Если параметр Источник задает несколько файлов и ключ -r не задан, Результат должен быть каталогом. Параметр результат может состоять из имени диска с двоеточием, имени каталога, имени файла или их комбинации.
/?
Отображение справки в командной строке.

Заметки

  • Использование команды expand в консоли восстановления

    Команда expand с другими параметрами доступна в консоли восстановления.


Cacls

Просмотр или изменение файлов избирательных таблиц управления доступом (DACL).

Синтаксис

cacls имя_файла [/t] [/e] [/c] [/g пользователь:разрешение] [/r пользователь [...]] [/p пользователь:разрешение [...]] [/d пользователь [...]]

Параметры

имя_файла
Обязательный параметр. Вывод избирательных таблиц управления доступом (DACL) указанных файлов.
/t
Изменение избирательных таблиц контроля доступа (DACL) указанных файлов в текущем каталоге и всех подкаталогах.
/e
Редактирование избирательной таблицы управления доступом (DACL) вместо ее замены.
/c
Продолжение внесения изменений в избирательные таблицы управления доступом (DACL) с игнорированием ошибок.
/g пользователь:разрешение
Предоставление прав доступа указанному пользователю. В следующей таблице перечислены допустимые значения параметра разрешение.
Значение | Описание
n | Нет
r | Чтение
w | Запись
c | Изменение (запись)
f | Полный доступ
/r пользователь
Отмена прав доступа для указанного пользователя.
/p пользователь: разрешение
Смена прав доступа для указанного пользователя. В следующей таблице перечислены допустимые значения параметра разрешение.
Значение | Описание
n | Нет
r | Чтение
w | Запись
c | Изменение (запись)
f | Полный доступ
/d пользователь
Запрещение доступа для указанного пользователя.
/?
Отображение справки в командной строке.

Заметки

  • Для расшифровки полученных результатов воспользуйтесь следующей таблицей.
    Вывод | Применение таблицы управления доступом (ACE)
    OI | Для этой папки и ее файлов
    CI | Для этой папки и ее подпапок
    IO | Таблица управления доступом (ACE) не применяется к текущему файлу/каталогу
    Выходное сообщение отсутствует | Только для этой папки
    (IO)(CI) | Для этой папки, ее подпапок и файлов
    (OI)(CI)(IO) | Только для подпапок и файлов
    (CI)(IO) | Только для подпапок
    (OI)(IO) | Только для файлов
  • Для задания нескольких файлов можно использовать подстановочные знаки (* и ?).
  • Имеется возможность указать несколько пользователей.


Call

Вызов одного пакетного файла из другого без завершения выполнения первого файла. Команда call принимает метки в качестве объекта вызова. Используемая в командной строке, а не в сценарии или пакетном файле, команда Call игнорируется.

Синтаксис

call [[диск:][путь] имя_файла [пакетные_параметры]] [:метка [аргументы]]

Параметры

[диск:][путь] имя_файла
Задает имя и местоположение пакетного файла для запуска. Параметр имя_файла должен иметь расширение .bat или .cmd.
пакетные_параметры
Задает данные командной строки, используемые программой пакетной обработки, включая параметры командной строки, имена файлов, пакетные параметры (в диапазоне от %0 до %9) или переменные (например %baud%).
:метка
Указывает метку, на которую должно быть передано управление программы пакетной обработки. При использовании команды call с этим параметром создается новый контекст пакетного файла, а управление передается инструкции, следующей за указанной меткой. Когда первый раз встречается конец пакетного файла (после перехода на метку), управление возвращается на инструкцию, следующую за инструкцией call. При втором достижении конца файла выполнение пакетной программы прекращается.
аргументы
Задает данные командной строки, которые передаются в новый экземпляр программы пакетной обработки, начинающейся с :метки, включая параметры командной строки, имена файлов, пакетные параметры (в диапазоне от %1 до %9) или переменные (например %baud%).
/?
Отображение справки в командной строке.

Заметки

  • Использование пакетных параметров

    Пакетные параметры могут содержать любые сведения, которые допускается передавать в программы пакетной обработки, включая параметры командной строки, имена файлов, пакетные параметры (в диапазоне от %0 до %9) или переменные (например %baud%).

  • Использование каналов и символов перенаправления

    Каналы и символы перенаправления не допускается использовать с командой call.

  • Рекурсивный вызов пакетных файлов

    Создание пакетных файлов, которые вызывают сами себя, допускается, однако в этом случае необходимо задать условия выхода. В противном случае родительская и дочерняя программы будут вызывать друг друга в бесконечном цикле.

  • Работа с расширениями командного процессора

    Если расширения командного процессора разрешены (задано по умолчанию), команда call принимает метки в качестве объекта вызова. Правильный синтаксис:

    call :аргументы метки

    Для получения дополнительных сведений о разрешении и запрещении расширений командного процессора щелкните ссылку cmd.

Примеры

Для вызова программы Checknew.bat из другого пакетного файла в тексте родительского пакетного файла введите следующую строку:

call checknew

Если родительская пакетная программа принимает два пакетных параметра и требуется передать их в файл Checknew.bat, включите следующую команду в родительскую пакетную программу:

call checknew %1 %2


Chcp

Просмотр номера текущей кодовой страницы или изменение текущей кодовой страницы консоли. Выполненная без параметров команда chcp выводит номер текущей кодовой страницы для окна командной строки.

Синтаксис

chcp [код]

Параметры

код
Задает номер кодовой страницы. Поддерживаемые кодовые таблицы с соответствующими странами/регионами или языками приведены в следующей таблице.
Кодовая страница | Страна/регион или язык
437 | США
850 | Многоязыковый (латиница I)
852 | Восточная и центральная Европа (латиница II)
855 | Кириллица (русский)
857 | Турецкий
860 | Португальский
861 | Исландский
863 | Французский (Канада)
865 | Скандинавский
866 | Русский
869 | Современный греческий
/?
Отображение справки в командной строке.

Заметки

  • Только кодовая страница изготовителя вычислительной техники (ИВТ), установленная в системе Windows XP, отображается правильно в окне командной строки при использовании растрового шрифта. Прочие кодовые страницы будут правильно отображаться только в полноэкранном режиме или в окне командной строки, использующем шрифты TrueType.
  • Подготовка кодовых страниц, в отличие от MS-DOS, не требуется.
  • В программах, запущенных после назначения новой кодовой страницы, используется эта кодовая страница, а в программах, запущенных до назначения новой кодовой страницы, — исходная.

Примеры

Чтобы просмотреть номера текущей кодовой страницы, введите следующую команду:

chcp

Отобразится сообщение следующего вида:

Текущая кодовая страница: 437

Чтобы заменить текущую кодовую страницу страницей 850 (многоязычная латиница 1), введите следующую команду:

chcp 850

Если введено неверное значение номера кодовой страницы, на экран выводится следующее сообщение об ошибке:

Указана недопустимая кодовая страница


Chdir

Chdir (Cd)

Вывод имени текущего каталога или переход в другую папку. При использовании только с именем диска (например chdir C:) команда chdir выводит имена текущих диска и папки. Выполненная без параметров команда chdir выводит текущие диск и каталог.

Синтаксис

chdir [[/d] [диск:][путь] [..]] [[/d] [диск:][путь] [..]]

cd [[/d] [диск:][путь] [..]] [[/d] [диск:][путь] [..]]

Параметры

/d
Смена текущего диска или текущего каталога на диске.
[диск:][путь]
Задание имени диска (если он отличается от текущего) и каталога, в который требуется перейти.
[..]
Переход в родительскую папку.
/?
Отображение справки в командной строке.

Заметки

  • Работа с расширениями командного процессора

    Если расширения командного процессора разрешены (задано по умолчанию), имена папок в пути к текущему каталогу отображаются точно так же, как на жестком диске, в том же формате имен папок с учетом регистра. Например, если имя папки на жестком диске — C:\Temp, команда CD C:\TEMP задает текущий каталог C:\Temp, соответствующий формату имени этой папки на жестком диске.

    Чтобы запретить расширения командного процессора для определенного процесса, введите следующую команду:

    cmd e:off

    Если расширения командного процессора запрещены, в команде chdir нельзя использовать пробелы в качестве разделителей. Таким образом, можно перейти в подкаталог, имя которого содержит пробел, не заключая параметр [путь] в кавычки. Например, следующий путь позволяет перейти в подкаталог \Start menu.

    cd \winnt\profiles\username\programs\start menu

    Для получения дополнительных сведений о разрешении и запрещении расширений командного процессора щелкните ссылку cmd.

  • Переход в корневой каталог

    Корневой каталог является вершиной дерева каталогов на диске. Чтобы перейти в корневой каталог, введите следующую команду:

    cd\

  • Переход из основного каталога одного диска в основной каталог другого

    Чтобы перейти в основной каталог диска отличного от текущего, введите следующую команду:

    chdir [диск:\[каталог]]

    cd [диск:\[каталог]]

    Чтобы проверить переход к этому каталогу, введите одну из следующих команд:

    chdir [диск:]

    cd [диск:]

  • Команда chdir с другими параметрами доступна в консоли восстановления.

Примеры

Используемая с именем диска команда chdir позволяет перейти в текущий каталог этого диска. Например, если ввести команду cd c: в приглашении каталога C:\Temp, отобразится следующая строка:

C:\Temp

Чтобы перейти в текущий каталог Reports, введите одну из следующих команд:

chdir \reports

cd \reports

Чтобы перейти из текущего каталога в подкаталог \Specials\Sponsors, введите следующую команду:

cd \specials\sponsors

Или, если текущим каталогом является \Specials, введите следующую команду, чтобы перейти в подкаталог \Specials\Sponsors:

cd sponsors

Чтобы перейти из подкаталога в родительский каталог, введите следующую команду:

cd ..

Для вывода на экран имени текущего каталога можно использовать команду chdir или cd без параметров. Например, если текущим каталогом является \Public\Jones на диске B, вызов команды chdir приведет к следующему результату:

B:\Public\Jones

Если при работе на диске D требуется скопировать все файлы каталогов \Public\Jones и \Public\Lewis на диске C в корневой каталог диска D, введите следующую последовательность команд:

chdir c:\public\jones

copy c:*.* d:\

chdir c:\public\lewis

copy c:*.* d:\

Если требуется скопировать все файлы каталогов \Public\Jones и \Public\Lewis в текущий каталог диска D, введите следующие команды:

chdir c:\public\jones

copy c:*.* d:

chdir c:\public\lewis

copy c:*.* d:


Chkdsk

Вывод на экран отчета о состоянии диска в форме, зависящей от используемой файловой системы. Команда chkdsk также составляет список ошибок на диске и исправляет их. Выполненная без параметров команда chkdsk выводит информацию о состоянии текущего диска.

Синтаксис

chkdsk [том:][[путь] имя_файла] [/f] [/v] [/r] [/x] [/i] [/c] [/l[:размер]]

Параметры

том:
Указывает букву диска (с последующим двоеточием), точку подключения или имя тома.
[путь] имя_файла
Задает местонахождение и имя файла или имена множества файлов, для которых команда chkdsk проверит степень фрагментации. Для задания нескольких файлов можно использовать подстановочные знаки (* и ?).
/f
Задает исправление ошибок на диске. Диск должен быть заблокирован. Если диск не заблокирован командой chkdsk, отображается запрос на проверку диска при следующей перезагрузке компьютера.
/v
Выводит на экран имена проверяемых файлов и каталогов.
/r
Обнаруживает поврежденные сектора и восстанавливает ту часть данных, которая еще может быть прочитана. Диск должен быть заблокирован.
/x
Используйте только с файловой системой NTFS. При необходимости инициирует операцию отключения тома в качестве первого действия. Все открытые дескрипторы диска будут неверны. Параметр /x включает также функциональные возможности параметра /f.
/i
Используйте только с файловой системой NTFS. Выполняет менее тщательную проверку записей индекса, что уменьшает время, необходимое для работы команды chkdsk.
/c
Используйте только с файловой системой NTFS. Пропускает проверку циклов в структуре папок, что уменьшает время, необходимое для работы команды chkdsk.
/l[:размер]
Используйте только с файловой системой NTFS. Устанавливает указанный размер журнала. Если размер не указан, параметр /l выводит текущий размер.
/?
Отображение справки в командной строке.

Заметки

  • Выполнение команды chkdsk

    Чтобы выполнить команду chkdsk для жестких дисков, необходимо быть членом группы администраторов.

  • Проверка заблокированных дисков при перезагрузке

    Если требуется исправить ошибки на диске с помощью команды chkdsk, нельзя открывать файлы на этом диске. В противном случае выводится следующее сообщение о ошибке:

    Невозможно выполнить команду Chkdsk, так как указанный том используется другим процессом. Следует ли выполнить проверку этого тома при следующей перезагрузке системы? [Y(да)/N(нет)]

    Если пользователь выберет эту возможность, команда chkdsk проверит диск и автоматически исправит ошибки при перезагрузке компьютера. Если проверяемый раздел диска является загрузочным, команда chkdsk автоматически перезагрузит компьютер после проверки этого диска.

  • Отчет об ошибках

    Команда chkdsk выполняет проверку дискового пространства и его использования для файловых систем таблица размещения файлов (FAT) и NTFS. Команда Chkdsk позволяет получить отчет о состоянии со сведениями по каждой файловой системе. Отчет о состоянии диска включает перечень найденных ошибок. Если команда chkdsk запущена без параметра /f в активном разделе, может быть получено сообщение о наличии серьезных ошибок, так как диск нельзя заблокировать. Для поиска ошибок команду chkdsk нужно запускать время от времени на каждом диске.

  • Исправление ошибок

    Если указан параметр командной строки /f, программа chkdsk исправляет ошибки на диске. При работе chkdsk должна обеспечиваться возможность блокирования диска для исправления ошибок. Поскольку при исправлении ошибок обычно изменяется таблица размещения файлов и иногда происходит потеря данных, программа chkdsk запрашивает подтверждение в следующем виде:

    Потерянных кластеров: 10; цепочек: 3.

    Преобразовать потерянные цепочки кластеров в файлы [Y(да)/N(нет)]?

    Если ввести Y, Windows сохраняет каждую потерянную цепочку в корневом каталоге как файл с именем формата Filennnn.chk. После завершения выполнения chkdsk можно проверить эти файлы на наличие нужных сведений. Если ввести N, Windows исправляет ошибки на диске без сохранения данных из потерянных блоков.

    Если параметр командной строки /f не используется, программа chkdsk только выдает сообщение о наличие ошибок в файле, но не исправляет их.

    Если команда chkdsk /f запущена на диске большого объема (например 70 Гб) или диск содержит большое количество файлов (например несколько миллионов), для завершения работы программы chkdsk может потребоваться очень много времени (возможно несколько дней). В течение всего этого времени компьютер будет недоступен для пользователей, так как chkdsk не возвращает управления до завершения работы.

  • Проверка дисков с файловой системой FAT

    Система Windows выводит отчет программы chkdsk о состоянии диска с файловой системой FAT в следующем формате:

    Серийный номер тома: B1AF-AFBF

    72214528 байт всего на диске

    73728 байт в 3 скрытых файлах

    30720 байт в 12 каталогах

    11493376 байт в 386 пользовательских файлах

    61440 байт в поврежденных секторах

    60555264 байт доступно на диске

    2048 байт в каждом кластере

    Всего кластеров на диске: 35261.

    29568 кластеров на диске

  • Проверка дисков с файловой системой NTFS

    Система Windows выводит отчет программы chkdsk о состоянии диска с файловой системой NTFS в следующем формате:

    Тип файловой системы: NTFS.

    Проверка файлов...

    Проверка файлов завершена.

    Проверка индексов...

    Проверка индесков завершена.

    Проверка описателей защиты...

    Проверка описателей защиты завершена.

    12372 Кбайт всего на диске.

    3 Кбайт в 1 пользовательских файлах.

    2 КБ в 1 индексах.

    4217 КБ используется системой.

    8150 Кбайт свободно на диске.

    Размер кластера: 512 байт.

    Всего кластеров на диске: 24745.

    16301 кластеров на диске.
  • Использование chkdsk с открытыми файлами

    Если указан параметр /f, команда chkdsk выводит сообщение об ошибке, если на диске найдены открытые файлы. Если же параметр /f не указан и на диске найдены открытые файлы, chkdsk может выводить сообщения о потерянных блоках на диске. Это произойдет в случае, когда открытые файлы еще не записаны в таблице размещения файлов. Если программа chkdsk сообщает о большом количестве потерянных блоков дискового пространства, должна быть рассмотрена возможность ремонта диска.

  • Обнаружение физических ошибок диска

    Используйте параметр командной строки /r для обнаружения физических ошибок диска в файловой системе. Получения сведений о восстановлении физически поврежденных файлов с помощью команды recover

  • Отчет о поврежденных секторах диска

    Испорченные сектора, о которых сообщает команда chkdsk, были маркированы при первом форматировании диска. Такие сектора не представляют опасности.

  • Общие сведения о кодах завершения программы

    В следующей таблице перечислены коды завершения, которые могут содержатся в отчете программы chkdsk после окончания ее выполнения.

    Код выхода | Описание
    0 | Не найдено ни одной ошибки.
    1 | Ошибки найдены и исправлены.
    2

    Была выполнена очистка диска, например удалены ненужные файлы, или очистка не была выполнена из-за отсутствия ключа /f.

    3 | Диск не может быть проверен, ошибки не могут быть исправлены или ошибки не были исправлены, так как не был задан ключ /f.
  • Команда chkdsk с другими параметрами доступна в консоли восстановления.

Примеры

Если требуется проверить диск в дисководе D и исправить все обнаруженные ошибки в Windows, введите следующую команду:

chkdsk d: /f

Если обнаружена ошибка, выполнение программы сhkdsk приостанавливается и выводятся соответствующие сообщения. По окончании выполнения команды chkdsk на экран выводится отчет, содержащий сведения о текущем состоянии диска. До завершения работы chkdsk нельзя открывать какие-либо файлы на указанном диске.

Чтобы проверить фрагментацию всех файлов в текущем каталоге на диске с файловой системой FAT, введите следующую команду:

chkdsk *.*

Chkdsk выведет отчет о состоянии диска, а затем список фрагментированных файлов, удовлетворяющих шаблону команды.


Chkntfs

Просмотр или задание планирования автоматической проверки системы для томов файловых систем FAT, FAT32 или NTFS при запуске компьютера.

Синтаксис

chkntfs том: [...]

chkntfs [/d]

chkntfs [/t[:время]]

chkntfs [/x том: [...]]

chkntfs [/c том: [...]]

Параметры

том: [...]
Обязательный параметр. Указание буквы диска (с последующим двоеточием), точки подключения или имени тома. Выводит сообщение, в котором указана файловая система заданного тома. Если выполняется запланированная автоматическая проверка файлов, данный параметр позволяет вывести сообщение о повреждении тома. В этом случае необходимо запустить команду chkdsk.
/d
Восстановление всех параметров chkntfs по умолчанию, за исключением времени, оставшегося до автоматической проверки файлов. По умолчанию при запуске компьютера проверяются все тома.
/t[:время]
Изменение инициализации обратного времени отсчета в Autochk.exe на указанное значение времени в секундах. Если параметр :время не задан, параметр /t выводит текущее время обратного отсчета.
/x том: [...]
Исключение указанного тома из проверки при запуске компьютера, даже если помечено, что для него требуется запуск chkdsk.
/c том: [...]
Планирование проверки указанного тома при запуске компьютера.
/?
Отображение справки в командной строке.

Заметки

  • Чтобы выполнить команду chkntfs, необходимо быть членом локальной группы администраторов.
  • Хотя инициализацию времени обратного отсчета в Autochk.exe можно установить в ноль, это не позволит отменить автоматическую проверку файлов, которая является потенциально длительной процедурой.

Примеры

Чтобы вывести инициализацию времени обратного отсчета файла Autochk.exe, введите следующую команду:

chkntfs /t

При изменении инициализации времени обратного отсчета в Autochk.exe введите время в секундах. Например, чтобы установить время обратного отсчета в 30 секунд, введите следующую команду:

chkntfs /t:30

Параметр командной строки /x не обладает свойством накопления. Если он вводится несколько раз, самая последняя запись переопределяет предыдущие данные. Чтобы исключить несколько томов, перечислите их в одной команде. Например, чтобы исключить тома E: и F:, введите следующую команду:

chkntfs /x e: f:

Чтобы исключить только том F:, введите следующую команду:

chkntfs /x e:

chkntfs /x f:

Параметр командной строки /c обладает свойством накопления. Если требуется проверять только указанный том, восстановите параметры по умолчанию для сброса всех предыдущих команд, исключите проверку всех томов, а затем запланируйте автоматическую проверку файлов для нужного тома.

Например, чтобы запланировать автоматическую проверку файлов только на диске D:, введите следующие команды:

chkntfs /d

chkntfs /x c: d: e:

chkntfs /c d:


Cipher

Отображение или изменение шифрование папок и файлов на томах NTFS. Использованная без параметров команда cipher отображает состояние шифрования текущей папки и всех файлов, находящихся в ней.

Синтаксис

cipher [{/e|/d}] [/s:каталог] [/a] [/i] [/f] [/q] [/h] [/k] [/u[/n]] [путь [...]] | [/r:имя_файла_без_расширения] | [/w:путь]

Параметры

/e
Шифрует указанные папки. Папки помечаются таким образом, чтобы файлы, которые будут добавляться в папку позже, также шифровались.
/d
Расшифровывает указанные папки. Папки помечаются таким образом, чтобы файлы, которые будут добавляться в папку позже, также шифровались.
/s: каталог
Выполняет выбранную операцию над указанной папкой и всеми подпапками в ней.
/a
Выполняет операцию над файлами и каталогами.
/i
Продолжение выполнения указанной операции даже после возникновения ошибок. По умолчанию выполнение cipher прекращается после возникновения ошибки.
/f
Выполнение шифрования или расшифровывания указанных объектов. По умолчанию уже зашифрованные или расшифрованные файлы пропускаются командой cipher.
/q
Включение в отчет только наиболее важных сведений.
/h
Отображение файлов с атрибутами «Скрытый» и «Системный». По умолчанию эти файлы не шифруются и не расшифровываются.
/k
Создание ключа шифрования файла для пользователя, выполнившего команду cipher. Если используется данный параметр, все остальные параметры команды cipher не учитываются.
/u
Обновление ключа шифрования файла пользователя или ключа агента восстановления на текущие ключи во всех зашифрованных файлах на локальном диске (если эти ключи были изменены). Этот параметр используется только вместе с параметром /n.
/n
Запрещение обновления ключей. Данный параметр служит для поиска всех зашифрованных файлов на локальных дисках. Этот параметр используется только вместе с параметром /u.
путь
Указывает шаблон, файл или папку.
/r:имя_файла_без_расширения
Создание нового сертификата агента восстановления и закрытого ключа с последующей их записью в файлах с именем, указанным в параметре имя_файла_без_расширения. Если используется данный параметр, все остальные параметры команды cipher не учитываются.
/w:путь
Удаление данных из неиспользуемых разделов тома. Параметр путь может указывать на любой каталог нужного тома. Если используется данный параметр, все остальные параметры команды cipher не учитываются.
/?
Отображение справки в командной строке.

Заметки

  • Использование параметра /w

    Параметр /w удаляет данные из доступных разделов тома и не применим к файлам или каталогам. При использовании данного параметра диск не блокируется, поэтому другие программы могут обращаться к разделам на диске, которые в этом случае не могут быть стерты cipher. Поскольку данный параметр выполняет запись в большую часть дискового тома, для завершения работы программы может потребоваться много времени, а поэтому его следует использовать только при необходимости.

  • Шифрование и расшифровывание файлов

    Чтобы предотвратить расшифровывание зашифрованного файла при изменении, рекомендуется зашифровать и файл, и папку, в которой он находится.

  • Использование файлов и папок, доступных только для чтения

    С помощью команды cipher нельзя зашифровать файлы, доступные только для чтения.

  • Использование нескольких имен папок

    Имеется возможность использовать несколько имен папок и подстановочные знаки.

  • Использование нескольких параметров

    Параметры должны быть разделены между собой по крайней мере одним пробелом.

Примеры

Чтобы зашифровать подпапку May в папке MonthlyReports с помощью команды cipher, введите следующую команду:

cipher /e monthlyreports\may

Чтобы зашифровать папку MonthlyReports, подпапки с January по December и подпапки Manufacturing в подпапках месяцев, введите:

cipher /e /s:monthlyreports

Чтобы зашифровать только файл Marketing.xls в подпапке May, введите:

cipher /e /a monthlyreports\may\marketing.xls

Чтобы зашифровать файл Marketing.xls, файл Maintenance.doc и подпапку Manufacturing (расположенные в папке May), введите:

cipher /e /a monthlyreports\may\ma*

Чтобы определить, зашифрована ли папка May, введите:

cipher monthlyreports\may

Чтобы определить, какие файлы зашифрованы в папке May, введите:

cipher monthlyreports\may\*


Cls

Очистка окна командной строки.

Синтаксис

cls

Параметры

/?
Отображение справки в командной строке.

Примеры

Чтобы очистить окно командной строки от сведений, которые в нем отображаются, и восстановить пустое окно, введите следующую команду:

cls


Cmd

Запуск нового экземпляра программы командного процессора Cmd.exe. Выполненная без параметров команда cmd выводит сведения о версии Windows XP и авторских правах.

Синтаксис

cmd [[{/c|/k}] [/s] [/q] [/d] [{/a|/u}] [/t:тф] [/e:{on|off}] [/f:{on|off}] [/v:{on|off}] команда]

Параметры

/c
Выполнение команды, заданной параметром команда, с завершением работы.
/k
Выполнение команды, заданной параметром команда, с продолжением работы.
/s
Изменение обработки команды после параметров /c или /k.
/q
Выключение режима вывода команд на экран.
/d
Отключение выполнения команд AutoRun.
/a
Вывод сведений в формате ANSI (American National Standards Institute).
/u
Вывод сведений в кодировке Юникод.
/t:тф
Изменение цвета текста т и фона ф. В следующей таблице перечислены допустимые шестнадцатеричные числа, которые можно задать в качестве значений параметров т и ф.
Значение | Цвет
0 | Черный
1 | Синий
2 | Зеленый
3 | Голубой
4 | Красный
5 | Сиреневый
6 | Желтый
7 | Белый
8 | Серый
9 | Светло-синий
A | Светло-зеленый
B | Светло-голубой
C | Светло-красный
D | Светло-сиреневый
E | Светло-желтый
F | Яркий белый
/e:on
Включение расширений командного процессора.
/e:off
Отключение расширений командного процессора.
/f:on
Включение завершения имен файлов и папок.
/f:off
Отключение завершения имен файлов и папок.
/v:on
Включение отложенного расширения переменных среды.
/v:off
Отключение отложенного расширения переменных среды.
строка
Задание команды для выполнения.
/?
Отображение справки в командной строке.

Заметки

  • Использование нескольких команд

    В параметре строка можно указать несколько команд, используя разделитель команд &&. Однако в этом случае необходимо заключить все эти команды в кавычки (например "команда&&команда&&команда").

  • Обработка кавычек

    Если указан параметр /c или /k, команда cmd обрабатывает остаток строки и кавычки сохраняются только при выполнении следующих условий:

    • параметр /s не используется;
    • используется только одна пара кавычек;
    • текст в кавычках не содержит никаких специальных символов (например: &<>( ) @ ^ |);
    • текст в кавычках не содержит одного или нескольких пробелов;
    • строка в кавычках является именем исполняемого файла.

    Если эти условия выполняются, строка обрабатывается, т. е. проверяется, является ли первый символ открывающей кавычкой. Если первый символ является открывающей кавычкой, он связывается с закрывающей кавычкой. Текст, следующий за закрывающей кавычкой, сохраняется.

  • Выполнение подразделов реестра

    Если в строке не указан параметр /d, программа Cmd.exe выполняет поиск следующих подразделов реестра:

    HKLM\Software\Microsoft\Command Processor\AutoRun\REG_SZ

    HKCU\Software\Microsoft\Command Processor\AutoRun REG_EXPAND_SZ

    Если присутствуют один или оба подраздела реестра, они выполняются перед всеми другими переменными.

    Внимание!

    • Ошибка при изменении реестра может серьезно повредить систему. Перед изменением реестра создайте резервную копию всех важных данных.
  • Разрешение и запрещение расширений командного процессора

    В Windows XP расширения командного процессора разрешены по умолчанию. Эти расширения можно запретить в определенном процессе с помощью параметра /e:off. В компьютере или сеансе пользователя можно разрешить или запретить расширения для всех параметров команды cmd, задав следующие значения REG_DWORD:

    HKLM\Software\Microsoft\Command Processor\EnableExtensions\REG_DWORD

    HKCU\Software\Microsoft\Command Processor\EnableExtensions\REG_DWORD

    Установите в реестре значение REG_DWORD в 0×1 (т. е. разрешить) или 0×0 (т. е. запретить) с помощью программы Regedit.exe. Пользовательские настройки имеют приоритет над настройками компьютера, а параметры командной строки имеют приоритет над параметрами реестра.

    Внимание!

    • Ошибка при изменении реестра может серьезно повредить систему. Перед изменением реестра создайте резервную копию всех важных данных.

    Если расширения командного процессора разрешены, вступают в силу следующие команды.

    • assoc
    • call
    • chdir (cd)
    • color
    • del (erase)
    • endlocal
    • for
    • ftype
    • goto
    • if
    • mkdir (md)
    • popd
    • prompt
    • pushd
    • set
    • setlocal
    • shift
    • start (также вносит изменения во внешние командные процессы)

  • Включение отложенного расширения переменных среды

    Если включено отложенное расширение переменных среды, можно воспользоваться восклицательным знаком, чтобы подставить значение переменной среды во время выполнения.

  • Включение завершения имен файлов и папок

    По умолчанию завершение имен файлов и папок не используется. Завершение имен файлов можно включить или отключить для определенного процесса команды cmd с помощью параметра /f:{on|off}. В компьютере или сеансе пользователя можно включить или отключить завершения имен файлов и папок для всех процессов команды cmd, задав следующие значения REG_DWORD:

    HKLM\Software\Microsoft\Command Processor\CompletionChar\REG_DWORD

    HKLM\Software\Microsoft\Command Processor\PathCompletionChar\REG_DWORD

    HKCU\Software\Microsoft\Command Processor\CompletionChar\REG_DWORD

    HKCU\Software\Microsoft\Command Processor\PathCompletionChar\REG_DWORD

    Чтобы задать значение REG_DWORD, запустите программу Regedit.exe и введите шестнадцатеричное число управляющего символа для определенной функции (например 0×9 — это TAB, а 0×08 — это BACKSPACE). Пользовательские настройки имеют приоритет над настройками компьютера, а параметры командной строки имеют приоритет над параметрами реестра.

    Внимание!

    • Ошибка при изменении реестра может серьезно повредить систему. Перед изменением реестра создайте резервную копию всех важных данных.

    Если включено завершение имен файлов и папок с помощью параметра /f:on, воспользуйтесь клавишами CTRL+D для завершения имен папок и CTRL+F для завершения имен файлов. Чтобы отключить определенный символ завершения в реестре, введите значение пробела [0×20], поскольку он не является допустимым управляющим символом.

    Если нажать клавиши CTRL+D или CTRL+F, команда cmd выполнит завершение имени папки или файла. Данные комбинации клавиш выполняют следующие функции: добавление подстановочных знаков в строку (если они отсутствуют), создание списка подходящих путей, а затем отображение первого пути из этого списка. Если ни один из путей не удовлетворяет условиям отбора, функция завершения имен файлов и папок выдает звуковой сигнал не выводит сведения на экран. Для перемещения по списку путей, удовлетворяющих условиям отбора, нажимайте клавиши CTRL+D или CTRL+F. Для перемещения по списку в обратном порядке нажмите одновременно клавишу SHIFT и клавиши CTRL+D или CTRL+F. Чтобы сбросить сохраненный список путей, удовлетворяющих условиям отбора, и создать новый список, измените строку и нажмите клавиши CTRL+D или CTRL+F. При переключении между клавишами CTRL+D и CTRL+F сохраненный список путей сбрасывается и создается новый. Единственная разница между клавишами CTRL+D и CTRL+F заключается в том, что CTRL+D позволяет отбирать только имена файлов, а CTRL+F — как имена файлов, так и имена папок. Если завершения имен файлов и папок используется с одной из встроенных команд каталогов (т. е. CD, MD или RD), предполагается завершение папок.

    Завершение имен файлов и папок правильно обрабатывает имена файлов, которые содержат пробелы или специальные символы, если соответствующий путь заключен в кавычки.

    Кавычки необходимы при использовании следующих специальных символов: & < > [ ] { } ^ = ; ! ' + , ` ~ [пробел].

    Если вводятся сведения, содержащие пробелы, заключите этот текст в кавычки (например "Имя компьютера").

    Если выполняется завершение имен файлов и папок из строки, часть [пути], расположенная справа от курсора, (т. е. с той точки строки, с которой выполняется завершение) отбрасывается.


Cmstp

Установка или удаление профиля службы диспетчера подключений. Выполненная без параметров команда cmstp устанавливает профиль службы со стандартными параметрами, соответствующими данной операционной системе и разрешениям пользователя.

Синтаксис

Синтаксис 1: имя_файла_профиля_службы.exe /q:a /c:"cmstp.exe имя_файла_профиля_службы.inf [/nf] [/ni] [/ns] [/s] [/su] [/u]"

Синтаксис 2: cmstp.exe [/nf] [/ni] [/ns] [/s] [/su] [/u] "[диск:][путь]имя_файла_профиля_службы.inf"

Параметры

имя_файла_профиля_службы.exe
Обязательный параметр для синтаксиса 1, но недопустим для синтаксиса 2. Задает имя пакета установки, содержащего профиль, который требуется установить.
/q:a
Обязательный параметр для синтаксиса 1, но недопустим для синтаксиса 2. Задает установку профиля без подтверждения пользователя. В этом случае будет отображаться сообщение об успешном завершении установки.
[диск:][путь]имя_файла_профиля_службы.inf
Обязательный параметр. Задает имя файла настройки, который определяет режим установки профиля. Параметр [диск:][путь] недопустим для синтаксиса 1.
/nf
Файлы поддержки не устанавливаются.
/ni
Значок на рабочем столе не создается. Данный параметр применяется только на компьютерах, работающих под управлением операционных систем Windows 95, Windows 98, Windows NT 4.0 или Windows Millennium Edition.
/ns
Ярлык на рабочем столе не создается. Данный параметр применяется только на компьютерах, работающих под управлением операционных систем Windows 2000 или Windows XP.
/s
Отмена уведомлений (т. е. запросов на подтверждения пользователя и сообщения об успешном завершении установки) при установке или удалении профиля службы.
/su
Профиль службы устанавливается только для одного, а не для всех пользователей. Данный параметр применяется только на компьютерах, работающих под управлением операционных систем Windows 2000 или Windows XP.
/u
Удаление профиля службы.
/?
Отображение справки в командной строке.

Заметки

  • /s — единственный параметр, который можно использовать вместе с /u.
  • Синтаксис 1 обычно используется в приложении выборочной установки. Чтобы воспользоваться этим синтаксисом, необходимо запустить команду cmstp из каталога, в котором находится файл, указанный в параметре имя_файла_профиля_службы.exe.

Примеры

Следующие примеры иллюстрируют возможные варианты использования команды cmstp при работе с вымышленным профилем службы Fiction и его файлами.

  • Чтобы установить профиль службы Fiction без файлов поддержки, введите следующую команду:

    • fiction.exe /c:"cmstp.exe fiction.inf /nf"

  • Чтобы установить профиль службы Fiction для одного пользователя без уведомлений, введите следующую команду:

    • fiction.exe /c:"cmstp.exe fiction.inf /s /su"

  • Чтобы удалить профиль службы Fiction без уведомлений, введите следующую команду:

    • fiction.exe /c:"cmstp.exe fiction.inf /s /u"


Color

Изменение цвета текста и фона в окне командной строки для текущего сеанса. Выполненная без параметров команда color восстанавливает стандартные цвета текста и фона в окне командной строки.

Синтаксис

color [тф]

Параметры

тф
Изменение цвета текста т и фона ф. В следующей таблице перечислены допустимые шестнадцатеричные числа, которые можно задать в качестве значений параметров т и ф.
Значение | Цвет
0 | Черный
1 | Синий
2 | Зеленый
3 | Голубой
4 | Красный
5 | Сиреневый
6 | Желтый
7 | Белый
8 | Серый
9 | Светло-синий
A | Светло-зеленый
B | Светло-голубой
C | Светло-красный
D | Светло-сиреневый
E | Светло-желтый
F | Яркий белый
/?
Отображение справки в командной строке.

Заметки

  • Чтобы задать стандартные цвета в окне командной строки, щелкните левый верхний угол этого окна, выберите команду Умолчания, перейдите к вкладке Цвета и укажите цвета для параметров Текст на экране и Фон экрана.
  • Для изменения цветов окна командной строки в текущем сеансе можно воспользоваться командой cmd /t:тф.
  • Если цвета текста и фона совпадают, команда color устанавливает значение параметра ERRORLEVEL в единицу (1).

Примеры

Чтобы изменить цвет текста на красный, а цвет фона на белый в окне командной строки, введите следующую команду:

color FC


Comp

Побайтное сравнение двух или нескольких файлов. Команда comp позволяет сравнивать файлы, находящиеся на разных дисках и в разных каталогах. При сравнении файлов с помощью команды comp выводятся их имена и расположения. Выполненная без параметров команда comp запрашивает файлы для сравнения.

Синтаксис

comp [файл1] [файл2] [/d] [/a] [/l] [/n=кол_строк] [/c]

Параметры

файл1
Задание имени и расположения первого файла или набора файлов для сравнения. Для указания нескольких файлов можно использовать подстановочные знаки (* и ?).
файл2
Задание имени и расположения второго файла или набора файлов для сравнения. Для задания нескольких файлов можно использовать подстановочные знаки (* и ?).
/d
Вывод различий в десятичном формате. (По умолчанию используется шестнадцатеричный формат.)
/a
Вывод различий в символьном виде.
/l
Вывод номера строки, в которой обнаружено различие, вместо отображения смещения в байтах.
/n=кол_строк
Сравнение первых нескольких строк, заданных параметром кол_строк, обоих файлов, даже если эти файлы имеют разный размер.
/c
Сравнение без учета регистра.
/?
Отображение справки в командной строке.

Примечания

  • Сравнение файлов с одинаковыми именами

    Если сравниваются файлы с одинаковыми именами, они должны находятся в разных каталогах или на разных дисках. Если в параметре файл2 не указано имя файла, предполагается, что имя файл2 совпадает с именем файл1. Для задания имен файлов можно использовать подстановочные знаки (* и ?).

  • Неполное задание параметров файл1 и файл2

    Если имена файлов файл1 или файл2 введены не полностью или параметр файл2 пропущен, программа comp выведет на экран запрос для получения недостающих сведений. Если параметр файл1 содержит только имя диска или каталога без имени файла, команда comp сравнивает все файлы в заданном каталоге с файлом файл2. Если параметр файл2 содержит только имя диска или каталога, будет предполагаться, что имя файла файл2 такое же, как в параметре файл1.

  • Вывод информации о несовпадениях

    В процессе сравнения программа comp выводит сообщения с указанием расположения несовпадающих байтов в файлах. В каждое сообщение включены сведения о смещении адреса несовпадающих байтов и содержимое этих байт (в шестнадцатеричном формате, если не указан параметр /a или /d). Эти сообщения имеют следующий формат:

    Ошибка сравнения OFFSET xxxxxxxx

    файл1 = xx

    файл2 = xx

    После того как найдено 10 различий, работа команды comp прекращается и выводится следующее сообщение:

    Обнаружено 10 различий. Сравнение завершено.

  • Сравнение файлов разного размера

    Чтобы сравнить файлы разных размеров, необходимо указать параметр /n. Если файлы имеют различные размеры, comp выводит следующее сообщение:

    Разные размеры файлов

    Сравнить другие файлы [Y(да)/N(нет)]?

    Нажмите клавишу Y для сравнения следующей пары файлов. Нажмите клавишу N для завершения выполнения команды comp.

    При нажатии клавиши Y команда comp продолжает сравнение с заданными параметрами, пока не будет нажата клавиша N или заново введена эта команда.

    При работе с файлами разного размера воспользуйтесь параметром /n, чтобы сравнить только начала файлов.

  • Последовательное сравнение файлов

    Если использованы подстановочные знаки (* и ?) для задания нескольких файлов, comp найдет первый файл, удовлетворяющий шаблону файл1, и выполнит его сравнение с соответствующим файлом файл2, если он существует. Команда comp выводит результаты сравнения и проводит сравнение всех файлов, удовлетворяющих шаблону файл1. После завершения работы comp будет выведено следующее сообщение:

    Сравнить другие файлы [Y(да)/N(нет)]?

    Чтобы сравнить другие файлы, нажмите клавишу Y. Команда comp запросит расположения и имена новых файлов. Чтобы завершить сравнение, нажмите клавишу N. При нажатии клавиши Y команда comp запрашивает параметры командной строки. Если эти параметры не заданы, программа comp использует параметры, введенные ранее.

  • Если файлы не найдены

    Если командой comp не найдены указанные файлы, выводится запрос на продолжение сравнения.

Примеры

Чтобы сравнить содержимое каталога C:\Reports с содержимым каталога резервных копий \\Sales\Backup\April, введите следующую команду:

comp c:\reports \\sales\backup\april

Чтобы сравнить первые десять строк файлов в каталоге \Invoice и вывести результат в десятичном формате, введите следующую команду:

comp \invoice\*.txt \invoice\backup\*.txt /n=10 /d


Compact

Вывод сведений или изменение уплотнения файлов и каталогов в разделах NTFS. Запущенная без параметров команда compact выводит сведения об уплотнении файлов в текущем каталоге.

Синтаксис

compact [{/c|/u}] [/s[:каталог]] [/a] [/i] [/f] [/q] [имя_файла[...]]

Параметры

/c
Уплотнение заданного каталога или файла.
/u
Разуплотнение заданного каталога или файла.
s:каталог
Задание выполнения операции (уплотнения или разуплотнения) во всех подкаталогах указанного или текущего каталога.

/a
Отображение скрытых и системных файлов.
/i
Игнорирование ошибок.
/f
Принудительное уплотнение или разуплотнение каталогов или файлов. Используется в случае, когда предыдущая операция над данным каталогом или файлом была прервана в результате сбоя системы. Для полного уплотнения частично уплотненного файла используются параметры /c и /f, а также задается имя такого файла.
/q
Включение в отчет только существенных сведений.
имя_файла
Задание имени файла или каталога. Допускается использование нескольких имен файлов и подстановочных знаков (* и ?).
/?
Отображение справки в командной строке.

Примечания

  • Команда compact является интерфейсом командной строки для встроенного средства уплотнения NTFS. Команда позволяет просматривать и задавать атрибуты уплотнения файлов и каталогов разделов дисков с файловой системой NTFS. Состояние сжатия каталога показывает, будут ли автоматически сжаты файлы, добавляемые в каталог. Когда изменяется состояние сжатия каталога, не нужно изменять состояние сжатия файлов, уже помещенных в каталог.
  • Нельзя использовать команду compact для чтения, записи и присоединения томов, уплотненных служебными программами DriveSpace и DoubleSpace.

Примеры

Чтобы задать состояние уплотнения текущей папки, а также ее подпапок и существующих файлов, из этой папки, введите следующую команду:

compact /c /s

Чтобы задать состояние уплотнения файлов в текущей папке, а также всех ее подпапок и файлов в них, без изменения состояния самой этой папки, введите следующую команду:

compact /c /s *.*

Чтобы уплотнить том из корневой папки этого тома, введите следующую команду:

compact /c /i /s:\

В этом примере задается состояние уплотнения корневой папки и всех папок данного тома, а также уплотняются все файлы этого тома. Параметр /i позволяет отменить вывод сообщений об ошибках, чтобы не прерывать процесс уплотнения.

Чтобы уплотнить все файлы с расширением .bmp в каталоге \Tmp и его подкаталогах, но без установки атрибута уплотнения для этих каталогов, введите следующую команду:

compact /c /s:\tmp *.bmp

Чтобы завершить уплотнение файла Zebra.bmp, который был частично уплотнен до сбоя системы, выполните следующую команду:

compact /c /f zebra.bmp

Чтобы удалить атрибуты уплотнения в каталоге C:\Tmp, но без изменения уплотнения файлов в этом каталоге, введите следующую команду:

compact /u c:\tmp


Convert

Преобразование томов с файловой системой FAT и FAT32 в тома с файловой системой NTFS.

Синтаксис

convert [том] /fs:ntfs [/v] [/cvtarea:имя_файла] [/nosecurity] [/x]

Параметры

том
Указание буквы диска (с последующим двоеточием), точки подключения или имени тома, преобразуемых в файловую систему NTFS.
/fs:ntfs
Обязательный параметр. Преобразование тома в файловую систему NTFS.
/v
Задание режима вывода дополнительной информации, т. е. в процессе преобразования выводятся все сообщения.
/cvtarea:имя_файла
Только для опытных пользователей. Задание записи основной таблицы файлов (MFT) и прочих файлов метаданных NTFS в существующий непрерывный файл-заглушку. Этот файл должен находится в корневом каталоге преобразуемой файловой системы. Использование параметра /CVTAREA позволяет получить менее фрагментированную файловую систему после преобразования. Для получения оптимальных результатов размер этого файла должен равняться числу файлов и каталогов в файловой системе, выраженному в килобайтах, однако служебная программа преобразования обрабатывает файлы любого размера.

Важно!

  • Файл-заглушку необходимо создать перед выполнением команды convert с помощью команды fsutil file createnew. Команда convert не позволяет создать этот файл. Эта команда только перезаписывает данный файл данными NTFS. После преобразования все неиспользованное пространство этого файла освобождается.
/nosecurity
Задание свободного доступа к параметрам безопасности преобразованных файлов и каталогов.
/x
Отключение тома перед преобразованием при необходимости. Все открытые дескрипторы тома становятся недействительными.

Примечания

  • Необходимо задать преобразование диска при перезагрузке компьютера. В противном случае отсутствует возможность преобразовать текущий диск.
  • Если команда convert не может заблокировать диск (например системный том или текущий диск), выводится приглашение преобразовать диск при следующей перезагрузке компьютера.
  • Основная таблица файлов (MFT) имеет другое расположение в томах, преобразованных из предыдущей версии файловой системы NTFS, поэтому их быстродействие может уступать томам, преобразованным из Windows NT.
  • Тома, преобразованные из файловой системы FAT в NTFS, несколько уступают по быстродействию томам, непосредственно отформатированным в NTFS. В преобразованных томах основная таблица файлов (MFT) может оказаться фрагментированной. Кроме того, в преобразованных загрузочных томах разрешения на доступ NTFS недействительны после преобразования тома.

Примеры

Чтобы преобразовать тома на диске E в формат NTFS и вывести все сообщения, введите следующую команду:

convert e: /fs:ntfs /v


Copy

Копирование одного или нескольких файлов из одного расположения в другое.

Синтаксис

copy [/d] [/v] [/n] [{/y|/-y}] [/z] [{/a|/b}] источник [{/a|/b}] [+ источник [{/a|/b}] [+ ...]] [назначение [{/a|/b}]]

Параметры

/d
Сохранение копируемых шифрованных файлов как расшифрованных в месте назначения.
/v
Проверка правильности копирования путем сравнения копий файлов.
/n
Использование короткого имени (при наличии) копируемого файла, если его имя превышает 8 символов или его расширение превышает 3 символа.
/y
Отмена вывода запроса на подтверждение перезаписи существующего конечного файла.
/-y
Вывод запроса на подтверждение перезаписи существующего конечного файла.
/z
Копирование файлов по сети в режиме перезапуска.
/a
Указание текстового файла в формате ASCII.
/b
Указание двоичного файла.
источник
Обязательный параметр. Задание расположение файла или набора файлов, которые требуется скопировать. Параметр источник может состоять из имени диска с двоеточием, имени папки, имени файла или их комбинации.
назначение
Обязательный параметр. Задание расположения, в которое требуется скопировать файл или набор файлов. Параметр назначение может состоять из имени диска с двоеточием, имени папки, имени файла или их комбинации.
/?
Отображение справки в командной строке.

Примечания

  • Имеется возможность скопировать текстовый файл, в котором используется символ конца файла (CTRL+Z) для обозначения конца файла.
  • Использование параметра /a

    Если параметр /a стоит перед списком файлов в командной строке, он применяется ко всем файлам, перечисленным до параметра /b команды copy. В этом случае /b применяется к файлу, предшествующему /b.

    Если параметр /a стоит после списка файлов в командной строке, он применяется ко всем файлам, перечисленным до параметра /b команды copy. В этом случае /b применяется к файлу, предшествующему /b.

    Результат применения параметра /a зависит от его положения в командной строке. Если параметр /a стоит после параметра источник, команда copy обрабатывает файл как текстовый в формате ASCII и копирует данные, которые находятся перед первым символом конца файла.

    Если параметр /a расположен после параметра назначение, команда copy добавляет символ конца файла как последний символ файла.

  • Использование параметра /b

    Параметр /b задает считывание командным процессором количества байт, равного размеру файла в каталоге. Параметр /b задается по умолчанию для команды copy, за исключением случаев использования copy для слияния файлов.

    Если параметр /b стоит перед списком файлов в командной строке, он применяется ко всем файлам, перечисленным до параметра /a команды copy. В этом случае /a применяется к файлу, предшествующему /a.

    Если параметр /b стоит после списка файлов в командной строке, он применяется ко всем файлам, перечисленным до параметра /a команды copy. В этом случае /a применяется к файлу, предшествующему /a.

    Результат применения параметра /b зависит от его положения в командной строке. Если параметр /b стоит после параметра источник, команда copy копирует файл целиком, включая все символы конца строки.

    Если параметр /b стоит после параметра назначение, команда copy не добавляет символ конца строки.

  • Использование параметра /v

    Если операция записи не может быть проверена, выводится сообщение об ошибке. Хотя ошибки записи редко возникают при работе с командой copy, параметром /v можно воспользоваться для проверки правильности записи важных данных. Параметр /v также завершает работу команды copy, поскольку необходимо проверить каждый сектор, записанный на диск.

  • Использование параметров /y и /-y

    Если параметр /y установлен заранее в переменной среды COPYCMD, можно переопределить эту настройку, указав параметр /-y в командной строке. При переопределении данной настройки по умолчанию выводится запрос, за исключением исключением случаев выполнения команды copy в пакетном файле.

  • Объединение файлов

    Чтобы объединить файлы, укажите один файл в параметре назначение и несколько в параметре источник (используя подстановочные знаки или формат файл1+файл2+файл3).

  • Использование параметра /z

    Если во время фазы копирования теряется сетевое подключение (например, если сервер переходит в автономный режим, разрывая подключение), команда copy /z позволяет продолжить копирование после восстановления подключения. Кроме того, параметр /z позволяет отобразить сведения о завершении операции копирования в процентах для каждого файла.

  • Использование внешних устройств в операциях копирования

    В качестве параметров источник и назначение можно указать имена устройств.

  • Использование параметра /b при копировании на устройство

    Если в параметре назначение указано устройство (например Com1 или Lpt1), параметр /b позволяет скопировать данные на это устройство в двоичном режиме. В двоичном режиме команда copy /b копирует все символы (включая управляющие символы, такие как CTRL+C, CTRL+S, CTRL+Z и перевод строки) на устройство как данные. Однако если параметр /b не указан, данные копируются на устройство в формате ASCII. В этом режиме управляющие символы могут вызвать слияние файлов в системе Windows XP в процессе копирования.

  • Использование стандартного имени конечного файла

    Если конечный файл не задан, по умолчанию файлы будут скопированы с тем же именем, датой и временем создания в текущий каталог на текущем диске. Если исходный файл находится в текущем каталоге на текущем диске, выполнение команды copy завершается и выводится следующее сообщение об ошибке:

    Невозможно скопировать файл в себя

    Скопировано файлов: 0

  • Слияние файлов

    Если введено несколько параметров источник, разделенных знаком плюс (+), команда copy объединяет файлы в один. Если в параметре источник использованы подстановочные знаки (* или ?), а в параметре назначение задан один файл, команда copy объединит все файлы, удовлетворяющие шаблону в параметре источник, в один с именем, указанным в параметре назначение. В обоих случаях, если не задан параметр /b, команда copy объединяет файлы как текстовые.

  • Копирование файлов нулевой длины

    Команда Copy не копирует файлы, которые имеют длину, равную 0 байт. Для выполнения этой операции служит команда xcopy.

  • Изменение даты и времени модификации файла

    Если требуется установить текущую дату и время в качестве даты модификации файла без изменения его содержимого, воспользуйтесь следующим синтаксисом:

    copy /b источник+,,

    Запятые заменяют параметр назначение.

  • Копирование файлов в подкаталогах

    Для копирования всех файлов каталога и его подкаталогов служит команда xcopy.

  • Команда copy с другими параметрами доступна в консоли восстановления.

Примеры

Чтобы скопировать файл Memo.doc в файл Letter.doc на текущем диске и убедиться, что символ конца файла находится в конце скопированного файла, введите следующую команду:

copy memo.doc letter.doc /a

Чтобы скопировать файл Robin.typ с текущего каталога на текущем диске в существующий каталог Birds на диске C, введите следующую команду:

copy robin.typ c:\birds

Если каталог Birds не существует, файл Robin.typ будет скопирован в файл с именем Birds в корневой каталог диска C.

Чтобы скопировать несколько файлов в один, перечислите несколько файлов в параметре источник, разделяя их имена значком плюс (+), и укажите в параметре назначение файл, который должен содержать результат объединения этих файлов. Например, чтобы объединить файлы Mar89.rpt, Apr89.rpt и May89.rpt из текущего каталога на текущем диске и поместить их в файл Report в текущем каталоге на текущем диске, введите следующую команду:

copy mar89.rpt + apr89.rpt + may89.rpt report

При объединении команда copy создает конечный файл с текущими датой и временем. Если параметр назначение не указан, файлы объединяются и сохраняются в файле с именем первого файла в списке. Например, чтобы объединить четыре файла в файле Report, если такой файл уже существует, введите следующую команду:

copy report + mar89.rpt + apr89.rpt + may89.rpt

Кроме того, несколько файлов можно объединить в один с помощью символов подстановки (* или ?). Например, чтобы объединить все файлы с расширением .txt в текущем каталоге на текущем диске в файл Combin.doc, введите следующую команду:

copy *.txt combin.doc

Если требуется объединить несколько двоичных файлов в один с использованием подстановочных знаков, воспользуйтесь параметром /b. В результате CTRL+Z не будет рассматриваться как символ конца файла в Windows XP. Например, введите следующую команду:

copy /b *.exe combin.exe

Внимание!

  • Если объединяются двоичные файлы, результат может оказаться непригодным из-за нарушения внутреннего форматирования.

В следующем примере команда copy объединяет каждый файл с расширением .txt с соответствующим ему файлом с расширением .ref. Результатом является файл с тем же именем, но с расширением .doc. Таким образом, команда copy объединит файлы File1.txt и File1.ref в файл File1.doc, затем файлы File2.txt и File2.ref в файл File2.doc и т. д. Например, введите следующую команду:

copy *.txt + *.ref *.doc

Чтобы объединить сначала все файлы с расширением .txt, а затем все файлы с расширением .ref в файл Combin.doc, введите следующую команду:

copy *.txt + *.ref combin.doc


Country

Задание использования подсистемой MS-DOS международного формата для времени, дат, валют, разделителей и преобразования символов.

Синтаксис

country=xxx[,[yyy][,[диск:][путь] имя_файла]]

Параметры

xxx
Задание кода страны.
yyy
Задание кодовой страницы для данного кода страны.
[диск:][путь] имя_файла
Задание местонахождения и имени файла, содержащего информацию о национальных форматах.
/?
Отображение справки в командной строке.

Примечания

  • Команда country обеспечивает распознавание подсистемой MS-DOS набора символов и соглашения о пунктуации при использовании одного из поддерживаемых национальных языков. Используйте файл %системный_корневой_каталог%\System32\Config.nt или эквивалентный файл запуска, указанный в PIF-файле программы, для загрузки настройки Код страны.
  • Установка поддерживаемых языков

    В следующей таблице перечислены страны и языки, поддерживаемые подсистемой MS-DOS. В ней также перечислены кодовые страницы, которые могут быть использованы с этими кодами стран. Например, если используется код страны 003, при задании параметра yyy можно использовать только кодовые страницы 437 или 850. Первая из двух кодовых страниц, перечисленных для каждой страны/региона или языка, является кодовой страницей, используемой по умолчанию.

    Страна/регион или язык | Код страны/региона | Кодовые страницы
    США | 001 | 437, 850
    Французский (Канада) | 002 | 863, 850
    Голландия | 031 | 850, 437
    Бельгия | 032 | 850, 437
    Франция | 033 | 850, 437
    Испания | 034 | 850, 437
    Венгрия | 036 | 852, 850
    Италия | 039 | 850, 437
    Швейцария | 041 | 850, 437
    Чешская республика | 042 | 852, 850
    Словакия | 042 | 852, 850
    Великобритания | 044 | 437, 850
    Дания | 045 | 850, 865
    Швеция | 046 | 850, 437
    Норвегия | 047 | 850, 865
    Польша | 048 | 852, 850
    Германия | 049 | 850, 437
    Бразилия | 055 | 850, 437
    Международный английский | 061 | 437, 850
    Португалия | 351 | 850, 860
    Финляндия | 358 | 850, 437
  • Задание национального формата для времени и даты

    Код страны задает формат времени и даты, используемый в следующих командах: backup, date и time.

    В следующей таблице перечислены форматы даты и времени для каждого кода страны. Для каждого кода страны в соответствующих колонках представлена дата 3 января 1994г. и время 17 часов 35 минут (0 секунд и 0 сотых секунды).

    Страна/регион или язык | Код страны/региона | Формат даты | Формат времени
    США | 001 | 01/03/1994 | 5:35:00.00p
    Французский (Канада) | 002 | 1994-01-03 | 17:35:00
    Латинская Америка | 003 | 03/01/1994 | 5:35:00.00p
    Голландия | 031 | 03-01-94 | 17:35:00
    Бельгия | 032 | 03/01/94 | 17:35:00
    Франция | 033 | 03.01.1994 | 17:35:00
    Испания | 034 | 3/01/94 | 17:35:00
    Венгрия | 036 | 1994.01.03 | 17:35:00
    Италия | 039 | 03/01/94 | 17.35.00
    Швейцария | 041 | 03.01.94 | 17 35.00
    Чешская республика | 042 | 03.01.1994 | 17:35:00
    Словакия | 042 | 03.01.1994 | 17:35:00
    Великобритания | 044 | 03/01/94 | 17:35:00.00
    Дания | 045 | 03-01-94 | 17.35.00
    Швеция | 046 | 1994-01-03 | 17.35.00
    Норвегия | 047 | 03.01.94 | 17:35:00
    Польша | 048 | 1994-01-03 | 17:35:00
    Германия | 049 | 03.01.1994 | 17:35:00
    Бразилия | 055 | 03/01/94 | 17:35:00
    Международный английский | 061 | 03/01/1994 | 17:35:00.00
    Португалия | 351 | 03-01-1994 | 17:35:00
    Финляндия | 358 | 3.1.1994 | 17.35.00

Примеры

Чтобы преобразования валюты, времени, даты и символов в соответствии с французским национальным форматом, добавьте следующую команду в файл Config.nt:

country=033

Чтобы задать кодовую страницу вместе с кодом страны для Франции, введите следующую команду:

country=033,850

Если кодовая страница не задана, но введен параметр [диск:][путь] имя_файла, необходимо ввести запятую, предваряющую кодовую страницу, как показано в примере:

country=033,,c:\winnt\system32\country.sys


Сервер сценариев для командной строки (CScript.exe)

Использование сервера сценариев для командной строки (CScript.exe)

Программа Cscript.exe является интерфейсом командной строки сервера сценариев, который позволяет указать параметры для настройки свойств сценария.

С помощью программы Cscript.exe можно запустить сценарий, введя имя его файла в командной строке. Как Microsoft Internet Explorer сервер сценариев Windows служит контроллером средств обработки сценариев Windows, однако для его работы требуется очень небольшой объем памяти. Сервер сценариев Windows оптимально подходит как для интерактивных, так и для пакетных сценариев, таких как сценарий входа в систему и сценарий администрирования.

Сервер сценариев Windows поддерживает сценарии, написанные в редакторах VBScript и Jscript. При запуске сценария с рабочего стола или из командной строки сервер сценария считывает и передает содержимое указанного файла в зарегистрированный обработчик сценариев. Расширения файлов (.vbs для VBScript и .js для JScript) используются в обработчике сценариев для определения языка сценария. Благодаря этому, разработчик сценария не обязан знать точный программный идентификатор (ProgID) обработчика сценариев. Сопоставление расширения имени файла сценария с программным идентификатором и запуск конкретного обработчика сценариев осуществляется сервером сценариев Windows XP.


path

Устанавливает путь поиска в переменной среды PATH, которая является набором каталогов, используемых для поиска исполняемых файлов. Вызванная без параметров, команда path выводит текущий путь поиска.

Синтаксис

path [[%path%] [диск:]путь [;...]]

Параметры

[диск:]путь
Задает диск и каталог для установки пути поиска.
;
Разделяет каталоги в пути поиска.
%path%
Задает Windows XP для добавления пути поиска к уже существующему в списке переменной среды PATH набору каталогов.
/?
Выводит справку в командной строке.

Примечания

  • Использование значения ;

    Если ; используется в качестве самостоятельного параметра, то происходит удаление существующего пути поиска, найденного в переменной PATH.

  • Использование %path%

    Если параметр %path% включен в синтаксис, то командный интерпретатор Cmd.exe заменяет его на значение пути поиска, найденное в переменной PATH, устраняя тем самым необходимость ручного ввода этих значений в командной строке.

  • Текущий каталог

    Операционная система всегда начинает поиск с текущего каталога, а затем продолжает его в каталогах, заданных в пути поиска.

  • Файлы с одинаковыми именами и разными расширениями

    В некоторых случаях в одном каталоге могут содержаться файлы с одинаковыми именами, но с разными расширениями. Например, файл Accnt.com, запускающий бухгалтерскую программу, и файл Accnt.bat, выполняющий подключение к бухгалтерской сети.

    Поиск файлов происходит с учетом их расширений в следующем порядке:.exe, .com, .bat и .cmd. Чтобы запустить файл Accnt.bat (при наличии в том же каталоге файла Accnt.com), необходимо в командной строке указать его расширение (.bat).

  • Два или более одинаковых имен файлов в пути поиска

    Если в пути поиска указаны два или более файлов с одинаковыми именами и расширением, то Windows XP сначала осуществляет поиск указанного имени в текущем каталоге, а затем уже в каталогах пути поиска в том же порядке, в котором они перечислены в PATH.

  • Поиск подсистемы MS-DOS

    Если команда path включена в файл Autoexec.nt, то при каждом входе в систему она будет автоматически добавлять заданный путь поиска подсистемы MS-DOS к пути поиска Windows XP. Интерпретатор команд Cmd.exe не использует файл Autoexec.nt. При запуске из ярлыка Cmd.exe наследует набор переменных среды из My Computer/Properties/Advanced/Environment.

Примеры

Приведенная ниже команда задает использование Windows XP для поиска трех каталогов для нахождения внешних команд. Пути для этих трех каталогов следующие: C:\User\Taxes, B:\User\Invest и B:\Bin:

path c:\user\taxes;b:\user\invest;b:\bin


Pathping

Предоставляет информацию о латентности сети и потерях данных на промежуточных узлах между исходным пунктом и пунктом назначения. Команда Pathping в течение некоторого периода времени отправляет многочисленные сообщения с эхо-запросом каждому маршрутизатору, находящемуся между исходным пунктом и пунктом назначения, а затем на основании пакетов, полученных от каждого из них, вычисляет результаты. Поскольку pathping показывает коэффициент потери пакетов для каждого маршрутизатора или связи, можно определить маршрутизаторы или субсети, имеющие проблемы с сетью. Команда Pathping выполняет эквивалентное команде tracert действие, идентифицируя маршрутизаторы, находящиеся на пути. Затем она периодически в течение заданного времени обменивается пакетами со всеми маршрутизаторами и на основании числа пакетов, полученных от каждого из них, обрабатывает статистику. Запущенная без параметров, команда pathping выводит справку.

Синтаксис

pathping [-n] [-h максимальное_число_переходов] [-g список_узлов] [-p период] [-q число_запросов [-w интервал] [-T] [-R] [имя_конечного_компьютера]

Параметры

-n
Предотвращает попытки команды pathping сопоставить IP-адреса промежуточных маршутизаторов с их именами. Это позволяет ускорить вывод результатов команды pathping.
-h максимальное_число_переходов
Задает максимальное количество переходов на пути при поиске конечного пункта назначения. Значение по умолчанию равно 30.
-g список_узлов
Указывает для сообщений с эхо-запросом использование параметра свободной маршрутизации в IP-заголовке с набором промежуточных мест назначения, указанным в списке_компьютеров. При свободной маршрутизации последовательные промежуточные места назначения могут быть разделены одним или несколькими маршрутизаторами. Максимальное число адресов или имен в списке равно 9. Список_адресов представляет собой набор IP-адресов (в точечно-десятичной нотации), разделенных пробелами.
-p период
Задает время ожидания между последовательными проверками связи (в миллисекундах). Значение по умолчанию равно 250 миллисекунд (1/4 секунды).
-q число_запросов
Задает количество сообщений с эхо-запросом, отправленных каждому маршрутизатору пути. По умолчанию — 100.
-w интервал
Задает время ожидания каждого отклика (в миллисекундах). Значение по умолчанию равно 3000 миллисекунд (3 секунды).
-T
Присоединяет тег приоритета уровня 2 (например 802.1p) к сообщениям с эхо-запросом, отправляемым каждому сетевому устройству на маршруте. Это помогает обнаружить сетевые устройства, для которых не настроен приоритет уровня 2. Он предназначен для проверки соединений, использующих спецификации QoS.
-R
Проверяет, все ли сетевые устройства вдоль маршрута поддерживают протокол RSVP (Resource Reservation Setup Protocol, протокол настройки резервирования ресурсов), который позволяет главному компьютеру резервировать определенную часть пропускной способности для потока данных. Этот параметр предназначен для проверки соединений, использующих спецификации QoS.
имя_конечного_компьютера
Задает пунтк назначения, идентифицированный IP-адресом или именем узла.
/?
Отображает справку в командной строке.

Примечания

  • Параметры команды Pathping вводятся с учетом регистра.
  • Во избежание перегрузки сети пакеты должны передаваться через довольно большие интервалы времени.
  • Чтобы минимизировать эффект потери пакетов, не нужно слишком часто выполнять проверку связи.
  • При использовании параметра -p пакеты для проверки связи отсылаются каждому промежуточному узлу отдельно. Поэтому интервал времени между двумя пакетами, переданными одному узлу, составляет (период) x (число узлов).
  • С помощью параметра -w пакеты можно отправлять одновременно. Поэтому промежуток времени, указанный в параметре интервал, не ограничен промежутком времени, указанным в параметре период.
  • Использование параметра -T

    • Включение приоритета уровня 2 на узловом компьютере позволяет передавать пакеты с тегом приоритета уровня 2, который используется устройствами уровня 2 для назначения пакету приоритета. Устройства старого типа, которые не распознают приоритет уровня 2, будут отвергать пакеты с тегами, так как они будут выглядеть неправильно сформированными. Данный параметр помогает определить компьютер сети, который отвергает эти пакеты.

  • Использование параметра -R

    • Каждому сетевому устройству на маршруте передается сообщение резервирования RSVP для несуществующего сеанса. Если устройство не настроено на поддержку протокола RSVP, оно возвращает сообщение о недоступности протокола ICMP. Если устройство поддерживает протокол RSVP, оно возвращает ошибку резервирования. Некоторые устройства не могут возвращать ни одно из этих сообщений. В этом случае выводится сообщение о таймауте.

  • Эта команда доступна только если в свойствах сетевого адаптера в объекте Сетевые подключения в качестве компонента установлен протокол Интернета (TCP/IP).

Примеры

Приведенный ниже пример содержит результаты работы команды pathping:

D:\>pathping -n corp1

Трассировка маршрута к corp1 [10.54.1.196]
с максимальным числом прыжков 30:
  0  172.16.87.35
  1  172.16.87.218
  2  192.168.52.1
  3  192.168.80.1
  4  10.54.247.14
  5  10.54.1.196

Подсчет статистики за: 125 сек. ...
            Исходный узел   Маршрутный узел
Hop  RTT    Утер./Отпр.      Утер./Отпр.     Адрес
  0                                           172.16.87.35
                                0/ 100 =  0%   |
  1   41мс     0/ 100 =  0%     0/ 100 =  0%  172.16.87.218
                               13/ 100 = 13%   |
  2   22мс    16/ 100 = 16%     3/ 100 =  3%  192.68.52.1
                                0/ 100 =  0%   |
  3   24мс    13/ 100 = 13%     0/ 100 =  0%  192.68.80.1
                                0/ 100 =  0%   |
  4   21мс    14/ 100 = 14%     1/ 100 =  1%  10.54.247.14
                                0/ 100 =  0%   |
  5   24мс    13/ 100 = 13%     0/ 100 =  0%  10.540.10.196

Трассировка завершена.

После запуска pathping сначала выводится путь. Это тот же путь, который выводится командой tracert. Далее в течение 90 секунд команда выдает сообщение о том, что она занята (это время варьируется в зависимости от числа переходов). В течение этого времени происходит сбор сведений со всех маршрутизаторов, перечисленных выше, и со всех соединений между ними. По завершении этого периода выводятся результаты проверки.

В примере отчета, приведенном выше, столбцы This Node/Link, Lost/Sent = Pct и Address показывают, что при переходе от адреса 172.16.87.218 к 192.168.52.1 теряется 13 процентов пакетов. Маршрутизаторы в узлах 2 и 4 также пропускают пакеты, адресованные им, но эти потери не оказывают влияние на их способность пересылать пакеты, которые им не адресованы.

Оценки потерь для соединений (задаваемых вертикальной чертой | в столбце Address) показывают перегрузку, вызывающую потерю пакетов, пересылаемых по маршруту. Степень потерь пакетов на маршрутизаторах (в правом столбце таких строк указан IP-адрес маршрутизатора) показывает, что процессоры этих маршрутизаторов перегружены.


Pause

Приостанавливает выполнение пакетной программы с выводом сообщения об ожидании нажатия пользователем любой клавиши.

Синтаксис

pause

Параметры

/?
Отображает справку в командной строке.

Примечания

  • При запуске команды prompt выводится следующее сообщение:

    Для продолжения нажмите любую клавишу . . .

  • Если при работе пакетной программы была нажата комбинация CTRL+C для ее остановки, то на экран будет выведено следующее сообщение:

    Завершить выполнение пакетного файла [Y(да)/N(нет)]?

    Если была нажата клавиша Y (подтверждение), пакетная программа будет закончена и управление вернется операционной системе. По этой причине команда pause может быть вставлена перед разделом пакетного файла, который потребуется пропустить. Команда pause приостанавливает выполнение пакетной программы, аналогичное действие можно сделать, нажав комбинацию CTRL+C и Y.

Примеры

Для создания пакетной программы запроса пользователю о необходимости заменить диск в одном из дисководов, введите:

@echo off
:begin
copy a:*.*
echo Please put a new disk into drive A
pause
goto begin

В этом примере все файлы с диска A копируются в текущий каталог. После этого на экран выводится запрос вставить другой диск в дисковод А, затем команда pause приостанавливает работу программы, чтобы пользователь мог сменить диск и нажать любую клавишу для продолжения процесса. Данная пакетная программа работает как бесконечный цикл. Команда goto BEGIN возвращает управление на начало командного файла. Для завершения работы этой пакетной программы требуется нажать комбинацию CTRL+C и Y.


Pbadmin

Администрирует телефонные книги. Команда pbadmin без параметров запускает компонент Администратор телефонной книги (PBA).

Синтаксис

pbadmin.exe /N имя_телефонной_книги [/R путь_файла_области\имя_файла_области] [/P путь_файла_данных\имя_файла_данных]

pbadmin.exe /I имя_телефонной_книги /R путь_файла_области\имя_файла_области

pbadmin.exe /I имя_телефонной_книги /P путь_файла_данных\имя_файла_данных

pbadmin.exe /O имя_телефонной_книги_имя_сервера_имя_пользователя_пароль

pbadmin.exe /B имя_телефонной_книги

Параметры

/N имя_телефонной_книги
Создает телефонную книгу (.mdb). Параметр имя_телефонной_книги задает имя создаваемого файла.
/I имя_телефонной_книги
Импортирует данные в телефонную книгу (.mdb) из файла области (.txt) или файла телефонной книги (.pbk или .txt) Параметр имя_телефонной_книги задает телефонную книгу, в которую будут импортироваться данные. Параметр /R или /P используется совместно с параметром /I.
/R путь_файла_области\имя_файла_области
Задает имя и путь файла области, который нужно импортировать в телефонную книгу.
/P путь_файла_данных\имя_файла_данных
Задает имя и местоположение файла телефонной книги (.pbk или .txt), который нужно импортировать в телефонную книгу.
/O имя_телефонной книги_имя_сервера_имя_пользователя_пароль
Настраивает параметры телефонной книги. Параметр имя_телефонной книги задает имя телефонной книги для настройки ее параметров. Параметр имя_сервера задает имя сервера, на котором будет опубликована телефонная книга. Параметр имя_пользователя задает учетную запись пользователя с разрешениями FTP на сервере с установленной службой телефонной книги (PBS). Параметр пароль задает пароль для учетной записи пользователя на сервере PBS.
/B имя_телефонной_книги
Публикует телефонную книгу Параметр имя_телефонной_книги задает имя телефонной книги для ее публикации. Перед использованиемпараметра /B требуется настроить телефонную книгу с помощью параметра /O.
/?
Отображает справку в командной строке.

Примечания

  • Для создания телефонной книги (.mdb) используйте команду:

    • pbadmin.exe /N имя_телефонной_книги [/R путь_файла_области\имя_файла_области] [/P путь_файла_данных\имя_файла_данных]

  • Для импортирования данных в телефонную книгу из файла области используйте команду:

    • pbadmin.exe /I имя_телефонной_книги /R путь_файла_области\имя_файла_области

  • Для импортирования данных в телефонную книгу из файла телефонной книги (.pbk) или отформатированного соответствующим образом текстового файла (.txt) используйте команду:

    • pbadmin.exe /I имя_телефонной_книги /P путь_файла_данных\имя_файла_данных

  • Для настройки параметров публикации для телефонной книги используйте команду:

    • pbadmin.exe /O имя_телефонной_книги_имя_сервера_имя_пользователя_пароль

  • Для публикации телефонной книги используйте команду:

    • pbadmin.exe /B имя_телефонной_книги

  • Для команды pbadmin термин «телефонная книга» означает телефонную книгу (.mdb), а термин «файл телефонной книги» означает файл телефонной книги (.pbk).
  • Параметры командной строки вводятся с учетом регистра.
  • Имя телефонной книги не должно быть более восьми символов, не может состоять только из цифр и не может содержать пробелы или любые из следующих символов: ! , ; * = / \ : ? ' " < > | . & % {} [] @ ( ) ´ ` ~
  • При задании пути необходимо задать полный путь. В путь к телефонной книге, файлу телефонной книги или файлу области нельзя вставлять пробелы.
  • Перед использованием команды pbadmin требуется установить администратор телефонной книги (PBA), а затем из каталога PBA запустить эту команду. Для установки администратора телефонной книги вставьте установочный компакт-диск Windows XP Professional или Windows 2000 в дисковод и щелкните Обзор этого компакт-диска. Последовательно откройте папки VALUEADD, MSFT, MGMT и PBA. Дважды щелкните PBAINST и следуйте инструкциям, отображаемым на экране.

Примеры

В примере, приведенном ниже, используются вымышленные данные.

Для создания телефонной книги с именем Awesome введите:

pbadmin.exe /N Awesome

Для импортирования данных в телефонную книгу с именем Awesome из файла области с именем Region1.txt, находящегося в каталоге C:\Temp, введите:

pbadmin.exe /I Awesome /R C:\Temp\Region1.txt

Для настройки параметров телефонной книги с именем Awesome, именем сервера Rainier, именем пользователя jobrown и паролем mypassword введите:

pbadmin.exe /O Awesome Rainier jobrown mypassword

Для публикации телефонной книги с именем Awesome введите:

pbadmin.exe /B Awesome


Pentnt

Обнаруживает ошибки деления с плавающей точкой процессора Pentium, отключает аппаратную обработку чисел с плавающей точкой и включает эмуляции операций с плавающей точкой.

Синтаксис

pentnt [-c] [-f] [-o]

Параметры

-c
Включает условную эмуляцию.
-f
Включает безусловную эмуляцию.
-o
Отключает безусловную эмуляцию и повторно включает аппаратную обработку (если есть).
/?
Отображает справку в командной строке.

Примечания

  • Перед параметрами данной команды должен стоять - ( дефис), а не / (косая черта).
  • Использование параметра командной строки -c

    Эмуляция включается тогда и только тогда, когда система распознает ошибку деления с плавающей точкой процессора Pentium в момент загрузки. При задании этого параметра компьютер следует перезапустить, чтобы изменения вступили в силу.

  • С помощью параметра командной строки -f аппаратная обработка чисел с плавающей запятой отключается и включается эмуляция независимо от наличия ошибки процессора Pentium. Этот параметр полезен при проверке программных эмуляторов и для работы с ошибками вычислений с плавающей точкой, известными операционной системе. При задании этого параметра компьютер следует перезапустить, чтобы изменения вступили в силу.
  • При задании параметра -o при выборе этого параметра компьютер следует перезапустить, чтобы изменения вступили в силу.


Использование пакетных параметров командной строки

Пакетные параметры командной строки используются в пакетном файле для получения информации о настройках среды.

Файл Cmd.exe разворачивает переменные с %0 по %9. При использовании пакетных параметров переменная %0 заменяется на имя пакетного файла, а переменные с %1 по %9 — на соответствующие аргументы, напечатанные в командной строке. Для доступа к переменным больше %9 запустите команду shift. Для получения дополнительных сведений о команде shift смотрите раздел Shift. Параметр %* ссылается на все аргументы, которые передаются пакетному файлу, за исключением параметра %0.

Например, для копирования содержимого из папки 1 (Folder1) в папку 2 (Folder2), где параметр %1 заменяется на значение Folder1, а параметр %2 — на значение Folder2, в пакетном файле с именем Mybatch.bat введите следующую строку:

xcopy %1\*.* %2

Для запуска файла введите:

mybatch.bat C:\folder1 D:\folder2

Результат будет таким же, как и при записи в пакетный файл строки:

xcopy C:\folder1 \*.* D:\folder2

С пакетными параметрами можно также использовать модификаторы. Модификаторы используют информацию о текущем диске и каталоге как часть или полное имя файла или каталога. Для использования модификатора напечатайте символ (%), затем символ тильды (~), а затем соответствующий модификатор (т.е., %~модификатор).

В следующей таблице описаны модификторы, используемые для расширения.

Модификатор | Описание
%~1 | расширение %1 и удаление любых кавычек ("")
%~f1 | замена %1 полным путем
%~d1 | замена %1 именем диска
%~p1 | замена %1 путем
%~n1 | замена %1 именем файла
%~x1 | замена %1 расширением имени файла
%~s1 | замена путем, содержащим только короткие имена
%~a1 | Замена %1 атрибутами файла
%~t1 | замена %1 датой и временем модификации файла
%~z1 | замена %1 размером файла
%~$PATH:1 | поиск в каталогах, перечисленных в переменной среды PATH, замена %1 полным именем первого найденного файла. Если переменная среды не определена или поиск не обнаружил файлов, модификатор выдает пустую строку.

В следующей таблице даны возможные комбинации модификаторов и квалификаторов для получения более сложных результатов.

Модификатор | Описание
%~dp1 | замена %1 именем диска и путем
%~nx1 | замена %1 именем файла и расширением
%~dp$PATH:1 | поиск в каталогах, перечисленных в переменной среды PATH, и замена %1 именем диска и путем к первому найденному файлу.
%~ftza1 | замена %1 строкой, аналогичной результату работы программы dir

Примечание

  • %1 и PATH в показанных выше примерах можно заменить на другие значения пакетных параметров.

Модификатор %* является уникальным, так как он представляет все аргументы, переданные пакетному файлу. Этот модификатор не используется в комбинации с модификатором %~. Конструкция %~ должна завершаться допустимым номером аргумента.

Нельзя манипулировать пакетными параметрами подобно переменным среды. Нельзя искать и заменять значения или контролировать подстроки. Но переменной среды можно назначить параметр, а потом уже ей манипулировать.


Popd

Изменяет текущий в каталог на каталог, сохраненный командой pushd.

Синтаксис

popd

Параметры

/?
Отображает справку в командной строке.

Примечания

  • Каждое выполнение команды pushd сохраняет один каталог. Запустив команду pushd несколько раз, можно сохранить несколько каталогов.
    Каталоги сохраняются последовательно в виртуальном стеке. Если команда pushd выполняется один раз, то каталог, в котором используется команда, помещается в стеке вниз. Если запустить команду еще раз, второй каталог помещается над первым. Этот процесс повторяется при каждом вызове команды pushd .

    Команду popd можно использовать для изменения текущего каталога на каталог, сохраненный последним командой pushd. Если используется команда popd, верхний каталог в стеке удаляется и текущий каталог заменяется на этот каталог. Если запустить команду popd еще раз, из стека будет удален следующий верхний каталог.
  • Если расширения командного процессора разрешены, то команда popd удаляет любые имена дисков, назначенные командой pushd.

Примеры

Команды pushd и popd можно использовать в пакетной программе для изменения текущего каталога, в котором она была запущена, и последующего возврата к нему. В приведенном ниже примере показано, как это сделать:

@echo off
rem Этот пакетный файл удаляет все файлы .txt в заданном каталоге
pushd %1
del *.txt
popd
cls
echo Все текстовые файлы в каталоге %1 удалены


Print

Отправляет текстовый файл на принтер.

Синтаксис

print [/d:принтер] [диск:][путь] имя_файла [ ...]

Параметры

/d:принтер
Задает имя принтера, на котором требуется напечатать файл. Можно задать локальный принтер, указав порт на компьютере, к которому подключен принтер. Допустимые значения для параллельных портов: LPT1, LPT2 и LPT3. Допустимые значения для последовательных портов: COM1, COM2, COM3 и COM4. Можно также задать сетевой принтер по его имени в сети (\\имя_сервера\имя_принтера). Если принтер не задан, то задание уйдет на печать в порт LPT1.
диск:
Задает логический и физический диск, на котором находится файл, задаваемый на печать. Этот параметр не нужен, если файл для печати находится на текущем диске.
путь
Задание местоположения файла на диске. Этот параметр не нужен, если файл для печати находится в текущем каталоге.
имя_файла [...]
Обязательный параметр. Задает имя файла, который требуется напечатать. В одном вызове команды может быть задано несколько файлов.
/?
Отображает справку в командной строке.

Примечания

  • Если задание отправлено на принтер, подключенный к последовательному или параллельному портам локального компьютера, то печать будет осуществляться в фоновом режиме.
  • Большинство программ имеет встроенные возможности печати. Для печати файлов, созданных с помощью таких программ необходимо использовать команду print.
  • С помощью команды mode можно выполнить настройки в командной строке. Дополнительные сведения о настройках для принтера, подключенного к параллельному или последовательному порту, о выводе статуса принтера или подготовке принтера к использованию кодовых страниц см. в ссылке mode.

Примеры

Для отправки на печать файла Report.txt из текущего каталога на принтер, подключенный к порту LPT2 локального компьютера, введите:

print /d:LPT2 report.txt

Для отправки файла Report.txt из каталога c:\Accounting в очередь на печать принтера Printer1 на сервере \\CopyRoom введите:

print /d:\\copyroom\printer1 c:\accounting\report.txt


Prncnfg.vbs

Настраивает или отображает параметры принтера. При вызове команды prncnfg.vbs без параметров в командной строке отображается справка по команде prncnfg.vbs.

Вывод параметров принтера

Синтаксис

cscript prncnfg.vbs -g [-s удаленный_компьютер] -p имя_принтера [-u имя_пользователя -w пароль]

Параметры

-g
Обязательный параметр. Задает вывод параметров принтера.
-s удаленный_компьютер
Задает имя удаленного компьютера, управляющего принтером, параметры которого требуется вывести на экран. Если компьютер не указан, то используется локальный компьютер.
-p имя_принтера
Обязательный параметр. Задает имя принтера, параметры которого требуется вывести на экран.
-u имя_пользователя -w пароль
Задает учетную запись с разрешениями подключаться с помощью инструментария управления Windows к компьютеру, подключенному к принтеру, параметры которого требуется вывести на экран. Все члены группы «Администраторы» имеют такие разрешения, но они могут быть даны и другим пользователям. Если учетная запись не задана, то для того, чтобы команда работала, необходимо войти в систему с учетной записью, имеющей такие разрешения.
/?
Отображает справку в командной строке.

Примечания

  • Эта команда запускает программу из каталога systemroot\system32. Она вводится в командной строке с этим каталогом, указанным в качестве текущего, или в начале команды cscript вводится полный путь к этому каталогу.
  • Если аргументы параметров команды содержат пробелы, их следует заключать в кавычки (например "имя компьютера").

Пример

Для вывода на экран параметров принтера с именем ColorPrinter_2, очередь печати которого находится на компьютере с именем HRServer,введите:

cscript prncnfg.vbs -g -s HRServer -p ColorPrinter_2

Настройка параметров принтера

Синтаксис

cscript prncnfg.vbs -t [-s удаленный_компьютер] -p имя_принтера [-u имя_пользователя -w пароль] [-r имя_порта] [-l путь] [-m комментарий] [-h имя_ресурса] [-f разделитель] [-y тип_данных] [-st время_запуска] [-ut время_завершения] [-o приоритет] [-i приоритет_по_умолчанию] [{+ | -}shared] [{+ | -}direct] [{+ | -}published] [{+ | -}hidden] [{+ | -}rawonly] [{+ | -}queued] [{+ | -}keepprintedjobs] [{+ | -}workoffline] [{+ | -}enabledevq] [{+ | -}docompletefirst][{+ | -}enablebidi]

Параметры

-t
Обязательный параметр. Задает настройку параметров принтера.
-s удаленный_компьютер
Задает имя удаленного компьютера, подключенного к принтеру, параметры которого требуется настроить. Если компьютер не указан, используется локальный компьютер.
-p имя_принтера
Обязательный параметр. Задает имя принтера, параметры которого требуется настроить.
-u имя_пользователя -w пароль
Задает учетную запись с разрешениями подключаться с помощью инструментария управления Windows к компьютеру, подключенному к принтеру, параметры которого требуется настроить. Все члены группы «Администраторы» имеют такие разрешения, но они могут быть даны и другим пользователям. Если учетная запись не задана, то для того, чтобы команда работала, необходимо войти в систему с учетной записью, имеющей такие разрешения.
-r имя_порта
Задает порт, к которому подключен принтер. Если это параллельный или последовательный порт, то используется его ID (например, LPT1 или COM1). Если это порт TCP/IP, то используется имя, заданное при добавлении порта.
-l путь
Задает местоположение принтера, например, «Копировальный зал».
-m комментарий
Задает строку комментариев.
-h имя_ресурса
Задает сетевое имя принтера.
-f разделитель
Задает файл с текстом, появляющимся на страницах-разделителях.
-y тип_данных
Задает тип данных, которые принтер может обработать. Для получения дополнительных сведений о типах данных щелкните ссылку "См. также".
-st время_запуска
Настраивает принтер на работу в режиме, ограниченном во времени. Задает время, после которого принтер будет доступен. При отправке на приостановленный принтер документ будет храниться в очереди до тех пор, пока этот принтер вновь не станет доступным. Время отображается в 24-часовом формате. Например, для задания 23:00 введите 2300.
-ut время_завершения
Настраивает принтер на работу в режиме, ограниченном во времени. Задает время, после которого принтер будет недоступен. При отправке на приостановленный принтер документ будет храниться в очереди до тех пор, пока этот принтер вновь не станет доступным. Время отображается в 24-часовом формате. Например, для задания 23:00 введите 2300.
-o приоритет
Задает приоритет отправки задания на печать. Очередь печати с высшим приоритетом получает свои задания быстрее, чем любая очередь с низшим приоритетом.
-i приоритет_по_умолчанию
Задает приоритет по умолчанию каждому заданию на печать.
{+ | -}shared
Задает общий доступ к принтеру в сети.
{+ | -}direct
Задает признак прямой отправки документа (минуя очередь) на устройство печати.
{+ | -}published
Задает публикацию принтера в службе Active Directory. Если опубликовать принтер, то другие пользователи сети смогут искать его с помощью текущего местоположения и возможностей, например, цветной печати и сшивателя.
{+ | -}hidden
Зарезервированный код.
{+ | -}rawonly
Задает постановку в очередь только тех заданий, которые содержат исходные данные.
{+ | -}queued
Задает признак начала печати документа после того, как его последняя страница окажется в очереди. Программа, отправившая документ на печать, недоступна до завершения печати. Эта задержка компенсируется тем, что документ доступен принтеру целиком.
{+ | -}keepprintedjobs
Задает признак сохранения документа в очереди после его вывода на печать. Он дает возможность повторно печатать документ прямо из очереди, а не из программы печати.
{+ | -}workoffline
Задает отправку документов в очередь на печать, если компьютер не подключен к сети.
{+ | -}enabledevq
Задает параметр, позволяющий хранить в очереди задания, установки которых не совпадают с установками принтера (например, PostScript-файлы для принтеров, не поддерживающих язык PostScript) и не печатать их.
{+ | -}docompletefirst
Задает параметр, устанавливающий, что диспетчер очереди печати должен отправить в соответствующую очередь задания с более низшим приоритетом, но уже поступившие в очередь, раньше отправки в эту же очередь заданий с более высшим приоритетом, находящихся в процессе поступления в очередь. Если этот параметр задан, а документов, закончивших поступление в очередь нет, то диспетчер очереди раньше отправит в очередь более крупные документы. Этот параметр повышает эффективность работы принтера с помощью приоритетов. Если он отключен, то диспетчер отсылает в соответствующие очереди задания с высшим приоритетом.
{+ | -}enablebidi
Задает отправку принтером диспетчеру очереди печати информации о статусе.
/?
Отображает справку в командной строке.

Примечания

  • Эта команда запускает программу из каталога systemroot\system32. Она вводится в командной строке с этим каталогом, указанным в качестве текущего, или в начале команды cscript вводится полный путь к этому каталогу.
  • Если аргументы параметров команды содержат пробелы, их следует заключать в кавычки (например "имя компьютера").

Пример

Для настройки принтера с именем ColorPrinter_2 на то, чтобы диспетчер очереди печати на удаленном компьютере с именем HRServer хранил задания после их печати, введите:

cscript prncnfg.vbs -t -s HRServer -p ColorPrinter_2 +keepprintedjobs

Изменение имени принтера

Синтаксис

cscript prncnfg.vbs -x [-s удаленный_компьютер] -p имя_принтера -z новое_имя_принтера [-u имя_польззователя -w пароль]

Параметры

-x
Обязательный параметр. Задает изменение имени принтера.
-s удаленный_компьютер
Задает имя удаленного компьютера, подключенного к принтеру, имя которого требуется изменить. Если компьютер не указан, используется локальный компьютер.
-p имя_принтера
Обязательный параметр. Задает текущее имя принтера.
-z новое_имя_принтера
Обязательный параметр. Задает новое имя принтера.
-u имя_пользователя -w пароль
Задает учетную запись с разрешениями подключаться, с помощью инструментария управления Windows к компьютеру, подключенному к принтеру, который требуется переименовать. Все члены группы «Администраторы» имеют такие разрешения, но эти разрешения могут быть даны и другим пользователям. Если учетная запись не задана, то для того, чтобы команда работала, необходимо войти в систему с учетной записью, имеющей такие разрешения.
/?
Отображает справку в командной строке.

Примечания

  • Эта команда запускает программу из каталога systemroot\system32. Она вводится в командной строке с этим каталогом, указанным в качестве текущего, или в начале команды cscript вводится полный путь к этому каталогу.
  • Если аргументы параметров команды содержат пробелы, их следует заключать в кавычки (например "имя компьютера").

Пример

Для изменения имени принтера с ColorPrinter_2 на ColorPrinter_3 на удаленном компьютере с именем HRServer введите:

cscript prncnfg.vbs -x -s HRServer -p ColorPrinter_2 -z ColorPrinter_3


Prndrvr.vbs

Добавляет, удаляет и составляет списки драйверов. При вызове команды prndrvr.vbs без параметров в командной строке отображается справка по команде prndrvr.vbs.

Установка драйвера принтера

Синтаксис

cscript prndrvr.vbs -a [-m имя_драйвера] [-v {0 | 1 | 2 | 3}] [-e среда] [-s удаленный_компьютер] [-h путь] [-i имя_файла.inf] [-u имя_пользователя -w пароль]

Параметры

-a
Обязательный параметр. Задает установку драйвера.
-m имя_драйвера
Задает имя драйвера для установки. Часто драйверам присваиваютсся имена моделей принтеров, которые они поддерживают. Более подробные сведения о драйверах можно найти в документации оборудования.
-v {0 | 1 | 2 | 3}
Задает версию драйвера для установки. Сведения об использовании версий драйверов определенными средами смотрите в описании параметра -e среда. Если версия драйвера не указана, то будет установлена версия, подходящая версии Windows, запущенной на компьютере, на котором устанавливается драйвер.
  • Версия 0 поддерживает Windows 95, Windows 98 и Windows Millennium Edition.
  • Версия 1 поддерживает Windows NT 3.51.
  • Версия 2 поддерживает Windows NT 4.0.
  • Версия 3 поддерживает Windows XP and Windows 2000.
-e среда
Задает среду для драйвера, который требуется установить. Если среда не задана, то используется среда компьютера, на котором устанавливается драйвер. В следующей таблице представлено соответствие среды и версии драйвера.
Среда | Доступные версии
"Windows NT x86" | 1, 2 и 3
"Windows NT Alpha_AXP" | 1 и 2
"Windows IA64" | 3
"Windows NT R4000" | 1
"Windows NT PowerPC" | 1
Windows 4.0 | 0
-s удаленныый_компьютер
Задает имя удаленного компьютера, на котором требуется установить драйвер. Если компьютер не указан, то драйвер устанавливается на локальном компьютере.
-h путь
Задает путь к файлу драйвера. Если путь не указан, то используется путь к местоположению, из которого была установлена Windows.
-i имя_файла.inf
Задает имя файла драйвера, который требуется установить. Если имя файла не указано, то используется ntprint.inf.
-u имя_пользователя -w пароль
Задает учетную запись с разрешениями подключаться с помощью инструментария управления Windows к компьютеру, на котором требуется установить драйвер. Все члены группы «Администраторы» имеют такие разрешения, но они могут быть даны и другим пользователям. Если учетная запись не задана, то для того, чтобы команда работала, необходимо войти в систему с учетной записью, имеющей такие разрешения.
/?
Отображает справку в командной строке.

Примечания

  • Эта команда запускает программу из каталога systemroot\system32. Она вводится в командной строке с этим каталогом, указанным в качестве текущего, или в начале команды cscript вводится полный путь к этому каталогу.
  • Если аргументы параметров команды содержат пробелы, их следует заключать в кавычки (например "имя компьютера").

Пример

Для добавления 3 версии драйвера принтера с именем "Color Printer Driver 1" к локальному компьютеру с установленной Windows NT x86 введите:

cscript prndrvr.vbs -a -m "Color Printer Driver 1" -v 3 -e "Windows NT x86"

Удаление драйвера принтера

Синтаксис

cscript prndrvr.vbs -d [-s удаленный_компьютер] -m имя_драйвера -v {0 | 1 | 2 | 3} -e среда

[-u UserName -w пароль]

Параметры

-d
Обязательный параметр. Задает удаление драйвера.
-s удаленный_компьютерr
Задает имя удаленного компьютера, на котором требуется удалить драйвер. Если компьютер не указан, то драйвер удаляется на локальном компьютере.
-m имя_драйвера
Обязательный параметр. Задает имя драйвера для удаления. Часто драйверам присваиваются имена моделей принтеров, которые они поддерживают. Более подробные сведения о драйверах можно найти в документации оборудования.
-v {0 | 1 | 2 | 3}
Обязательный параметр. Указывает версию драйвера, который требуется удалить. Сведения об использовании версий драйверов определенными системами смотрите в описании параметра -e среда.
  • Версия 0 поддерживает Windows 95, Windows 98 и Windows Millennium Edition.
  • Версия 1 поддерживает Windows NT 3.51.
  • Версия 2 поддерживает Windows NT 4.0.
  • Версия 3 поддерживает Windows XP and Windows 2000.
-e среда
Обязательный параметр. Задает среду для драйвера, который требуется удалить. В следующей таблице представлено соответствие среды и версии драйвера.
Среда | Доступные версии
"Windows NT x86" | 1, 2 и 3
"Windows NT Alpha_AXP" | 1 и 2
"Windows IA64" | 3
"Windows NT R4000" | 1
"Windows NT PowerPC" | 1
"Windows 4.0" | 0
-u имя_пользователя -w пароль
Задает учетную запись с разрешениями подключаться с помощью инструментария управления Windows к компьютеру, на котором требуется удалить драйвер. Все члены группы «Администраторы» имеют такие разрешения, но они могут быть даны и другим пользователям. Если учетная запись не задана, то для того, чтобы команда работала, необходимо войти в систему с учетной записью, имеющей такие разрешения.
/?
Отображает справку в командной строке.

Примечания

  • Эта команда запускает программу из каталога systemroot\system32. Она вводится в командной строке с этим каталогом, указанным в качестве текущего, или в начале команды cscript вводится полный путь к этому каталогу.
  • При удалении драйвера принтера необходимо включить и среду, и параметры версии.
  • Если аргументы параметров команды содержат пробелы, их следует заключать в кавычки (например "имя компьютера").

Составление списка драйверов принтера на компьютере

Синтаксис

cscript prndrvr.vbs -l [-s удаленный_компьютер] [-u имя_пользователя -w пароль]

Параметры

-l
Обязательный параметр. Задает составление списка всех драйверов на удаленном компьютере.
-s удаленный_компьюте
Указывает удаленный компьютер, драйверы которого требуется внести в список. Если компьютер не указан, то в список заносятся драйверы локального компьютера.
-u имя_пользователя -w пароль
Задает учетную запись с разрешениями подключаться с помощью инструментария управления Windows к компьютеру, на котором требуется составить список драйверов. Все члены группы «Администраторы» имеют такие разрешения, но они могут быть даны и другим пользователям. Если учетная запись не задана, то для того, чтобы команда работала, необходимо войти в систему с учетной записью, имеющей такие разрешения.
/?
Отображает справку в командной строке.

Примечания

  • Эта команда запускает программу из каталога systemroot\system32. Она вводится в командной строке с этим каталогом, указанным в качестве текущего, или в начале команды cscript вводится полный путь к этому каталогу.
  • Если аргументы параметров команды содержат пробелы, их следует заключать в кавычки (например "имя компьютера").

Удаление всех неиспользуемых драйверов принтера из компьютера

Синтаксис

cscript prndrvr.vbs -l [-s удаленный_компьютер] [-u имя_пользователя -w пароль]

Параметры

-x
Обязательный параметр. Задает удаление списка всех неиспользуемых драйверов принтера на компьютере.
-s удаленный_компьютер
Задает имя удаленного компьютера, на котором требуется удалить драйверы. Если компьютер не указан, то драйверы удаляются на локальном компьютере.
-u имя_пользователя -w пароль
Задает учетную запись с разрешениями подключаться с помощью инструментария управления Windows к компьютеру, на котором требуется удалить драйверы. Все члены группы «Администраторы» имеют такие разрешения, но они могут быть даны и другим пользователям. Если учетная запись не задана, то для того, чтобы команда работала, необходимо войти в систему с учетной записью, имеющей такие разрешения.
/?
Отображает справку в командной строке.

Примечания

  • Эта команда запускает программу из каталога systemroot\system32. Она вводится в командной строке с этим каталогом, указанным в качестве текущего, или в начале команды cscript вводится полный путь к этому каталогу.
  • Если аргументы параметров команды содержат пробелы, их следует заключать в кавычки (например "имя компьютера").


Prnjobs.vbs

Приостанавливает, возобновляет, отменяет и перечисляет задания печати. При вызове команды prnjobs.vbs без параметров в командной строке отображается справка о команде prnjobs.vbs.

Приостановка выполнения задания

Синтаксис

cscript prnjobs -z [-s удаленный_компьютер] -p имя_принтера -j номер_задания [-u имя_пользователя -w пароль]

Параметры

-z
Обязательный параметр. Задает приостановку печати задания.
-s удаленный_компьютер
Задает имя компьютера, на который было отослано задание, которое требуется приостановить. Если компьютер не указан, используется локальный компьютер.
-p имя_принтера
Обязательный параметр. Задает имя принтера, на котором будет распечатано задание, которое требуется приостановить.
-j номер_задания
Обязательный параметр. Задает ID-номер задания, печать которого требуется приостановить.
-u имя_пользователя -w пароль
Задает учетную запись с разрешениями подключаться с помощью инструментария управления Windows к компьютеру, на который отослано задание, печать которого требуется приостановить. Все члены группы «Администраторы» имеют такие разрешения, но они могут быть даны и другим пользователям. Если учетная запись не задана, то для того, чтобы команда работала, необходимо войти в систему с учетной записью, имеющей такие разрешения.
/?
Отображает справку в командной строке.

Примечания

  • Эта команда запускает программу из каталога systemroot\system32. Она вводится в командной строке с этим каталогом, указанным в качестве текущего, или в начале команды cscript вводится полный путь к этому каталогу.
  • Для вывода списка заданий и их ID-номеров эта команда вводится с параметром -l.
  • Если аргументы параметров команды содержат пробелы, их следует заключать в кавычки (например "имя компьютера").

Пример

Для приостановки печати задания с ID, равным 27, посланного на печать на удаленный компьютер с именем HRServer для печати на принтере с именем ColorPrinter введите:

cscript prnjobs.vbs -z -s HRServer -p ColorPrinter -j 27

Возобновление печати задания

Синтаксис

cscript prnjobs -m [-s удаленный_компьютер] -p имя_принтера -j номер_задания [-u имя_пользователя -w пароль]

Параметры

-m
Обязательный параметр. Задает возобновление печати приостановленного задания.
-s удаленный_компьютер
Задает имя удаленного компьютера, на который было отослано задание, печать которого требуется возобновить. Если компьютер не указан, используется локальный компьютер.
-p имя_принтера
Обязательный параметр. Задает имя принтера, на котором будет распечатано задание, печать которого требуется возобновить.
-j номер_задания
Обязательный параметр. Задает ID-номер задания, печать которого требуется возобновить.
-u имя_пользователя -w пароль
Задает учетную запись с разрешениями подключаться с помощью инструментария управления Windows к компьютеру, на который отослано задание, печать которого требуется возобновить. Все члены группы «Администраторы» имеют такие разрешения, но они могут быть даны и другим пользователям. Если учетная запись не задана, то для того, чтобы команда работала, необходимо войти в систему с учетной записью, имеющей такие разрешения.
/?
Отображает справку в командной строке.

Примечания

  • Эта команда запускает программу из каталога systemroot\system32. Она вводится в командной строке с этим каталогом, указанным в качестве текущего, или в начале команды cscript вводится полный путь к этому каталогу.
  • Для вывода списка заданий и их ID-номеров эта команда вводится с параметром -l.
  • Если аргументы параметров команды содержат пробелы, их следует заключать в кавычки (например "имя компьютера").

Отмена печати задания

Синтаксис

cscript prnjobs -x [-s удаленный_компьютер] -p имя_принтера -j номер_задания [-u имя_пользователя -w пароль]

Параметры

-x
Обязательный параметр. Задает отмену печати задания.
-s удаленный_компьютер
Задает имя удаленного компьютера, на который было отослано задание, печать которого требуется отменить. Если компьютер не указан, используется локальный компьютер.
-p имя_принтера
Обязательный параметр. Задает имя принтера, печать задания на котором требуется отменить.
-j номер_задания
Обязательный параметр. Задание ID-номера задания, печать которого требуется отменить.
-u имя_пользователя -w пароль
Задает учетную запись с разрешениями подключаться с помощью инструментария управления Windows к компьютеру, на который отослано задание, печать которого требуется отменить. Все члены группы «Администраторы» имеют такие разрешения, но они могут быть даны и другим пользователям. Если учетная запись не задана, то для того, чтобы команда работала, необходимо войти в систему с учетной записью, имеющей такие разрешения.
/?
Отображает справку в командной строке.

Примечания

  • Эта команда запускает программу из каталога systemroot\system32. Она вводится в командной строке с этим каталогом, указанным в качестве текущего, или в начале команды cscript вводится полный путь к этому каталогу.
  • Для вывода списка заданий и их ID-номеров эта команда вводится с параметром -l.
  • Если аргументы параметров команды содержат пробелы, их следует заключать в кавычки (например "имя компьютера").

Составление список заданий печати в очереди принтера

Синтаксис

cscript prnjobs -l [-s удаленный_компьютер] [-p имя_принтера] [-u имя_пользователя -w пароль]

Параметры

-l
Обязательный параметр. Задает составление списка всех заданий печати в очереди принтера.
-s удаленный_компьютер
Задает имя компьютера, на котором находится очередь печати, список которой требуется составить. Если компьютер не указан, используется локальный компьютер.
-p имя_принтера
Задает имя принтера, очередь на печать которого содержит задания для составления списка. Если не задать принтер, то в список будут внесены все задания из всех очередей печати.
-u имя_пользователя -w пароль
Задает учетную запись с разрешениями подключаться с помощью инструментария управления Windows к компьютеру, на котором находится очередь печати, список заданий печати которой требуется составить. Все члены группы «Администраторы» имеют такие разрешения, но они могут быть даны и другим пользователям. Если учетная запись не задана, то для того, чтобы команда работала, необходимо войти в систему с учетной записью, имеющей такие разрешения.
/?
Отображает справку в командной строке.

Примечания

  • Эта команда запускает программу из каталога systemroot\system32. Она вводится в командной строке с этим каталогом, указанным в качестве текущего, или в начале команды cscript вводится полный путь к этому каталогу.
  • Для вывода списка заданий и их ID-номеров эта команда вводится с параметром -l.
  • Если аргументы параметров команды содержат пробелы, их следует заключать в кавычки (например "имя компьютера").

Пример

Для составления списка заданий печати из очереди локального принтера с именем ColorPrinter_2 введите:

cscript prnjobs.vbs -l -p ColorPrinter_2


Prnmngr.vbs

Добавляет, удаляет и составляет список принтеров или подключений принтеров в дополнение к настройкам и выводу принтера, заданного по умолчанию. При выводе команды prnmngr.vbs без параметров в командной строке отображается справка по команде prnmngr.vbs.

Добавление локального принтера

Синтаксис

cscript prnmngr.vbs -a -p имя_принтера [-s удаленный_компьютер] -m имя_драйвера -r имя_порта [-u имя_пользователя -w пароль]

Параметры

-a
Обязательный параметр. Задает добавление локального принтера.
-s удаленный_компьютер
Задает имя удаленного компьютера, к которому требуется добавить локальный принтер. Если компьютер не указан, используется локальный компьютер.
-p имя_принтера
Обязательный параметр. Задает имя локального принтера, который требуется добавить.
-m имя_драйвера
Обязательный параметр. Задает имя драйвера для локального принтера, который требуется добавить. Обычно драйверы имеют имена моделей принтеров, которые они поддерживают. Более подробные сведения о драйверах можно найти в документации оборудования.
-r имя_порта
Обязательный параметр. Задает порт, к которому подключен принтер. Если это параллельный или последовательный порт, то используется его ID (например, LPT1 или COM1). Если это порт TCP/IP, то — имя, заданное при добавлении порта.
-u имя_пользователя -w пароль
Задает учетную запись с разрешениями подключаться с помощью инструментария управления Windows к компьютеру, к которому требуется добавить принтер. Все члены группы «Администраторы» имеют такие разрешения, но они могут быть даны и другим пользователям. Если учетная запись не задана, то для того, чтобы команда работала, необходимо войти в систему с учетной записью, имеющей такие разрешения.
/?
Отображает справку в командной строке.

Примечания

  • Эта команда запускает программу из каталога systemroot\system32. Она вводится в командной строке с этим каталогом, указанным в качестве текущего, или в начале команды cscript вводится полный путь к этому каталогу.
  • Если аргументы параметров команды содержат пробелы, их следует заключать в кавычки (например "имя компьютера").

Пример

Для добавления принтера с именем ColorPrinter_2, подключенного к порту LPT1 локального компьютера и для которого нужен драйвер с именем Color Printer Driver1, введите:

cscript prnmngr.vbs -a -p ColorPrinter_2 -m "Color Printer Driver1" -r lpt1:

Добавление подключений принтера

Синтаксис

cscript prnmngr.vbs -ac -p имя_принтера

Параметры

-ac
Обязательный параметр. Задает добавление подключения принтера.
-p имя_принтера
Обязательный параметр. Заданет имя принтера, для которого требуется добавить подключение.
/?
Отображает справку в командной строке.

Примечания

  • Эта команда запускает программу из каталога systemroot\system32. Она вводится в командной строке с этим каталогом, указанным в качестве текущего, или в начале команды cscript вводится полный путь к этому каталогу.
  • Если аргументы параметров команды содержат пробелы, их следует заключать в кавычки (например "имя компьютера").

Удаление принтера

Синтаксис

cscript prnmngr.vbs -d -p имя_принтера [-u имя_пользователя -w пароль] [-s удаленный_компьютер]

Параметры

-d
Обязательный параметр. Задает принтер для удаления.
-p имя_принтера
Обязательный параметр. Задает имя принтера для удаления.
-u имя_пользователя -w пароль
Задает учетную запись с разрешениями подключаться с помощью инструментария управления Windows к компьютеру, на котором требуется удалить принтер. Все члены группы «Администраторы» имеют такие разрешения, но они могут быть даны и другим пользователям. Если учетная запись не задана, то для того, чтобы команда работала, необходимо войти в систему с учетной записью, имеющей такие разрешения.
-s удаленный_компьютер
Задает имя удаленного компьютера, к которому требуется добавить локальный принтер. Если компьютер не указан, принтер добавляется к локальному компьютеру.
/?
Отображает справку в командной строке.

Примечания

  • Эта команда запускает программу из каталога systemroot\system32. Она вводится в командной строке с этим каталогом, указанным в качестве текущего, или в начале команды cscript вводится полный путь к этому каталогу.
  • Если аргументы параметров команды содержат пробелы, их следует заключать в кавычки (например "имя компьютера").

Пример

Для удаления принтера с именем ColorPrinter_2 с удаленного компьютера с именем HRServer введите:

cscript prnmngr.vbs -d -s HRServer -p ColorPrinter_2

Удаление всех принтеров из компьютера

Синтаксис

cscript prnmngr.vbs -x [-s удаленный_компьютер] [-u имя_пользователя] [-w пароль]

Параметры

-x
Обязательный параметр. Задает удаление всех принтеров на компьютере.
-s удаленный_компьютер
Задает имя удаленного компьютера, из которого требуется удалить все принтеры. Если компьютер не указан, то все принтеры будут удалены на локальном компьютере.
-u имя_пользователя -w пароль
Задает учетную запись с разрешениями подключаться с помощью инструментария управления Windows к компьютеру, на котором требуется удалить все принтеры. Все члены группы «Администраторы» имеют такие разрешения, но они могут быть даны и другим пользователям. Если учетная запись не задана, то для того, чтобы команда работала, необходимо войти в систему с учетной записью, имеющей такие разрешения.
/?
Отображает справку в командной строке.

Примечания

  • Эта команда запускает программу из каталога systemroot\system32. Она вводится в командной строке с этим каталогом, указанным в качестве текущего, или в начале команды cscript вводится полный путь к этому каталогу.
  • Если аргументы параметров команды содержат пробелы, их следует заключать в кавычки (например "имя компьютера").

Вывод принтера, используемого по умолчанию

Синтаксис

cscript prnmngr.vbs -g

Параметры

-g
Обязательный параметр. Задает вывод принтера, используемого по умолчанию.
/?
Отображает справку в командной строке.

Примечания

  • Эта команда запускает программу из каталога systemroot\system32. Она вволдится в командной строке с этим каталогом, указанным в качестве текущего, или в начале команды cscript вводится полный путь к этому каталогу.
  • Если аргументы параметров команды содержат пробелы, их следует заключать в кавычки (например "имя компьютера").

Установка принтера, используемого по умолчанию

Синтаксис

cscript prnmngr.vbs -t -p имя_принтера

Параметры

-t
Обязательный параметр. Задает принтер, используемый по умолчанию.
-p имя_принтера
Обязательный параметр. Задает имя принтера для установки его использования по умолчанию.
/?
Отображает справку в командной строке.

Примечания

  • Эта команда запускает программу из каталога systemroot\system32. Она вводится в командной строке с этим каталогом, указанным в качестве текущего, или в начале команды cscript вводится полный путь к этому каталогу.
  • Если аргументы параметров команды содержат пробелы, их следует заключать в кавычки (например "имя компьютера").

Составление списка всех принтеров для компьютера

Синтаксис

cscript prnmngr.vbs -l [-s удаленный_компьютер] [-u имя_пользователя -w пароль]

Параметры

-l
Обязательный параметр. Задает составление списка всех принтеров для компьютера.
-s удаленный_компьютер
Задает имя удаленного компьютера, из которого требуется удалить все принтеры. Если компьютер не указан, список принтеров добавляется к локальному компьютеру.
-u имя_пользователя -w пароль
Задает учетную запись с разрешениями подключаться с помощью инструментария управления Windows к компьютеру, для которого требуется составить список принтеров. Все члены группы «Администраторы» имеют такие разрешения, но они могут быть даны и другим пользователям. Если учетная запись не задана, то для того, чтобы команда работала, необходимо войти в систему с учетной записью, имеющей такие разрешения.
/?
Отображает справку в командной строке.

Примечания

  • Эта команда запускает программу из каталога systemroot\system32. Она вводится в командной строке с этим каталогом, указанным в качестве текущего, или в начале команды cscript вводится полный путь к этому каталогу.
  • Если аргументы параметров команды содержат пробелы, их следует заключать в кавычки (например "имя компьютера").


Prnport.vbs

Создает, удаляет и составляет список стандартных TCP/IP-портов принтера в дополнение к выводу на экран и изменению настроек порта. При вызове команды prnport.vbs без параметров в командной строке выводится справка по команде prnport.vbs.

Создание стандартного порта TCP/IP

Синтаксис

cscript prnport.vbs -a -r имя_порта [-s удаленный_компьютер] -h IP-адрес [-u имя_пользователя -w пароль] [-o {raw -n номер_порта | lpr}] [-q имя_очереди] [-m{e | d}] [-i индекс] [-y имя_сообщества] [-2{e | d}]

Параметры

-a
Обязательный параметр. Задание создания стандартного порта TCP/IP принтера
-r имя_порта
Обязательный параметр. Задает порт, к которому подключен принтер.
-s удаленный_компьютер
Задает имя удаленного компьютера, к которому требуется добавить порт. Если компьютер не указан, порт добавляется к локальному компьютеру.
-h IP-адрес
Обязательный параметр. Задает IP-адрес для назначения его порту.
-u имя_пользователя -w пароль
Задает учетную запись с разрешениями подключаться с помощью инструментария управления Windows к компьютеру, на котором требуется создать стандартный порт принтера TCP/IP. Все члены группы «Администраторы» имеют такие разрешения, но они могут быть даны и другим пользователям. Если учетная запись не задана, то для того, чтобы команда работала, необходимо войти в систему с учетной записью, имеющей такие разрешения.
-o {raw -n номер_порта | lpr}
Задает протокол, используемый портом: необработанный TCP или TCP LPR. Для необработанного протокола TCP задается номер порта для порта принтера необработанного протокола TCP. По умолчанию номер этого порта равен 9100. Для получения дополнительных сведений щелкните ссылку "См. также". Большинство принтеров использует необработанный протокол TCP. В сетях UNIX принтерами обычно используется протокол TCP LPR.
-q имя_очереди
Задает имя очереди для необработанного протокола TCP
-m{e | d}
Задает признак использования SNMP. Параметр e включает SNMP. Параметр d отключает SNMP.
-i индекс
Задает индекс SNMP при включении SNMP.
-y имя_сообщества
Задает имя сообщества SNMP при включении SNMP.
-2{e | d}
Переключатель режима двойных очередей (повторная постановка в очередь) для портов TCP LPR. Двойные очереди необходимы, так как TCP LPR должен включать точное число байт в контрольный файл, отправляемый на принтер, а протокол не может получить это число от локальной службы печати. Поэтому, когда файл помещается в очередь печати TCP LPR, он также помещается как временный файл в каталог system32. TCP LPR определяет размер временного файла и отправляет этот размер серверу LPD. Параметр e включает двойные очереди. Параметр d отключает двойные очереди.
/?
Отображает справку в командной строке.

Примечания

  • Эта команда запускает программу из каталога systemroot\system32. Она вводится в командной строке с этим каталогом, указанным в качестве текущего, или в начале команды cscript вводится полный путь к этому каталогу.
  • Если требуется изменить настройки конфигурации для стандартного порта TCP/IP принтера после его создания, введите команду cscript prnport.vbs с параметром -t.
  • Если аргументы параметров команды содержат пробелы, их следует заключать в кавычки (например "имя компьютера").
  • XOX

Удаление стандартного порта TCP/IP принтера

Синтаксис

cscript prnport.vbs -d -r имя_порта [-s удаленный_компьютер] [-u имя_пользователя -w пароль]

Параметры

-d
Обязательный параметр. Задает удаление стандартного порта TCP/IP принтера
-r имя_порта
Обязательный параметр. Задает удаление стандартного порта TCP/IP принтера
-s удаленный_компьютер
Задает имя удаленного компьютера, у которого требуется удалить порт. Если компьютер не указан, то порт удаляется на локальном компьютере.
-u имя_пользователя [пароль | *]
Задает учетную запись с разрешениями подключаться с помощью инструментария управления Windows к компьютеру, на котором требуется удалить стандартный порт TCP/IP принтера. Все члены группы «Администраторы» имеют такие разрешения, но они могут быть даны и другим пользователям. Если учетная запись не задана, то для того, чтобы команда работала, необходимо войти в систему с учетной записью, имеющей такие разрешения.
/?
Отображает справку в командной строке.

Примечания

  • Эта команда запускает программу из каталога systemroot\system32. Она вводится в командной строке с этим каталогом, указанным в качестве текущего, или в начале команды cscript вводится полный путь к этому каталогу.
  • Если аргументы параметров команды содержат пробелы, их следует заключать в кавычки (например "имя компьютера").

Пример

Для удаления стандартного порта TCP/IP принтера с именем IP_192.168.12.128 из удаленного компьютера с именем HRServer введите:

cscript prnport.vbs -d -r IP_192.168.12.128 -s HRServer

Составление списка стандартных портов TCP/IP принтера на компьютере

Синтаксис

cscript prnport.vbs -l [-s удаленный_компьютер] [-u имя_пользователя -w пароль]

Параметры

-l
Обязательный параметр. Задает составление списка всех стандартных портов TCP/IP принтера на компьютере.
-s удаленный_компьютер
Задает имя удаленного компьютера, для которого требуется составить список всех портов. Если компьютер не указан, то список составляется для локального компьютера.
-u имя_пользователя -w пароль
Задает учетную запись с разрешениями подключаться с помощью инструментария управления Windows к компьютеру, для которого требуется составить список всех стандартных портов TCP/IP принтера. Все члены группы «Администраторы» имеют такие разрешения, но они могут быть даны и другим пользователям. Если учетная запись не задана, то для того, чтобы команда работала, необходимо войти в систему с учетной записью, имеющей такие разрешения.
/?
Отображает справку в командной строке.

Примечания

  • Эта команда запускает программу из каталога systemroot\system32. Она вводится в командной строке с этим каталогом, указанным в качестве текущего, или в начале команды cscript вводится полный путь к этому каталогу.
  • Если аргументы параметров команды содержат пробелы, их следует заключать в кавычки (например "имя компьютера").

Пример

Для составления списка всех стандартных портов TCP/IP принтера для удаленного компьютера с именем HRServer введите:

cscript prnport.vbs -l -s HRServer

Вывод параметров стандартного порта TCP/IP принтера

Синтаксис

cscript prnport.vbs -g -r имя_порта [-s удаленный_компьютер] [-u имя_пользователя -w пароль]

Параметры

-g
Обязательный параметр. Задает вывод параметров стандартного порта TCP/IP принтера.
-r имя_порта
Обязательный параметр. Задает порт, для которого требуется вывод параметров.
-s удаленный_компьютер
Задает имя удаленного компьютера, на котором находится порт, настройку параметров которого требуется вывести. Если компьютер не указан, то выводится информация для порта локального компьютера.
-u имя_пользователя -w пароль
Задает учетную запись с разрешениями подключаться, с помощью инструментария управления Windows к компьютеру, параметры порта которого требуется вывести. Все члены группы «Администраторы» имеют такие разрешения, но они могут быть даны и другим пользователям. Если учетная запись не задана, то для того, чтобы команда работала, необходимо войти в систему с учетной записью, имеющей такие разрешения.
/?
Отображает справку в командной строке.

Примечания

  • Эта команда запускает программу из каталога systemroot\system32. Она вводится в командной строке с этим каталогом, указанным в качестве текущего, или в начале команды cscript вводится полный путь к этому каталогу.
  • Если аргументы параметров команды содержат пробелы, их следует заключать в кавычки (например "имя компьютера").

Настройка параметров стандартного порта TCP/IP принтера

Синтаксис

cscript prnport.vbs -t -r имя_порта [-s удаленный_компьютер] [-o {raw -n имя_порта | lpr}] [-h IP-адрес] [-q имя_очереди] [-m{e | d}] [-i индекс] [-y имя_сообщества] [-2{e | d}] [-u имя_пользователя -w пароль]

Параметры

-t
Обязательный параметр. Задает настройку параметров стандартного порта TCP/IP принтера
-r имя_порта
Обязательный параметр. Задает порт, к которому подключен принтер.
-s удаленный_компьютер
Задает имя удаленного компьютера, параметры порта которого требуется настроить. Если компьютер не указан, настраивается порт локального компьютера.
-o {raw -n номер_порта | lpr}
Задает протокол, используемого портом: необработанный TCP или TCP LPR. Если используется необработанный протокол TCP, то задается номер порта для порта принтера необработанного протокола TCP. Большинство принтеров использует необработанный протокол TCP. В сетях UNIX принтеры обычно используют протокол TCP LPR.
-h IP-адрес
Задает IP-адрес принтера, параметры порта которого требуется настроить.
-q имя_очереди
Задает имя очереди для необработанного протокола TCP
-m{e | d}
Задает признак использования SNMP. Параметр e включает SNMP. Параметр d отключает SNMP.
-i индекс
Задает индекс SNMP при включении SNMP.
-y имя_сообщества
Задает имя сообщества SNMP при включении SNMP.
-2{e | d}
Переключатель режима двойных очередей (повторная постановка в очередь) для портов TCP LPR. Двойные очереди необходимы, так как TCP LPR должен включать точное число байт в контрольный файл, отправляемый на принтер, а протокол не может получить это число от локальной службы печати. Поэтому, когда файл помещается в очередь печати TCP LPR, он в качестве временного файла помещается в каталог system32. TCP LPR определяет размер временного файла и отправляет этот размер серверу LPD. Параметр e включает двойные очереди. Параметр d отключает двойные очереди.
-u имя_пользователя -w пароль
Задает учетную запись с разрешениями подключаться с помощью инструментария управления Windows к компьютеру, порт которого требуется настроить. Все члены группы «Администраторы» имеют такие разрешения, но они могут быть даны и другим пользователям. Если учетная запись не задана, то для того, чтобы команда работала, необходимо войти в систему с учетной записью, имеющей такие разрешения.
/?
Отображает справку в командной строке.

Примечания

  • Эта команда запускает программу из каталога systemroot\system32. Она вводится в командной строке с этим каталогом, указанным в качестве текущего, или в начале команды cscript вводится полный путь к этому каталогу.
  • Если аргументы параметров команды содержат пробелы, их следует заключать в кавычки (например "имя компьютера").


Prnqctl.vbs

Печатает пробную страницу, приостанавливает или возобновляет печать на принтере и чистит очередь принтера. При вызове команды prncnfg.vbs без параметров в командной строке отображается справка по команде prncnfg.vbs.

Приостановка печати

Синтаксис

cscript prncnfg.vbs -g [-s удаленный_компьютер] -p имя_принтера [-u имя_пользователя -w пароль]

Параметры

-z
Обязательный параметр. Задает приостановку печати задания.
-s удаленный_компьютер
Задает имя компьютера, подключенного к принтеру, печать на котором требуется приостановить. Если компьютер не указан, то печать приостанавливается на принтере, подключенном к локальному компьютеру.
-p имя_принтера
Обязательный параметр. Задает имя принтера, работу которого требуется приостановить.
-u имя_пользователя -w пароль
Задает учетную запись с разрешениями подключаться с помощью инструментария управления Windows к компьютеру, подключенному к принтеру, печать которого требуется приостановить. Все члены группы «Администраторы» имеют такие разрешения, но они могут быть даны и другим пользователям. Если учетная запись не задана, то для того, чтобы команда работала, необходимо войти в систему с учетной записью, имеющей такие разрешения.
/?
Отображает справку в командной строке.

Примечания

  • Эта команда запускает программу из каталога systemroot\system32. Она вводится в командной строке с этим каталогом, указанным в качестве текущего, или в начале команды cscript вводится полный путь к этому каталогу.
  • Если аргументы параметров команды содержат пробелы, их следует заключать в кавычки (например "имя компьютера").

Пример

Для того, чтобы приостанвить печать на принтере с именем ColorPrinter_2 с удаленного компьютера с именем HRServer, введите:

cscript prnqctl.vbs -z -s HRServer -p ColorPrinter_2

Возобновление печати

Синтаксис

cscript prncnfg.vbs -g [-s удаленный_компьютер] -p имя_принтера [-u имя_пользователя -w пароль]

Параметры

-m
Обязательный параметр. Задает возобновление печати задания.
-s удаленный_компьютер
Задает имя компьютера, подключенного к принтеру, печать на котором требуется возобновить. Если компьютер не указан, печать возобновляется на принтере, подключенном к локальному компьютеру.
-p имя_принтера
Обязательный параметр. Задает имя принтера, на котором требуется возобновить печать.
-u имя_пользователя -w пароль
Задает учетную запись с разрешениями подключаться с помощью инструментария управления Windows к компьютеру, подключенному к принтеру, печать которого требуется возобновить. Все члены группы «Администраторы» имеют такие разрешения, но они могут быть даны и другим пользователям. Если учетная запись не задана, то для того, чтобы команда работала, необходимо войти в систему с учетной записью, имеющей такие разрешения.
/?
Отображает справку в командной строке.

Примечания

  • Эта команда запускает программу из каталога systemroot\system32. Она вводится в командной строке с этим каталогом, указанным в качестве текущего, или в начале команды cscript вводится полный путь к этому каталогу.
  • Если аргументы параметров команды содержат пробелы, их следует заключать в кавычки (например "имя компьютера").

Пример

Для возобновления печати на принтере с именем ColorPrinter_2 с удаленного компьютера с именем HRServer введите:

cscript prnqctl.vbs -m -s HRServer -p ColorPrinter_2

Печать пробной страницы

Синтаксис

cscript prnqctl.vbs -e [-s удаленный_компьютер] -p имя_принтера [-u имя_пользователя -w пароль]

Параметры

-e
Обязательный параметр. Задание печати пробной страницы.
-s удаленный_компьютер
Задает имя компьютера, подключенного к принтеру, на котором требуется напечатать пробную страницу. Если компьютер не указан, используется локальный компьютер.
-p имя_принтера
Обязательный параметр. Задает имя принтера, на котором требуется напечатать пробную страницу.
-u имя_пользователя -w пароль
Задает учетную запись с разрешениями подключаться с помощью инструментария управления Windows к компьютеру, подключенному к принтеру, на котором требуется напечатать пробную страницу. Все члены группы «Администраторы» имеют такие разрешения, но они могут быть даны и другим пользователям. Если учетная запись не задана, то для того, чтобы команда работала, необходимо войти в систему с учетной записью, имеющей такие разрешения.
/?
Отображает справку в командной строке.

Примечания

  • Эта команда запускает программу из каталога systemroot\system32. Она вводится в командной строке с этим каталогом, указанным в качестве текущего, или в начале команды cscript вводится полный путь к этому каталогу.
  • Если аргументы параметров команды содержат пробелы, их следует заключать в кавычки (например "имя компьютера").

Отмена всех заданий в очереди принтера

Синтаксис

cscript prnqctl.vbs -x [-s удаленный_компьютер] -p имя_принтера [-u имя_пользователя -w пароль]

Параметры

-x
Обязательный параметр. Задает отмену печати всех заданий очереди принтера.
-s удаленный_компьютер
Задает имя компьютера, подключенного к принтеру, печать всех заданий в очереди которого требуется отменить. Если компьютер не указан, используется локальный компьютер.
-p имя_принтера
Обязательный параметр. Задает имя принтера, печать всех заданий в очереди которого требуется отменить.
-u имя_пользователя -w пароль
Задает учетную запись с разрешениями подключаться с помощью инструментария управления Windows к компьютеру, на котором требуется отменить печать всех заданий из очереди принтера. Все члены группы «Администраторы» имеют такие разрешения, но они могут быть даны и другим пользователям. Если учетная запись не задана, то для того, чтобы команда работала, необходимо войти в систему с учетной записью, имеющей такие разрешения.
/?
Отображает справку в командной строке.

Примечания

  • Эта команда запускает программу из каталога systemroot\system32. Она вводится в командной строке с этим каталогом, указанным в качестве текущего, или в начале команды cscript вводится полный путь к этому каталогу.
  • Если аргументы параметров команды содержат пробелы, их следует заключать в кавычки (например "имя компьютера").


Prompt

Изменяет приглашение командной строки (Cmd.exe). Вызванная без параметров, команда prompt восстанавливает стандартные настройки приглашения командной строки: имя текущего диска с последующим именем текущего каталога и знак "больше" (>).

Синтаксис

prompt [текст]

Параметры

текст
Задает любой текст и сведения, которые будут выводиться в приглашении командной строки.
/?
Отображает справку в командной строке.

Примечания

  • Вид приглашения командной строки может быть настроен так, чтобы выводить имя текущего каталога, текущее время, дату и номер версии Windows XP.
  • Приведенный ниже список содержит сочетания символов, которые можно использовать вместо или вместе с символьными строками в параметре текст . Список содержит краткое описание текста или сведений, которые каждая комбинация символов добавляет в приглашение командной строки.
    Символ | Описание
    $q | = (знак равенства)
    $$ $ (знак доллара)
    $t | Текущее время
    $d | Текущая дата
    $p | Текущий диск и каталог
    $v | Windows XP номер версии
    $n | Текущий диск
    $g | > (знак "больше")
    $l | < (знак "меньше")
    $b | (канал)
    $_ Перевод строки
    $e | Управляющий код ANSI (код 27)
    $h | Забой (для удаления символа, написанного в приглашении командной строки)
    $a | & (амперсанд)
    $c | ( (левая скобка)
    $f | ) (правая скобка)
    $s | пробел
  • Если расширения командного процессора разрешены (используются по умолчанию), то команда prompt поддерживает следующие дополнительные символы форматирования:
    Символ | Описание
    $+ Ноль или несколько знаков плюс (+), в зависимости от глубины стека каталогов команды pushd (по одному символу на каждый уровень).
    $m | Удаленное имя, связанное с текущим именем диска, или пустая строка, если текущий диск не является сетевым.
  • Если использован символ $p, система Windows 2000 читает диск после выполнения каждой команды для определения текущего диска и каталога. На это может потребоваться дополнительное время, особенно для гибких дисков.

Примеры

Следующий пример устанавливает приглашение командной строки в виде текущего диска, текущего каталога и знака угловой скобки (>):

prompt $p$g

Следующая команда выводит приглашение из двух строк с текущим временем в первой строке и текущей датой во второй:

prompt time is: $t$_date is: $d


Pushd

Сохраняет имя текущего каталога для команды popd и переходит в другой каталог.

Синтаксис

pushd [путь]

Параметры

путь
Задает путь к месту, в которое должна быть перенаправлена папка. Эта команда поддерживает относительные пути.
/?
Отображает справку в командной строке.

Примечания

  • Каждое выполнение команды pushd сохраняет один каталог. Запустив команду pushd несколько раз, можно сохранить несколько каталогов.
    Каталоги сохраняются последовательно в виртуальном стеке. Если команда pushd выполняется один раз, то каталог, в котором используется команда, помещается в стеке вниз. Если запустить команду еще раз, второй каталог помещается над первым. Этот процесс повторяется при каждом вызове команды pushd .

    Команду popd можно использовать для изменения текущего каталога на каталог, сохраненный последним командой pushd. Если используется команда popd, верхний каталог в стеке удаляется и текущий каталог заменяется на этот каталог. Если использовать команду popd еще раз, из стека будет удален следующий верхний каталог.
  • Если расширения командного процессора разрешены, то команда pushd разрешает указывать сетевой путь или локальный диск и путь.
  • Если задан сетевой путь, то команда pushd временно назначает первое неиспользованное имя диска (начиная с Z:) заданному сетевому ресурсу. Далее команда меняет текущий диск и каталог на указанный каталог в заново назначенном диске. Если расширения командного процессора разрешены, то команда popd удаляет любые имена дисков, созданные командой pushd.

Примеры

Команды pushd и popd можно использовать в пакетной программе для изменения текущего каталога, в котором она была запущена, и последующего возврата к нему. В приведенном ниже примере показано, как это сделать:

@echo off
rem Этот пакетный файл удаляет все файлы .txt в заданном каталоге
pushd %1
del *.txt
popd
cls
echo Все текстовые файлы в каталоге %1 удалены


Файл Pagefileconfig.vbs

Позволяет администратору вывести и настроить параметры использования виртуальной памяти файлом подкачки.

Изменяет параметры использования виртуальной памяти файлом подкачки.

Синтаксис

pagefileconfig[.vbs] /change [/s компьютер [/u домен\пользователь [/p пароль]]] {[/i начальный_размер_файла_подкачки]|[/m максимальный_размер_файла_подкачки]} /vo {буква_тома|*} [/vo {буква_тома_2|*} [...]]

Параметры

/s компьютер
Задает имя или IP-адрес удаленного компьютера (не используйте обратную косую черту). По умолчанию используется локальный компьютер.
/u домен\пользователь
Запускает сценарий с разрешениями учетной записи пользователя, указанного, как пользователь или домен\пользователь. По умолчанию используются разрешения текущего вошедшего пользователя компьютера, с которого поступила эта команда.
/p пароль
Задает пароль учетной записи пользователя, указанного в параметре /u.
/i начальный_размер_файла_подкачки
Задает новый начальный размер (в Мбайт) для указанного файла подкачки.
/m максимальный_размер_файла_подкачки
Задает новый максимальный размер (в Мбайт) для указанного файла подкачки.
/vo {буква_тома|*}
Задает том или тома параметров файла подкачки, которые должны быть изменены. Том задается буквой с последующим двоеточием (Например «C:»).
/?
Выводит справку в командной строке.

Примеры

Далее приведены примеры использования команды pagefileconfig /change.

pagefileconfig.vbs /change /m 400 /vo c:
pagefileconfig.vbs /change /s srvmain /u maindom\hiropln /m 400 /vo c:
pagefileconfig.vbs /change /s srvmain /u maindom\hiropln /i 20 /vo *
pagefileconfig.vbs /change /s srvmain /u maindom\hiropln /p p@ssW23 /i 200 /m 500 /vo c: /vo d:

Создает или добавляет дополнительный файл подкачки к системе.

Синтаксис

pagefileconfig.vbs /create [/s компьютер [/u домен\пользователь [/p пароль]]] /i начальный_размер_файла_подкачки /m максимальный_размер_файла_подкачки /vo {буква_тома|*} [/vo {буква_тома_2|*} [...]]

Параметры

/s компьютер
Задает имя или IP-адрес удаленного компьютера (не используйте обратную косую черту). По умолчанию используется локальный компьютер.
/u домен\пользователь
Запускает сценарий с разрешениями учетной записи пользователя, заданными в пользователь или домен\пользователь. По умолчанию используются разрешения текущего вошедшего пользователя компьютера, с которого поступила эта команда.
/p пароль
Задает пароль учетной записи пользователя, заданного в параметре /u.
/i начальный_размер_файла_подкачки
Задает новый начальный размер (в Мбайт) для указанного файла подкачки.
/m максимальный_размер_файла_подкачки
Задает новый максимальный размер (в Мбайт) для указанного файла подкачки.
/vo {буква_тома|*}
Задает том или тома параметров файла подкачки, которые должны быть созданы. Том задается буквой с последующим двоеточием (Например «C:»).
/?
Выводит справку в командной строке.

Примеры

Далее приведены примеры использования команды pagefileconfig /create:

pagefileconfig.vbs /create /i 140 /m 300 /vo d:
pagefileconfig.vbs /create /s srvmain /u maindom\hiropln /i 150 /m 300 /vo d:
pagefileconfig.vbs /create /s srvmain /u maindom\hiropln /i 50 /m 200 /vo *
pagefileconfig.vbs /create /s srvmain /u maindom\hiropln /p p@ssW23 /i 100 /m 600 /vo d: /vo e: /vo f:

Удаляет файл подкачки из системы.

Синтаксис

pagefileconfig.vbs /delete [/s компьютер [/u домен\пользователь [/p пароль]]] /vo {буква_тома|*} [/vo {буква_тома_2|*} [...]]

Параметры

/s компьютер
Задает имя или IP-адрес удаленного компьютера (не используйте обратную косую черту). По умолчанию используется локальный компьютер.
/u домен\пользователь
Запускает сценарий с разрешениями учетной записи пользователя, указанного в пользователь или домен\пользователь. По умолчанию используются разрешения текущего вошедшего пользователя компьютера, с которого поступила эта команда.
/p пароль
Задает пароль учетной записи пользователя в параметре /u.
/vo {буква_тома|*}
Задает том или тома параметров файла подкачки, которые должны быть удалены. Том задается буквой с последующим двоеточием (Например «C:»).
/?
Выводит справку в командной строке.

Примеры

Далее приведены примеры использования команды pagefileconfig /delete:

pagefileconfig.vbs /delete /vo d:
pagefileconfig.vbs /delete /s srvmain /u maindom\hiropln /vo d:
pagefileconfig.vbs /delete /s srvmain /u maindom\hiropln /p p@ssW23 /vo d: /vo e: /vo f:

Запрашивает и выводит параметры использования виртуальной памяти файлом подкачки.

pagefileconfig.vbs /query [/s компьютер [/u домен\пользователь [/p пароль]]] [/fo {TABLE|LIST|CSV}]

Параметры

/s компьютер
Задает имя или IP-адрес удаленного компьютера (не используйте обратную косую черту). По умолчанию используется локальный компьютер.
/u домен\пользователь
Запускает сценарий с разрешениями учетной записи пользователя, указанный в пользователь или домен\пользователь. По умолчанию используются разрешения текущего вошедшего пользователя компьютера, с которого поступила эта команда.
/p пароль
Задает пароль учетной записи пользователя в параметре /u.
/fo {TABLE|LIST|CSV}
Задает формат выходных данных запроса. Допустимые значения: TABLE, LIST и CSV. По умолчанию используется значение LIST.
/?
Выводит справку в командной строке.

Примеры

Далее приведены примеры использования команды pagefileconfig /query:

pagefileconfig.vbs /query
pagefileconfig.vbs /query /fo table
pagefileconfig.vbs /query /s srvmain /u maindom\hiropln
pagefileconfig.vbs /query /s srvmain /u maindom\hiropln /p p@ssW23 /fo list

Примечания

  • Максимальный размер файла подкачки ограничен размером свободного места на диске за вычетом размера аварийного дампа, заданного для системного диска.


Ping

С помощью отправки сообщений с эхо-запросом по протоколу ICMP проверяет соединение на уровне протокола IP с другим компьютером, поддерживающим TCP/IP. После каждой передачи выводится соответствующее сообщение с эхо-ответом. Ping - это основная TCP/IP-команда, используемая для устранения неполадки в соединении, проверки возможности доступа и разрешения имен. Команда ping, запущенная без параметров, выводит справку.

Синтаксис

ping
 [-t]
 [-a]
 [-n счетчик]
 [-l размер]
 [-f]
 [-i TTL]
 [-v тип]
 [-r счетчик]
 [-s счетчик]
 [{-j список_узлов | -k список_узлов}]
 [-w интервал] [имя_конечного_компьютера]

Параметры

-t
Задает для команды ping отправку сообщений с эхо-запросом к точке назначения до тех пор, пока команда не будет прервана. Для прерывания команды и вывода статистики нажмите комбинацию CTRL-BREAK. Для прерывания команды ping и выйхода из нее нажмите клавиши CTRL-C.
-a
Задает разрешение обратного имени по IP-адресу назначения. В случае успешного выполнения выводится имя соответствующего узла.
-n счетчик
Задает число отправляемых сообщений с эхо-запросом. По умолчанию — 4.
-l размер
Задает длину (в байтах) поля данных в отправленных сообщениях с эхо-запросом. По умолчанию — 32 байта. Максимальный размер — 65527.
-f
Задает отправку сообщений с эхо-запросом с флагом «Don't Fragment» в IP-заголовке, установленном на 1. Сообщения с эхо-запросом не фрагментируются маршрутизаторами на пути к месту назначения. Этот параметр полезен для устранения проблем, возникающих с максимальным блоком данных для канала (Maximum Transmission Unit).
-i TTL
Задает значение поля TTL в IP-заголовке для отправляемых сообщений с эхо-запросом. По умолчанию берется значение TTL, заданное по умолчанию для узла. Для узлов Windows XP это значение обычно равно 128. Максимальное значение TTL — 255.
-v тип
Задает значение поля типа службы (TOS) в IP-заголовке для отправляемых сообщений с эхо-запросом. По умолчанию это значение равно 0. тип — это десятичное значение от 0 до 255.
-r счетчик
Задает параметр записи маршрута (Record Route) в IP-заголовке для записи пути, по которому проходит сообщение с эхо-запросом и соответствующее ему сообщение с эхо-ответом. Каждый переход в пути использует параметр записи маршрута. По возможности значение счетчика задается равным или большим, чем количество переходов между источником и местом назначения. Параметр счетчик имеет значение от 1 до 9.
-s счетчик
Указывает вариант штампа времени Интернета (Internet Timestamp) в заголовке IP для записи времени прибытия сообщения с эхо-запросом и соответствующего ему сообщения с эхо-ответом для каждого перехода. Параметр счетчик имеет значение от 1 до 4.
-j список_узлов
Указывает для сообщений с эхо-запросом использование параметра свободной маршрутизации в IP-заголовке с набором промежуточных точек назначения, указанным в списке_узлов. При свободной маршрутизации последовательные промежуточные точки назначения могут быть разделены одним или несколькими маршрутизаторами. Максимальное число адресов или имен в списке узлов — 9. Список узлов — это набор IP-адресов (в точечно-десятичной нотации), разделенных пробелами.
-k список_узлов
Указывает для сообщений с эхо-запросом использование параметра строгой маршрутизации в IP-заголовке с набором промежуточных точек назначения, указанным в списке_узлов. При строгой маршрутизации следующая промежуточная точка назначения должна быть доступной напрямую (она должна быть соседней в интерфейсе маршрутизатора). Максимальное число адресов или имен в списке узлов равно 9. Список узлов — это набор IP-адресов (в точечно-десятичной нотации), разделенных пробелами.
-w интервал
Определяет в миллисекундах время ожидания получения сообщения с эхо-ответом, которое соответствует сообщению с эхо-запросом. Если сообщение с эхо-ответом не получено в пределах заданного интервала, то выдается сообщение об ошибке "Request timed out". Интервал по умолчанию равен 4000 (4 секунды).
имя_конечного_компьютера
Задает точку назначения, идентифицированную IP-адресом или именем узла.
/?
Отображает справку в командной строке.

Примечания

  • Команда ping позволяет проверить имя и IP-адрес компьютера. Если проверка IP-адреса успешная, и проверка имени — нет, то имеет место проблема разрешения имен. В этом случае с помощью запросов DNS (Domain Name System) или с помощью методов разрешения имен NetBIOS проверьте, чтобы имя задаваемого компьютера было разрешено в локальном файле Hosts.
  • Эта команда доступна только если в свойствах сетевого адаптера в объекте Сетевые подключения в качестве компонента установлен протокол Интернета (TCP/IP).

Примеры

Приведенный ниже пример содержит результаты работы команды ping:

C:\>ping example.microsoft.com

Pinging example.microsoft.com [192.168.239.132] with 32 bytes of data:

Reply from 192.168.239.132: bytes=32 time=101ms TTL=124

Reply from 192.168.239.132: bytes=32 time=100ms TTL=124

Reply from 192.168.239.132: bytes=32 time=101ms TTL=124

Reply from 192.168.239.132: bytes=32 time=101ms TTL=124

Для отправки сообщения точке назначения 10.0.99.221 и сопоставления с ее узловым именем введите:

ping -a 10.0.99.221

Для отправки точке назначения 10.0.99.221 десяти сообщений с эхо-запросом, каждое из которых имеет поле данных из 1000 байт, введите:

ping -n 10 -l 1000 10.0.99.221

Для отправки сообщения точке назначения 10.0.99.221 и записи маршрута для 4 переходов введите:

ping -r 4 10.0.99.221

Для отправки сообщения точке назначения 10.0.99.221 и задания свободной маршрутизации для точек назначения 10.12.0.1-10.29.3.1-10.1.44.1 введите:

ping -j 10.12.0.1 10.29.3.1 10.1.44.1 10.0.99.221

Условные обозначения форматирования

Формат | Значение
Курсив | Сведения, вводимые пользователем
Полужирный | Элементы, вводимые без изменений
Многоточие (...) | Параметр может быть введен в командной строке несколько раз
В квадратных скобках ([]) | Необязательные элементы
В фигурых скобках ({}); варианты, разделенные вертикальной линией (|), пример: {even|odd} | Набор вариантов, из которых необходимо выбрать один
Шрифт Courier | Выходные данные программы


SC

Взаимодействует с контроллером служб и установленными службами. SC.exe извлекает и задает сведения об управлении службами. Программа SC.exe используется для тестирования и отладки служебных программ. Параметры службы, хранящиеся в реестре, можно настроить так, чтобы контролировать запуск приложений службы во время загрузки и их выполнение как фоновых процессов. С помощью параметров SC.exe имеется возможность настроить конкретную службу, отобразить текущее состояние службы, остановить и запустить службу. Чтобы автоматизировать запуск и завершение работы последовательности служб, создаются пакетные файлы, вызывающие различные команды SC.exe. SC.exe предоставляет возможности, сходные с возможностями средства «Службы» в элементе «Администрирование» панели управления.

Определяет сохранение последней загрузки как последней удачной конфигурации.

Синтаксис

sc [имя_сервера] boot [{bad|OK}]

Параметры

имя_сервера
Задает имя удаленного сервера, на котором находится служба. В имени следует использовать формат UNC (Universal Naming Convention) ("\\myserver"). Чтобы запустить SC локально, этот параметр следует пропустить.
[{bad|OK}]
Определяет последнюю загрузку как неудачную или задает сохранение последней загрузки в качестве последней удачной конфигурации.
/?
Отображает справку в командной строке.

Примеры

Далее приведены примеры использования команды sc boot.

sc boot ok
sc boot bad

Изменяет значение записей службы в реестре и в базе данных диспетчера служб.

Синтаксис

sc [имя_сервера] config [имя_службы] [type= {own|share|kernel|filesys|rec|adapt|interact type= {own|share}}] [start= {boot|system|auto|demand|disabled}] [error= {normal|severe|critical|ignore}] [binpath= имя_двоичного_пути] [group= группа_порядка_загрузки] [tag= {yes|no}] [depend= зависимости] [obj= {имя_учетной_записи|имя_объекта}] [displayname= отображаемое_имя] [password= пароль]

Параметры

имя_сервера
Задает имя удаленного сервера, на котором находится служба. В имени следует использовать формат UNC (Universal Naming Convention) ("\\myserver"). Чтобы запустить SC локально, этот параметр следует пропустить.
имя_службы
Указывает имя службы, возвращенное операцией getkeyname.
type= {own|share|kernel|filesys|rec|adapt|interact type= {own|share}}
Указывает тип службы.
Значение | Описание
own | Служба выполняется в собственном процессе. Она не использует исполняемый файл совместно с другими службами. Эта установка используется по умолчанию
share | Служба выполняется как общий процесс. Она использует исполняемый файл совместно с другими службами
kernel | Драйвер
filesys | Драйвер файловой системы
rec | Драйвер, определяющий файловую систему (указывает файловые системы, используемые на компьютере)
adapt | Драйвер устройства (определяет элементы оборудования, например клавиатуру, мышь или дисковод)
interact | Служба может взаимодействовать с рабочим столом, получая входные данные от пользователей. Интерактивные службы должны выполняться с системной учетной записью. Этот тип должен использоваться вместе с type= own или type= shared (например, type= interact type= own). Самостоятельное использование типа type= interact приведет к ошибке недопустимого параметра
start= {boot|system|auto|demand|disabled}
Указывает тип запуска для службы.
Значение | Описание
boot | Драйвер устройства, который загружается загрузчиком системы.
system | Драйвер устройства, который запускается при инициализации ядра.
auto | Служба, которая автоматически запускается при каждой перезагрузке компьютера и даже в том случае, если на компьютер не вошел ни один пользователь
demand | Служба, которая должна запускаться вручную. Это значение используется по умолчанию, если не указан параметр start=
disabled | Служба, которую нельзя запустить. Чтобы запустить отключенную службу, выберите другой тип запуска
error= {normal|severe|critical|ignore}
Указывает серьезность ошибки, если служба не запускается при загрузке.
Значение | Описание
normal | Ошибка записывается в журнал и выводится окно сообщения, информирующее пользователя об отказе при запуске службы. Запуск будет продолжен. Это устанавливается по умолчанию
severe | Ошибка заносится в журнал (если это возможно). Компьютер пытается перезагрузиться в последней удачной конфигурации. Компьютер можно будет перезагрузить, но выполнить службу, возможно, не удастся
critical | Ошибка заносится в журнал (если это возможно). Компьютер пытается перезагрузиться в последней удачной конфигурации. Если имеет место отказ последней правильной конфигурации, запуск также приведет к отказу и процесс загрузки остановится на ошибке
ignore | Ошибка заносится в журнал и запуск продолжается. Ошибка записывается в журнал ошибок и другие уведомления пользователю не выводятся
binpath= имя_двоичного_пути
Указывает путь в двоичном файле службы
group= группа_порядка_загрузки
Указывает имя группы, членом которой является эта служба. Список групп сохраняется в реестре в подразделе HKLM\System\CurrentControlSet\Control\ServiceGroupOrder. Значение по умолчанию является пустым
tag= {yes|no}
Указывает, следует ли получить код TagID из вызова CreateService. Теги используются только драйверами, запускающимися при загрузке или запуске системы
depend= зависимости
Указывает имена служб и групп, которые должны быть запущены раньше данной службы. Имена разделяются косой чертой (/)
obj= {имя_учетной_записи|имя_объекта}
Указывает имя учетной записи, для которой будет выполняться служба, или имя объекта драйвера Windows, в котором будет запущен драйвер. По умолчанию установленое имя учетной записи — Локальная система.
displayname= отображаемое_имя
Определяет понятное, точное имя для службы, которое используется в программах пользовательского интерфейса. Например, имя раздела службы «wuaserv» не очень понятно пользователю, а отображаемое имя — «Автоматическое обновление».
password= пароль
Задает пароль. Данный параметр требуется при использовании учетной записи, отличной от учетной записи «Локальная система».
/?
Отображает справку в командной строке.

Примечания

  • Если между параметром и его значением имеется пробел (например type= own вместо type=own) произойдет сбой операции.

Примеры

Далее приведены примеры использования команды sc config.

sc config NewService binpath= "ntsd -d c:\windows\system32\NewServ.exe"

Чтобы возобновить остановленную службу, отправляет службе запрос CONTINUE.

Синтаксис

sc [имя_сервера] continue [имя_службы]

Параметры

имя_сервера
Задает имя удаленного сервера, на котором находится служба. В имени следует использовать формат UNC ("\\myserver"). Чтобы запустить SC локально, этот параметр следует пропустить.
имя_службы
Указывает имя службы, возвращенное операцией getkeyname.
/?
Отображает справку в командной строке.

Примечания

  • Используйте операцию continue для возобновления работы остановленной службы.

Примеры

Далее приведены примеры использования команды sc continue.

sc continue tapisrv

Отправляет службе код CONTROL B.

Синтаксис

sc [имя_сервера] control [имя_службы] [{paramchange|netbindadd|netbindremove|netbindenable|netbinddisable|пользовательский_управляющий_код}]

Параметры

имя_сервера
Задает имя удаленного сервера, на котором находится служба. В имени следует использовать формат UNC ("\\myserver"). Чтобы запустить SC локально, этот параметр следует пропустить.
имя_службы
Указывает имя службы, возвращенное операцией getkeyname.
{paramchange|netbindadd|netbindremove|netbindenable|netbinddisable|пользовательский_управляющий_код}
Задает управляющий код, который посылается службе.
/?
Отображает справку в командной строке.

Создает раздел и записи службы в реестре и в базе данных диспетчера служб.

Синтаксис

sc [имя_сервера] create [имя_службы] [type= {own|share|kernel|filesys|rec|adapt|interact type= {own|share}}] [start= {boot|system|auto|demand|disabled}] [error= {normal|severe|critical|ignore}] [binpath= имя_двоичного_пути] [group= группа_порядка_загрузки] [tag= {yes|no}] [depend= зависимости] [obj= {имя_учетной_записи|имя_объекта}] [displayname= отображаемое_имя] [password= пароль]

Параметры

имя_сервера
Задает имя удаленного сервера, на котором находится служба. В имени следует использовать формат UNC ("\\myserver"). Чтобы запустить SC локально, этот параметр следует пропустить.
имя_службы
Указывает имя службы, возвращенное операцией getkeyname.
type= {own|share|kernel|filesys|rec|adapt|interact type= {own|share}}
Указывает тип службы. Тип по умолчанию type= own.
Значение | Описание
own | Служба выполняется в собственном процессе. Она не использует исполняемый файл совместно с другими службами. Эта установка используется по умолчанию
share | Служба выполняется как общий процесс. Она использует исполняемый файл совместно с другими службами
kernel | Драйвер
filesys | Драйвер файловой системы
rec | Драйвер, определяющий файловую систему (указывает файловые системы, используемые на компьютере)
interact | Служба может взаимодействовать с рабочим столом, получая входные данные от пользователей. Интерактивные службы должны выполняться с системной учетной записью. Этот тип должен использоваться вместе с type= own или type= shared (например, type= interact type= own). Самостоятельное использование типа type= interact приведет к ошибке недопустимого параметра
start= {boot|system|auto|demand|disabled}
Указывает тип запуска для службы. Тип запуска по умолчанию start= demand.
boot | Драйвер устройства, который загружается загрузчиком системы
system | Драйвер устройства, который запускается при инициализации ядра
auto | Служба, которая автоматически запускается при каждой перезагрузке компьютера и даже в том случае, если на компьютер не вошел ни один пользователь
demand | Служба, которая должна запускаться вручную. Это значение используется по умолчанию, если не указан параметр start=
disabled | Служба, которую нельзя запустить. Чтобы запустить отключенную службу, выберите другой тип запуска
error= {normal|severe|critical|ignore}
Указывает серьезность ошибки, если служба не запускается при загрузке. Значение параметра по умолчанию error= normal.
normal | Ошибка записывается в журнал и выводится окно сообщения, информирующее пользователя об отказе при запуске службы. Запуск будет продолжен. Это устанавливается по умолчанию
severe | Ошибка заносится в журнал (если это возможно). Компьютер пытается перезагрузиться в последней удачной конфигурации. Компьютер можно будет перезагрузить, но выполнить службу, возможно, не удастся
critical | Ошибка заносится в журнал (если это возможно). Компьютер пытается перезагрузиться в последней удачной конфигурации. Если имеет место отказ последней правильной конфигурации, запуск также приведет к отказу и процесс загрузки остановится на ошибке
ignore | Ошибка заносится в журнал и запуск продолжается. Ошибка записывается в журнал ошибок и другие уведомления пользователю не выводятся
binpath= имя_двоичного_пути
Указывает путь в двоичном файле службы. Значение по умолчанию для параметра binpath= не задано. Эту строку необходимо указать.
group= группа_порядка_загрузки
Указывает имя группы, членом которой является эта служба. Список групп сохраняется в реестре в подразделе HKLM\System\CurrentControlSet\Control\ServiceGroupOrder. Значение по умолчанию является пустым.
tag= {yes|no}
Указывает, следует ли получить код TagID из вызова CreateService. Теги используются только драйверами, запускающимися при загрузке или запуске системы.
depend= зависимости
Указывает имена служб и групп, которые должны быть запущены раньше данной службы. Имена разделяются косой чертой (/).
obj= {имя_учетной_записи|имя_объекта}
Указывает имя учетной записи, для которой будет выполняться служба, или имя объекта драйвера Windows, в котором будет запущен драйвер
displayname= отображаемое_имя
Определяет понятное, точное имя для службы, которое используется в программах пользовательского интерфейса.
password= пароль
Задает пароль. Данный параметр требуется при использовании учетной записи, отличной от учетной записи «Локальная система».
/?
Отображает справку в командной строке.

Примечания

  • Если между параметром и его значением имеется пробел (например type= own вместо type=own) произойдет сбой операции.

Примеры

Далее приведены примеры использования команды sc create.

  • sc \\myserver create NewService binpath= c:\windows\system32\NewServ.exe
  • sc create NewService binpath= c:\windows\system32\NewServ.exe type= share start= auto depend= "+TDI Netbios"

    Удаляет раздел службы из реестра. Если служба выполняется или другой процесс использует эту службу, она помечается для удаления.

    Синтаксис

    sc [имя_сервера] delete [имя_службы]

    Параметры

    имя_сервера
    Задает имя удаленного сервера, на котором находится служба. В имени следует использовать формат UNC ("\\myserver"). Чтобы запустить SC локально, этот параметр следует пропустить.
    имя_службы
    Указывает имя службы, возвращенное операцией getkeyname.
    /?
    Отображает справку в командной строке.

    Примечания

    • Для удаления служб DHCP, DNS и других встроенных в операционную систему служб используйте средство «Установка и удаление программ». Средство «Установка и удаление программ» не только удаляет раздел реестра для службы, но и службу, и ярлыки этой службы.

    Примеры

    Далее приведены примеры использования команды sc delete.

    sc delete newserv

    Задает строку описания для службы.

    Синтаксис

    sc [имя_сервера] description [имя_службы] [описание]

    Параметры

    имя_сервера
    Задает имя удаленного сервера, на котором находится служба. В имени следует использовать формат UNC ("\\myserver"). Чтобы запустить SC локально, этот параметр следует пропустить.
    имя_службы
    Указывает имя службы, возвращенное операцией getkeyname.
    описание
    Задает описание для конкретной службы. Если строка не указана, описание службы не изменяется. Количество символов в строке описания службы неограниченно.
    /?
    Отображает справку в командной строке.

    Примеры

    Далее приведены примеры использования команды sc description.

    sc description newserv "Runs quality of service control."

    Выводит список служб, которые не могут выполнятся, пока запущена определенная служба.

    Синтаксис

    sc [имя_сервера] enumdepend [имя_службы] [размер_буфера]

    Параметры

    имя_сервера
    Задает имя удаленного сервера, на котором находится служба. В имени следует использовать формат UNC ("\\myserver"). Чтобы запустить SC локально, этот параметр следует пропустить.
    имя_службы
    Указывает имя службы, возвращенное операцией getkeyname.
    размер_буфера
    Задает размер буфера перечисления в байтах. Значение по умолчанию равно 1024 байта.
    /?
    Отображает справку в командной строке.

    Примечания

    • Если размер буфера небольшой, операция enumdepend выводит зависимости только частично и указывает размер дополнительного буфера, который необходим для вывода всех зависимостей. Запустите операцию повторно и укажите больший размер буфера, если вывод обрезается.

    Примеры

    Далее приведены примеры использования команды sc enumdepend.

    sc enumdepend rpcss 5690
    sc enumdepend tapisrv

    Определяет действия, которые надо предпринять при сборе работы службы.

    Синтаксис

    sc [имя_сервера] failure [имя_службы] [reset= интервал_без_ошибок] [reboot= широковещательное_сообщение] [command= командная_строка] [actions= действия_при_сбое_и_время_задержки]

    Параметры

    имя_сервера
    Задает имя удаленного сервера, на котором находится служба. В имени следует использовать формат UNC ("\\myserver"). Чтобы запустить SC локально, этот параметр следует пропустить.
    имя_службы
    Указывает имя службы, возвращенное операцией getkeyname.
    reset= интервал_без_ошибок
    Задает период времени работы службы без ошибок (в секундах), после которого счетчик ошибок сбрасывается в 0. Данный параметр должен использоваться совместно с параметром actions=.
    reboot= широковещательное_сообщение
    Определяет сообщение для широковещательной рассылки при сбое работы службы.
    command= командная_строка
    Определяет командную строку для запуска при сбое работы службы.
    actions= действия_при_сбое_и_время_задержки
    Указывает действия при сбое и время задержки (в миллисекундах), отделенные косой чертой (/). Допустимы следующие действия: run, restart и reboot. Этот ключ не может быть использован с параметром reset=. Чтобы не предпринимать никаких действий при сбое, используйте параметр actions= "".
    /?
    Отображает справку в командной строке.

    Примечания

    • Изменить параметры при сбое можно не для всех служб. Некоторые из них выполняются как набор служб.
    • Чтобы запустить пакетный файл после сбоя, укажите в параметре command=: cmd.exe диск:\имя_файла.bat, где диск:\имя_файла.bat — полное имя пакетного файла.
    • Чтобы запустить файл VBS после сбое, для параметра command= укажите следующее: диск:\мой_сценарий.vbs, где диск:\мой_сценарий.vbs — полное имя файла сценария.
    • По возможности определите три различных действия для параметра actions=, которые будут использоваться при первом, втором и третьем отказах службы.
    • Если между параметром и его значением имеется пробел (например type= own вместо type=own) произойдет сбой операции.

    Примеры

    Далее приведены примеры использования команды sc failure.

    sc failure msftpsvc reset= 30 actions= restart/5000
    sc failure dfs reset= 60 command= c:\windows\services\restart_dfs.exe actions= run/5000
    sc failure dfs reset= 60 actions= reboot/30000

  • sc failure dfs reset= 60 reboot= "Отказ работы службы распределенной файловой системы (DFS). Поэтому через 30 секунд будет произведена перезагрузка компьютера." actions= reboot/30000
  • sc failure myservice reset= 3600 reboot= "Сбой службы «MyService» — перезагрузка машины" command= "%windir%\MyServiceRecovery.exe" actions= restart/5000/run/10000/reboot/60000

    Получает отображаемое имя определенной службы.

    Синтаксис

    sc [имя_сервера] getdisplayname [имя_службы] [размер_буфера]

    Параметры

    имя_сервера
    Задает имя удаленного сервера, на котором находится служба. В имени следует использовать формат UNC ("\\myserver"). Чтобы запустить SC локально, этот параметр следует пропустить.
    имя_службы
    Указывает имя службы, возвращенное операцией getkeyname.
    размер_буфера
    Задает размер буфера в байтах. Значение по умолчанию равно 1024 байта.
    /?
    Отображает справку в командной строке.

    Примеры

    Далее приведены примеры использования команды sc getdisplayname.

    sc getdisplayname clipsrv
    sc getdisplayname tapisrv
    sc getdisplayname sharedaccess

    Выводит имя раздела, соответствующего определенной службы, используя отображаемое имя как входящие данные.

    Синтаксис

    sc [имя_сервера] getkeyname [отображаемое_имя_службы] [размер_буфера]

    Параметры

    имя_сервера
    Задает имя удаленного сервера, на котором находится служба. В имени следует использовать формат UNC ("\\myserver"). Чтобы запустить SC локально, этот параметр следует пропустить.
    отображаемое_имя_службы
    Указывает отображаемое имя службы.
    размер_буфера
    Задает размер буфера в байтах. Значение по умолчанию равно 1024 байта.
    /?
    Отображает справку в командной строке.

    Примечания

    • Если отображаемое_имя_службы содержит пробелы, его следует заключать в кавычки (т. е. "отображаемое имя службы").

    Примеры

    Далее приведены примеры использования команды sc getkeyname.

    sc getkeyname "удаленный вызов процедур (rpc)"
    sc getkeyname "общий доступ к подключению к Интернету"
    sc getkeyname "папка обмена"

    Посылает службе запрос INTERROGATE.

    Синтаксис

    sc [имя_сервера] interrogate [имя_службы]

    Параметры

    имя_сервера
    Задает имя удаленного сервера, на котором находится служба. В имени следует использовать формат UNC ("\\myserver"). Чтобы запустить SC локально, этот параметр следует пропустить.
    имя_службы
    Указывает имя службы, возвращенное операцией getkeyname.
    /?
    Отображает справку в командной строке.

    Примечания

    • Отправление запроса INTERROGATE влечет за собой обновление состояния службы с помощью диспетчера служб.

    Примеры

    Далее приведены примеры использования команды sc interrogate.

    sc interrogate sharedaccess
    sc interrogate rpcss

    Блокирует базу данных диспетчера служб.

    Синтаксис

    sc [имя_сервера] lock

    Параметры

    имя_сервера
    Задает имя удаленного сервера, на котором находится служба. В имени следует использовать формат UNC ("\\myserver"). Чтобы запустить SC локально, этот параметр следует пропустить.
    /?
    Отображает справку в командной строке.

    Примечания

    • Блокирование базы данных диспетчера служб препятствует запуску любой службы. Используйте эту операцию, чтобы убедиться, что служба не будет запущена после остановки. Это позволяет выполнить некоторые действия (например, удалить службу) без помех.
    • Использование операции lock приводит к блокированию базы данных диспетчера служб; ввод u позволяет разблокировать базу данных. Имеется возможность удалить процесс, из которого была блокирована база данных.

    Примеры

    Далее приведены примеры использования команды sc lock.

    sc lock

    Посылает службе запрос PAUSE.

    Синтаксис

    sc [имя_сервера] pause [имя_службы]

    Параметры

    имя_сервера
    Задает имя удаленного сервера, на котором находится служба. В имени следует использовать формат UNC ("\\myserver"). Чтобы запустить SC локально, этот параметр следует пропустить.
    имя_службы
    Указывает имя службы, возвращенное операцией getkeyname.
    /?
    Отображает справку в командной строке.

    Примечания

    • Используйте операцию pause для приостановки службы перед завершением ее работы.
    • Не все службы могут быть приостановлены.
    • Не все службы выполняют одинаковые действия в процессе приостановки. Некоторые продолжают обслуживать текущих клиентов и отказываются принять новых. Другие службы прекращают обслуживать существующих клиентов и отказываются принять новых.

    Примеры

    Далее приведены примеры использования команды sc pause.

    sc pause tapisrv

    Запрашивает сведения о конфигурации службы.

    Синтаксис

    sc [имя_сервера] qc [имя_службы] [размер_буфера]

    Параметры

    имя_сервера
    Задает имя удаленного сервера, на котором находится служба. В имени следует использовать формат UNC ("\\myserver"). Чтобы запустить SC локально, этот параметр следует пропустить.
    имя_службы
    Указывает имя службы, возвращенное операцией getkeyname.
    размер_буфера
    Задает размер буфера в байтах. Значение по умолчанию равно 1024 байта.
    /?
    Отображает справку в командной строке.

    Примечания

    • С помощью операции qc на экран выводится следующая информация о службе: SERVICE_NAME (имя раздела реестра для службы), TYPE, ERROR_CONTROL, BINARY_PATH_NAME, LOAD_ORDER_GROUP, TAG, DISPLAY_NAME, DEPENDENCIES и SERVICE_START_NAME.

    • Администратор может использовать SC, чтобы определить двоичное имя любой службы и выяснить, использует ли служба процесс совместно с другими службами. Для этого введите следующую команду:

      sc qc имя_службы

      С помощью SC можно сопоставить службы в узле «Службы» консоли ММС процессам в программе «Системный монитор». Если двоичное имя службы — Services.exe, значит, служба имеет общий доступ к процессу контроллера службы.

      Services.exe запускает все службы. Чтобы сэкономить системные ресурсы, несколько служб Win32, разработанные для Windows, совместно используют процесс Services.exe. Эти службы не указаны в качестве отдельных процессов в средствах «Системный монитор» и «Диспетчер задач». Это верно и для процесса Svchost.exe, являющийся базовым процессом службы, который совместно используется множеством работающих служб.

      Может не существовать процесса для каждой службы Win32, потому что третья часть этих служб настроена на совместное использование процессов. SC можно использовать для получения сведений о конфигурации этих служб. Если служба не использует процесс совместно с другими службами, в программе «Системный монитор» во время выполнения службы существует процесс для нее.

    • Команды SС полезны разработчикам служб, потому что предоставляют более подробные и точные сведения о службах, чем программа Services.exe, которая включена в Windows. Services.exe определяет запущена служба, остановлена или приостановлена. Хотя этих средств достаточно для отлаженного приложения, которое выполняется безошибочно, сведения, предоставляемые ими о разработанной службе, могут ввести в заблуждение. Например, служба, которая запускается, отображена как запущенная, независимо от того, действительно ли она выполняется или нет.

      SC реализует вызовы ко всем функциям интерфейса API управления службами Windows. Настроить параметры для этих функций можно, задав их в командной строке.

      С помощью средства SC имеется возможность запросить состояние службы и получить значения, хранящиеся в полях структуры состояний. Services.exe не выводит полное состояние службы, а средства SC отображают точное состояние службы, а также номер последней контрольной точки и сведения о состоянии ожидания. Контрольную точку можно использовать как средство отладки, потому что она показывает путь инициализации до момента, когда программа перестала отвечать. SC позволяет задавать имя удаленного компьютера, что дает возможность вызвать функции интерфейса API службы и посмотреть структуры состояния службы на удаленном компьютере.

    Примеры

    Далее приведены примеры использования команды sc qc.

    sc qc \\myserver newsrvice
    sc qc rpcss 248

    Выводит на экран строку описания службы.

    Синтаксис

    sc [имя_сервера] qdescription [имя_службы] [размер_буфера]

    Параметры

    имя_сервера
    Задает имя удаленного сервера, на котором находится служба. В имени следует использовать формат UNC ("\\myserver"). Чтобы запустить SC локально, этот параметр следует пропустить.
    имя_службы
    Указывает имя службы, возвращенное операцией getkeyname.
    размер_буфера
    Задает размер буфера в байтах. Значение по умолчанию равно 1024 байта.
    /?
    Отображает справку в командной строке.

    Примеры

    Далее приведены примеры использования команды sc qdescription.

    sc qdescription rpcss
    sc qdescription rpcss 138

    Выводит на экран действия, которые будут выполняться при отказе работы службы.

    Синтаксис

    sc [имя_сервера] qfailure [имя_службы] [размер_буфера]

    Параметры

    имя_сервера
    Задает имя удаленного сервера, на котором находится служба. В имени следует использовать формат UNC ("\\myserver"). Чтобы запустить SC локально, этот параметр следует пропустить.
    имя_службы
    Указывает имя службы, возвращенное операцией getkeyname.
    размер_буфера
    Задает размер буфера в байтах. Значение по умолчанию равно 1024 байта.
    /?
    Отображает справку в командной строке.

    Примечания

    • Операция qfailure выводит на экран следующие сведения о службе: SERVICE_NAME (имя раздела реестра для службы), RESET_PERIOD, REBOOT_MESSAGE, COMMAND_LINE и FAILURE_ACTIONS.

    Примеры

    Далее приведены примеры использования команды sc qfailure.

    sc qfailure rpcss
    sc qfailure rpcss 20

    Получает и отображает сведения о конкретной службе, драйвере, типе службы или типе драйвера.

    Синтаксис

    sc [имя_сервера] query [имя_службы] [type= {driver|service|all}] [type= {own|share|interact|kernel|filesys|rec|adapt}] [state= {active|inactive|all}] [bufsize= размер_буфера] [ri= индекс_возобновления] [group= имя_группы]

    Параметры

    имя_сервера
    Задает имя удаленного сервера, на котором находится служба. В имени следует использовать формат UNC ("\\myserver"). Чтобы запустить SC локально, этот параметр следует пропустить.
    имя_службы
    Указывает имя службы, возвращенное операцией getkeyname. Данный параметр операции query не используется совместно с другими параметрами этой операции (отличными от параметра имя_сервера).
    type= {driver|service|all}
    Указывает объекты для перечисления. Тип по умолчанию service.
    Значение | Описание
    driver | Указывает перечисление только драйверов
    service | Указывает перечисление только служб
    all | Указывает перечисление драйверов и служб
    type= {own|share|interact|kernel|filesys|rec|adapt}
    Указывает тип драйверов и тип служб для перечисления.
    Значение | Описание
    own | Служба выполняется в собственном процессе. Она не использует исполняемый файл совместно с другими службами. Эта установка используется по умолчанию
    share | Служба выполняется как общий процесс. Она использует исполняемый файл совместно с другими службами
    interact | Служба может взаимодействовать с рабочим столом, получая входные данные от пользователей. Интерактивные службы должны выполняться с системной учетной записью
    kernel | Драйвер
    filesys | Драйвер файловой системы
    state= {active|inactive|all}
    Указывает состояние запуска службы, которая включается в перечисление. По умолчанию active.
    Значение | Описание
    active | Указывает все активные службы
    inactive | Указывает все приостановленные или остановленные службы
    all | Указывает все службы
    bufsize= размер_буфера
    Задает размер буфера перечисления в байтах. По умолчанию размер пакета равен 1024 байтам. Увеличьте размер буфера перечисление, когда вывод результатов запроса превышает 1024 байтов.
    ri= индекс_возобновления
    Указывает номер индекса, с которого начинается или возобновляется перечисление. Номер по умолчанию равен 0. Когда в ответ на запрос выведено больше сведений, чем буфер может отобразить по умолчанию, используйте данный параметр совместно с параметром bufsize=.
    group= имя_группы
    Указывает группу служб для перечисления. По умолчанию выбираются все группы.
    /?
    Отображает справку в командной строке.

    Примечания

    • Если между параметром и его значением имеется пробел (например type= own вместо type=own) произойдет сбой операции.
    • Операция query отображает следующие сведения о службе: SERVICE_NAME (имя раздела реестра для службы), TYPE, STATE (а также состояния, которые недоступны), WIN32_EXIT_B, SERVICE_EXIT_B, CHECKPOINT и WAIT_HINT.
    • В некоторых случаях параметр type= может использоваться дважды. Первое появление параметра type= указывает, следует ли запрашивать службы, драйверы или и то и другое. Второе появление параметра type= указывает тип из операции create для дальнейшего сужения области запроса.
    • Когда вывод результата команды query превышает размер буфера перечисления, выводится следующее сообщение:

      Enum: more data, need 1822 bytes start resume at index 79

      Чтобы вывести на экран оставшиеся сведения результата команды query, повторно выполните команду query, указав в параметре bufsize= количество байтов и конкретный индекс в параметре ri=. Например, оставшиеся выходные данные можно вывести на экран с помощью следующей команды.

      sc query bufsize= 1822 ri= 79

    Примеры

    Далее приведены примеры использования команды sc query.

    sc query
    sc query messenger
    sc query type= driver
    sc query type= service
    sc query state= all
    sc query bufsize= 50
    sc query ri= 14
    sc query type= service type= interact
    sc query type= driver group= ndis

    Получает и отображает подробные сведения о конкретной службе, драйвере, типе службы или типе драйвера.

    Синтаксис

    sc [имя_сервера] queryex [type= {driver|service|all}] [type= {own|share|interact|kernel|filesys|rec|adapt}] [state= {active|inactive|all}] [bufsize= размер_буфера] [ri= индекс_возобновления] [group= имя_группы]

    Параметры

    имя_сервера
    Задает имя удаленного сервера, на котором находится служба. В имени следует использовать формат UNC ("\\myserver"). Чтобы запустить SC локально, этот параметр следует пропустить.
    имя_службы
    Указывает имя службы, возвращенное операцией getkeyname. Данный параметр операции queryex не используется совместно с другими параметрами этой операции (отличными от параметра имя_сервера).
    type= {driver|service|all}
    Указывает объекты для перечисления. Тип по умолчанию service.
    Значение | Описание
    driver | Указывает перечисление только драйверов
    service | Указывает перечисление только служб
    all | Указывает перечисление драйверов и служб
    type= {own|share|interact|kernel|filesys|rec|adapt}
    Указывает тип драйверов и тип служб для перечисления.
    Значение | Описание
    own | Служба выполняется в собственном процессе. Она не использует исполняемый файл совместно с другими службами. Эта установка используется по умолчанию
    share | Служба выполняется как общий процесс. Она использует исполняемый файл совместно с другими службами
    interact | Служба может взаимодействовать с рабочим столом, получая входные данные от пользователей. Интерактивные службы должны выполняться с системной учетной записью
    kernel | Драйвер
    filesys | Драйвер файловой системы
    state= {active|inactive|all}
    Указывает состояние запуска службы, которая включается в перечисление. По умолчанию active.
    Значение | Описание
    active | Указывает все активные службы
    inactive | Указывает все приостановленные или остановленные службы
    all | Указывает все службы
    bufsize= размер_буфера
    Задает размер буфера перечисления в байтах. По умолчанию размер пакета равен 1024 байтам.
    ri= индекс_возобновления
    Указывает номер индекса, с которого начинается или возобновляется перечисление. По умолчанию — 0.
    group= имя_группы
    Указывает группу служб для перечисления. По умолчанию выбираются все группы.
    /?
    Отображает справку в командной строке.

    Примечания

    • Если между параметром и его значением имеется пробел (например type= own вместо type=own) произойдет сбой операции.
    • Операция queryex отображает следующие сведения о службе: SERVICE_NAME (имя раздела реестра для службы), TYPE, STATE (а также состояния, которые недоступны), WIN32_EXIT_B, SERVICE_EXIT_B, CHECKPOINT, WAIT_HINT, PID и FLAGS.
    • В некоторых случаях параметр type= может использоваться дважды. Первое появление параметра type= указывает, следует ли запрашивать службы, драйверы или и то и другое. Второе появление параметра type= указывает тип из операции create для дальнейшего сужения области запроса.
    • Когда вывод результата команды queryex превышает размер буфера перечисления, выводится следующее сообщение:

      Enum: more data, need 2130 bytes start resume at index 75

      Чтобы вывести на экран оставшиеся сведения результата команды queryex, повторно выполните команду queryex, указав в параметре bufsize= количество байтов и конкретный индекс в параметре ri=. Например, оставшиеся выходные данные можно вывести на экран с помощью следующей команды.

      sc queryex bufsize= 2130 ri= 75

    Примеры

    Далее приведены примеры использования команды sc queryex.

    sc queryex messenger
    sc queryex group= ""

    Запрашивает и отображает состояние блокировки базы данных диспетчера служб.

    Синтаксис

    sc [имя_сервера] querylock

    Параметр

    имя_сервера
    Задает имя удаленного сервера, на котором находится служба. В имени следует использовать формат UNC ("\\myserver"). Чтобы запустить SC локально, этот параметр следует пропустить.
    /?
    Отображает справку в командной строке.

    Задает дескриптор безопасности службы с помощью SDDL.

    Синтаксис

    sc [имя_сервера] sdset имя_службы дескриптор_безопасности_службы

    Параметры

    имя_сервера
    Задает имя удаленного сервера, на котором находится служба. В имени следует использовать формат UNC ("\\myserver"). Чтобы запустить SC локально, этот параметр следует пропустить.
    имя_службы
    Указывает имя службы, возвращенное операцией getkeyname.
    дескриптор_безопасности_службы
    Задает дескриптор службы в SDDL.
    /?
    Отображает справку в командной строке.

    Отображает дескриптор безопасности службы с помощью SDDL.

    Синтаксис

    sc [имя_сервера] sdshow имя_службы

    Параметры

    имя_сервера
    Задает имя удаленного сервера, на котором находится служба. В имени следует использовать формат UNC ("\\myserver"). Чтобы запустить SC локально, этот параметр следует пропустить.
    имя_службы
    Указывает имя службы, возвращенное операцией getkeyname.
    /?
    Отображает справку в командной строке.

    Примеры

    sc sdshow rpcss

    Служит для запуска службы.

    Синтаксис

    sc [имя_сервера] start имя_службы [аргументы_службы]

    Параметры

    имя_сервера
    Задает имя удаленного сервера, на котором находится служба. В имени следует использовать формат UNC ("\\myserver"). Чтобы запустить SC локально, этот параметр следует пропустить.
    имя_службы
    Указывает имя службы, возвращенное операцией getkeyname.
    аргументы_службы
    Задает аргументы службы, которые надо выполнить для запуска службы.
    /?
    Отображает справку в командной строке.

    Примеры

    Далее приведены примеры использования команды sc start.

    sc start tapisrv

    Посылает службе запрос STOP.

    Синтаксис

    sc [имя_сервера] stop имя_службы

    Параметры

    имя_сервера
    Задает имя удаленного сервера, на котором находится служба. В имени следует использовать формат UNC ("\\myserver"). Чтобы запустить SC локально, этот параметр следует пропустить.
    имя_службы
    Указывает имя службы, возвращенное операцией getkeyname.
    /?
    Отображает справку в командной строке.

    Примечания

    • Не все службы могут быть приостановлены.

    Примеры

    Далее приведены примеры использования команды sc stop.

    sc stop tapisrv


Schtasks

Настраивает выполнение команд и программ через заданные интервалы или в указанное время. Добавляет и удаляет задания из расписания, запускает и останавливает задания по требованию, отображает и изменяет назначенные задания.

Создает новое назначенное задание.

Синтаксис

schtasks /create /tn имя_задания /tr выполнение_задания /sc расписание [/mo модификатор] [/d день] [/m месяц[,месяц...] [/i время_простоя] [/st время_запуска] [/sd дата_запуска] [/ed дата_окончания] [/s компьютер [/u [домен\]пользователь /p пароль]] [/ru {[домен\]пользователь | "System"} [/rp пароль]] /?

Параметры

/tn имя_задания
Определяет имя для задания.
/tr выполнение_задания
Указывает программу или команду, которая выполняет задание. Введите полный путь и имя исполняемого файла, файла сценария или пакетного файла. Если пропущен путь, программа SchTasks.exe предполагает, что файл находится в системном_корневом_каталоге\System32.
/sc расписание
Задает тип расписания. Допустимыми значениями являются ЕЖЕМИНУТНО, ЕЖЕЧАСНО, ЕЖЕДНЕВНО, ЕЖЕНЕДЕЛЬНО, ЕЖЕМЕСЯЧНО, ОДНОКРАТНО, ПРИ ЗАПУСКЕ, ПРИ ВХОДЕ В СИСТЕМУ, ПРИ ПРОСТОЕ.
Значение | Описание
ЕЖЕМИНУТНО, ЕЖЕЧАСНО, ЕЖЕДНЕВНО, ЕЖЕНЕДЕЛЬНО, ЕЖЕМЕСЯЧНО | Определяют единицу времени для расписания
ОДНОКРАТНО | Задание выполняется один раз в указанное время и дату
ПРИ ЗАПУСКЕ | Задание выполняется каждый раз при запуске системы. Можно указать дату запуска или выполнить задание в следующий раз при запуске системы
ПРИ ВХОДЕ В СИСТЕМУ | Задание выполняется каждый раз при входе пользователя (любого) в систему. Можно указать дату запуска или выполнить задание в следующий раз при входе пользователя в систему
ПРИ ПРОСТОЕ | Задание выполняется каждый раз при простое компьютера в течение заданного промежутка времени. Можно указать дату запуска или выполнить задание в следующий раз при простое компьютера
/mo модификатор
Определяет частоту выполнения команды в соответствии с его типом расписания. Этот параметр обязателен для расписания ЕЖЕМЕСЯЧНО. Параметр является допустимым, но необязательным для расписаний ЕЖЕМИНУТНО, ЕЖЕЧАСНО, ЕЖЕДНЕВНО или ЕЖЕНЕДЕЛЬНО. По умолчанию значение равно 1.
Тип расписания | Модификатор | Описание
ЕЖЕМИНУТНО | 1 - 1439 | Задание выполняется через каждые n минут.
ЕЖЕЧАСНО | 1 - 23 | Задание выполняется через каждые n часов.
ЕЖЕДНЕВНО | 1 - 365 | Задание выполняется через каждые n дней.
ЕЖЕНЕДЕЛЬНО | 1 - 52 | Задание выполняется через каждые n недель.
ЕЖЕМЕСЯЧНО | 1 - 12 | Задание выполняется через каждые n месяцев.
 | ПОСЛЕДНИЙ | Задание выполняется в последний день месяца.
 | ПЕРВЫЙ, ВТОРОЙ, ТРЕТИЙ, ЧЕТВЕРТЫЙ, ПОСЛЕДНИЙ | При использовании с параметром /d день задание выполняется в определенный день недели. Например, в третью среду месяца.
/d день
Указывает день недели и день месяца. Параметр допустим только с расписаниями ЕЖЕНЕДЕЛЬНО или ЕЖЕМЕСЯЧНО.
Тип расписания | Значение дня
ЕЖЕНЕДЕЛЬНО | Необязательно. Допустимые значения — с ПН по ВС и *(каждый день). По умолчанию установлено значение ПН
ЕЖЕМЕСЯЧНО | Значения ПН — ВС требуются, когда используется модификатор (/mo) ПЕРВЫЙ, ВТОРОЙ, ТРЕТИЙ, ЧЕТВЕРТЫЙ ИЛИ ПОСЛЕДНИЙ. Значения 1 — 31 являются необязательными и допустимы, только если модификатора нет или тип его 1 — 12. По умолчанию установлено значение 1 (первый день месяца).
/m месяц[,месяц...]
Указывает месяц года. Допустимые значения — с ЯНВ по ДЕК и * (каждый месяц). Параметр /m действителен только для расписания ЕЖЕМЕСЯЧНО. Параметр требуется при использовании модификатора ПОСЛЕДНИЙ. В других случаях он является необязательным. Значение по умолчанию *(каждый месяц).
/i время_простоя
Указывает интервал времени простоя компьютера (в минутах) до начала выполнения задания. Введите любое число от 1 до 999. Параметр допустим только с расписанием ПРИ ПРОСТОЕ, в этом случае он обязателен.
/st время_запуска
Задает время начала выполнения задания в 24-часовом формате в виде чч:мм:сс. По умолчанию установлено локальное время, когда команда завершена. Параметр /st является действительным для расписаний типа ЕЖЕМИНУТНО, ЕЖЕДНЕВНО, ЕЖЕНЕДЕЛЬНО, ЕЖЕМЕСЯЧНО и ОДНОКРАТНО . Требуется для расписания ОДНОКРАТНО.
/sd дата_запуска
Задает дату начала выполнения задания в формате мм/дд/гггг. По умолчанию установлено значение текущей даты. Параметр /sd можно использовать со всеми расписаниями. Он требуется для расписания ОДНОКРАТНО.
/ed дата_окончания
Определяет последнюю дату, на которую назначается выполнение команды. Параметр является необязательным. Недопустимо использование с расписаниями типа ОДНОКРАТНО, ПРИ ЗАПУСКЕ, ПРИ ВХОДЕ В СИСТЕМУ, ПРИ ПРОСТОЕ. По умолчанию у расписаний нет даты окончания.
/s компьютер
Задает имя или IP-адрес удаленного компьютера (с обратными косыми чертами или без них). По умолчанию используется локальный компьютер.
/u [домен\]пользователь
Выполняет команду с разрешения указаной учетной записи пользователя. По умолчанию, команда запускается с разрешения пользователя, вошедшего в систему компьютера, на котором выполняется SchTasks.
/p пароль
Задает пароль учетной записи пользователя, указанной параметром /u. Параметр требуется при использовании параметра /u.
/ru {[домен\]пользователь | "System"}
Выполняет задания с разрешения указанной учетной записи пользователя. По умолчанию, начинается выполнение задание с разрешения пользователя, вошедшего в систему компьютера, на котором выполняется SchTasks.
Значение | Описание
[домен\]пользователь | Определяет учетную запись пользователя.
"System" или "" | Указывает учетную запись NT Authority\System, которую использует операционная система.
/rp пароль
Определяет пароль учетной записи пользователя, заданной параметром /ru. Если пропустить этот параметр при указании учетной записи пользователя, программ SchTasks.exe предлагает ввести пароль и скрывает введенный текст. Для заданий, выполняемых с разрешений ученой записи NT Authority\System, не требуется пароль и программа SchTasks.exe не предлагает его ввести.
/?
Отображает справку в командной строке.

Примечания

  • Программа SchTasks.exe не проверяет расположения файлов программ и пароли учетных записей пользователей. Если путь к файлу или пароль учетной записи введен неверно, задание создается, но не выполняется. Также если пароль изменился или истек срок его действия и в сохраненном задании пароль не изменен, задание не выполняется.
  • Учетная запись NT Authority\System не имеет прав интерактивного входа. Пользователи не видят и не могут взаимодействовать с программами, запущенными с разрешений системы.
  • Каждое задание выполняет только одну программу. Однако, можно создать пакетный файл, запускающий несколько заданий, а затем запланировать задание, которое выполняет этот пакетный файл.
  • Имеется возможность протестировать задание сразу же после его создания. Используйте операцию run для тестирования задания и затем проверьте наличие ошибок в файле SchedLgU.txt (системный_корневой_каталог\SchedLgU.txt).

Синтаксис и примеры для каждого типа расписания

Синтаксис

schtasks /create /tn имя_задания /tr выполнение_задания /sc ежеминутно [/mo {1 - 1439}] [/st время_запуска] [/sd дата_запуска] [/ed дата_окончания] [/s компьютер [/u [домен\]пользователь /p пароль]] [/ru {[домен\]пользователь | "System"} [/rp пароль]]

Пример

Чтобы запланировать выполнение задания каждые 20 минут

Следующая команда задает выполнение сценария безопасности Sec.vbs каждые 20 минут. Т. к. в команде не учтена дата запуска и время, задание запускается через 20 минут после завершения команды, и выполняется каждые 20 минут соответственно при работе системы. Следует отметить, что исходный файл сценария безопасности находится на удаленном компьютере, а задание назначается и выполняется на локальном компьютере.

schtasks /create /sc ежеминутно /mo 20 /tn "Сценарий безопасности" /tr \\central\data\scripts\sec.vbs

В результате, SchTasks.exe выводит сообщение, в котором объясняется, что задание будет выполняться с разрешения текущего пользователя, и запрашивается пароль этого пользователя. При вводе пароля SchTasks.exe скрывает вводимый текст.

Задача будет создана под именем текущего пользователя.
Введите пароль:
************

Затем SchTasks.exe выводит на экран сообщение, указывающее, что задание назначено:

УДАЧА. Запланированная задача "Сценарий безопасности" была успешно создана.

Запрос показывает задание, назначенное командой:

Имя задания                  Следующий запуск            Состояние
========================= ======================== ==============
Сценарий безопасности           10:50:00 AM , 15/01/2004

Синтаксис

schtasks /create /tn имя_задания /tr выполнение_задания /sc ежечасно [/mo {1 - 365}] [/st время_запуска] [/sd дата_запуска] [/ed дата_окончания] [/s компьютер [/u [домен\]пользователь /p пароль]] [/ru {[домен\]пользователь | "System"} [/rp пароль]]

Пример

Чтобы запланировать выполнение команды каждый час в пять минут следующего часа

Следующая команда назначает выполнение программы MyApp каждый час, начиная с пяти минут первого ночи. Т. к. параметр /mo пропущен, команда использует значение по умолчанию для часового расписания, т. е. 1 час. Если команда будет запущена после 12:05 А.М., программа не будет выполняться до следующего дня.

schtasks /create /sc ежечасно /st 00:05:00 /tn "My App" /tr c:\apps\myapp.exe

Чтобы запланировать выполнение команды каждые 5 часов

Следующая команда назначает выполнение программы MyApp через каждые пять часов, начиная с первого марта 2001 года. Параметр /mo используется для задания интервала, а параметр /sd — для задания даты запуска. В команде не указано время запуска, поэтому для него используется текущее время.

schtasks /create /sc ежечасно /mo 5 /sd 15/01/2004 /tn "My App" /tr c:\apps\myapp.exe

Синтаксис

schtasks /create /tn имя_задания /tr выполнение_задания /sc ежедневно [/mo {1 - 365}] [/st время_запуска] [/sd дата_запуска] [/ed дата_окончания] [/s компьютер [/u [домен\]пользователь /p пароль]] [/ru {[домен\]пользователь | "System"} [/rp пароль]]

Пример

Чтобы запланировать выполнение задания каждый день

Следующий пример назначает запуск программы MyApp один раз в день, каждый день в 8:00 А.М. до 31-го декабря 2001 года. Параметр /mo пропущен, поэтому для выполнения программы каждый день используется значение интервала по умолчанию, равное 1.

schtasks /create /tn "My App" /tr c:\apps\myapp.exe /sc ежедневно /st 08:00:00 /ed 15/01/2004

Чтобы запланировать выполнение задания каждые несколько дней

Следующая команда назначает выполнение программы MyApp каждые несколько дней в 1:00 Р.М. (13:00), начиная с 31-го декабря 2003 года. Параметр /mo используется для задания интервала в 2 дня.

schtasks /create /tn "My App" /tr c:\apps\myapp.exe /sc ежедневно /mo 2 /st 13:00:00 /sd 15/01/2004

Синтаксис

schtasks /create /tn имя_задания /tr выполнение_задания /sc еженедельно [/d {ПН — ВС | *}] [/mo {1 - 52}] [/st время_запуска] [/sd дата_запуска] [/ed дата_окончания] [/s компьютер [/u [домен\]пользователь /p пароль]] [/ru {[домен\]пользователь | "System"} [/rp пароль]]

Пример

Чтобы запланировать выполнение задания каждые шесть недель

Следующая команда назначает запуск программы MyApp на удаленном компьютере каждые шесть недель. Параметр /mo используется для задания интервала. Применяются также параметры /s, чтобы указать удаленный компьютер, и /ru, чтобы назначить выполнение задания с разрешения учетной записи администратора. Параметр /rp пропущен, поэтому SchTasks.exe предлагает ввести пароль учетной записи администратора.

Команда запускается удаленно, поэтому все пути в команде, включая путь к файлу MyApp.exe, указываются на удаленном компьютере.

schtasks /create /tn "My App" /tr c:\apps\myapp.exe /sc еженедельно /mo 6 /s Server16 /ru Admin01

Чтобы запланировать выполнение задания каждые несколько недель по пятницам

Следующая команда назначает запуск задания по пятницам раз в несколько недель. Параметр /mo используется для определения двухнедельного интервала, а параметр /d для указания дня недели. Чтобы задание запускалось каждую пятницу, пропустите параметр /mo или установите его значение равным 1.

schtasks /create /tn "My App" /tr c:\apps\myapp.exe /sc еженедельно /mo 2 /d ПТ

Синтаксис

Общий синтаксис ежемесячного расписания
schtasks /create /tn имя_задания /tr выполнение_задания /sc ежемесячно [/mo {ПЕРВЫЙ | ВТОРОЙ | ТРЕТИЙ | ЧЕТВЕРТЫЙ | ПОСЛЕДНИЙ | ПОСЛЕДНИЙ] [/d {ПН - ВС | 1 - 31}] [/m {ЯНВ - ДЕК[,ЯНВ - ДЕК...] | *}] [/st время_запуска] [/sd дата_запуска] [/ed дата_окончания] [/s компьютер [/u [домен\]пользователь /p пароль]] [/ru {[домен\]пользователь | "System"} [/rp пароль]]
Синтаксис для конкретной недели
schtasks /create /tn имя_задания /tr выполнение_задания /sc ежемесячно /mo {ПЕРВЫЙ | ВТОРОЙ | ТРЕТИЙ | ЧЕТВЕРТЫЙ | ПОСЛЕДНИЙ} /d {ПН - ВС} [/m {ЯНВ - ДЕК[,ЯНВ - ДЕК...] | *}] [/st время_запуска] [/sd дата_запуска] [/ed дата_окончания] [/s компьютер [/u [домен\]пользователь /p пароль]] [/ru {[домен\]пользователь | "System"} [/rp пароль]]
Синтаксис для последнего дня месяца
schtasks /create /tn имя_задания /tr выполнение_задания /sc ежемесячно /mo ПОСЛЕДНИЙ /m {ЯНВ - ДЕК[,ЯНВ - ДЕК...] | *} [/st время_запуска] [/sd дата_запуска] [/ed дата_окончания] [/s компьютер [/u [домен\]пользователь /p пароль]] [/ru {[домен\]пользователь | "System"} [/rp пароль]]
Синтаксис для конкретной даты
schtasks /create /tn имя_задания /tr выполнение_задания /sc ежемесячно /d {1 - 31} [/m {ЯНВ - ДЕК[,ЯНВ - ДЕК...] | *}] [/st время_запуска] [/sd дата_запуска] [/ed дата_окончания] [/s компьютер [/u [домен\]пользователь /p пароль]] [/ru {[домен\]пользователь | "System"} [/rp пароль]]

Примеры

Чтобы назначить задание на первый день каждого месяца

Следующая команда планирует выполнение программы MyApp в первый день каждого месяца. Модификатора по умолчанию нет, день по умолчанию — первый, а месяц по умолчанию — каждый месяц, поэтому для команды не нужны дополнительные параметры.

schtasks /create /tn "My App" /tr c:\apps\myapp.exe /sc ежемесячно

Чтобы назначить задание на последний день каждого месяца

Следующая команда планирует выполнение программы MyApp в последний день каждого месяца. Параметр /mo используется для указания последнего дня месяца, а параметр /m c подстановочным знаком (*) означает, что программа запускается в последний день каждого месяца.

schtasks /create /tn "My App" /tr c:\apps\myapp.exe /sc ежемесячно /mo последний /m *

Чтобы запланировать выполнение задания каждые три месяца

Следующая команда назначает запуск программы MyApp через каждые три месяца. Параметр /mo используется для задания интервала.

schtasks /create /tn "My App" /tr c:\apps\myapp.exe /sc ежемесячно /mo 3

Чтобы назначить задание на второе воскресенье каждого месяца

Следующая команда планирует выполнение программы MyApp во второе воскресенье каждого месяца. Параметр /mo используется для определения второй недели, а параметр /d для указания дня недели.

schtasks /create /tn "My App" /tr c:\apps\myapp.exe /sc ежемесячно /mo ВТОРОЙ /d ВС

Чтобы назначить задание на 15-е число мая и июня

Следующая команда задает выполнение программы MyApp 15-го мая и 15-го июня в 3:00 РМ (15:00). Параметр /d используется для определения даты, параметр /m — для задания месяцев. В команде учитывается параметр /st для указания времени запуска.

schtasks /create /tn "My App" /tr c:\apps\myapp.exe /sc ежемесячно /d 15 /m МАЙ,ИЮН /st 15:00:00

Синтаксис

schtasks /create /tn имя_задания /tr выполнение_задания /sc однократно /st время_запуска /sd дата_запуска [/s компьютер [/u [домен\]пользователь /p пароль]] [/ru {[домен\]пользователь | "System"} [/rp пароль]]

Пример

Чтобы запланировать выполнение задания один раз

Следующая команда назначает запуск программы MyApp в полночь 1-го января 2002 года. Параметр /ru используется для выполнения задания с разрешения учетной записи администратора, параметр /rp предоставляет пароль для учетной записи администратора.

  • schtasks /create /tn "My App" /tr c:\apps\myapp.exe /sc однократно /st 00:00:00 /sd 01/01/2002 /ru Admin23 /rp p@ssworD1

    Синтаксис

    schtasks /create /tn имя_задания /tr выполнение_задания /sc при запуске [/sd дата_запуска] [/s компьютер [/u [домен\]пользователь /p пароль]] [/ru {[домен\]пользователь | "System"} [/rp пароль]]

    Пример

    Чтобы запланировать выполнение задания каждый раз при запуске системы

    Следующая команда назначает выполнение программы MyApp каждый раз при запуске системы, начиная с 15-го марта 2001 года.

    schtasks /create /tn "My App" /tr c:\apps\myapp.exe /sc при запуске /sd 03/15/2001

    Синтаксис

    schtasks /create /tn имя_задания /tr выполнение_задания /sc при входе в систему [/sd дата_запуска] [/s компьютер [/u [домен\]пользователь /p пароль]] [/ru {[домен\]пользователь | "System"} [/rp пароль]]

    Пример

    Чтобы запланировать выполнение задания, когда пользователь входит в систему на удаленном компьютере

    Следующая команда назначает запуск пакетного файла каждый раз при входе пользователя (любого) в систему на удаленном компьютере. Для указания удаленного компьютера в команде используется параметр /s. Все пути в команде, включая путь к пакетному файлу, должны быть указаны для удаленного компьютера, потому что данная команда — команда удаленной системы.

    schtasks /create /tn "Запустить веб-узел" /tr c:\myiis\webstart.bat /sc при входе в систему /s Server23

    Синтаксис

    schtasks /create /tn имя_задания /tr выполнение_задания /sc при простое /i время_простоя [/sd дата_запуска] [/s компьютер [/u [домен\]пользователь /p пароль]] [/ru {[домен\]пользователь | "System"} [/rp пароль]]

    Пример

    Чтобы запланировать выполнение задания каждый раз во время простоя компьютера

    Следующая команда назначает запуск программы MyApp каждый раз во время простоя компьютера. Необходимый параметр /i используется в команде, чтобы указать, что компьютер должен простаивать в течение 10 минут перед запуском задания.

    schtasks /create /tn "My App" /tr c:\apps\myapp.exe /sc при простое /i 10

    Еще примеры

    Чтобы создать задание, которое выполняется с разрешений системы

    Следующая команда назначает запуск программы MyApp с разрешений учетной записи NT Authority\System. В этом примере, назначено выполнение задания 1-го числа каждого месяца, но можно использовать любой тип расписания для запуска программы с разрешениями системы.

    В команде используется параметр /ru "System", чтобы определить контекст безопасности системы. Параметр /rp пропущен, потому что системные задания не используют пароль

    schtasks /create /tn "My App" /tr c:\apps\myapp.exe /sc ежемесячно /d 1 /ru "System"

    В результате программа SchTasks.exe выведет на экран информационное сообщение и сообщение об успехе. Пароль не запрашивается.

СВЕДЕНИЯ: Задание будет создано под именем текущего пользователя ("NT AUTHORITY\SYSTEM").
УДАЧА. Запланированная задача "My App" была успешно создана.

    Чтобы создать задание, которое запускает несколько программ

    Каждое задание выполняет только одну программу. Однако, можно создать пакетный файл, запускающий несколько заданий, а затем запланировать задание, которое выполняет этот пакетный файл. Следующая процедура представляет этот метод.

    1. Создайте пакетный файл, запускающих необходимые программы.

      В данном примере создан пакетный файл, который запускает программы «Просмотр событий» (Eventvwr.exe) и «Системный монитор» (Perfmon.exe).

      • Откройте текстовый редактор, например «Блокнот».
      • Введите имя и полный путь к выполняемому файлу для каждой программы. В данном случае файл включает следующие строки:

        C:\Windows\System32\Eventvwr.exe
        C:\Windows\System32\Perfmon.exe

      • Сохраните файл как MyApps.bat.
    2. Используете программу SchTasks.exe для создания задания, которое запускает MyApps.bat.

      Следующая команда создает задание «Монитор», которое выполняется каждый раз при входе любого пользователя в систему. В команде используется параметр /tn для имени задачи, параметр /tr для запуска файла MyApps.bat. Параметр /sc указывает тип расписания OnLogon, а параметр /ru задает учетную запись администратора.

      schtasks /create /tn Монитор /tr C:\MyApps.bat /sc при входе в систему /ru Reskit\Administrator

      В результате этой команды каждый раз при входе пользователя в систему, задание запускает программы «Просмотр событий» и «Системный монитор».

    Изменяет один или несколько следующих параметров задания:

    • программу, которую запускает задание (/tr);
    • учетную запись пользователя, под которой выполняется задание (/ru);
    • пароль ученой записи пользователя (/rp).

    Синтаксис

    schtasks /change /tn имя_задания [/s компьютер [/u [домен\]пользователь /p пароль]] [/tr выполнение_задания] [/ru [домен\]пользователь | "System"] [/rp пароль]

    Параметры

    /tn имя_задания
    Указывает задание, которое требуется изменить. Введите имя задания.
    /s компьютер
    Задает имя или IP-адрес удаленного компьютера (с обратными косыми чертами или без них). По умолчанию используется локальный компьютер.
    /u [домен\]пользователь
    Выполняет команду с разрешения указанной учетной записи пользователя. По умолчанию, команда запускается с разрешения пользователя, вошедшего в систему компьютера, на котором выполняется SchTasks.
    /p пароль
    Задает пароль учетной записи пользователя, указанной параметром /u. Параметр требуется при использовании параметра /u.
    /tr выполнение_задания
    Изменяет программу, которую запускает задание. Введите полный путь и имя исполняемого файла, файла сценария или пакетного файла. Если пропущен путь, программа SchTasks.exe предполагает, что файл находится в системном_корневом_каталоге\System32. Указанная программа заменяет исходную программу, выполняемую заданием.
    /ru [домен\]пользователь | "System"
    Изменяет учетную запись пользователя для этого задания.
    Значение | Описание
    [домен\]пользователь | Определяет учетную запись пользователя.
    "System" или "" | Указывает учетную запись NT Authority\System, которую использует операционная система.

    Когда меняется учетная запись пользователя, необходимо также сменить пароль. Если в команде есть параметр /ru, но не присутствует параметр /rp, SchTasks.exe предлагает ввести новый пароль и скрывает вводимый текст.

    Для заданий, выполняемых с разрешений ученой записи NT Authority\System, не требуется пароль и программа SchTasks.exe не предлагает его ввести.

    /rp пароль
    Изменяет пароль учетной записи пользователя для этого задания. Введите новый пароль.
    /?
    Отображает справку в командной строке.

    Примечания

    • Параметры /tn и /s определяют задание. Параметры /tr, /ru и /rp задают свойства задания, которые можно изменить.
    • В команде, в которой используется операция change, должно измениться хотя бы одно свойство задания.
    • Учетная запись NT Authority\System не имеет прав интерактивного входа. Пользователи не видят и не могут взаимодействовать с программами, запущенными с разрешений системы.

    Примеры

    Чтобы изменить программу, которую запускает задание

    Следующая команда изменяет программу, которую выполняет задание «Virus Check», с VirusCheck.exe на VirusCheck2.exe. Параметр /tn используется в команде для идентификации задания, параметр /tr для указания новой программ для этого задания. (Невозможно изменить имя задания.)

    schtasks /change /tn "Virus Check" /tr C:\VirusCheck2.exe

    В ответ, команда SchTasks.exe выводит следующее сообщение об успешной операции:

    УДАЧА. Параметры запланированной задачи "Virus Check" были изменены.

    В результате выполнения команды, задание «Virus Check» тут же запускает VirusCheck2.exe.

    Чтобы изменить пароль для удаленного задания

    Следующая команда изменяет пароль учетной записи пользователя для задания «RemindMe» на удаленном компьютере «Svr01». Параметр /tn используется в команде для идентификации задания, параметр /s для указания удаленного компьютера. Параметр /rp задает новый пароль : p@ssWord3.

    Процедуру требуется выполнять каждый раз при истечении срока действия или изменении учетной записи пользователя. Если пароль, сохраненный в задании, недопустим, задание не выполняется.

    schtasks /change /tn RemindMe /s Svr01 /rp p@ssWord3

    В ответ, команда SchTasks.exe выводит следующее сообщение об успешной операции:

    УДАЧА. Параметры запланированной задачи "RemindMe" были изменены.

    В результате команды, задание «RemindMe» выполняется под исходной учетной записью пользователя, но с новым паролем.

    Чтобы изменить программу и учетную запись пользователя для задания

    Следующая команда изменяет запускаемую программу и учетную запись пользователя, под которой выполняется задание. По существу, используется старое расписание для нового задания. Данная команда изменяет задание «Блокнот», которое запускает Notepad.exe каждое утро в 09:00 а.m., на запуск Internet Explorer.

    Параметр /tn используется для идентификации задания. Параметр /tr меняет запускаемую программу, а параметр /ru — учетную запись пользователя, под которой выполняется данное задание.

    Параметр /rp, представляющий пароль учетной записи, пропущен. Необходимо указать пароль для учетной записи: можно использовать параметр /rp и ввести пароль явно или подождать, пока программа SchTasks.exe предложит ввести пароль, и затем задать его в скрытом тексте.

    schtasks /change /tn Блокнот /tr "c:\program files\Internet Explorer\iexplore.exe" /ru DomainX\Admin01

    В ответ, SchTasks.exe запрашивает пароль учетной записи пользователя. Вводимый текст скрывается так, что пароль незаметен.

    Введите пароль для DomainX\Admin01: *********

    Обратите внимание, что параметр /tn идентифицирует задание, а параметры /tr и /ru изменяют свойства задания. Нельзя использовать другой параметр для идентификации задания и изменения его имени.

    В ответ, команда SchTasks.exe выводит следующее сообщение об успешной операции:

    УДАЧА. Параметры запланированной задачи "Блокнот" были изменены.

    В результате команды, задание «Блокнот» выполняется под новой учетной записью пользователя и запускает другую программу.

    Чтобы изменить программу для системной учетной записи

    Данная команда изменяет задание «SecurityScript» так, что оно выполняется с разрешения учетной записи NT Authority\System. Параметр /ru "" в команде указывает системную учетную запись.

    schtasks /change /tn SecurityScript /ru ""

    В ответ, команда SchTasks.exe выводит следующее сообщение об успешной операции:

    Удача. Параметры запланированной задачи "SecurityScript" были изменены.

    SchTasks.exe не предлагает ввести пароль, потому что для заданий, выполняющихся с разрешения системной учетной записи, не требуется пароль.

    Немедленно запускает назначенное задание. Операция run игнорирует расписание, но использует путь к файлу программы, учетную запись пользователя и пароль, сохраненные в задании, чтобы немедленно запустить это задание.

    Синтаксис

    schtasks /run /tn имя_задания [/s компьютер [/u [домен\]пользователь /p пароль]] /?

    Параметры

    /tn имя_задания
    Идентифицирует задание. Параметр обязательный.
    /s компьютер
    Задает имя или IP-адрес удаленного компьютера (с обратными косыми чертами или без них). По умолчанию используется локальный компьютер.
    /u [домен\]пользователь
    Выполняет команду с разрешения указанной учетной записи пользователя. По умолчанию, команда запускается с разрешения пользователя, вошедшего в систему компьютера, на котором выполняется SchTasks.
    /p пароль
    Задает пароль учетной записи пользователя, указанной параметром /u. Параметр требуется при использовании параметра /u.
    /?
    Отображает справку в командной строке.

    Примечания

    • Используйте данную операцию, чтобы протестировать задания. Если задание не выполняется, проверьте журнал транзакций службы «Планировщик заданий»(системный_корневой_каталог\SchedLgU.txt) на наличие ошибок.
    • Выполнение задания не влияет на расписание задания и не меняет время следующего выполнения, назначенное для него.
    • Чтобы удаленно выполнить задание, оно должно быть назначено для удаленного компьютера. При запуске задания оно выполняется только на удаленном компьютере. Чтобы проверить выполнение задания на удаленном компьютере, используйте диспетчер задач или журнал транзакций службы «Планировщик заданий» (системный_корневой_каталог\SchedLgU.txt).

    Примеры

    Чтобы выполнить задание на локальном компьютере

    Следующая команда запускает задание «Сценарий безопасности».

    schtasks /run /tn "Сценарий безопасности"

    В ответ, программа SchTasks.exe запускает сценарий задания и выводит на экран следующее сообщение:

    УДАЧА. Запланированная задача "Сценарий безопасности" выполняется.

    Чтобы выполнить задание на удаленном компьютере

    Данная команда запускает задание «Update» на удаленном компьютере «Srv01»:

    schtasks /run /tn Update /s Svr01

    В этом случае программа SchTasks.exe выводит следующее сообщение об ошибке:

    ОШИБКА. Не удается выполнить запланированную задачу "Update".

    Чтобы выяснить причину ошибки, посмотрите журнал транзакций назначенных заданий (C:\Windows\SchedLgU.txt) на компьютере «Svr01». В журнале появилась запись:

"Update.job" (update.exe) 3//2004 1:15:46 PM ** ОШИБКА **

Попытка использования учетной записи задания окончилась неудачей, поэтому задание выполнено не было.
    Специфическая ошибка:
    0x8007052e: Отказ входа в систему: Причина: неизвестное имя пользователя или неверный пароль.
    Проверьте правильность указания имени пользователя и пароля и повторите попытку.

    Имя пользователя или пароль являются недопустимыми для системы. Следующая команда schtasks /change обновляет имя пользователя и пароль для задания «Update» на компьютере Srv01.

    schtasks /change /tn Update /s Svr01 /ru Administrator /rp PassW@rd3

    После завершения команды change, повторяется команда run. Сейчас запускает программу Update.exe и SchTasks.exe выводит сообщение:

    УДАЧА. Запланированная задача "Update" выполняется.

    Останавливает программу, запущенную заданием.

    Синтаксис

    schtasks /end /tn имя_задания [/s компьютер [/u [домен\]пользователь /p пароль]] /?

    Параметры

    /tn имя_задания
    Идентифицирует задание, запускающее программу. Параметр обязательный.
    /s компьютер
    Задает имя или IP-адрес удаленного компьютера (с обратными косыми чертами или без них). По умолчанию используется локальный компьютер.
    /u [домен\]пользователь
    Выполняет команду с разрешения указанной учетной записи пользователя. По умолчанию, команда запускается с разрешения пользователя, вошедшего в систему компьютера, на котором выполняется SchTasks.
    /p пароль
    Задает пароль учетной записи пользователя, указанной параметром /u. Параметр требуется при использовании параметра /u.
    /?
    Вывод справки.

    Примечания

    • SchTasks.exe завершает только элементы программы, запущенной с помощью назначенного задания. Чтобы остановить другие процессы, используйте средство «TaskKill», включенное в систему Windows XP Professional. Дополнительные сведения о средстве TaskKill.
      • .

    Примеры

    Чтобы завершить задание на локальном компьютере

    Следующая команда останавливает экземпляр Notepad.exe, который был запущен заданием «Мой блокнот».

    schtasks /end /tn "Мой блокнот"

    В ответ, программа SchTasks.exe останавливает запущенный экземпляр Notepad.exe и выводит следующее сообщение об удачной операции.

    УДАЧА. Запланированная задача "Мой блокнот" была успешно снята.

    Чтобы завершить задание на удаленном компьютере

    Следующая команда завершает экземпляр Internet Explorer, который был запущен заданием «InternetOn» на удаленном компьютере «Svr01».

    schtasks /end /tn InternetOn /s Svr01

    В ответ, программа SchTasks.exe останавливает запущенный экземпляр Internet Explorer и выводит следующее сообщение об удачной операции.

    УДАЧА. Запланированная задача "InternetOn" была успешно снята.

    Удаляет назначенное задание

    Синтаксис

    schtasks /delete /tn {имя_задания | *} [/f] [/s компьютер [/u [домен\]пользователь /p пароль]] [/?]

    Параметры

    /tn {имя_задания | *}
    Идентифицирует удаляемое задание. Параметр обязательный.
    Значение | Описание
    имя_задания | Удаляет данное задание.
    * Удаляет все задания, назначенные на компьютере.
    /f
    Отменяет вывод сообщения об уведомлении. Задание удаляется без предупреждения.
    /s компьютер
    Задает имя или IP-адрес удаленного компьютера (с обратными косыми чертами или без них). По умолчанию используется локальный компьютер.
    /u [домен\]пользователь
    Выполняет команду с разрешения указанной учетной записи пользователя. По умолчанию команда запускается с разрешения пользователя, вошедшего в систему компьютера, на котором выполняется SchTasks.
    /p пароль
    Задает пароль учетной записи пользователя, указанной параметром /u. Параметр требуется при использовании параметра /u.
    /?
    Отображает справку в командной строке.

    Примечания

    • Операция delete удаляет задание из расписания. При этом не удаляется программа, которую выполняет или прерывает задание.
    • Команда delete.* удаляет все задания, назначенные для компьютера, а не только задания, назначенные текущим пользователем.

    Примеры

    Чтобы удалить задание из расписания удаленного компьютера

    Следующая команда удаляет задание «Start Mail» из расписания удаленного компьютера. Параметр /s используется в программе для указания удаленного компьютера.

    schtasks /delete /tn "Start Mail" /s Svr16

    В ответ, программа SchTasks.exe выводит на экран следующее сообщение о подтверждении. Чтобы удалить задание, введите y. Для отмены команды введите n.

    ПРЕДУПРЕЖДЕНИЕ: Хотите удалить задание «Start Mail» (Д/Н )? д
УДАЧА. Запланированная задача "Start Mail" была успешно удалена.

    Чтобы удалить все задания, назначенные для локального компьютера

    Следующая команда удаляет все задания из расписания локального компьютера, включая задания, назначенные другими пользователями. Параметр /tn * в команде представляет все задания на компьютере, а параметр /f отменяет вывод сообщения о подтверждении.

    schtasks /delete /tn * /f

    В ответ на эту команду, программа SchTasks.exe выводит следующее сообщение, показывающее, что только назначенное задание «SecureScript» удалено.

    УДАЧА. Запланированная задача "SecureScript" была успешно удалена.

    Выводит на экран все задания, назначенные для выполнения на компьютере, включая задание, назначенные другими пользователями.

    Синтаксис

    schtasks [/query] [/fo {TABLE | LIST | CSV}] [/nh] [/v] [/s компьютер [/u [домен\]пользователь /p пароль]]

    Параметры

    [/query]
    Имя запроса является необязательным. При вводе команды schtasks без параметров выполняется запрос.
    /fo {TABLE|LIST|CSV}
    Задает выходной формат. Выходной формат по умолчанию — TABLE.
    /nh
    Опускает заголовки столбцов при отображении таблицы. Параметр является допустимым с выходными форматами TABLE и CSV.
    /v
    К выведенным заданиям добавляет их дополнительные свойства.

    Запросы, в которых используется параметр /v должны иметь выходной формат LIST или CSV.

    /s компьютер
    Задает имя или IP-адрес удаленного компьютера (с обратными косыми чертами или без них). По умолчанию используется локальный компьютер.
    /u [домен\]пользователь
    Выполняет команду с разрешения указанной учетной записи пользователя. По умолчанию, команда запускается с разрешения пользователя, вошедшего в систему компьютера, на котором выполняется SchTasks.
    /p пароль
    Задает пароль учетной записи пользователя, указанной параметром /u. Параметр требуется при использовании параметра /u.
    /?
    Отображает справку в командной строке.

    Примечания

    • Операция query выводит список всех заданий, назначенных для компьютера, а не только заданий, назначенных текущим пользователем.

    Примеры

    Чтобы отобразить назначенные задания на локальном компьютере

    Следующие команды выводят на экран все задания, назначенные для локального компьютера. Эти команды приводят к одному результату. Их можно использовать без изменений.

    schtasks

    schtasks /query

    В ответ на команду, программа SchTasks.exe по умолчанию выводит задания в формате таблицы, например:

Имя задания                  Следующий запуск            Состояние
========================= ======================== ==============
Microsoft Outlook         При запуске
SecureScript              14:42:00 PM , 2/4/2001

    Чтобы вывести на экран дополнительные свойства назначенных заданий

    Следующая команда запрашивает вывод подробных сведений о заданиях на локальном компьютере. Параметр /v используется в команде для запроса подробного вывода, а параметр /fo LIST — для форматирования вывода в список для облегчения процесса чтения. Используйте эту команду, чтобы проверить, что созданное задание имеет

    schtasks /query /fo LIST /v

    В ответ на эту команду, программа SchTasks.exe выводит на экран подробный список свойств для всех заданий. Далее показан список для задания, запланированного для выполнения в 4:00 в последнюю пятницу каждого месяца:

Имя узла:                           RESKIT01
Имя задачи:                          SecureScript
Следующий запуск:                    4:00:00 AM , 15/01/2004
Состояние:                          Не выполняется
Последний запуск:                      Нет
Последний результат:                    0
Создан:                               user01
Расписание:                В 4:00 AM в последнюю пт каждого месяца, начиная с 15/01/2004
Задача для выполнения:               C:\WINDOWS\system32\notepad.exe
Рабочая папка:                       notepad.exe
Комментарий:                          Н/Д
Состояние назначенной задачи:         Включено
Тип разписания:                       Ежемесячно
Модификатор:                          последняя пятница
Время запуска:                         4:00:00 AM
Дата начала:                          15/01/2004
Дата окончания:                          Н/Д
Дн.:                                      пятница
Мес.:                                     янв,фев,мар,апр,май,июн,июл,авг,сен,окт,ноя,дек
Запуск от имени:                               RESKIT\user01
Удалить задачу, если она не перенесена:            Отключено
Остановить задачу, если она выполняется Х ч. и Х мин.:     72:00
Повторять: до: время:                                       Отключено
Повторять: в течение: длительность:                         Отключено
Повторять: остановить, если выполняется                     Отключено
При простое: Время начала (для типа расписания ПРИ ПРОСТОЕ) Отключено
При простое: Запускать только при простое в Х мин.          Отключено
При простое: Без простоя повторять попытки в течение Х мин.    Отключено
При простое: Остановить задачу по завершении простоя              Отключено
Управление электропитанием: Не запускать при питании от батареи       Отключено
Управление электропитанием: Останавливать при питании от батареи        Отключено

    Чтобы просмотреть задания, назначенные для удаленного компьютера

    Следующая команда запрашивает список заданий, назначенных для удаленного компьютера, и добавляет задания в файл журнала в формате с разделителями — запятыми на локальном компьютере. Чтобы собрать и отслеживать задания, назначенные нескольким компьютерам, используйте данный формат команды.

    Параметр /s идентифицирует уделенный компьютер «Reskit16», параметр /fo задает формат, а параметр /nh отменяет вывод заголовков столбцов. Символ добавления >> перенаправляет вывод в журнал заданий p0102.csv на локальный компьютер «Srv01». Путь к локальному компьютеру должен быть задан полностью, потому что команда выполняется на удаленном компьютере.

    schtasks /query /s Reskit16 /fo csv /nh >> \\svr01\data\tasklogs\p0102.csv

    В ответ на команду, программа SchTasks.exe добавляет задания, назначенные для удаленного компьютера, в файл p0102.csv на локальном компьютере Srv01.

    Примечания

    • SchTasks.exe выполняет операции, похожие на операции средства «Назначенные задания» в панели управления. Это средство также используется для создания, удаления, настройки и вывода назначенных заданий.
    • При вводе команды schtasks без параметров выполняется запрос.
    • Пользователь должен быть членом группы «Администраторы» на компьютере, на котором команда выполняется.
    • Для проверки выполнения или выяснения причины невыполнения назначенного задания см. журнал транзакций службы планировщика заданий (системный_корневой_каталог\SchedLgU.txt).
    • В редких случаях файлы заданий повреждаются. Поврежденные задания не выполняются. При попытке выполнить операцию поврежденного задания, SchTasks.exe выводит следующее сообщение об ошибке:
      ОШИБКА. Недопустимые данные.

      Восстановить поврежденные задания нельзя. Чтобы восстановить системные параметры назначения заданий, удалите задания из системы с помощью SchTasks.exe или средства «Назначенные задания» и повторно запланируйте их.

    • SchTasks.exe заменяет средство At.exe, включенное в предыдущие версии Windows.


Secedit

Настраивает и анализирует безопасность системы, сравнивая текущую конфигурацию хотя бы с одним шаблоном.

Синтаксис

secedit /analyze /db имя_файла [/cfg имя_файла] [/log имя_файла] [/quiet]

Параметры

/db имя_файла
Обязательный параметр. Указывает путь к базе и имя файла базы, содержащей сохраненную конфигурацию, по которой будет производиться анализ. Если значение имя_файла соответствует новой базе, необходимо указать параметр командной строки /cfg имя_файла.
/cfg имя_файла
Определяет путь к шаблону безопасности и имя файла шаблона, который будет импортироваться в базу данных для анализа. Данный параметр командной строки может использоваться только вместе с параметром /db. Если параметр не указан, анализ выполняется по конфигурации, хранящейся в базе данных.
/log имя_файла
Отображает имя и путь файла журнала для анализа. Если данный параметр не указан, используется файл журнала по умолчанию.
/quiet
Предотвращает вывод на экран и в файл журнала. Имеется возможность посмотреть результаты анализа, используя оснастку «Анализ и настройка безопасности».

secedit /configure

Служит для настройки безопасности системы с использованием сохраненного шаблона.

Синтаксис

secedit /configure /db имя_файла [/cfg имя_файла ] [/overwrite][/areas область1 область2...] [/log имя_файла] [/quiet]

Параметры

/db имя_файла
Обязательный параметр. Представляет имя файла базы данных, содержащей применяемый шаблон безопасности.
/cfg имя_файла
Имя файла шаблона безопасности, который будет импортироваться в базу данных и применяться при настройке безопасности. Данный параметр командной строки может использоваться только вместе с параметром /db. Если данный параметр не указан, будет использоваться шаблон, хранящийся в базе данных.
/overwrite
Cледует указывать в том случае, если шаблон безопасности, указанный в параметре /cfg, должен замещать любой шаблон или составной шаблон, хранящийся в базе данных, вместо того, чтобы добавлять результаты в хранящуюся базу данных. Данный параметр командной строки может использоваться только вместе с параметром /cfg. Если параметр не указан, шаблон, указанный в аргументе /cfg, будет добавлен в шаблон, хранящийся в базе данных.
/areas область1 область2...
Определяет области безопасности, которые следует применить в системе. Если область не указана, в системе применяются все области. Имена областей должны разделяться пробелами.
Имя области | Описание
SECURITYPOLICY | Локальная политика и политика для домена, включая политики учетных записей, политики аудита и т. п.
GROUP_MGMT | Настройка ограничений для всех групп, указанных в шаблоне безопасности
USER_RIGHTS | Права пользователей на вход в систему и предоставление привилегий
REGKEYS | Безопасность разделов локального реестра
FILESTORE | Безопасность локальных устройств хранения файлов
SERVICES | Безопасность для всех определенных служб
/log имя_файла
Отображает имя и путь файла журнала для анализа. Если путь не задан, используется путь по умолчанию.
/quiet
Предотвращает вывод на экран и в файл журнала.

secedit /export

Служит для экспорта сохраненного шаблона из базы данных безопасности в файл шаблона безопасности.

Синтаксис

secedit /export [/mergedpolicy] [/DB имя_файла] [/CFG имя_файла] [/areas область1 область2...] [/log имя_файла] [/quiet]

Параметры

/mergedpolicy
Объединяет и экспортирует настройку безопасности локальной политики и настройку политики домена.
/db имя_файла
Указывает файл базы данных, содержащий экспортируемый шаблон. Если база данных не указана, используется база данных системной политики.
/db имя_файла
Определяет имя файла, где должен быть сохранен шаблон.
/areas область1 область2...
Задает области безопасности, которые следует экспортировать в шаблон. При неуказанной области экспортируются все области. Имена областей должны разделяться пробелами.
Имя области | Описание
SECURITYPOLICY | Определяет локальную политику и политику для домена, включая политики учетных записей, политики аудита и т. п.
GROUP_MGMT | Задает настройку ограничений для всех групп, указанных в шаблоне безопасности
USER_RIGHTS | Указывает права пользователей на вход в систему и предоставляет привилегии
REGKEYS | Определяет безопасность раздела локального реестра
FILESTORE | Определяет безопасность локальных устройств хранения файлов
SERVICES | Задает безопасность для всех определенных служб
/log имя_файла
Отображает имя и путь файла журнала для анализа. Если путь не задан, используется путь по умолчанию.
/quiet
Предотвращает вывод на экран и в файл журнала.

secedit /validate

Служит для проверки синтаксиса шаблона безопасности при его импорте в базу данных или применении к системе.

Синтаксис

secedit /validate имя_файла

Параметр

имя_файла
Указывает имя файла шаблона безопасности, который был создан с помощью средства «Шаблоны безопасности».

Примечания

  • Команда secedit /refreshpolicy была заменена командой gpupdate.


Set

Устанавливает, удаляет и просматривает переменные среды. Вызванная без параметров, команда set выводит список установленных переменных среды и их значений.

Синтаксис

set [[/a [выражение]] [/p [переменная=]] строка]

Параметры

/a
Указывает, что параметр строка является вычисляемым числовым выражением.
/p
Задает значение переменной строкой ввода.
переменная
Указывает имя переменной, значение которой требуется задать или изменить.
строка
Задает строковое значение для указанной переменной.
/?
Отображает справку в командной строке.

Примечания

  • Использование команды set в консоли восстановления

    Команда set с другими параметрами доступна в консоли восстановления.

  • Использование специальных символов

    Символы <, >, |, &, ^ являются специальными символами командной оболочки, необходимо либо ставить перед ними управляющий символ (^), либо заключать в кавычки, при использовании символов в параметре строка (например, "строка_содержания&символ"). При заключении в кавычки строки, содержащей специальные символы, кавычки считаются частью значения переменной среды.

  • Использование переменных среды

    Переменные среды используются для управления работой некоторых пакетных файлов и программ и для управления работой Windows XP и подсистемы MS-DOS. Команда set часто используется в файле Autoexec.nt для установки переменных среды.

  • Вывод текущих установок среды

    Когда команда set вызвана без параметров, на экран будут выведены текущие установки. Обычно эти установки включают переменные COMSPEC и PATH, используемые для поиска программ на диске. Две другие переменные среды, используемые Windows XP — это PROMPT и DIRCMD.

  • Использование параметров

    При указании значений для переменной и строки значение переменной добавляется к окружению, а строка ставится в соответствие этой переменной. Если переменная уже существует, новое значение замещает старое значение.

    Если в команде set указано только имя переменной и знак равенства (без значения), какое-либо значение больше не будет ставиться в соответствие переменной среды, что эквивалентно удалению переменной среды.

  • Использование /a

    В следующей таблице представлены операторы, поддерживающие параметр /a, в порядке убывания очередности.

    Оператор Выполнение оператора
    < > Группировка
    * / % + - Арифметические действия
    << >> Логический перенос
    & Поразрядное И
    ^ Поразрядное исключающее ИЛИ
    | Поразрядное ИЛИ
    = *= /= %= += -= &= ^= |= <<= >>= Назначение
    , Разделитель выражения

    При использовании логических операторов (&& ||) или оператора остатка от деления (%) заключайте выражение строки в кавычки. Любые нечисловые строки в выражении считаются именами переменной среды, чьи значения преобразованы в числа до обработки. Если указано имя переменной среды, которое не определено в текущем окружении, ей присваивается значение нуля, что позволяет выполнять арифметические операции со значениями переменной среды без использования % для получения значения.

    При выполнении команды set /a из командной строки вне командного сценария, выводится конечное значение выражения.

    Численные значения — это десятичные числа, кроме чисел с префиксами 0× для шестнадцатеричных чисел и 0 для восьмеричных чисел. Таким образом, 0×12 тоже самое, что 18 и 022. Восьмеричное представление можно спутать. Например, 08 и 09 недопустимы, потому что 8 и 9 не являются восьмеричными цифрами.

  • Использование /p

    Используется, когда не требуется включать командную строку.

  • Поддержка расширения переменной среды с задержкой

    Добавлена поддержка расширения переменной среды с задержкой. Эта поддержка отключена по умолчанию, можно включить или отключить ее с помощью команды cmd /v.

  • Работа с расширениями команды

    При включенных расширениях команды (установлено по умолчанию) и выполнении команды set без значений, на экран выводятся все текущие переменные среды. Если же выполняется команда set со значением, отображаются переменные, соответствующие этому значению.

  • Использование команды set в пакетных файлах

    При создании пакетных файлов, используйте команду set для создания переменных и использовании их в качестве числовых переменных от %0 до %9. Также можно использовать переменные от %0 до %9 как ввод для команды set.

  • Обращение к переменным команды set из пакетных программ

    При обращении к переменной из пакетной программы имя переменной должно быть заключено в знаки процентов (%). Например, если в пакетной программе создается переменная BAUD, с ней может быть связан заменяемый параметр путем использования имени %baud% в командной строке.

Примеры

Чтобы задать переменную среды с именем TEST^1, введите команду:

set testVar=test^^1

Чтобы задать переменную среды с именем TEST&1, введите команду:

set testVar=test^&1

Значением переменной команды set определяет все, что следует за знаком равенства (=). При вводе:

set testVar="test^1"

Результат будет следующим:

testVar="test^1"

Для установки переменной среды INCLUDE так, чтобы с ней была связана строка C:\Inc (каталог Inc на диске C), можно использовать следующую команду:

set include=c:\inc

Строку C:\Inc можно использовать в пакетных файлах, заключив имя INCLUDE в знаки процента (%). Например, в пакетном файле можно использовать следующую команду для вывода содержимого каталога, на который указывает переменная среды INCLUDE:

dir %include%

При выполнении команды строка %include% будет заменена строкой C:\Inc.

Можно также использовать команду set в пакетной программе, которая добавляет новый каталог к переменной среды PATH. Например:

@echo off
rem ADDPATH.BAT добавляет новый каталог
rem к переменной среды path.
set path=%1;%path%
set

При включенных расширениях команды (установлено по умолчанию) и выполнении команды set со значением, на экран выводятся все переменные среды, соответствующие значению. Например, при вводе в командную строку : set p, результат будет следующим:

Path=C:\WINNT\system32;C:\WINNT;C:\WINNT\System32\Wbem
PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH
PROCESSOR_ARCHITECTURE=x86
PROCESSOR_IDENTIFIER=x86 Family 6 Model 8 Stepping 1, GenuineIntel
PROCESSOR_LEVEL=6
PROCESSOR_REVISION=0801
ProgramFiles=C:\Program Files
PROMPT=$P$G


Setlocal

Начало области задания для определения переменных среды в пакетном файле. Локальное окружение используется до тех пор, пока не встретится команда endlocal или не будет достигнут конец пакетного файла.

Синтаксис

setlocal {enableextension | disableextensions} {enabledelayedexpansion | disabledelayedexpansion}

Аргументы

enableextension
Включает расширения командного процессора до появления соответствующей команды endlocal, вне зависимости от состояния расширений командного процессора перед командой setlocal.
disableextensions
Выключает расширения командного процессора до появления соответствующей команды endlocal, вне зависимости от состояния расширений командного процессора перед командой setlocal.
enabledelayedexpansion
Включает расширения переменной среды с задержкой до появления соответствующей команды endlocal, вне зависимости от состояния расширений командного процессора перед командой setlocal.
disabledelayedexpansion
Выключает расширения переменных среды с задержкой до появления соответствующей команды endlocal, вне зависимости от состояния расширений командного процессора перед командой setlocal.
/?
Отображает справку в командной строке.

Примечания

  • Использование команды setlocal

    Команда setlocal не выполняется при использовании вне сценария или пакетного файла.

  • Изменение переменных среды

    Используйте команду setlocal для изменения переменных среды при выполнении пакетного файла. Изменения среды, выполненные после setlocal, являются локальными для пакетного файла. Cmd.exe восстанавливает первоначальные параметры при обнаружении команды endlocal или достижении конца пакетного файла.

  • Допускается использование нескольких команд setlocal и endlocal в пакетной программе (так называемых, вложенных команд).
  • Проверка расширений командного процессора в пакетных файлах

    Команда setlocal устанавливает переменную ERRORLEVEL. При выполнении аргументов {enableextension | disableextensions} или {enabledelayedexpansion | disabledelayedexpansion} переменная ERRORLEVEL имеет значение ноль (0). В противном случае ее значение — 1. Этим можно воспользоваться в пакетных программах для проверки доступности расширений командного процессора, например:

        verify other 2>nul
    setlocal enableextensions
    if errorlevel 1 echo Включение расширений командного процессора невозможно

    Так как команда cmd не устанавливает значение переменной ERRORLEVEL, когда расширения командного процессора отключены, команда verify устанавливает переменную ERRORLEVEL в ненулевое значение при использовании этой команды с недопустимым аргументом. Если используется команда setlocal с аргументами {enableextension | disableextensions} или {enabledelayedexpansion | disabledelayedexpansion} и значение переменной ERRORLEVEL не 1, расширения командного процессора недоступны.

Примеры

Локальное изменение переменных среды в пакетном файле может быть использовано следующим образом:

  rem *******Начало комментария**************
  rem Эта программа запускает приложение superapp в сети,
  rem записывает вывод в файл и загружает этот файл в программу
  rem Блокнот.
  rem *******Конец комментария **************
      @echo off
      setlocal
      path=g:\programs\superapp;%path%
      call superapp>c:\superapp.out
      endlocal
      start notepad c:\superapp.out


Setver

Устанавливает номер версии MS-DOS, который подсистема MS-DOS сообщает программам. Использованная без параметров, команда setver выводит таблицу текущих версий.

Синтаксис

setver [диск:путь] [имя_файла n.nn]

setver [диск:путь] [имя_файла [/delete [/quiet]]

Для вывода сведений о текущих назначениях версий используется следующий формат:

setver [диск:путь]

Параметры

[диск:путь
Указывает путь к файлу Setver.exe.
имя_файла
Задает имя файла программы (.exe или .com), которое будет добавлено к таблице назначения версий. Использование подстановочных знаков (* и ?) не допускается.
n.nn
Задает версию MS-DOS (например, 3.3 или 4.01), которую подсистема MS-DOS сообщает заданной программе.
/delete
Удаляет сведения о данной программе из таблицы назначения версий. Так же можно использовать параметр /d.
/quiet
Скрывает сообщение, которое обычно выводится при удалении записи из таблицы назначения версий.
/?
Отображает справку в командной строке.

Примечания

  • Использование таблицы назначения версий

    Многие программы, которые были разработаны для использования с предыдущими версиями MS-DOS, будут корректно работать с системой Windows XP. Однако, в некоторых случаях, программа может не работать до тех пор, пока ее имя не будет включено в таблицу назначения версий. Эта таблица сообщает программе, что она работает с той версией MS-DOS, для которой она была разработана, несмотря на то что она в действительности работает с подсистемой MS-DOS. Воспринимая версию MS-DOS 5.0 как более старую, программа может работать корректно. Однако, использование команды setver не решит проблему с теми программами, которые несовместимы с системой Windows XP.

  • Загрузка таблицы назначения версий в память

    Перед использованием команды setver таблица назначений версий должна быть загружена в память с помощью команды device в файле Config.nt.

  • Обновление таблицы назначения версий

    После обновления таблицы назначения версий (добавления или удаления записей) должен быть запущен новый экземпляр интерпретатора командной строки для считывания обновленной таблицы назначения версий.

  • Обновление существующих записей

    Если задано имя файла, который уже находится в таблице назначения версий, новая запись заменит старую.

  • Коды завершения команды setver

    Чтобы проанализировать в пакетной программе коды завершения, выведенные командой setver, используйте параметр уровень_ошибки в командной строке if. В следующей таблице перечислены коды завершения с кратким описанием.

    Код завершения | Описание
    0 | Программа setver успешно закончила работу
    1 | Задан неверный ключ командной строки
    2 | Задано неверное имя файла
    3 | Недостаточно системной памяти для работы команды
    4 | Задан недопустимый формат номера версии
    5 | Программа setver не может найти заданную запись в таблице назначения версий
    6 | Программа setver не может найти файл Setver.exe
    7 | Задан недопустимый диск
    8 | Задано слишком много параметров команды
    9 | Отсутствует параметр команды setver
    10 | Программа setver обнаружила ошибку при чтении файла Setver.exe
    11 | Файл Setver.exe поврежден
    12 | Заданный файл Setver.exe не поддерживает таблицу назначения версий
    13 | В таблице назначения версий недостаточно места для новой записи
    14 | Программа setver обнаружила ошибку при записи в файл Setver.exe

Примеры

Для запуска Myprog.exe, файла, который выполняется с MS-DOS версии 3.30, создайте запись в таблице назначения версий, в результате чего, Myprog.exe интерпретирует подсистему MS-DOS, как версию 3.30, вводом следующей команды:

setver myprog.exe 3.30

Для удаления записи о программе Myprog.exe из таблицы назначения версий служит следующая команда:

setver myprog.exe /delete

Для просмотра содержимого таблицы назначения версий на диске C служит следующая команда:

setver c:


Share

Смотреть здесь


Shell

Указывает имя и местоположение альтернативного командного интерпретатора, которого использует Windows XP для подсистемы MS-DOS.

Синтаксис

shell=[[диск:]путь] имя_файла [параметры]

Параметры

[[диск:][путь] имя_файла
Задает местоположение и имя командного интерпретатора.
параметры
Задает параметры и ключи командной строки для использования при запуске заданного командного интерпретатора.
/?
Отображает справку в командной строке.

Примечания

  • Параметры по умолчанию

    По умолчанию, подсистема MS-DOS использует специальную версию интерпретатора Command.com, которая работает так же, как и другие подсистемы Windows XP, (включая каналы и перенаправления между системами) и команда shell не является необходимой.

  • Задание 16-разрядного командного интерпретатора

    Хотя это и не рекомендуется, команда shell может задавать альтернативный 16-разрядный командный интерпретатор.

  • Использование параметров командной строки с командным интерпретатором

    Команда shell сама по себе не использует параметры командной строки, но если они нужны командному интерпретатору, параметры могут быть заданы в команде shell.

Примеры

Предположим, что файл Newshell.com, находящийся в каталоге /Bin на загрузочном диске, должен быть использован как альтернативный командный интерпретатор. Для этого в файл Config.nt должна быть вставлена следующая команда:

shell=\bin\newshell.com


Shift

Изменяет положения пакетных параметров в пакетных файлах.

Синтаксис

shift

Параметры

отсутствуют

Примечания

  • Использование параметра командной строки shift с расширениями командного процессора

    Если расширения командного процессора разрешены (используются по умолчанию), команда shift поддерживает ключ /n, который указывает команде начинать сдвиг с n-го аргумента, где n — число от нуля до восьми. Например:

    SHIFT /2

    сдвинет %3 на %2, %4 на %3 и т. д. %0 и %1 останутся неизменными.

  • Работа команды shift

    Команда shift изменяет значения замещаемых параметров %0 - %9 путем копирования каждого параметра в предыдущий. Другими словами, значение %1 копируется в %0, значение %2 — в %1 и т. д. Такой прием оказывается полезным при написании пакетных файлов, выполняющих одну и ту же операцию над любым числом параметров.

  • Работа более чем с 10 пакетными параметрами

    Команда shift также может быть использована для создания пакетных программ, воспринимающих более 10 параметров. В командной строке такой программы можно задать более 10-ти параметров, при этом все параметры, следующие за десятым (то есть за переменной%9) будут последовательно помещены в эту переменную %9.

  • Использование %* с командой shift

    Команда shift не влияет на пакетный параметр %*.

  • Смещение параметров в обратном направлении

    Команды, выполняющей обратный сдвиг не существует. После сдвига параметров командой shift начальное значение первого параметра (%0) не может быть восстановлено.

Примеры

В следующем пакетном файле Mycopy.bat показано, как использовать команду shift с произвольным числом пакетных параметров. Файл копирует набор файлов в заданный каталог. Пакетные параметры представлены аргументами имени файла и каталога.

@echo off
rem MYCOPY.BAT копирует произвольное число файлов
rem в каталог.
rem Используется следующий синтаксис:
rem mycopy dir файл1 файл2 ...
set todir=%1
:getfile
shift
if "%1"=="" goto end
copy %1 %todir%
goto getfile
:end
set todir=
echo Работа закончена


Shutdown

Позволяет выключать или перезапускать локальный или удаленный компьютер. Использование без параметров команды shutdown приведет к выходу из системы текущего пользователя.

Синтаксис

shutdown [{-l|-s|-r|-a}] [-f] [-m [\\имя_компьютера]] [-t xx] [-c "сообщение"] [-d[u][p]:xx:yy]

Параметры

-l
Осуществляет выход текущего пользователя из системы (также используется по умолчанию). -m имя_компьютера имеет приоритет.
-s
Выключает локальный компьютер.
-r
Выполняет перезагрузку после выключения.
-a
Прерывает выключение. Игнорируются все параметры, кроме -l и имя_компьютера. Параметр -a можно использовать только в течение интервала таймаута.
-f
Принудительно закрывает выполняющиеся приложения.
-m [\\имя_компьютера]
Указывает компьютер, который требуется выключить.
-t xx
Устанавливает таймер завершения работы системы на xx секунд. По умолчанию это время составляет 20 секунд.
-c "сообщение"
Задает сообщение, выводящееся в области «Сообщение» в окне «Завершение работы системы». Можно использовать до 127 знаков. Текст сообщения должен быть заключен в прямые кавычки.
-d [u][p]:xx:yy
Отображает перечень кодов причины выключения. В следующей таблице перечислены различные значения.
Значение | Описание
u | Указывает код пользователя
p | Указывает код планового выключения
xx | Указывает основной код причины (0-255)
yy | Указывает вспомогательный код причины (0-65536)
/?
Отображает справку в командной строке.

Примечания

  • Если указывается основной и вспомогательный коды причины, необходимо предварительно определить эти коды на каждом компьютере, на котором планируется использовать конкретный код. Если коды причины не определены на конечном компьютере, программа «Просмотр событий» не сможет занести в журнал правильный текст причины.

Примеры

Чтобы выключить сервер \\MyServer через 60 секунд, принудительно закрыть выполняющиеся приложения, перезагрузить компьютер после выключения, указать код пользователя, указать что выключение является плановым, занести в журнал основной код причины 125 и вспомогательный код причины 1, введите:

shutdown -r -f -m \\MyServer -t 60 -d up:125:1


Sort

Считывает входящие данные, сортирует их. Результат может быть выведен на экран, в файл или на другое устройство.

Синтаксис

sort [/r] [/+n] [/m килобайты] [/l язык] [/rec символы] [[диск1:][путь1]имя_файла1] [/t [диск2:][путь2]] [/o [диск3:][путь3]имя_файла3]

[команда |] sort [/r] [/+n] [/m килобайты] [/l язык] [/rec символы] [[диск1:][путь1]имя_файла1][/t [диск2:][путь2]] [/o [диск3:][путь3]имя_файла3]

Параметры

/r
Изменяет порядок сортировки, задает сортировку от Z к A, затем от 9 к 0.
/+n
Указывает номер позиции символа, n, начиная с которой sort выполняет сравнение.
/m килобайты
Указывает количество основной памяти, используемой для сортировки (в килобайтах).
/l язык
Переопределяет порядок сортировки символов, задаваемый языком, который используется системой по умолчанию(т. е. языком и страной/регионом, выбранными при установке).
/rec символы
Указывает максимальное числа символов в записи (или строке) входного файла. (Значение по умолчанию равно 4096, максимальное значение — 65535).
[диск1:][путь1]имя_файла1
Указывает сортируемый файл. Если имя не указано, сортируется стандартный ввод. При указании входного файла команда работает быстрее, чем при перенаправлении того же файла на стандартный ввод.
/t [диск2:][путь2]
Указывает каталог для хранения рабочих данных команды sort, если сортируемые данные не помещаются в основной памяти. По умолчанию используется системный временный каталог.
/o [диск3:][путь3]имя_файла3
Указывает файл для хранения отсортированного ввода. Если параметр не указан, данные будут записываться в стандартный вывод. При указании выходного файла команда работает быстрее, чем при перенаправлении того же файла на стандартный вывод.
/?
Отображает справку в командной строке.

Примечания

  • Использование параметра командной строки /+n

    Использование параметра командной строки /+n, например /+3 указывает, что сравнение должно начинаться с третьего символа в каждой строке. Строки, имеющие меньше, чем n символов, оказываются перед другими строками. По умолчанию сравнение начинается с первого символа в строке.

  • Использование параметра командной строки /m килобайты

    Всегда используется как минимум 160 Кб. Если указан объем памяти, для сортировки используется указанный объем (но не меньше 160 Кб), независимо от объема доступной памяти.

    Максимальный объем памяти по умолчанию, если параметр не указан, составляет 90 процентов доступной основной памяти, если и ввод, и вывод идет через файлы, и 45 процентов в противоположном случае. Настройки по умолчанию обычно дают наилучшее быстродействие.

  • Использование параметра командной строки /l язык

    В настоящий момент единственной альтернативой языку по умолчанию является «C», который позволяет сортировать быстрее, чем при сортировке естественного языка. Сортировка символов производится по их двоичной кодировке.

  • Задание источника данных

    Когда задан параметр команда или имя_файла, команда sort действует как фильтр и получает входные данные из стандартного ввода (обычно с клавиатуры, из канала или из файла).

  • Использование перенаправления с командой sort

    Чтобы направить команде sort данные от другой команды или направить результаты сортировки другой команде (например команде more для вывода с паузой после заполнения экрана), может быть использован символ канала (|). Использование символов «меньше» (<) или «больше» (>) для указания входного и выходного файлов не может быть очень эффективным. Вместо этого непосредственно укажите входной файл (как определено синтаксисом команды) и укажите выходной файл с помощью ключа /o. Сортировка, указанная таким способом, может оказаться значительно быстрее, особенно для больших файлов.

  • Строчные и заглавные буквы

    Команда sort не различает строчные и заглавные буквы.

  • Размер файлов

    Команда sort может обрабатывать файлы любого размера.

  • Последовательность сортировки

    Программа сортировки использует последовательность сортировки, соответствующую текущим установкам языка или страны/региона и текущей кодовой странице. Символы с кодом ASCII, большим 127, сортируются в соответствии со сведениями в файле Country.sys или в альтернативном файле, заданном командой country в файле Config.nt.

  • Использование памяти

    Если сортируемые данные помещаются в памяти (максимального объема памяти по умолчанию или объема, указанного параметром /m), сортировка выполняется за один проход. В противном случае, сортировка выполняется за два прохода, так что объемы памяти, использованной для проходов сортировки и слияния, равны. Если выполняются два прохода, частично отсортированные данные хранятся во временном файле на диске. Если памяти недостаточно для выполнения сортировки в два прохода, выдается сообщение об ошибке времени выполнения. Если параметр /m указывает больший объем памяти, чем доступный на самом деле, может произойти снижение быстродействия или может возникнуть ошибка времени выполнения.

Примеры

Сортировка файла

Следующая команда считывает файл Expenses.txt, сортирует его в обратном порядке и выводит на экран:

sort /r expenses.txt

Сортировка результата работы команды

Чтобы найти в большом файле с именем Maillist.txt строку «Jones» и отсортировать результаты поиска, используйте канал (|) для направления результата работы команды find команде sort, как показано ниже:

find "Jones" maillist.txt | sort

Команда выводит на экран отсортированный список строк, содержащих заданный текст.

Сортировка ввода с клавиатуры

Для сортировки данных, вводимых с клавиатуры, и вывода результат на экран можно использовать команду sort без параметров, как показано в следующем примере:

sort

Затем вводится текст, который необходимо отсортировать; каждая строка заканчивается нажатием клавиши ENTER. Когда ввод будет закончен, следует нажать комбинацию CTRL+Z и ENTER. Команда sort выведет на экран введенные строки, отсортированные в алфавитном порядке.

Вывод также может быть направлен и в файл. Чтобы получить дополнительные сведения, выберите redirect из списка в Справочнике.


Stacks

Поддерживает динамическое использование стеков данных при обработке аппаратных прерываний. Чтобы использовать эту переменную среду, поместите ее в файл Config.nt.

Синтаксис

stacks=число,размер

Параметры

число
Задает количество стеков. Допустимые значения числа — 0 и от 8 до 64.
размер
Задает размер (в байтах) каждого стека. Допустимые значения размера — 0 и от 32 до 512.

Примечания

  • Параметры по умолчанию

    В приведенной ниже таблице приведены значения, используемые для команды stack по умолчанию.

    Компьютер | Стеки
    IBM PC, IBM PC/XT, IBM PC-Portable | 0,0
    Другие | 9,128
  • Специальные случаи выделения стеков

    При обработке аппаратного прерывания система Windows XP выделяет один стек из заданного количества стеков. Если для параметров число и размер заданы нулевые значения, Windows XP не выделяет стеки. В этом случае каждая запущенная программа должна иметь достаточного стекового пространства для обработки аппаратных прерываний. Большинство компьютеров работают корректно, оставляя в памяти пространство для программ, однако, если при задании нулевых значений числа и размера система начинает работать неустойчиво, следует вернуться к параметрам, заданным по умолчанию.

Примеры

Чтобы выделить 8 стеков по 512 байт для обработки аппаратных прерываний, в файл Config.nt должна быть добавлена следующая команда:

stacks=8,512


Start

Запускает определенную программу или команду в отдельном окне. При запуске без параметров команда start создает новое окно командной строки.

Синтаксис

start ["заголовок"] [/d путь] [/i] [/min] [/max] [{/separate | /shared}] [{/low | /normal | /high | /realtime | /abovenormal | belownormal}] [/wait] [/b] [имя_файла] [параметры]

Параметры

"заголовок"
Указывает заголовок, выводимый в области заголовка окна.
/d путь
Указывает каталог запуска.
/i
Передает начальные установки среды интерпретатора Cmd.exe в новое окно командной строки.
/min
Запускает новое окно командной строки в свернутом виде.
/max
Запускает новое окно командной строки в развернутом виде.
/
Запускает 16-битные программы в отдельном пространстве памяти.
/shared
Запускает 16-битные программы в отдельном пространстве памяти.
/low
Запускает приложение с низким приоритетом.
/normal
Запускает приложение с нормальным приоритетом.
/high
Запускает приложение с высоким приоритетом.
/realtime
Запускает приложение с приоритетом реального времени.
/abovenormal
Запускает приложение с приоритетом выше среднего.
/belownormal
Запускает приложение с приоритетом ниже среднего.
/wait
Запускает приложение с ожиданием окончания его работы.
/b
Запускает приложение без открытия нового окна командной строки. Обработка комбинации клавиш CTRL+C не производится, пока приложение не разрешит обработку CTRL+C. Для прерывания приложения следует использовать CTRL+BREAK.
имя_файла
Задает команду или программу для запуска.
параметры
Задает параметры, которые будут переданы вызываемой программе.

Примечания

  • Неисполняемые файлы можно запустить через сопоставление файла с приложением. Для этого просто введите имя файла (как команду). Для получения дополнительных сведений о создании этих сопоставлений в командном сценарии используйте команды assoc и ftype, см. Справочник.
  • Когда выполняется команда, в которой есть строка «CMD», являющаяся первым элементом без классификаторов расширения или пути, «CMD» заменяется значением переменной COMSPEC. Таким образом запрещается запуск cmd из текущего каталога.
  • При выполнении приложения 32-разрядного графического интерфейса пользователя, команда cmd не дожидается завершения приложения перед возвращением в командную строку. Этого не происходит, если приложение запускается из командной строки.
  • Когда выполняется команда, первый элемент которой не содержит расширения, CMD.EXE использует значение переменной среды PATHEXT для определения расширений, поиск которых будет производиться и порядок их поиска. По умолчанию значения для переменной PATHEXT: .COM, .EXE, .BAT, .CMD (т. е., синтаксис такой же, как у переменной PATH; различные элементы разделяются точками с запятой).
  • Когда ведется поиск исполняемого файла и не находится соответствующего расширения, команда start начинает поиск каталога. Если он существует, команда start отрывает программу Explorer.exe по этому маршруту.

Примеры

Для того чтобы запустить программу Myapp, но при этом остаться в текущем окне командной строки, следует использовать следующую команду:

start myapp


Subst

Устанавливает соответствие пути в файловой системе заданному диску. Вызванная без параметров, команда subst выводит имена виртуальных дисков, созданных предыдущими вызовами команды.

Синтаксис

subst [диск: [диск2:]путь]

subst диск1: /d

Параметры

диск1:
Задает диск, которому будет поставлен в соответствие заданный путь
диск2:
Задает физический диск, на который ссылается заданный путь (если не совпадает с текущим диском).
путь
Задает путь, который ставится в соответствие диску.
/d
Удаляет виртуальный диск.
/?
Отображает справку в командной строке.

Примечания

  • Следующие команды не будут работать и не должны быть использованы с дисками, созданными командой subst:
    • chkdsk
    • diskcomp
    • diskcopy
    • format
    • label
    • recover
  • Параметр диск1 должен лежать в диапазоне, задаваемом командой lastdrive. В противном случае subst выведет следующее сообщение об ошибке:

    Недопустимый параметр - диск1:

Примеры

Чтобы создать виртуальный диск Z на пути B:\User\Betty\Forms, введите следующую команду:

subst z: b:\user\betty\forms

Теперь, вместо ввода полного имени, можно получить доступ к каталогу, обращаясь к диску, как показано ниже:

z:


Switches

Позволяет работать с расширенной клавиатурой как с обычной.

Синтаксис

switches=/k

Параметры

отсутствуют

Примечания

  • Команда используется в файле Config.nt.
  • Команда может быть использована при работе с программой, которая не воспринимает коды клавиш расширенной клавиатуры.
  • Если использована команда switches=/k и установлен драйвер Ansi.sys, параметр командной строки /k должен быть задан в команде device, загружающей драйвер Ansi.sys.

Примеры

Если требуется использование функций обычной клавиатуры даже при подключении расширенной клавиатуры, в файл Config.nt должна быть включена следующая команда:

switches=/k


Программа проверки системных файлов (sfc)

Сканирует и проверяет версии всех защищенных системных файлов после перезапуска компьютера.

Синтаксис

sfc [/scannow] [/scanonce] [/scanboot] [/revert] [/purgecache] [/cachesize=x]

Параметры

/scannow
Незамедлительно сканирует все защищенные системные файлы.
/scanonce
Однократно сканирует все защищенные системные файлы.
/scanboot
Сканирует все защищенные системные файлы каждый раз при перезапуске компьютера.
/revert
Восстанавливает стандартные параметры работы сканера.
/purgecache
Очищает кэш файлов программы защиты файлов Windows и немедленно сканирует все защищенные системные файлы.
/cachesize=x
Назначает размер, в мегабайтах (Мбайт), кэша файлов для защиты файлов Windows.
/?
Отображает справку в командной строке.

Примечания

  • Для выполнения команды sfc необходимо войти в систему в качестве члена группы администраторов.
  • Если программа sfc находит, что защищенный файл был переопределен, подходящая версия файла восстанавливается из папки %системный_корневой_каталог%\system32\dllcache, а затем заменяет неправильный файл.
  • Если папка %системный_корневой_каталог%\system32\dllcache повреждается или становится непригодной для пользования, восстановите ее содержимое с помощью команд sfc /scannow, sfc /scanonce или sfc /scanboot.


Systeminfo

Выводит на экран подробные сведения о конфигурации компьютера и операционной системы, сведения о безопасности, код продукта и параметры оборудования, такие как ОЗУ, дисковое пространство и сетевые карты.

Синтаксис

systeminfo[.exe] [/s компьютер [/u домен\пользователь [/p пароль]]] [/fo {TABLE|LIST|CSV}] [/nh]

Параметры

/s компьютер
Указывает имя или IP-адрес удаленного компьютера (не используйте обратную косую черту). По умолчанию используется локальный компьютер.
/u домен\пользователь
Выполняет команду с разрешениями учетной записи пользователя, который указан как пользователь или домен\пользователь. По умолчанию используются разрешения текущего вошедшего пользователя компьютера, с которого поступила эта команда.
/p пароль
Определяет пароль учетной записи пользователя, заданной параметром /u.
/fo {TABLE|LIST|CSV}
Задает формат выходных данных. Допустимые значения: TABLE, LIST и CSV. По умолчанию для выходных данных используется формат TABLE.
/nh
Запрещает вывод заголовков столбцов. Данный параметр является допустимым, если параметр /fo имеет значение TABLE или CSV.
/?
Отображает справку в командной строке.

Примеры

Далее приведены примеры использования команды getmac:

systeminfo.exe /s srvmain
systeminfo.exe /s srvmain /u maindom\hiropln
systeminfo /s srvmain /u maindom\hiropln /p p@ssW23 /fo table


Taskkill

Завершает одно или несколько заданий или процессов. Процессы могут быть уничтожены кодом процесса или именем образа.

Синтаксис

taskkill [/s компьютер] [/u домен\пользователь [/p пароль]]] [/fi имя_фильтра] [/pid код_процесса]|[/im имя_образа] [/f][/t]

Параметры

/s компьютер
Указывает имя или IP-адрес удаленного компьютера (не используйте обратную косую черту). По умолчанию используется локальный компьютер.
/u домен\пользователь
Выполнение команды с разрешениями учетной записи пользователя, который указан как пользователь или домен\пользователь. По умолчанию используются разрешения текущего вошедшего пользователя компьютера, с которого поступила эта команда.
/p пароль
Определяет пароль учетной записи пользователя, заданной параметром /u.
/fi имя_фильтра
Задает типы процессов, которые следует завершить и не следует. Допустимыми именами фильтров, операторами и значениями являются следующие.
Имя | Операторы | Значение
Hostname | eq, ne | Любая допустимая строка
Status | eq, ne | RUNNING|NOT RESPONDING
Imagename | eq, ne | Любая допустимая строка
PID | eg, ne, gt, lt, ge, le | Любой положительное число
Session | eg, ne, gt, lt, ge, le | Любой действительный номер сеанса
CPUTime | eg, ne, gt, lt, ge, le | Допустимое время в формате чч:мм:сс. Компоненты мм и сс должны иметь значения от 0 до 59, а чч может быть любым значением числа без знака
Memusage | eg, ne, gt, lt, ge, le | Любое целое число
Username | eq, ne | Любое действительное имя пользователя ([домен\]пользователь).
Services | eq, ne | Любая допустимая строка
Windowtitle | eq, ne | Любая допустимая строка
/pid код_процесса
Указывает код процесса, который необходимо завершить.
/im имя_образа
Указывает имя образа процесса, который необходимо завершить. Используйте подстановочный знак (*) для указания всех имен образа.
/f
Указывает, что процесс(ы) должен быть принудительно завершен. Этот параметр не действует для удаленных процессов, все удаленные процессы завершаются принудительно.
/t
Задает завершение всех дочерних процессов вместе с родительским, такое действие обычно известно как уничтожение дерева.
/?
Отображает справку в командной строке.

Примечания

  • Подстановочный символ (*) принимается только при указании вместе с фильтрами.
  • Завершение удаленных процессов всегда выполняется принудительно независимо от указания параметра /f.
  • Указание имени компьютера в качестве фильтра HOSTNAME приведет к завершению работы и остановке всех процессов.
  • Используйте команду tasklist для определения кода завершаемого процесса.
  • Команда taskkill является заменой средству Kill.

Примеры

Далее приведены примеры использования команды taskkill:

taskkill /pid 1230 /pid 1241 /pid 1253
taskkill /f /fi "USERNAME eq NT AUTHORITY\SYSTEM" /im notepad.exe
taskkill /s srvmain /f /im notepad.exe
taskkill /s srvmain /u maindom\hiropln /p p@ssW23 /fi "IMAGENAME eq note*" /im *
taskkill /s srvmain /u maindom\hiropln /fi "USERNAME ne NT*" /im *
taskkill /f /fi "PID ge 1000" /im *


Tasklist

Отображает список приложений и служб с кодом процесса (PID) для всех задач, выполняющихся на локальном или удаленном компьютере.

Синтаксис

tasklist[.exe] [/s компьютер] [/u домен\пользователь [/p пароль]] [/fo {TABLE|LIST|CSV}] [/nh] [/fi фильтр [/fi фильтр2 [ ... ]]] [/m [модуль] | /svc | /v]

Параметры

/s компьютер
Указывает имя или IP-адрес удаленного компьютера (не используйте обратную косую черту). По умолчанию используется локальный компьютер.
/u домен\пользователь
Выполняет команду с разрешениями учетной записи пользователя, который указан как пользователь или домен\пользователь. По умолчанию используются разрешения текущего вошедшего пользователя компьютера, с которого поступила эта команда.
/p пароль
Определяет пароль учетной записи пользователя, заданной параметром /u.
/fo {TABLE|LIST|CSV}
Задает формат выходных данных. Допустимые значения: TABLE, LIST и CSV. По умолчанию для выходных данных используется формат TABLE.
/nh
Запрещает вывод заголовков столбцов. Данный параметр является допустимым, если параметр /fo имеет значение TABLE или CSV.
/fi имя_фильтра
Задает типы процессов, которые следует завершить или не следует. Допустимыми именами фильтров, операторами и значениями являются следующие.
Имя | Операторы | Значение
Status | eq, ne | RUNNING|NOT RESPONDING
Imagename | eq, ne | Любая допустимая строка
PID | eg, ne, gt, lt, ge, le | Любой положительное число
Session | eg, ne, gt, lt, ge, le | Любой действительный номер сеанса.
SessionName | eq, ne | Любая допустимая строка
CPUTime | eg, ne, gt, lt, ge, le | Допустимое время в формате чч:мм:сс. Компоненты мм и сс должны иметь значения от 0 до 59, а чч может быть любым значением числа без знака
Memusage | eg, ne, gt, lt, ge, le | Любое целое число
Username | eq, ne | Любое действительное имя пользователя ([домен\]пользователь)
Services | eq, ne | Любая допустимая строка
Windowtitle | eq, ne | Любая допустимая строка
Modules | eq, ne | Любая допустимая строка
/m [модуль]
Задает вывод сведений о модулях для каждого процесса. При указании модуля отображаются все процессы, использующие этот модуль. Если модуль не определен, выводятся на экран все процессы для всех модулей. Нельзя использовать совместно с параметрами /svc и /v
/svc
Отображает без обрезки сведения о всех службах для каждого процесса. Данный параметр является допустимым, если параметр /fo имеет значение TABLE. Нельзя использовать совместно с параметрами /m и /v
/v
Задает отображение подробных сведений о задании в выходных данных. Нельзя использовать совместно с параметрами /svc и /m.
/?
Отображает справку в командной строке.

Примечания

  • Команда tasklist является заменой средству TList.

Примеры

Далее приведены примеры использования команды taskkill:

tasklist /v /fi "PID gt 1000" /fo csv
tasklist /fi "USERNAME ne NT AUTHORITY\SYSTEM" /fi "STATUS eq running"
tasklist /v /fi "STATUS eq running"
tasklist /s srvmain /nh
tasklist /s srvmain /s srvny
tasklist /s srvmain /u maindom\hiropln /p p@ssW23 /nh


Tcmsetup

Настраивает или отключает клиента TAPI.

Синтаксис

tcmsetup [/q] [/x] /c сервер1 [сервер2...]

tcmsetup [/q] /c /d

Параметры

/q
Запрещает вывод сообщений.
/x
Указывает ответные вызовы при установке соединения для сетей с высокой нагрузкой, в которых велики потери пакетов. При отсутствии параметра используются обратные вызовы без установки соединения.
/c
Обязательный параметр. Указывает настройку клиента.
сервер1
Обязательный параметр. Указывает имя удаленного сервера, у которого есть поставщики услуг TAPI, необходимые клиенту. Клиент использует линии и телефоны служб поставщиков. Клиент должен находиться в одном домене с сервером или в домене, у которого установлены двухсторонние отношения доверия с доменом, содержащим сервер.
сервер2...
Указывает дополнительный сервер или несколько серверов, доступных клиенту. При вводе списка серверов вставляйте пробел между именами серверов.
/d
Очищает список удаленных серверов. Отключает клиента телефонии, запретив ему использовать поставщиков услуг TAPI на удаленных серверах.
/?
Отображает справку в командной строке.

Примечания

  • Для правильной работы телефонии TAPI выполните команду tcmsetup для указания удаленных серверов, используемых клиентами TAPI.
  • Чтобы запустить эту команду, необходимо принадлежать к группе администраторов.
  • Перед тем как пользователь сможет использовать телефон или линию на сервере TAPI, администратор сервера телефонии должен назначить пользователю телефон или линию.
  • Список серверов телефонии, созданный этой командой, заменяет существующий список серверов, доступных клиенту. Данную команду нельзя использовать для добавления сервера в существующий список.


Службы и программы TCP/IP

Служебные программы TCP/IP обеспечивают подключение к сетям, например к сетям UNIX-компьютеров. Чтобы использовать программы TCP/IP, на компьютере должна быть установлена поддержка протокола TCP/IP.

Для получения сведений щелкните ссылку.

  • Arp
  • Nslookup
  • Finger
  • Ping
  • Ftp
  • Rcp
  • Hostname
  • Rexec
  • Ipconfig
  • Route
  • Lpq
  • Rsh
  • Lpr
  • Tftp
  • Nbtstat
  • Tracert
  • Netstat


Команды Telnet

Команды telnet позволяют связаться с удаленным компьютером, использующим протокол Telnet. Можно выполнить команду telnet без параметров для входа в контекст telnet, обозначенный в командной строке Telnet (telnet). В командной строке Telnet используйте следующие команды для управления компьютером, на котором выполняется клиент Telnet.

Команды tlntadmn позволяют удаленно управлять компьютером, на котором выполняется сервер Telnet. Эти команды выполняются из командной строки. Команда tlntadmn без параметров отображает настройку локального сервера.

Чтобы использовать команды telnet из командной строки Telnet

Чтобы запустить клиент Telnet и ввести командную строку Telnet

Синтаксис

telnet [\\удаленный_сервер]

Параметры

\\удаленный_сервер
Отображает имя подключаемого сервера
/?
Отображает справку в командной строке.

Примечания

  • При использовании команды telnet без параметров запускается клиент Telnet.
  • В командной строке Telnet необходимо использовать команды Telnet.

Чтобы остановить клиент Telnet

Синтаксис

quit

Параметры

отсутствуют

Примечания

  • Допускается сокращение этой команды до q.

Чтобы подключить клиент Telnet к удаленному компьютеру

Синтаксис

open [\\удаленный_сервер] [порт]

Параметры

\\удаленный_сервер
Указывает имя управляемого сервера. Если сервер не указан, используется локальный сервер.
порт
Указывает используемый порт. Если порт не указан, используется порт по умолчанию.

Примечания

  • Допускается сокращение этой команды до o.

Примеры

Чтобы подключиться к удаленному серверу Redmond через порт 44, введите в командную строку:
o redmond 44

Чтобы отключить клиент Telnet от удаленного компьютера

Синтаксис

close [\\удаленный_сервер]

Параметры

\\удаленный_сервер
Указывает имя управляемого сервера. Если сервер не указан, используется локальный сервер.

Примечания

  • Допускается сокращение этой команды до c.

Примеры

Чтобы отключиться от удаленного сервера Redmond, введите команду:
c redmond 44

Чтобы настроить параметры клиента Telnet

Синтаксис

set [\\удаленный_сервер] [ntlm] [localecho] [term {ansi | vt100 | vt52 | vtnt}] [escape символ] [logfile имя_файла] [logging] [bsasdel] [crlf] [delasbs] [mode {console | stream}] [?]

Параметры

\\удаленный_сервер
Указывает имя управляемого сервера. Если сервер не указан, используется локальный сервер.
ntlm
Включает проверку подлинности NTML, если она доступна на удаленном сервере.
localecho
Включает режим локального отображения команд.
term {ansi | vt100 | vt52 | vtnt}
Задает терминал указанного типа.
escape символ
Задает управляющий символ. Управляющий символ может быть отдельным символом или сочетанием клавиши CTRL и символа. Чтобы задать комбинацию клавиш, удерживайте клавишу CTRL во время ввода символа, который необходимо назначить.
logfile имя_файла
Задает файл журнала активности Telnet. Файл журнала должен располагаться на локальном компьютере. Запись в журнал начинается автоматически после выбора этого параметра.
logging
Включает ведение журнала. Если файл журнала не задан, выводится сообщение об ошибке.
bsasdel
Задает клавишу BACKSPACE, как удалить.
crlf
Назначает новый линейный режим, который опреляет клавишу ENTER как 0x0D, 0x0A.
delasbs
Назначает клавише DELETE значение удаления последнего символа.
mode {console | stream}
Задает режим работы.
?
Позволяет просматривать полный синтаксис команды.

Примечания

  • Чтобы отключить назначенный ранее параметр, в командной строке Telnet, введите:

    unset [параметр]

  • Чтобы назначить управляющий символ, введите команду:

    –e символ

  • В версиях Telnet, отличных от английской, доступна команда codeset параметр. Codeset параметр задает текущий кодовый набор для параметра, который может быть одним из следующих: Shift JIS, Japanese EUC, JIS Kanji, JIS Kanji (78), DEC Kanji, NEC Kanji. Необходимо назначить такой же кодовый набор на удаленном компьютере.

Чтобы отправить команды клиента Telnet

Синтаксис

send [\\удаленный_сервер] [ao] [ayt] [esc] [ip] [synch] [?]

Параметры

\\удаленный_сервер
Имя сервера, к управлению которым требуется перейти. Если сервер не указан, используется локальный сервер.
ao
Отменяет команду ввода.
ayt
Посылает команду «Вы на месте?»
esc
Отправляет текущий управляющий знак.
ip
Прерывает выполнение команды обработки.
synch
Выполняет операцию синхронизации Telnet.
?
Позволяет просматривать полный синтаксис команды.

Чтобы посмотреть текущие параметры клиента Telnet

Синтаксис

display

Параметры

отсутствуют

Примечания

  • Данная команда выводит текущие рабочие параметры для клиента Telnet. При работе в режиме сеанса Telnet (другими словами, при подключении к серверу Telnet), можно выйти из сеанса для изменения параметров, нажав клавиши CTRL+]. Для возвращения в сеанс Telnet нажмите клавишу ENTER.

Чтобы использовать команды tlntadmn из командной строки

Чтобы администрировать компьютер, на котором выполняется сервер Telnet/P>

Синтаксис

tlntadmn [\\удаленный_сервер] [start] [stop] [pause] [continue]

Параметры

\\удаленный_сервер
Указывает имя сервера, к управлению которым требуется перейти. Если сервер не указан, используется локальный сервер.
start
Запускает сервер Telnet.
stop
Останавливает сервер Telnet.
pause
Прерывает работу сервера Telnet.
continue
Возобновляет работу сервера Telnet.
/?
Отображает справку в командной строке.

Примечания

  • С помощью команд tlntadmn можно удаленно администрировать компьютер, на котором запущен сервер Telnet, если оба компьютера работают под управлением Windows XP. Команды tlntadmn не могут быть использованы для удаленного администрирования сервера Telnet, работающего под управлением Windows 2000, с компьютера, работающего под управлением Windows XP.

Чтобы администрировать сеансы Telnet

Синтаксис

tlntadmn [\\удаленный_сервер] [-s] [-k{код_сеанса | all}] [-m {код_сеанса | all} "сообщение"]

Параметры

\\удаленный_сервер
Указывает имя сервера, к управлению которым требуется перейти. Если сервер не указан, используется локальный сервер.
-s
Отображает активные сеансы Telnet.
-k{код_сеанса | all}
Завершает сеансы. Введите код сеанса для завершения конкретного сеанса или введите all для завершения всех сеансов.
-m {код_сеанса | all} "сообщение"
Отправляет сообщение в один или несколько сеансов. Введите код сеанса для отправки сообщения в конкретный сеанс или введите all для отправки сообщения во все сеансы. Введите сообщение, которое нужно послать, в кавычках (т. е. "сообщение").
/?
Отображает справку в командной строке.

Примечания

  • С помощью команд tlntadmn можно удаленно администрировать компьютер, на котором запущен сервер Telnet, если оба компьютера работают под управлением Windows XP. Команды tlntadmn не могут быть использованы для удаленного администрирования сервера Telnet, работающего под управлением Windows 2000, с компьютера, работающего под управлением Windows XP.

Чтобы установить параметры журнала событий для компьютера, на котором выполняется сервер Telnet

Синтаксис

tlntadmn [\\удаленный_компьютер] config [auditlocation={eventlog | file | both}][audit=[{+ | -}admin][{+ | -}user][{+ | -}fail]]

Параметры

\\удаленный_сервер
Указывает имя сервера, к управлению которым требуется перейти. Если сервер не указан, используется локальный сервер.
auditlocation={eventlog | file | both}
Указывает, следует ли отправлять сведения о событиях в окно просмотра событий, в файл или в оба места.
audit=[{+ | -}admin][{+ | -}user][{+ | -}fail]
Указывает, для каких событий требуется аудит (события регистрации администратора, события регистрации пользователя или неудачные попытки регистрации). Чтобы задать аудит событий конкретного типа, введите знак «плюс» (+) перед данным типом событий. Чтобы остановить аудит событий конкретного типа, введите знак «минус» (-) перед данным типом событий.
/?
Отображает справку в командной строке.

Примечания

  • С помощью команд tlntadmn можно удаленно администрировать компьютер, на котором запущен сервер Telnet, если оба компьютера работают под управлением Windows XP. Команды tlntadmn не могут быть использованы для удаленного администрирования сервера Telnet, работающего под управлением Windows 2000, с компьютера, работающего под управлением Windows XP.
  • Если указано, куда отправить сведения о событии без определения типа или типов сведений для аудита, только для сведений о событиях регистрации администратора будет проводиться аудит и отправка в указанное место.

Примеры

Для отправки информации о событиях в окно просмотра событий введите:

tlntadmn config auditlocation=eventlog

Для аудита событий регистрации администратора и неудачных попыток регистрации введите:

tlntadmn config audit=+admin +fail

Чтобы задать основной домен для компьютера, на котором выполняется сервер Telnet

Синтаксис

tlntadmn [\\удаленный_сервер] config [dom=имя_домена]

Параметры

\\удаленный_сервер
Указывает имя сервера, к управлению которым требуется перейти. Если сервер не указан, используется локальный сервер.
dom=имя_домена
Указывает домен, который требуется сделать основным.
/?
Отображает справку в командной строке.

Примечания

  • С помощью команд tlntadmn можно удаленно администрировать компьютер, на котором запущен сервер Telnet, если оба компьютера работают под управлением Windows XP. Команды tlntadmn не могут быть использованы для удаленного администрирования сервера Telnet, работающего под управлением Windows 2000, с компьютера, работающего под управлением Windows XP.

Примеры

Чтобы сделать домен Redmond основным доменом на локальном сервере, введите:

tlntadmn config dom=Redmond

Чтобы сопоставить клавишу ALT для компьютера, на котором выполняется сервер Telnet

Синтаксис

tlntadmn [\\удаленный_сервер] config [ctrlakeymap={yes | no}]

Параметры

\\удаленный_сервер
Указывает имя сервера, к управлению которым требуется перейти. Если сервер не указан, используется локальный сервер.
ctrlakeymap={yes | no}
Указывает, требуется ли интерпретация сервером Telnet сочетания клавиш CTRL+A как ALT. Введите yes для сопоставления сочетания клавиш или no для отказа от сопоставления.
/?
Отображает справку в командной строке.

Примечания

  • С помощью команд tlntadmn можно удаленно администрировать компьютер, на котором запущен сервер Telnet, если оба компьютера работают под управлением Windows XP. Команды tlntadmn не могут быть использованы для удаленного администрирования сервера Telnet, работающего под управлением Windows 2000, с компьютера, работающего под управлением Windows XP.
  • Если клавиша ALT не сопоставлена, сервер Telnet не отправляет нажатие клавиши ALT в приложения, где это может потребоваться.

Чтобы задать максимальное число подключений для компьютера, на котором выполняется сервер Telnet

Синтаксис

tlntadmn [\\удаленный_сервер] config [maxconn=положительное_целое]

Параметры

\\удаленный_сервер
Указывает имя сервера, к управлению которым требуется перейти. Если сервер не указан, используется локальный сервер.
maxconn=положительное_целое
Устанавливает максимальное число подключений. Этот номер можно указать с помощью любого положительного целого меньше 10 миллионов.
/?
Отображает справку в командной строке.

Примечания

  • С помощью команд tlntadmn можно удаленно администрировать компьютер, на котором запущен сервер Telnet, если оба компьютера работают под управлением Windows XP. Команды tlntadmn не могут быть использованы для удаленного администрирования сервера Telnet, работающего под управлением Windows 2000, с компьютера, работающего под управлением Windows XP.

Чтобы задать максимальное число неудачных попыток доступа для компьютера, на котором выполняется сервер Telnet

Синтаксис

tlntadmn [\\удаленный_компьютер] config [maxfail=положительное_целое]

Параметры

\\удаленный_сервер
Указывает имя сервера, к управлению которым требуется перейти. Если сервер не указан, используется локальный сервер.
maxfail=положительное_целое
Задает максимальное разрешенное число неудачных попыток входа для пользователя. Этот номер можно указать с помощью любого положительного целого меньше 100.
/?
Отображает справку в командной строке.

Примечания

  • С помощью команд tlntadmn можно удаленно администрировать компьютер, на котором запущен сервер Telnet, если оба компьютера работают под управлением Windows XP. Команды tlntadmn не могут быть использованы для удаленного администрирования сервера Telnet, работающего под управлением Windows 2000, с компьютера, работающего под управлением Windows XP.

Чтобы задать режим работы для компьютера, на котором выполняется сервер Telnet

Синтаксис

tlntadmn [\\удаленный_сервер] config [mode={console | stream}]

Параметры

\\удаленный_сервер
Указывает имя сервера, к управлению которым требуется перейти. Если сервер не указан, используется локальный сервер.
mode {console | stream}
Указывает режим работы.
/?
Отображает справку в командной строке.

Примечания

  • С помощью команд tlntadmn можно удаленно администрировать компьютер, на котором запущен сервер Telnet, если оба компьютера работают под управлением Windows XP. Команды tlntadmn не могут быть использованы для удаленного администрирования сервера Telnet, работающего под управлением Windows 2000, с компьютера, работающего под управлением Windows XP.

Чтобы задать порт Telnet для компьютера, на котором выполняется сервер Telnet

Синтаксис

tlntadmn [\\удаленный_сервер] config [port=целое_значение]

Параметры

\\удаленный_сервер
Указывает имя сервера, к управлению которым требуется перейти. Если сервер не указан, используется локальный сервер.
port=целое_значение
Задает порт Telnet. Порт можно указать с помощью любого целого меньше 1 024.
/?
Отображает справку в командной строке.

Примечания

  • С помощью команд tlntadmn можно удаленно администрировать компьютер, на котором запущен сервер Telnet, если оба компьютера работают под управлением Windows XP. Команды tlntadmn не могут быть использованы для удаленного администрирования сервера Telnet, работающего под управлением Windows 2000, с компьютера, работающего под управлением Windows XP.

Чтобы задать методы проверки подлинности для компьютера, на котором выполняется сервер Telnet

Синтаксис

tlntadmn [\\удаленный_сервер] config [sec=[{+ | -}ntlm][{+ | -}passwd]]

Параметры

\\удаленный_сервер
Указывает имя сервера, к управлению которым требуется перейти. Если сервер не указан, используется локальный сервер.
sec=[{+ | -}ntlm][{+ | -}passwd]
Определяет использование проверки подлинности NTML или пароля, или одновременое их применение для проверки подлинности попыток входа. Чтобы использовать конкретный тип проверки подлинности, введите знак «плюс» (+) перед данным типом проверки. Чтобы предотвратить использование проверки подлинности определенного типа, введите знак «минус» (-) перед этим типом.
/?
Отображает справку в командной строке.

Примечания

  • С помощью команд tlntadmn можно удаленно администрировать компьютер, на котором запущен сервер Telnet, если оба компьютера работают под управлением Windows XP. Команды tlntadmn не могут быть использованы для удаленного администрирования сервера Telnet, работающего под управлением Windows 2000, с компьютера, работающего под управлением Windows XP.
  • NTML — это протокол проверки подлинности для транзакций между двумя компьютерами, один из которых или оба находятся под управлением Windows NT 4.0 и более ранних версий. Кроме того, протокол проверки подлинности NTML используется для компьютеров, не входящих в домен, таких как независимые серверы и рабочие группы.

Чтобы задать таймаут простоя сеансов для компьютера, на котором выполняется сервер Telnet

Синтаксис

tlntadmn [\\удаленный_сервер] config [timeout=чч:мм:сс]

Параметры

\\удаленный_сервер
Указывает имя сервера, к управлению которым требуется перейти. Если сервер не указан, используется локальный сервер.
timeout=чч:мм:сс
Задает значение истечения времени в часах, минутах и секундах.
/?
Отображает справку в командной строке.

Примечания

  • С помощью команд tlntadmn можно удаленно администрировать компьютер, на котором запущен сервер Telnet, если оба компьютера работают под управлением Windows XP. Команды tlntadmn не могут быть использованы для удаленного администрирования сервера Telnet, работающего под управлением Windows 2000, с компьютера, работающего под управлением Windows XP.

Примечания

  • Чтобы переключиться с клиента Telnet в режим команд, в командной строке Telnet нажмите сочетание клавиш CTRL+]. Для обратного перехода к клиенту Telnet, нажмите клавишу ENTER.


Time

Выводит и задает системное время. При использовании без параметров, команад time отображает системное время и предалагает ввести новое время.

Синтаксис

time [/t] [/time] [часы:[минуты[:секунды[.сотые]]][{A|P}]]

Параметры

/t
Выводит на экран текущее системное время без предложения ввода нового.
/time
Такой же как параметр /t.
часы
Задает значение часов. Допустимы величины от 0 до 23.
минуты
Задает значение минут. Допустимы величины от 0 до 59.
секунды
Задает значение секунд. Допустимы величины от 0 до 59.
сотые
Задает значение сотых долей секунды. Допустимы величины от 0 до 99.
{A|P}
Задает время до полудня (A.M.) или после полудня (P.M.) для 12-часового формата времени. Если указано допустимое 12-ти часовое значение, но не задано значение A или P, команда time использует A (до полудня).
/?
Отображает справку в командной строке.

Примечания

  • Чтобы сохранить время при использовании команды time без параметров, нажмите клавишу ENTER.
  • Использование параметра /t

    Параметр командной строки /t доступен только в том случае, если расширения командного процессора разрешены (разрешены по умолчанию). Дополнительные сведения о расширениях командного процессора см. в разделе cmd, доступном по ссылке «См. также».

  • Задание недопустимого формата времени

    При задании недопустимого формата времени выводится сообщение и предлагается ввести время корректно:

    Указано недопустимое время
    Введите новое время:_

  • Изменение формата времени

    Формат представления времени может быть изменен с помощью объекта Дата и время на панели управления. Чтобы изменить настройки только в подсистеме MS-DOS, измените параметр country в файле Config.nt. В зависимости от выбранной страны, время выводится в 12- или 24-часовом формате. Если время задано в 12-часовом формате, следует задавать параметр P для значений времени после полудня.

Примеры

Для установки часов компьютера на 1:36 после полудня введите одну из следующих команд:

time 13:36

time 1:36P


W32tm

Используется для определения причины неполадок, связанных со службой времени Windows

Синтаксис

  • {/config [/computer:имя_компьютера] [ [/update] [/manualpeerlist:список_компьютеров] ] [/syncfromflags:список_флажков] ]|/monitor|/ntte|/ntpte|/register|/resync [{:имя_компьютера] [/nowait]|[/rediscover}]|/tz|/unregister}

    Параметры

    /config [/computer:имя_компьютера] [ [/update] [/manualpeerlist:список_компьютеров] ] [/syncfromflags:список_флажков]
    Выполняет согласование настроек времени на локальном и конечном компьютере. Одинаковое время синхронизации можно задать с помощью ключа /manualpeerlist. Изменения конфигурации не учитываются, пока не перезапустится служба времени Windows или не будет использован ключ /update. Ключ /syncfromflags применяется, чтобы задать типы источников синхронизации, и может быть установлен либо MANUAL для использования списка узлов, заданного вручную, или DOMHIER для синхронизации с контроллера домена.
    /monitor
    Осуществляет наблюдение за конечным компьютером или списком компьютеров.
    /ntte
    Преобразует системное время NT в читаемый формат.
    /ntpte
    Преобразует время NTP в читаемый формат.
    /register
    Регистрирует запуск службы и добавляет стандартную конфигурацию в реестр.
    /resync [{:имя_компьютера] [/nowait]|[/rediscover}]
    Ресинхронизирует часы по мере возможности, не обращая внимания статистику накопленных ошибок. Если не указан компьютера, ресинхронизирован будет локальный компьютер. Ресинхронизация не выполняется без использования ключа /nowait. Текущие источники времени используются до тех пор, пока не введен ключ /rediscover, который выполняет принудительное повторное обнаружение сетевых ресурсов перед ресинхронизацией.
    /tz
    Отображает текущую настройку часового пояса
    /unregister
    Отменяет регистрацию службы и удаляет сведения о конфигурации из реестра.
    /?
    Отображает справку в командной строке.

    Примечания

    • Средство предназначено для системных администраторов для определения причин неполадок, связанных со временем системы Windows.

      Для получения дополнительных сведений см. раздел net time.

    • Чтобы служба времени Windows использовала изменения, выполненные с помощью команды W32tm, необходимо оповестить службу. Чтобы оповестить службу времени Windows, в командной строке введите: w32tm /config /update.

    Примеры

    Чтобы отобразить текущую настройку часового пояса, введите команду:

    w32tm /tz


Title

Создает заголовок окна командной строки.

Синтаксис

title [строка]

Параметры

строка
Задает текст заголовка окна командной строки.
/?
Отображает справку в командной строке.

Примечания

  • Чтобы указать заголовок окна для пакетных программ, включите команду title в начало пакетной программы.
  • Установленный заголовок окна может быть изменен только повторным вызовом команды title.

Примеры

Чтобы установить заголовок окна для пакетной программы, введите следующую команду:

rem Эта пакетная программа обновляет сведения о сотруднике:
cls
@echo off
title Обновление файлов
copy \\server\share\*.xls c:\users\common\*.xls
echo Файлы обновлены.
title Командная строка

См. также


Tree

Представляет графически дерево каталогов заданного пути или диска.

Синтаксис

tree [диск:][путь] [/f] [/a]

Параметры

диск:
Задает дисковод, содержащий диск, графическое представление дерева каталогов которого будет выведено.
путь
Задает каталог, для которого будет выведена структура подкаталогов.
/f
Выводит имена файлов в каждом каталоге.
/a
Задает использование командой tree текстовых символов вместо графических для вывода связей между каталогами.
/?
Отображает справку в командной строке.

Примечания

  • Структура дерева, выводимого командой tree на монитор, определяется параметрами, заданными при вызове команды. Если диск или путь не заданы, команда tree выведет часть дерева каталогов, начиная с текущего каталога на текущем диске.

Примеры

Для вывода имен всех подкаталогов на текущем диске служит следующая команда:

tree \

Для постраничного вывода имен файлов во всех каталогах диска C можно использовать следующую команду:

tree c:\ /f | more

Для печати списка файлов из предыдущего примера может быть использована следующая команда:

tree c:\ /f > prn

См. также


Type

Вывод содержимого текстового файла на экран. Команда type применяется для просмотра текстового файла без его изменения.

Синтаксис

type [диск:][путь] имя_файла

Параметры

[диск:][путь] имя_файла
Задает местоположение и имя файла для просмотра. Имена нескольких файлов разделяются пробелами.
/?
Отображает справку в командной строке.

Примечания

  • Если используется диск файловой системы NTFS и имя_файла содержит пробелы, заключайте текст в кавычки (т. е. "имя файла").
  • Если на экран выводится двоичный файл или файл, созданный программой, возможно появление на экране служебных символов, таких как прогон страницы или управляющие последовательности. Эти символы представляют собой коды управления, используемые в двоичных файлах. Обычно команда type не используется для просмотра двоичных файлов.

Примеры

Чтобы вывести содержимое файла с именем Holiday.mar, введите следующую команду:

type holiday.mar

Чтобы вывести содержимое большого файла с паузой после заполнения экрана, введите следующую команду:

type holiday.mar | more


Tracert

Определяет путь до точки назначения с помощью посылки в точку назначения эхо-сообщений протокола Control Message Protocol (ICMP) с постоянным увеличением значений срока жизни (Time to Live, TTL). Выведенный путь — это список ближайших интерфейсов маршрутизаторов, находящихся на пути между узлом источника и точкой назначения. Ближний интерфейс представляют собой интерфейс маршрутизатора, который является ближайшим к узлу отправителя на пути. Запущенная без параметров, команда tracert выводит справку.

Синтаксис

tracert
 [-d]
 [-h максимальное_число_переходов]
 [-j список_узлов]
 [-w интервал] [имя_конечного_компьютера]

Параметры

-d
Предотвращает попытки команды tracert разрешения IP-адресов промежуточных маршрутизаторов в имена. Увеличивает скорость вывода результатов команды tracert.
-h максимальное_число_переходов
Задает максимальное количество переходов на пути при поиске конечного объекта. Значение по умолчанию равно 30.
-j список_узов
Указывает для сообщений с эхо-запросом использование параметра свободной маршрутизации в заголовке IP с набором промежуточных мест назначения, указанных в списке_узлов. При свободной маршрутизации успешные промежуточные места назначения могут быть разделены одним или несколькими маршрутизаторами. Максимальное число адресов или имен в списке — 9. Список_адресов представляет набор IP-адресов (в точечно-десятичной нотации), разделенных пробелами.
-w интервал
Определяет в миллисекундах время ожидания для получения эхо-ответов протокола ICMP или ICMP-сообщений об истечении времени, соответствующих данному сообщению эхо-запроса. Если сообщение не получено в течение заданного времени, выводится звездочка (*). Таймаут по умолчанию 4000 (4 секунды).
имя_конечного_компьютера
Задает точку назначения, указанную IP-адресом или именем узла.
-?
Отображает справку в командной строке.

Примечания

  • Диагностическое средство, предназначенное для определения маршрута до точки назначения с помощью посылки в точку назначения эхо-запросов протокола Internet Control Message Protocol (ICMP) с различными значениями срока жизни (TTL, Time-To-Live). Каждый маршрутизатор, через который проходит путь, обязан перед дальнейшей пересылкой пакета уменьшить значение его поля TTL по меньшей мере на 1. Фактически, TTL — счетчик узлов. Предполагается, что когда параметр TTL становится равен 0, маршрутизатор посылает системе-источнику сообщение ICMP об истечении времени. Команда tracert определяет маршрут, посылая первый эхо-запрос с полем TTL, равным 1, и увеличивая значение этого поля на единицу для каждого последующего отправляемого эхо-пакета до тех пор, пока конечный узел не ответит или пока не будет достигнуто максимальное значение поля TTL. Максимальное количество переходов по умолчанию равно 30 и может быть изменено с помощью параметра -h. Путь определяется из анализа сообщений ICMP об истечении времени, полученных от промежуточных маршрутизаторов, и это-ответов точки назначения. Однако некоторые маршрутизаторы не посылают сообщений об истечении времени для пакетов с нулевыми значениями TTL и не видны для команды tracert. В этом случае для перехода отображается ряд звездочек (*).
  • Чтобы выполнить трассировку маршрута, вывести значение задержки распространения по сети и потерь пакета на каждом маршрутизаторе и узле в пути, используйте команду pathping.
  • Эта команда доступна, только если в свойствах сетевого адаптера в объекте Сетевые подключения в качестве компонента установлен протокол Интернета (TCP/IP).

Примеры

Чтобы выполнить трассировку пути к узлу corp7.microsoft.com, введите команду:

tracert corp7.microsoft.com

Чтобы выполнить трассировку пути к узлу corp7.microsoft.com и предотвратить разрешение каждого IP-адреса в имя, введите:

tracert -d corp7.microsoft.com

Чтобы выполнить трассировку пути к узлу corp7.microsoft.com и использовать узлы 10.12.0.1-10.29.3.1-10.1.44.1 для свободной маршрутизации, введите следующую команду:

tracert -j 10.12.0.1 10.29.3.1 10.1.44.1 corp7.microsoft.com

Условные обозначения форматирования

Формат | Значение
Курсив | Сведения, вводимые пользователем
Полужирный | Элементы, вводимые без изменений
Многоточие (...) | Параметр может быть введен в командной строке несколько раз
В квадратных скобках ([]) | Необязательные элементы
В фигурых скобках ({}); варианты, разделенные вертикальной линией (|), пример: {even|odd} | Набор вариантов, из которых необходимо выбрать один
Шрифт Courier | Выходные данные программы


Команды служб терминалов

Для получения сведений щелкните ссылку.

  • change logon
  • change port
  • change user
  • cprofile
  • flattemp
  • logoff
  • msg
  • mstsc
  • query process
  • query termserver
  • query user
  • register
  • reset session
  • query session
  • shadow
  • tscon
  • tsdiscon
  • tskill
  • tsprof
  • tsshutdn


Macfile

Команда Macfile служит для управления серверами, томами, папками и файлами файлового сервера для «Макинтоша» из командной строки. Административные задачи могут быть автоматизированы включением последовательностей команд в пакетные файлы и запуском этих файлов вручную или в заранее определенное время.

Изменение каталогов тома, доступного для «Макинтоша»

Синтаксис

macfile directory [/server:\\имя_компьютера] /path:папка [/owner:имя_владельца] [/group:имя_группы] [/permissions:разрешения]

Параметры

/server:\\имя_компьютера
Сервер, на котором требуется изменить папку. Если данный параметр не задан, эта операция выполняется на локальном компьютере.
/path:папка
Обязательный параметр. Путь к папке, которую требуется изменить. Указанная папка должна существовать. Команда macfile directory не позволяет создавать папки.
/owner:имя_владельца
Смена владельца папки. Если данный параметр не задан, владелец остается прежним.
/group:имя_группы
Задание или изменение основной группы «Макинтоша», связанной с этой папкой. Если данный параметр не задан, основная группа не изменяется.
/permissions:разрешения
Задание разрешений на папку для владельца, основной группы и всех остальных. Для настройки разрешений используется число, содержащее 11 знаков. Цифра 1 означает разрешение; 0 — его отмену (например 11111011000). Позиция цифры соответствует определенному разрешению в соответствии со следующей таблицей. Если данный параметр не задан, разрешения не изменяются.
Позиция | Установка разрешения
Первая | OwnerSeeFiles
Вторая | OwnerSeeFolders
Третья | OwnerMakeChanges
Четвертая | GroupSeeFiles
Пятая | GroupSeeFolders
Шестая | GroupMakeChanges
Седьмая | WorldSeeFiles
Восьмая | WorldSeeFolders
Девятая | WorldMakeChanges
Десятая | Папка не может быть переименована, перемещена, или удалена.
Одиннадцатая | Изменения применяются к текущей папке и всем ее подпапкам.
/?
Отображение справки в командной строке.

Заметки

  • Если аргументы параметров команды содержат пробелы или специальные знаки, их следует заключать в кавычки (например "имя компьютера").
  • Команда macfile directory используется, чтобы сделать доступной для пользователей «Макинтоша» существующую папку на томе, также доступном для «Макинтоша». Команда macfile directory не создает папки. Перед тем как обратиться к команде macfile directory, воспользуйтесь диспетчером файлов, командной строкой или командой macintosh new folder для создания папки на томе, доступном для «Макинтоша».

Примеры

В следующем примере показано изменение разрешений для подпапки «May sales» на томе «Statistics», доступном для «Макинтоша» на диске E локального сервера. Назначаются разрешения на просмотр файлов, просмотр папок и внесение изменений для владельца и на просмотр файлов и папок для всех остальных. При этом папки остаются защищенными от переименования, перемещения и удаления.

macfile directory /path:"e:\statistics\may sales" /permissions:11111011000

Объединение данных файла «Макинтоша» и компонентов ресурсов

Синтаксис

macfile forkize [/server:\\имя_компьютера] [/creator:имя_источника] [/type:имя_типа] [/datafork:путь_к_файлу] [/resourcefork:путь_к_файлу] /targetfile:путь_к_файлу

Параметры

/server:\\имя_компьютера
Сервер, на котором будут объединены файлы. Если данный параметр не задан, операция выполняется на локальном компьютере.
/creator:имя_источника
Источник файла. Программа Macintosh Finder использует параметр командной строки /creator для определения приложения, создавшего файл.
/type:имя_типа
Тип файла. Программа Macintosh Finder использует параметр командной строки /type для определения типа файла в приложении, создавшем файл.
/datafork:путь_к_файлу
Размещение файла данных, предназначенного для объединения. Допускается указание пути к файлу на удаленном компьютере.
/resourcefork:путь_к_файлу
Размещение файла ресурсов, предназначенного для объединения. Допускается указание пути к файлу на удаленном компьютере.
/targetfile:путь_к_файлу
Обязательный параметр. Размещение файла, созданного путем объединения файла данных и файла ресурсов, или файла, тип и источник которого изменены. Этот файл должен находиться на указанном сервере.
/?
Отображение справки в командной строке.

Заметки

  • Если аргументы параметров команды содержат пробелы или специальные знаки, их следует заключать в кавычки (например "имя компьютера").

Примеры

Чтобы создать файл Treeapp на доступном для «Макинтоша» томе «D:\Release» из файла ресурсов «C:\Cross\Mac\Appcode» и настроить отображение файла на экране клиентов «Макинтоша» как приложения (приложения для «Макинтоша» используют тип APPL) с источником (подписью) MAGNOLIA, введите:

macfile forkize /resourcefork:c:\cross\mac\appcode /type:APPL /creator:MAGNOLIA /targetfile:D:\Release\Treeapp

Чтобы сменить источник файла на Microsoft Word 5.1 для файла WORD.txt в папке «D:\Word documents\Group files» на сервере \\SERVERA, введите:

macfile forkize /server:\\servera /creator:MSWD /type:TEXT /targetfile:"d:\Word documents\Group files\Word.txt"

Изменение сообщения при входе и ограничение сеансов

Синтаксис

macfile server [/server:\\имя_компьютера] [/maxsessions:{число| unlimited}] [/loginmessage:сообщение]

Параметры

/server:\\имя_компьютера
Сервер, на котором будут изменены параметры. Если этот параметр не задан, операция выполняется на локальном компьютере.
/maxsessions:[число| unlimited]
Максимальное количество пользователей, которые могут одновременно использовать серверы файлов и печати для «Макинтоша». Если данный параметр не задан, значение maxsessions для сервера не изменяется.
/loginmessage:сообщение
Смена сообщения, которое пользователи «Макинтоша» увидят при входе на файловый сервер для «Макинтоша». Максимальное количество знаков сообщения при входе — 199. Если данный параметр не задан, сообщение loginmessage этого сервера не изменяется. Чтобы удалить существующее сообщение при входе, воспользуйтесь параметром /loginmessage, оставив сообщение пустым.
/?
Отображение справки в командной строке.

Заметки

  • Если аргументы параметров команды содержат пробелы или специальные знаки, их следует заключать в кавычки (например "имя компьютера").

Примеры

Для изменения количества сеансов файлового сервера и сервера печати для «Макинтоша», разрешенных на локальном сервере, с текущего значения на пять сеансов и добавления сообщения «Выйдите из сервера для Macintosh после окончания работы», введите:

macfile server /maxsessions:5 /loginmessage:"Выйдите из сервера для Macintosh после окончания работы"

Добавление, изменение и удаление тома, доступного для Macintosh

Синтаксис

macfile volume {/add | /set} [/server:\\имя_компьютера] /name:имя_тома /path:папка [/readonly:{true | false}] [/guestsallowed:{true | false}] [/password:пароль] [/maxusers:{число| unlimited}]

macfile volume /remove [/server:\\имя_компьютера] /name:имя_тома

Параметры

{/add | /set}
Обязателен при добавлении или изменении тома, доступного для «Макинтоша». Добавление или изменение указанного тома.
/server:\\имя_компьютера
Сервер, на котором следует добавить, изменить или удалить том. Если данный параметр не задан, операция выполняется на локальном компьютере.
/name:имя_тома
Обязательный параметр. Имя добавляемого, изменяемого или удаляемого тома.
/path:папка
Требуется и используется только при добавлении тома. Путь к корневой папке добавляемого тома.
/readonly:[true | false]
Разрешение изменения файлов этого тома пользователями. Значение true запрещает изменение файлов на этом томе пользователями. Значение false разрешает изменение файлов на этом томе пользователями. Если при создании тома этот параметр не задан, изменение файлов разрешено. Если при изменении тома этот параметр опущен, режим readonly для тома не изменяется.
/guestsallowed:{true | false}
Управление доступом к тому пользователей, вошедших в систему как гости. Значение true разрешает использование этого тома гостями. Значение false запрещает использование этого тома гостями. Если при добавлении тома этот параметр не задан, гости имеют доступ к тому. Если при изменении тома этот параметр не задан, состояние guestsallowed для тома не изменяется.
/password:пароль
Пароль, который будет требоваться для доступа к тому. Если при создании тома этот параметр не задан, пароль не создается. Если при изменении тома этот параметр не задан, предыдущий пароль не меняется.
/maxusers:[число| unlimited]
Максимальное количество пользователей, одновременно получающих доступ к тому. Если при добавлении тома этот параметр не задан, одновременно к тому может обращаться любое количество пользователей. Если при изменении тома этот параметр не задан, предыдущее значение maxusers не меняется.
/remove
Обязательный параметр при удалении тома, доступного для «Макинтоша». Удаление указанного тома.
/?
Отображение справки в командной строке.

Заметки

  • Если аргументы параметров команды содержат пробелы или специальные знаки, их следует заключать в кавычки (например "имя компьютера").

Примеры

Чтобы создать том «US Marketing Statistics» на локальном сервере, используя папку Stats на диске E, и запретить доступ к нему гостям, введите:

macfile volume /add /name:"US Marketing Statistics" /guestsallowed:false /path:e:\Stats

Чтобы сделать том, созданный выше, доступным только для чтения, задать пароль на доступ к нему и ограничить максимальное количество пользователей пятью, введите:

macfile volume /set /name:"US Marketing Statistics" /readonly:true /password:saturn /maxusers:5

Чтобы добавить том «Landscape Design» на сервер \\Magnolia, используя папку Trees на диске E, и разрешить доступ гостей к нему, введите:

macfile volume /add /server:\\Magnolia /name:"Landscape Design" /path:e:\Trees

Чтобы удалить том «Sales Reports» с локального сервера, введите:

macfile volume /remove /name:"Sales Reports"


Mem

Служит для вывода сведений о свободных и занятых областях памяти и программах, находящихся в памяти подсистемы MS-DOS. При запуске команды mem без параметров на экран выводятся сведения о свободной и об использованной памяти подсистемы MS-DOS.

Синтаксис

mem [{/program | /debug | /classify}]

Параметры

/program
Вывод сведений о загруженных в память программах.
/debug
Вывод сведений о загруженных программах и внутренних драйверах, а также других сведений..
/classify
Вывод сведений о программах, загруженных в обычную память и в верхнюю область памяти.
/?
Отображение справки в командной строке.

Заметки

  • Использование параметра /program

    Параметр /program нельзя использовать совместно с параметром /debug или /classify. Допускается использование сокращения /p вместо /program.

  • Использование параметра /debug

    Параметр /debug нельзя использовать совместно с параметром /program или /classify. Допускается использование сокращения /d вместо /debug.

  • Использование параметра /classify

    Параметр /classify обеспечивает вывод сведений о размере каждой программы в десятичном и шестнадцатеричном формате, итоговые сведения об использовании памяти и список наибольших доступных блоков памяти. Параметр /classify нельзя использовать совместно с параметром /program или /debug. Допускается использование сокращения /c вместо /classify.

  • Вывод сведений о состоянии памяти

    Подсистема MS-DOS выводит сведения о состоянии расширенной памяти, только если в память загружено что-либо по адресам выше 1 МБ.

Примеры

Предположим, подсистема MS-DOS сконфигурирована так, что используется расширенная память. Для вывода сведений об использовании всех областей памяти — обычной, расширенной и отображаемой, а также для вывода сведений о загруженных программах следует использовать следующую команду:

mem /program

Результат будет выглядеть примерно следующим образом:

Адрес       Имя          Размер      Тип

000000                   000400     Вектор прерывания
000400                   000100     Область обмена ПЗУ (ROM)
000500                   000200     Область обмена DOS

000700      IO           000310     Системные данные

000A10      MSDOS        0014D0     Системные данные

001EE0      IO           0018D0     Системные данные
                KBD      000800      Системная программа
                HIMEM    000420      DEVICE=
                         000340      FILES=
                         000090      FCBS=
                         000170      LASTDRIVE=
                         000710      STACKS=
0037C0      COMMAND      000A40     Программа
004210      MSDOS        000070     - Свободно -
004290      COMMAND      0001F0     Окружение
004490      MEM          0001D0     Окружение
004670      MEM          017550     Программа
01BBD0      MSDOS        084410     - Свободно -
09FFF0      SYSTEM       028000     Системная программа

0C8000      IO           0083D0     Системные данные
                MOUSE    0083C0      Системная программа
0D03E0      MSDOS        000050     - Свободно -
0D0440      REDIR        0009F0     Программа
0D0E40      DOSX         007CA0     Программа
0D8AF0      DOSX         001030     Данные
0D9B30      MSDOS        0164C0     - Свободно -

    655360 байт - всего обычной памяти
    655360 байт - доступно для MS-DOS
    637296 максимальный размер исполняемой программы

1048576 байт - всего непрерывной дополнительной памяти
         0 байт - доступно непрерывной дополнительной памяти
    405504 байт - доступной памяти XMS
           резидентная часть MS-DOS загружена в сегмент HMA

  • «Всего обычной памяти» представляет количество виртуальной памяти, выделенной подсистеме MS-DOS до первых 640 КБ.
  • «Доступно для MS-DOS» представляет объем выделенной обычной памяти, включая память, необходимую для Cmd.exe.
  • «Максимальный размер исполняемой программы» равен размеру наибольшего непрерывного блока обычной памяти, доступной для программ.
  • «Всего памяти EMS» (не показано в предыдущем примере) является количеством отображаемой памяти, которая может быть использована подсистемой MS-DOS.
  • «Свободно памяти EMS» (не показано в предыдущем примере) равно количеству отображаемой памяти, доступной программам.
  • «Всего непрерывной дополнительной памяти» равно объему памяти выше 1 МБ.
  • «Доступно непрерывной дополнительной памяти» является количеством памяти, доступным через интерфейс прерывания 15h. Эта память не используется диспетчерами расширенной памяти, такими как Himem.sys. Некоторые старые программы используют такую схему организации дополнительной памяти.
  • «Доступной памяти XMS» является объемом памяти, которая используется диспетчерами расширенной памяти, такими как Himem.sys, и доступна для использования программами.


Mkdir

Создание папки или подпапки.

Синтаксис

mkdir [диск:]путь

md [диск:]путь

Параметры

диск:
Диск, на котором будет создана новая папка.
путь
Обязательный параметр. Имя и местоположение новой папки. Максимальная длина пути определяется типом файловой системы.
/?
Отображение справки в командной строке.

Заметки

  • Если расширения командного процессора разрешены (по умолчанию они разрешены), с помощью одной команды mkdir можно создать все вложенные папки по указанному пути. Дополнительные сведения о расширениях командного процессора см. в разделе cmd.

Примеры

Чтобы создать папку Налоги с подпапкой Ставки, содержащей папку Текущие, введите:

mkdir \Налоги\Ставки\Текущие

Данная команда аналогична использованию следующей последовательности команд (если разрешения командного процессора запрещены):

mkdir \Налоги
chdir \Налоги
mkdir Ставки
chdir Ставки
mkdir Текущие


Mmc

Служит для открытия окна консоли MMC. Используя параметры командной строки mmc, можно открывать определенную консоль MMC, открывать консоль MMC в авторском режиме и выбирать запускаемую версию консоли: 32-разрядную или 64-разрядную.

Синтаксис

mmc путь\имя_файла.msc [/a] [/64] [/32]

Параметры

путь\имя_файла.msc
Запуск консоли MMC с открытием сохраненной консоли. Необходимо указать полный путь и имя файла сохраненной консоли. Если файл консоли не указан, будет открыта новая консоль MMC.
/a
Открытие сохраненной консоли в авторском режиме. Используется для внесения изменений в сохраненные консоли.
/64
Открытие 64-разрядной версии консоли MMC (MMC64). Этот параметр следует использовать только при работе в Windows XP 64-Bit Edition.
/32
Открытие 32-разрядной версии консоли MMC (MMC32). При работе в Windows XP 64-Bit Edition в окне консоли MMC, запущенной с этим параметром, можно открывать 32-разрядные оснастки.
/?
Отображение справки в командной строке.

Заметки

  • Использование параметра командной строки путь\имя_файла.msc

    Для создания командных строк и ярлыков, которые не зависят от явного расположения файлов консоли, можно использовать переменные среды. Например, если путь к файлу консоли включает системную папку (например, mmc c:\winnt\system32\console_name.msc), то для указания пути можно использовать переменную %systemroot%: (mmc %systemroot%\system32\console_name.msc). Это полезно при делегировании заданий пользователям, работающим на разных компьютерах.

  • Использование параметра командной строки /a

    Когда консоли открываются с этим параметром, они открываются в авторском режиме, независимо от режима, используемого по умолчанию. Используемый по умолчанию режим файла при этом не меняется. Без этого параметра файлы будут открываться в соответствии со своими параметрами.

  • После открытия консоли MMC или файла консоли любая существующая консоль открывается с помощью команды Открыть из меню Консоль.
  • С помощью командной строки можно создавать ярлыки для запуска консоли MMC и работы с сохраненными консолями. Команда для командной строки работает в окне команды Выполнить из меню Пуск, в любом окне командной строки, в ярлыках, в пакетных файлах и программах, вызывающих такие команды.


Mode

Служит для отображения состояния и изменения параметров системы, а также перенастройки портов или устройств. При вызове команды mode без параметров отображаются все изменяемые атрибуты консоли и доступные COM-устройства. Поскольку команда mode служит для выполнения многих задач, для каждой такой задачи следует использовать индивидуальный синтаксис. Выберите задачу, которую требуется выполнить.

Задание параметров последовательного порта

Синтаксис

mode com m[:] [baud=b] [parity=p] [data=d] [stop=s] [to={on|off}] [xon={on|off}] [odsr={on|off}] [octs={on|off}] [dtr={on|off|hs}] [rts={on|off|hs|tg}] [idsr={on|off}]

Параметры

com m [:]
Номер порта асинхронной связи.
baud=b
Скорость передачи в битах в секунду. В следующем списке приведены допустимые значения параметра b и соответствующие им скорости.
Значение | Скорость
11 | 110 бод
15 | 150 бод
30 | 300 бод
60 | 600 бод
12 | 1200 бод
24 | 2400 бод
48 | 4800 бод
96 | 9600 бод
19 | 19 200 бод
parity=p
Режим проверки ошибок передачи. В следующей таблице приведен список допустимых значений p. По умолчанию используется значение e. Не все компьютеры поддерживают значения m и s.
Значение | Описание
n | нет
e | чет (even)
o | нечет (odd)
m | пометка (mark)
s | пробел (space)
data=d
Число битов данных в символе. Допустимые значения d находятся в диапазоне от 5 до 8. Значение по умолчанию равно 7. Не все компьютеры поддерживают значения 5 и 6.
stop=s
Число стоповых битов, определяющих конец символа: 1, 1,5 или 2. Если скорость передачи равна 110, по умолчанию используется значение 2. В противном случае используется значение 1. Не все компьютеры поддерживают значение 1,5.
to={on|off}
Режим обработки бесконечных пауз передачи. По умолчанию режим отключен (off).
xon={on|off}
Режим использования протокола xon/xoff для управления передачей.
odsr={on|off}
Включение или отключение согласования выходов с использованием сигнала Data Set Ready (DSR).
octs={on|off}
Включение или отключение согласования выходов с использованием сигнала Clear To Send (CTS).
dtr={on|off|hs}
Режим использования сигнала готовности терминала данных (DTR). Возможные значения: on (включено), off (отключено), handshake (согласование).
rts={on|off|hs|tg}
Режим использования сигнала Request To Send (RTS). Возможные значения: on (включено), off (отключено), handshake (согласование) и toggle (переключение).
idsr={on|off}
Режим использования распознавания сигнала DSR.
/?
Отображение справки в командной строке.

Вывод сведений обо всех внешних устройствах либо о заданном устройстве

Синтаксис

mode [устройство] [/status]

Параметры

устройство
Имя устройства, сведения о котором будут выведены.
/status
Запрос сведений о состоянии перенаправленного параллельного принтера. Допускается использование сокращения /sta вместо /status.
/?
Отображение справки в командной строке.

Заметки

  • Запущенная без параметров, команда mode выводит информацию о состоянии всех внешних устройств системы.

Перенаправление вывода с параллельного порта на последовательный

Синтаксис

mode lpt n[:]=com m[:]

Параметры

lpt n
Обязательный параметр. Параллельный порт. Допустимые значения n находятся в диапазоне от 1 до 3.
com m [:]
Обязательный параметр. Последовательный порт. Допустимые значения m находятся в диапазоне от 1 до 4.
/?
Отображение справки в командной строке.

Заметки

  • Для перенаправления вывода на печать необходимо быть членом группы «Администраторы».

Примеры

Чтобы перенаправить на локальном компьютере вывод с параллельного порта на последовательный, необходимо вызвать команду mode дважды. Первая команда mode конфигурирует последовательный порт. Вторая команда mode перенаправляет вывод параллельного принтера на последовательный порт, указанный в первой команде mode.

Например, если последовательный принтер работает со скоростью 4800 бод с контролем передачи по четности и подключен к порту COM1 (первое последовательное устройство компьютера), следует использовать следующие две команды:

mode com1 48,e,,,b
mode lpt1=com1

Если вывод принтера был перенаправлен с порта LPT1 на порт COM1, но затем было решено напечатать файл на принтере, подключенном к порту LPT1, перед печатью необходимо вызвать следующую команду.

mode lpt1

Эта команда предотвращает перенаправление файла с порта LPT1 на порт COM1.

Выбор, обновление или вывод номера кодовой страницы, используемой в окне командной строки

Синтаксис

mode устройство codepage select=yyy

mode устройство codepage [/status]

Параметры

устройство
Обязательный параметр. Устройство, для которого выбирается кодовая страница. CON является единственным допустимым значением.
codepage select=
Обязательный параметр. Кодовая страница, используемая с заданным устройством. Допускается использование сокращений cp и sel вместо codepage и select соответственно.
yyy
Обязательный параметр. Номер выбираемой кодовой страницы. Ниже приведены существующие кодовые таблицы с соответствующими странами/регионами или языками:
Значение | Страна/регион
437 | США
850 | Многоязычная (латиница I)
852 | Восточная и центральная Европа (латиница II)
855 | Кириллица (русский)
857 | Турецкий
860 | Португальский
861 | Исландский
863 | Французский (Канада)
865 | Скандинавский
866 | Русский
869 | Современный греческий
codepage
Обязательный параметр. Вывод номеров кодовых страниц, выбранных для заданного устройства.
/status
Вывод номеров кодовых страниц, выбранных для данного устройства. Допускается использование сокращения /sta вместо /status. Независимо от того, задан ли параметр /status, команда mode codepage выводит номера кодовых страниц, выбранных для заданного устройства.
/?
Отображение справки в командной строке.

Изменение размера курсора командной строки

Синтаксис

mode con[:] [cols=c] [lines=n]

Параметры

con[:]
Обязательный параметр. Указывает на изменения в окне командной строки.
cols=c
Число символов (столбцов), определяющих ширину буфера экрана.
lines=n
Число строк, определяющих длину буфера экрана.
/?
Отображение справки в командной строке.

Задание частоты повторений знаков с клавиатуры

Синтаксис

mode con[:] [rate=r delay=d]

Параметры

con[:]
Обязательный параметр. Задает установку параметра для клавиатуры.
rate=r
Частота повторений вывода знака на экран при нажатии и удержании клавиши.
delay=d
Промежуток времени, после которого нажатая и удерживаемая клавиша начинает повторять знаки.
/?
Отображение справки в командной строке.

Заметки

  • Частота повторений — это частота, с которой знак повторно вводится с клавиатуры при удержании соответствующей клавиши. Параметр состоит из двух частей: частоты повторений и задержки повторения. Некоторые клавиатуры не распознают эту команду.
  • Использование параметра rate=r

    Допустимые значения — от 1 до 32. Эти величины приблизительно соответствуют повторению от 2 до 30 знаков в секунду соответственно. Значение по умолчанию равно 20 для клавиатур, совместимых с IBM AT, и 21 для клавиатур, совместимых с IBM PS/2. Если установлена частота повторений, необходимо установить и задержку.

  • Использование параметра delay=d

    Допустимые значения параметра d — 1, 2, 3 и 4 (0,25 секунды, 0,50 секунды, 0,75 секунды и 1 секунда соответственно). Значение по умолчанию равно 2. При установке задержки также должна быть задана и частота повторений.


More

Служит для поэкранного вывода информации.

Синтаксис

команда | more [/c] [/p] [/s] [/t n] [+n]

more [[/c] [/p] [/s] [/t n] [+n]] < [диск:] [путь] имя_файла

more [/c] [/p] [/s] [/t n] [+n] [файлы]

Параметры

[диск:] [путь] имя_файла
Файл, который будет выведен на экран.
команда
Команда, которая будет выводить на экран какие-либо сведения.
/c
Очистка экрана перед выводом страницы.
/p
Обработка символов перевода страницы.
/s
Замена нескольких пустых строк одной.
/t n
Замена знаков табуляции количеством пробелов, заданным значением n.
+n
Вывод первого файла, начиная со строки n.
файлы
Список файлов для вывода. Имена файлов разделяются пробелами.
/?
Отображение справки в командной строке.

Заметки

  • Использование команды more в консоли восстановления

    Команда more с другими параметрами доступна в консоли восстановления.

  • Использование клавиш по время работы команды more

    В ответ на приглашение команды more (-- More --) можно нажимать следующие клавиши.

    Клавиша | Действие
    ПРОБЕЛ | Вывод следующей страницы
    ENTER | Вывод следующей строки
    f | Вывод следующего файла
    q | Выход
    ? Вывод списка команд
    = Вывод номеров строк
    p n | Вывод следующих n строк
    s n | Пропуск следующих n строк
  • Задание источника данных

    Когда используется символ перенаправления (<), в качестве источника данных для команды должно быть указано имя файла. В командах dir, sort или type можно использовать знак «|».

Примеры

Для просмотра на экране файла Clients.new может быть использована любая из следующих двух команд:

more < clients.new

type clients.new | more

Команда more выводит первый экран из файла Clients.new и следующее приглашение:

-- More --

Для продолжения просмотра может быть нажата клавиша ПРОБЕЛ.

Для очистки экрана и удаления лишних пустых строк перед выводом файла Clients.new может быть использована любая из следующих команд:

more /c /s < clients.new

type clients.new | more /c /s

Команда more выводит первый экран из файла Clients.new и следующее приглашение:

-- More --

Для построчного вывода файла необходимо нажать ENTER.

Для вывода следующего экрана необходимо нажать ПРОБЕЛ.

Для вывода следующего файла из списка требуется ввести f.

Для выхода из программы more нажмите клавишу q.

В ответ на запрос команды more можно нажимать клавиши, рассмотренные в этом примере:

-- More [Параметры: psfq=<пробел><ENTER>] --

Чтобы вывести номер текущей строки, нажмите клавишу =. Номер строки будет добавлен к приглашению more, как показано ниже:

-- More [Строка: 24] --

Чтобы вывести определенное количество строк, нажмите клавишу p. Будет запрошено количество строк, которое требуется вывести:

-- More -- Строки:

Теперь требуется ввести число и нажать клавишу ENTER. На экран будет выведено заданное число строк.

Чтобы пропустить определенное количество строк, нажмите клавишу s. Будет запрошено количество строк, которое требуется пропустить:

-- More -- Строки:

Следует ввести число и нажать клавишу ENTER. Будет пропущено заданное количество строк файла и продолжен вывод информации.


Mountvol

Служит для создания, удаления и получения списка точек подключения тома. Команда Mountvol является обеспечивает подключение томов, не требуя для этого букву диска.

Синтаксис

mountvol [диск:]путь имя_тома

mountvol [диск:]путь /d

mountvol [диск:]путь /L

mountvol диск: /s

Параметры

[диск:]путь
Папка существующего каталога NTFS, в которой находится точка подключения.
имя_тома
Имя тома, являющегося местом назначения точки подключения. Имя тома задается в формате \\?\Volume{код_GUID}\, где {код_GUID} является глобальным уникальным идентификатором (GUID) (например \\?\Volume\{2eca078d-5cbc-43d3-aff8-7e8511f60d0e}\).
/d
Удаление точки подключения из указанной папки.
/L
Вывод списка имен подключенных дисков для указанной папки.
/s
Только для компьютеров на основе процессора. Подключение системного раздела EFI к указанному диску.
/?
Отображение справки в командной строке.

Заметки

  • Если свободные буквы дисков отсутствуют, подключите локальные тома без использования букв дисков.
  • Если требуется увеличить свободное место на томе, не форматируя и не меняя жесткий диск, можно подключить к какому-либо его пути другой том.
  • Выгода использования одного тома с несколькими путями присоединения состоит в возможности использования всех локальных дисков с помощью одного имени диска (например C:). Отпадает необходимость помнить соответствие томов и имен дисков, хотя можно и присоединить локальные тома, и по-прежнему использовать имена дисков.


Move

Служит для перемещения одного или нескольких файлов из одного каталога в другой.

Синтаксис

move [{/y|/-y}] [источник] [результат]

Параметры

/y
Запрет на выдачу запроса подтверждения перезаписи существующего файла-результата.
/-y
Выдача запроса подтверждения перезаписи существующего файла-результата.
источник
Путь и имя одного или нескольких файлов для перемещения. Если требуется переместить или переименовать каталог, в качестве источника должен быть указан путь к текущему каталогу и его имя.
результат
Путь и имя, куда требуется переместить файлы. Если требуется переместить или переименовать каталог, в качестве результата должен быть указан путь к конечному каталогу и его имя.
/?
Отображение справки в командной строке.

Заметки

  • Использование параметра командной строки /y

    Параметр командной строки /y может быть установлен заранее в переменной среды COPYCMD. Значение может быть переопределено параметром /-y в командной строке. По умолчанию если команда copy выполняется не в пакетной программе, при замене требуется подтверждение.

  • Перемещение зашифрованных файлов

    При перемещении файлов на том, не поддерживающий шифрованную файловую систему (EFS), возникнет ошибка. Следует предварительно расшифровать файлы или переместить их на том, поддерживающий EFS.

Примеры

Чтобы переместить все файлы с расширением XLS из каталога \Data в каталог \Second_Q\Reports, введите:

move \data\*.xls \second_q\reports\


Msiexec

Средство установки, изменения и выполнения операций установщика Windows из командной строки.

Установка и настройка продукта

Синтаксис

msiexec /i {пакет|код_продукта}

Параметры

/i
Установка или настройка продукта.
пакет
Имя файла пакета установщика Windows.
код_продукта
Глобальный уникальный идентификатор (GUID) пакета установщика Windows.

Заметки

  • Регистр букв при вводе параметров командной строки установщика Windows не учитывается.

Примеры

Чтобы установить продукт из файла A:\Example.msi, введите:

msiexec /i A:\Example.msi

Использование режима административной установки

Синтаксис

msiexec /a пакет

Параметры

/a
Выбор режима административной установки.
пакет
Имя файла пакета установщика Windows.

Заметки

  • Регистр букв при вводе параметров командной строки установщика Windows не учитывается.

Восстановление продукта

Синтаксис

msiexec /f [p][o][e][d][c][a][u][m][s][v]{пакет|код_продукта}

Параметры

/f
Включение одного или нескольких параметров командной строки, перечисленных в следующей таблице.
Параметр | Описание
p | Переустановка только в случае отсутствия файла.
o | Переустановка при отсутствии файла или если установлена его старая версия.
e | Переустановка при отсутствии файла или если установлена его текущая либо старая версия.
d | Переустановка в случае отсутствия файла или если установлена другая его версия.
c | Переустановка в случае отсутствия файла или в случае, если контрольная сумма не совпадает с вычисленным значением.
a | Принудительная переустановка всех файлов.
u | Перезапись всех необходимых пользовательских записей реестра.
m | Перезапись всех необходимых записей реестра компьютера.
s | Перезапись всех имеющихся ярлыков.
v | Запуск файлов из источника и повторное кэширование локального пакета.
пакет
Имя файла пакета установщика Windows.
код_продукта
Глобальный уникальный идентификатор (GUID) пакета установщика Windows.

Заметки

  • Пропуск всех значений свойств, заданных в командной строке.
  • Параметром по умолчанию для этой командной строки является параметр /fpecms.
  • Регистр букв при вводе параметров командной строки установщика Windows не учитывается.

Примеры

Чтобы восстановить пакет установки, введите:

msiexec /fpecms Example.msi

Удаление продукта

Синтаксис

msiexec /x {пакет|код_продукта}

Параметры

/x
Удаление продукта.
пакет
Имя файла пакета установщика Windows.
код_продукта
Глобальный уникальный идентификатор (GUID) пакета установщика Windows.

Заметки

  • Регистр букв при вводе параметров командной строки установщика Windows не учитывается.

Примеры

Чтобы удалить или отменить установку пакета, введите:

msiexec /x Example.msi

Объявление продукта

Синтаксис

msiexec /j [{u|m}] пакет

msiexec {u|m} пакет /t список_преобразований

msiexec {u|m} пакет /g код_языка

Параметры

/j
Объявление продукта.
u
Объявление для текущего пользователя.
m
Объявление для всех пользователей компьютера.
пакет
Файл пакета установщика Windows.
/g код_языка
Служит для задания языка.
/t список_преобразований
Применение преобразований к объявляемому пакету.

Заметки

  • Пропуск всех значений свойств, заданных в командной строке.
  • При необходимости установить приложение с повышенными привилегиями используйте параметр /jm.
  • Регистр букв при вводе параметров командной строки установщика Windows не учитывается.

Примеры

Чтобы объявить пакет для всех пользователей этого компьютера, введите:

msiexec /jm Example.msi

Чтобы объявить пакет для всех пользователей этого компьютера, введите:

msiexec /jm Example.msi

Установка уровня ведения журнала

Синтаксис

msiexec /L [i][w][e][a][r][u][c][m][p][v][+][!]файл_журнала.txt

Параметры

/L
Путь к файлу журнала.
i
Занесение в журнал сообщений о состоянии.
w
Занесение в журнал некритических предупреждений.
e
Занесение в журнал сообщений об ошибках.
a
Занесение в журнал выполнения действий.
r
Занесение в журнал записей со сведениями о действиях.
u
Занесение в журнал запросов пользователей.
c
Занесение в журнал исходных параметров пользовательского интерфейса.
m
Занесение в журнал нехватки памяти.
p
Занесение в журнал свойств терминала.
v
Занесение в журнал подробных сведений. Для использования параметра v следует задавать /L*v.
+
Добавление в существующий файл.
!
Сброс в журнал каждой строки.
*
Занесение в журнал всех сведений, кроме параметра v. Это подстановочный знак.
файл_журнала.txt
Имя и путь к текстовому файлу журнала.

Заметки

  • Регистр букв при вводе параметров командной строки установщика Windows не учитывается.
  • Чтобы включить в файл журнала параметр v при использовании подстановочного знака, введите в командной строке /L*v.
  • Параметры файла журнала установщика Windows могут также использоваться для процессов удаления и восстановления.

Примеры

Чтобы установить пакет и создать файл журнала, включающий в себя сведения о состоянии, сообщения о нехватке памяти и все сообщения об ошибках, введите следующую команду:

msiexec /i Example.msi /Lime logfile.txt

Применение исправления

Синтаксис

msiexec /p пакет_исправлений

Параметры

/p
Применение исправлений.
пакет_исправлений
Определенное исправление.

Заметки

  • Чтобы применить исправления к установочному административному пакету, введите следующую строку:

    msiexec /p пакет_исправлений /a Example.msi

  • Регистр букв при вводе параметров командной строки установщика Windows не учитывается.

Установка преобразования с использованием командной строки

Синтаксис

msiexec /i пакет TRANSFORMS=список_преобразований

Параметры

/i
Установка или настройка продукта.
пакет
Файл пакета установщика Windows.
TRANSFORMS=
Свойство, используемое для указания файлов преобразования (MST), которые следует применить к пакету.
список_преобразований
Список путей, разделенных точкой с запятой.

Заметки

  • Регистр букв при вводе параметров командной строки установщика Windows не учитывается.

Установка и объявление продукта с преобразованием при помощи командной строки

Синтаксис

msiexec /i пакет /j[u][m] /t список_преобразований

Параметры

/i
Установка или настройка продукта.
пакет
Имя файла пакета установщика Windows.
/j
Объявление продукта. Этот параметр игнорирует любые значения свойств, введенные в командной строке.
u
Объявление для текущего пользователя.
m
Объявление для всех пользователей данного компьютера.
/t
Применение преобразований к объявляемому пакету.
список_преобразований
Список путей, разделенных точкой с запятой.

Заметки

  • Регистр букв при вводе параметров командной строки установщика Windows не учитывается.

Задание уровня пользовательского интерфейса

Синтаксис

msiexec /q{n|b|r|f|n+|b+|b-}

Параметры

/qn
Запрет на отображение пользовательского интерфейса.
/qb
Отображение основного пользовательского интерфейса.
/qr
Отображение сокращенного пользовательского интерфейса с выводом модального диалогового окна в конце установки.
/qf
Отображение полного пользовательского интерфейса с выводом модального диалогового окна в конце.
/qn+
Запрет на отображение пользовательского интерфейса за исключением вывода модального диалогового окна в конце.
/qb+
Отображение основного пользовательского интерфейса с выводом модального диалогового окна в конце.
/qb-
Отображение основного пользовательского интерфейса без модальных диалоговых окон.

Заметки

  • Параметр /qb+- не является поддерживаемым уровнем пользовательского интерфейса. При отмене установки пользователем модальное окно не выводится.
  • Регистр букв при вводе параметров командной строки установщика Windows не учитывается.

Примеры

Для отображения основного пользовательского интерфейса в ходе установки пакета Example.msi введите:

msiexec /qb Example.msi

Вывод сведений об авторских правах для установщика Windows

Синтаксис

msiexec {/?|/h}

Параметры

{/?|/h}
Отображение версии установщика Windows и сведений об авторских правах.

Заметки

  • Регистр букв при вводе параметров командной строки установщика Windows не учитывается.

Вызов системной функции DllRegisterServer для регистрации модулей, указанных в командной строке

Синтаксис

msiexec /y модуль

Параметры

/y
Вызов системной функции DllRegisterServer для регистрации модулей, указанных в командной строке
модуль
Имя файла модуля.

Заметки

  • Этот параметр используется только для данных из реестра, которые не могут быть добавлены с помощью таблиц реестра MSI-файла.
  • Регистр букв при вводе параметров командной строки установщика Windows не учитывается.

Примеры

В следующем примере показано использование команды msiexec /y:

msiexec /y my_file.dll

Вызов системной функции DllRegisterServer для отмены регистрации модулей, указанных в командной строке

Синтаксис

msiexec /z модуль

Параметры

/z
Вызов системной функции DllRegisterServer для отмены регистрации модулей, указанных в командной строке.
модуль
Имя файла модуля.

Заметки

  • Этот параметр используется только для данных из реестра, которые не могут быть добавлены с помощью таблиц реестра MSI-файла.
  • Регистр букв при вводе параметров командной строки установщика Windows не учитывается.

Примеры

В следующем примере показано использование команды msiexec /z:

msiexec /z my_file.dll


Msinfo32

Служит для отображения подробных сведений об оборудовании, системных компонентах и среде программного обеспечения.

Синтаксис

  • msinfo32 [/?] [/pch] [/nfo имя_файла] [/report имя_файла] [/computer имя_компьютера] [/showcategories] [/category код_категории] [/categories код_категории]

    Параметры

    имя_файла
    Файл, который требуется открыть. Файл может иметь расширение NFO, XML, TXT или CAB.
    /?
    Отображение справки по команде msinfo32.
    /pch
    Отображение журнала.
    /nfo имя_файла
    Сохранение экспортированного файла как NFO-файла.
    /report имя_файла
    Сохранение экспортированного файла как TXT-файла.
    /computer имя_компьютера
    Открытие окна сведений о системе для указанного удаленного компьютера.
    /showcategories
    Открытие окна сведений о системе, содержащего все доступные коды категорий.
    /category код_категории
    Открытие окна сведений о системе, в котором выбрана указанная категория. Для отображения списка доступных кодов категорий служит параметр /showcategories
    /categories код_категории
    Открытие окна сведений о системе, содержащего только указанные категории. Вывод также ограничивается только выбранными категориями. Для отображения списка доступных кодов категорий служит параметр /showcategories
    /?
    Отображение справки в командной строке.

    Заметки

    • Некоторые категории сведений о системе содержат большие объемы данных. Скорость создания отчетов для этих категорий можно увеличить, используя команду start /wait.

    Примеры

    Чтобы получить список доступных кодов категорий, введите:

    msinfo32 /showcategories

    Чтобы открыть окно сведений о системе, содержащее все доступные сведения, кроме сведений о загруженных модулях, введите:

    msinfo32 /categories +all -loadedmodules

    Чтобы открыть окно сведений о системе и создать NFO-файл syssum.nfo, содержащий сведения категории «Сведения о системе», введите:

    msinfo32 /nfo syssum.nfo /categories +systemsummary

    Чтобы вывести сведения о конфликте ресурсов и создать NFO-файл conflicts.nfo, содержащий сведения о конфликтах ресурсов, введите:

    msinfo32 /nfo conflicts.nfo /categories +componentsproblemdevices+resourcesconflicts+resourcesforcedhardware


Rasdial

Выполняет автоматический набор номера для клиентов Microsoft. Команда rasdial, запущенная без параметров, показывает состояние текущих подключений.

Синтаксис

rasdial имя_подключения [имя_пользователя [{пароль|*}]] [/domain:домен] [/phone:номер_телефона] [/callback:номер_для_ответного_вызова] [/phonebook:путь_к_телефонной_книге] [/prefixsuffix]

rasdial [имя_подключения] /disconnect

Параметры

имя_подключения
Требуется при подключении к записи телефонной книги (.pbk). Задает запись текущего файла .pbk из корневой_папки_системы\System32\Ras. Если имя_подключения содержит пробелы, его следует заключать в кавычки (т. е. "имя_подключения").

Файл Rasphone.pbk используется по умолчанию, если не задана Личная_телефонная_книга. Если она задана, используется файл имя_пользователя.pbk. Имя выводится в заголовке окна Rasphone при задании личной телефонной книги. В случае конфликта имен происходит добавление цифр.

имя_пользователя [{пароль|*}]
Задает имя пользователя и пароль для подключения. Если используется символ звездочки, пользователю выдается запрос на ввод пароля, но вводимые символы не отображаются.
/domain:домен
Задает домен, в котором находится учетная запись пользователя. Если этот параметр отсутствует, используется последнее значение поля Домен диалогового окна Подключение к.
/phone:номер_телефона
Заменяет номер телефона, заданный для телефонного номера данной записи в файле телефонной книги Rasphone.pbk.
/callback:номер_для_ответного вызова
Заменяет номер телефона для ответного вызова, заданный для записи из файла телефонной книги Rasphone.pbk.
/phonebook:путь_к_телефонной_книге
Задает путь к файлу телефонной книги. По умолчанию задан системный_корневой_каталог\System32\Ras\имя_пользователя.pbk. Можно указать полный путь к файлу.
/prefixsuffix
Применяет к набираемому номеру телефона параметры набора номера TAPI для текущего местоположения. Эти параметры настраиваются в телефонной службе с помощью компонента "Параметры телефона и модема", находящегося на панели управления. По умолчанию этот параметр отключен.
/disconnect
Данный параметр требуется при отключении. Отключает заданное подключение. Отключение также выполняется с помощью ввода параметра /d.

Примечания

  • Команда rasdial не поддерживает следующие функции Rasphone.exe:
    • Записи, требующие ввода данных в терминальном режиме в процессе набора номера.
    • Набор номера через оператора или вручную.

Примеры

В примере показано подключение к записи OFFICE файла телефонной книги Rasphone.pbk.

rasdial office

В примере показано подключение к записи OFFICE 2 файла телефонной книги Rasphone.pbk с заданием номера обратного вызова.

rasdial "office 2" /callback:555-0100

В примере показано отключение от записи EAST OFFICE.

rasdial "EAST OFFICE" /d


Recover

Восстанавливает сохранившуюся на испорченных или дефектных дисках информацию.

Синтаксис

recover [диск:][путь] имя_файла

Параметры

[диск:][путь] имя_файла
Задает местонахождение и имя файла, который подлежит восстановлению.
/?
Отображает справку в командной строке.

Примечания

  • Команда recover считывает файл сектор за сектором и восстанавливает информацию, которая еще может быть считана. Данные в поврежденных секторах будут утеряны.
  • Ограничения на параметр [диск:][путь]имя_файла

    Использование подстановочных знаков (* и ?) в команде recover не допускается. Должно быть указано имя файла.

  • Новый ввод потерянных данных

    Так как все данные в испорченных секторах будут потеряны, файлы следует восстанавливать по одному. После процедуры восстановления требуется отредактировать каждый файл и снова ввести в него потерянную информацию.

  • Восстановление испорченных секторов

    Поврежденные сектора, о которых сообщает команда chkdsk, были маркированы при первом форматировании диска. Они не представляют опасности и команда recover не будет обращать на них внимание.

Примеры

Для восстановления файла Story.txt из каталога \Fiction на диске D: введите:

recover d:\fiction\story.txt


Использование операторов перенаправления команд

Операторы перенаправления команд используются для изменения местоположений потоков ввода и вывода команд, заданных по умолчанию, на какие-либо другие. Местоположение потоков ввода и вывода называется дескриптор.

В следующей таблице описаны операторы перенаправления потоков ввода и вывода команд.

Оператор перенаправления | Описание
> | Записывает данные на выходе команды вместо командной строки в файл или на устройство, например, на принтер.
< | Читает поток входных данных команды из файла, а не с клавиатуры.
>> | Добавляет выходные данные команды в конец файла, не удаляя при этом существующей информации из файла.
>& | Считывает данные на выходе одного дескриптора как входные данные для другого дескриптора.
<& | Считывает входные данные одного дескриптора как выходные данные другого дескриптора.
| | Считывает выходные данные одной команды и записывает их на вход другой команды. Эта процедура известна под названием «канал».

По умолчанию, входные данные команды (дескриптор STDIN) отсылаются с клавиатуры интерпретатору команд Cmd.exe, далее Cmd.exe отправляет выходные данные команды (дескриптор STDOUT) в окно командной строки.

В следующей таблице представлены доступные дескрипторы.

дескриптор | Числовой эквивалент дескриптора | Описание
STDIN | 0 | Ввод с клавиатуры
STDOUT | 1 | Вывод в окно командной строки
STDERR | 2 | Ошибка вывода в окно командной строки
UNDEFINED | 3-9 | Эти дескрипторы определяются индивидуально для каждой прикладной программы.

Номера от 0 до 9 представляют первые 10 дескрипторов. Для запуска программы и перенаправления любого из 10 дескрипторов используется интерпретатор команд Cmd.exe. Для задания требуемого дескриптора перед оператором перенаправления введите его номер. Если дескриптор не определен, то по умолчанию оператором перенаправления ввода «<» будет ноль (0), а оператором перенаправления вывода «>» будет единица (1). После ввода оператора «<» или «>» необходимо указать, откуда читать и куда записывать данные. Можно задать имя файла или любой из существующих дескрипторов.

Для задания перенаправления в существующие дескрипторы используется амперсанд (&), затем номер требуемого дескриптора (например, &номер_дескриптора). Например, для перенаправления дескриптора 2 (STDERR) в дескриптор 1 (STDOUT) введите:

1<&2

Дублирование дескрипторов

Оператор перенаправления «&» дублирует выходные или входные данные с одного заданного дескриптора на другой заданный дескриптор. Например, для отправки выводных данных команды dir в файл File.txt и отправки ошибки вывода в файл File.txt введите:

dir>c:\file.txt 2>&1

При дублировании дескриптора происходит копирование всех его исходных характеристик. Например, если дескриптор доступен только для записи, то все его дубликаты будут доступны только для записи. Нельзя продублировать дескриптор с доступом только для чтения в дескриптор с доступом только для записи.

Перенаправление ввода команд (<)

Для перенаправления ввода команд с цифровой клавиатуры на файл или на устройство используйте оператор «<». Например, для ввода команды sort из файла List.txt введите:

sort<file.txt

Содержимое файла File.txt появится в командной строке в виде списка в алфавитном порядке.

Оператор «<» открывает заданное имя файла с доступом только для чтения. Поэтому с его помощью нельзя записывать в файл. Например, при запуске программы с оператором <&2 все попытки прочитать дескриптор 0 ни к чему не приведут, так как изначально он был открыт с доступом только для записи.

Примечание

  • Дескриптор 0 задан по умолчанию для оператора перенаправления ввода «<».

Перенаправление вывода команд (>)

Выходные данные практически всех команд высвечиваются в окне командной строки. Даже команды, выводящие данные на диск или принтер, выдают сообщения и запросы в окне командной строки.

Для перенаправления вывода команд из окна командной строки в файл или на устройство применяется оператор «>». Этот оператор используется с большинством команд. Например, для перенаправления вывода команды dir в файл Dirlist.txt введите:

dir>dirlist.txt

Если файл Dirlist.txt не существует, интерпретатор команд Cmd.exe создаст его. Если файл существует, Cmd.exe заменит информацию в файле на данные, полученные от команды dir.

Для запуска команды netsh routing dump и последующей отправки результатов ее работы в Route.cfg введите:

netsh routing dump>c:\route.cfg

Оператор «>» открывает заданный файл с доступом только для записи. Поэтому с помощью данного оператора файл прочитать нельзя. Например, при запуске программы с оператором перенаправления <&0 все попытки записать дескриптор 1 ни к чему не приведут, так как изначально дескриптор 0 был открыт с доступом только для чтения.

Примечание.

  • Дескриптор 1 задан по умолчанию для оператора перенаправления вывода «>».

Использование оператора «<&» для перенаправления ввода и дублирования

Для использования оператора перенаправления ввода необходимо, чтобы задаваемый файл уже существовал. Если файл для ввода существует, то интерпретатор команд Cmd.exe открывает его с доступом только для чтения и его содержимое отправляет в команду так, как если бы это был ввод с цифровой клавиатуры. При задании дескриптора интерпретатор команд Cmd.exe дублирует его в дескриптор, существующий в системе.

Например, для считывания файла File.txt на вход в дескриптор 0 (STDIN) введите:

<file.txt

Для открытия файла File.txt, сортировки его содержимого и последующей отправки в окно командной строки (STDOUT) введите:

sort<file.txt

Для того чтобы найти файл File.txt и перенаправить дескриптор 1 (STDOUT) и дескриптор 2 (STDERR) в Search.txt введите:

findfile file.txt>search.txt 2<&1

Для дублирования определенного пользователем дескриптора 3 в качестве входной информации для дескриптора 0 (STDIN) введите:

<&3

Использование оператора «>&» для перенаправления ввода и дублирования

При перенаправлении вывода в файл и задании существующего имени файла интерпретатор команд Cmd.exe открывает файл с доступом только для записи и переписывает его содержимое. Если дескриптор задан, интерпретатор команд Cmd.exe дублирует файл в существующий дескриптор.

Для дублирования определенного пользователем дескриптора 3 в дескриптор 1 введите:

>&3

Для перенаправления всех выходных данных, включая выходные данные дескриптора 2 (STDERR), команды ipconfig в дескриптор 1 (STDOUT) и последующего перенаправления выходных данных в Output.log введите:

ipconfig.exe>>output.log 2>&1

Использование оператора «>>» для добавления вывода

Для добавления выходных данных команды в конец файла без потери хранящейся в нем информации используется двойной символ «больше» (>>). Например, следующая команда добавляет список каталогов, созданный командой dir, в файл Dirlist.txt:

dir>>dirlist.txt

Для добавления выходных данных команды netstat в конец файла Tcpinfo.txt введите:

netstat>>tcpinfo.txt

Использование оператора канала (|)

Оператор канала «вертикальная линия» (|) забирает выходные данные одной команды (по умолчанию STDOUT) и направляет их на вход другой команды (по умолчанию STDIN). Например, следующая команда сортирует каталог:

dir | sort

В данном примере обе команды запускаются одновременно, но команда sort приостанавливает работу до получения выходных данных команды dir. Команда sort использует выходные данные команды dir в качестве своих входных данных, а затем свои выходные данные отправляет в дескриптор 1 (STDOUT).

Комбинирование команд с операторами перенаправления

Комбинируя команды-фильтры с другими командами и именами файлов, можно создавать команды на заказ. Например, для сохранения имен файлов, содержащих строку «LOG», используется следующая команда:

dir /b | find "LOG" > loglist.txt

Выход команды dir отсылается в команду-фильтр find. Имена файлов, содержащие строку «LOG», хранятся в файле Loglist.txt в виде списка (например, NetshConfig.log, Logdat.svd и Mylog.bat).

При использовании более одного фильтра в одной команде их необходимо отделять с помощью канала (|). Например, следующая команда ищет в каждом каталоге диска C файлы, в названии которых присутствует строка «Log», и выводит их постранично на экран:

dir c:\ /s /b | find "LOG" | more

Наличие канала (|) указывает Cmd.exe, что выход команды dir нужно отправить команде-фильтру find. Команда find выбирает только те имена файлов, в которых содержится строка «LOG». Команда more выводит на экран имена файлов, полученные командой find с паузой после заполнения каждого экрана. Сведения о командах-фильтрах см. в разделе Использование фильтров.


Reg

Добавляет, изменяет и отображает на экране информацию разделов реестра и значение записей реестра.

Добавляет новый раздел или новую запись в реестр.

Синтаксис

reg add имя_раздела [/v имя_записи|/ve] [/t тип_данных] [/s разделитель] [/d значение] [/f]

Параметры

имя_раздела
Задает полный путь к разделу. Для удаленных компьютеров перед путем к разделу в формате \\имя_компьютера\путь_к_разделу вставляется имя компьютера. Если параметр имя_компьютера не задан, операция по умолчанию выполняется на локальном компьютере. Путь следует начинать с соответствующего поддерева. Допустимыми поддеревьями являются HKLM, HKCU, HKCR, HKU и HKCC.
/v имя_записи
Задает имя записи для добавления к заданному разделу.
/ve
Задает нулевое значение для записи, добавляемой в реестр.
/t тип_данных
Задает тип данных для значения записи. Параметр тип_данных может иметь одно из перечисленных ниже значений:

REG_SZ

REG_MULTI_SZ

REG_DWORD_BIG_ENDIAN

REG_DWORD

REG_BINARY

REG_DWORD_LITTLE_ENDIAN

REG_LINK

REG_FULL_RESOURCE_DESCRIPTOR

REG_EXPAND_SZ

/s разделитель
Задает символы для разделения копий данных. Используется при задании REG_MULTI_SZ в качестве типа данных и при размещении более одной записи в списке. Если разделитель не задан, то используется разделитель \0, заданный по умолчанию.
/d значение
Задает значение для новой записи реестра.
/f
Добавляет раздел или запись без запроса на подтверждение.
/?
Вывод справки в командной строке.

Примечания

  • С помощью данной операции нельзя добавлять поддеревья. Эта версия регистра не запрашивает подтверждения при добавлении нового раздела.
  • В следующей таблице представлены значения возврата для операции reg add.
    Значение | Описание
    0 | Успех
    1 | Сбой

Примеры

Далее приведены примеры использования команды reg add.

reg add \hklm\software\myco /v data /t reg_binary /d fe340ead
reg add "hkcu\software\microsoft\winmine" /v Name3 /t reg_sz /d Anonymous
reg add "hkcu\software\microsoft\winmine" /v Time3 /t reg_dword /d 5

Сравнивает заданные разделы или записи реестра.

Синтаксис

reg compare имя_раздела_1 имя_раздела_2 [/v имя_записи | /ve] {[/oa]|[/od]|[/os]|[on]} [/s]

Параметры

имя_раздела
Задает полный путь к разделу. Для удаленных компьютеров имя компьютера вставляется перед путем к разделу в формате \\имя_компьютера\путь_к_разделу. Если параметр имя_компьютера не задан, операция по умолчанию выполняется на локальном компьютере. Путь следует начинать с соответствующего поддерева. Допустимыми поддеревьями являются HKLM, HKCU, HKCR, HKU и HKCC. Если задан удаленный компьютер, то можно использовать только поддеревья HKLM и HKU.
/v имя_записи
Сравнивает специальную запись раздела.
/ve
Задает для сравнения только те записи, которые не имеют значения.
{[/oa]|[/od]|[/os]|[on]}
Задает вывод различий и совпадений. По умолчанию установлено значение /od.
Значение | Описание
/oa | Задает вывод всех различий и совпадений. По умолчанию отображаются только различия.
/od | Задает вывод различий. Этот вариант используется по умолчанию.
/os | Задает вывод совпадений. По умолчанию отображаются только различия.
/on | На экран ничего не выводится. По умолчанию отображаются только различия.
/s разделитель
Сравнивает все разделы и записи.
/?
Вывод справки в командной строке.

Примечания

  • В следующей таблице представлены значения возврата для операции reg compare.
    Значение | Описание
    0 | Сравнение успешно и результаты совпадают.
    1 | Сравнение не прошло.
    2 | Сравнение прошло успешно и найдены различия.

Примеры

Далее приведены примеры использования команды reg compare.

reg compare "hkcu\software\microsoft\winmine" "hkcu\software\microsoft\winmine" /od /s

Копирует запись реестра в заданный каталог локального или удаленного компьютера.

Синтаксис

reg copy имя_раздела_1 имя_раздела_2 [/s] [/f]

Параметры

имя_раздела_1
Задает полный путь к разделу для копирования. Для удаленных компьютеров перед путем к разделу в формате \\имя_компьютера\путь_к_разделу вставляется имя компьютера. Если параметр имя_компьютера не задан, операция по умолчанию выполняется на локальном компьютере. Путь следует начинать с соответствующего поддерева. Допустимыми поддеревьями являются HKLM, HKCU, HKCR, HKU и HKCC. Если задан удаленный компьютер, то можно использовать только поддеревья HKLM и HKU.
имя_раздела_2
Задает полный путь к разделу точки назначения. Для удаленных компьютеров перед путем к разделу в формате \\имя_компьютера\путь_к_разделу вставляется имя компьютера. Если параметр имя_компьютера не задан, операция по умолчанию выполняется на локальном компьютере. Путь следует начинать с соответствующего поддерева. Допустимыми поддеревьями являются HKLM, HKCU, HKCR, HKU и HKCC. Если задан удаленный компьютер, то можно использовать только поддеревья HKLM и HKU.
/s
Копирует все вложенные разделы и записи заданного раздела.
/f
Копирует раздел без запроса на подтверждение.
/?
Вывод справки в командной строке.

Примечания

  • Эта версия команды Reg не запрашивает подтверждения при копировании раздела.
  • В следующей таблице представлены значения возврата для операции reg copy.
    Значение | Описание
    0 | Успех
    1 | Сбой

Примеры

Далее приведены примеры использования команды reg copy:

reg copy "hkcu\software\microsoft\winmine" "hkcu\software\microsoft\winminebk" /s /f
reg copy "hkcu\software\microsoft\winminebk" "hkcu\software\microsoft\winmine" /s

Удаляет раздел или записи реестра.

Синтаксис

reg delete имя_раздела [{/v имя_записи|/ve|/va}] [/f]

Параметры

имя_раздела
Задает полный путь к разделу. Для удаленных компьютеров перед путем к разделу в формате \\имя_компьютера\путь_к_подразделу вставляется имя компьютера. Если параметр имя_компьютера не задан, операция по умолчанию выполняется на локальном компьютере. Путь следует начинать с соответствующего поддерева. Допустимыми поддеревьями являются HKLM, HKCU, HKCR, HKU и HKCC.
/v имя_записи
Удаляет запись раздела. Если запись не задана, то будут удалены все записи и вложенные разделы данного раздела.
/ve
Задает для удаления только те записи, которые не имеют значения.
/va
Удаляет все записи заданного раздела. Данный параметр не удаляет вложенные разделы в заданном разделе.
/f
Удаляет существующий раздел реестра или запись без запроса на подтверждение.
/?
Вывод справки в командной строке.

Примечания

  • В следующей таблице представлены значения возврата для операции reg copy.
    Значение | Описание
    0 | Успех
    1 | Сбой

Примеры

Далее приведены примеры использования команды reg delete.

reg delete "hkcu\software\microsoft\winmine" /v Name1
reg delete "hkcu\software\microsoft\winmine" /v Time1
reg delete "hkcu\software\microsoft\winmine" /va

Создает копию заданных разделов, записей или значений в файле, который можно отправить на другие серверы.

Синтаксис

reg export имя_раздела имя_файла

Параметры

имя_раздела
Задает полный путь к разделу. Операция export работает только на локальном компьютере. Путь начинается с соответствующего поддерева. Допустимыми поддеревьями являются HKLM, HKCU, HKCR, HKU и HKCC.
имя_файла
Задает имя и путь экспортируемого файла. Файл должен иметь расширение .reg.
/?
Вывод справки в командной строке.

Примечания

  • В следующей таблице представлены значения возврата для операции reg export.
    Значение | Описание
    0 | Успех
    1 | Сбой

Примеры

Далее приведены примеры использования команды reg export.

reg export "hkcu\software\microsoft\winmine" c:\data\regbackups\wmbkup.reg

Копирует разделы, записи и значения из экспортированного реестра в реестр локального компьютера.

Синтаксис

reg import имя_файла

Параметры

имя_файла
Задает имя и путь файла для копирования в реестр локального компьютера. Предварительно с помощью операции reg export этот файл требуется создать.
/?
Вывод справки в командной строке.

Примечания

  • В следующей таблице представлены значения возврата для операции reg import.
    Значение | Описание
    0 | Успех
    1 | Сбой

Примеры

Далее приведены примеры использования команды reg import.

reg import "hkcu\software\microsoft\winmine" c:\data\regbackups\wmbkup.reg

Записывает сохраненные разделы и записи в другой раздел реестра. Предполагается, что это будет временный файл для устранения неполадок или редактирования записей реестра.

Синтаксис

reg load имя_раздела имя_файла

Параметры

имя_раздела
Задает полный путь к разделу. Для удаленных компьютеров перед путем к разделу в формате \\имя_компьютера\путь_к_подразделу вставляется имя компьютера. Если параметр имя_компьютера не задан, операция по умолчанию выполняется на локальном компьютере. Путь следует начинать с соответствующего поддерева. Допустимыми поддеревьями являются HKLM, HKCU, HKCR, HKU и HKCC.
имя_файла
Задает путь и имя файла, который будет загружен. Этот файл должен быть создан заранее с помощью операции reg save и с расширением .hiv.
/?
Вывод справки в командной строке.

Примечания

  • В следующей таблице представлены значения возврата для операции reg load.
    Значение | Описание
    0 | Успех
    1 | Сбой

Примеры

Далее приведены примеры использования команды reg load.

reg load "hkcu\software\microsoft\winminebk2" wmbkup.hiv

Возвращает список следующего уровня вложенных разделов и записей, находящихся в разделе реестра.

Синтаксис

reg query имя_раздела [{/v имя_записи|/ve}] [/s]

Параметры

имя_раздела
Задает полный путь к разделу. Для удаленных компьютеров перед путем к разделу в формате \\имя_компьютера\путь_к_подразделу вставляется имя компьютера. Если параметр имя_компьютера не задан, операция по умолчанию выполняется на локальном компьютере. Путь следует начинать с соответствующего поддерева. Допустимыми поддеревьями являются HKLM, HKCU, HKCR, HKU и HKCC. Если задан удаленный компьютер, то можно использовать только поддеревья HKLM и HKU.
/v имя_записи
Возвращает запись и ее значение. Этот параметр возвращает только те записи, которые находятся непосредственно под заданным разделом. Записи из вложенных разделов, находящихся под текущим разделом, не выводятся. Если имя_записи пропущено, то возвращаются все записи, находящиеся в данном разделе.
/ve
Задает только те записи, которые не имеют значения.
/s
Возвращает все разделы и записи во все уровни. Без этого параметра будет возвращен только следующий уровень разделов и записей.
/?
Вывод справки в командной строке.

Примечания

  • В следующей таблице представлены значения возврата для операции reg query.
    Значение | Описание
    0 | Успех
    1 | Сбой

Примеры

Далее приведены примеры использования команды reg query.

reg query "hklm\system\currentcontrolset\control\session manager" /v maxstacktracedepth

reg query "hkcu\software\microsoft\winmine" /s

Записывает сохраненные вложенные разделы и записи обратно в раздел реестра.

Синтаксис

reg restore имя_раздела имя_файла

Параметры

имя_раздела
Задает полный путь к разделу. Операция restore работает только на локальном компьютере. Путь следует начинать с соответствующего поддерева. Допустимыми поддеревьями являются HKLM, HKCU, HKCR, HKU и HKCC.
имя_файла
Задает путь и имя файла, который будет обратно записан в реестр. Файл должен быть создан заранее с помощью операции reg save с расширением .hiv.
/?
Вывод справки в командной строке.

Примечания

  • Эта операция используется для перезаписывания отредактированных записей реестра. Перед редактированием записей родительский раздел необходимо сохранить с помощью операции reg save. В случае сбоя редактирования с помощью описанной выше операции этот раздел можно восстановить.
  • В следующей таблице представлены значения возврата для операции reg restore.
    Значение | Описание
    0 | Успех
    1 | Сбой

Примеры

Далее приведены примеры использования команды reg restore.

reg restore "hkcu\software\microsoft\winmine" wmbkup.hiv

Сохраняет копии заданных разделов, записей и значений реестра в заданном файле.

Синтаксис

reg save имя_раздела имя_файла

Параметры

имя_раздела
Задает полный путь к разделу. Для удаленных компьютеров перед путем к разделу в формате \\имя_компьютера\путь_к_подразделу вставляется имя компьютера. Если параметр имя_компьютера не задан, операция по умолчанию выполняется на локальном компьютере. Путь следует начинать с соответствующего поддерева. Допустимыми поддеревьями являются HKLM, HKCU, HKCR, HKU и HKCC.
имя_файла
Задает путь и имя файла, который будет создан. Если путь не задан, используется текущий путь.
/?
Вывод справки в командной строке.

Примечания

  • В следующей таблице представлены значения возврата для операции reg save.
    Значение | Описание
    0 | Успех
    1 | Сбой

Примеры

Далее приведены примеры использования команды reg save.

reg save "hkcu\software\microsoft\winmine" wmbkup.hiv

Удаляет раздел реестра, загруженного с помощью операции reg load.

Синтаксис

reg unload имя_раздела

Параметры

имя_раздела
Задает полный путь к разделу. Для удаленных компьютеров перед путем к разделу в формате \\имя_компьютера\путь_к_подразделу вставляется имя компьютера. Если параметр имя_компьютера не задан, операция по умолчанию выполняется на локальном компьютере. Путь следует начинать с соответствующего поддерева. Допустимыми поддеревьями являются HKLM, HKCU, HKCR, HKU и HKCC.
/?
Вывод справки в командной строке.

Примечания

  • В следующей таблице представлены значения возврата для операции reg unload.
    Значение | Описание
    0 | Успех
    1 | Сбой

Примеры

Далее приведены примеры использования команды reg unload.

reg unload "hkcu\software\microsoft\winminebk2"

  • Ошибка при изменении реестра может серьезно повредить систему. Перед изменением реестра создайте резервную копию всех важных данных.

Внимание!

  • Не редактируйте реестр до тех пор, пока не останется никакой альтернативы. Редактор реестра обходит стандартную защиту, настраивая параметры, которые вызывают снижение производительности, повреждение системы и даже требуют переустановить Windows. Для обеспечения безопасности большинство параметров реестра можно удалить с помощью программы панели управления или консоли MMC. Если требуется напрямую отредактировать реестр, то перед этим обязательно нужно сделать резервную копию. Дополнительные сведения смотрите в справке по редактору реестра.

Примечания

  • Использование команды Reg напрямую редактирует реестр локального или удаленного компьютеров. Эти изменения могут привести компьютер в нерабочее состояние и даже к необходимости установки операционной системы заново. Для внесения изменений в реестр вместо прямого его редактирования по возможности используйте панель управления или консоль ММС.
  • Некоторые операции допускают просмотр или настройку записей реестра на локальном или удаленном компьютерах, а другие - только настройку на локальных компьютерах. Кроме того, удаленный доступ к реестру может сделать недоступными некоторые параметры. Для того чтобы убедиться, что данную операцию и данные параметры можно использовать соответственно на удаленном компьютере и в данной ситуации, проверьте синтаксис каждой операции.


Regsvr32

Данная команда регистрирует в реестре файлы .dll как компоненты команды.

Синтаксис

regsvr32 [/u] [/s] [/n] [/i[:cmdline]] имя_dll

Параметры

/u
Отменяет регистрацию сервера.
/s
Задает запуск regsvr32 без вывода сообщений на экран.
/n
Указывает не вызывать DllRegisterServer. Этот параметр можно использовать с параметром /i.
/i:cmdline
Вызывает DllInstall с помощью дополнительной передачи [cmdline]. При использовании с параметром /u вызывает удаление dll.
dllname
Задает имя файла dll для последующей регистрации.
/?
Вывод справки в командной строке.

Примеры

Для регистрации файла .dll для схемы Active Directory введите:

regsvr32 schmmgmt.dll


Rem

Добавляет комментарии в пакетные файлы или файлы настройки.

Синтаксис

rem [текст]

Параметры

текст
Задает строку символов, используемую в качестве комментария.
/?
Вывод справки в командной строке.

Примечания

  • Вывод комментариев с помощью команды echo

    Команда rem не выводит комментарии на экран. Для вывода комментариев на экран необходимо использовать команду echo on в пакетных файлах или в файле Config.nt.

  • Ограничения на комментарии в пакетных файлах

    В тексте комментариев нельзя использовать символы перенаправления (< или >) или канала (|).

  • Использование команды rem для добавления вертикальных пробелов.

    Вместо команды rem, которая без текста комментария применяется для добавления вертикальных пробелов в пакетный файл, можно просто использовать пустые строки. При обработке пакетной программы пустые строки пропускаются.

Примеры

Следующий пример показывает применение комментариев и вертикальных пробелов в пакетном файле.

@echo off
rem Эта пакетная программа форматирует и проверяет новые диски.
rem Она называется CHECKNEW.BAT.
rem
echo Вставьте новый диск в дисковод B.
pause
format b: /v
chkdsk b:

Предположим, что в файл Config.nt требуется ввести поясняющий комментарий перед командой prompt. Для этого в файл Config.nt следует добавить следующие строки:

rem Установка приглашения для вывода текущего каталога
prompt $p$g


Rename (ren)

Изменяет имя файла или набора файлов.

Синтаксис

rename [диск:][путь] имя_файла_1 имя_файла_2

ren [диск:][путь] имя_файла_1 имя_файла_2

Параметры

[диск:][путь] имя_файла1
Задает местоположение и имя файла или набора файлов для переименования.
имя_файла_2
Задает новое имя файла. Если используются подстановочные знаки (* и ?), то имя_файла_2 указывает новые имена для файлов. При переименовании файлов нельзя задать новый диск или путь.
/?
Вывод справки в командной строке.

Примечания

  • Переименование файлов

    Допускается переименование всех файлов, соответствующих заданному имени файла. Команду rename нельзя использовать для переименования файлов на разных дисках или для их перемещения в другой каталог.

  • Использование подстановочных знаков при переименовании

    Подстановочные знаки (* и ?) могут быть использованы в параметрах, задающих имена. Если они использованы в параметре имя_файла_2, то символы, замещаемые символами подстановки, будут теми же, что и в параметре имя_файла_1.

  • Команда переименования не будет работать, если имя_файла_2 уже существует.

    Если имя файла, задаваемое параметром имя_файла_2, уже существует, команда rename выведет на экран следующее сообщение:

    Дублирование имени файла или файл не найден

Примеры

Допустим, что необходимо изменить расширения имен всех файлов в текущем каталоге с расширением .txt; например, требуется заменить расширение .txt на .doc. Для выполнения этих изменений введите:

ren *.txt *.doc

Для переименования файла или каталога Chap10 в Part10 введите:

ren chap10 part10


Replace

Заменяет файлы в одном каталоге файлами с теми же именами из другого каталога. Команда replace также может быть использована для добавления только тех файлов, которых еще нет в каталоге.

Синтаксис

replace [диск1:][путь1] имя_файла [диск2:][путь2] [/a] [/p] [/r] [/w]

replace [диск1:][путь1] имя_файла [диск2:][путь2] [/p] [/r] [/s] [/w] [/u]

Параметры

[диск1:][путь1] имя_файла
Задает местонахождение и имя файла или набора исходных файлов.
[диск2:][путь2]
Задает местонахождение файла-результата. Имена замещаемых файлов не могут быть заданы. Если ни диск, ни каталог не заданы, replace использует текущий диск и текущий каталог.
/a
Добавляет, а не перезаписывает файлы в каталог-результат. Нельзя использовать данный параметр совместно с параметром /s или /u.
/p
Добавляет или перезаписывает файлы с подтверждением.
/r
Замещает файлы, предназначенные только для чтения, так же, как и обычные файлы. Если этот параметр не задан, а программа пытается заменить файл, предназначенный только для чтения, на экран будет выведено сообщение об ошибке и операция замены будет остановлена.
/w
Перед началом поиска исходных файлов система будет ждать, пока пользователь вставит диск в дисковод. Если ключ /w не задан, замена или добавление фалов начнется сразу же после нажатия клавиши ENTER.
/s
Ищет по всем подкаталогам каталога-назначения и заменяет файлы с подходящими именами. Нельзя использовать параметр /s совместно с параметром командной строки /a. Команда replace не ищет подкаталоги, указанные параметром путь1.
/u
Заменяет (обновляет) только те файлы, которые имеют более раннюю дату модификации, чем файлы в исходном каталоге. Нельзя использовать параметр /u совместно с параметром командной строки /a.
/?
Отображает справку в командной строке.

Примечания

  • Сообщения команды replace

    И при замене, и при добавлении файлов команда replace выводит их имена на экран. По окончании работы команда replace выводит на экран итоговую строку в одном из следующих форматов:

    nnn файлов добавлено
    nnn файлов заменено

    ни один файл не добавлен
    ни один файл не заменен

  • Замена файлов на гибких дисках

    Если используются гибкие диски и необходима их замена во время работы команды replace, требуется задать параметр командной строки /w и команда replace будет ожидать замены дисков в случае необходимости.

  • Ограничения команды replace

    Команда replace не может быть использована для обновления скрытых или системных файлов. Чтобы получить сведения о смене атрибутов скрытых и системных файлов, смотрите attrib

  • Коды завершения команды replace

    В следующем списке приведены коды завершения команды с кратким описанием.

    Код завершения | Описание
    0 | Файлы успешно заменены или добавлены командой replace
    1 | Команда replace обнаружила некорректную версию MS-DOS
    2 | Команда replace не может найти исходные файлы
    3 | Команда replace не может найти исходные файлы или файлы-результаты
    5 | Пользователь не имеет доступа к заменяемым файлам
    8 | Недостаточно системной памяти для работы команды
    11 | В строке вызова команды содержится синтаксическая ошибка

    В пакетных программах можно использовать параметр уровень_ошибки команды if для анализа кода завершения команды replace. Чтобы посмотреть пример пакетной программы, обрабатывающей коды завершения, выберите if из списка в ссылке «См. также».

Примеры

Предположим, что несколько каталогов на диске C содержат различные версии файла Phones.cli, который включает имена клиентов и их телефонные номера. Для замены всех этих файлов новейшей версией с диска в дисководе A служит следующая команда:

replace a:\phones.cli c:\ /s

Предположим, требуется добавить новый драйвер принтера в каталог Tools на диске C, в котором уже содержится несколько файлов драйверов принтеров для текстовых процессоров.

replace a:*.prd c:\tools /a

Эта команда просматривает текущий каталог диска A и находит все файлы с расширением .prd, а затем добавляет эти файлы в каталог Tools на диске C. Так как задан параметр /a, команда replace добавит только те файлы, которых еще нет на диске C.


Rmdir (rd)

Удаляет каталог.

Синтаксис

rmdir [диск:]путь [/s] [/q]

rd [диск:]путь [/s] [/q]

Параметры

[диск:]путь
Задает диск и местоположение каталога для удаления.
/s
Удаляет указанный каталог и все подкаталоги вместе с файлами. Параметр /s используется для удаления дерева каталогов.
/q
Запускает rmdir в скрытом режиме. Команда удаляет каталоги без запроса подтверждения.
/?
Отображает справку в командной строке.

Примечания

  • Использование команды rmdir в консоли восстановления

    Команда rmdir с другими параметрами доступна в консоли восстановления.

  • Удаление каталогов со скрытыми и системными файлами

    Удаление каталогов со скрытыми и системными файлами невозможно. При попытке удаления, появится следующее сообщение:

    Каталог не является пустым.

    Для получения списка скрытых и системных файлов следует использовать команду dir, а для просмотра и смены атрибутов — команду attrib.

  • Использование обратной косой черты

    Если перед первым именем каталога вставлена обратная косая черта (\), этот каталог будет рассматриваться как подкаталог корневого каталога независимо от имени текущего каталога. Если обратной косой черты нет, каталог будет рассматриваться как подкаталог текущего каталога.

  • Удаление текущего каталога

    Команда rmdir не может быть использована для удаления текущего каталога. Вначале необходимо перейти в другой каталог (который не является подкаталогом текущего) и затем использовать команду rmdir. При попытке удалить текущий каталог появляется следующее сообщение:

    Нет доступа к файлу, так как он используется другим процессом.

Примеры

Для удаления каталога \User\Smith вначале необходимо удостовериться в том, что он не содержит файлов. Для этого наберите в командной строке:

dir \user\smith /a

На экране должны быть выведены только символы «.» и «..».

Затем из любого каталога, кроме \User\Smith, запустите следующую команду:

rmdir \user\smith

Для удаления каталога \User, всех файлов и всех подкаталогов используйте следующую команду:

rmdir /s \user


Rsm

Управляет ресурсами носителей с помощью службы «Съемные ЗУ». Используя команду rsm можно запускать пакетные сценарии для приложений, которые не поддерживает интерфейс API системы съемных носителей.

Чтобы выделить носитель из пула носителей

Синтаксис

rsm allocate /m имя_пула_носителей /o{errunavail|new|next} {/l{g|f}код_логического_носителя | /p{g|f}код_раздела} [/ln имя_логического_носителя] [/ld описание_логического_носителя] [/pn имя_раздела] [/pd описание_раздела] [/t время_ожидания] [/b]

Параметры

/m имя_пула_носителей
Носитель выбирается из указанного пула носителей. Это значит, что для работы будет использоваться выделенный носитель из этого пула.
/o
Разрешает использование одного из параметров, выведенных в следующей таблице.
Значение | Описание
errunavail | Предотвращает создание запроса оператора на новый носитель, если выделение носителя по заданным ограничениям невозможно
new | Выделяет раздел, который не может быть использован вместе с другим приложением. Так можно резервировать вторую сторону двустороннего носителя
next | Выделяет следующую сторону носителя, выделенного ранее с помощью аргумента new
/l{g|f}код_логического_носителя
Указывает носитель для выделения с помощью кода логического носителя. Используйте код GUID (с параметром lg) или понятное имя (с параметромIf). Параметр код_логического_носителя задает следующую выделяемую сторону неодностороннего носителя. Этот параметр необязателен и используется только с параметрами /o и next. После освобождения этого носителя его код не будет определен.
/p{g|f}код_раздела
Указывает раздел для выделения с помощью кода раздела. Используйте код GUID (с параметром lg) или понятное имя (с параметромIf). Этот параметр необязателен и остается определенным даже после освобождения носителя.
/ln имя_логического_носителя
Задает носитель для выделения, используя имя логического носителя.
/ld описание_логического_носителя
Задает носитель для выделения, используя описание логического носителя.
/pn имя_раздела
Определяет раздел для выделения, используя имя раздела.
/pd описание_раздела
Указывает раздел носителя для выделения, используя описание раздела.
/t время_ожидания
Задает время ожидания в миллисекундах. Время ожидания по умолчанию не ограничено.
/b
Отображается только код GUID для операции выделения. Это сделано для того, чтобы результат одной команды можно было наиболее просто передать следующей команде.

/?
Отображает справку в командной строке.

Примечания

  • В других командах параметры /lf и /pf позволяют задать в качестве параметра имя логического носителя или его стороны соответственно. Если в данной команде не используются имена носителей (понятные имена), в следующих командах для указания логического носителя можно будет использовать только коды GUID.

Чтобы создать пул носителей

Синтаксис

rsm createpool /m имя_пула_носителей /a{existing|always|new} [/t{g|f}код_типа_носителей_в_пуле] [/d] [/r]

Параметры

/m имя_пула_носителей
Задает имя создаваемого пула.
/a
Разрешает использование одного из параметров, выведенных в следующей таблице.
Значение | Описание
existing | Открывает существующий пул носителей или возвращает ошибку, если указанный пул носителей не существует
always | Открывает имеющийся пул носителей или создает новый пул носителей, если указанный пул не найден
new | Создает новый пул носителей или возвращает ошибку, если указанный пул носителей уже существует.
/tg код_типа_носителей_в_пуле
Указывает тип носителей, находящихся в пуле, используя код GUID. По умолчанию используется тип носителей родительского пула.
/tg код_типа_носителей_в_пуле
Указывает тип носителей, находящихся в пуле, используя понятное имя. По умолчанию используется тип носителей родительского пула.
/d
Разрешает пулу носителей автоматически извлекать носители из пула свободных носителей. Если ключ /d не включен в команду, данному пулу не разрешено выделять носители из пула свободных носителей.
/r
Разрешает пулу носителей автоматически возвращать носители в пул свободных носителей. Если ключ /r не включен в команду, данному пулу не разрешено возвращать носители в пул свободных носителей.

/?
Отображает справку в командной строке.

Чтобы освободить носитель

Синтаксис

rsm deallocate /l{g|f}код_логического_носителя | /p{g|f}код_раздела

Параметры

/lg код_логического_носителя
Указывает логический носитель для освобождения, используя код GUID.
/lf код_логического_носителя
Определяет логический носитель для освобождения, используя понятное имя.
/pg код_раздела
Задает сторону носителя для освобождения, используя код GUID.
/pf код_раздела
Указывает сторону носителя для освобождения, используя понятное имя.

/?
Отображает справку в командной строке.

Примечания

  • Для задания освобождаемого логического носителя может использоваться имя логического носителя или имя его стороны (раздела), только если одно из этих имен было задано в команде allocate (параметры /ln и /pn соответственно). В противном случае необходимо задать код логического носителя (LMID) или код раздела (PARTID).

Чтобы удалить пул носителей

Синтаксис

rsm deletepool /m имя_пула_носителей

Параметры

/m имя_пула_носителей
Задает имя удаляемого пула.

/?
Отображает справку в командной строке.

Чтобы отсоединить носитель от диска

Синтаксис

rsm dismount {/l{g|f}код_логического_носителя | /p{g|f}код_раздела
rsm dismount [/o[deferred]]}

Параметры

/lg код_логического_носителя
Указывает логический носитель для отсоединения, используя код GUID.
/lf код_логического_носителя
Определяет логический носитель для отсоединения, используя понятное имя.
/pg код_раздела
Задает сторону носителя для отсоединения, используя код GUID.
/pf код_раздела
Указывает сторону носителя для отсоединения, используя понятное имя.
/o
При совместном использовании с дополнительным параметром deferred, данный необязательный ключ отмечает носитель как отсоединяемый, но носитель остается в устройстве. Последующие команды присоединения будут выполняться, как обычно. Если этот параметр не используется, носитель будет отсоединен от устройства.
/?
Отображает справку в командной строке.

Примечания

  • Для задания отсоединяемого логического носителя может использоваться имя логического носителя или имя его стороны (раздела), только если одно из этих имен было задано в команде allocate (параметры /ln и /pn соответственно). В противном случае необходимо задать код логического носителя (LMID) или код раздела (PARTID).

Чтобы извлечь носитель из библиотеки

Носитель для извлечения можно задать одним из трех способов.

  • Указать физический носитель, который требуется извлечь, используя код физического носителя (PMID) или имя физического носителя.
  • Извлечь носитель из определенного отсека в библиотеке.
  • Извлечь носитель c определенного устройства в библиотеке.

Синтаксис

rsm eject {/p{g|f}код_физического_носителя | /s{g|f}код_отсека /l{g|f}код_библиотеки | /d{g|f}код_устройства /l{g|f}код_библиотеки
rsm eject [/o код_операции_извлечения]
rsm eject [/a{start|stop|queue}]
rsm eject [/b]

Параметры

/pg код_физического_носителя
Указывает физический носитель для извлечения, используя код GUID.
/pf код_физического_носителя
Определяет физический носитель для извлечения, используя понятное имя.
/sg код_отсека
Задает отсек, содержащий носитель для извлечения, используя код GUID.
/sf код_отсека
Указывает отсек, содержащий носитель для извлечения, используя понятное имя.
/lg код_библиотеки
С помощью кода GUID определяет библиотеку, содержащую отсек или устройство, из которого требуется извлечь носитель.
/lf код_библиотеки
С помощью понятного имени указывает библиотеку, содержащую отсек или устройство, из которого требуется извлечь носитель.
/dg код_устройства
Задает устройство, содержащее носитель для извлечения, используя код GUID.
/df код_устройства
Указывает устройство, содержащее носитель для извлечения, используя понятное имя.
/o код_операции_извлечения
Используется, чтобы задать код GUID для конкретной операции извлечения. Для прерывания выполнения определенной операции извлечения вместе с параметром /a и аргументом stop можно использовать необязательный параметр /o. Он также служит для отображения кода GUID определенной операции извлечения совместно с параметром /a и аргументом start.
/a
Разрешает использование одного из параметров, выведенных в следующей таблице.
Значение | Описание
Start | По умолчанию, запускает операцию извлечения немедленно. Носитель будет извлечен до истечения времени ожидания либо пока не будет выполнена другая команда «eject» с параметром командной строки /a и параметром stop. В таких командах извлечения с помощью параметра командной строки /o также должен быть задан код GUID операции. Время ожидания задается в объекте библиотеки (для всех операций извлечения) для данной библиотеки. Этот параметр задается через интерфейс API системы съемных носителей. Также может использоваться совместно с параметром /o для отображения кода GUID определенной операции извлечения
Stop | Прекращает выполнение операции извлечения до истечения времени ожидания. Определенную операцию извлечения можно прервать, используя код GUID, отображаемый при использовании параметра start с ключами /a и /o
Queue | Поставляет носитель в очередь на извлечение. Этот аргумент используется при работе с библиотеками, имеющими порты вставки/извлечения для нескольких отсеков
/b
Отображает только код GUID операции извлечения для использования в сценариях.

/?
Отображает справку в командной строке.

Чтобы извлечь носитель из сменщика ATAPI

Синтаксис

rsm ejectatapi /n номер_сменщика_ATAPI

Параметры

/n номер_сменщика_ATAPI
Задает номер сменщика. номер_сменщика_ATAPI — число в конце строки имени устройства сменщика. Например, номер сменщика ATAPI «\\.\CdChanger0» — 0.

/?
Отображает справку в командной строке.

Примечания

  • До выполнения данной команды вручную остановите службу ntmssvc.

Чтобы произвести учет носителей в определенной автоматической библиотеке

Синтаксис

rsm inventory /l{g|f}код_библиотеки /a{full|fast|default|none|stop}

Параметры

/lf код_библиотеки
Указывает библиотеку, в которой необходимо произвести учет, используя понятное имя.
/lg код_библиотеки
Указывает библиотеку, в которой необходимо произвести учет, используя код GUID.
/a
Обязательный параметр. Определяет тип операции учета, которую надо выполнить. В следующей таблице представлен список допустимых операций учета.
Значение | Описание
Full | Выполняет полный учет носителей в библиотеке. Система съемных носителей присоединяет каждую ленту или диск библиотеки и читает коды носителя.
Fast | Осуществляет учет штрих-кодов, если в библиотеке установлен считыватель штрих-кода. Если в библиотеке нет считывателя штрих-кода, система съемных носителей проверяет отсек и производит чтение кода носителя, подключенного к отсеку, который раньше был пустым.
Default | Выполняет учет, использую метод по умолчанию, указанный в диалоговом окне библиотеки Свойства
None | Учет не производится
Stop | Останавливает текущий учет для конкретной библиотеки, если он выполняется

/?
Отображает справку в командной строке.

Чтобы присоединить носитель к указанной библиотеке

Присоединяемый логический носитель должен быть задан кодом логического носителя (LMID) или именем логического носителя.

Синтаксис

rsm mount {/l{g|f}код_логического_носителя | /p{g|f}код_раздела | [/s{g|f}код_отсека /c{g|f}код сменщика}
rsm mount [/d{g|f}код_устройства]
rsm mount /o{errunavail|drive|read|write|offline}
rsm mount [/r{normal|high|low|highest|lowest}]
rsm mount [/t время_ожидания]

Параметры

/lf код_логического_носителя
Определяет логический носитель для присоединения, используя понятное имя.
/pf код_раздела
Указывает сторону носителя для присоединения, используя понятное имя.
/pg код_раздела
Задает сторону носителя для присоединения, используя код GUID.
/lg код_логического_носителя
Определяет логический носитель для присоединения, используя код GUID.
/cg код_сменщика
Задает сменщика, в котором содержится носитель для присоединения, используя код GUID. Этот аргумент можно задать только совместно с параметром /sg и кодом GUID отсека.
/cf код_сменщика
Указывает сменщика, в котором содержится носитель для присоединения, используя понятное имя. Этот аргумент можно задать только совместно с параметром /sg и кодом GUID отсека.
/sg код_отсека
Задает отсек носителей, в котором содержится носитель для присоединения, используя код GUID. Этот аргумент можно задать только совместно с параметром /cg и кодом GUID сменщика.
/sf код_отсека
Определяет отсек носителей, в котором содержится носитель для присоединения, используя понятное имя. Этот аргумент можно задать только совместно с параметром /cg и кодом GUID сменщика.
/dg код_устройства
Указывает определенное устройство, на котором требуется выполнить присоединение носителя, используя код GUID. Этот параметр необязателен и используется только с ключом /o и параметром drive.
/df код_устройства
Задает определенное устройство, на котором требуется выполнить присоединение носителя, используя понятное имя. Этот параметр необязателен и используется только с ключом /o и параметром drive.
/o
Разрешает использование одного из параметров. указанных в следующей таблице.
Значение | Описание
Errunavail | Выдает ошибку, если носитель или устройство недоступны
Drive | Задает определенное устройство, на котором выполняется присоединение. Этот аргумент используется совместно с ключом /d
Read | Присоединяет носитель для чтения
Write | Присоединяет носитель для чтения. Если используется этот аргумент, носитель, работа с которым завершена, не будет присоединен.
Offline | Выдает ошибку, если носитель не подключен
/r
В необязательном порядке определяет порядок присоединения (или приоритет). Приоритет для присоединения можно также указать с помощью одного из параметров: normal (по умолчанию), high, low, highest и lowest.
/t
В необязательном порядке задает время ожидания для команды в миллисекундах. Время ожидания по умолчанию «бесконечно».

/?
Отображает справку в командной строке.

Примечания

  • При использовании команды mount можно задать присоединяемый носитель с помощью параметра /l, параметра /p или сочетания параметров /s и /c.

Чтобы обновить библиотеку, физический носитель или все устройства с определенным типом носителя

Эта команда опрашивает указанные устройства для занесения их текущего состояния в базу данных съемных носителей. Эта команда обычно используется после извлечения и вставки носителей.

Синтаксис

rsm refresh {/l{g|f]код_библиотеки | /p{g|f}код_физического_носителя | /tg код_типа_носителя}

Параметры

/lg код_библиотеки
Задает библиотеку для обновления, используя код GUID.
/lf код_библиотеки
Определяет библиотеку для обновления, используя понятное имя.
/pg код_физического_носителя
Указывает физический носитель для обновления, используя код GUID.
/pf код_физического_носителя
Указывает физический носитель для обновления, используя понятное имя.
/tg код_типа_носителя
Задает тип носителя, который требуется обновить. Можно указать только код GUID. Этот параметр позволяет обновить состояния всех устройств чтения съемных носителей, указав код GUID съемного носителя. Этот код GUID можно определить командой «view» следующим образом: rsm view /tmedia_type /guiddisplay.
/?
Отображает справку в командной строке.

Чтобы отобразить список объектов носителей

Синтаксис

rsm view /t{drive|library|changer|storageslot|iedoor|ieport|physical_media| media_pool|partition|logical_media|media_type|drive_type|librequest}
rsm view [/cg код_контейнера]
rsm view [/guiddisplay]
rsm view [/b]

Параметры

/t {drive|library|changer|storageslot|iedoor|ieport|physical_media| media_pool|partition|logical_media|media_type|drive_type|librequest}
Выводит на экран список объектов ностелей указанного типа. При использовании без параметров будет выдан список всех пулов носителей системы съемных носителей (всех библиотек).
/cg код_контейнера
Задает код GUID контейнера объекта. Тип контейнера зависит от типа объекта (параметра), заданного в ключе /t. Если код контейнера не задан, будут выведена все экземпляры соответствующего типа объекта.
/guiddisplay
Отображает код GUID и понятое имя для объектов.
/b
Отображает только код GUID объекта для использования в сценариях.
/?
Отображает справку в командной строке.

Примечания

  • Если не используются ключи /guiddisplay и /b, отображаются только понятные имена объектов.

Примечания

  • После успешного выполнения команды возвращается код ERROR_SUCCESS. Если команда по каким-либо причинам не выполнена, возвращается код ошибки, который можно использовать в сценариях. Код ошибки представляет собой либо системный код ошибки, либо один из кодов, указанных в таблице.
    Код ошибки | Описание
    536870913 | Заданы неверные аргументы. Обычно эта ошибка бывает вызвана наличием пробела после параметра, например /t 50 вместо /t50
    536870914 | Заданы повторяющиеся параметры. Например, задана команда allocate с двумя параметрами /m
    536870915 | Указанному понятному имени не соответствует ни один код GUID. Проверьте правильность написания понятного имени с учетом регистра
    536870916 | Задано недостаточно параметров. Проверьте, не пропущен ли обязательный параметр
    536870917 | Задан неверный код GUID. Для определения правильного кода GUID воспользуйтесь командой view
    536870918 | Этот код возвращается только командой ejectatapi. Проверьте правильность работы сменщика ATAPI


Runas

Запускает конкретные средства и программы с разрешениями, отличными от тех, которые предоставляет текущая учетная запись.

Синтаксис

  • runas [{/profile|/noprofile}] [/env] [/netonly] [/smartcard] [/showtrustlevels] [/trustlevel] /user:учетная_запись_пользователя program

    Параметры

    /profile
    Загружает профиль пользователя. Параметр /profile используется по умолчанию.
    /no profile
    Определяет, что профиль пользователя не надо загружать. Это позволяет загрузить приложение быстрее, но также может привести к сбоям в некоторых приложениях.
    /env
    Задает использование текущей сетевой среды вместо локальной среды пользователя.
    /netonly
    Показывает использование введенных сведений о пользователе только для удаленного доступа.
    /smartcard
    Определяет необходимость поддержки учетных данных с помощью смарт-карты.
    /showtrustlevels
    Выводит список параметров /trustlevel.
    /trustlevel
    Указывает уровень проверки подлинности, на котором необходимо выполнить приложение. Используйте параметр /showtrustlevels для просмотра доступных уровней доверия.
    /user:учетная_запись_пользователя
    Задает имя учетной записи пользователя, которая будет использована для запуска программы. Учетная запись пользователя должна быть представлена в формате пользователь@домен или домен\пользователь.
    program
    Задает команду или программу, которая будет запущена с помощью учетной записи, указанной в параметре /user.
    /?
    Отображает справку в командной строке.

    Примечания

    • Администраторам рекомендуется использовать учетную запись с ограниченными разрешениями для выполнения повседневных задач, не связанных с администрированием, и учетную запись с более широкими правами только для выполнения отдельных административных задач. Чтобы реализовать такой подход без выхода из системы и повторного входа, войдите в систему с обычной учетной записью и используйте команду runas для запуска программ, требующих более широких прав.
    • Использование команды runas не ограничено административными учетными записями, хотя именно такой способ является наиболее употребительным. Любой пользователь с несколькими учетными записями может использовать runas для запуска программы, консоли MMC или компонента панели управления с другими личными данными.
    • Если необходимо использовать учетную запись администратора на своем компьютере, в качестве параметра /user: введите одно из следующих значений:

      /user:учетная_запись_администратора@имя_компьютера

      /user:имя_компьютера\учетная_запись_администратора

    • Чтобы использовать данную команду в качестве администратора домена, введите одно из следующих значений параметра:

      /user:учетная_запись_администратора@имя_домена

      /user:имя_домена\учетная_запись_администратора

    • С помощью команды runas можно выполнять программы (*.exe), запускать сохраненные консоли MMC (*.msc), ярлыки программ и сохраненных консолей MMC и компоненты панели управления. Их можно запускать в качестве администратора, даже если вход в систему был произведен с учетной записью члена другой группы, например группы пользователей или опытных пользователей.
    • Можно использовать команду runas для запуска любой программы, консоли MMC или компонента панели управления. Поскольку указываются соответствующие сведения об имени пользователя и его пароле, учетная запись пользователя предоставляет возможность подключения к компьютеру, а программа, консоль MMC или компонент панели управления становятся доступными в системе для учетной записи пользователя.
    • Команда runas позволяет администрировать сервер в другом лесе (компьютер, с которого запускается программа, и сервер располагаются в разных доменах).
    • При попытке запуска программы, консоли MMC или компонента контрольной панели из сети с помощью runas выполнение может окончиться неудачей, поскольку личные сведения, использованные для подключения к сетевому ресурсу, могут отличаться от тех, что использованы при запуске программы. Личные сведения, использованные при запуске программы, могут не позволить получить доступ к тому же сетевому ресурсу.
    • Некоторые компоненты, например папка «Принтеры» и элементы рабочего стола, открываются косвенно. Эти компоненты не могут быть запущены командой runas.
    • Если выполнение команды runas заканчивается неудачей, может оказаться, что служба вторичного входа не запущена или используемая учетная запись пользователя недопустима. Чтобы проверить состояние службы вторичного входа, в компоненте «Управление компьютером» щелкните узел Службы и приложения, а затем — Службы. Чтобы проверить учетную запись пользователя, попытайтесь подключиться к соответствующему домену с помощью этой учетной записи.

    Примеры

    Чтобы в качестве администратора на локальном компьютере запустить экземпляр интерпретатора командной строки , введите команду:

    runas /user:имя_локального_компьютера\administrator cmd

    После запроса введите пароль администратора.

    Чтобы запустить экземпляр оснастки «Управление компьютером», используя учетную запись администратора домена companydomain\domainadmin, введите команду:

    runas /user:companydomain\domainadmin "mmc %windir%\system32\compmgmt.msc"

    После запроса введите пароль соответствующей учетной записи.

    Чтобы запустить экземпляр блокнота, используя учетную запись администратора домена user в домене domain.microsoft.com, введите команду:

    runas /user:user@domain.microsoft.com "notepad my_file.txt"

    После запроса введите пароль соответствующей учетной записи.

    Чтобы запустить экземпляр окна командной строки, сохраненную консоль MMC, компонент панели управления или программу, которая будет администрировать сервер в другом лесе, введите команду:

    runas /netonly /user:домен\имя_пользователя "команда"

    В параметре домен\имя_пользователя должен быть указан пользователь с разрешениями, достаточными для администрирования сервера. После запроса введите пароль соответствующей учетной записи.


Rcp

Копирует файлы между компьютером c системой Windows XP и компьютером, на котором запущен сервер rshd. Windows XP и Windows 2000 не работают с rshd. Команда rcp, запущенная без параметров, выводит справку.

Синтаксис

rcp [{-a | -b}] [-h] [-r] [узел][.пользователь:] [источник] [узел][.пользователь:] [путь\точка_назначения]

Параметры

-a
Задает режим передачи (ASCII). В этом режиме символ конца строки для систем UNIX заменяется символом возврата каретки, а для персональных компьютеров — парой возврат каретки /перевод строки. Этот режим используется по умолчанию.
-b
Задает режим передачи двоичных файлов. Преобразование комбинации возврат каретки/перевод строки не выполняется.
-h
Передает исходные файлы с атрибутом «скрытый» на компьютер с Windows XP. В противном случае скрытые файлы не копируются.
-r
Рекурсивно копирует в точку назначения все каталоги источника.
узел
Задает имя локального или удаленного узла. Если узел задан с помощью IP-адреса или имя узлового компьютера содержит точки (.), необходимо задать пользователя.
пользователь
Задает имя пользователя Если имя пользователя не задано, то используется имя текущего пользователя, вошедшего в систему.
источник
Задает файлы для копирования.
путь\точка_назначения
Задает путь каталога для входа в систем на удаленном узле. Для задания пути на удаленном компьютере используются подстановочные знаки (\ , " или '). При задании нескольких исходных файлов точкой назначения является каталог.
/?
Отображает справку в командной строке.

Примечания

  • Передача данных кому-либо еще ( третьей стороне).

    Команду rcp, осуществляющую подключение, можно также использовать для передачи файлов третьй стороне. Команду rcp можно запустить с компьютера с системой Windows XP для копирования файлов между двумя компьютерами, на которых запущены серверы rshd. Сервер (демон) rshd доступен на компьютерах с системой UNIX, поэтому компьютер под управлением Windows XP при передаче данных третьей стороне может выступать только в роли компьютера, с которого запускаются команды.

  • Использование параметра -r

    И источник, и путь\точка_назначения должны быть каталогами. Если источник не является каталогом, параметр -r можно использовать без рекурсии.

  • Использование параметров источник и путь\точка_назначения

    Если имя файла не начинается с косой черты (/) для системы UNIX или обратной косой черты (\) для системы Windows XP, предполагается, что местоположение файла указано относительно текущего рабочего каталога. Для системы Windows XP — это каталог, из которого запущена команда. Для удаленной системы — это каталог входа удаленного пользователя в систему. Точка (.) указывает на текущий каталог. При задании пути на удаленном компьютере для указания подстановочных знаков следует использовать управляющие символы (\ , " или ').

  • Права доступа на удаленной системе

    Команда rcp не запрашивает пароль. Имя текущего или заданного пользователя должно существовать на удаленном компьютере и допускать выполнение команды rcp.

  • Файл .rhosts

    Файл .rhosts задает имена удаленных систем и пользователей, которым разрешен доступ к локальным ресурсам с использованием команд rsh или rcp. Этот файл (или его эквивалент, HOSTS) требуется для доступа к удаленной системе, использующей эти команды. Команды rsh и rcp, передают имя локального пользователя удаленной системе. Удаленная система использует это имя и IP-адрес (обычно сопоставляемый с именем компьютера) запрашиваемой системы для предоставления доступа. Пароль для доступа к ресурсам с использованием этих команд не требуется.

    Если пользователь подключен к домену, основной контроллер домена должен быть доступен для сопоставления имени входа в систему, так как имя не кэшируется на локальном компьютере. Поскольку имя пользователя является частью протокола rsh, команда не будет выполняться, если его нельзя получить.

    Файл .rhosts — это текстовый файл, каждая строка которого является записью. Запись включает имя локального компьютера, имя локального пользователя и произвольный комментарий. Каждое поле отделяется символом табуляции или пробелом, комментарий начинается со знака (#), например:

    computer5marie #Этот компьютер находится в комнате 31A

    Файл .rhosts должен находиться в основном каталоге пользователя на удаленном компьютере. Дополнительные сведения о специфическом использовании файла .rhosts на удаленном компьютере см. в документации удаленного компьютера.

    Кроме того, можно добавить имя компьютера в файл /Etc/Hosts на удаленном компьютере. Это позволит удаленной системе проверять подлинность удаленных запросов к компьютеру с использованием TCP/IP-утилит Windows XP.

  • Задание имен компьютеров (узлов)

    Для использования имени пользователя, отличающегося от имени текущего пользователя задайте компьютер.пользователь. Если параметр компьютер.пользователь задан вместе с источником, файл .rhosts на удаленном компьютере должен содержать следующую запись для пользователя :

    rcp host99.user7:file1 corp7.admin:file2

    Файл .rhosts на компьютере corp7 должен иметь запись для пользователя user7 , подключенного к компьютеру host99.

    Если имя компьютера задано как полное доменное имя, содержащее точки, имя пользователя должно быть добавлено к имени компьютера, как было описано выше. Иначе последняя часть имени домена будет рассматриваться как имя пользователя, как показано ниже:

    rcp domain-name1.user:user92 domain-name2.user:user7

  • Удаленная обработка

    На большинстве систем UNIX удаленная обработка производится командой, запускаемой пользовательской оболочкой. Файлы .profile или .cshrc исполняются до анализа имен файлов, что позволяет использовать экспортируемые переменные оболочки (выделяя их кавычками или управляющими символами) в именах файлов удаленной системы.

  • Копирование файлов

    При попытке копировать несколько файлов в файл, а не в каталог, будет скопирован только последний файл из списка. Команда rcp не копирует файл сам в себя (источник и точка назначения не должны быть одинаковыми.)

    Если пользователь подключен к компьютеру с Windows XP Professional с помощью имени домена, отличного от локального, а основной контроллер домена недоступен, то при команде rcp будет сбой, так как не сможет определит локальное имя пользователя. Это же ограничение действует и для команды rsh.

  • Эта команда доступна только если в свойствах сетевого адаптера в объекте Сетевые подключения в качестве компонента установлен протокол Интернета (TCP/IP).

Примеры

Для копирования локального файла в каталог подключения удаленного компьютера введите:

rcp filename remotecomputer:

Для копирования локального файла в существующий каталог с новым именем файла на удаленном компьютере введите:

rcp filename remotecomputer:/directory/newfilename

Для копирования нескольких локальных файлов в подкаталог в удаленном каталоге подключения введите:

rcp file1 file2 file3 remotecomputer:subdirectory/filesdirectory

Для копирования из удаленного источника в текущий каталог на локальном компьютере введите:

rcp remotecomputer:filename

Для копирования нескольких файлов с удаленных компьютеров на удаленный компьютер с другим именем пользователя введите:

rcp remote1.user1:file1 remote2.user2:file2 remotedest.destuser:directory

Условные обозначения форматирования

Формат | Значение
Курсив | Сведения, вводимые пользователем
Полужирный | Элементы, вводимые без изменений
Многоточие (...) | Параметр может быть введен в командной строке несколько раз
В квадратных скобках ([]) | Необязательные элементы
В фигурых скобках ({}); варианты, разделенные вертикальной линией (|), пример: {even|odd} | Набор вариантов, из которых необходимо выбрать один
Шрифт Courier | Выходные данные программы


Rexes

Rexec

Запускает команды на удаленных компьютерах с работающей службой Rexec. Команда rexec проверяет подлинность имени пользователя на удаленном компьютере до выполнения определенной команды. Операционные системы Windows XP и Windows 2000 не предоставляют возможности службы Rexec. Запущенная без параметров команда rexec выводит справку.

Синтаксис

rexec [узел] [-l имя_пользователя] [-n] [команда]

Параметры

узел
Указывает имя или IP-адрес удаленного узла (компьютера), на котором необходимо выполнить команду.
-l имя_пользователя
Задает имя пользователя, которое будет использовано на удаленном компьютере. Если этот параметр опущен, используется имя текущего пользователя, вошедшего в систему.
-n
Перенаправляет ввод команды rexec с устройства NUL. Это предотвращает отображение результатов команды на локальном компьютере.
команда
Задает команду, которая будет запущена на удаленном компьютере.
/?
Отображает справку в командной строке.

Примечания

  • Стандартные операции

    Команда rexec запрашивает пароль пользователя и проверяет его на удаленном компьютере. Заданная команда будет выполняться после подтверждения подлинности пароля.

    Команда rexec копирует стандартный ввод в удаленную команду, стандартный вывод удаленной команды в свой стандартный поток вывода и стандартные ошибки удаленной команды в свой стандартный поток сообщений об ошибках. Команда rexec обычно завершает работу после окончания работы удаленной команды.

  • Использование символов перенаправления

    Для выполнения перенаправления на удаленном компьютере следует заключать символы перенаправления в кавычки (например, ">>"). При отсутствии кавычек перенаправление выполняется на локальном компьютере. Например, следующая команда будет добавлять удаленный файл уд_файл к локальному файлу лок_файл:

    rexec уд_компьютер cat уд_файл >> лок_файл

    Следующая команда будет добавлять удаленный файл уд_файл1 к файлу уд_файл2 на удаленном компьютере:

    rexec уд_компьютер cat уд_файл1">>" уд_файл2

  • Интерактивные команды

    Большинство интерактивных команд не могут быть запущены командой rexec. Например, командой rexec не могут быть запущены программы vi или emacs. Однако, имеется возможность использовать команды telnet.

  • Эта команда доступна, только если в свойствах сетевого адаптера в объекте Сетевые подключения в качестве компонента установлен протокол Интернета (TCP/IP).

Примеры

Чтобы выполнить команду telcon на удаленном компьютере «vax1», используя имя «admin1», введите следующую команду:

rexec vax1 -l admin1 telcon

Условные обозначения форматирования

Формат | Значение
Курсив | Сведения, вводимые пользователем
Полужирный | Элементы, вводимые без изменений
Многоточие (...) | Параметр может быть введен в командной строке несколько раз
В квадратных скобках ([]) | Необязательные элементы
В фигурых скобках ({}); варианты, разделенные вертикальной линией (|), пример: {even|odd} | Набор вариантов, из которых необходимо выбрать один
Шрифт Courier | Выходные данные программы


Route

Выводит на экран и изменяет записи в локальной таблице IP-маршрутизации. Запущенная без параметров, команда route выводит справку.

Синтаксис

route [-f] [-p] [команда [конечная_точка] [mask маска_сети] [шлюз] [metric метрика]] [if интерфейс]]

Параметры

-f
Очищает таблицу маршрутизации от всех записей, которые не являются узловыми маршрутами (маршруты с маской подсети 255.255.255.255), сетевым маршрутом замыкания на себя (маршруты с конечной точкой 127.0.0.0 и маской подсети 255.0.0.0) или маршрутом многоадресной рассылки (маршруты с конечной точкой 224.0.0.0 и маской подсети 240.0.0.0). При использовании данного параметра совместно с одной из команд (таких, как add, change или delete) таблица очищается перед выполнением команды.
-p
При использовании данного параметра с командой add указанный маршрут добавляется в реестр и используется для инициализации таблицы IP-маршрутизации каждый раз при запуске протокола TCP/IP. По умолчанию добавленные маршруты не сохраняются при запуске протокола TCP/IP. При использовании параметра с командой print выводит на экран список постоянных маршрутов. Все другие команды игнорируют этот параметр. Постоянные маршруты хранятся в реестре по адресу HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\PersistentRoutes
команда
Указывает команду, которая будет запущена на удаленной системе. В следующей таблице представлен список допустимых параметров.
Команда | Назначение
add | Добавление маршрута
change | Изменение существующего маршрута
delete | Удаление маршрута или маршрутов
print | Печать маршрута или маршрутов
конечная_точка
Определяет конечную точку маршрута. Конечной точкой может быть сетевой IP-адрес (где разряды узла в сетевом адресе имеют значение 0), IP-адрес маршрута к узлу, или значение 0.0.0.0 для маршрута по умолчанию.
mask маска_сети
Указывает маску сети (также известной как маска подсети) в соответствии с точкой назначения. Маска сети может быть маской подсети соответствующей сетевому IP-адресу, например 255.255.255.255 для маршрута к узлу или 0.0.0.0. для маршрута по умолчанию. Если данный параметр пропущен, используется маска подсети 255.255.255.255. Конечная точка не может быть более точной, чем соответствующая маска подсети. Другими словами, значение разряда 1 в адресе конечной точки невозможно, если значение соответствующего разряда в маске подсети равно 0.
шлюз
Указывает IP-адрес пересылки или следующего перехода, по которому доступен набор адресов, определенный конечной точкой и маской подсети. Для локально подключенных маршрутов подсети, адрес шлюза — это IP-адрес, назначенный интерфейсу, который подключен к подсети. Для удаленных маршрутов, которые доступны через один или несколько маршрутизаторов, адрес шлюза — непосредственно доступный IP-адрес ближайшего маршрутизатора.
metric метрика
Задает целочисленную метрику стоимости маршрута (в пределах от 1 до 9999) для маршрута, которая используется при выборе в таблице маршрутизации одного из нескольких маршрутов, наиболее близко соответствующего адресу назначения пересылаемого пакета. Выбирается маршрут с наименьшей метрикой. Метрика отражает количество переходов, скорость прохождения пути, надежность пути, пропускную способность пути и средства администрирования.
if интерфейс
Указывает индекс интерфейса, через который доступна точка назначения. Для вывода списка интерфейсов и их соответствующих индексов используйте команду route print. Значения индексов интерфейсов могут быть как десятичные, так и шестнадцатеричные. Перед шестнадцатеричными номерами вводится 0х. В случае, когда параметр if пропущен, интерфейс определяется из адреса шлюза.
/?
Отображает справку в командной строке.

Примечания

  • Большие значения в столбце metric таблицы маршрутизации — результат возможности протокола TCP/IP автоматически определять метрики маршрутов таблицы маршрутизации на основании конфигурации IP-адреса, маски подсети и стандартного шлюза для каждого интерфейса ЛВС. Автоматическое определение метрики интерфейса, включенное по умолчанию, устанавливает скорость каждого интерфейса и метрики маршрутов для каждого интерфейса так, что самый быстрый интерфейс создает маршруты с наименьшей метрикой. Чтобы удалить большие метрики, отключите автоматическое определение метрики интерфейса в дополнительных свойствах протокола TCP/IP для каждого подключения по локальной сети.
  • Имена могут использоваться для параметра конечная_точка, если существует соответствующая запись в файле базы данных Networks, находящемся в папке системный_корневой_каталог\System32\Drivers\Etc. В параметре шлюз можно указывать имена до тех пор, пока они разрешаются в IP-адреса с помощью стандартных способов разрешения узлов, таких как запрос службы DNS, использование локального файла Hosts, находящегося в папке системный_корневой_каталог\system32\drivers\etc, или разрешение имен NetBIOS.
  • Если команда — print или delete, параметр шлюз опускается и используются подстановочные знаки для указания точки назначения и шлюза. Значение конечной_точки может быть подстановочным значением, которое указывается звездочкой (*). При наличии звездочки (*) или вопросительного знака (?) в описании конечной точки, они рассматриваются как подстановки, тогда печатаются или удаляются только маршруты, соответствующие точке назначения. Звездочка соответствует любой последовательности символов, а вопросительный знак — любому одному символу. 10.*.1, 192.168.*, 127.* и *224* являются допустимыми примерами использования звездочки в качестве подстановочного символа.
  • При использовании недопустимой комбинации значений конечной точки и маски подсети (маски сети) выводится следующее сообщение об ошибке : «Маршрут: неверная маска подсети адреса шлюза». Ошибка появляется, когда одно или несколько значений разрядов в адресе конечной точки равно 1, а значения соответствующих разрядов маски подсети — 1. Для проверки этого состояния выразите конечную точку и маску подсети в двоичном формате. Маска подсети в двоичном формате состоит из последовательности единичных битов, представляющей часть сетевого адреса конечной точки, и последовательности нулевых битов, обозначающей часть адреса узла конечной точки. Проверьте наличие единичных битов в части адреса точки назначения, которая является адресом узла (как определено маской подсети).
  • Параметр -p поддерживается в команде route только в операционных системах Windows NT 4.0, Windows 2000, Windows Millennium Edition и Windows XP.
  • Эта команда доступна, только если в свойствах сетевого адаптера в объекте Сетевые подключения в качестве компонента установлен протокол Интернета (TCP/IP).

Примеры

Чтобы вывести на экран все содержимое таблицы IP-маршрутизации, введите команду:

route print

Чтобы вывести на экран маршруты из таблицы IP-маршрутизации, которые начинаются с 10., введите команду:

route print 10.*

Чтобы добавить маршрут по умолчанию с адресом стандартного шлюза 192.168.12.1, введите команду:

route add 0.0.0.0 mask 0.0.0.0 192.168.12.1

Чтобы добавить маршрут к конечной точке 10.41.0.0 с маской подсети 255.255.0.0 и следующим адресом перехода 10.27.0.1, введите команду:

route add 10.41.0.0 mask 255.255.0.0 10.27.0.1

Чтобы добавить постоянный маршрут к конечной точке 10.41.0.0 с маской подсети 255.255.0.0 и следующим адресом перехода 10.27.0.1, введите команду:

route -p add 10.41.0.0 mask 255.255.0.0 10.27.0.1

Чтобы добавить маршрут к конечной точке 10.41.0.0 с маской подсети 255.255.0.0 и следующим адресом перехода 10.27.0.1 и метрикой стоимости 7, введите команду:

route add 10.41.0.0 mask 255.255.0.0 10.27.0.1 metric 7

Чтобы добавить маршрут к конечной точке 10.41.0.0 с маской подсети 255.255.0.0 и следующим адресом перехода 10.27.0.1 и использованием индекса интерфейса 0х3, введите команду:

route add 10.41.0.0 mask 255.255.0.0 10.27.0.1 if 0x3

Чтобы удалить маршрут к конечной точке 10.41.0.0 с маской подсети 255.255.0.0, введите команду:

route delete 10.41.0.0 mask 255.255.0.0

Чтобы удалить все маршруты из таблицы IP-маршрутизации, которые начинаются с 10., введите команду:

route delete 10.*

Чтобы изменить следующий адрес перехода для маршрута с конечной точкой 10.41.0.0 и маской подсети 255.255.0.0 с 10.27.0.1 на 10.27.0.25, введите команду:

route change 10.41.0.0 mask 255.255.0.0 10.27.0.25

Условные обозначения форматирования

Формат | Значение
Курсив | Сведения, вводимые пользователем
Полужирный | Элементы, вводимые без изменений
Многоточие (...) | Параметр может быть введен в командной строке несколько раз
В квадратных скобках ([]) | Необязательные элементы
В фигурых скобках ({}); варианты, разделенные вертикальной линией (|), пример: {even|odd} | Набор вариантов, из которых необходимо выбрать один
Шрифт Courier | Выходные данные программы


Rsh

Выполняет команды на удаленном компьютере, на котором запущена служба RSH или демон. Windows XP и Windows 2000 не поддерживают службу RSH. Службу RSH с именем Rshsvc.exe предоставляет пакет «Windows 2000 Server Resource Kit». Used without parameters, rsh displays help.

Синтаксис

rsh [узел] [-l имя_пользователя] [-n] [команда]

Параметры

узел
Задает удаленный узел (компьютер), на котором запускается команда.
-l имя_пользователя
Задает имя пользователя, используемое при подключении к удаленной системе. Если этот параметр опущен, используется имя текущего пользователя, вошедшего в систему.
-n
Перенаправляет ввод команды rsh с устройства NUL. Это предотвращает отображение результатов команды на локальном компьютере.
команда
Указывает команду, которая будет запущена на удаленной системе.
/?
Отображает справку в командной строке.

Примечания

  • Стандартные операции

    Команда rsh копирует стандартный ввод в удаленную команду, стандартный вывод удаленной команды в свой стандартный поток вывода и стандартные ошибки удаленной команды в свой стандартный поток сообщений об ошибках. Команда Rsh обычно заканчивает работу после окончания работы удаленной команды.

  • Использование символов перенаправления

    Заключайте символы перенаправления в кавычки для выполнения перенаправления на удаленном компьютере (например, ">>"). При отсутствии кавычек перенаправление выполняется на локальном компьютере. Например, следующая команда будет добавлять удаленный файл уд_файл к локальному файлу лок_файл:

    rsh уд_компьютер cat уд_файл >> лок_файл

    Следующая команда будет добавлять удаленный файл уд_файл1 к файлу уд_файл2 на удаленном компьютере:

    rsh уд_компьютер cat уд_файл1">>" уд_файл2

  • Использование команды rsh

    При использовании компьютера, который находится под управлением Windows XP Professional и входит в домен, должен быть доступен основной контроллер домена для проверки имени пользователя, в противном случае, команда rsh не выполняется.

  • Файл .rhosts

    Файл .rhosts обычно управляет правами сетевого доступа к UNIX системам. В этом файле перечислены имена компьютеров и соответствующие имена пользователей, которые имеют доступ к удаленным компьютерам. При обращении к удаленной системе с правильно настроенным файлом .rhosts с помощью команд rcp, rexec и rsh ввод имени пользователя и пароля не требуется.

    Файл .rhosts является текстовым файлом, в котором каждая строка является записью. Запись состоит из локального имени компьютера, локального имени пользователя и произвольного комментария. Каждое поле отделяется символом табуляции или пробелом, комментарий начинается со знака (#), например: Например:

    узел7 #Этот компьютер находится в комнате 31

    Файл .rhosts должен находиться в основном каталоге пользователя на удаленном компьютере. Дополнительные сведения о специфической реализации файла .rhosts на удаленном компьютере см. в документации удаленного компьютера.

  • Эта команда доступна, только если в свойствах сетевого адаптера в объекте Сетевые подключения в качестве компонента установлен протокол Интернета (TCP/IP).

Примеры

Чтобы выполнить команду telcon на удаленном компьютере «vax1», используя имя «admin1», введите следующую команду:

rsh vax1 -l admin1 telcon

Условные обозначения форматирования

Формат | Значение
Курсив | Сведения, вводимые пользователем
Полужирный | Элементы, вводимые без изменений
Многоточие (...) | Параметр может быть введен в командной строке несколько раз
В квадратных скобках ([]) | Необязательные элементы
В фигурых скобках ({}); варианты, разделенные вертикальной линией (|), пример: {even|odd} | Набор вариантов, из которых необходимо выбрать один
Шрифт Courier | Выходные данные программы


Rundll32

Windows имеет в своем составе утилиту командной строки Rundll32.exe, позволяющую запускать команды-функции, заложенные в DLL-файлах.

Список команд.

  • rundll32 shell32.dll,Control_RunDLL hotplug.dll - диалоговое окно Отключение или извлечение аппаратного устройства
  • rundll32 diskcopy,DiskCopyRunDll - вызов диалога "Копирование диска".
  • rundll32 keyboard,disable - отключение клавиатуры до следующей перезагрузки.
  • rundll32 mouse,disable - отключение мыши до перезагрузки.
  • rundll32 krnl386.exe,exitkernel - выгрузить ядро системы, выход из Windows.
  • rundll32 mshtml.dll,PrintHTML "HtmlFileNameAndPath" - распечатать документ HTML, где "HtmlFileNameAndPath" - путь к файлу и его имя.
  • rundll32 мсprint2.dll,RUNDLL_PrintTestPage - распечатать тестовую страницу на принтере.
  • rundll32 netplwiz.dll,AddNetPlaceRunDll - вызов мастера подключения нового сетевого ресурса "Добавление в сетевое окружение".
  • rundll32 rnaui.dll,RnaWizard - вызов мастера "Удаленный доступ к сети".
  • rundll32 rnaui.dll,RnaWizard /1 - вызов мастера "Удаленный доступ к сети" без отображения начального окна.
  • rundll32 shell,ShellExecute - открыть Проводник (папка "Рабочий стол").
  • rundll32 shell32,Control_RunDLL - открыть в Проводнике папку "Панель управления".
  • rundll32 shell32,Control_RunDLL appwiz.cpl,,n - вызов диалогового окна "Установка и удаление программ", будет открыта вкладка с номером "n" (от 1 до 3).
  • rundll32 shell32,Control_RunDLL main.cpl @0 - открыть диалог "Свойства мыши".
  • rundll32 shell32,Control_RunDLL main.cpl @1 - открыть диалог "Свойства клавиатуры".
  • rundll32 shell32,Control_RunDLL main.cpl @2 - открыть папку "Принтеры".
  • rundll32 SHELL32,SHHelpShortcuts_RunDLL PrintersFolder - открыть папку "Принтеры".
  • rundll32 shell32,Control_RunDLL main.cpl @3 - открыть папку "Шрифты".
  • rundll32 SHELL32,SHHelpShortcuts_RunDLL FontsFolder - открыть папку "Шрифты".
  • rundll32 SHELL32,Control_RunDLL modem.cpl, add - открыть диалог "Свойства модема".
  • rundll32 shell32,Control_RunDLL timedate.cpl - открыть диалог "Дата и время".
  • rundll32 shell32,OpenAs_RunDLL - вызвать диалог "Открыть с помощью...".
  • rundll32 shell32,ShellAboutA WINHOWTO.RU - информация о версии Windows.
  • rundll32 shell32,SHExitWindowsEx 0 - закрыть все программы, перегрузить оболочку.
  • rundll32 shell32, SHExitWindowsEx 1 - выключить ПК.
  • rundll32 SHELL32, SHExitWindowsEx -1 - перегрузить оболочку Windows.
  • rundll32 shell32, SHExitWindowsEx 2 - перегрузить ПК.
  • rundll32 shell32,SHExitWindowsEx 4 - принудительно закрыть все программы.
  • rundll32 shell32,SHExitWindowsEx 8 - выход из Windows и выключение ATX-совместимого ПК.
  • rundll32 shell32,SHFormatDrive - вызов диалога форматирования диска А:.
  • rundll32 SHELL32,SHHelpShortcuts_RunDLL AddPrinter - запуск "Мастера установки принтера".
  • rundll32 shell32,SHHelpShortcuts_RunDLL Connect - запуск мастера подключения сетевого диска.
  • rundll32 SHELL32,SHHelpShortcuts_RunDLL PrintTestPage - распечатать тестовую страницу.
  • rundll32 sysdm.cpl,InstallDevice_Rundll - вызов мастера установки оборудования.
  • rundll32 url.dll,FileProtocolHandler %1 - открыть веб-страницу, где %1 - URL сайта (включая http://).
  • rundll32 url.dll,MailToProtocolHandler %1 - создать новое письмо, где %1 - e-mail адресата.
  • rundll32 user,CASCADECHILDWINDOWS - расположить все окна каскадом.
  • rundll32 user,TILECHILDWINDOWS - расположить все окна по экрану.
  • rundll32 user,disableoemlayer - сбой системы (!) - отключаются все функции ввода-вывода (клавиатура, дисплей, мышь). Будет черный экран с курсором и не реагирующая система, Windows продолжает работать.
  • rundll32 user,ExitWindowsExec - быстрая перезагрузка Windows.
  • rundll32 user,RepaintScreen - выполнить команду "Обновить".
  • rundll32 user,SetCaretBlinkTime n - задать частоту мигания курсора, соответствующую значению параметра n.
  • rundll32 user,SetCursorPos - переместить курсор мыши в верхний левый угол экрана.
  • rundll32 user,SetDoubleClickTime n - задать скорость двойного нажатия левой кнопки мыши (Double Click), соответствующую параметру n.
  • rundll32 user,SwapMouseButton - поменять местами клавиши мыши (обратная смена невозможна).
  • rundll32 user,WNetConnectDialog - вызов диалога "Подключение сетевого диска".
  • rundll32 user,WNetDisconnectDialog - вызов диалога "Отключение сетевого диска".
  • rundll32 AppWiz.Cpl,NewLinkHere %1 - запуск мастера создания нового ярлыка, где %1 - путь к исходному файлу.


Append

Разрешение программе открывать файлы данных в указанных папках, как будто они находятся в текущей папке. Вызванная без параметров, команда append выводит список присоединенных каталогов.

Синтаксис

append [;] [[диск:]путь[;...]] [/x:{on|off}][/path:{on|off}] [/e]

Параметры

;
Очищает список папок, заданных в предыдущих вызовах команды append.
[диск:]путь
Задает диск и папку, которую требуется присоединить к текущей папке. Если диск не указан, по умолчанию используется текущий диск. Имеется возможность задать несколько комбинаций [диск:]путь, разделенных точкой с запятой.
/x:{on | off}
Определяет, будет ли подсистема MS-DOS искать присоединенные папки при выполнении программ. /x:on — поиск присоединенных папок выполняется. /x:off — поиск присоединенных папок не выполняется.
/path:{on|off}
Указывает программе на необходимость поиска файлов в присоединенных папках, если имена файлов указаны полностью. По умолчанию используется значение /path:on.
/e
Запись списка присоединенных папок в переменную среды APPEND. Этот параметр командной строки можно использовать только при первом вызове команды append после запуска системы.
/?
Отображение справки в командной строке.

Заметки

  • Сохранение списка присоединенных папок

    Параметр командной строки /e команды append позволяет присвоить список присоединенных папок переменной среды с именем APPEND. Для этого сначала используйте команду append только с параметром командной строки /e. Затем повторно воспользуйтесь командой append, указав папки, которые требуется присоединить. Параметры /e и [диск:]путь не могут использоваться в одной командной строке.

  • Задание нескольких присоединенных папок

    Чтобы присоединить несколько папок, вводите их, разделяя точками с запятой. При повторном вызове команды append с параметрами [диск:]путь существующий список присоединенных папок в команде append будет заменен новым.

  • Использование параметра dir

    При использовании команды dir для вывода списка фалов и подкаталогов каталога имена файлов из присоединенных папок не отображаются.

  • Разрешение конфликтов имен файлов

    Если в имена файлов в текущей и присоединенной папке совпадают, для работы программ открываются файлы текущей папки.

  • Команда append и создание новых файлов

    Если открыт файл в присоединенной папке, то работа с ним ведется так же, как и с файлами текущей папки. Если выполняется сохранение файла путем создания файла с таким же именем, новый файл сохраняется в текущей папке, а не в присоединенной. Команда append используется при работе с файлами данных, которые не изменяются или изменяются без создания новых копий. Например, при работе с базами данных новые копии файлов, как правило, не создаются. Текстовые редакторы и процессоры обычно сохраняют файлы путем создания новых копий. Чтобы избежать некорректной работы, не используйте команду append с такими программами.

  • Использование параметра /x:on с командой path

    Если задан параметр /x:on, программы, находящиеся в присоединенных папках, могут быть запущены просто вводом имени программы в командной строке. Обычно команда path позволяет указать папки, содержащие программы, однако для указания присоединенных папок, содержащих программы, не требуется использовать команду path. Подсистема MS-DOS найдет эту программу с использованием списка присоединенных каталогов. Это вызвано тем, что MS-DOS вначале ищет исполняемый файл программы в текущем каталоге, а затем в каталогах, задаваемых командой .

  • Сокращение параметра /x:on до /x

    Имеется возможность сократить параметр /x:on до /x. Для этого введите параметр /x:on при первом вызове команды append после запуска системы. После этого можно переключаться между /x:on и /x:off.

  • Использование параметра /e с командой set

    Воспользовавшись параметром /e с командой set, можно вывести список присоединенных папок.

Примеры

Чтобы получить возможность открывать в программах файлы данных из папок B:\Letters и A:\Reports как из текущей папки, введите:

append b:\letters;a:\reports

Чтобы присоединить те же самые папки и сохранить копию списка присоединенных файлов в среде Windows XP (эту операцию нужно выполнять при первом вызове команды append после запуска системы), введите:

append /e

append b:\letters;a:\reports


Assoc

Вывод или изменение связи между расширениями имени и типами файлов. Запущенная без параметров команда assoc выводит список текущих связей между расширениями имени и типами файлов.

Синтаксис

assoc [.рсш[=[тип_файла]]]

Параметры

.рсш
Задание расширения имени файла.
тип_файла
Задание типа файла, с которым сопоставляется указанное расширение имени файла.
/?
Отображение справки в командной строке.

Заметки

  • Чтобы удалить связь между расширением имени и типом файла, введите пробел после знака равенства.
  • Чтобы просмотреть текущие типы файлов, выполните команду ftype без параметров.
  • Чтобы направить вывод команды assoc в текстовый файл, воспользуйтесь оператором перенаправления >.

Примеры

Чтобы вывести текущий тип файла, соответствующий расширению имени файла .txt, введите:

assoc .txt

Чтобы удалить тип файла, соответствующий расширению имени файла .txt, введите:

assoc .txt=

Чтобы просмотреть текущие сопоставления типов файлов, введите:

assoc | more

Чтобы отправить результаты выполнения команды assoc в файл Assoc.cfg, введите:

assoc>assoc.cfg


At

Запуск программ и команд в заданное время. Команду at можно использовать только при запущенной службе расписаний. Вызванная без параметров команда at выводит список всех команд и программ, которые будут запущены с ее помощью.

Синтаксис

at [\\имя_компьютера] [{[код] [/delete]|/delete [/yes]}]

at [[\\имя_компьютера] часы:минуты [/interactive] [{/every:дата[,...]|/next:дата[,...]}] команда]

Параметры

\\имя_компьютера
Задание удаленного компьютера, на котором могут быть запущены команды и программы. Если этот параметр не задан, предполагается, что они будут запущены на том компьютере, где выполняется команда at.
код
Указание идентификационного номера, присваиваемого команде или программе, которая будет запущена.
/delete
Отмена выполнения команды. Если идентификатор Код не задан, все запланированные команды на компьютере будут отменены.
/yes
Задание утвердительного ответа на все запросы системы при отмене запланированных событий.
часы:минуты
Задание времени запуска команды. Время задается в 24-х часовом формате часы:минуты (от 00:00 [полночь] до 23:59).
/interactive
Обмен данными с помощью команды с теми пользователями, которые работают в системе в момент выполнения запланированной команды.
/every:
Выполнение команды в указанный день или дни в течение недели или месяца (например каждый четверг или каждый третий день месяца).
дата
Задание даты выполнения команды. Имеется возможность указать один или несколько дней недели (т. е. ввести M,T,W,Th,F,S,Su) либо один или несколько дней месяца (т. е. ввести числа в диапазоне от 1 до 31). Несколько дат разделяются запятыми. Если параметр дата не задан, в команде at используется текущий день месяца.
/next:
Выполнение команды при наступлении следующей заданной даты (например в следующий четверг).
команда
Задание команды Windows, программы (т. е. файл .exe или .com) или пакетного файла (т. е. файл .bat или .cmd), которые требуется выполнить. Если для задания команды необходимо указывать ее местоположение, имя файла задается полностью, с указанием пути и диска. Если команда запускается на удаленном компьютере, укажите имя сервера и сетевое имя в стандартном формате записи пути (UNC), а не имя диска этого компьютера.
/?
Отображение справки в командной строке.

Заметки

  • Команда Schtasks является более мощным, расширенным средством планирования заданий с помощью командной строки и включает в себя все функциональные возможности команды at. Для планирования заданий с командной строки используйте команду schtasks вместо at.

  • Использование at

    Для вызова команды at пользователь должен быть членом локальной группы администраторов.

  • Загрузка программы Cmd.exe

    Команда at не вызывает автоматически командный процессор Cmd.exe перед запуском команды. Если запускается не исполняемый (.exe) файл, перед командой должен быть явно загружен командный процессор Cmd.exe, например:

    cmd /c dir > c:\test.out

  • Просмотр запланированных команд

    Если команда at используется без параметров, запланированные задания выводятся в таблице следующего вида:

    Состояние  Код   День       Время        Командная строка
    OK      1    Каждый F    4:30 PM     net send group leads status due
    OK      2    Каждый M    12:00 AM    chkstor > check.file
    OK      3    Каждый F    11:59 PM    backup2.bat
  • Включение идентификационного номера (код)

    Если в командной строке для команды at указан идентификационный номер (код), выводятся сведения об одной записи, имеющие следующий вид:

    Код задачи:      1

Состояние:       OK

Дата:     Каждый  F

Время дня:  4:30 PM

Команда:      net send group leads status due

    После того как запуск команды запланирован с помощью at, особенно если запускаемая команда имеет дополнительные параметры, проверьте правильность ее ввода, вызвав at без параметров. Если сведения в столбце «Командная строка» содержат ошибки, удалите запись о данной команде в списке запланированных команд и повторно введите данные. Если по-прежнему имеют место ошибки, введите команду с меньшим числом параметров.

  • Просмотр результатов

    Команды, запуск которых задан с помощью at, выполняются как фоновые процессы. Сведения не отображаются на экране компьютера. Для перенаправления вывода в файл используется символ перенаправления (>). Если вывод перенаправляется в файл, необходимо использовать управляющий символ (^) перед символом перенаправления независимо от того, используется ли at в командной строке или в пакетном файле. Например, чтобы перенаправить вывод в файл Output.txt, введите:

    at 14:45 c:\test.bat ^>c:\output.txt

    Текущим каталогом для выполнения запланированных команд является системный_корневой_каталог.

  • Изменение системного времени

    Если системное время изменено после планирования вызова команд с помощью at, синхронизируйте планировщик команды at с измененным системным временем, вызвав at без параметров.

  • Сохранение запланированных команд

    Запланированные команды сохраняются в реестре. Таким образом, запланированные задания не будут потеряны при перезапуске службы расписаний.

  • Подключение к сетевым дискам

    Не указывайте перенаправленные диски для запланированных заданий, требующих доступ к сети. Служба расписаний может не получить доступа к таким дискам или диски могут оказаться неподключенными, если другой пользователь окажется подключенным к системе в момент выполнения запланированного задания. Вместо этого, используйте пути UNC при работе с запланированными заданиями. Например:

    at 13:00 my_backup \\server\share

    Запрещается использовать следующий синтаксис, где x: — подключение, устанавливаемое пользователем:

    at 13:00 my_backup x:

    Если с помощью at запланирована команда, использующая буквенное обозначение диска для подключения к общему каталогу, то после выполнения команды должна быть запланирована команда at, отключающая данный диск. В противном случае, имя, присвоенное данному диску, будет недоступно в командной строке.

Примеры

Для вывода списка команд, которые будут выполнены на сервере Marketing, можно использовать следующую команду:

at \\marketing

Для получения дополнительных сведений о команде с идентификатором 3 на сервере Corp требуется ввести следующую команду:

at \\corp 3

Для запуска команды net share на сервере Corp в 8:00 и перенаправления вывода на сервер Maintenance в общий каталог Reports в файл Corp.txt требуется ввести следующую команду:

at \\corp 08:00 cmd /c "net share reports=d:\marketing\reports >> \\maintenance\reports\corp.txt"

Чтобы записывать на магнитную ленту резервную копию жесткого диска сервера Marketing в полночь через каждые пять дней, создайте пакетный файл Archive.cmd, содержащий команды резервирования, а затем запланируйте запуск пакетного файла, введя:

at \\marketing 00:00 /every:5,10,15,20,25,30 archive

Чтобы отменить вызов всех команд, запланированных на данном сервере, необходимо очистить расписание команды at следующим образом:

at /delete

Чтобы запустить команду, которая не является исполняемым файлом, введите перед ней cmd /c для загрузки программы Cmd.exe следующим образом:

cmd /c dir > c:\test.out


Atmadm

Контроль подключений и адресов, зарегистрированных диспетчером вызовов ATM в сетях с асинхронным режимом передачи (ATM). Команда atmadm может быть использована для вывода статистики входящих и исходящих вызовов ATM-адаптеров. Вызванная без параметров команда atmadm отображает статистику для контроля состояния активных ATM-подключений.

Синтаксис

atmadm [/c][/a] [/s]

Параметры

/c
Вывод сведений о вызовах для всех текущих подключений к сетевому ATM-адаптеру, установленному на компьютере.
/a
Вывод зарегистрированного ATM-адреса точек доступа к сетевым службам (Network Service Access Point, NSAP) для каждого адаптера, установленного на компьютере.
/s
Вывод статистики для контроля состояния активных ATM-подключений.
/?
Отображение справки в командной строке.

Примеры

Вывод сведений о вызовах

Чтобы вывести сведения о вызовах для всех текущих подключений к сетевому ATM-адаптеру, установленному на компьютере, введите:

atmadm /c

Сведения, полученные в результате выполнения команды atmadm /c, будут иметь следующий вид:

Статистика диспетчера звонков ATM

ATM-подключения для интерфейса : [009] Адаптер Olicom ATM PCI 155

   Подключение  VPI/VCI   Удаленный адрес/
                          Параметры носителя (измеряются в байт/с)
   In  PMP SVC    0/193   47000580FFE1000000F21A2E180020481A2E180B
                          Tx:UBR,Peak 0,Avg 0,MaxSdu 1516
                          Rx:UBR,Peak 16953936,Avg 16953936,MaxSdu 1516
   Out P-P SVC    0/192   47000580FFE1000000F21A2E180020481A2E180B
                          Tx:UBR,Peak 16953936,Avg 16953936,MaxSdu 1516
                          Rx:UBR,Peak 16953936,Avg 16953936,MaxSdu 1516
   In  PMP SVC    0/191   47000580FFE1000000F21A2E180020481A2E180B
                          Tx:UBR,Peak 0,Avg 0,MaxSdu 1516
                          Rx:UBR,Peak 16953936,Avg 16953936,MaxSdu 1516
   Out P-P SVC    0/190   47000580FFE1000000F21A2E180020481A2E180B
                          Tx:UBR,Peak 16953936,Avg 16953936,MaxSdu 1516
                          Rx:UBR,Peak 16953936,Avg 16953936,MaxSdu 1516
   In  P-P SVC    0/475   47000580FFE1000000F21A2E180000C110081501
                          Tx:UBR,Peak 16953984,Avg 16953984,MaxSdu 9188
                          Rx:UBR,Peak 16953936,Avg 16953936,MaxSdu 9188
   Out PMP SVC    0/194   47000580FFE1000000F21A2E180000C110081501 (0)
                          Tx:UBR,Peak 16953984,Avg 16953984,MaxSdu 9180
                          Rx:UBR,Peak 0,Avg 0,MaxSdu 0
   Out P-P SVC    0/474   4700918100000000613E5BFE010000C110081500
                          Tx:UBR,Peak 16953984,Avg 16953984,MaxSdu 9188
                          Rx:UBR,Peak 16953984,Avg 16953984,MaxSdu 9188
   In  PMP SVC    0/195   47000580FFE1000000F21A2E180000C110081500
                          Tx:UBR,Peak 0,Avg 0,MaxSdu 0
                          Rx:UBR,Peak 16953936,Avg 16953936,MaxSdu 9180

В следующей таблице содержится описание каждого элемента из приведенного вывода команды atmadm /c.

Тип данных | Изображение на экране | Описание
Сведения о подключении | In/Out | Направление вызова. In — вызов сетевого ATM-адаптера другим устройством. Out — вызов другого устройства сетевым ATM-адаптером.
PMP | Вызов из одной точки нескольких точек.
P-P | Прямой вызов.
SVC | Соединение по переключаемому виртуальному каналу.
PVC | Соединение по постоянному виртуальному каналу.
Сведения о VPI/VCI | VPI/VCI | Виртуальный путь и виртуальный канал входящего и исходящего вызовов.
Удаленный адрес/Параметры носителя | 47000580FFE1000000F21A2E180000C110081500 | Адрес NSAP вызывающего (In) или вызываемого (Out) устройства ATM.
Tx Параметр Tx включает три следующих элемента.
  • Указанный или используемый по умолчанию тип скорости передачи (UBR — неуказанная, CBR — постоянная, VBR — переменная или ABR — доступная скорость передачи).
  • Указанная или используемая по умолчанию скорость линии.
  • Указанный размер единицы данных службы (SDU).
Rx Параметр Rx включает три следующих элемента.
  • Указанный или используемый по умолчанию тип скорости передачи (UBR — неуказанная, CBR — постоянная, VBR — переменная или ABR — доступная скорость передачи).
  • Указанная или используемая по умолчанию скорость линии.
  • Указанный размер единицы данных службы (SDU).

Вывод всех зарегистрированных адресов

Чтобы вывести зарегистрированные ATM-адреса точек доступа к сетевым службам (Network Service Access Point, NSAP) для каждого адаптера, установленного на компьютере, введите:

atmadm /a

Сведения, полученные в результате выполнения команды atmadm /a, будут иметь следующий вид:

Статистика диспетчера звонков ATM

Адреса ATM для интерфейса : [009] Адаптер Olicom ATM PCI 155

47000580FFE1000000F21A2E180000C110081500

Вывод статистики

Чтобы вывести статистику для контроля состояния активных ATM-подключений, введите:

atmadm /s

Сведения, полученные в результате выполнения команды atmadm /s, будут иметь следующий вид:

Статистика диспетчера звонков ATM

Статистика диспетчера вызовов ATM для интерфейса : [009] Адаптер Olicom ATM PCI 155

    Текущие активные звонки                        = 4
    Общее число успешных входных звонков           = 1332
    Общее число успешных выходных звонков          = 1297
    Число сбоев входных звонков                    = 1
    Число сбоев выходных звонков                   = 1
    Число звонков, прерванных удаленным абонентом  = 1302
    Число звонков, прерванных локальным абонентом  = 1323
    Послано сигнальных и ILMI-пакетов              = 33655
    Получено сигнальных и ILMI-пакетов             = 34989

В следующей таблице содержится описание каждого элемента из приведенного вывода команды atmadm /s.

Статистика диспетчера вызовов | Описание
Текущие активные звонки | Активные вызовы ATM-адаптера, установленного на компьютере.
Общее число успешных входных звонков | Успешно полученные вызовы в сети с асинхронной передачей.
Общее число успешных выходных звонков | Вызовы с данного компьютера, успешно выполненные на других ATM-устройствах в сети.
Число сбоев входных звонков | Входящие вызовы, которым не удалось подключиться к компьютеру.
Число сбоев выходных звонков | Исходящие вызовы, которым не удалось подключиться к другому устройству в сети.
Число звонков, прерванных удаленным абонентом | Звонки, прерванные удаленным устройством в сети.
Число звонков, прерванных локальным абонентом | Звонки, прерванные компьютером.
Послано сигнальных и ILMI-пакетов | Количество пакетов интегрированного интерфейса локального управления (ILMI), отправленных коммутатору, к которому компьютер пытается подключиться.
Получено сигнальных и ILMI-пакетов | Количество пакетов ILMI, полученных от коммутатора.


Attrib

Позволяет просматривать, устанавливать или снимать атрибуты файла или каталога, такие как «Только чтение», «Архивный», «Системный» и «Скрытый». Выполненная без параметров команда attrib выводит атрибуты всех файлов в текущем каталоге.

Синтаксис

attrib [{+r|-r}] [{+a|-a}] [{+s|-s}] [{+h|-h}] [[диск:][путь] имя_файла] [/s[/d]]

Параметры

+r
Установка атрибута «Только чтение».
-r
Снятие атрибута «Только чтение».
+a
Установка атрибута «Архивный».
-a
Снятие атрибута «Архивный».
+s
Установка атрибута «Системный».
-s
Снятие атрибута «Системный».
+h
Установка атрибута «Скрытый».
-h
Снятие атрибута «Скрытый».
[диск:][путь] имя_файла
Задание местонахождения и имени каталога, файла или набора файлов, атрибуты которых требуется просмотреть или изменить. Для обработки группы файлов допускается применение подстановочных знаков (? и *) в параметре имя_файла.
/s
Выполнение команды attrib и всех параметров командной строки для соответствующих файлов в текущем каталоге и всех его подкаталогах.
/d
Выполнение команды attrib и всех параметров командной строки для каталогов.
/?
Отображение справки в командной строке.

Заметки

  • Работа с группами файлов

    Для просмотра или изменения атрибутов группы файлов можно воспользоваться подстановочными знаками (? и *) в параметре имя_файла. Для изменения атрибутов системных или скрытых файлов вначале требуется снять соответствующие атрибуты.

  • Использование атрибута «Архивный»

    Атрибут «Архивный» (т. е. параметр +a) используется для отметки файлов, измененных со времени последнего резервного копирования. Этот атрибут используется в команде xcopy.

  • Команда attrib с другими параметрами доступна в консоли восстановления.

Примеры

Чтобы вывести атрибуты файла News86, расположенного в текущем каталоге, введите следующую команду:

attrib news86

Чтобы назначить атрибут «Только чтение» файлу Report.txt, введите следующую команду:

attrib +r report.txt

Чтобы снять атрибут "Только чтение" с файлов в каталоге \Public\Jones на диске B и всех его подкаталогах, введите следующую команду:

attrib -r b:\public\jones\*.* /s

Предположим, что необходимо передать коллеге диск, содержащий файлы из текущего каталога диска A, за исключением файлов с расширением .bak. Поскольку для копирования файлов с установленным атрибутом «Архивный» может быть использована команда xcopy, необходимо установить этот атрибут для всех файлов, подлежащих копированию. Вначале установите атрибут «Архивный» для всех файлов на диске A, а затем снимите этот атрибут для файлов с расширением .bak. Например, введите следующую команду:

attrib +a a:*.* attrib -a a:*.bak

Теперь для копирования файлов с диска A на диск B воспользуйтесь командой xcopy. Запущенная с параметром /a команда xcopy скопирует только файлы с установленным атрибутом «Архивный». Например, введите следующую команду:

xcopy a: b: /a

Если требуется снять атрибут Архивный со скопированных файлов, воспользуетесь командой xcopy с параметром /m вместо /a. Например, введите следующую команду:

xcopy a: b: /m


Append

Arp

Служит для вывода и изменения записей кэша протокола ARP, который содержит одну или несколько таблиц, использующихся для хранения IP-адресов и соответствующих им физических адресов Ethernet или Token Ring. Для каждого сетевого адаптера Ethernet или Token Ring, установленного в компьютере, используется отдельная таблица. Запущенная без параметров, команда arp выводит справку.

Синтаксис

arp [-a [инет_адрес] [-N иф_адрес]] [-g [инет_адрес] [-N иф_адрес]] [-d инет_адрес [иф_адрес]] [- инет_адрес е_адрес [иф_адрес]]

Параметры

-a [инет_адрес] [-N иф_адрес]
Вывод таблиц текущего протокола ARP для всех интерфейсов. Чтобы вывести записи ARP для определенного IP-адреса, воспользуйтесь командой arp -a с параметром инет_адрес, где инет_адрес — это IP-адрес. Чтобы вывести таблицы кэша ARP для определенного интерфейса, укажите параметр -N иф_адрес, где иф_адрес — это IP-адрес, назначенный интерфейсу. Параметр -N вводится с учетом регистра.
-g [инет_адрес] [-N иф_адрес]
Совпадает с -a.
-d инет_адрес [иф_адрес]
Удаление записи с определенным IP-адресом, где инет_адрес — это IP-адрес. Чтобы запись таблицы для определенного интерфейса, укажите параметр иф_адрес, где иф_адрес — это IP-адрес, назначенный интерфейсу. Чтобы удалить все записи, введите звездочку (*) вместо параметра инет_адрес.
-s инет_адрес е_адрес [иф_адрес]
Добавление статической записи, которая сопоставляет IP-адрес инет_адрес с физическим адресом е_адрес, в кэш ARP. Чтобы добавить статическую запись кэша ARP в таблицу для определенного интерфейса, укажите параметр иф_адрес, где иф_адрес — это IP-адрес, назначенный интерфейсу.
/?
Отображение справки в командной строке.

Заметки

  • IP-адреса для параметров инет_адрес и иф_адрес записываются в точечно-десятичной нотации.
  • Физический адрес для параметра е_адрес состоит из шести байт, записанных в шестнадцатеричном формате и разделенных дефисами (например 00-AA-00-4F-2A-9C).
  • Записи, добавленные с параметром -s, являются статическими и не удаляются из кэша ARP после истечения периода времени. Записи удаляются, если остановлен и запущен протокол TCP/IP. Чтобы создать постоянные статические записи кэша ARP, введите соответствующие команды arp и воспользуйтесь планировщиком заданий для выполнения этого файла при запуске.
  • Эта команда доступна, только если в свойствах сетевого адаптера в объекте Сетевые подключения в качестве компонента установлен протокол Интернета (TCP/IP).

Примеры

Чтобы вывести таблицы кэша ARP для всех интерфейсов, введите:

arp -a

Чтобы вывести таблицу кэша ARP для интерфейса, которому назначен IP-адрес 10.0.0.99, введите:

arp -a -N 10.0.0.99

Чтобы добавить статическую запись кэша ARP, которая сопоставляет IP-адрес 10.0.0.80 с физическим адресом 00-AA-00-4F-2A-9C, введите:

arp - 10.0.0.80 00-AA-00-4F-2A-9C

Условные обозначения форматирования

Формат | Значение
Курсив | Сведения, вводимые пользователем
Полужирный | Элементы, вводимые без изменений
Многоточие (...) | Параметр может быть введен в командной строке несколько раз
В квадратных скобках ([]) | Необязательные элементы
В фигурых скобках ({}); варианты, разделенные вертикальной линией (|), пример: {even|odd} | Набор вариантов, из которых необходимо выбрать один
Шрифт Courier | Выходные данные программы


Label

Служит для создания, изменения или удаления метки тома (т. е. имени) диска. Команда label без параметров используется для изменения текущей метки тома или ее удаления.

Синтаксис

label [диск:][метка]

label [/MP][том][метка]

Параметры

диск:
Буква диска (за которой следует двоеточие), имя которого требуется изменить.
метка
Имя тома.
/MP
Рассмотрение тома как точки подключения или имени тома.
том
Буква диска (за которой следует двоеточие), точка подключения или имя тома. Если задано имя тома, параметр /MP указывать не нужно..
/?
Отображение справки в командной строке.

Заметки

  • В Windows метка тома выводится в как часть сведений о каталоге. Если существует серийный номер диска, он также отображается в Windows.
  • Сообщения команды Label

    Если при вызове команды label метка не задана, на экран будет выведено сообщение в следующем формате:

    Том в устройстве A имеет метку xxxxxxxxxxx
    Серийный номер тома: xxxx-xxxx
    Метка тома (11 символов, ENTER - метка не нужна):

    Сообщение «Серийный номер тома» выводится, только если диск имеет серийный номер.

    После сообщения можно ввести новую метку тома или нажать клавишу ENTER для удаления текущей метки тома. Если диск имел метку тома и была нажата клавиша ENTER для его удаления, будет выведен следующий запрос на подтверждение:

    Удалить текущую метку тома [Y(да)/N(нет)]?

    Для удаления метки следует нажать Y, для отказа от удаления — N.
  • Ограничения на имена меток томов

    Метка тома может содержать до 32 знаков для файловой системы NTFS или до 11 знаков для файловой системы FAT и может содержать пробелы (но не знаки табуляции).

    Метки томов с файловой системой FAT не могут содержать следующие символы:

    * ? / \ | . , ; : + = [ ] < > "

    Эти ограничения не применяются к томам NTFS.

    На томах FAT метки хранятся в верхнем регистре независимо от регистра букв веденной строки. Метка тома файловой системы NTFS будет выводиться так, как она была введена.

Примеры

Чтобы присвоить диску A метку, введите:

label a:метка диска


Loadfix

Служит для загрузки программы выше первых 64 Кбайт обычной памяти и запуска этой программы.

Синтаксис

loadfix[диск:][путь] имя_файла

Параметры

[диск:][путь]
Диск и каталог, в котором расположена программа.
имя_файла
Имя программы.
/?
Отображение справки в командной строке.

Заметки

  • Чтобы использовать команду loadfix, ее следует включить в начало командной строки вызова программы.
  • Когда вся программа или ее часть загружена в первые 46 КБ обычной памяти и ее выполнение невозможно, некоторые программы выводят следующее сообщение:
    Packed file corrupt

    Как правило, эта ошибка возникает, когда драйверы устройств загружаются в верхнюю область памяти, оставляя первые 64Кб обычной памяти для использования программами. Если данное сообщение появляется на экране, следует использовать команду loadfix для обеспечения загрузки программы выше первых 64Кб обычной виртуальной памяти.

Примеры

Чтобы загрузить программу Myapp.exe (из папки Apps на диске C) с использованием параметра командной строки /c (например, чтобы загрузить программу в символьном режиме), введите:

loadfix c:\apps\myapp.exe /c

Эту команду также можно включить в пакетную программу.


Loadhigh

Служит для загрузки программы в верхнюю область памяти. Это позволяет оставить больше свободной обычной памяти для других программ. Для указания программы, которую требуется загрузить в верхнюю область памяти, используйте файл системный_корневой_каталог\System32\Config.nt или эквивалентный файл запуска.

Синтаксис

loadhigh [диск:][путь] имя_файла [параметры]

Параметры

[диск:][путь] имя_файла
Местоположение и имя программы, которая будет загружена. Параметр имя_файла является обязательным.
параметры
Параметры командной строки, используемые программой.
/?
Отображение справки в командной строке.

Заметки

  • Для использования команды loadhigh в файл Config.nt или другой эквивалентный файл должна быть включена команда dos=umb. Чтобы получить дополнительные сведения о команде dos=umb, выберите dos из списка в ссылке «См. также».
  • Для загрузки программ в верхнюю область памяти вначале необходимо установить диспетчер расширенной памяти Himem.sys. Для этого используется команда device в файле Config.nt или эквивалентном загрузочном файле.
  • Если для загрузки программы используется команда loadhigh, система Windows XP попытается загрузить ее в верхнюю область памяти. Если в верхней области памяти недостаточно места, программа будет загружена в обычную память, но никаких сообщений об этом не выводится.
  • Наиболее подходящим вариантом использования команды loadhigh является ее включение в файл Autoexec.nt или эквивалентный загрузочный файл.

Примеры

Для загрузки драйвера в верхнюю область памяти в файл Autoexec.nt или эквивалентный загрузочный файл следует включить следующую строку:

lh %systemroot%\system32\dosx


Lodctr

Служит для регистрации имен новых счетчиков производительности и текста объяснения для службы или драйвера устройства, а также для сохранения и восстановления значений счетчика и текста объяснения.

Синтаксис

lodctr [\\имя_компьютера] имя_файла [/s:имя_файла] [/r:имя_файла]

Параметры

[\\имя_компьютера] имя_файла
Регистрация параметров имени счетчика производительности и текста объяснения, содержащихся в файле инициализации имя_файла. Если не указано имя_компьютерапо умолчанию командой lodctr будет использоваться локальный компьютер.
/s:имя_файла
Сохранение параметров реестра счетчика производительности и объясняющего текста в файле имя_файла.
/r:имя_файла
Восстановление параметров реестра счетчика производительности и объясняющего текста из файла имя_файла.

Внимание!

  • Если используется команда lodctr /r, параметры реестра счетчика производительности и объясняющий текст будут заменены данными из указанного файла.
/?
Отображение справки в командной строке.

Заметки

  • Если аргументы параметров команды содержат пробелы, их следует заключать в кавычки (например "имя компьютера").

Примеры

Чтобы сохранить текущие параметры реестра производительности и текст объяснения счетчика в файл perf backup1.txt, введите:

lodctr /s:"perf backup1.txt"


Lpg

Lpq

Служит для отображения состояния очереди печати на компьютере, использующем программное обеспечение сервера печати Line Printer Daemon (LPD). При вызове команды lpq без параметров в командной строке отображается справка по команде lpq.

Синтаксис

lpq -S имя_сервера -P имя_принтера [-l]

Параметры

-S имя_сервера
Обязательный параметр. Имя компьютера, на котором находится очередь печати, состояние которой требуется просмотреть.
-P имя_принтера
Обязательный параметр. Имя принтера, состояние очереди печати которого требуется просмотреть.
-l
Отображение сведений о состоянии очереди печати.
/?
Отображение справки в командной строке.

Условные обозначения форматирования

Формат | Значение
Курсив | Сведения, вводимые пользователем
Полужирный | Элементы, вводимые без изменений
Многоточие (...) | Параметр может быть введен в командной строке несколько раз
В квадратных скобках ([]) | Необязательные элементы
В фигурых скобках ({}); варианты, разделенные вертикальной линией (|), пример: {even|odd} | Набор вариантов, из которых необходимо выбрать один
Шрифт Courier | Выходные данные программы


Lpr

Служит для отправки файла на компьютер, использующий программное обеспечение сервера печати Line Printer Daemon (LPD), для подготовки к печати. При вызове команды lpr без параметров в командной строке отображается справка по команде lpr.

Синтаксис

lpr [-S сервера] -P имя_принтера [-C титульный_лист] [-J имя_задания] [{-o | -o l}] [-d] [-x] имя_файла

Параметры

-S сервера
Имя или IP-адрес компьютера, к которому подключен принтер, на котором требуется напечатать файл. Этот параметр не следует задавать, если принтер подключен к локальному компьютеру.
-P имя_принтера
Обязательный параметр. Имя принтера, на котором требуется напечатать файл.
-C титульный_лист
Текст для печати на титульном листе задания печати. Если этот параметр не задан, на титульном листе будет напечатано имя компьютера, с которого поступило задание печати.
-J имя_задания
Имя задания, которое будет напечатано на титульной странице. Если этот параметр не задан, на титульной странице будет напечатано имя файла.
{-o | -o l}
Тип файла, который требуется напечатать. Параметр -o задает печать текстового файла. Параметр -o l задает печать двоичного файла (например PostScript).
-d
Отправка файла данных перед управляющим файлом. Этот параметр следует использовать, если сначала требуется отправить файл данных. Дополнительные сведения можно найти в документации по принтеру.
-x
Включение совместимости команды lpr с операционной системой Sun Microsystems, выпуски которой до версии 4.1.4_u1 включительно назывались SunOS.
имя_файла
Обязательный параметр. Имя файла, который требуется напечатать.
/?
Отображение справки в командной строке.

Заметки

  • Чтобы найти имя принтера, откройте папку «Принтеры и факсы». Чтобы открыть компонент «Принтеры и факсы», нажмите кнопку Пуск, выберите команду Панель управления, щелкните категорию Принтеры и другое оборудование, затем щелкните значок Принтеры и факсы.

Условные обозначения форматирования

Формат | Значение
Курсив | Сведения, вводимые пользователем
Полужирный | Элементы, вводимые без изменений
Многоточие (...) | Параметр может быть введен в командной строке несколько раз
В квадратных скобках ([]) | Необязательные элементы
В фигурых скобках ({}); варианты, разделенные вертикальной линией (|), пример: {even|odd} | Набор вариантов, из которых необходимо выбрать один
Шрифт Courier | Выходные данные программы


Ver

Отображение номера версии Windows XP.

Синтаксис

ver

Параметры

/?
Отображает справку в командной строке.


Vol

Отображает метку тома диска и серийный номер, если они существуют. Серийный номер выводится для дисков, отформатированных в версии MS-DOS версии 4.0 и более поздних.

Синтаксис

vol [диск:]

Параметры

диск:
Задает имя дисковода, содержащего диск, для которого будет выведена метка тома и серийный номер.
/?
Отображает справку в командной строке.


Vssadmin

Отображает в окне командной строки архивы снимков состояния томов и все установленные системы записи снимков состояния и доступа к ним.

Синтаксис

Vssadmin list {shadows [/set= [код_GUID_набора_снимков_состояния]] | writers | providers}

Параметры

list shadows [/set= [код_GUID_набора_снимков_состояния]]
Отображает все снимки состояния системы, объединенные кодом GUID в набор снимков состояния (группа снимков состояния, созданных в одно время).
list writers
Отображает имя, код GUID, код (ID) экземпляра и статус всех установленных систем записи снимков состояния.
list providers
Отображает имя, код GUID, и версии всех установленных систем доступа к снимкам состояния.
/?
Отображает справку в командной строке.

Примеры

Чтобы вывести на экран все установленные системы доступа к снимкам состояния тома, введите следующую команду:

vssadmin list providers


Winnt

Выполняет установку или обновление до Windows XP. При совместимости оборудования с операционной системой Windows XP, можно выполнить команду winnt из командной строки Windows 3x или в сеансе MS-DOS.

Синтаксис

winnt [/s:источник] [/t:временный_диск] [/u:файл_ответов][/udf:код [,файл_UDB]] [/r:папка][/rx:папка][/e:команда][/a]

Параметры

/s:источник
Задает местонахождение источника устанавливаемых файлов Windows XP. Расположение должно быть задано полным путем в форме x:\[путь] или \\сервер\общая_папка[\путь].
/t:временный_диск
Указывает размещение временных файлов на указанном диске и установку Windows XP на этом диске. Если местоположение не указано, программа установки попытается сама определить нужный диск.
/u:файл_ответов
Выполняет установку без вмешательства пользователя с помощью файла ответов. Файл ответов содержит ответы на все или часть вопросов, задаваемых конечному пользователю во время установки. Параметр /u нужно использовать совместно с параметром /s.
/udf:код [,файл_UDB]
Показывает идентификатор (код), который программа установки использует для указания способа изменения файла ответов файлом базы данных уникальности (Uniqueness Database, UDB) (см. описание ключа /u). Файл UDB изменяет значения в файле ответов, а идентификатор определяет используемые в файле UDB значения. Если файл_UDB не указан, программа настройки предлагает пользователю вставить диск, содержащий файл $Unique$.udb.
/r:папка
Указывает необязательную папку для установки. Папка остается после завершения установки.
/rx:папка
Указывает необязательную папку для копирования. Папка удаляется после завершения установки.
/e:команда
Указывает программе установки выполнить заданную команду перед завершающей фазой установки.
/a
Включает специальные возможности.
/?
Отображает справку в командной строке.


Использование средств WMIC

Программа WMIC представляет собой командную строку и интерфейс написания сценариев, которые упрощают использование инструментария управления Windows (WMI) и систем, управляемых с помощью WMI.

Программа WMIC основана на псевдонимах. С помощью псевдонимов можно получать доступ к основным данным инструментария WMI, не имея представления о его устройстве. Данные WMI и возможности WMI доступны через инструментарий управления без псевдонимов.

Вывести список доступных псевдонимов можно использованием параметра справки WMIC /?. Программа WMIC содержит встроенную справочную систему. Использование параметра /? возможно в любое время и на любой стадии для обнаружения дополнительных параметров текущего контекста. Параметр /? отображает доступные псевдонимы, команды и глобальные переключатели (т. е. переключатели, применяемые ко всей программе WMIC). Чтобы вывести на экран действия и переключали, доступные псевдониму, введите имя псевдоним и параметр /?. Для представления параметров, доступных определенному действию, введите имя псевдонима, действие и затем параметр /?.

Например, процессы, выполняющиеся в системе в настоящий момент, доступны в псевдониме PROCESS. Для просмотра всех процессов, выполняющихся на текущий момент на компьютере. введите PROCESS в служебную программу WMIC. Чтобы отобразить определенный процесс введите команду, подобную PROCESS WHERE (Description="explorer.exe"). Получить конкретные свойства процессов можно вводом такой команды как PROCESS GET Name, Handle, PageFaults.

Имеется возможность использовать те же параметры без применения псевдонимов с помощью команды CLASS Например, CLASS Win32_Process GET Name, Handle, PageFaults. Однако, необходимо определить имя класса из других источников. Условию псевдонима Where эквивалентно использование команды PATH Win32_Process.Description="explorer.exe".

Параметр | Результат
/? | Вывод справки
CLASS | Явный ввод имени класса схемы WMI без использования применяемого по умолчанию псевдонима WMIC
PATH | Прямой доступ к экземплярам схемы WMI без использования применяемого по умолчанию псевдонима WMIC
CONTEXT | Отображение текущих значений всех глобальных переключателей
QUIT | Выход из программы WMIC
EXIT | Выход из программы WMIC

Вызов WMIC

WMIC можно использовать как в интерактивном, так и в пакетном режиме. Интерактивный режим удобен, когда оператор вводит последовательность команд WMIC, работая непосредственно за компьютером. Пакетный режим предназначен для запуска WMIC из командного файла или применяется, когда требуется выполнить одну команду.

Интерактивный режим

Чтобы запустить WMIC в интерактивном режиме, в окне «Пуск» - «Выполнить» или в командной строке введите:

wmic <CR>

Появится приглашение:

wmic:root\cli>

(root\cli — роль WMIC, используемая по умолчанию).

В ответ на приглашение можно ввести псевдоним, команду или переключатель, а также ключ /? для вывода справочных сведений.

Для выхода из интерактивного режима можно использовать команду Exit или Quit.

Пакетный режим

Чтобы получить сведения об использовании WMIC в пакетном режиме, введите:

wmic /?

Ключ /? обеспечивает вывод справки (при этом управление будет возвращено в командную строку операционной системы). В пакетном режиме, также как и в интерактивном, можно использовать псевдонимы, переключатели и команды.


W32tm

Используется для определения причины неполадок, связанных со службой времени Windows

Синтаксис

  • {/config [/computer:имя_компьютера] [ [/update] [/manualpeerlist:список_компьютеров] ] [/syncfromflags:список_флажков] ]|/monitor|/ntte|/ntpte|/register|/resync [{:имя_компьютера] [/nowait]|[/rediscover}]|/tz|/unregister}

    Параметры

    /config [/computer:имя_компьютера] [ [/update] [/manualpeerlist:список_компьютеров] ] [/syncfromflags:список_флажков]
    Выполняет согласование настроек времени на локальном и конечном компьютере. Одинаковое время синхронизации можно задать с помощью ключа /manualpeerlist. Изменения конфигурации не учитываются, пока не перезапустится служба времени Windows или не будет использован ключ /update. Ключ /syncfromflags применяется, чтобы задать типы источников синхронизации, и может быть установлен либо MANUAL для использования списка узлов, заданного вручную, или DOMHIER для синхронизации с контроллера домена.
    /monitor
    Осуществляет наблюдение за конечным компьютером или списком компьютеров.
    /ntte
    Преобразует системное время NT в читаемый формат.
    /ntpte
    Преобразует время NTP в читаемый формат.
    /register
    Регистрирует запуск службы и добавляет стандартную конфигурацию в реестр.
    /resync [{:имя_компьютера] [/nowait]|[/rediscover}]
    Ресинхронизирует часы по мере возможности, не обращая внимания статистику накопленных ошибок. Если не указан компьютер, ресинхронизирован будет локальный компьютер. Ресинхронизация не выполняется без использования ключа /nowait. Текущие источники времени используются до тех пор, пока не введен ключ /rediscover, который выполняет принудительное повторное обнаружение сетевых ресурсов перед ресинхронизацией.
    /tz
    Отображает текущую настройку часового пояса
    /unregister
    Отменяет регистрацию службы и удаляет сведения о конфигурации из реестра.
    /?
    Отображает справку в командной строке.

    Примечания

    • Средство предназначено для системных администраторов для определения причин неполадок, связанных со временем системы Windows.

      Для получения дополнительных сведений см. раздел net time.

    • Чтобы служба времени Windows использовала изменения, выполненные с помощью команды W32tm, необходимо оповестить службу. Чтобы оповестить службу времени Windows, в командной строке введите: w32tm /config /update.

    Примеры

    Чтобы отобразить текущую настройку часового пояса, введите команду:

    w32tm /tz

    Условные обозначения форматирования

    Формат | Значение
    Курсив | Сведения, вводимые пользователем
    Полужирный | Элементы, вводимые без изменений
    Многоточие (...) | Параметр может быть введен в командной строке несколько раз
    В квадратных скобках ([]) | Необязательные элементы
    В фигурых скобках ({}); варианты, разделенные вертикальной линией (|), пример: {even|odd} | Набор вариантов, из которых необходимо выбрать один
    Шрифт Courier | Выходные данные программы


If

Обработка условий в пакетных программах.

Синтаксис

if [not] errorlevel число команда [else выражение]

if [not] строка1==строка2 команда [else выражение]

if [not] exist имя_файла команда [else выражение]

Если расширения командного процессора разрешены, следует использовать следующий синтаксис:

if [/i] строка1 оп_сравнения строка2 команда [else выражение]

if cmdextversion число команда [else выражение]

if defined переменная команда [else выражение]

Параметры

not
Задает выполнение команды только в случае невыполнения условия.
errorlevel число
Условие выполняется, если предыдущая команда, обработанная интерпретатором команд Cmd.exe, завершилась с кодом, равным или большим числа.
команда
Команда, которая должна быть обработана в случае выполнения условия.
строка1==строка2
Условие выполняется, если строки строка1 и строка2 совпадают. Строки могут быть заданы явно или могут быть пакетными переменными (например, %1). Явно заданные строки нет необходимости заключать в кавычки.
exist имя_файла
Условие выполняется, если существует файл с именем имя_файла.
оп_сравнения
Трехзначный оператор сравнения. В следующей таблице перечислены допустимые значения оп_сравнения.
Оператор | Описание
EQU | равно
NEQ | не равно
LSS | меньше
LEQ | меньше или равно
GTR | больше
GEQ | больше или равно
/i
Сравнение строк без учета регистра знаков. Параметр /i можно использовать в конструкции string1==string2 команды if. Эти сравнения являются общими. Если и строка1, и строка2 состоят из цифр, строки преобразовываются в числа и выполняется сравнение чисел.
cmdextversion число
Условие выполняется, только если номер внутренней версии, связанный с расширениями командного процессора Cmd.exe, равен или больше числа. первая версия имела номер 1. Номер версии увеличивается на 1 при внесении в расширения командного процессора значительных изменений. Условие с cmdextversion не выполняется, если расширения командного процессора запрещены (по умолчанию они разрешены).
defined переменная
Условие выполняется, если переменная определена.
выражение
Команда и все ее параметры для обработке в командной строке при выполнении оператора else.
/?
Отображение справки в командной строке.

Заметки

  • Если условие, заданное в команде if, выполняется, будет выполнена команда, следующая за условием. Если условие не выполняется, команда, заданная в операторе if, пропускается, а управление переходит к команде оператора else, если она задана.
  • Когда программа завершается, она возвращает код завершения. С помощью параметра errorlevel коды завершения можно использовать в качестве условий.
  • Использование команды defined переменная

    При использовании команды defined переменная добавляются следующие три переменные: %errorlevel%, %cmdcmdline% и %cmdextversion%.

    %errorlevel% замещается строковым представлением текущего значения errorlevel, если только уже не существует переменная среды с именем ERRORLEVEL. В этом случае будет использовано ее значение. В следующем примере показано использование значения errorlevel после выполнения пакетной программы:

    goto answer%errorlevel%
    :answer0
    echo Код возврата программы равен 0
    :answer1
    echo Код возврата программы равен 1
    goto end
    :end
    echo Готово!

    Операторы сравнения оп_сравнения также можно использовать следующим образом:

    if %errorlevel% LEQ 1 goto okay

    %cmdcmdline% замещается исходной командной строкой, переданной Cmd.exe, до ее обработки в Cmd.exe, если только уже не существует переменная среды с именем cmdcmdline. В этом случае будет использовано значение cmdcmdline.

    %cmdextversion% замещается строковым представлением текущего значения cmdextversion, если только уже не существует переменная среды с именем CMDEXTVERSION. В этом случае будет использовано ее значение.

  • Использование оператора else

    Оператор else должен размещаться в той же строке, что и команда if. Пример:

    IF EXIST имя_файла. (
del имя_файла.
) ELSE (
echo имя_файла. отсутствует.
)

    Приведенный ниже пример не будет работать, поскольку команда del должна заканчиваться новой строкой:

    IF EXIST имя_файла. del имя_файла. ELSE echo имя_файла. отсутствует

    Приведенный ниже пример не будет работать, поскольку команда else должна находиться в той же строке, что и команда if:

    IF EXIST имя_файла. del имя_файла.
ELSE echo имя_файла. отсутствует

    Если необходимо разместить всю инструкцию в одной строке, можно использовать следующую правильную форму исходной инструкции:

    IF EXIST имя_файла. (del имя_файла.) ELSE echo имя_файла. отсутствует

Примеры

Если файл Product.dat не удается найти, появится следующее сообщение:

if not exist product.dat echo Не найден файл данных

Если в приведенном ниже примере при форматировании диска в дисководе A возникнет ошибка, будет выведено сообщение об ошибке:

:begin
@echo off
format a: /s
if not errorlevel 1 goto end
echo Ошибка при форматировании.
:end
echo Конец пакетной программы.

Если ошибка не возникнет, сообщение об ошибке выведено не будет.

Команда if не может быть использована непосредственно для проверки существования каталога, но в каждом каталоге существует устройство (NUL). Следовательно, существование каталога может быть проверено, как показано ниже. В следующем примере проверяется наличие каталога:

if exist c:mydir\nul goto process


Install

Служит для загрузки резидентных программ в память. Для указания программы, которую требуется установить, используйте файл системный_корневой_каталог\System32\Config.nt или эквивалентный файл запуска.

Синтаксис

install=[диск:][путь] имя_файла [параметры_команды]

Параметры

[диск:][путь] имя_файла
Имя и местоположение файла резидентной программы для загрузки.
параметры_команды
Параметры, передаваемые программе имя_файла.
/?
Отображение справки в командной строке.

Заметки

  • Команда install следует использовать для загрузки в память резидентной программы непосредственно перед вызовом приложений, для работы которых она необходима. Если резидентная программа загружается в память из файла Autoexec.nt, она будет загружаться при запуске каждого экземпляра командного интерпретатора, что приведет к лишнему расходу памяти.
  • Команда install не может применяться для загрузки программ, использующих переменные окружения, клавиши быстрого вызова или требуют наличия командного интерпретатора Cmd.exe для обработки критических ошибок.

Примеры

Для загрузки программы в память из файла Config.nt используется следующая команда:

install


Ipseccmd

Служит для настройки политик IPSec (Internet Protocol Security) в службе каталогов либо в локальном или удаленном реестре. Ipseccmd является альтернативой для командной строки оснастке консоли MMC «Политики безопасности IP». Ipseccmd имеет три режима: динамический, статический и режим запроса.

Динамический режим ipseccmd

Динамический режим Ipseccmd служит для добавления анонимных правил в имеющуюся политику безопасности IPSec путем добавления их в базу данных политик безопасности IPSec. Добавленные правила будут присутствовать даже после перезапуска службы «Службы IPSEC». Преимуществом использования динамического режима является сосуществование добавляемых правил с политикой IPSec домена. По умолчанию используется динамический режим Ipseccmd.

Синтаксис

  • Для добавления правила используется следующий синтаксис:

    • ipseccmd [\\имя_компьютера] -f список_фильтров [-n список_политик_согласования] [-t адрес_туннеля] [-a список_способов_пров_подлинности] [-1s список_методов_безопасности] [-1k параметры_смены_ключа] [-1p] [-1f список_фильтров_осн_режима] [-1e срок_действия] [-soft] [-confirm] [{-dialup | -lan}]

  • Для удаления всех динамических политик используется следующий синтаксис:

    • ipseccmd -u

Параметры

\\имя_компьютера
Имя локального или удаленного компьютера, на который требуется добавить правило.
-f список_фильтров
Необходим в первом случае. Одно или несколько определений фильтра, разделенных пробелами, для быстрого режима сопоставления безопасности. Каждое определение фильтра включает набор сетевого трафика, к которому относится это правило.
-n список_политик_согласования
Один или несколько методов безопасности, разделенных пробелами, для защиты трафика, определенного списком фильтров.
-t адрес_туннеля
Конечная точка туннеля для режима туннеля, заданная как IP-адрес или имя в системе DNS.
-a список_способов_пров_подлинности
Один или несколько способов проверки подлинности, разделенных пробелами.
-1s список_методов_безопасности
Один или несколько методов обеспечения безопасности при обмене ключами, разделенных пробелами.
-1k параметры_смены_ключа
Параметры смены ключа в основном режиме сопоставления безопасности.
-1p
Включение основного ключа безопасной пересылки.
-1f список_фильтров_осн_режима
Одно или несколько определений фильтров для сопоставлений безопасности основного режима, разделенных пробелами.
-1e срок_действия
Срок действия мягких сопоставлений безопасности в секундах.
-soft
Включение мягких сопоставлений безопасности.
-confirm
Запрос подтверждения перед добавлением правила или политики.
{-dialup | -lan}
Применение правила только к подключениям удаленного доступа и подключениям через телефон либо к подключениям через локальную сеть.
-u
Необходим во втором случае. Удаление всех динамических правил.
/?
Отображение справки в командной строке.

Заметки

  • Команду Ipseccmd нельзя использовать для настройки правил на компьютерах, работающих под управлением Windows 2000.
  • Если не задан параметр имя_компьютера, правило будет применено к локальному компьютеру.
  • Если используется параметр имя_компьютера, его необходимо задавать перед всеми остальными параметрами, а также обладать правами администратора на компьютере, в политику которого требуется добавить правило.
  • Для параметра -f определение фильтра представляет собой один или несколько фильтров, разделенных пробелами и представленных в следующем формате:

    • исходный_адрес/исходная_маска:исходный_порт=конечный_адрес/конечная_маска:конечный_порт:протокол

    • Значения исходная_маска, исходный_порт, конечная_маска и конечный_порт являются необязательными. Если они не указаны, в фильтре будет использована маска 255.255.255.255 и все порты.
    • Значение протокол является необязательным. Если оно не указано, в фильтре будут использованы все протоколы. Если протокол задан, необходимо также задать порт либо поставить перед протоколом два двоеточия (::). (См. первый пример для динамического режима.) Протокол должен быть последним элементом фильтра. Можно использовать следующие обозначения протоколов: ICMP, UDP, RAW или TCP.
    • Заменяя знак «равно» (=) знаком «плюс» (+), можно создавать отраженные фильтры.
    • Значения исходный_адрес/исходная_маска или конечный_адрес/конечная_маска можно заменять значениями из следующей таблицы.
      • Значение | Описание
0 | Локальный адрес или локальные адреса
* | Любой адрес
DNS-имя | DNS-имя домена. Если DNS-имени сопоставлено несколько адресов, оно не учитывается.
Код GUID | Глобальный уникальный идентификатор (GUID) интерфейса локальной сети в форме {12345678-1234-1234-1234-123456789ABC}. Задание кода GUID не поддерживается при использовании параметра -n в статическом режиме.
    • Задав определение фильтра default, можно включить правило отклика по умолчанию.
    • Разрешающий фильтр можно задать, заключив определение фильтра в скобки. Блокирующий фильтр можно задать, заключив определение фильтра в квадратные скобки ([ ]).
    • Если для адресов Интернета используются маски подсети на основе классов (маски подсети, определенные границами октетов), для задания масок подсети можно использовать подстановочные знаки. Например, 10.*.*.* является тем же, что и 10.0.0.0/255.0.0.0, а 10.92.*.* — тем же, что и 10.92.0.0/255.255.0.0.

    Примеры фильтров

    Чтобы создать отраженные фильтры для фильтрации TCP-трафика между Computer1 и Computer2, введите:

    Computer1+Computer2::TCP

    Чтобы создать фильтр для всего TCP-трафика из подсети 172.31.0.0/255.255.0.0, порт 80, в подсеть 10.0.0.0/255.0.0.0, порт 80, введите:

    172.31.0.0/255.255.0.0:80=10.0.0.0/255.0.0.0:80:TCP

    Чтобы создать отраженный фильтр для передачи трафика между локальным IP-адресом и IP-адресом 10.2.1.1, введите:

    (0+10.2.1.1)

  • Для параметра -n одна или несколько политик согласования разделяются пробелами и задаются в одной из следующих форм:
    • esp[алг_шифрования,алг_пров_подлинности]смена_ключа PFS[группа]
    • ah[алг_хеширования]
    • ah[алг_хеширования]+esp[алг_шифрования,алг_пров_подлинности]

    где алг_шифрования может иметь значение none, des или 3des, алг_пров_подлинности может иметь значение none, md5 или sha, а алг_хеширования может иметь значение md5 или sha.

    • Конфигурация esp[none,none] не поддерживается.
    • Параметр sha соответствует алгоритму хеширования SHA1.
    • Параметр смена_ключа необязателен, и он задает количество килобайт (на что указывает буква K после числа) или количество секунд (на что указывает буква S после числа), после которых происходит смена ключа сопоставления безопасности в быстром режиме. Чтобы указать оба параметра смены ключа, разделите два числа косой чертой (/). Например, чтобы ключ в быстром режиме сопоставления безопасности сменялся через каждый час и через каждые 5 мегабайт данных, введите:

      • 3600S/5000K

    • Параметр PFS является необязательным, он включает сеансовые циклы безопасной пересылки. По умолчанию сеансовые циклы безопасной пересылки отключены
    • Параметр группа является необязательным, он включает группу Диффи-Хелмана для сеансовых циклов безопасной пересылки. Для низкой группы (1) Диффи-Хелмана следует задавать значение PFS1 или P1. Для средней группы (2) Диффи-Хелмана следует задавать значение PFS2 или P2. По умолчанию значение группы сеансовых циклов безопасной пересылки берется из текущих параметров основного режима.
    • Если не заданы политики согласования, по умолчанию используются следующие политики согласования:
      • esp[3des,sha]
      • esp[3des,md5]
      • esp[des,sha]
      • esp[des,md5]
  • Если параметр -t не задан, используется режим транспорта IPSec.
  • Для параметра -a один или несколько способом проверки подлинности разделяются пробелами и задаются в одной из следующих форм:
    • preshare:"строка_общего_ключа"
    • kerberos
    • cert:"центр_серт"

    Параметр строка_общего_ключа задает строку знаков общего ключа. Параметр центр_серт задает отличительное имя сертификата, отображаемое в окне оснастки «Политики безопасности IP», когда этот сертификат выбран в качестве способа проверки подлинности для правила. Регистр в значениях параметров строка_общего_ключа и центр_серт имеет значение. Название способа можно сокращать, указывая только первую букву: p, k или c. Если параметр -a не задан, по умолчанию используется способ проверки подлинности Kerberos.

  • Для параметра -1s один или несколько методов безопасности смены ключа разделяются пробелами и задаются в следующем формате:

    • алг_шифрования-алг_хеширования-номер_группы

    где алг_шифрования может иметь значение des или 3des, алг_хеширования может иметь значение md5 или sha, а номер_группы может иметь значение 1 для низкой (1) группы Диффи-Хелмана или 2 для средней (2) группы Диффи-Хелмана. Если параметр -1s не задан, по умолчанию используются методы безопасности смены ключа 3des-sha-2, 3des-md5-2, des-sha-1 и des-md5-1.

  • Для параметра -1k можно задать количество сопоставлений безопасности быстрого режима (на что указывает буква Q после числа) или количество секунд (на что указывает буква S после числа), после которых происходит смена ключа сопоставления безопасности в основном режиме. Чтобы указать оба параметра смены ключа, разделите два числа косой чертой (/). Например, чтобы ключ в основном режиме сопоставления безопасности сменялся через каждые 10 сопоставлений безопасности быстрого режима и через каждый час, введите:

    • 10Q/3600S

    Если параметр -1k не задан, по умолчанию смена ключа для основного режима происходит через неограниченное количество сопоставлений безопасности быстрого режима и через каждые 480 минут.

  • По умолчанию основной ключ безопасной пересылки отключен.
  • Для параметра -1f синтаксис задания определения фильтра основного режима тот же, что и для параметра -f, за исключением того, что нельзя задавать разрешающие фильтры, блокирующие фильтры, порты и протоколы. Если параметр -1f не задан, фильтры основного режима создаются автоматически на основе фильтров быстрого режима.
  • Если параметр -1e не задан, срок действия для мягких сопоставлений безопасности равен 300 секунд. Однако, если не задан параметр -soft, мягкие сопоставления безопасности отключены.
  • Подтверждение доступно только в динамическом режиме.
  • Если не задан ни параметр -dialup, ни параметр -lan, правило будет применено ко всем адаптерам.

Примеры

Чтобы создать правило, использующее заголовок проверки подлинности (AH) с хешированием MD5 для всего входящего и исходящего трафика локального компьютера, введите:

ipseccmd -f 0+* -n ah[md5]

Чтобы создать правило туннеля для трафика с адресов 10.2.1.1 и 10.2.1.13 с использованием конечной точки туннеля 10.2.1.13, режимом туннеля AH с использованием алгоритма хеширования SHA1 и включенным основным ключом безопасной пересылки, а также с выдачей запроса перед созданием правила, введите:

ipseccmd -f 10.2.1.1=10.2.1.13 -t 10.2.1.13 -n ah[sha] -1p -c

Чтобы создать правило на компьютере corpsrv1 для всего трафика между компьютерами corpsrv1 и corpsrv2 с использованием сочетания AH и ESP (Encapsulating Security Payload) и проверкой подлинности с помощью общего ключа, введите:

ipseccmd \\corpsrv1 -f corpsrv2+corpsrv1 -n ah[md5]+esp[des,sha] -a p:"corpauth"

Статический режим ipseccmd

Статический режим Ipseccmd служит для создания именованных политик и именованных правил. Используя статический режим, также можно изменять имеющиеся политики и правила, если они созданы с помощью Ipseccmd. Синтаксис статического режима объединяет синтаксис динамического режима с параметрами, позволяющими ему работать на уровне политики.

Синтаксис

ipseccmd параметры_динамического_режима -w тип[:расположение] -p имя_политики[:интервал_опроса] -r имя_правила [{-x | -y}] [-o]

Параметры

параметры_динамического_режима
Обязательный параметр. Задает набор описанных ранее параметров динамического режима для правила IPSec.
-w тип[:расположение]
Обязательный параметр. Задает запись политик и правил в локальный реестр, реестр удаленного компьютера или домен Active Directory.
-p имя_политики[:интервал_опроса]
Обязательный параметр. Задает имя политики и интервал ее обновления в минутах. Если значение имя_политики содержит пробелы, его следует заключать в кавычки (т. е. "имя_политики").
-r имя_правила
Обязательный параметр. Задает имя правила. Если значение имя_правила содержит пробелы, его следует заключать в кавычки (т. е. "имя_правила").
[{-x | -y}]
Назначение политики локального реестра. Параметр -x задает назначение политики локального реестра. Параметр -у отменяет назначение политики локального реестра.
-o
Удаление правила или политики.
/?
Отображение справки в командной строке.

Заметки

  • Для параметра -w атрибут тип должен иметь значение reg для выбора реестра локального или удаленного компьютера либо значение ds для выбора Active Directory.
    • Если атрибут тип имеет значение reg, но значение расположение не задано, правило будет создано в реестре локального компьютера.
    • Если атрибут тип имеет значение reg и в качестве атрибута расположение задано имя удаленного компьютера, правило будет создано в реестре этого удаленного компьютера.
    • Если атрибут тип имеет значение ds, но значение расположение не задано, правило будет создано в домене Active Directory, в который входит локальный компьютер.
    • Если атрибут тип имеет значение ds и в качестве атрибута расположение задан домен Active Directory, правило будет создано в этом домене.
  • Если политика, заданная в параметре -p, уже существует, указанное правило будет добавлено в эту политику. В противном случае будет создана политика с указанным именем. Если в качестве интервала_опроса задано целое число, для данной политики будет установлен этот интервал опроса в минутах.
  • Если правило, имя которого задано в параметре -r, уже существует, оно будет изменено в соответствии с заданными параметрами. Например, если включить параметр -f для имеющегося правила, будут заменены только фильтры этого правила. Если правила с указанным именем не существует, оно будет создано.
  • Если задан параметр -o, все параметры указанной политики будет удалены. Не используйте этот параметр, если имеются другие политики, ссылающиеся на объекты в политике, которую требуется удалить.

  • Использование статического режима отличается от использования динамического режима в одном отношении. В динамическом режиме разрешающие и блокирующие фильтры задаются в списке_фильтров, следующем за параметром -f. В статическом режиме разрешающие и блокирующие фильтры задаются в списке_политик_согласования, следующем за параметром -n. Вдобавок к параметрам динамического режима, описанным в списке_политик_согласования, в статическом режиме также можно использовать параметры block, pass и inpass. В следующей таблице приведена таблица со списком и описанием этих параметров.

    Параметр | Описание
    block | Остальные политики в списке_политик_согласования не учитываются, а все фильтры считаются блокирующими.
    pass | Остальные политики в списке_политик_согласования не учитываются, а все фильтры считаются разрешающими.
    inpass | Фильтры входящего трафика позволяют сначала устанавливать небезопасное подключение, но все последующие ответы будут безопасными с использованием IPSec.

Примеры

Чтобы создать политику «Политика домена» с 30-минутным интервалом обновления в домене Active Directory, членом которого является локальный компьютер, с правилом «Безопасные серверы» для трафика между локальным компьютером и компьютерами SecuredServer1 и SecuredServer2 с использованием способов проверки подлинности Kerberos и общим ключом, введите:

ipseccmd -f 0+SecuredServer1 0+SecuredServer2 -a k p:"corpauth" -w ds -p "Политика домена":30 -r "Безопасные серверы"

Чтобы создать и назначить локальную политику «Весь трафик» и правило «Защита трафика», используя отраженный фильтр, всему трафику локального компьютера с использованием общего ключа в качестве способа проверки подлинности, введите:

ipseccmd -f 0+* -a p:"localauth" -w reg -p "Весь трафик" -r "Защита трафика" -x

Режим запроса ipseccmd

Режим запроса Ipseccmd служит для просмотра данных из базы данных политик безопасности IPSec.

Синтаксис

ipseccmd [\\имя_компьютера] show {{[filters] | [policies] | [auth] | [stats] | [sas]} | all}

Параметры

\\имя_компьютера
Имя удаленного компьютера, данные которого требуется просмотреть.
show
Обязательный параметр. Запуск Ipseccmd в режиме запроса.
filters
Отображение фильтров основного и быстрого режимов.
policies
Отображение политик основного и быстрого режимов.
auth
Отображение способов проверки подлинности основного режима.
stats
Отображение статистики протоколов IKE и IPSec.
sas
Отображение сопоставлений безопасности основного и быстрого режимов.
all
Отображение всех данных.
/?
Отображение справки в командной строке.

Заметки

  • Команду Ipseccmd нельзя использовать для отображения данных IPSec на компьютерах, работающих под управлением Windows 2000.
  • Если параметр имя_компьютера не задан, отображаются сведения о локальном компьютере.
  • Если используется параметр имя_компьютера, его необходимо задавать перед всеми остальными параметрами, а также обладать правами администратора на компьютере, данные которого требуется просмотреть.

Примеры

Для отображения фильтров и политик основного и быстрого режимов локального компьютера введите:

ipseccmd show filters policies

Для отображения всех сведений IPSec удаленного компьютера Server1 введите:

ipseccmd \\Server1 show all


Ipxroute

Служит для отображения и изменения таблицы маршрутизации протокола IPX. При вызове команды ipxroute без параметров отображаются используемые по умолчанию параметры пакетов, отправляемых на неизвестные и широковещательные адреса, а также адреса многоадресной рассылки.

Синтаксис

ipxroute servers [/type=x]

ipxroute ripout сеть

ipxroute resolve {guid | name} {код_guid | имя_адаптера}

ipxroute board=число [def] [gbr] [mbr] [remove=xxxxxxxxxxxx]

ipxroute config

Параметры

servers [/type=x]
Вывод таблицы точки доступа к службе (Service Access Point, SAP) для указанного типа сервера. X должно быть целым числом. Например, при задании параметра /type=4 выводятся все файловые серверы. Если не задать параметр /type, будут выведен список серверов всех типов, отсортированный по имени.
ripout сеть
Определение достижимости сети путем проверки таблицы маршрутизации стека IPX и отправки запроса rip при необходимости. Сеть представляет собой номер сегмента сети IPX
.
resolve {guid | name} {код_guid | имя_адаптера}
Разрешение кода GUID в понятное имя или наоборот.
board=число
Сетевой адаптер, у которого запрашиваются или которому передаются данные.
def
Отправка пакетов по широковещательной рассылке ALL ROUTES. Если пакет передается по уникальному аппаратному адресу, который отсутствует в исходной таблице маршрутов, по умолчанию используется одноадресная рассылка SINGLE ROUTES.
gbr
Отправка пакетов по широковещательной рассылке ALL ROUTES. Если пакет передается по широковещательному адресу (FFFFFFFFFFFF), по умолчанию передается широковещательный пакет SINGLE ROUTES.
mbr
Отправка пакетов по широковещательной рассылке ALL ROUTES. Если пакет передается по адресу многоадресной рассылки (C000xxxxxxxx), по умолчанию передается широковещательный пакет SINGLE ROUTES.
remove=xxxxxxxxxxxx
Удаление адреса указанного узла из исходной таблицы маршрутов.
config
Отображение сведений о всех сетевых привязках, на работу с которыми настроен протокол IPX.
/?
Отображение справки в командной строке.

Примеры

Чтобы просмотреть сегменты сети, в которые входит данная рабочая станция, адрес узла рабочей станции и используемый тип кадра, введите следующую команду:

ipxroute config


Irftp

Служит для отправки файлов по инфракрасной связи. При вызове команды irftp без параметров или с параметром /s открывается диалоговое окно Инфракрасная связь, позволяющее выбрать файлы для отправки, не пользуясь командной строкой.

Синтаксис

irftp [диск:\] [[путь] имя_файла] [/h]

irftp /s

Параметры

диск:\
Диск, содержащий файлы, которые требуется отправить по инфракрасной связи.
[путь] имя_файла
Расположение и имя файла для отправки по инфракрасной связи. При задании нескольких файлов необходимо указывать полный путь к каждому файлу.
/h
Включение скрытого режима. Когда используется скрытый режим, передача файлов выполняется без отображения диалогового окна Инфракрасная связь.
/s
Открытие диалогового окна Инфракрасная связь, позволяющего выбрать один или несколько файлов для отправки без использования командной строки.

Заметки

  • Прежде чем использовать эту команду, убедитесь, что передающее и принимающее устройства обладают функционирующими инфракрасными портами и что между этими устройствами установлена инфракрасная связь.

Примеры

Чтобы отправить документ Microsoft Word РабочийДокумент, расположенный в папке РабочиеФайлы (на диске C исходного компьютера), на другой компьютер, введите:

irftp C:\РабочиеФайлы\РабочийДокумент.doc /h

Чтобы отправить два документа Microsoft Word — РабочийДокумент1 и РабочийДокумент2 — расположенные в папке РабочиеФайлы (на диске C исходного компьютера), на другой компьютер, введите:

irftp C:\РабочиеФайлы\РабочийДокумент1.doc C:\РабочиеФайлы\РабочийДокумент2.doc /h

В этом примере используется скрытый режим, поэтому диалоговое окно Инфракрасная связь открываться не будет.


Ipconfig

Служит для отображения всех текущих параметров сети TCP/IP и обновления параметров DHCP и DNS. При вызове команды ipconfig без параметров выводится только IP-адрес, маска подсети и основной шлюз для каждого сетевого адаптера.

Синтаксис

ipconfig [/all] [/renew [адаптер]] [/release [адаптер]] [/flushdns] [/displaydns] [/registerdns] [/showclassid адаптер] [/setclassid адаптер [код_класса]]

Параметры

/all
Вывод полной конфигурации TCP/IP для всех адаптеров. Без этого параметра команда ipconfig выводит только IP-адреса, маску подсети и основной шлюз для каждого адаптера. Адаптеры могут представлять собой физические интерфейсы, такие как установленные сетевые адаптеры, или логические интерфейсы, такие как подключения удаленного доступа.
/renew [адаптер]
Обновление конфигурации DHCP для всех адаптеров (если адаптер не задан) или для заданного адаптера. Данный параметр доступен только на компьютерах с адаптерами, настроенными для автоматического получения IP-адресов. Чтобы указать адаптер, введите без параметров имя, выводимое командой ipconfig.
/release [адаптер]
Отправка сообщения DHCPRELEASE серверу DHCP для освобождения текущей конфигурации DHCP и удаление конфигурации IP-адресов для всех адаптеров (если адаптер не задан) или для заданного адаптера. Этот адаптер отключает протокол TCP/IP для адаптеров, настроенных для автоматического получения IP-адресов. Чтобы указать адаптер, введите без параметров имя, выводимое командой ipconfig.
/flushdns
Сброс и очистка содержимого кэша сопоставления имен DNS клиента. Во время устранения неполадок DNS эту процедуру используют для удаления из кэша записей отрицательных попыток сопоставления и других динамически добавляемых записей.
/displaydns
Отображение содержимого кэша сопоставления имен DNS клиента, включающего записи, предварительно загруженные из локального файла Hosts, а также последние полученные записи ресурсов для запросов на сопоставление имен. Эта информация используется службой DNS клиента для быстрого сопоставления часто встречаемых имен без обращения к указанным в конфигурации DNS-серверам.
/registerdns
Динамическая регистрация вручную имен DNS и IP-адресов, настроенных на компьютере. Этот параметр полезен при устранении неполадок в случае отказа в регистрации имени DNS или при выяснении причин неполадок динамического обновления между клиентом и DNS-сервером без перезагрузки клиента. Имена, зарегистрированные в DNS, определяются параметрами DNS в дополнительных свойствах протокола TCP/IP.
/showclassid адаптер
Отображение кода класса DHCP для указанного адаптера. Чтобы просмотреть код класса DHCP для всех адаптеров, вместо параметра адаптер укажите звездочку (*). Данный параметр доступен только на компьютерах с адаптерами, настроенными для автоматического получения IP-адресов.
/setclassid адаптер [код_класса]
Задание кода класса DHCP для указанного адаптера. Чтобы задать код класса DHCP для всех адаптеров, вместо параметра адаптер укажите звездочку (*). Данный параметр доступен только на компьютерах с адаптерами, настроенными для автоматического получения IP-адресов. Если код класса DHCP не задан, текущий код класса удаляется.
/?
Отображение справки в командной строке.

Заметки

  • Команда ipconfig является эквивалентом для командной строки команды winipcfg, имеющейся в Windows Millennium Edition, Windows 98 и Windows 95. Хотя Windows XP не имеет графического эквивалента команде winipcfg, для просмотра и обновления IP-адреса можно воспользоваться окном «Сетевые подключения». Для этого откройте окно Сетевые подключения, щелкните правой кнопкой мыши сетевое подключение, выберите команду Состояние, а затем откройте вкладку Поддержка.
  • Данная команда доступна только на компьютерах с адаптерами, настроенными для автоматического получения IP-адресов. Это позволяет пользователям определять, какие значения конфигурации были получены с помощью DHCP, APIPA или другой конфигурации.
  • Если имя адаптер содержит пробелы, его следует заключать в кавычки (т. е. "имя_адаптера").
  • В именах адаптеров, задаваемых для команды ipconfig, поддерживается использование подстановочного знака звездочки (*) для задания имен, начинающихся с указанной строки или содержащих указанную строку. Например, имя Подкл* будет включать все адаптеры, начинающиеся со строки «Подкл», а имя *сет* — все адаптера, содержащие строку «сет».
  • Эта команда доступна, только если в свойствах сетевого адаптера в объекте Сетевые подключения в качестве компонента установлен протокол Интернета (TCP/IP).

Примеры

Чтобы вывести основную конфигурацию TCP/IP для всех адаптеров, введите:

ipconfig

Чтобы вывести полную конфигурацию TCP/IP для всех адаптеров, введите:

ipconfig /all

Чтобы обновить конфигурацию IP-адреса, назначенного DHCP-сервером, только для адаптера Подключение по локальной сети, введите:

ipconfig /renew "Подключение по локальной сети"

Чтобы сбросить кэш сопоставления имен DNS при наличии неполадок в сопоставлении имен, введите:

ipconfig /flushdns

Чтобы вывести код класса DHCP для всех адаптеров с именами, начинающимися со слова Подключение, введите:

ipconfig /showclassid Подключение*

Чтобы задать код класса DHCP TEST для адаптера Подключение по локальной сети, введите:

ipconfig /setclassid "Подключение по локальной сети" TEST

Условные обозначения форматирования

Формат | Значение
Курсив | Сведения, вводимые пользователем
Полужирный | Элементы, вводимые без изменений
Многоточие (...) | Параметр может быть введен в командной строке несколько раз
В квадратных скобках ([]) | Необязательные элементы
В фигурых скобках ({}); варианты, разделенные вертикальной линией (|), пример: {even|odd} | Набор вариантов, из которых необходимо выбрать один
Шрифт Courier | Выходные данные программы


Getmac

Возвращает аппаратный (MAC) адрес и список сетевых протоколов, связанных с каждым адресом для всех сетевых плат в любом компьютере — как локальном, так и доступном по сети.

Синтаксис

getmac[.exe] [/s компьютер [/u домен\пользователь [/p пароль]]] [/fo {TABLE|LIST|CSV}] [/nh] [/v]

Параметры

/s компьютер
Имя или IP-адрес удаленного компьютера (не используйте обратную косую черту). По умолчанию используется локальный компьютер.
/u домен\пользователь
Выполнение команды с разрешениями учетной записи пользователя, который указан как пользователь или домен\пользователь. По умолчанию используются разрешения текущего вошедшего пользователя компьютера, с которого поступила эта команда.
/p пароль
Пароль учетной записи пользователя, заданной параметром /u.
/fo {TABLE|LIST|CSV}
Формат выходных данных запроса. Допустимые значения: TABLE, LIST и CSV. По умолчанию для выходных данных используется формат TABLE.
/nh
Запрет на вывод заголовка столбца. Данный параметр является допустимым, если параметр /fo имеет значение TABLE или CSV.
/v
Вывод подробных сведений.
/?
Отображение справки в командной строке.

Заметки

  • Команду Getmac полезно использовать, если требуется ввести MAC-адрес в сетевой анализатор либо требуется определить, какие протоколы используются каждой сетевой платой компьютера.

Примеры

Далее приведены примеры использования команды getmac:

getmac /fo table /nh /v
getmac /s srvmain
getmac /s srvmain /u maindom\hiropln
getmac /s srvmain /u maindom\hiropln /p p@ssW23
getmac /s srvmain /u maindom\hiropln /p p@ssW23 /fo list /v
getmac /s srvmain /u maindom\hiropln /p p@ssW23 /fo table /nh


Goto

В пакетной программе передает управление Windows XP в строку, определенную меткой. Когда метка найдена, выполнение продолжается со следующей за ней строки.

Синтаксис

goto метка

Параметры

метка
Строка в пакетной программе, к которой выполняется переход.
/?
Отображение справки в командной строке.

Заметки

  • Работа с расширениями команды

    Если расширения команды включены (по умолчанию они включены) и в команде goto используется метка :EOF, управление будет передано в конец файла текущего пакетного сценария для выхода из него без назначения метки. Когда используется команда goto с меткой :EOF, перед меткой должно быть вставлено двоеточие. Пример:

    goto :EOF

  • Использование допустимых значений метки

    Метка может включать пробелы, но не может включать другие разделители, такие как точка с запятой или знак равенства. В команде goto используются только первые восемь знаков метки. Например, следующие метки эквивалентны и рассматриваются как :hithere0:

    :hithere0

    :hithere01

    :hithere02

  • Совпадение меток в пакетных программах

    Метка, заданная в команде, должна соответствовать метке в тексте пакетной программы. Метка в пакетной программе должна начинаться с двоеточия (:). В Windows XP строка пакетной программы, начинающаяся с двоеточия (:), опознается как метка и не обрабатывается как команда. Если строка начинается с двоеточия, все присутствующие в ней команды обработаны не будут. Если в пакетном файле не содержится заданной метки, программа будет остановлена, а на экран будет выведено следующее сообщение:

    Метка не найдена.

  • Использование команды goto для обработки условий

    Команду goto можно использовать совместно с другими командами для выполнения операций с условиями.

Примеры

Следующая пакетная программа форматирует диск в дисководе A как системный диск. Если форматирование прошло успешно, команда goto передает управление Windows XP на метку :end.

echo off
format a: /s
if not errorlevel 1 goto end
echo Ошибка при форматировании.
:end
?echo конец пакетной программы.


Gpupdate

Обновляет локальные параметры и параметры групповой политики Active Directory, включая параметры безопасности. Эта команда заменяет устаревший параметр /refreshpolicy команды secedit.

Синтаксис

gpupdate [/target:{computer|user}] [/force] [/wait:значение] [/logoff] [/boot]

Параметры

/target:{computer|user}
Обрабатывает только параметры компьютера или параметры текущего пользователя. По умолчанию обрабатываются и параметры компьютера, и параметры пользователя.
/force
Игнорирует все оптимизации в процессе обработки и восстанавливает все предыдущие настройки.
/wait:значение
Время ожидания окончания обработки политики в секундах. По умолчанию это время составляет 600 секунд. 0 означает «без ожидания»; -1 означает «время ожидания не ограничено».
/logoff
Задает выход из системы по завершении обновления. Это необходимо для тех клиентских расширений оснастки «Групповая политика», которые обрабатываются не в фоновом режиме, а при входе пользователя в систему, например, при установке программного обеспечения и перенаправлении папок. Этот параметр не работает, если вызываемые расширения, необходимые для выхода пользователя из системы, отсутствуют.
/boot
Перезапускает компьютер после завершения обновления. Это необходимо для тех клиентских расширений оснастки «Групповая политика», которые обрабатываются не в фоновом режиме, а при входе пользователя в систему, например, при установке программного обеспечения и перенаправлении папок. Этот параметр не работает, если вызываемые расширения, необходимые для перезапуска компьютера, отсутствуют.
/?
Вывод справки в командной строке.

Примечания

  • Если допущена синтаксическая ошибка, то подобно данному разделу справки выводится синтаксическая сводка.

Примеры

Далее приведены примеры использования команды gpupdate:

gpupdate

gpupdate /target:computer

gpupdate /force /wait:100

gpupdate /boot


Gpresult

Отображение параметров групповой политики и результирующей политики (RSOP) для пользователя или компьютера.

Синтаксис

gpresult [/s компьютер [/u домен\пользователь /p пароль]] [/user имя_конечного_пользователя] [/scope {user|computer}] [/v] [/z]

Параметры

/s компьютер
Имя или IP-адрес удаленного компьютера. (Не используйте обратную косую черту.) По умолчанию используется локальный компьютер.
/u домен\пользователь
Выполнение команды с разрешениями учетной записи пользователя, который указан как пользователь или домен\пользователь. По умолчанию используются разрешения текущего вошедшего пользователя компьютера, с которого поступила эта команда.
/p пароль
Пароль учетной записи пользователя, заданной параметром /u.
/user имя_конечного_пользователя
Имя пользователя, для которого требуется просмотреть данные RSOP.
/scope {user | computer}
Отображение результатов для параметра user или computer. Допустимыми значениями параметра /scope являются user или computer. Если опустить параметр /scope, результаты gpresult будут выданы для параметров user и computer.
/v
Вывод подробных сведений о политике.
/z
Вывод всех доступных сведений о групповой политике. Поскольку при использовании этого параметра выдается больше сведений, чем при использовании параметра /v, рекомендуется перенаправлять вывод в текстовый файл (например gpresult /z >policy.txt).
/?
Отображение справки в командной строке.

Заметки

  • Оснастка «Групповая политика» — это основной инструмент администратора для определения и управления параметрами работы программ, сетевых ресурсов и операционной системы для пользователей и компьютеров организации. В среде Active Directory групповая политика применяется к пользователям или компьютерам на основе их принадлежности к узлам, доменам или организационным подразделениям.
  • Поскольку к любому компьютеру или пользователю можно применять перекрывающиеся уровни политик, групповая политика при входе в систему создает результирующую политику. Gpresult отображает результирующую политику, действующую на компьютере для указанного пользователя после входа в систему.

Примеры

Далее приведены примеры использования команды gpresult:

gpresult /user targetusername /scope computer
gpresult /s srvmain /u maindom\hiropln /p p@ssW23 /user targetusername /scope USER
gpresult /s srvmain /u maindom\hiropln /p p@ssW23 /user targetusername /z >policy.txt
gpresult /s srvmain /u maindom\hiropln /p p@ssW23


Graftabl

Служит для включения возможности отображения расширенного набора символов в графическом режиме.

Синтаксис

graftabl [xxx] [/status]

Параметры

xxx
Задает кодовую страницу, для которой обеспечивается вывод расширенных символов. Ниже приведены существующие кодовые таблицы с соответствующими странами/регионами или языками:
Значение | Страна/регион
437 | США
850 | Многоязычная (латиница I)
852 | Восточная и центральная Европа (латиница II)
855 | Кириллица (русский)
857 | Турецкий
860 | Португальский
861 | Исландский
863 | Французский (Канада)
865 | Скандинавский
866 | Русский
869 | Современный греческий
/status
Кодовая страница, используемая graftabl.
/?
Отображение справки в командной строке.

Заметки

  • Чтобы получить сведения об использовании кодовых страниц, выберите chcp или mode (установка кодовых страниц устройства) из списка в ссылке «См. также».
  • Команда Graftabl не влияет на кодовую страницу, используемую при вводе. Команда Graftabl определяет только вывод на монитор расширенных символов указанной кодовой страницы. Для смены кодовой страницы следует использовать команды mode и chcp.
  • Коды завершения команды graftabl

    В следующей таблице перечислены коды завершения с кратким описанием.

    Код завершения | Описание
    0 | Набор символов успешно загружен. Ранее кодовая страница загружена не была.
    1 | Задан недопустимый параметр. Никакое действие выполнено не было.
    2 | Возникла ошибка файла.
  • В пакетных программах можно использовать параметр errorlevel команды if для анализа кода завершения команды graftabl.

Примеры

Для загрузки графических символов кодовой страницы 437 (США) в память служит следующая команда:

graftabl 437

Для загрузки графических символов кодовой страницы 850 (многоязычной) в память служит следующая команда:

graftabl 850


Пакетные файлы

Использование пакетных файлов (bat)

Пакетные файлы, также называемые программами пакетной обработки или сценариями, позволяют упростить выполнение утомительных и часто используемых операций. Пакетный файл представляет собой неформатированный текстовый файл, содержащий одну или несколько команд и имеющий расширение имени .bat или .cmd. Когда имя такого файла вводится в командной строке, программа Cmd.exe выполняет по порядку команды, записанные в файле.

В пакетный файл можно включить любую команду. Некоторые команды, такие как for, goto и if, позволяют выполнять обработку условий в пакетных файлах. Например, if позволяет запускать команды в зависимости от выполнения заданного условия. Другие команды позволяют управлять вводом и выводом, а также запускать другие пакетные файлы.

Стандартные коды ошибок, возвращаемые большинством приложений — это 0, если ошибки отсутствуют, и 1 (или более высокое значение), если возникла ошибка. Чтобы определить значения отдельных кодов, см. справочную документацию приложения.

Дополнительные сведения об операциях пакетных файлов см. в следующих разделах.

  • Использование параметров командной строки пакетного файла
  • Использование фильтров
  • Использование операторов перенаправления команд

Для получения дополнительных сведений о командах, используемых в пакетных файлах, щелкните соответствующую ссылку.

  • Call
  • Echo
  • Endlocal
  • For
  • Goto
  • If
  • Pause
  • Rem
  • Setlocal
  • Shift


Bootcfg

Настройка, запрос или изменение параметров файла Boot.ini.

Добавление параметров загрузки операционной системы для определенной записи операционной системы.

Синтаксис

bootcfg /addsw [/s компьютер [/u домен\пользователь /p пароль]] [/mm максимальный_объем_ОЗУ] [/bv] [/so] [/ng] /id номер_строки_записи_в_разделе_ОС

Параметры

/s компьютер
Имя или IP-адрес удаленного компьютера (не используйте обратную косую черту). По умолчанию используется локальный компьютер.
/u домен\пользователь
Выполнение команды с разрешениями учетной записи пользователя, который указан как пользователь или домен\пользователь. По умолчанию используются разрешения текущего вошедшего пользователя компьютера, с которого поступила эта команда.
/p пароль
Пароль учетной записи пользователя, заданной параметром /u.
/mm максимальный_объем_ОЗУ
Добавление ключа /maxmem в строку, указанную в параметре номер_строки_записи_в_разделе_ОС, и задание максимального объема ОЗУ, доступного операционной системе.
/bv
Добавление ключа /basevideo в строку, указанную в параметре номер_строки_записи_в_разделе_ОС, который задает в операционной системе стандартный режим VGA для установленного видеодрайвера.
/so
Добавление ключа /sos в строку, указанную в параметре номер_строки_записи_в_разделе_ОС, который задает в операционной системе вывод имен драйверов устройств при их загрузке.
/ng
Добавление ключа /noguiboot в строку, указанную в параметре номер_строки_записи_в_разделе_ОС, который отключает индикатор выполнения Windows XP Professional, отображающийся перед приглашением на вход в систему нажатием клавиш CTRL+ALT+DEL.
/id номер_строки_записи_в_разделе_ОС
Указание номера строки записи операционной системы в разделе [operating systems] файла Boot.ini, в которую добавляются параметры загрузки операционной системы. Первая строка после заголовка раздела [operating systems] имеет номер 1.
/?
Отображение справки в командной строке.

Примеры

Следующие примеры иллюстрируют использование команды bootcfg /addsw.

bootcfg /addsw /mm 64 /id 2
bootcfg /addsw /so /id 3
bootcfg /addsw /so /ng /s srvmain /u hiropln /id 2
bootcfg /addsw /ng /id 2
bootcfg /addsw /mm 96 /ng /s srvmain /u maindom\hiropln /p p@ssW23 /id 2

Создание с помощью копирования другого экземпляра операционной системы, для которого можно добавить ключи.

Синтаксис

bootcfg /copy [/s компьютер [/u домен\пользователь /p пароль]] [/d описание] [/id номер_строки_записи_в_разделе_ОС]

Параметры

/s компьютер
Имя или IP-адрес удаленного компьютера (не используйте обратную косую черту). По умолчанию используется локальный компьютер.
/u Domain\User
Выполнение команды с разрешениями учетной записи пользователя, который указан как пользователь или домен\пользователь. По умолчанию используются разрешения текущего вошедшего пользователя компьютера, с которого поступила эта команда.
/p пароль
Пароль учетной записи пользователя, заданной параметром /u.
/d описание
Задает описание для новой записи операционной системы.
/id номер_строки_записи_в_разделе_ОС
Указание номера строки записи операционной системы в разделе [operating systems] файла Boot.ini для копирования. Первая строка после заголовка раздела [operating systems] имеет номер 1.
/?
Отображение справки в командной строке.

Примеры

Следующие примеры иллюстрируют использование команды bootcfg /copy.

bootcfg /copy /d "\ABC Server\" /id 1
bootcfg /copy /s srvmain /u maindom\hiropln /p p@ssW23 /d "Windows XP" /id 2
bootcfg /copy /u hiropln /p p@ssW23 /d "AB Ver 1.001" /id 2

Настройка отладки порта 1394 для определенной записи операционной системы.

Синтаксис

bootcfg /dbg1394 {ON|OFF|EDIT} [/s компьютер [/u домен\пользователь /p пароль]] [/ch канал] /id номер_строки_записи_в_разделе_ОС

Параметры

ON|OFF|EDIT
Указание значения для отладки порта 1394.
Значение | Описание
ON | Включение поддержки удаленной отладки путем добавления ключа /dbg1394 в строку, указанную в параметре номер_строки_записи_в_разделе_ОС.
OFF | Отключение поддержки удаленной отладки путем удаления ключа /dbg1394 из строки, указанной в параметре номер_строки_записи_в_разделе_ОС.
EDIT | Разрешение вносить изменения в настроки порта и скорости путем изменения значений канала, связанных с ключом /dbg1394, для указанного параметра номер_строки_записи_в_разделе_ОС.
/s компьютер
Имя или IP-адрес удаленного компьютера (не используйте обратную косую черту). По умолчанию используется локальный компьютер.
/u домен\пользователь
Выполнение команды с разрешениями учетной записи пользователя, который указан как пользователь или домен\пользователь. По умолчанию используются разрешения текущего вошедшего пользователя компьютера, с которого поступила эта команда.
/p пароль
Пароль учетной записи пользователя, заданной параметром /u.
/ch канал
Указание канала, используемого для отладки. Допустимыми значениями являются целые числа в диапазоне от 1 до 64. Если отладка порта 1394 отключена, не используйте параметр /ch канал.
/id номер_строки_записи_в_разделе_ОС
Указание номера строки записи операционной системы в разделе [operating systems] файла Boot.ini, в которую добавляются параметры отладки порта 1394. Первая строка после заголовка раздела [operating systems] имеет номер 1.
/?
Отображение справки в командной строке.

Примеры

Следующие примеры иллюстрируют использование команды bootcfg /dbg1394.

bootcfg /dbg1394 /id 2
bootcfg /dbg1394 on /ch 1 /id 3
bootcfg /dbg1394 edit /ch 8 /id 2
bootcfg /s srvmain /u maindom\hiropln /p p@ssW23 /dbg1394 off /id 2

Добавление или изменение параметров отладки для определенной записи операционной системы.

Синтаксис

bootcfg /debug {ON|OFF|EDIT} [/s компьютер [/u домен\пользователь /p пароль]] [/port {COM1|COM2|COM3|COM4}] [/baud {9600|19200|38400|57600|115200}] [/id номер_строки_записи_в_разделе_ОС]

Параметры

ON|OFF|EDIT
Указывает значение для отладки.
Значение | Описание
ON | Включение поддержки удаленной отладки путем добавления ключа /debug в строку, указанную в параметре номер_строки_записи_в_разделе_ОС.
OFF | Отключение поддержки удаленной отладки путем удаления ключа /debug из строки, указанной в параметре номер_строки_записи_в_разделе_ОС.
EDIT | Разрешение вносить изменения в настройки порта и скорости путем изменения значений, связанных с ключом /debug, для указанного параметра номер_строки_записи_в_разделе_ОС.
/s компьютер
Имя или IP-адрес удаленного компьютера (не используйте обратную косую черту). По умолчанию используется локальный компьютер.
/u домен\пользователь
Выполнение команды с разрешениями учетной записи пользователя, который указан как пользователь или домен\пользователь. По умолчанию используются разрешения текущего вошедшего пользователя компьютера, с которого поступила эта команда.
/p пароль
Пароль учетной записи пользователя, заданной параметром /u.
/port {COM1|COM2|COM3|COM4}
Последовательный порт, используемый для отладки. Если отладка отключена, не используйте параметр /port.
/baud {9600|19200|38400|57600|115200}
Скорость передачи, используемая для отладки. Если отладка отключена, не используйте параметр /baud.
/id номер_строки_записи_в_разделе_ОС
Указывает номер строки записи операционной системы в разделе [operating systems] файла Boot.ini, в которую добавляются параметры отладки. Первая строка после заголовка раздела [operating systems] имеет номер 1.
/?
Отображение справки в командной строке.

Заметки

  • Если необходима отладка порта 1394, используйте команду bootcfg /dbg1394.

Примеры

Следующие примеры иллюстрируют использование команды bootcfg /debug.

bootcfg /dbg1394 /id 2
bootcfg /dbg1394 on /ch 19200 /id 3
bootcfg /dbg1394 edit /ch 8 /id 2
bootcfg /s srvmain /u maindom\hiropln /p p@ssW23 /dbg1394 off /id 2

Задает запись операционной системы, используемую по умолчанию.

Синтаксис

bootcfg /default [/s компьютер [/u домен\пользователь /p пароль]] [/id номер_строки_записи_в_разделе_ОС]

Параметры

/s компьютер
Имя или IP-адрес удаленного компьютера (не используйте обратную косую черту). По умолчанию используется локальный компьютер.
/u домен\пользователь
Выполнение команды с разрешениями учетной записи пользователя, который указан как пользователь или домен\пользователь. По умолчанию используются разрешения текущего вошедшего пользователя компьютера, с которого поступила эта команда.
/p пароль
Пароль учетной записи пользователя, заданной параметром /u.
/id номер_строки_записи_в_разделе_ОС
Указывает номер строки записи операционной системы в разделе [operating systems] файла Boot.ini, используемую по умолчанию. Первая строка после заголовка раздела [operating systems] имеет номер 1.
/?
Отображение справки в командной строке.

Примеры

Следующие примеры иллюстрируют использование команды bootcfg /default.

bootcfg /default /id 2
bootcfg /default /s srvmain /u maindom\hiropln /p p@ssW23 /id 2

даление записи операционной системы в разделе [operating systems] файла Boot.ini.

Синтаксис

bootcfg /delete [/s компьютер [/u домен\пользователь /p пароль]] [/id номер_строки_записи_в_разделе_ОС]

Параметры

/s компьютер
Имя или IP-адрес удаленного компьютера (не используйте обратную косую черту). По умолчанию используется локальный компьютер.
/u домен\пользователь
Выполнение команды с разрешениями учетной записи пользователя, который указан как пользователь или домен\пользователь. По умолчанию используются разрешения текущего вошедшего пользователя компьютера, с которого поступила эта команда.
/p пароль
Пароль учетной записи пользователя, заданной параметром /u.
/id номер_строки_записи_в_разделе_ОС
Указывает номер строки записи операционной системы в разделе [operating systems] файла Boot.ini для удаления. Первая строка после заголовка раздела [operating systems] имеет номер 1.
/?
Отображение справки в командной строке.

Примеры

Следующие примеры иллюстрируют использование команды bootcfg /delete.

bootcfg /delete /id 1
bootcfg /delete /s srvmain /u maindom\hiropln /p p@ssW23 /id 3

Позволяет пользователю добавлять или изменять параметры для перенаправления консоли EMS на удаленный компьютер. При использовании EMS в заголовок [boot loader] файла Boot.ini добавляется строка "redirect=Port#", а в указанную строку записи операционной системы — ключ /redirect. Функция EMS доступна только на серверах.

Синтаксис

bootcfg /ems {ON|OFF|EDIT} [/s компьютер [/u домен\пользователь /p пароль]] [/port {COM1|COM2|COM3|COM4|BIOSSET}] [/baud {9600|19200|38400|57600|115200}] [/id номер_строки_записи_в_разделе_ОС]

Параметры

ON|OFF|EDIT
Указывает значение для перенаправления EMS.
Значение | Описание
ON | Разрешает удаленный вывод для указанного параметра номер_строки_записи_в_разделе_ОС. Добавляет ключ /redirect в строку, указанную в параметре номер_строки_записи_в_разделе_ОС, и параметр redirect=comX в раздел [boot loader]. Значение comX задается параметром /port.
OFF | Запрещает вывод на удаленном компьютере. Удаляет ключ /redirect из строки, указанной в параметре номер_строки_записи_в_разделе_ОС, и параметр redirect=comX из раздела [boot loader].
EDIT | Позволяет изменять настройки порта путем изменения параметра redirect=comX в разделе [boot loader]. Восстанавливается значение comX, заданное параметром /port.
/s компьютер
Имя или IP-адрес удаленного компьютера (не используйте обратную косую черту). По умолчанию используется локальный компьютер.
/u домен\пользователь
Выполнение команды с разрешениями учетной записи пользователя, который указан как пользователь или домен\пользователь. По умолчанию используются разрешения текущего вошедшего пользователя компьютера, с которого поступила эта команда.
/p пароль
Пароль учетной записи пользователя, заданной параметром /u.
/port {COM1|COM2|COM3|COM4|BIOSSET}
Последовательный порт, используемый для перенаправления. Параметр BIOSSET задает использование настроек BIOS при определении порта для перенаправления в EMS. Если удаленное управление выводом запрещено, не используйте параметр /port.
/baud {9600|19200|38400|57600|115200}
Скорость передачи, используемая для перенаправления. Если удаленное управление выводом запрещено, не используйте параметр /baud.
/id номер_строки_записи_в_разделе_ОС
Указывает номер строки записи операционной системы в разделе [operating systems] файла Boot.ini, в которую добавляется параметр EMS. Первая строка после заголовка раздела [operating systems] имеет номер 1. Данный параметр является обязательным, если значение EMS установлено в ON или OFF.
/?
Отображение справки в командной строке.

Заметки

  • Дополнительные сведения о службах аварийного управления (EMS) см. в центре справки и поддержки.

Примеры

Следующие примеры иллюстрируют использование команды bootcfg /ems.

bootcfg /ems on /port com1 /baud 19200 /id 2
bootcfg /ems on /port biosset /id 3
bootcfg /s srvmain /ems off /id 2
bootcfg /ems edit /port com2 /baud 115200
bootcfg /s srvmain /u maindom\hiropln /p p@ssW23 /ems off /id 2

Запрос и отображение записей разделов [boot loader] и [operating systems] файла Boot.ini.

Синтаксис

bootcfg /query [/s компьютер [/u домен\пользователь /p пароль]]

Параметры

/s компьютер
Имя или IP-адрес удаленного компьютера (не используйте обратную косую черту). По умолчанию используется локальный компьютер.
/u домен\пользователь
Выполнение команды с разрешениями учетной записи пользователя, который указан как пользователь или домен\пользователь. По умолчанию используются разрешения текущего вошедшего пользователя компьютера, с которого поступила эта команда.
/p пароль
Пароль учетной записи пользователя, заданной параметром /u.
/?
Отображение справки в командной строке.

Заметки

  • Следующий пример иллюстрирует вывод команды bootcfg /query.
    Параметры загрузки
--------------------
timeout: 30
default: multi(0)disk(0)rdisk(0)partition(1)\WINDOWS

Элементы списка загрузки
------------
Идентификатор загрузочной записи:   1
Понятное имя:   "Microsoft Windows XP Professional"
Путь:            multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
Параметры загрузки ОС: /fastdetect /debug /debugport=com1:
  • В разделе «Параметры загрузки» вывода команды bootcfg query отображаются все записи из раздела [boot loader] файла Boot.ini.
  • В разделе «Элементы списка загрузки» вывода bootcfg query отображаются следующие сведения для каждой записи операционной системы в разделе [operating systems] файла Boot.ini: «Идентификатор загрузочной записи», «Понятное имя», «Путь» и «Параметры загрузки ОС».

Примеры

Следующие примеры иллюстрируют использование команды bootcfg /query.

bootcfg /query
bootcfg /query /s srvmain /u maindom\hiropln /p p@ssW23
bootcfg /query /u hiropln /p p@ssW23

Добавление параметров загрузки операционной системы, заданных в виде строки, в запись операционной системы в разделе [operating systems] файла Boot.ini.

Синтаксис

bootcfg [/s компьютер [/u домен\пользователь /p пароль]] /raw строка_параметров_загрузки_ОС [/id номер_строки_записи_в_разделе_ОС]

Параметры

/s компьютер
Имя или IP-адрес удаленного компьютера (не используйте обратную косую черту). По умолчанию используется локальный компьютер.
/u домен\пользователь
Выполнение команды с разрешениями учетной записи пользователя, который указан как пользователь или домен\пользователь. По умолчанию используются разрешения текущего вошедшего пользователя компьютера, с которого поступила эта команда.
/p пароль
Пароль учетной записи пользователя, заданной параметром /u.
Строка_параметров_загрузки_ОС
Параметры загрузки операционной системы, добавляемые в запись операционной системы. Эти параметры загрузки заменяют все существующие параметры загрузки, связанные с данной записью операционной системы. Проверка параметров_загрузки_ОС не выполняется.
/id номер_строки_записи_в_разделе_ОС
Указывает номер строки записи операционной системы в разделе [operating systems] файла Boot.ini для обновления. Первая строка после заголовка раздела [operating systems] имеет номер 1.
/?
Отображение справки в командной строке.

Заметки

  • Команда Bootcfg raw используется для добавления текста в конец записи операционной системы, замещающего все существующие параметры записи операционной системы. Этот текст должен содержать допустимые параметры загрузки операционной системы, такие как /debug, /fastdetect, /nodebug, /baudrate, /crashdebug и /sos. Например, следующая команда добавляет параметры "/debug /fastdetect" в конец первой записи операционной системы, которые заменяют все ранее заданные параметры данной записи операционной системы:

    bootcfg /raw "/debug /fastdetect" /id 1

  • Дополнительные сведения о необязательных параметрах загрузки операционной системы и использовании файла Boot.ini при запуске Windows см. в статье Q170756, "Available Switch Options for Windows NT Boot.ini File" на веб-узле Microsoft Knowledge Base. (http://www.microsoft.com/)

Примеры

Следующие примеры иллюстрируют использование команды bootcfg /raw.

bootcfg /raw "/debug /sos" /id 2
bootcfg /raw /s srvmain /u maindom\hiropln /p p@ssW23 "/crashdebug " /id 2

Удаление параметров загрузки операционной системы из определенной записи операционной системы.

Синтаксис

bootcfg /rmsw [/s компьютер [/u домен\пользователь /p пароль]] [/mm] [/bv] [/so] [/ng] /id номер_строки_записи_в_разделе_ОС

Параметры

/s компьютер
Имя или IP-адрес удаленного компьютера (не используйте обратную косую черту). По умолчанию используется локальный компьютер.
/u домен\пользователь
Выполнение команды с разрешениями учетной записи пользователя, который указан как пользователь или домен\пользователь. По умолчанию используются разрешения текущего вошедшего пользователя компьютера, с которого поступила эта команда.
/p пароль
Пароль учетной записи пользователя, заданной параметром /u.
/mm
Удаление ключа /maxmem и соответствующего значения максимального объема памяти из строки, указанной в параметре номер_строки_записи_в_разделе_ОС. Ключ /maxmem задает максимальный объем ОЗУ, доступный операционной системе.
/bv
Удаление ключа /basevideo из строки, указанной в параметре номер_строки_записи_в_разделе_ОС. Ключ /basevideo задает использование стандартного режима VGA в операционной системе для установленного видеодрайвера.
/so
Удаление ключа /sos из строки, указанной в параметре номер_строки_записи_в_разделе_ОС. Ключ /sos задает в операционной системе вывод имен драйверов устройств при их загрузке.
/ng
Удаление ключа /noguiboot из строки, указанной в параметре номер_строки_записи_в_разделе_ОС. Ключ /noguiboot отключает индикатор выполнения Windows XP Professional, отображающийся перед приглашением на вход в систему нажатием клавиш CTRL+ALT+DEL.
/id номер_строки_записи_в_разделе_ОС
Указывает номер строки записи операционной системы в разделе [operating systems] файла Boot.ini, из которой удаляются параметры загрузки операционной системы. Первая строка после заголовка раздела [operating systems] имеет номер 1.
/?
Отображение справки в командной строке.

Примеры

Следующие примеры иллюстрируют использование команды bootcfg /rmsw.

bootcfg /rmsw /mm 64 /id 2
bootcfg /rmsw /so /id 3
bootcfg /rmsw /so /ng /s srvmain /u hiropln /id 2
bootcfg /rmsw /ng /id 2
bootcfg /rmsw /mm 96 /ng /s srvmain /u maindom\hiropln /p p@ssW23 /id 2

Изменение значения таймаута операционной системы.

Синтаксис

bootcfg /timeout значение_таймаут [/s компьютер [/u домен\пользователь /p пароль]]

Параметры

значение_таймаута
Значение таймаута в разделе [boot loader]. Это время ожидания в секундах, в течение можно выбрать операционную системе в экране начальной загрузки, прежде чем стандартные парметры будут загружены программой NTLDR. Если задано знчение 0, программа NTLDR запускает используемую по умолчанию операционную систему сразу, без отображения экрана начальной загрузки.
/s компьютер
Имя или IP-адрес удаленного компьютера (не используйте обратную косую черту). По умолчанию используется локальный компьютер.
/u домен\пользователь
Выполнение команды с разрешениями учетной записи пользователя, который указан как пользователь или домен\пользователь. По умолчанию используются разрешения текущего вошедшего пользователя компьютера, с которого поступила эта команда.
/p пароль
Пароль учетной записи пользователя, заданной параметром /u.
/?
Отображение справки в командной строке.

Примеры

Следующие примеры иллюстрируют использование команды bootcfg /timeout.

bootcfg /timeout 30
bootcfg /s srvmain /u maindom\hiropln /p p@ssW23 /timeout 50


Справка

Служит для просмотра описаний системных (т. е. не сетевых) команд. При вызове без параметров команда help выводит список всех системных команд с краткими описаниями.

Синтаксис

{help [команда]|[команда]/?}

Параметры

команда
Команда, сведения о которой требуется получить.

Заметки

  • Существует два способа получения интерактивной справки с помощью команды help. Можно ввести help команда или команда /?. При использовании параметра /? вывод справка осуществляется быстрее.

Примеры

Чтобы просмотреть сведения о команде xcopy, введите одну из следующих команд:

help xcopy
xcopy /?


Helpctr

Запуск справки и поддержки. При вызове без параметров команда helpctr открывает домашнюю страницу центра справки и поддержки.

Синтаксис

helpctr [/url [адрес_URL]] [/mode [адрес_URL]] [/hidden] [/fromstarthelp]

Параметры

/url [адрес_URL]
Адрес URL, который требуется открыть в центре справки и поддержки.
/mode [адрес_URL]
Файл определения языка наращиваемой разметки (XML), поддерживающий схему Launch_Description.dtd, управляющую контекстом, макетом и содержанием центра справки и поддержки.
/hidden
Запуск центра справки и поддержки без отображения пользовательского интерфейса. С помощью данной команды можно загрузить раздел. Она используется для удаленного администрирования выполнения сценария.
/fromstarthelp
Запуск нового экземпляра центра справки и поддержки.
/?
Отображение справки в командной строке.

Заметки

  • Использование атрибута адрес_URL

    При использовании параметра /url или /mode атрибут адрес_URL можно заключать в кавычки (т. е. "адрес_URL"). If a space exists within URL, replace it by typing %20 (that is, "URL%20 Address").

Примеры

Чтобы запустить сеанс удаленного помощника с помощью файла .msrincident, введите:

HelpCtr /mode "hcp://CN=Microsoft%20Corporation,L=Redmond,S=Washington,C=US/Remote%20Assistance/RAClientLayout.xml" /url "hcp://CN=Microsoft%20Corporation,L=Redmond,S=Washington,C=US/Remote%20Assistance/Interaction/Client/rctoolScreen1.htm?IncidentFile=rahelp.msrincident"


Hosthame

Hostname

Отображение имени узла, входящего в состав полного имени компьютера.

Синтаксис

hostname

Параметры

/?
Отображение справки в командной строке.

Заметки

  • Эта команда доступна, только если в свойствах сетевого адаптера в объекте Сетевые подключения в качестве компонента установлен протокол Интернета (TCP/IP).

Примеры

Чтобы просмотреть имя компьютера, введите:

hostname

Условные обозначения форматирования

Формат | Значение
Курсив | Сведения, вводимые пользователем
Полужирный | Элементы, вводимые без изменений
Многоточие (...) | Параметр может быть введен в командной строке несколько раз
В квадратных скобках ([]) | Необязательные элементы
В фигурых скобках ({}); варианты, разделенные вертикальной линией (|), пример: {even|odd} | Набор вариантов, из которых необходимо выбрать один
Шрифт Courier | Выходные данные программы


Openfiles

Запрашивает или отображает открытые файлы. Также запрашивает, отображает или разъединяет файлы, открытые сетевыми пользователями.

Разъединяет одного или нескольких удаленных пользователей, присоединенных к открытым общим файлам.

Синтаксис

openfiles.exe /disconnect [/s Компьютер [/u домен\пользователь [/p пароль]]] {[/id КодОткрытогоФайла]|[/a ИмяПользователя]|[/o РежимОткрытия]} [/se ИмяСессии] [/op ИмяОткрытогоФайла]

Параметры

/s компьютер
Имя или IP-адрес удаленного компьютера. Не используйте обратную косую черту. По умолчанию используется локальный компьютер.
/u домен\пользователь
Выполнение команды с разрешениями учетной записи пользователя, который указан как пользователь или домен\пользователь. По умолчанию используются разрешения текущего вошедшего пользователя компьютера, с которого поступила эта команда.
/p пароль
Определяет пароль учетной записи пользователя, заданной параметром /u.
/id КодОткрытогоФайла
Разъединяет файл, открытый со специальным цифровым параметром КодОткрытогоФайла на компьютере, указанном параметром /s. Для определения кода файла следует использовать команду openfiles.exe /query. Подстановочный знак (*) может быть использован для разъединения всех открытых файлов на указанном компьютере.
/a ИмяПользователя
Разъединяет все открытые файлы, доступ к которым осуществлялся указанным пользователем на компьютере, указанном параметром /s. С помощью подстановочного знака (*) можно отключить все открытые файлы на указанном компьютере.
/o РежимОткрытия
Разъединяет все открытые файлы с указанным параметром РежимОткрытия на компьютере, указанном параметром /s. Параметр РежимОткрытия включает режим чтения/записи и режим чтения. С помощью подстановочного знака (*) можно отключить все открытые файлы на указанном компьютере.
/se ИмяСессии
Разъединяет все открытые файлы, которые были созданы указанной сессией на компьютере, указанном параметром /s. С помощью подстановочного знака (*) можно отключить все открытые файлы на указанном компьютере.
/op ИмяОткрытогоФайла
Разъединяет открытый файл, который был создан с указанным параметром ИмяОткрытогоФайла на компьютере, указанном параметром /s. С помощью подстановочного знака (*) можно отключить все открытые файлы на указанном компьютере.
/?
Отображает справку в командной строке.

Примеры

Далее приведены примеры использования команды openfiles /disconnect:

openfiles.exe /disconnect /id 1
openfiles.exe /disconnect /a hiropln
openfiles.exe /disconnect /o read/write
openfiles.exe /disconnect /op "c:\my documents\somedoc.doc"
openfiles /disconnect /session machine /id 5
openfiles.exe /disconnect /s srvmain /u maindom\hiropln /id 5
openfiles /disconnect /s srvmain /u maindom\hiropln /p p@ssW23 /id *

Запрашивает и отображает открытые файлы.

Синтаксис

openfiles.exe /query [/s компьютер [/u домен\пользователь [/p пароль]]] [/fo {TABLE|LIST|CSV}] [/nh] [/v]

Параметры

/s компьютер
Имя или IP-адрес удаленного компьютера. Не используйте обратную косую черту. По умолчанию используется локальный компьютер.
/u домен\пользователь
Выполнение команды с разрешениями учетной записи пользователя, который указан как пользователь или домен\пользователь. По умолчанию используются разрешения текущего вошедшего пользователя компьютера, с которого поступила эта команда.
/p пароль
Определяет пароль учетной записи пользователя, заданной параметром /u.
/fo {TABLE|LIST|CSV}
Формат выходных данных запроса. Допустимые значения: TABLE, LIST и CSV. По умолчанию для выходных данных используется значение TABLE.
/nh
Запрещает вывод заголовка столбца. Данный параметр является допустимым, если параметр /fo имеет значение TABLE или CSV.
/v
Задает отображение подробных сведений о задании в выходных данных.
/?
Отображает справку в командной строке.

Примеры

Далее приведены примеры использования команды openfiles /query:

openfiles.exe /query
openfiles.exe /query /fo table /nh
openfiles.exe /query /fo list /v
openfiles.exe /query /s srvmain /u maindom\hiropln /p p@ssW23


Unlodctr

Удаляет имена счетчиков производительности и текст объяснения для службы или драйвера устройства из системного реестра.

Синтаксис

Unlodctr [\\имя_компьютера] имя_драйвера

Параметры

[\\имя_компьютера] имя_драйвера
Удаляет параметры имени счетчика производительности и текст объяснения для драйвера или службы, описанные в параметре имя_драйвера, из системного реестра Windows XP. Если не указано имя_компьютера по умолчанию Windows XP будет использовать локальный компьютер.
/?
Отображает справку в командной строке.

Примечания

  • Если аргументы параметров команды содержат пробелы, их следует заключать в кавычки (например "имя компьютера").

Примеры

Чтобы удалить текущие параметры реестра производительности и текст объяснения счетчика для службы RSVP на компьютере comp1, введите:

unlodctr \\comp1 RSVP


Xcopy

Копирует файлы и каталоги, включая подкаталоги.

Синтаксис

xcopy источник [результат] [/w] [/p] [/c] [/v] [/q] [/f] [/l] [/g] [/d[:мм-дд-гггг]] [/u] [/i] [/s [/e]] [/t] [/k] [/r] [/h] [{/a|/m}] [/n] [/o] [/x] [/exclude:файл1[+[файл2]][+[файл3]] [{/y|/-y}] [/z]

Параметры

источник
Обязательный параметр. Задает местонахождение и имена файлов для копирования. Параметр должен задавать или диск, или путь.
результат
Задает место, куда будут скопированы файлы. Параметр может включать имя диска с двоеточием, имя каталога, имя файла или их комбинацию.
/w
Выводит следующее сообщение с ожиданием подтверждения начала копирования:

Нажмите любую клавишу, чтобы начать копирование файлов

/p
Запрашивает подтверждение при создании каждого файла-результата.
/c
Игнорирует ошибки.
/v
Проверяет каждый скопированный файл на соответствие его оригиналу.
/q
Отменяет вывод на экран сообщений команды xcopy.
/f
Выводит имена исходных файлов и файлов-результатов в процессе копирования.
/l
Отображает список копируемых файлов.
/g
Создает незашифрованные файлы-результаты.
/d[:мм-дд-гггг]
Копирует только файлы, измененные не ранее заданной даты. Если не включить значение мм-дд-гггг, команда xcopy копирует все файлы-источники, которые новее существующих файлов-результатов. Эта возможность позволяет обновлять только измененные файлы.
/u
Копирует (обновляет) только те файлы-источники, которые уже существуют в каталоге результата.
/i
Если источником является каталог или источник содержит подстановочные знаки и результат не существует, команда xcopy считает, что результат — это имя каталога, и создает новый каталог. Затем xcopy копирует все указанные файлы в новый каталог. По умолчанию команда xcopy запрашивает подтверждение, является ли параметр результат каталогом или файлом.
/s
Копирует каталоги и подкаталоги, если они не пусты. Если параметр /s не задан, команда xcopy будет работать только с одним каталогом.
/e
Копирует все подкаталоги, включая пустые. Параметр /e используется с параметрами /s и /t.
/t
Копирует только структуру подкаталога (т. е. дерево), а не файлы. Для копирования пустых каталогов следует задать ключ /e.
/k
Копирует файлы с атрибутом «только для чтения» с сохранением этого атрибута для скопированных файлов, оригиналы которых имеют этот атрибут. По умолчанию команда xcopy удаляет атрибут «только для чтения».
/r
Копирует файлы с атрибутом «только для чтения».
/h
Копирует системные и скрытые файлы. По умолчанию команда xcopy не копирует системные и скрытые файлы.
/a
Копирует только те файлы, которые имеют установленный атрибут «архивный». При использовании параметра /a атрибут "архивный" у исходных файлов не меняется. Сведения об установке атрибутов с помощью команды attrib
/m
Копирует только те файлы, которые имеют установленный атрибут «архивный». В отличие от параметра /a, параметр /m очищает атрибут «архивный» у скопированных файлов. Сведения об установке атрибутов с помощью команды attrib
/n
Копирует с использованием коротких имен файловой системы NTFS. Параметр /n требуется при копировании из файловой системы NTFS в файловую систему FAT или когда на диске-результате требуется использование соглашения об именах файлов как в файловой системе FAT (8.3). Файлы могут записываться в файловую систему FAT или NTFS.
/o
Копирует сведения о принадлежности файлов и избирательной таблице управления доступом (DACL).
/x
Копирует сведения о параметрах аудита файла и системной таблице управления доступом (SACL) (подразумевается наличие /p).
/exclude:файл1[+[файл2]][+[файл3]]
Определяет список файлов, содежащих строки.
/y
Устраняет выдачу запроса на подтверждение перезаписи существующего конечного файла.
/-y
Выдает запрос на подтверждение перезаписи существующего конечного файла.
/z
Копирует по сети в режиме перезапуска.
/?
Отображает справку в командной строке.

Примечания

  • Использование параметра /v
  • Использование параметра /exclude

    Построчный вывод всех строк в каждом файле. При соответсвтии выведенной строки части пути копируемого файла, он исключается из процесса копирования. Например, если указана строка «\Obj\», исключается все файлы, расположенные в каталоге «Obj». Например, если указана строка «.obj», исключается все файлы с расширением .obj.

  • Использование параметра /z

    Если во время фазы копирования теряется сетевое подключение (например, если сервер переходит автономный режим, разрывая подключение), копирование возобновляется после восстановления подключения. Использование параметра /z команды вызывает также отображение доли (в процентах) завершенной операции копирования для каждого файла.

  • Использование параметра /y в переменной среде COPYCMD.

    Можно применять параметр /y в переменной среде COPYCMD. Эта настройка может быть переопределена использованием параметра /-y в командной строке. По умолчанию если команда copy выполняется не в пакетной программе, при замене требуется подтверждение.

  • Копирование зашифрованных файлов

    При копировании файлов на том, не поддерживающий шифрованную файловую систему (EFS), возникнет ошибка. Следует предварительно расшифровать файлы или копировать их на том, поддерживающий EFS.

  • Добавление файлов

    Чтобы объединить файлы, укажите один файл-результат, но несколько файлов-источников (с помощью подстановочных знаков или формата файл1+файл2+файл3).

  • Значение по умолчанию для результата

    Если параметр результат не задан, xcopy будет копировать файлы в текущий каталог.

  • Указание в качестве результата файла или каталога

    Если параметр результат не содержит существующий каталок или не заканчивается обратной чертой(\), выводится следующее сообщение:

    Что означает destination:
    имя файла или каталога
    (F = файл, D = каталог)?

    Нажмите F, если файл или файлы должны копироваться в файл. Нажмите D, если файл или файлы должны копироваться в каталог.

    Чтобы устранить вывод этого сообщения, используйте параметр /i. В результате чего, команда xcopy предполагает, что результат является каталогом, если источник престаляет собой несколько файлов или каталогов.

  • Использование команды xcopy для установки атрибута «архивный» для файлов результата

    Команда xcopy создает файлы с установленным атрибутом «архивный», независимо от состояния этого атрибута у исходных файлов. Получение дополнительных сведений об атрибутах файлов команды attrib

  • Сравнение команд xcopy и diskcopy

    Команда xcopy должна быть использована вместо diskcopy при копировании файлов и подкаталогов на диск другого формата. Так как команда diskcopy копирует диски по дорожкам, требуется, чтобы исходный диск и диск-результат имели одинаковый формат. Для команды xcopy это требование не нужно. Обычно следует использовать команду xcopy, если только не требуется получить два диска с одинаковыми образами.

  • Коды завершения программы xcopy

    Для анализа кодов завершения, выведенных командой xcopy, используйте параметр уровень_ошибки в командной строке if пакетных программ. В следующей таблице перечислены коды завершения с кратким описанием.

    Код завершения | Описание
    0 | Файлы скопированы без ошибок
    1 | Файлы для копирования не найдены
    2 | Нажата комбинация CTRL+C для остановки команды xcopy
    4 | Возникла ошибка инициализации. Недостаточно места в памяти или на диске, введено неверное имя диска или неверный синтаксис вызова команды
    5 | Диск защищен от записи

Примеры

Чтобы копировать все файлы и подкаталоги (включая пустые подкаталоги) с диска A на диск B, введите:

xcopy a: b: /s /e

Чтобы включить в операцию копирования предыдущего примера системные и скрытые файлы следует использовать параметр /h:

xcopy a: b: /s /e /h

Чтобы обновить файлы в каталоге \Reports файлами из каталога \Rawdata, измененными после 29 декабря 1993 года, введите:

xcopy \rawdata \reports /d:29-12-1993

Чтобы обновить файлы предыдущего примера, уже существующие в каталоге \Reports, независимо от их даты, введите следующую команду:

xcopy \rawdata \reports /u

Чтобы получить списк файлов, которые были бы скопированы в предыдущем примере, следует ввести команду:

xcopy \rawdata \reports /d:29-12-1993 /l > xcopy.out

Список файлов, которые были бы скопированы, находится в файле Xcopy.out.

Чтобы скопировать каталог \Customer и все подкаталоги \\Public\Address на сетевой диск H, сохранить у файлов атрибут «только для чтения», введите команду:

xcopy \customer h:\public\address /s /e /k /p

Чтобы выдать предыдущую команду, убедиться, что команда xcopy создает каталог \Address и устранить вывод сообщение о создании нового каталога, добавьте параметр /i следующим образом:

xcopy \customer h:\public\address /s /e /k /p /i

Для запуска программы xcopy и анализа кодов завершения можно создать пакетный файл и использовать оператор if для обработки кодов завершения в случае возникновения ошибок. Например, следующая пакетная программа использует замещаемые параметры для задания источника xcopy и результата:

@echo off
rem COPYIT.BAT копирует все файлы во всех подкаталогах
rem исходного диска или каталога (%1) на другой диск

rem или в другой каталог (%2)

?? xcopy %1 %2 /s /e

??if errorlevel 4 goto lowmemory
?if errorlevel 2 goto abort
?if errorlevel 0 goto exit

??:lowmemory ?
echo Недостаточно памяти для копирования файлов,
задан недопустимый ?echo диск или ошибка в синтаксисе командной строки.
?goto exit
??
:abort ?
echo Нажата комбинация CTRL+C для остановки копирования.
?goto exit ?
?
:exit

Эта пакетная программа может быть использована для копирования всех файлов каталога C:\Prgmcode и его подкаталогов на диск D следующим образом:

copyit c:\prgmcode d:

Командный интерпретатор подставляет C:\Prgmcode вместо параметра %1 и B вместо параметра %2, затем использует команду xcopy с параметрами /e и /s. Если при выполнении xcopy произошла ошибка, пакетная программа считывает код завершения и переходит на метку, указанную в соответствующей инструкции IF ERRORLEVEL. В результате на экран выводится сообщение о характере ошибки и осуществляется выход из пакетной программы.


Ntsd

Команда Ntsd включена в помощь разработчикам программ, только им следует использовать эту команду.


Ntcmdprompt

Запуск командного интерпретатора Cmd.exe, а не интерпретатора Command.com после запуска резидентной программы (TSR) или после временного выхода из приложения MS-DOS.

Синтаксис

ntcmdprompt

Параметры

/?
Отображает справку в командной строке.

Замечания

  • При работе с Command.com некоторые возможности интерпретатора команд Cmd.exe, такие как отображение списка использованных команд с помощью параметра doskey, не поддерживаются. Если необходимо вызывать командный интерпретатор Cmd.exe после загрузки резидентных программ или из приложения MS-DOS, следует использовать команду ntcmdprompt. Однако, во время работы Cmd.exe резидентная программа может быть недоступна. Команду ntcmdprompt можно поместить в файл Config.nt или в соответствующий ему специальный файл настройки приложения (PIF).

Примеры

Чтобы включить команду ntcmdprompt в файл Config.nt или в другой загрузочный файл, заданный в файле PIF, введите следующее.

ntcmdprompt


Ntbackup

Архивация может выполняться из командной строки или пакетного файла с помощью команды ntbackup и различных параметров командной строки.

Синтаксис

ntbackup backup [systemstate] "@имя_файла_bks" /J {"имя_задания"} [/P {"имя_пула"}] [/G {"идентификатор_guid"}] [/T { "имя_ленты"}] [/N {"носитель"}] [/F {"имя_файла"}] [/D {"описание"}] [/DS {"имя_сервера"}] [/IS {"имя_сервера"}] [/A] [/V:{yes|no}] [/R:{yes|no}] [/L:{f|s|n}] [/M {тип_архива}] [/RS:{yes|no}] [/HC:{on|off}] [/SNAP:{on|off}]

Параметры

systemstate
Указывает, что следует выполнить архивацию данных о состоянии системы. При выборе данного параметра будет установлен обычный или копирующий тип архивации.
@имя_ bks_файла
Указывает имя файла (с расширением bks) со списком файлов для архивации в данном задании архивации. Перед именем файла должен стоять символ @. Этот файл содержит сведения о файлах и папках, подлежащих архивации. Этот файл должен быть создан с помощью программы архивации с графическим интерфейсом.
/J {"имя_задания"}
Указывает имя задания, которое будет упоминаться в файле журнала. Обычно имя задания описывает файлы и папки, подлежащие архивации в данном задании архивации, а также содержит дату и время архивации.
/P {"название_пула"}
Указывает пул носителей, носитель из которого будет использован. Обычно это подпул пула носителей архивации, такой как 4-мм DDS. Если этот подпул был выбран, невозможно использовать параметры командной строки /A, /G, /F или /T.
/G {"идентификатор_guid"}
Добавляет или заменяет данные на ленте. Не следует использовать этот параметр совместно с параметром /P.
/T {"имя_ленты"}
Добавляет или заменяет данные на ленте. Не следует использовать этот параметр совместно с параметром /P.
/N {"носитель"}
Указывает новое имя ленты. Не следует использовать параметр /A совместно с этим параметром.
/F {"имя_файла"}
Путь и имя файла на логическом диске. Совместно с этим параметром не следует использовать следующие параметры: /P /G /T.
/D {"описание"}
Указывает метку для каждого архива.
/DS {"имя_сервера"}
Производит архивацию файла службы каталогов указанного сервера Microsoft Exchange.
/IS {"имя_сервера"}
Производит архивацию файла банка сообщений указанного сервера Microsoft Exchange.
/A
Производит архивацию с добавлением в архив. Совместно с этим параметром следует использовать параметр /G или /T. Не следует использовать этот параметр совместно с параметром /P.
/V:{yes|no}
Проверяет данные после архивации.
/R:{yes|no}
Ограничивает доступ к этой ленте одним владельцем или членами группы «Администраторы».
/L:{f|s|n}
Указывает тип файла журнала: f=полный, s=сокращенный, n=нет (файл журнала не создается).
/M {тип_архива}
Указывает тип архива. Этот параметр должен иметь одно из следующих значений: normal, copy, differential, incremental или daily.
/RS:{yes|no}
Производит архивацию перемещенных данных на съемных носителях. Параметр командной строки /RS не требуется для архивации локальной базы данных съемных носителей (эта база данных содержит заместители мест файлов удаленного хранилища). При архивации папки %systemroot% программа архивации автоматически архивирует и базу данных съемных носителей.
/HC:{on|off}
Использует при возможности аппаратное сжатие.
/SNAP:{on|off}
Указывает, является (on) или не является (off) архив снимком состояния тома.
/M {тип_архива}
Указывает тип архива. Этот параметр должен иметь одно из следующих значений: normal, copy, differential, incremental или daily.
/?
Отображает справку в командной строке.

Замечания

  • Восстановление файлов из командной строки с помощью команды ntbackup невозможно.
  • Если следующие параметры командной строки не заданы, будут использованы соответствующие настройки программы архивации с графическим интерфейсом: /V /R /L /M /RS /HC. Например, если в диалоговом окне Параметры программы архивации включено сжатие при архивации, при отсутствии параметра /HC в командной строке данные будут сжиматься. Но если в командной строке задан параметр /HC:off, он заменяет значение параметра диалогового окна Параметры, и сжатие не используется.
  • Если на данном компьютере запущены службы мультимедиа Windows и требуется выполнить архивацию файлов этих служб, ознакомьтесь с разделом о выполнении архивации служб Windows Media электронной документации по службам Windows Media. Для архивации или восстановления файлов служб Windows Media следуйте инструкциям, приведенным в электронной документации по службам Windows Media.
  • Архивация данных о состоянии системы возможна только для локального компьютера. Нельзя архивировать данные о состоянии системы для удаленного компьютера.
  • Если управление носителями осуществляется службой «Съемные ЗУ» или для сохранения данных используется внешнее хранилище, следует регулярно архивировать файлы, находящиеся в следующих папках:

    системный_корневой_каталог\System32\Ntmsdata

    системный_корневой_каталог\System32\Remotestorage

    Это будет гарантировать возможность восстановления всех данных, сохраненных во внешнем хранилище и на съемном ЗУ.

Примеры

Пример 1

В этом примере создается обычный архив — «Задание 1» удаленного общего ресурса \\iggy-multi\c$. Для этого ленте из пула носителей «Backup» присваивается имя «Созданный из командной строки архив 1». Заданию архивации также будет дано описание «Архивация из командной строки». Архив будет проверен сразу после завершения архивации, доступ к нему будет предоставляться не только владельцу/администратору, будет вестись сокращенный журнал, архивация данных из внешнего хранилища выполняться не будет, а аппаратное сжатие будет включено.

ntbackup backup \\iggy-multi\c$ /m normal /j "Задание 1" /p "Backup" /n "Созданный из командной строки архив 1" /d "Архивация из командной строки" /v:yes /r:no /l:s /rs:no /hc:on

Пример 2

В этом примере создается копирующий архив — «Задание 2» локального диска D:\. Архивируемые файлы и папки будут добавлены на ленту «Созданный из командной строки архив 1». Все другие параметры будут взяты из настроек программы архивации.

ntbackup backup d:\ /j "Задание 2" /a /t "Созданный из командной строки архив 1" /m copy

Пример 3

В этом примере создается архив того типа, который указан в программе архивации. При этом будет использован файл со списком файлов для архивации Commandline.bks, расположенный в папке C:\Program Files\Windows NT\ntbackup\data\. Задание архивации будет названо «Задание 3», а название ленты «Созданный из командной строки архив 1» будет заменено на «Созданный из командной строки архив 2».

ntbackup backup "@C:\Program Files\Windows NT\ntbackup\data\commandline.bks" /j "Задание 3" /t "Созданный из командной строки архив 1" /n "Созданный из командной строки архив 2"

Пример 4

Следующие примеры иллюстрируют выполнение архивации из командной строки. Все три примера используют тип архива, параметры проверки, уровень ведения журнала, аппаратное сжатие и другие параметры, заданные в программе архивации. В первом примере выполняется архивация ресурса \\iggy-multi\d$ в файл D:\Backup.bkf. Во втором примере архивация тех же данных в этот же файл. В третьем примере имеющийся архив заменяется новым архивом, содержащим те же данные. Во всех трех примерах букву диска можно заменить полным именем UNC (то есть, вместо файла архива d:\backup.bkf можно задать файл \\iggy-multi\d$\backup.bkf).

ntbackup backup \\iggy-multi\d$ /j "Созданный из командной строки архив 4" /f "D:\backup.bkf"

ntbackup backup \\iggy-multi\d$ /j "Созданный из командной строки архив 5" /f "D:\backup.bkf" /a

ntbackup backup \\iggy-multi\d$ /j "Созданный из командной строки архив 6" /f "D:\backup.bkf"


Nlsfunc

Загрузка данных для конкретной страны/области.

Синтаксис

nlsfunc [[диск:][путь][имя_файла]]

Параметры

[[диск:][путь][имя_файла]]
Указание файла, содержащего данные для конкретной страны/области.
/?
Отображение справки в командной строке.


Nbtstat

Служит для отображения статистики протокола NetBIOS over TCP/IP (NetBT), таблиц имен NetBIOS для локального и удаленного компьютеров, а также кэша имен NetBIOS. Команда Nbtstat позволяет обновить кэш имен NetBIOS и имена, зарегистрированные в службе имен Интернета Windows (WINS). Запущенная без параметров, команда nbtstat выводит справку.

Синтаксис

nbtstat
 [-a удаленное_имя]
 [-A IP-адрес]
 [-c]
 [-n]
 [-r]
 [-R]
 [-RR]
 [-s]
 [-S]
 [интервал]

Параметры

-a удаленное_имя
Отображение таблицы имен NetBIOS удаленного компьютера, где удаленное_имя является именем NetBIOS удаленного компьютера. Таблица имен NetBIOS является списком имен NetBIOS, соответствующих приложениям NetBIOS, работающим на данном компьютере.
-A IP-адрес
Отображение таблицы имен NetBIOS удаленного компьютера, заданного IP-адресом (десятичные числа, разделенные точками).
-c
Отображение содержимого кэша имен NetBIOS, таблицы имен NetBIOS и их разрешенных IP-адресов.
-n
Отображение таблицы имен NetBIOS локального компьютера. Состояние Зарегистрирован означает, что это имя зарегистрировано на сервере WINS или в качестве широковещательного адреса.
-r
Отображение статистики разрешения имен NetBIOS. На компьютере Windows XP, настроенном для использования WINS, этот параметр возвращает количество имен, разрешенных и зарегистрированных для широковещательной рассылки или WINS.
-R
Очистка содержимого кэша имен NetBIOS и перезагрузка записей #PRE из файла Lmhosts.
-RR
Освобождение и обновление имен NetBIOS для локального компьютера, зарегистрированного на серверах WINS.
-s
Отображение сеансов клиента и сервера NetBIOS с попыткой преобразования конечного IP-адреса в имя.
-S
Вывод сведений о работе сервера и клиента NetBIOS; удаленные компьютеры выводятся только по IP-адресам.
интервал
Обновление выбранной статистики на экране через промежутки времени, заданные значением интервал. Нажатие клавиш CTRL+C останавливает обновление статистики. Если этот параметр не задан, команда nbtstat выводит сведения о текущей конфигурации один раз.
/?
Отображение справки в командной строке.

Заметки

  • При задании параметров команды nbtstat учитывается регистр символов.
  • В следующей таблице приведены заголовки столбцов, отображаемые программой nbtstat.
    Заголовок | Описание
    Ввод | Число полученных байт.
    Вывод | Число отправленных байт.
    Вид | Направление передачи от локального компьютера (Исх) или от удаленного компьютера (Вхд).
    Время жизни | Время, оставшееся до сброса элемента кэша таблицы имен.
    Локальное имя | Локальное имя NetBIOS, соответствующее данному подключению.
    Удаленный узел | Имя или IP-адрес удаленного компьютера.
    <03> | Последний байт имени NetBIOS, преобразованный в шестнадцатеричную форму. Каждое имя NetBIOS может иметь длину 16 знаков. Последний байт часто имеет специальное значение, так как одно имя может встречаться несколько раз на одном компьютере, различаясь только последним байтом. Например, код <20> представляет собой пробел.
    Тип | Тим имени. Имя может быть уникальным именем или именем группы.
    Состояние | «Зарегистрирован» (служба NetBIOS работает на удаленном компьютере) или «Конфликт» (в службе уже зарегистрировано такое же имя компьютера).
    Состояние | Состояние подключений NetBIOS.
  • В следующей таблице приведены возможные состояния подключения NetBIOS.
    Состояние | Описание
    Подключен | Сеансовое подключение установлено.
    Назначен | Конечная точка подключения создана и связана с IP-адресом.
    Ожидание | Конечная точка доступна для входящих подключений.
    Простаивает | Конечная точка создана, но подключение не получено.
    Подключается | Сеанс в состоянии подключения, сопоставление имени и IP адреса для точки назначения определено.
    Прием | Запрос на входящее подключение принят, подключение будет установлено.
    Повторное подключение | Повторная попытка установки подключения (после первой неудачной попытки).
    Исходящий | Сеанс находится в процессе подключения, создается подключение TCP.
    Входящий | Сеанс находится в процессе подключения.
    Отключение | Сеанс находится в процессе отключения.
    Отключен | Локальный компьютер отправил запрос на отключение и ожидает подтверждения от удаленной системы.
  • Эта команда доступна, только если в свойствах сетевого адаптера в объекте Сетевые подключения в качестве компонента установлен протокол Интернета (TCP/IP).

Примеры

Чтобы вывести таблицу имен удаленного компьютера, имеющего имя NetBIOS CORP07, введите:

nbtstat -a CORP07

Чтобы вывести таблицу имен NetBIOS удаленного компьютера, имеющего IP-адрес 10.0.0.99, введите:

nbtstat -A 10.0.0.99

Чтобы вывести таблицу имен локального компьютера, введите:

nbtstat -n

Чтобы вывести содержимое кэша имен NetBIOS локального компьютера, введите:

nbtstat -c

Чтобы очистить кэш имен NetBIOS и перезагрузить записи #PRE из локального файла Lmhosts, введите:

nbtstat -R

Чтобы освободить имена NetBIOS, зарегистрированные на сервере WINS, и снова зарегистрировать их, введите:

nbtstat -RR

Чтобы просмотреть статистику сеанса NetBIOS по IP-адресу с обновлением каждые пять секунд, введите:

nbtstat -S 5

Условные обозначения форматирования

Формат | Значение
Курсив | Сведения, вводимые пользователем
Полужирный | Элементы, вводимые без изменений
Многоточие (...) | Параметр может быть введен в командной строке несколько раз
В квадратных скобках ([]) | Необязательные элементы
В фигурых скобках ({}); варианты, разделенные вертикальной линией (|), пример: {even|odd} | Набор вариантов, из которых необходимо выбрать один
Шрифт Courier | Выходные данные программы


Netstat

Отображение активных подключений TCP, портов, прослушиваемых компьютером, статистики Ethernet, таблицы маршрутизации IP, статистики IPv4 (для протоколов IP, ICMP, TCP и UDP) и IPv6 (для протоколов IPv6, ICMPv6, TCP через IPv6 и UDP через IPv6). Запущенная без параметров, команда nbtstat отображает подключения TCP.

Синтаксис

netstat
 [-a]
 [-e]
 [-n]
 [-o]
 [-p протокол]
 [-r]
 [-s]
 [интервал]

Параметры

-a
Вывод всех активных подключений TCP и прослушиваемых компьютером портов TCP и UDP.
-e
Вывод статистики Ethernet, например количества отправленных и принятых байтов и пакетов. Этот параметр может комбинироваться с ключом -s.
-n
Вывод активных подключений TCP с отображением адресов и номеров портов в числовом формате без попыток определения имен.
-o
вывод активных подключений TCP и включение кода процесса (PID) для каждого подключения. Код процесса позволяет найти приложение на вкладке Процессы диспетчера задач Windows. Этот параметр может комбинироваться с ключами -a, -n и -p.
-p протокол
Вывод подключений для протокола, указанного параметром протокол. В этом случае параметр протокол может принимать значения tcp, udp, tcpv6 или udpv6. Если данный параметр используется с ключом -s для вывода статистики по протоколу, параметр протокол может иметь значение tcp, udp, icmp, ip, tcpv6, udpv6, icmpv6 или ipv6.
-s
Вывод статистики по протоколу. По умолчанию выводится статистика для протоколов TCP, UDP, ICMP и IP. Если установлен протокол IPv6 для Windows XP, отображается статистика для протоколов TCP через IPv6, UDP через IPv6, ICMPv6 и IPv6. Параметр -p может использоваться для указания набора протоколов.
-r
Вывод содержимого таблицы маршрутизации IP. Эта команда эквивалентна команде route print.
интервал
Обновление выбранных данных с интервалом, определенным параметром интервал (в секундах). Нажатие клавиш CTRL+C останавливает обновление. Если этот параметр пропущен, netstat выводит выбранные данные только один раз.
/?
Отображение справки в командной строке.

Примечания

  • Параметрам, используемым с данной командой, должен предшествовать дефис (-), а не косая черта (/).
  • Команда Netstat выводит статистику для следующих объектов.
    • Протокол

      Имя протокола (TCP или UDP).

    • Локальные адреса

      IP-адрес локального компьютера и номер используемого порта. Имя локального компьютера, соответствующее IP-адресу и имени порта, выводится только в том случае, если не указан параметр -n. Если порт не назначен, вместо номера порта будет выведена звездочка (*).

    • Внешние адреса

      IP-адрес и номер порта удаленного компьютера, подключенного к данному сокету. Имена, соответствующие IP-адресу и порту, выводятся только в том случае, если не указан параметр -n. Если порт не назначен, вместо номера порта будет выведена звездочка (*).

    • (Состояние)

      Указание состояния подключения TCP. Возможные значения:

      CLOSE_WAIT

      CLOSED

      ESTABLISHED

      FIN_WAIT_1

      FIN_WAIT_2

      LAST_ACK

      LISTEN

      SYN_RECEIVED

      SYN_SEND

      TIMED_WAIT

  • Эта команда доступна, только если в свойствах сетевого адаптера в объекте Сетевые подключения в качестве компонента установлен протокол Интернета (TCP/IP).

Примеры

Для вывода статистики Ethernet и статистики по всем протоколам введите следующую команду:

netstat -e -s

Для вывода статистики только по протоколам TCP и UDP введите следующую команду:

netstat -s -p tcp udp

Для вывода активных подключений TCP и кодов процессов каждые 5 секунд введите следующую команду:

nbtstat -o 5

Для вывода активных подключений TCP и кодов процессов каждые с использованием числового формата введите следующую команду:

nbtstat -n -o

Условные обозначения форматирования

Формат | Значение
Курсив | Сведения, вводимые пользователем
Полужирный | Элементы, вводимые без изменений
Многоточие (...) | Параметр может быть введен в командной строке несколько раз
В квадратных скобках ([]) | Необязательные элементы
В фигурых скобках ({}); варианты, разделенные вертикальной линией (|), пример: {even|odd} | Набор вариантов, из которых необходимо выбрать один
Шрифт Courier | Выходные данные программы


Query process

Отображает сведения о процессах, запущенных на сервере терминалов. Эту команду можно использовать для нахождения программ, запущенных выбранным пользователем, а также для нахождения пользователей, запустивших данную программу.

Синтаксис

query process
 [{ *|код_процесса|имя_пользователя|имя_сеанса|/id:nn|имя_программы}]
 [/server:имя_сервера]
 [/system]

Параметры

*
Отображает список процессов для всех сеансов.
код_процесса
Указывает процесс, заданный этим цифровым кодом.
имя_пользователя
Указывает имя пользователя, процессы которого нужно отобразить в списке.
имя_сеанса
Указывает имя сеанса, процессы которого нужно отобразить в списке.
/id:nn
Указывает код сеанса, процессы которого нужно отобразить в списке.
имя_программы
Указывает имя программы, процессы которой запрашиваются. Для этого необходимо иметь расширение .exe.
/server:имя_сервера
Определяет процессы на вибранном сервере терминалов. Если сервер терминалов не задан, то по умолчанию выбирается текущий.
/system
Отображает текущие сведения о системных процессах. Если нет необходимости в отображении сведений о системных процессах, то этот параметр не используется.
/?
Отображает справку в командной строке.

Примечания

  • Для выполнения команды query process администратор должен иметь разрешение на «Полный доступ».
  • Если не задать ни один из параметров имя_пользователя, имя_сеанса, /id:код_сеанса, имя_программы, *, то команда query process отображает только процессы, принадлежащие текущему пользователю.
  • Если задан сеанс, то он должен быть активным. Для задания процесса можно использовать подстановочные символы.
  • С помощью команды query process можно получить следующие сведения:
    • сведения о пользователе, который владеет процессом;
    • сведения о сеансе, который владеет процессом;
    • сведения о коде сеанса;
    • сведения об имени процесса;
    • сведения о состоянии процесса;
    • сведения о коде процесса.
  • При отображении сведений командой query process выводится символ (>) перед каждым процессом, принадлежащим текущему пользователю.

Условные обозначения форматирования

Формат | Значение
Курсив | Сведения, вводимые пользователем
Полужирный | Элементы, вводимые без изменений
Многоточие (...) | Параметр может быть введен в командной строке несколько раз
В квадратных скобках ([]) | Необязательные элементы
В фигурых скобках ({}); варианты, разделенные вертикальной линией (|), пример: {even|odd} | Набор вариантов, из которых необходимо выбрать один
Шрифт Courier | Выходные данные программы


Query session

Отображает сведения о сеансах на сервере терминалов. Этот список включает не только сведения об активных сеансах, но и о других сеансах, запущенных на сервере.

Синтаксис

query session
 [{имя_сеанса|имя_пользователя|код_сеанса}]
 [/server:имя_сервера]
 [/mode]
 [/flow]
 [/connect]
 [/counter]

Параметры

имя_сеанса
Отображает имя запрашиваемого сеанса.
имя_пользователя
Отображает имя пользователя, сеанс которого необходимо запросить.
код_сеанса
Отображает код запрашиваемого сеанса.
/server:имя_сервера
Задает сервер терминалов для запроса. По умолчанию — это текущий сервер.
/mode
Отображает текущие параметры линии.
/flow
Отображает текущие параметры управления потоком.
/connect
Отображает текущие параметры подключения.
/counter
Отображает текущие сведения о счетчиках, включая общее число созданных сеансов, отключений и подключений заново.
/?
Отображает справку в командной строке.

Примечания

  • Пользователь всегда может запросить сеанс, к которому он подключен. Чтобы запросить другие сеансы, пользователь должен иметь разрешение на запрос сведений.
  • Если сеанс не задан с помощью параметров имя_сеанса, имя_пользоателя, код_сеанса или query session, то отображаются сведения о всех активных сеансах в системе.
  • При отображении сведений командой query process символ (>) выводится перед текущим сеансом.

Примеры

Чтобы отобразить сведения о всех активных сеансах на сервере SERVER2, введите:

query session /server:SERVER2

Чтобы отобразить сведения об активном сеансе MODEM02, введите:

query session MODEM02

После выполнения команды query session на экран будут выведены следующие сведения:

C:\>query session
 СЕАНС   ПОЛЬЗОВАТЕЛЬ       ID СТАТУС  ТИП   УСТРОЙСТВО
>console        administrator   0 active wdcon
 rdp-tcp#1      client1         1 active wdtshare
 rdp-tcp                        2 listen wdtshare
                                4 idle
                                5 idle

Символом (>) отмечен текущий сеанс. В столбце СЕАНС выводится имя, назначенное сеансу. В столбце ПОЛЬЗОВАТЕЛЬ отображается имя пользователя, подключенного к сеансу. В столбце СТАТУС отображаются сведения о текущем состоянии сеанса. В столбце ТИП отображаются сведения о типе сеанса. В столбце УСТРОЙСТВО, который не отображается для сеансов консоли или сетевых сеансов, собраны сведения об именах устройств, назначенные сеансу. Комментарии, следующие за сведениями о сеансе, появляются из профиля сеанса.

Любые сеансы, исходное состояние которых настроено как «Отключено», не отображаются в списке запроса сеансов, до своего разрешения.

Условные обозначения форматирования

Формат | Значение
Курсив | Сведения, вводимые пользователем
Полужирный | Элементы, вводимые без изменений
Многоточие (...) | Параметр может быть введен в командной строке несколько раз
В квадратных скобках ([]) | Необязательные элементы
В фигурых скобках ({}); варианты, разделенные вертикальной линией (|), пример: {even|odd} | Набор вариантов, из которых необходимо выбрать один
Шрифт Courier | Выходные данные программы


Query termserver

Отображает список всех серверов терминалов в сети.

Синтаксис

query termserver
 [имя_сервера]
 [/domain:домен]
 [/address]
 [/continue]

Параметры

имя_сервера
Задает имя сервера терминалов.
/domain:домен
Задает домен для запроса серверов терминалов. Если запрашивается домен, в котором пользователь работает в данный момент, то нет необходимости задавать его дополнительно.
/адрес
Отображает адреса сети и узлов для каждого сервера.
/continue
Запрещает остановку после отображения каждого экрана со сведениями.
/?
Отображает справку в командной строке.

Примечания

  • Команда query termserver ищет в сети все серверы терминалов и сообщает о них следующие сведения:
    • имя сервера;
    • сеть (и адрес узла, если используется параметр /address).

Примеры

Чтобы отобразить сведения о всех серверах терминалов в сети, введите:

query termserver

Чтобы отобразить сведения о сервере терминалов с именем server3, введите:

query termserver server3

Чтобы отобразить сведения о всех серверах терминалов в домене SYSTEM, введите:

query termserver /domain:system

Чтобы отобразить адреса сети и узла для сервера терминалов с именем server3, введите:

query termserver server3 /address

Условные обозначения форматирования

Формат | Значение
Курсив | Сведения, вводимые пользователем
Полужирный | Элементы, вводимые без изменений
Многоточие (...) | Параметр может быть введен в командной строке несколько раз
В квадратных скобках ([]) | Необязательные элементы
В фигурых скобках ({}); варианты, разделенные вертикальной линией (|), пример: {even|odd} | Набор вариантов, из которых необходимо выбрать один
Шрифт Courier | Выходные данные программы


Query user

Отображает сведения о пользовательских сеансах на сервере терминалов.

Синтаксис

query user [{имя_пользователя|имя_сеанса|код_сеанса}] [/server:имя_сервера]

Параметры

имя_пользователя
Задает запрашиваемое имя пользователя для входа.
имя_сеанса
Отображает имя запрашиваемого сеанса.
код_сеанса
Отображает код запрашиваемого сеанса.
/server:имя_сервера
Отображает запрашиваемый сервер терминалов. В противном случае используется текущий сервер терминалов.
/?
Отображает справку в командной строке.

Примечания

  • Эта команда может использоваться для выяснения того, вошел ли определенный пользователь на заданный сервер терминалов. С помощью команды query user можно получить следующие сведения:
    • имя пользователя;
    • имя сеанса на сервере терминалов;
    • код сеанса;
    • состояние сеанса (активно или отключено);
    • время простоя сеанса (количество минут, прошедшее с последнего нажатия клавиши клавиатуры или движения указателя мыши);
    • дату и время входа пользователя.
  • Для использования команды query user необходимо иметь разрешение «Полный доступ» или специальное разрешение на запрос информации.
  • При использовании команды query user без задания имени пользователя, имени сеанса или кода сеанса на экран выводится список всех пользователей, которые вошли на сервер. Кроме того, можно использовать команду query session для отображения списка всех сеансов на сервере.
  • При отображении сведений командой query user символ (>) выводится перед текущим сеансом.
  • Параметр /server необходимо использовать только при вводе команды query user с удаленного сервера.

Примеры

Чтобы отобразить сведения о всех пользователях, которые вошли в систему, введите:

query user

Чтобы отобразить сведения о пользователе USER1 на сервере SERVER1, введите:

query user USER1 /server:SERVER1

Условные обозначения форматирования

Формат | Значение
Курсив | Сведения, вводимые пользователем
Полужирный | Элементы, вводимые без изменений
Многоточие (...) | Параметр может быть введен в командной строке несколько раз
В квадратных скобках ([]) | Необязательные элементы
В фигурых скобках ({}); варианты, разделенные вертикальной линией (|), пример: {even|odd} | Набор вариантов, из которых необходимо выбрать один
Шрифт Courier | Выходные данные программы